Изменения в версиях

  • Версия 11.1
  • Версия 11.0
  • Версия 10.3
  • Версия 10.2
  • Версия 10.1
  • Версия 10.0
  • Версия 9.8
  • Версия 9.6
  • Версия 9.5
  • Версия 9.4
  • Версия 9.3
  • Версия 9.2
  • Версия 9.1
  • Версия 8.13
  • Версия 8.12
  • Версия 8.11
  • Версия 8.9
  • Версия 8.8
  • Версия 8.5
  • Версия 8.4
  • Версия 8.3.1
  • Версия 8.2

Руководство пользователя QUIK © ARQA Technologies / www.arqatech.com/ru/products/quik/


Что нового

Версия 11.1

  1. Изменен подход к определению краткого наименования и ISIN для инструментов с одинаковыми кодами на разных биржах в таблице «Позиции по инструментам». Теперь их отображение зависит от фирмы и торгового счета, на который были загружены позиции.
  2. Оптимизированы расход памяти и быстродействие при расчете Клиентского портфеля.
  3. Добавлен новый расширенный статус заявки для срочного рынка «Заявка снята по причине кросс-сделки».
  4. В Таблицу заявок добавлено новое поле «Причина снятия».

Версия 11.0

  1. Поддержана работа с новым режимом «РЕПО с открытой датой» на Фондовом рынке Московской Биржи:
    • На формы ввода заявок РЕПО и РЕПО с ЦК добавлен признак «С открытой датой»;
    • В контекстном меню таблицы «Сделки для исполнения» поддержан ввод поручения на закрытие сделки РЕПО с открытой датой.
  2. Пользователи с правами менеджера при подключении к серверу теперь могут получать позиции только по клиенту, который выбран в глобальном фильтре, что значительно ускоряет процесс загрузки данных.
  3. Оптимизирована рассылка позиций по денежным средствам и инструментам при переподключении к серверу QUIK пользователя с правами менеджера.
  4. При открытии формы ввода адресной заявки по безадресной котировке добавлена возможность выбора класса, в котором будет выставлена заявка.
    Выбор класса доступен только при использовании «Специализированного» режима отображения.
  5. Добавлены новые параметры в следующие таблицы:
    • В таблицу «Заявки» добавлены параметры «Внешнее количество», «Орг-я трейдера»;
    • В таблицу «Сделки для исполнения» добавлены параметры «Причина отмены», «Тип сделки депозита», «Стоимость выкупа РЕПО с открытой датой в день T+1», «День Т+1 для сделок РЕПО с Открытой датой», «Отчет на закрытие сделки РЕПО с Открытой датой», «Статус РЕПО с открытой датой»;
    • В Таблицу заявок на внебиржевые сделки добавлены параметры «Причина отклонения», «Стоимость выкупа РЕПО с открытой датой в день T+1», «День Т+1 для сделок РЕПО с Открытой датой», «РЕПО с открытой датой»;
    • В таблицу «Торговые счета» добавлен параметр «Рынок депозитов»;
    • В Таблицу сделок добавлены параметры «Тип сделки депозита», «Стоимость выкупа РЕПО с открытой датой в день T+1», «День Т+1 для сделок РЕПО с Открытой датой», «РЕПО с открытой датой»;
    • В Таблицу обезличенных сделок и таблицу «Информация по кодам расчетов по инструментам» добавлен параметр «РЕПО с открытой датой»;
    • В таблицы «Позиции по деньгам» и «Позиции по инструментам» добавлен параметр «Наименование фирмы».
  6. В таблице «Отчеты по сделкам для исполнения» в параметре «Тип отчета» добавлено новое значение «Закрытие».

Версия 10.3

  1. Изменена логика работы с формами ввода заявок и адресных заявок. Окно формы ввода заявки теперь не будет закрываться, если в результате обработки транзакции была получена ошибка. Это позволит, при необходимости, скорректировать параметры транзакции и отправить ее снова.
  2. Автоматическая подстановка торгового счета в форму ввода заявки выполняется с учетом настроек, которые ограничивают список доступных торговых счетов для клиента на стороне сервера QUIK.
  3. Поддержана возможность подключения к серверу QUIK при использовании адреса в формате IPv6.

Версия 10.2

  1. Изменения при работе с формами ввода заявок:
    • Добавлена настройка «Использовать немодальные формы ввода», которая изменяет принцип работы с формами ввода заявок и адресных заявок. При включении данной настройки появляется возможность открытия нескольких форм ввода, при этом данные окна можно выносить за пределы основного окна программы.
    • Добавлена настройка «Отображать поверх всех окон», которая позволяет открывать и отображать немодальные формы ввода заявок поверх остальных окон программы.
  2. Изменен дизайн окна настройки фильтра по параметру в таблицах:

  3. В окне редактирования таблиц добавлены кнопки [image] и [image] для быстрого перемещения выбранных параметров в начало и конец списка.
  4. Добавлена настройка «Связывать вынесенные окна», позволяющая использовать режим связанных окон для таблиц и окон, вынесенных за пределы основного окна программы.
  5. Изменен формат диалогового окна в случае аварийного завершения работы Рабочего места QUIK. При возникновении данной ситуации у пользователя появится возможность сформировать отчет об ошибке, который можно отправить по электронной почте на адрес quiksupport@arqatech.com, либо перезапустить Рабочее место QUIK.
  6. В таблице сделок поддержано отображение новых типов сделок на срочном рынке Московской Биржи:
    • Техническая (предварительная) сделка с провайдером ликвидности;
    • Сделка вследствие добровольного выхода из вечного фьючерса (на основании поданной заявки);
    • Сделка вследствие принудительного выхода из вечного фьючерса (реализация неудовлетворенного спроса);
    • Сделка в связанном инструменте вследствие выхода из вечного фьючерса.
  7. В таблицу «Текущие торги» добавлен параметр «Тип исполнения опциона», в котором транслируется тип опционов срочного рынка Московской Биржи.
  8. Локальные оповещения, для которых не удалось определить инструмент, отображаются в окне оповещений со статусом «Не активно». Также в окне редактирования таблицы оповещений добавлен фильтр «Неактивные», который позволяет выключить или включить отображение оповещений такого типа.
  9. Изменения в работе с таблицей «Доска опционов»:
    • В таблицу можно добавлять опционы на акции;
    • Добавлена возможность экспорта таблицы по ODBC.
  10. В таблице «Книга заявок на размещение» добавлена возможность отмены нескольких выделенных заявок.
  11. Добавлена настройка «Запрашивать подтверждение при загрузке позиций», при включении которой загрузка позиций из файла выполняется только после подтверждения операции в диалоговом окне.
  12. В окно с результатами поиска инструмента добавлен параметр «Тип сложного финансового продукта».

Версия 10.1

Актуализирован расчет покупательной способности с учетом обновленных ставок комиссий Фондового рынка Московской Биржи.

Версия 10.0

  1. Добавлена возможность установки валюты цены приобретения при загрузке позиции по инструменту.
  2. Изменены формы установки позиций по денежным средствам и по инструментам.

  3. Добавлена настройка «Отображать в портфеле клиентов», позволяющая оптимизировать работу терминала при наличии большого количества строк в таблице «Клиентский портфель». При помощи настройки можно отфильтровать строки, которые будут отображаться в таблице.
  4. Новые параметры в таблицах:
    • В таблицу «Текущие торги» добавлены параметры «ID аукциона» и «Эмитент».
    • В таблицы заявок, сделок, обезличенных сделок, адресных заявок и сделок для исполнения добавлен параметр «Индикатор».
    • В таблицу сделок для исполнения добавлены параметры «Дата изменения индикатора» и «Значение индикатора».
    • В таблицы заявок, адресных заявок и сделок добавлен параметр «Внешняя ссылка».
    • В таблицу «Расчетные коды» добавлен параметр «Счет типа “С”».
    • В таблицу транзакций добавлены следующие параметры: «Время выполнения (мкс)», «Номер заявки2», «Операция2», «Цена2», «Количество2», «Остаток2», «Фирма2», «Счет2», «Код клиента2», «Код инструмента2», «Комментарий2», «Код биржи2».
  5. Параметр «Валюта цены» в таблице заявок переименован в «Валюта заявки».
  6. Расширен формат выходного файла (*.lco) при использовании динамической корректировки позиций из файла. Добавлены параметры «RESULT_CODE» и «RESULT_DESC» для анализа результата выполнения операции.
  7. Изменения в QLUA:
    • Информация о ногах инструмента теперь передается вместе с описанием инструмента в виде вложенной таблицы «legs». Параметры «buy_leg_classcode», «buy_leg_seccode», «sell_leg_classcode», «sell_leg_seccode», которые ранее могли использоваться для получения данной информации, теперь недоступны.
    • Информация об ответе на транзакцию была расширена параметрами «sent_local_time», «got_local_time», «order_flags», а также таблицей «orders», которая будет добавляться и содержать вложенные таблицы вида «order_» при работе с транзакциями по перестановке двух и более заявок.
  8. Изменен подход к сохранению таблиц «Текущие торги» и «Таблица истории значений параметров» при выборе пункта контекстного меню «Сохранить в файл». Начиная с версии 10.0.0 в файл будет сохраняться не фиксированный набор параметров, а непосредственно параметры, которые добавлены и отображаются в сохраняемой таблице.

Версия 9.8

    Для пользователей Сервиса QDealing реализована возможность установить перечень контрагентов, которым будет разрешено просматривать безадресные котировки. Информация о настроенных разрешениях будет доступна в таблице «Разрешения на получение РПС-котировок».

Версия 9.6

    Добавлена возможность выбора класса исполнения безадресной заявки для РПС и РЕПО. Поведение управляется новой настройкой в секции [QUOTES_EXECUTION].

Версия 9.5

  1. Поддержан учет позиций по премиальным опционам на акции при расчете показателей клиентского портфеля.
  2. Реализован функционал записи данных в ОЗУ в случае, если на момент запуска Рабочего места и инициализации файловых хранилищ терминала возникла проблема с доступом к одному из файлов с расширением DAT. При возникновении такой ситуации, будет отображаться системное сообщение вида: «Не удалось получить доступ к файлу <название файла designtimesp=322>.dat, возможно недостаточно места на диске. Данные будут сохраняться в оперативной памяти».

    При завершении работы терминала будет выполняться попытка записи данных из ОЗУ в файловое хранилище.

  3. Теперь к таблице «РПС котировки» может быть применен Режим связанных окон, таблицы связываются с данными основной Таблицы текущих торгов.

Версия 9.4

  1. Оптимизировано построение клиентского портфеля для Рабочих мест с менеджерскими правами, использующих Терминальный модуль риск-менеджера «CoLibri». В окне редактирования таблицы «Клиентский портфель» добавлена настройка «В том числе для переноса позиций», регулирующая трансляцию информации по клиентам без коротких позиций в модуль «CoLibri».
  2. Поддержана работа в режиме сервера терминалов.
  3. Расчет доходности облигаций фондового рынка Московской биржи на форме ввода заявки. Данный функционал требует наличия Модуля хранения и распространения справочников версии 1.2.0 или выше в конфигурации брокера.
  4. Добавлено значение параметра «Торговая сессия» в таблицах «Заявки» и «Сделки». Новое значение – «Утренняя сессия» относится к утренней торговой сессии фондового рынка Московской биржи.
  5. В таблицу «Текущие торги» добавлен параметр «Доступность в утренней сессии», который является признаком допуска инструмента к торгам в утреннюю сессию на фондовом рынке Московской биржи.
  6. Оптимизирована трансляция на терминал новых инструментов, появившихся в течение торговой сессии.
  7. На форме ввода алгоритмической заявки типа «Айсберг» добавлена возможность указать рабочий интервал, данный функционал появился в версии 5.2 Модуля алгоритмической торговли.
  8. Повторная запись результата корректировки, пропущенного из-за ошибки доступа к .lco файлу.
  9. Поддержка полного неттинга для расчета маржинальных параметров для клиентов с типом кредитования «МД+».
  10. Добавлена возможность получать значение параметра «Валюта цены приобретения» таблицы позиций по инструментам при помощи Lua. В Lua таблицу depo_limits добавлен параметр «wa_price_currency».

Версия 9.3

  1. На горизонтальной линии в режиме «Магнит» теперь отображается центральная точка, которая притягивается к ценам ближайших свечей.
  2. Для таблицы текущих торгов добавлена функция «Диаграмма доходности облигаций», позволяющая построить диаграмму доходности по всем инструментам из таблицы с типом «Облигация».
  3. После первичной установки QUIK из дистрибутива и запуске LUA скриптов по умолчанию теперь используется версия LUA 5.4.1.
  4. На форме ввода заявки вида РЕПО-М добавлен учет кратности лота при расчете количества.

Версия 9.2

  1. Реализована трансляция даты расчётов для таблицы «Позиций по деньгам».
  2. Поддержан расчёт параметра «Расчётная сумма» для акций в таблицах «Таблица заявок» и «Таблица сделок». Ранее этот параметр рассчитывался только для облигаций.
  3. Поддержан расчет дополнительных параметров первой и второй частей заявок РЕПО для акций. Ранее дополнительные параметры рассчитывались только для облигаций.

    Пример расчета:
  4. Поддержан расчёт объёма на форме ввода адресных заявок для акций. Это позволяет рассчитывать цену или количество в заявке на основании указанного объёма. Функционал поддержан только для специализированной формы ввода адресной заявки.

    Пример специализированной формы ввода адресной заявки:
  5. Изменены наименования следующих пунктов меню, настроек и заголовков окон:
    • пункт меню «Заменить заявку средствами ТС» переименован в «Изменить параметры заявки»;
    • настройка «Заменять заявки средствами торговой системы» переименована в «Заменять заявки путем изменения их параметров»;
    • настройка «По возможности заменять заявки средствами торговой системы» переименована в «По возможности заменять заявки путем изменения их параметров»;
    • заголовок окна «Работа с крипто-провайдерами» переименован в «Крипто-провайдеры»;
    • заголовок окна «Вывод через DDE сервер» переименован в «Вывод через DDE-сервер».
  6. При наведении курсора на параметр таблицы «Клиентский портфель» теперь появляется подсказка с описанием параметра.

  7. При создании таблицы «Состояние счета» теперь по умолчанию выбирается максимальный срок расчётов, соответствующий плановой позиции.
  8. Реализован режим «Магнит» [image] для примагничивания точек линий и фигур к ценам свечей графика.
  9. Реализована возможность перемещения рисунков, линий и средств технического анализа графиков с помощью зажатой клавиши «Shift» вдоль оси времени без изменения уровня цены.
  10. Изменён набор типов ограничений таблицы «Ограничения по клиентским счетам», которые отображаются при создании таблицы. Теперь при создании таблицы отображаются только ограничения типа «По денежным средствам». Отображение других типов ограничений можно включить в окне редактирования таблицы.
  11. Расширен набор параметров функций QLUA getPortfolioInfo и getPortfolioInfoEx. Новые параметры позволяют изменять параметры расчёта портфеля, выполняемые указанными функциями.
  12. Для параметра «Тип сложного финансового продукта», отображаемого в «Таблице текущих торгов» в виде числового значения, поддержано отображение описания типа сложности в окне информации по инструменту.
  13. Поддержан новый тип кредитования «FX» для таблицы «Клиентский портфель», отображаемый в поле «Тип клиента».
  14. Поддержано отображение поля «Тип ликвидности» для таблицы «Таблица заявок».
  15. Оптимизирован процесс построения и расчета клиентского портфеля для CoLibri.
  16. Для таблицы «Клиентский портфель» добавлен индикатор загрузки, который сообщает клиенту о том, что в настоящий момент терминал получил не все данные, необходимые для отображения данных в таблице «Клиентский портфель».

    Пример отображения индикатора:

    Версия 9.1

    1. При успешном подключении к серверу добавлено отображение информации о дате и времени предыдущего входа в систему, а также об IP-адресе, с которого было выполнено подключение.
    2. Добавлена возможность настройки шрифта и межстрочного интервала в Таблице котировок. Настройка выполняется в разделе «Программа» / «Шрифты» основных настроек Рабочего места QUIK.
    3. В графике добавлена новая графическая фигура «Горизонтальный луч»:

    4. Новые параметры в таблицах:
      • В Таблицу заявок добавлены параметры «Дата расчетов», «Дата расчетов второй части», «Дата начала действия», «Тип контракта», «Количество второй части», «Объем второй части», «Торговая сессия», «Тип ввода цены», «Сумма РЕПО видимой части», «Видимая часть в %», «Приоритетное обеспечение».
      • В Таблицу сделок добавлены параметры «Дата фиксации», «Дата начала действия», «Тип контракта», «Спот-котировка», «Валюта комиссии торговой системы», «Валюта комиссии брокера», «Торговая сессия».
      • В таблицу «Расчетные коды» добавлены параметры «Доступен в утреннюю сессию», «Идентификатор расчетного счета/кода», «Учитывать процентный риск».
      • В Таблицу информации об участниках торгов добавлен параметр «Доступен в утренней сессии».
    5. В окно просмотра новостей информационных агентств добавлены параметры «Инструмент» и «Страна» для отображения списка инструментов и стран, связанных с отображаемой новостью.
    6. В таблице «Позиции по деньгам» максимальный размер поля «Описание» увеличен до 128 символов.
    7. Добавлена возможность быстрого доступа к транзакции замены заявки, если данная транзакция поддерживается на стороне торговой системы. При включении настройки «Заменять заявки средствами торговой системы» (в разделе «Торговля» / «Заявки» / «Замена заявок» основных настроек Рабочего места QUIK) в контекстном меню Таблицы заявок появится пункт «Заменить заявку средствами ТС». Кроме этого, данный режим будет использоваться при замене заявок при помощи режима drag-and-drop в окне котировок или на графике.
      Если при замене заявки при помощи режима drag-and-drop требуется как ранее сначала снимать, а затем выставлять новую заявку, необходимо отключить настройку «По возможности заменять заявки средствами торговой системы» в разделе настроек «Замена заявок».
    8. Изменения в специализированных формах ввода заявок:
      • Для облигаций точность параметра «Доходность» теперь равна точности цены инструмента;
      • Количество отображаемых символов на кнопке «Max» увеличено до 12.
    9. В таблицу «Купить/Продать» добавлена настройка «Показывать информационные классы», отвечающая за отображение в таблице инструментов информационных классов.
    10. Изменен функционал меток на графике:
      • Привязка меток теперь осуществляется не к шкале, а к графику в диалоге редактирования метки на вкладке «Координаты».
      • На метки распространяется действие настройки «Оставлять трендовые линии, фигуры и метки при смене инструмента».
    11. Переименованы столбцы в ряде таблиц:
      • В таблицах «Заявки на внебиржевые сделки» и «Сделки для исполнения» столбец «Дата исполнения» переименован в «Дата расчетов».
      • В таблицах «Заявки», «Сделки», «Заявки на внебиржевые сделки», «Сделки для исполнения», «Переводы НКЦ» столбец «Settlement Date» переименован в «Settle date».

    Версия 8.13

    1. Реализованы новые формы ввода заявок для режима аукционов Модуля QUIK Matching Engine. В данных формах для аукционов с типом «Закрытый Стандартный Аукцион» появилась возможность ввода заявок по объёму, а также выбор типа исполнения «AON»:

    Новые формы ввода доступны при наличии Модуля QUIK Matching Engine версии 1.22 и выше.
    2. Реализована новая форма ввода адресной заявки по облигациям, в которой доступны:
      • Расчет и подстановка цены по указанной доходности;
      • Расчет доходности по указанной цене;
      • Кнопка «Max» для расчета максимально доступного количества, исходя из текущих средств клиента;
      • Поле «Объем» с возможностью задать количество, исходя из объема;
      • Параметры с информацией о величине НКД и комиссии.

    Новая форма ввода доступна только для облигаций Модуля QUIK Matching Engine.
    3. В форме ввода заявки РЕПО-М по облигациям реализован расчет и отображение параметров первой и второй части сделки РЕПО, а также предварительный расчёт параметров сделки.

    Новая форма ввода доступна только для облигаций Системы брокерских котировок версии 4.39 и выше.
    4. В формах ввода адресных заявок и заявок РЕПО добавлена проверка указанного количества на соответствие кратности лота инструмента.
    5. В окне котировок режима «Односторонний аукцион» Модуля QUIK Matching Engine добавлен параметр «Объем», в котором будет отображаться:
      • Для конкурентных заявок объем исполнения для данного ценового уровня;
      • Для неконкурентных заявок суммарный объем всех неконкурентных заявок.
    6. В таблице «Текущие торги» поддержано отображение инструментов с подтипом «Акции инвестиционного фонда».

    Версия 8.12

    1. Пункт контекстного меню «Новая OMS-заявка» таблицы котировок (стакана) теперь доступен для пользователей с ролью «Сейлз-трейдер» и «Сейлз».
    2. Реализована возможность выставления OMS-заявок по двойному клику левой клавишей мыши по таблице котировок. В связи с чем в меню «Система»/«Настройки»/«Основные настройки»/«Торговля»/«Котировки», в группу настроек добавлен пункт «Выставить OMS-заявку». Доступно для пользователей с ролью «Сейлз-трейдер» и «Сейлз».
    3. Изменение функционала фильтрации OMS-заявок по клиентам и торговым кодам. В таблице OMS-заявок теперь вместо одного «Фильтра клиентов» отображается два отдельных фильтра: «Фильтр клиентов» и «Фильтр торговых кодов».
    4. В таблицы «Параметры рыночных рисков [ЦК]» и «Параметры рыночных рисков [Валюта]» добавлено поле «Валюта ставки риска».
    5. Из таблицы «Параметры рыночных рисков [ЦК]» убрано поле «Рыночный риск, %». Значения отображаются в поле «Дисконт, %».
    6. Изменения в специализированной форме ввода заявок («Торговля»/«Заявки»/«Формы ввода»/«Режим отображения»/«Специализированный»):
      • При изменении количества в поле «Количество» с помощью стрелок «вверх» или «вниз» количество меняется с учётом параметра «Кратность лота» инструмента;
      • Значение «НКД» теперь учитывает количество лотов в заявке;
      • При выборе признака «Рыночная» в форме ввода заявки по облигациям поле «Доходность» теперь очищается.
    7. Модифицированы окна «Идентификация пользователя» и «Изменение пароля». Теперь на формах отображается текущая раскладка клавиатуры, выбранный язык и состояние кнопки Caps Lock. Кроме этого, по клику на значок справа от поля ввода пароля можно показать/скрыть пароль.

    8. Изменены диалоги, отображающиеся если указанная цена не соответствует шагу цены и/или количество не соответствует кратности лота:

      Версия 8.11

      1. Поддержана Lua версии 5.4.1, использование которой должно устранить многие проблемы с исполнением скриптов. При этом версия 5.3.5 продолжает поддерживаться и остаётся версией по умолчанию. Ранее собранные скрипты должны быть пересобраны под новую версию LUA, то же самое касается внешних библиотек, если они используются. В основные настройки рабочего места QUIK добавлен раздел «Lua скрипты».

        В диалог «Доступные скрипты» интерпретатора языка Lua добавлен выпадающий список на кнопку «Запустить».

      2. Осуществлён перенос диалога «Поток котировок» (стало «Котировки») и «Поток обезличенных сделок» (стало «Обезличенные сделки») в диалог основных настроек.

      3. При выборе ручного заказа данных добавлено предупреждение.

      4. Параметр «Получать информацию по обезличенным сделкам с текущего момента» и кнопка «Получить данные по обезличенным сделкам» переименованы в: «Получать обезличенные сделки с момента подключения» и кнопку «Перезаказать данные».
      5. В Таблицу текущих торгов для облигаций добавлен параметр «Неточные параметры», значения неточных параметров отображаются в таблице в виде аббревиатур, при наведении на которые появляется подсказка вида:

        Если пользователь выставляет заявку по инструменту, имеющему такие параметры, и в терминале включён запрос подтверждения при отправке заявок, то у пользователя дополнительно отображается соответствующее предупреждение.
      6. Добавлена возможность отображения состояния экспорта по DDE и ODBC в менеджере окон.

      7. Реализован единый диалог цветовых настроек и интерфейс для их управления для таблиц заявок, стоп-заявок, алго-заявок, омс-заявок, клиентских омс-заявок, омс-репо заявок, внебиржевых заявок, безадресных внебиржевых заявок и для сделок для исполнения.

      8. В таблицы «Купить/Продать» и «Состояние счёта» добавлены поля «ГО покупателя» и «ГО продавца».
      9. В таблицу «Позиции по инструментам» для реализации корректной работы со средневзвешенной ценой позиции для инструментов, торгуемых в разных классах с разными валютами, добавлено поле «Валюта цены приобретения». Для корректной оценки такого вида нетипичных инструментов, также необходимо применение соответствующих настроек на стороне брокера.

      Версия 8.9

        • Поддержаны изменения МБ в трансляции значений признака «Квалифицированный инвестор» для акций и облигаций, теперь в Таблице текущих торгов для данного параметра будет отображаться одно из следующих значений:
          • «Для любых квал.инвесторов» – бумага предназначена к покупке всеми (любыми) квалифицированными инвесторами;
          • «Для юр.лиц - квал.инвесторов» – бумага предназначена к покупке квалифицированными инвесторами, являющимися юридическими лицами;
          • «» (пустая строка) – бумага предназначена к покупке любыми инвесторами.

          Версия 8.8

          1. Для облигаций реализована новая форма ввода заявок, с возможностью расчета и подстановки цены по указанной доходности, а также расчета доходности по указанной цене.

            Для использования данной формы необходимо в настройках клиентского места в разделе «Торговля / Заявки / Формы ввода» включить режим отображения «Специализированный».

            В текущий момент специализированная форма ввода доступна только для аукционов размещения и выкупа облигаций в Модуле QUIK Matching Engine.
            • Изменены настройки клиентского места в разделе «Торговля / Заявки / Формы ввода»:
              • Вид форм ввода заявок теперь определяется настройкой «Режим отображения»;
              • Опция «Применять стандартные формы ввода» заменена на режим отображения «Динамический»;
              • Удалена настройка «Упрощенная форма ввода».

              • В таблицу «Текущие торги» добавлены параметры:
                • «Допуск к дополнительной сессии» – признак допуска инструмента к торгам в вечернюю сессию на Фондовом рынке Московской Биржи;
                • «Повышенный инвестиционный риск» – признак принадлежности инструмента к перечню бумаг с повышенным инвестиционным риском.

                • В таблицы заявок, сделок и обезличенных сделок добавлен параметр «Расчетная сумма», в котором для облигаций будет отображаться сумма заявки и сделки с учетом НКД.

                Версия 8.5

                1. Реализован функционал быстрого фильтра в таблицах. Для активации \ деактивации быстрого фильтра используется пункт «Включить быстрый фильтр» \ «Выключить быстрый фильтр» контекстного меню, открываемого для заголовка самого левого столбца таблицы.

                  Данный функционал позволяет фильтровать информацию в таблицах QUIK с наглядным отображением критериев фильтрации.

                  Описание см. в п. 2.8.9 Руководства пользователя.
                  • Добавлена возможность быстрого выставления большого количества встречных заявок на внебиржевые сделки при помощи множественного выделения строк таблицы и нового пункта меню «Ввод встречных адресных заявок».

                    Описание см. в п. 3.21.6 Руководства пользователя.
                    • Добавлена возможность получать запрос на подтверждение операций закрытия и переворота позиции, совершаемых из панели торговли в стакане котировок. Запрос отображается при включённой настройке «Торговля» / «Заявки» / «Запрашивать подтверждение».

                      • Реализована специализированная форма ввода для эскпирации опционов.

                        • Добавлена возможность отображения теоретической стоимости опциона в верхней информационной панели стакана.

                          • Осуществлён переход на ядро LUA 5.3.5, что позволит данному языку программирования работать с 19-значными номерами заявок и сделок.
                          • Добавлен новый пункт меню «Что нового» в основное меню «Система» (под пунктом «Справка»). При его выборе открывается страница сайта https://arqatech.com/ru/support/files/quik-workstation/.

                          Версия 8.4

                          1. Добавлены новые функции для встроенного языка программирования Lua:
                            • getTrdAccByClientCode – функция предназначена для получения торгового счета срочного рынка по коду клиента фондового рынка с единой денежной позицией.
                            • getClientCodeByTrdAcc – функция предназначена для получения кода клиента фондового рынка с единой денежной позицией по торговому счету срочного рынка.
                            • isUcpClient – функция предназначена для получения признака, указывающего имеет ли клиент единую денежную позицию.

                              Описание функций приведено в Руководстве пользователя Интерпретатора языка Lua
                          2. В таблице «Сделки» поддержано отображение новых типов сделок Срочного рынка МБ:
                            • «Сделка исполнения фьючерса»;
                            • «Сделка исполнения опциона»;
                            • «Сделка истечения опциона».
                          3. Изменена цветовая схема отображения кнопок «Покупка/Продажа» на форме ввода заявок.

                          Версия 8.3.1

                          1. Добавлена трансляция процента ставки в стакан со SWAP инструментами.
                          2. В таблицу «Обязательства и требования по деньгам [Валюта]» добавлены новые параметры:
                            • «Входящая позиция под исполнение» — нетто между входящими требованиями и входящими обязательствами;
                            • «Плановая позиция под исполнение» — нетто между суммой в заявках на покупку и суммой в заявках на продажу.
                          3. Фильтрация классов IQS при вызове контекстного меню из таблицы «Позиции по клиентским счетам».
                          4. В таблице сделок поддержаны новые типы сделок EES:
                            • «67» — «Обратная EES-сделка»;
                            • «68» — «Прямая обеспеченная EES-сделка»;
                            • «69» — «Прямая необеспеченная EES-сделка»;
                            • «70» — «Прямая смешанная EES-сделка».
                          5. Изменено поведение настройки «Особо выделять ключевые параметры» для форм ввода заявок. Теперь при включении данной настройки жирным шрифтом будут выделяться только значения в полях ввода цены и количества. Текст «Покупка» и «Продажа» на кнопках выбора операции будет всегда отображаться обычным текстом, при этом фон неактивной кнопки будет закрашиваться соответствующим цветом.
                          6. Изменения в диалоге «Основные настройки»:
                            • Элементы управления (строка состояния и полосы прокрутки) перенесены из раздела «Программа» / «Панели инструментов» в раздел «Программа»;
                            • Пункт меню «Работать без звука» перенесен из основных настроек программы в «Звуки» и переименован в «Беззвучный режим»;
                            • Перенесен пункт «Использовать разделители разрядов в формах ввода» на вкладку «Торговля» / «Заявки» / «Формы ввода»;
                            • Пункты меню «Контекстный фильтр в списках» и «Контекстный поиск в выпадающих списках» удалены. Теперь настройки активны безусловно;
                            • Переименованы часть пунктов меню в разделе «Программа».
                            Было | Стало
                            Запуск и закрытие приложения
                            Показывать заставку | Отображать заставку
                            Обновлять версию программы | Проверять наличие обновлений
                            Запрашивать подтверждение на выход из программы | Запрашивать подтверждение при выходе из приложения
                            Отображение данных
                            Показывать полные коды опционов | Полные коды опционов
                            Показывать дату и время торговых данных с учетом локальной временной зоны | Данные в локальной временной зоне
                            Не показывать ФИО в заголовке программы | Скрывать ФИО пользователя в заголовке приложения
                            Элементы управления
                            Оформление интерфейса | Тема оформления
                            Применить цвета темы | Сбросить пользовательские цветовые настройки
                            Работать без звука | Беззвучный режим
                            Использовать разделители разрядов в формах ввода | Разделители разрядов в полях ввода
                          7. Поддержана новая комиссия (50 рублей) за сделки малого объёма на Валютном рынке МБ.
                          8. Сохранение ограничений Срочного рынка теперь происходит без привязки к транзакциям.

                          Версия 8.2

                          1. Добавлена новая таблица «РЕПО котировки». Теперь не требуется открывать отдельную таблицу котировок по каждому инструменту, новая таблица позволяет отслеживать все доступные в системе котировки в режиме РЕПО и РПС.
                          2. Всплывающие значки управления фильтрацией и условным форматированием из всплывающего меню в заголовке столбца переносятся в контекстное меню столбца, вызываемое щелчком правой кнопки мыши по заголовку столбца. В это же контекстное меню добавляются новые функции по работе с таблицей – автоподбор ширины и закрепление столбцов.

                          3. Сортировка по содержимому столбца таблиц выполняется в один клик левой клавишей мыши по заголовку столбца. В предыдущих версиях сортировка осуществлялась путем удержания нажатой клавиши Ctrl и нажатии левой клавишей мыши на заголовке столбца. Для активации прежнего поведения откройте диалог настроек клиентского места через пункт меню «Система / Настройки / Основные настройки… страница Окна / Таблицы» включите опцию «Сортировать по столбцу, удерживая Ctrl».
                          4. После обновления Рабочего места QUIK на версию 8.2.0 при запуске программы на экране отобразится сообщение, в котором перечислены изменения в поведении ПО:


Руководство пользователя

Рабочее место пользователя Программного комплекса QUIK – фронт–офисной системы прямого доступа. Версия 11.1

Содержание

  • Раздел 1. Подготовка к работе
  • Раздел 2. Основные принципы работы с программой
  • Раздел 3. Просмотр информации
  • Раздел 4. Работа с графиками
  • Раздел 5. Торговые операции клиента
  • Раздел 6. Совместная работа с другими приложениями
  • Раздел 7. Операции брокера
  • Раздел 8. Алгоритмический язык QPILE
  • Раздел 9. Дополнительные возможности
  • Раздел 10. Форматы сохранения таблиц в текстовый файл

Руководство пользователя QUIK © ARQA Technologies
www.arqatech.com/ru/products/quik/


Дополнительные консультации

Для решения вопросов по установке и эксплуатации программы, обращайтесь к Администратору системы QUIK Вашего брокера.

Информация об изменениях в очередных версиях программы доступна на официальном сайте в интернете: http://arqatech.com/ru/.

Ознакомиться с ответами на распространенные вопросы пользователей, а также задать свой вопрос разработчикам можно на форуме: http://forum.quik.ru/.

Ваши пожелания и комментарии к Руководству пользователя направляйте по электронной почте quiksupport@arqatech.com.


Раздел 1. Подготовка к работе

  • Общие сведения
  • Требования к оборудованию
  • Установка программы
  • Добавление и выбор криптопровайдера в настройках Рабочего места QUIK
  • Настройка шифрования средствами библиотеки qrypto32
  • Настройка шифрования и ЭЦП средствами библиотеки MP
  • Настройка шифрования и ЭЦП средствами библиотеки OpenSSL
  • Ключи запуска Рабочего места QUIK
  • Настройка параметров соединения
  • Настройка параметров получения и сохранения данных
  • Настройка соединения через прокси-сервер
  • Установление соединения с сервером
  • Мониторинг состояния соединения
  • Версии компонентов и плагинов
  • Обновление версии программы
  • Получение файлов
  • Сообщения об ошибках

В данном Руководстве описаны правила работы с программой, ее основные функции, порядок установки и настройки. Перед тем как совершить свою первую сделку, пожалуйста, прочитайте внимательно Руководство по эксплуатации, это поможет Вам избежать возможных ошибок.


Общие сведения

  • Основные функции
  • Как устроен интернет-трейдинг?

    • Рабочее место QUIK является основным пользовательским приложением программного комплекса, предоставляющим доступ к торгам и рыночной информации через Интернет в режиме реального времени (интернет-трейдинг).

    Основные функции

    Получение информации

    Одна из основных возможностей — отображение биржевой информации в режиме, максимально приближенном к реальному времени. Рабочее место QUIK позволяет наблюдать за текущим состоянием рынка, включая котировки второго уровня (очередь заявок, или так называемый «стакан» котировок), так и историю совершенных сделок. А также получать новости от информационных агентств и обмениваться сообщениями с брокером.

    Графики и индикаторы

    Динамика хода торгов наглядно представлена на графиках. Графики в QUIK можно выстраивать по любому рыночному параметру, с использованием инструментов технического анализа и отображением истории торгов. В приложении реализовано свыше 30 индикаторов технического анализа, линии, углы и дуги Фибоначчи, а также рисование трендовых, горизонтальных и вертикальных линий, графических и текстовых меток.

    Совершение сделок

    Рабочее место QUIK позволяет видеть состояния собственных средств клиента, формировать заявки на покупку/продажу инструментов и передавать их на сервер брокера. Поддерживается программный ввод заявок средствами встроенных языков программирования и ввод заявок с графика.

    Стандартный функционал Рабочего места QUIK позволяет настроить так называемый «скальперский стакан» (вид окна котировок), позволяющий при помощи кнопок на панели осуществлять быстрый ввод заявок, в том числе с помощью технологий drag-and-drop.

    Экспорт и импорт данных

    Встроенные средства экспорта данных позволяют использовать полученную информацию в других программах — собственных базах данных пользователя и системах тех. анализа. Возможен экспорт данных не только по сделкам, но и по любым параметрам торговой сессии. Вывод данных может осуществляться как «тиками» (т.е. по каждой сделке), так и «свечками» (данными по интервалу времени). Экспорт в MS Excel и базы данных осуществляется через DDE либо ODBC из большинства таблиц программы, включая Окно котировок («стакан»).

    Импорт транзакций представляет собой возможность подключения внешних программ для автоматизации формирования и ввода заявок в торговую систему. Импорт осуществляется посредством обмена данными через текстовые файлы или через API.

    Как устроен интернет-трейдинг?

    Центральным звеном системы является сервер QUIK. Сервер подключен к торговым системам бирж через специальные «шлюзы», передающие серверу информацию о торгах и средствах брокера на бирже, и принимающие поручения на покупку/продажу. Сервер осуществляет сбор информации с торговых систем и ее трансляцию всем активным (подключенным) клиентам с минимально возможной задержкой.

    Администратор системы регистрирует пользователей, устанавливает для них права на пользование информацией, а также определяет лимиты средств клиента, в пределах которых он может совершать сделки.

    Пользователь системы получает биржевую информацию о ходе биржевых торгов, доступных для торговли средствах и может самостоятельно участвовать в торгах, посылая заявки в торговую систему непосредственно с Рабочего места QUIK.

    Связь рабочего места пользователя с сервером системы осуществляется через сеть Интернет, протокол связи – TCP/IP. Вся информация между сервером и клиентом передается в зашифрованном виде. Во избежание несанкционированного доступа используется пароль.


Требования к оборудованию

Таблицу требований к оборудованию и программному обеспечению можно посмотреть на официальном сайте QUIK .


Установка программы

  1. Получите дистрибутив Рабочего места QUIK. Как правило, он содержит настройки для работы с определенным сервером QUIK, поэтому должен быть получен непосредственно от организации, обслуживающей сервер (брокера либо биржи).
  2. Запустите исполняемый файл дистрибутива и следуйте инструкциям программы установки. По окончании установки создастся папка QUIK в меню Windows: Пуск / Программы.
  3. Для надежной взаимной идентификации серверной части программного комплекса QUIK и клиентской части пользователя, а также для защиты информации, передаваемой по каналам связи, используется криптографическая защита информации. Дополнительно для подписи транзакций может использоваться электронная цифровая подпись (ЭЦП), а также механизм двухфакторной аутентификации. Средства защиты настраиваются пользователем в Рабочем месте QUIK.

    Если Ваш брокер предоставил отдельную инструкцию по настройке аутентификации и ЭЦП, выполните ее. Если такая инструкция не предоставлена, получите у Вашего брокера информацию, необходимую для настройки в Рабочем месте QUIK механизмов аутентификации и ЭЦП. Данная информация должна включать в себя ответы на такие вопросы как:

    • каким способом будет происходить аутентификация на сервере QUIK, какой криптопровайдер будет при этом использоваться;
    • будет ли использоваться ЭЦП, с помощью какого криптопровайдера.
  4. Выполните настройки аутентификации и криптографической защиты информации. Для этого установите или выберите из списка установленных криптопровайдер, который используется Вашим брокером, и выполните его настройку. В системе QUIK поддерживается работа со следующими криптопровайдерами:
    • qrypto32 – базовый механизм аутентификации по технологии «Публичный/секретный» ключ. Описание процедуры генерации ключей доступа см. в Руководстве пользователя Программы для создания и управления ключами (KeyGen). Программа поставляется в составе дистрибутива.
    • MP.
    • OpenSSL.

Добавление и выбор криптопровайдера для шифрования и ЭЦП в Рабочем месте QUIK описан в настройках Рабочего места.

Для запуска Рабочего места QUIK используйте ярлык Информационно-торговая система QUIK (файл info.exe).


Добавление и выбор криптопровайдера в настройках Рабочего места QUIK

  • Режим шифрования
  • Режим ЭЦП

    • Руководство пользователя QUIK © ARQA Technologies / www.arqatech.com/ru/products/quik/


Режим шифрования

Данный режим используется для работы по защищенному каналу связи клиент–сервер.

  1. Запустите Рабочее место QUIK. В основном меню выберите пункт Система / Настройки / Основные настройки….
  2. В открывшемся окне выберите вкладку «Программа / Шифрование».

    Нажмите на кнопку [image] «Шифровать с помощью СКЗИ».

    Откроется окно «Крипто-провайдеры». Окно содержит список установленных криптопровайдеров, а также набор кнопок для управления ими:

    • Для добавления нового криптопровайдера нажмите на кнопку «Добавить новый». При нажатии на кнопку открывается окно следующего вида:

      В окне «Добавление крипто-провайдера» заполните следующие поля:

      • «Файл исполняемого модуля» – путь к файлу библиотеки шифрования. Если файл указан верно, поля «Название» и «Описание» заполнятся автоматически.
      • «Файл настроек криптопровайдера» – путь к файлу настроек шифрования.

      Для сохранения настроек нажмите «Добавить». Чтобы закрыть окно без сохранения настроек, нажмите «Отмена».
    • Добавленный криптопровайдер появляется в списке установленных криптопровайдеров:

    • Выделите нужный криптопровайдер и нажмите кнопку «Выбрать».


Режим ЭЦП

Данный режим используется для работы с использованием ЭЦП.

  1. Запустите Рабочее место QUIK. В основном меню выберите пункт Система / Настройки / Основные настройки….
  2. В открывшемся окне выберите вкладку «Торговля / ЭЦП».

    Нажмите на кнопку [image] «Делать ЭЦП на СКЗИ».

    Откроется окно «Крипто-провайдеры». Окно содержит список установленных криптопровайдеров, а также набор кнопок для управления ими:

    • Для добавления нового криптопровайдера нажмите на кнопку «Добавить новый». При нажатии на кнопку открывается окно следующего вида:

      В окне «Добавление крипто-провайдера» заполните следующие поля:

      • «Файл исполняемого модуля» – путь к файлу библиотеки шифрования. Если путь и наименование файла указаны верно, поля «Название» и «Описание» заполнятся автоматически.
      • «Файл настроек криптопровайдера» – путь к файлу настроек шифрования.

      Для сохранения настроек нажмите «Добавить». Чтобы закрыть окно без сохранения настроек, нажмите «Отмена».
    • Добавленный криптопровайдер появляется в списке установленных криптопровайдеров:

    • Выделите нужный криптопровайдер и нажмите кнопку «Выбрать».


Настройка шифрования средствами библиотеки qrypto32

После генерации публичного и секретного ключей по инструкции, описанной в Руководстве пользователя Программы для создания и управления ключами (KeyGen), получите от брокера подтверждение регистрации публичного ключа и настройте криптопровайдер в Рабочем месте QUIK следующим образом.

В окне «Крипто-провайдеры» выделите криптопровайдер qrypto32 и нажмите на кнопку «Настроить».

В открывшемся окне укажите пути к публичному и секретному ключам:

Используемый файл настроек будет выбран автоматически.

Настройка завершается нажатием на кнопку «Сохранить».


Настройка шифрования и ЭЦП средствами библиотеки MP

  • Настройки провайдера
  • Генерация ключевой пары и запроса на сертификат
  • Установка сертификата

    • Руководство пользователя QUIK © ARQA Technologies / www.arqatech.com/ru/products/quik/


Настройки провайдера

В окне «Крипто-провайдеры» выделите криптопровайдер MP и нажмите на кнопку «Настроить».

Открывшееся окно предназначено для выбора схемы аутентификации, а также для просмотра и редактирования настроек крипто-провайдера для режимов шифрования и ЭЦП:

В выпадающем списке «Аутентификация» выберите схему аутентификации:

  • «определяется сервером» – схема аутентификации, настроенная на сервере по умолчанию;
  • «по сертификату пользователя» – схема аутентификации по сертификату пользователя. Для работы по данной схеме аутентификации необходимо создать ключи и установить сертификат шифрования;
  • «в домене по имени и паролю» – схема аутентификации по доменному имени и паролю;
  • «по имени и паролю» – схема аутентификации по имени и паролю. Схема совместима с любой из используемых на сервере схем аутентификации.
Для работы в режимах шифрования и ЭЦП может использоваться как один, так и разные сертификаты. Параметры криптопровайдера для работы в режиме шифрования и в режиме ЭЦП настраиваются отдельно и независимо друг от друга.

В случае использования аутентификации «по сертификату пользователя», необходимо указать ключевой контейнер для шифрования и / или ЭЦП, нажав на кнопку «Настроить». Выбор ключевого контейнера осуществляется одним из следующих способов:

  • «Файл сертификата» – указать файл сертификата, связанного с ключевым контейнером.

  • «Хеш сертификата» – указать хеш сертификата, связанного с ключевым контейнером:

  • «Ключевой контейнер» – выбрать ключевой контейнер.

Также в диалоге «Ключ и сертификат шифрования / ЭЦП» можно указать следующие настройки:

  • «Использовать локальное хранилище ПК» – при установленном признаке ключ находится в локальном хранилище компьютера, иначе – в хранилище текущего пользователя.
  • «Проверка сертификата по списку отзыва» – при установленном признаке производится проверка сертификата крипто-провайдером по списку отзыва сертификатов.

Настройка завершается нажатием на кнопку «OK».


Генерация ключевой пары и запроса на сертификат

Для работы с сервером через канал, защищаемый посредством провайдера MP, и/или для отправки транзакций на сервер с использованием ЭЦП с помощью библиотеки MP необходимо:

  1. Создать ключ сертификата.
  2. Получить сертификат.
  3. Установить сертификат.

Для создания ключа в окне «Крипто-провайдеры» выделите нужный крипто-провайдер курсором и нажмите кнопку «Создать ключ».

В открывшемся окне укажите место создания и хранения ключевого контейнера (в случае использования JaCarta или eToken требуется предварительная установка соответствующих программных продуктов):

  • «JaCarta» – закрытый ключ хранится в неизвлекаемой памяти (брелок);
  • «eToken» – закрытый ключ хранится в неизвлекаемой памяти (брелок);
  • «MS CSP Key Storage» – стандартный носитель ключевого контейнера. Обрабатывается с помощью Crypto API и CSP «Microsoft Strong Cryptographic Provider»;
  • «Другой (указать крипто-провайдер)» – выбор другого крипто-провайдера.

Нажмите кнопку «Далее» и укажите параметры создания ключевой пары и запроса на сертификат. Параметры, обязательные для заполнения, помечены «*»:

  1. Если пользователь ранее создавал ключевые пары с помощью данного интерфейса, и значения параметров прописаны в файле настроек, и если крипто-провайдер совпадает с крипто-провайдером, выбранным пользователем на шаге 1, то поля диалога автоматически заполняются соответствующими значениями из файла настроек (кроме поля «Имя ключевого контейнера»).
  2. В поле «Страна» вводится двухбуквенный код страны по стандарту ISO («ru» – Российская Федерация).

Далее файл запроса на сертификат необходимо передать брокеру по заранее оговоренному каналу связи и получить от брокера файл сертификата.

Если брокер самостоятельно формирует сертификат для клиента, то клиенту предоставляется контейнер с секретным ключом (файл с расширением *.pfx). Клиент должен установить полученный файл, следуя инструкции мастера установки:

Сертификат также можно получить через web-интерфейс удостоверяющего центра.

Далее можно переходить к установке сертификата.


Установка сертификата

В окне «Крипто-провайдеры» выделите нужный криптопровайдер и нажмите на кнопку «Установить сертификат».

В открывшемся окне укажите носитель ключевой пары и файл сертификата:

Для установки выбранного сертификата нажмите кнопку «Установить» (в зависимости от используемого носителя и сертификата система на данном шаге может потребовать ввести пароль).


Настройка шифрования и ЭЦП средствами библиотеки OpenSSL

  • Настройки провайдера
  • Генерация запроса на сертификат
  • Установка сертификата

    • Руководство пользователя QUIK © ARQA Technologies / www.arqatech.com/ru/products/quik/


Настройки провайдера

В окне «Крипто-провайдеры» выделите криптопровайдер OpenSSL и нажмите на кнопку «Настроить».

Открывшееся окно предназначено для выбора схемы аутентификации, выбора сертификатов шифрования и ЭЦП, а также для просмотра параметров выбранных сертификатов:

В выпадающем списке «Аутентификация» выберите схему аутентификации:

  • «определяется сервером» – схема аутентификации, настроенная на сервере по умолчанию;
  • «по сертификату пользователя» – схема аутентификации по сертификату пользователя. Для работы по данной схеме аутентификации необходимо создать запрос на сертификат и установить его;
  • «в домене по имени и паролю» – схема аутентификации по доменному имени и паролю;
  • «по имени и паролю» – схема аутентификации по имени и паролю;
  • «внутри домена» – схема аутентификации по доменному имени пользователя.
Для работы в режимах шифрования и ЭЦП может использоваться как один, так и разные сертификаты. Параметры криптопровайдера для работы в режиме шифрования и в режиме ЭЦП настраиваются отдельно и независимо друг от друга.

В случае использования аутентификации «по сертификату пользователя», необходимо создать запрос на сертификат, нажав на кнопку «Выбрать». Если в системе установлен сертификат, то по нажатию на кнопку «Выбрать» откроется окно выбора сертификата. После выбора сертификата в рамке отобразятся его параметры.

По нажатию на стрелку открываются параметры настройки схемы аутентификации «по сертификату пользователя» для установки признака проверки сертификата сервера, а также для выбора путей к папкам со списками отзыва и корневыми сертификатами.

Настройка завершается нажатием на кнопку «OK».


Генерация запроса на сертификат

Чтобы получить от брокера файл сертификата, необходимо по заранее оговоренному каналу связи передать ему файл запроса на сертификат, сформированный в Рабочем месте QUIK.

Диалог создания запроса на сертификат можно открыть в настройках клиентского места следующими способами:

  • в окне «Крипто-провайдеры» выделите криптопровайдер OpenSSL и нажмите на кнопку «Создать ключ»;
  • на вкладке «Торговля / ЭЦП» нажмите на кнопку «Загрузить». В открывшемся окне нажмите «Запрос».

Параметры, обязательные для заполнения, помечены «*»:

В поле «Страна» вводится двухбуквенный код страны по стандарту ISO. Например, «ru» – Российская Федерация.


Установка сертификата

Скопируйте полученный от брокера сертификат в корневую директорию Рабочего места QUIK.

Установка сертификата возможна двумя способами:

  1. В окне «Крипто-провайдеры» выделите криптопровайдер OpenSSL и нажмите на кнопку «Установить сертификат». Выберите файл сертификата и нажмите «Открыть».
  2. Установка сертификата на этапе установки сетевого соединения:
    • Запустите Рабочее место QUIK. Нажмите [image] для установки соединения. Откроется окно вида:

    • Выберите файл настроек в поле «Использовать настройки из файла» и нажмите «Ввод». Программа автоматически обнаруживает файл сертификата и выводит запрос на добавление его в хранилище. Нажмите «Да».

    • Открывается запрос на защиту приватного ключа паролем. При нажатии на кнопку «Нет» сертификат добавляется без пароля.

    • Для включения защиты нажмите «Да» и введите пароль.

      Пароль должен содержать хотя бы одну цифру, одну заглавную и одну строчную буквы латинского алфавита. Допускаются символы « « (пробел) и «-» (дефис). Длина пароля должна составлять не менее 8 символов.

    • Выберите сертификат и нажмите «OK».

    Данный способ используется также при плановой замене сертификата.


Ключи запуска Рабочего места QUIK

При запуске Рабочего места QUIK из командной строки используются следующие ключи:

  • -clear – очистить служебные файлы, которые содержат торговые данные (info.log (или curr_data.log в зависимости от настроек терминала), acnt.dat, alert.ik, alltrade.dat, trades.dat, orders.dat). Это позволяет ускорить загрузку программы.
  • -full-dump – в случае возникновения ошибки формируется DMP-файл, содержащий полную информацию о программе.
  • -security-replace – инструменты в WND-файле настроек заменяются в соответствии с правилами, заданными в файле замены.

    Формат запуска:

    info.exe -security-replace [<имя файла с правилами замены>]

    Если файл замены не указан, то используется файл replacements.txt, расположенный в каталоге с Рабочим местом QUIK.

    Формат файла замены:

    <Старый код класса 1>,<Старый код инструмента 1>=<Новый код класса 1>,<Новый код инструмента 1>

    …

    <Старый код класса N>,<Старый код инструмента N>=<Новый код класса N>,<Новый код инструмента N>

    Заменяются следующие параметры:

    • Код инструмента;
    • Краткое и полное наименование инструмента;
    • Код класса;
    • Наименование класса.
    Для корректной замены инструментов в таблице «Доска опционов» в качестве кода класса следует указывать код класса опционов, а в качестве заменяемого инструмента – код базового актива.

    Если указанный в файле замены инструмент не найден в справочнике инструментов Рабочего места QUIK, то операция замены не выполняется.

    Пример файла:

    SPBOPT,GZ10250BJ6=SPBOPT,GZ10250BL6

    SPBFUT,SiZ6=SPBFUT,SiH7
    Для сохранения изменённого файла настроек необходимо использовать функционал сохранения конфигурации Рабочего места QUIK в WND-файл.


Настройка параметров соединения

  • Настройки автоматического восстановления связи с сервером
  • Настройки мониторинга задержек на канале связи

    1. По умолчанию предлагается тип соединения, который был использован при предыдущем подключении. Если какое-то соединение было отредактировано или добавлено, то при очередном подключении оно будет предложено по умолчанию.
    2. Рекомендуется настроить очередность записей в списке соединений в порядке убывания частоты использования соединений, перемещая строки в списке кнопками со стрелками [image] и [image].

    1. Откройте пункт меню Система / Соединения....
    2. Для редактирования выберите строку из списка «Информация о соединениях» и нажмите кнопку «Изменить».
    3. Для создания нового соединения нажмите кнопку «Добавить».
    4. В поле «Сетевой адрес» укажите доступный сетевой адрес компьютера, на котором установлен сервер QUIK, в поле «Порт» – порт сервера. При работе через прокси-сервер в локальной сети его сетевой адрес и порт указываются в пункте меню программы Система / Настройки / Соединение с Интернетом... (см. Настройка соединения через прокси-сервер).
    5. В поле «Ключ сервера» укажите идентификатор ключа сервера. Идентификатор сообщается Администратором сервера QUIK.
      В поле «Сетевой адрес» указывается сетевое имя или IP-адрес компьютера, на котором установлен сервер QUIK.
    6. Нажмите кнопку «Да» для сохранения изменений или кнопку «Отмена» для закрытия окна без сохранения.
    7. Для удаления ненужного соединения выделите его описание в списке «Информация о соединениях» и нажмите кнопку «Удалить».

    Настройки автоматического восстановления связи с сервером

    1. Установите флажок «Восстанавливать связь автоматически через ... секунд с ... до ...».
      • в поле «через ... секунд» задайте период ожидания в секундах. Рекомендуемый интервал: 15-60 секунд. Минимальный интервал: 5 секунд.
      • В полях «с ... до...» укажите период времени, в течение которого будет действовать восстановление связи. Указывается системное время компьютера пользователя. Рекомендуется настраивать период в соответствии со временем проведения торгов на бирже, так как по завершении торгов сервер автоматически отключает всех пользователей. В последующие торговые дни связь будет автоматически восстанавливаться в назначенное время.
    2. Если флажок «При восстановлении использовать только параметры последнего соединения» включен (по умолчанию), то следующее соединение устанавливается с теми же настройками, что и в предыдущей попытке.

      Если флажок снят, то следующее соединение устанавливается с настройками, указанными в следующей строке списка «Информация о соединениях». Для этого необходимо упорядочить список доступных соединений с помощью кнопок [image] и [image] в соответствии с желаемой очередностью перебора соединений. Эта возможность может использоваться для подключения к серверу через разных провайдеров.

    Настройки мониторинга задержек на канале связи

    Если установлен флажок «Проверять связь с сервером каждые … секунд, посылая сообщение размером … байт», то программа проводит регулярный замер задержек на канале связи между сервером и клиентом, при этом значение по умолчанию (и минимальное значение) 30 секунд. Результаты замеров отображаются в «Информационном окне», см. Мониторинг состояния соединения.

    Функция имеет параметры для настройки:

    • интервал в секундах между отправкой сообщений, рекомендуемая величина: «60»;
    • величина отправляемого пакета, в байтах, рекомендуемая величина: «128».


Настройка параметров получения и сохранения данных

  • Настройка получения данных
  • Настройка сохранения данных

    • Настройка получения данных

    Настройка получения данных выполняется через пункт меню Система / Настройки / Основные настройки..., раздел «Программа» / «Получение данных».

    1. «Интервал обновления данных с текущим состоянием» – управление периодичностью обновления данных в Таблице текущих торгов:
      • «Запрашивать данные раз в … сек.» - данный признак позволяет отключить непрерывное получение данных для Таблицы текущих торгов. При включенном признаке информация в таблице обновляется периодически через установленный интервал, в секундах. Максимальный период обновления – 60 секунд. Признак включен по умолчанию. Значение по умолчанию: «1».
    2. «При получении нового инструмента» - управление добавлением новых инструментов в существующие таблицы:
      • «Добавлять его во все таблицы» – если флажок установлен, то при появлении в торговой системе нового инструмента в каком-либо классе он будет добавлен во все существующие таблицы, где отображаются инструменты данного класса, а также добавлен в список инструментов, отображаемых в «Таблице текущих торгов».
    3. «Получение позиций по глобальному фильтру клиента» – если флажок установлен, то пользователь получает только позиции по коду, указанному в глобальном фильтре. Если в фильтре выбрано значение «<Не указан>», то получение позиций не происходит. При изменении кода клиента в «Общем фильтре клиентов» или переключении на вкладку с другим кодом клиента получение позиций происходит по новому коду клиента. При включенном флажке «Получение позиций по глобальному фильтру клиента» установка фильтра через пункт меню Сервисы / Общие фильтры... либо нажатием сочетания клавиш Ctrl+G и включение опции «Исключать из фильтра выбранные» не используется. По умолчанию настройка выключена.

    Котировки

    Настройка списков инструментов для получения информации по котировкам выполняется через пункт меню Система / Настройки / Основные настройки... , раздел «Программа» / «Получение данных» / «Котировки».

    «Формировать список получаемых инструментов и параметров» – настройка объема данных, получаемых с сервера. Позволяет ограничить список принимаемых данных для сокращения трафика:

    1. «”умным” заказом данных (рекомендуется)» – получать новые значения по инструментам и их параметрам, которые отображаются в таблицах программы, необходимых для расчета маржинальных показателей, покупательной способности, используются в скриптах Lua и QPILE, отображаются на графиках, экспортируются в системы технического анализа и используются внешними подключаемыми модулями.

      Список таблиц, содержимое которых влияет на набор получаемых инструментов и параметров:

      • Таблица текущих торгов;
      • Таблица изменений параметров;
      • Таблица истории значений;
      • Клиентский портфель;
      • Купить/Продать;
      • Доска опционов;
      • Таблица локальных оповещений по параметрам таблицы текущих торгов.
    2. «по выбранным классам» — получать новые значения по инструментам и их параметрам по выбранным в окне данным. В окне представлен список, где с помощью галочек можно выбрать классы, получаемых данных. Также доступен поиск.
      • Пункт «Выбрать все» — отмечает все классы / очищает все.
      • Кнопка «Настроить по открытым таблицам» — настроить автоматически фильтры инструментов и параметров, выбрав только те инструменты и их параметры, которые отображаются в таблицах, открытых пользователем на данный момент. При редактировании пользователем настроек таблиц, настройки фильтров принимаемых данных изменятся соответственно.

        При включенной настройке кроме открытых окон учитываются также параметры, необходимые для расчета маржинальных показателей и покупательной способности.
      • Кнопка «Сбросить фильтры» — сбрасывает все настроенные фильтры по классам.
      • Общая статистика по всем выбранным и доступным параметрам отображается справа от списка;
        • классов выбрано / классов доступно – количество выбранных / доступных классов;
        • инструментов выбрано / инструментов доступно – общее количество выбранных / доступных инструментов;
        • параметров выбрано / параметров доступно – общее количество выбранных / доступных параметров.
      • Внутри каждого класса настраиваются:
        • «Фильтр инструментов» – если флажок установлен, то прием данных осуществляется только по выбранным инструментам. Если флажок снят, то прием данных осуществляется по всем инструментам, доступным для данного класса. Классы, по которым установлен фильтр инструментов, выделяются серым цветом;
        • «Фильтр параметров» – если флажок установлен, то прием данных осуществляется только по выбранным параметрам. Если флажок снят, то прием данных осуществляется по всем параметрам, доступным для инструментов данного класса. С помощью данного фильтра можно отказаться от получения неиспользуемых параметров.
        • Статистика по инструментам и параметрам выбранного класса отображается под фильтрами.

    Сохраните настройки, нажав кнопку «Сохранить».

    Обезличенные сделки

    Настройка списков инструментов для получения информации по обезличенным сделкам выполняется через пункт меню Система / Настройки / Основные настройки... , раздел «Программа» / «Получение данных» / «Обезличенные сделки».

    1. «Выбрать классы инструментов» — получать новые значения по инструментам классов, выбранным в окне. В окне представлен список доступных классов. Также доступен поиск.
      • Пункт «Выбрать все» — отмечает все классы / очищает все классы.
      • Кнопка «Сбросить фильтры» — сбрасывает все настроенные фильтры.
      • Общая статистика по всем выбранным классам и инструментам отображается справа от списка;
        • классов выбрано / классов доступно – количество выбранных / доступных классов;
        • инструментов выбрано / инструментов доступно – общее количество выбранных / доступных инструментов;
      • Внутри каждого класса настраивается:
        • «Фильтр инструментов» – если флажок установлен, то прием данных осуществляется только по выбранным инструментам. Если флажок снят, то прием данных осуществляется по всем инструментам, доступным для данного класса. Классы, по которым установлен фильтр инструментов, выделяются серым цветом.
        • Статистика по инструментам выбранного класса отображается под фильтрами.
    2. «Получать обезличенные сделки с момента подключения» – настройка рассылки обезличенных сделок пользователю. Если флажок установлен, то информация о сделках поступает с сервера QUIK с момента установления связи с сервером. Если флажок снят (по умолчанию), то сделки дозаказываются с учетом последней сделки, имеющейся в Рабочем месте QUIK.
    3. «Перезаказать данные» – при нажатии кнопки удаляется вся доступная информация об обезличенных сделках (очищаются все таблицы и файловое хранилище), сделки перезаказываются с учетом настройки «Получать обезличенные сделки с момента подключения».

      Сохраните настройки, нажав кнопку «Сохранить».

      Комментарии:
      1. Список инструментов, выбранных по умолчанию в диалоге создания Таблицы обезличенных сделок, совпадает со списком инструментов, отмеченных пользователем в диалоге настройки заказа обезличенных сделок. При добавлении в Таблицу обезличенных сделок инструментов, по которым не заказаны обезличенные сделки (т.е. инструменты не были выбраны в диалоге настроек заказа обезличенных сделок), данные инструменты автоматически добавляются в список инструментов для заказа обезличенных сделок.
      2. Если при создании тиковых графиков по Таблице обезличенных сделок или при настройке экспорта тиков в системы тех. анализа на основании Таблицы обезличенных сделок пользователь выбирает инструмент, по которому не заказаны обезличенные сделки, то данный инструмент автоматически добавляется в список инструментов для заказа обезличенных сделок.
      3. По кнопке «Перезаказать данные» не предусмотрена автоматическая очистка данных для экспорта обезличенных сделок с использованием ODBC и DDE. Очистка данных производится пользователем вручную. Перезапуск расчета QPILE-портфеля также осуществляется пользователем вручную.

          Настройка сохранения данных

          Настройка сохранения данных выполняется через пункт меню Система / Настройки / Основные настройки... , раздел «Программа» / «Сохранение данных».

          1. «Сохранять для получаемых инструментов и параметров» – признаки, определяющие количество информации, хранимой Рабочим местом QUIK для последующего использования.
            • «Только данные, отражающие текущее состояние» – сохраняются последние значения параметров,
            • «Данные, отражающие текущее состояние и всю историю изменений» – сохраняются все принятые значения параметров. Данное свойство необходимо при использовании Таблицы истории значений, Таблицы изменения параметров, построения графиков по значениям Таблицы текущих торгов, а также экспорта данных в системы технического анализа, если их источником является Таблица текущих торгов.
            • «Получать пропущенные данные» (влияет на скорость работы приложения) - при установленном флажке программа получает с сервера все данные с начала торгов за этот день. При снятом флажке производится прием только новых данных.

              Данное свойство необходимо, если используется Таблица истории (либо в графиках используются параметры из Таблицы истории) либо Таблица изменений значений параметров. Если указанные таблицы не задействованы, рекомендуется отключить этот флажок для уменьшения трафика.
          2. «Очищать данные после смены даты»:
            • «На локальной машине» – очищает в памяти данные предыдущей торговой сессии сразу после запуска программы, до установления связи с сервером. Используйте этот вариант, если нет необходимости получать информацию о торгах за предыдущий день перед началом торгов за текущий день.
            • «На сервере (при установлении связи)» – очищает данные предыдущей торговой сессии при появлении на сервере данных, относящихся к новой торговой сессии. Используйте это вариант, если информация о торгах принимается утром следующего дня (например, из-за существенной разницы в часовых поясах).


Настройка соединения через прокси-сервер

  • Информация для администратора локальной сети по настройке прокси-сервера

    • Для организации работы системы QUIK из локальной сети, имеющей ограничение доступа в Интернет, скорее всего потребуется настройка прокси-сервера администратором сети. Если существует возможность установить соединение без использования прокси-сервера, то выполнять эту настройку не следует.

    1. Откройте пункт меню Система / Настройки / Соединение с Интернетом....

    2. Установите флажок «Использовать прокси-сервер».
    3. В полях «Сетевой адрес» и «Порт» введите адрес и порт прокси-сервера (сообщается администратором локальной сети). Его также можно найти в настройках программы обозревателя Интернет, например для MS Internet Explorer нужно открыть пункт меню Сервис / Свойства браузера, вкладка «Подключения», нажать «Настройка сети» – в разделе «Прокси-сервер» указаны адрес прокси-сервера и номер порта, которые нужно указать в настройках.
      В поле «Адрес» указывается сетевое имя или IP-адрес компьютера, на котором установлен сервер QUIK.
    4. Выберите используемый тип соединения:
      • «SOCKS5 с идентификацией по имени и паролю» – если прокси-сервер поддерживает протокол SOCKS5, и требуется идентификация пользователя. В этом случае имя и пароль для доступа в Интернет будет запрашиваться для ввода пользователем вручную, если выбрано условие «Запрашивать имя или пароль в процессе соединения», либо они будут сохранены в файл настроек системы, если выбрано условие «Читать имя и пароль из файла настройки».
      • «SOCKS5 без идентификации пользователя» – если прокси-сервер поддерживает протокол SOCKS5 и идентификация пользователя не требуется.
      • «CONNECT через HTTP-порт прокси-сервера» – если протокол SOCKS5 не поддерживается сервером, но возможно использование команды протокола CONNECT. Ниже приведены примеры настройки для прокси-серверов, протестированных на возможность работы c QUIK:
        • Squid proxy (требуется дополнительная настройка),
        • MS Proxy (требуется дополнительная настройка),
        • WinGate (настройка не требуется).
      • «CONNECT через HTTP порт с идентификацией по имени и паролю» – если протокол SOCKS5 не поддерживается сервером, но возможно использование команды протокола CONNECT, и требуется идентификация пользователя. Имя и пароль для доступа в Интернет будет запрашиваться для ввода пользователем вручную, если выбрано условие «Запрашивать имя или пароль в процессе соединения», либо они будут сохранены в файл настроек системы, если выбрано условие «Читать имя и пароль из файла настройки».

    Информация для администратора локальной сети по настройке прокси-сервера

    Необходимо включить порт QUIK (номер порта сообщается администратором сервера QUIK) в список портов, через которые разрешено установление SSL-соединения.

    1. Настройки для Squid Proxy

      В файле sqiud.conf (обычно это /usr/local/squid/etc/squid.conf) должны быть следующие строки:

      • Включение 200 (например) порта в список SLL-портов:
      acl SSL_ports port 443 563 200
      acl Safe_ports port 80 21 443 447 563 1025-65535 200
      • Разрешить использовать метод CONNECT при обращении на определённые выше SSL-порты:
      acl CONNECT method CONNECT
      http_access deny CONNECT!SSL_por
    2. Настройки для MSProxy

      Необходимо с помощью программы Regedit изменить на компьютере с установленным MSProxy один из ключей в реестре Windows:

      HKEY_LOCAL_MACHINE / SYSTEM / CurrentControlSet / Services /
       W3Proxy / Parameters / SSLPortListMembers

      В список портов необходимо добавить используемый порт (например, 200). Если включен контроль доступа для сервиса «Web Proxy», то для протокола «Secure» нужно добавить группу «Everyone». В журналах сервиса эти соединения будут регистрироваться как от пользователя «anonymous».


Установление соединения с сервером

  1. Нажмите кнопку [image] на панели инструментов либо выберите пункт меню Система / Установить соединение.... Также можно использовать комбинацию клавиш «Ctrl»+«Q».
  2. При использовании криптопровайдера MP с хранением секретного ключа в неизвлекаемой памяти вставьте ключевой носитель. Соединение с сервером установится автоматически.
  3. При использовании криптопровайдеров Qrypto32, MP или OpenSSL (со схемой аутентификации «в домене по имени и паролю» или «по имени и паролю») настройте параметры соединения в окне «Идентификация пользователя»:

    • Выберите требуемое соединение. Рекомендации по выбору предпочтительного типа соединения можно получить у администратора сервера системы QUIK.

      Поставляемая в дистрибутиве конфигурация программы содержит определенный список настроенных соединений. При необходимости можно добавлять/удалять соединения либо изменять их настройки (см. Настройка параметров соединения).

    • Введите имя пользователя (login), указанное при регистрации ключа, и пароль к нему. При вводе обращайте внимание на правильность выбора регистра клавиатуры и языка, в конце строки отображается буквенный код раскладки и режима ввода букв, при нажатой клавише Caps Lock код раскладки отображается прописными буквами (например, RU/EN). Чтобы показать / скрыть пароль нажмите на значок «глаз» [image] / [image]. Пароль может быть изменен.

      Если включен признак «Запомнить имя», то при следующем открытии диалога поле «Имя пользователя» автоматически заполнится предыдущим введенным значением.

      Значение поля «Имя пользователя» запоминается при нажатии кнопки «Вход».
    • Нажмите «Вход». В случае успешного соединения на экране появится соответствующее сообщение с данными о предыдущем входе (дата, время, IP-адрес).О возможных ошибках см. Сообщения об ошибках.
  4. При использовании криптопровайдера MultiPurpose или OpenSSL (со схемой аутентификации «по сертификату пользователя») настройте параметры соединения в окне «Установка сетевого соединения»:

    • Выберите требуемое соединение. Рекомендации по выбору предпочтительного типа соединения можно получить у администратора сервера системы QUIK.

      Поставляемая в дистрибутиве конфигурация программы содержит определенный список настроенных соединений. При необходимости можно добавлять/удалять соединения либо изменять их настройки (см. Настройка параметров соединения).

    • Наименование криптопровайдера (системы криптографической защиты информации), используемого при шифровании, прописано в поле «Шифровать данные с помощью СКЗИ». В поле «Использовать настройки из файла» укажите путь и наименование файла настроек данного криптопровайдера либо выберите файл с помощью кнопки «…».
    • Нажмите «Ввод». В случае успешного соединения на экране появится сообщение системы «Соединение установлено». О возможных ошибках см. Сообщения об ошибках.

Чтобы отключиться от сервера, нажмите кнопку [image] на панели инструментов либо выберите пункт меню Система / Разорвать соединение.... Также можно использовать комбинацию клавиш «Alt»+«Q».


Изменение пароля

Диалог изменения пароля открывается:

  • При выборе пункта меню Сервисы/Изменить пароль. Пункт меню доступен при установленном соединении с сервером QUIK, если используется криптопровайдер MP или OpenSSL со схемой аутентификации «по имени и паролю».
  • По истечении срока действия пароля, либо если на сервере в настройках пользователя включен признак «Требовать смены пароля при следующем входе», после ввода текущего имени пользователя и пароля.

В диалоге «Изменение пароля» необходимо указать значения следующих параметров:

  1. При вводе обращайте внимание на правильность выбора регистра клавиатуры и языка, в конце строки отображается буквенный код раскладки и режима ввода букв, при нажатой клавише Caps Lock код раскладки отображается прописными буквами (например: английская раскладка с нажатой клавишей Caps Lock будет отображаться значением «EN» справа в поле ввода пароля, а русская раскладка без клавиши Caps Lock будет отображаться значением «ru»).
  2. Чтобы показать / скрыть пароль нажмите на значок «глаз» [image] / [image].
  • «пароль» – текущий пароль пользователя;
  • «новый пароль» – новый пароль пользователя;
  • «подтверждение пароля» – повторный ввод нового пароля для подтверждения.

Смена текущего пароля на новый производится при нажатии кнопки «Изменить».

ВАЖНО! При нажатии кнопки «Изменить» выполняется автоматическое переподключение к серверу QUIK.


Мониторинг состояния соединения

Контроль связи с сервером осуществляется несколькими способами:

  1. Индикатор состояния соединения с сервером расположен в правом углу строки состояния. Отображает дату торгов, данные по которым принимаются с сервера QUIK (например, предыдущие торги могут быть загружены с сервера утром следующего дня). Отсутствие даты в индикаторе означает отсутствие принятых данных. Цвет индикатора символизирует состояние соединения:
    • Зеленый - соединение установлено, данные обновляются.
    • Желтый - соединение не установлено, данные не обновляются (указана дата последнего обновления данных).
  2. Информационное окно отображает полный набор статистических параметров для контроля за состоянием соединения с сервером. Настройка окна осуществляется из пункта меню Система/О программе/Информационное окно....

    В открывшемся окне необходимо выбрать список и очередность параметров, отображаемых в информационном окне. Установленный флажок «Расширенный набор» добавляет дополнительные параметры в список доступных параметров:

    После настройки параметров открывается информационное окно:

    Доступные поля информационного окна

    Поле | Назначение
    Версия программы | Порядковый номер версии программы
    Дата торгов | Дата проведения торгов, по состоянию на которую получены данные
    Время сервера | Значение, которое рассчитывается на основе времени получения с сервера актуальных данных таблицы «Текущие торги». Формат определяется настройками операционной системы
    Время последней записи | Время получения с сервера последней записи (порции данных). Формат определяется настройками операционной системы
    Число записей | Число полученных с сервера записей
    Последняя запись | Номер последней полученной записи
    Отставшая запись | Номер последней полученной отставшей записи (после обрывов связи происходит восстановление пропущенных данных)
    Соединение | Состояния: Установлено/разорвано
    IP-адрес сервера | Адрес сервера QUIK в сети Интернет
    IP-порт сервера | Номер порта для доступа к серверу QUIK
    Описание соединения с сервером | Описание соединения в Списке доступных соединений
    Описание сервера | Имя сервера
    Пользователь | Имя пользователя (указывается при регистрации доступа)
    Организация | Организация пользователя (указывается при регистрации доступа)
    Текущее время | Время на компьютере пользователя. Формат определяется настройками операционной системы
    Время на связи | Продолжительность сеанса связи с сервером. Формат определяется настройками операционной системы
    *Идентификатор сессии | Уникальный идентификатор сессии
    *Код пользователя | Код пользователя на сервере QUIK
    *Занято памяти | Зарезервировано, не используется
    *Передано сообщений | Количество переданных записей
    *Передано всего байт | Общий объем исходящего трафика за сеанс связи
    *Передано полезных байт | Полезный объем исходящего трафика за сеанс связи
    *Передано за секунду | Объем данных в байтах, переданный за последнюю секунду
    *Принято сообщений | Количество принятых записей
    *Принято полезных байт | Полезный объем входящего трафика за сеанс связи
    *Принято всего байт | Общий объем входящего трафика за сеанс связи
    *Принято за секунду | Объем данных в байтах, принятый за последнюю секунду
    *Средняя скорость передачи | Объем переданных данных в байтах, разделенный на время на связи в секундах
    *Средняя скорость приема | Объем принятых данных в байтах, разделенный на время на связи в секундах
    **Время последней проверки связи | Время последнего выполнения замера задержки данных командой PING. Формат определяется настройками операционной системы
    **Задержка данных при обмене с сервером | Последнее полученное значение задержки данных, в секундах
    ** Средняя задержка данных | Средняя величина задержки данных за время текущего сеанса связи, в секундах
    ** Время максимальной задержки | Время появления максимальной задержки данных в текущем сеансе связи
    **Максимальная задержка данных | Максимальная величина задержки в текущем сеансе связи, в секундах
    *Конвертация символов Признак конвертации данных, получаемых с сервера QUIK из кодировки CP866 в кодировку CP1251 Возможные значения:
    • «Да»;
    • «Нет»
    *Позиций по деньгам | Количество денежных средств
    *Позиций по инструментам | Количество инструментов
    *Фьючерсных ограничений | Количество ограничений по фьючерсам
    *Фьючерсных позиций | Количество позиций по фьючерсам
    *Торговых счетов | Количество торговых счетов
    *Заявок | Количество заявок
    *Сделок | Количество сделок
    *Маржинальных рядов (всего; очередь) | Параметр служебного пользования. Предназначен только для сотрудников Службы технической поддержки
    *Маркеры рассылок | Параметр служебного пользования. Предназначен только для сотрудников Службы технической поддержки
    *Очередь сервисных задач | Параметр служебного пользования. Предназначен только для сотрудников Службы технической поддержки

    * - расширенный набор данных,

    ** - параметры проверки связи с сервером, см. Настройка параметров получения и сохранения данных

  3. Индикатор «Поезд»

    Слева на панели инструментов отображается анимационный индикатор в виде движущегося поезда. Движение поезда означает поступление данных с сервера. Если поезд стоит, значит, новые данные не поступают, возможна проблема связи с сервером. Если соединение не установлено, то поезд на картинке отсутствует.


Версии компонентов и плагинов

меню Система/О программе/Компоненты…

Назначение

В диалоге содержится информация о компонентах и плагинах используемой версии программы.

Формат таблицы

Каждая строка таблицы соответствует отдельному компоненту/плагину. В столбцах таблицы отображаются заголовки следующих параметров:

Название поля | Значение
Состояние Состояние компонента/плагина. Возможные значения:
  • «Загружен» – включен пользователем, загружен терминалом и работает;
  • «Выключен» – не загружается терминалом, так как выключен пользователем;
  • «Отказ» – включен пользователем, но при загрузке терминалом произошла ошибка (например, кончились лицензии на сервере), и в текущий момент он не работает
Название компонента | Название компонента/плагина
Версия | Версия компонента/плагина

С помощью флажка в колонке «Состояние» пользователь может включить или отключить использование определенного плагина. При отключении плагина его меню удаляется, а окна закрываются и не восстанавливаются автоматически при последующем включении.


Обновление версии программы

  • Автоматическое обновление
  • Запуск обновления вручную

    • Автоматическое обновление

    Система QUIK имеет встроенный механизм автоматического обновления версии программы. При соединении программы клиента с сервером системы производится сверка модулей программы и их версий на компьютере клиента с эталонной конфигурацией, размещенной на сервере.

    При обнаружении на сервере новых модулей программа предлагает произвести их прием и установку. Таким образом, для обновления программы нет необходимости устанавливать заново программу из дистрибутива, достаточно получить обновленные модули и позволить системе QUIK установить их. Для этого нажмите кнопку «Принять файлы».

    После загрузки файлов на компьютер клиента на экране появится предложение перезапустить программу, чтобы записать новые файлы взамен прежних. Нажмите кнопку «Да». После обновления программа предложит восстановить соединение с сервером и снова готова к работе.

    Для обновления программы перезагрузка компьютера не требуется.

    Возможность автоматического обновления версии программы может быть отключена. Для этого выберите пункт меню Система/Настройки/Основные настройки…, раздел «Программа», снимите флажок «Обновлять версию программы».

    Запуск обновления вручную

    Обновление версии программы можно запустить вручную, выбрав пункт меню Система/О программе/Проверить обновление программы.


Получение файлов

  • Назначение файловых областей
  • Назначение полей файловых областей
  • Прием файла

    • Механизм обновления версии программы может быть использован для передачи от администратора системы ее пользователям различных файлов. Для этого в меню программы Система / Получение файлов... предусмотрены специальные файловые области.

    Назначение файловых областей

    • «Личная» – для размещения документов и файлов, предназначенных только данному пользователю (например, отчеты брокера). Принятые файлы накапливаются в папке FILES\PRIVATE рабочей директории QUIK.
    • «Компании» – для размещения документов и файлов, предназначенных для сотрудников компании. Принятые файлы накапливаются в папке FILES\COMPANY рабочей директории QUIK.
    • «Общая» – для размещения файлов и документов общего пользования, таких как регламент оказания услуг брокера, тарифы, документация к программе. Принятые файлы накапливаются в папке FILES\PUBLIC рабочей директории системы QUIK.
    • «Программа» – для обновления версии программы.

    Нажатие кнопки «Обновить» приводит к повторному запросу состояния файловой области. Используйте ее, если ожидаете размещения какого-либо файла администратором.

    Назначение полей файловых областей

    • «Имя файла» – имя файла.
    • «Размер» – размер файла в байтах.
    • «Получено» – размер полученной части файла, в байтах.
    • «Новая версия» – версия файла на сервере.
    • «Текущая версия» – версия файла на компьютере клиента.
    • «Состояние» – состояние приема (есть, нет, устарел, идет прием. принят).

    Прием файла

    Чтобы принять файл, нужно выбрать его нажатием левой кнопки мыши. Выбранные файлы помечаются красным цветом. Поля «Всего» и «Выделено» информируют о количестве доступных и заказанных к получению данных.

    Нажмите кнопку «Принять файлы» для получения файлов. Разделы «Текущий файл» и «Всего» отображают состояние приема данных. Процесс получения завершается автоматически, поэтому можно закрыть это окно нажатием кнопки «Закрыть». При необходимости можно вызвать окно «Получение файлов» снова из меню программы и остановить прием нажатием кнопки «Прекратить прием».

    Процедура получения файлов осуществляется в фоновом режиме и не влияет на оперативность получения биржевой информации во время торгов. Однако, при работе по каналам связи с низкой пропускной способностью процесс может занять достаточно много времени. В таких случаях рекомендуется производить получение файлов либо перед началом торговой сессии, либо после ее окончания.
    Администратор системы может ввести ограничение на период времени в течение суток, когда возможно получение файлов.


Приложение 1

Сообщения об ошибках

  • Ошибки при вводе имени и пароля
  • Ошибки при установлении связи с сервером
  • Ошибки при работе с программой

    • Ошибки при вводе имени и пароля

    «Файл с ключами не найден»

    • Программе не удалось обнаружить файл с ключами, указанный в qrypto.cfg. Если ключи хранятся на ключевом носителе, убедитесь, что он вставлен в компьютер.
    • Если ключи хранятся не на ключевом носителе, убедитесь, что они доступны для чтения по адресу, указанному в разделе «Программа» / «Шифрование» пункта меню программы Система/Настройки / Основные настройки.... В открывшемся окне нужно нажать кнопку «Настройки по умолчанию» и найти строки «Файл с публичными ключами» и «Файл с секретными ключами». Если эти строки не указаны, то система по умолчанию ищет файлы с ключами на диске A:. Путь к файлу не должен содержать пробелов и русских букв. Изменять эти настройки можно только при отсутствии соединения с сервером QUIK.
    • Поврежден ключевой носитель либо файл с ключами. Использование ключа невозможно, необходимо заново создать и зарегистрировать на сервере ключ доступа.

    «Ключ сервера или пользователя не найден»

    • В файле публичных ключей pubring.txk отсутствует публичный ключ сервера с идентификатором, указанным в настройках выбранного соединения.
    • В файле секретных ключей secring.txk отсутствует секретный ключ пользователя, соответствующий введенному имени.

    «Ошибка ввода-вывода при обращении к файлу с ключами»

    • Ошибка обращения к файлу с ключами. Возможно, запрещен доступ к файлу.

    «Указано неверное имя файла с ключами»

    • В файле настроек qrypto.cfg указано неверное имя файла.

    «Неверный ключ в файле с ключами»

    • Один из ключей доступа, указанных в файле qrypto.cfg, имеет неверный формат либо поврежден. Необходимо создать и зарегистрировать ключи заново.

    Неверный пароль (Wrong password)

    • Введен неверный пароль. Удостоверьтесь, что пароль вводится при правильном регистре и языке, и повторите ввод.

    «Ошибка шифрования N …»

    • Произошла ошибка шифрования. При появлении данной ошибки отправьте снимок экрана (screenshot) в Службу технической поддержки QUIK – quiksupport@arqatech.com.

    Ошибки при установлении связи с сервером

    «Соединение установить не удалось»

    • Указанные в параметрах соединения IP-адрес и порт доступны с компьютера, на котором запущено Рабочее место QUIK, но сервер QUIK с такими параметрами не запущен. Обратитесь к администратору системы QUIK.
    • В базе сервера QUIK не найден пользователь с указанным ключом, Обратитесь к администратору системы QUIK.

    «Connection refused» (Соединение отвергнуто)

    • Указанные в параметрах соединения IP-адрес и порт доступны с компьютера, на котором запущено Рабочее место QUIK, но сервером QUIK не обслуживаются. Обратитесь к администратору системы QUIK.

    «No Route to Host» (Нет возможности подключения к серверу)

    • Указанные в параметрах соединения IP-адрес и порт недоступны с компьютера, на котором запущено Рабочее место QUIK. Обратитесь к своему администратору сети для настройки соединения с сервером QUIK.

    «You already work in system» (Вы уже работаете в системе)

    • Сервер не допускает одновременную работу двух пользователей с одинаковыми ключами доступа. Если такое сообщение получено при восстановлении соединения после обрыва (наиболее вероятно при модемном соединении), то достаточно повторить попытку через несколько секунд, когда сервер прекратит обработку предыдущего соединения.
    • Если сообщение получено при первом сеансе связи с сервером, обратитесь к администратору системы.

    «Licence expired» (Срок лицензии истек)

    • Истек срок действия лицензии на пользование терминалом системы QUIK. Обратитесь к администратору сервера QUIK для продления доступа.

    «Access locked by administrator» (Доступ заблокирован администратором)

    • Пользовательская учетная запись либо ip-адрес заблокированы администратором. Обратитесь к администратору сервера QUIK.

    «Protocol error» или «Outdated protocol version» или «Incorrect protocol version» или «Unsupported protocol» (Несоответствующая версия протокола)

    • Сервер не поддерживает работу с рабочим местом клиента данной версии. Старые версии рабочего места QUIK совместимы с новыми версиями серверной части, однако совместимость новых версий клиентского терминала с предыдущими версиями сервера не гарантируется.
    Используйте автоматическое обновление версии программы (пункт меню Система/О программе/Проверить обновление программы). В этом случае совместимость версий обеспечена.

    «Unknown provider» (Неизвестный криптопровайдер)

    • Настройки системы шифрования программы клиента не соответствуют применяемым на данном сервере QUIK. Измените настройки в соответствии с рекомендациями администратора сервера.

    «Certificate parts corrupted» (Сертификат поврежден)

    • Невозможно использовать данный сертификат подсистемы криптографической защиты информации. Обратитесь за помощью к администратору сервера.

    «User not found» (Пользователь не найден)

    • При SSL-авторизации не найден пользователь. Обратитесь за помощью к администратору сервера.

    «Error while context creation»

    • Ошибка в процедуре аутентификации. Сообщите об ошибке администратору сервера с указанием используемой системы криптографической защиты информации.

    Ошибки при работе с программой

    «Connection timed out» (Соединение разорвано)

    • Соединение прервано из-за плохого качества связи. Установите связь снова. Если разрывы связи случаются часто, проконсультируйтесь с администратором сервера QUIK насчет правильности настроек системы и выбора провайдера.

    «Connection reset by peer» (Потеряно соединение с сервером)

    • Соединение с сервером потеряно. Попытайтесь установить связь снова.
    • Произошло автоматическое отключение пользователей по окончании торгов.

    «Невозможно записать настройки соединения в файл настроек <путь к файлу>info.ini»

    • Файл имеет атрибут «Только для чтения». Уберите этот атрибут у файла.
    • Пользователь не имеет права на запись в директорию, где установлена программа. Попросите системного администратора разрешить запись в указанную директорию.
    • Файл занят другой программой. Убедитесь, что файл info.ini не открыт в какой-либо программе, например, текстовом редакторе.

    Программа запускается, но затем выдает ошибку и прекращает работу

    • Произошло нарушение целостности принятых данных. Необходимо удалить файл info.log из директории с установленной системой QUIK и запустить программу заново.
    • Произошло некорректное обновление версии программы. Необходимо восстановить предыдущее состояние системы. В рабочей директории системы QUIK найдите директорию «BACKUP». В ней расположены поддиректории с именами формата «ДДММГГГГ», где «ДД» – число, «ММ» – месяц, а «ГГГГ» – год даты обновления. Выберите директорию с датой последнего обновления и скопируйте все файлы из нее в рабочую директорию QUIK, после чего запустите программу заново.
    • Произошел сбой в работе системы. Обратитесь к администратору системы QUIK.

    «Терминал будет отключен через N секунд»

    • Пользователь был неактивен при включенной настройке «Отключаться по истечении заданного периода бездействия». Для продолжения работы нажмите кнопку «ОК» в открывшемся окне, иначе по истечении времени соединение с сервером будет разорвано и откроется окно сообщений:

      Соединение с сервером QUIK можно настроить только вручную.


Приложение 2

Пример получения сертификата через web-интерфейс удостоверяющего центра

  1. Откройте Internet Explorer (корректная работа по получению сертификата гарантирована только в данном браузере).
  2. Вставьте в строку адреса ссылку, полученную от брокера. В открывшемся окне для выбора задач отметьте галочками значения, указанные на скриншотах:

    Установите сертификат удостоверяющего центра с помощью мастера импорта сертификатов, выбрав хранилище «Доверенные корневые центры сертификации».
  3. Сертификат удостоверяющего центра установлен. Далее установите сертификат клиента:

    Отметьте галочками значения, указанные на скриншотах:

    В данном окне нажмите кнопку Browse и укажите путь к сформированному запросу на сертификат. В случае если браузер сообщает о недопустимости подобного действия из-за соображений политики безопасности, то содержимое файла запроса на сертификат можно просто скопировать в соответствующую форму:

    В появившемся окне выберите «Download CA certificate», после чего сертификат безопасности будет сохранён в указанном пользователем месте.


Раздел 2. Основные принципы работы с программой

  • Структура данных
  • Интерфейс программы
  • Общие фильтры
  • Быстрый поиск инструмента
  • Заказ данных
  • Экранные вкладки
  • Работа с окнами
  • Таблицы
  • Системные сообщения
  • Настройки Рабочего места QUIK
  • Изменение языка интерфейса
  • Сохранение/восстановление конфигурации из файла
  • Редактор горячих клавиш
  • Приложение


Структура данных

  • Выбор данных из класса с помощью фильтра
  • Выбор данных из класса с помощью раскрывающихся списков

    • Система QUIK позволяет получать информацию с нескольких секторов рынка (разные биржи, режимы торгов и т.д.). Ценные бумаги, индексы и прочие понятия, характеризующие уникальный вид данных, обобщенно именуются финансовыми или биржевыми инструментами. Однотипные данные, относящиеся к одному сектору рынка, группируются в классы инструментов.

    Пример классов:

    Акции 1-го уровня Московской Биржи, Облигации 1-го уровня Московской Биржи,
    Индексы Московской Биржи.

    Класс инструментов содержит список инструментов - перечень ценных бумаг или индексов. Список инструментов соответствует списку (листингу) бумаг в данном секторе рынка.

    Пример списка инструментов:

    Ростелеком, ЛУКОЙЛ, Сбербанк-п.

    Каждый класс инструментов имеет список параметров, характеризующих ход торгов по его инструментам.

    Пример списка параметров:

    Лучшая цена спроса, Спрос по лучшей цене, Количество заявок на покупку.

    Для исключения из списка ненужных значений предназначены фильтры . Исключенные (отфильтрованные) значения не отображаются в таблицах.

    Правила работы с классами

    Выбор элементов в классе осуществляется с помощью фильтров или раскрывающихся списков.

    Выбор данных из класса с помощью фильтра

    Выбор осуществляется нажатием на выбранном классе клавиши «пробел» либо левой кнопки мыши. Повторное нажатие приводит к отказу от выбора класса. Для выбора данных внутри класса используйте фильтр.

    Статусы выбора для классов:

    • - выбраны все элементы списка, фильтр не установлен;
    • - с помощью фильтра отобрано несколько элементов из списка;
    • - ни один элемент из списка не выбран

    При отказе от класса, по которому был установлен какой-либо фильтр, сброс настроек фильтра не происходит. Если класс будет снова выбран, фильтр активизируется. Чтобы отменить фильтр по классу, снимите на нем отметку [image] (флажок) либо очистите в настройках фильтра список выбранных параметров.

    Нажатием кнопки «Выделить все» выбираются все классы из списка доступных. При этом если по каким-либо классам уже установлены фильтры по инструментам и/или параметрам, то настройки фильтров сохраняются.

    Нажатием кнопки «Очистить» снимается выделение по всем классам. Если какой-либо из классов содержит настроенный фильтр, то при выборе данного класса фильтр активируется.

    Выбор данных из класса с помощью раскрывающихся списков

    Классы в раскрывающемся списке помечены символом «+», если список свернут, или символом «–», если список раскрыт. Для отображения списка инструментов выбранного класса, нажмите на классе клавишу «пробел» либо левую кнопку мыши на символе «+». Повторное нажатие приводит к сворачиванию списка.

    Выбор данных из класса осуществляется переносом выделенных параметров из списка доступных (слева) в список выбранных (справа) с помощью кнопок «Добавить», «Добавить все», «Убрать», «Очистить». Перенос параметров также осуществляется двойным нажатием левой кнопки мыши.

    Если это предусмотрено типом таблицы, список выбранных параметров можно упорядочить, выделив параметр и перемещая его по списку кнопками «вверх» и «вниз».

    Чтобы выделить сразу несколько параметров по порядку, держите нажатой клавишу «Shift». Чтобы выделить выборочно несколько параметров, удерживайте нажатой клавишу «Ctrl».


Интерфейс программы

  • Меню программы
  • Панель инструментов
  • Контекстное меню
  • Экранные вкладки
  • Строка состояния
  • «Горячие клавиши»

    • Основными элементами интерфейса терминала системы QUIK являются:

    1. Меню программы. Через меню осуществляется доступ ко всем функциям программы. Перечень пунктов меню и их назначение приведены в Приложении.
    2. Панель инструментов, на которой сосредоточены кнопки для быстрого доступа к наиболее часто используемым функциям.
    3. Контекстное меню, открывающееся нажатием правой кнопки мыши на каком-либо окне программы. Контекстное меню содержит перечень основных операций, которые можно выполнять с этим окном.
    4. Строка состояния. В ней отображается следующая системная информация:
      • время сервера;
      • текущее количество записей таблицы «Текущие торги», загруженных на сервер и отображаемых у конкретного клиента в терминале;
      • IP-адрес;
      • состояние соединения с сервером и дата.
    5. Вкладки. Предназначены для группировки окон программы и быстрого переключения между ними.
    6. Таблицы для отображения данных, получаемых с сервера.
    7. Диалоги - окна программы, предназначенные для ввода параметров пользователем. Например, окно настроек или ввода заявки.
    8. Графики. С помощью графиков отображается динамика изменения рыночных показателей.

    Меню программы

    Меню программы предназначено для доступа ко всем функциям программы. Набор пунктов меню зависит от прав пользователя системы QUIK на доступ к информации и совершение операций. Например, пункт «Новости» будет доступен в том случае, если пользователю разрешено получение новостей.

    В Руководстве пользователя вызов пунктов меню отображается жирным шрифтом, через косую черту (слеш). Например, фраза Система/Соединения... означает, что нужно выбрать пункт «Соединения...» в меню «Система».

    Панель инструментов

    Панель инструментов предназначена для быстрого доступа к основным функциям программы. Она представляет собой набор из нескольких панелей, которые можно включать/выключать и перемещать по экрану и располагать в несколько рядов. Чтобы включить панель, наведите курсор на панель и нажмите правую кнопку мыши – откроется контекстное меню со списком доступных панелей. Выбор нужной панели осуществляется нажатием левой кнопки мыши. Также настройку панелей можно выполнить из пункта меню программы Система/Настройки/Основные настройки..., раздел «Программа» / «Панели инструментов».

    Если все панели инструментов отключены, то контекстное меню не открывается, и включение панелей возможно только через меню программы.

    Значки на панели инструментов могут быть крупными либо мелкими (например, [image] или [image]). Большие кнопки лучше видны, но мелкие кнопки занимают меньше места на экране. Переключение размера выполняется из пункта меню программы Система/Настройки/Основные настройки..., раздел «Программа» / «Панели инструментов», флажок «Большие кнопки».

    Назначение каждой из кнопок подсвечивается подсказкой при наведении курсора на кнопку. Перечень панелей инструментов Рабочего места QUIK и их назначение приведены в таблице:

    Панель | Назначение
Картинка в углу | Анимированный индикатор «поезд» , отображающий поступление данных с сервера
Стандартная | Установление/разрыв связи, настройка таблиц, графиков, управление заявками
Окно сообщений | Просмотр сообщений программы , переход между сообщениями
Общий фильтр клиентов | Включение/отключение в таблицах фильтра по указанному коду клиента
Общий фильтр рынков | Включение/отключение в таблицах фильтра по классу инструментов
Свои таблицы | Открытие таблиц с информацией по позициям, заявкам и сделкам пользователя
Поиск инструмента | Быстрый поиск инструментов среди всех доступных инструментов и открытие таблиц и графиков с информацией по найденным инструментам
График | Управление окном графика, добавление индикаторов, трендов, масштабирование

    Назначение кнопок на панели см. в п. Назначение элементов Панели управления.

    Контекстное меню

    Контекстное меню позволяет настроить окно программы, а также вызвать другое окно, используя параметры в выбранной ячейке таблицы.

    Контекстное меню может быть вызвано одним нажатием правой кнопки мыши. Двойное нажатие правой кнопки мыши используется в некоторых окнах для быстрого вызова функций (открытие графика, снятие заявки). Настройка реакции программы на нажатие правой кнопки мыши осуществляется через пункт меню Система/Настройки/ Основные настройки..., раздел «Программа» / «Контекстное меню», пункт «Правая клавиши «мыши».

    Для вызова контекстного меню без мышки используется комбинация клавиш «Shift» + «F10» или специальная клавиша на клавиатуре, расположенная между клавишами «Win» и «Ctrl».

    Экранные вкладки

    Экранные вкладки предназначены для удобства расположения большого количества открытых окон и быстрого переключения между ними. Вкладки представляют собой «ярлычки» с названиями, которые можно расположить сверху или снизу от рабочей области программы. К каждой вкладке можно привязать одно или несколько окон, которые отображаются на экране только при выборе ярлычка данной вкладки.

    Подробное описание работы с вкладками читайте в п. Экранные вкладки.

    Строка состояния

    Строка состояния отображает состояние различных параметров программы: наличие связи с сервером, адрес сервера, получение данных, новых сообщений, настроенных оповещений, валюту цен. Отображение строки состояния включается/отключается через пункт меню Система/Настройки/ Основные настройки..., раздел «Программа», флажок «Строка состояния».

    «Горячие клавиши»

    Многие функции программы можно вызвать, нажав определенную комбинацию клавиш, называемых «горячими клавишами». Если для вызова функции нужно нажать одновременно две или больше клавиш, то в тексте Руководства пользователя нужные клавиши указываются через знак «+» (плюс), например «Ctrl»+«Q» (нажать «Ctrl» и «Q»). Для настройки комбинаций горячих клавиш есть специальный редактор. Он доступен из главного меню Система/Настройки/ Редактор горячих клавиш… или вызывается комбинацией «Ctrl»+«H». Перечень используемых сочетания клавиш и их назначение см. в Приложении.


Общие фильтры

  • Настройка общих фильтров
  • Фильтр по коду клиента/фамилии
  • Фильтр по классу инструментов/рынку

    • Общие фильтры – функция программы, предназначенная для одновременной настройки фильтров во всех таблицах программы, либо открытых на текущей вкладке. Функция может быть полезна для выполнения следующих задач:

    • Быстрая настройка группы таблиц заявок, сделок и позиций на отображение информации по заданному клиенту.
    • Быстрая перенастройка таблиц на отображение информации с одного счета либо идентификатора фирмы на другой.

    Вызов функции осуществляется из пункта меню Сервисы/Общие фильтры... или нажатием сочетания клавиш «Ctrl»+«G».

    Настройки общих фильтров сохраняются в файл конфигурации (*.wnd), в том числе при закрытии программы. При чтении файла конфигурации (например, при запуске программы) настройки фильтров будут загружены и доступны для редактирования в окне «Установка общих фильтров».

    Настройка общих фильтров

    1. Установка фильтра. Нажмите кнопку «…» справа от названия фильтра и сформируйте список выбранных значений. Нажмите кнопку «Да» для сохранения изменений. Выберите из списка действий с фильтром значение «Установить». При нажатии кнопки «Применить» настройки соответствующих фильтров в таблицах меняются на заданные.

      Установка фильтра с пустым списком выбранных параметров равносильна снятию фильтра.
    2. Снятие фильтра . Выберите из списка действий с фильтром значение «Снять». Нажатием кнопки «Применить» отключаются соответствующие фильтры в таблицах.
    3. Если в списке действий фильтра выбрано значение «Не изменять», то настройки данного фильтра при нажатии кнопки «Применить» не меняются.
    4. «Применять к окнам на всех вкладках» – если флажок установлен, то изменение настроек фильтров применяется ко всем таблицам Рабочего места QUIK. Если флажок снят, то меняются фильтры таблиц только на текущей вкладке.

    Кнопка «Отмена» закрывает окно без выполнения операций над фильтрами.

    Фильтр по коду клиента/фамилии

    Общий фильтр по коду клиента может быть вынесен на панель инструментов программы. Для этого выберите в контекстном меню панели инструментов пункт «Общий фильтр клиентов».

    Кнопка [image] «Подставлять код клиента из фильтра в формы подачи заявок» работает по принципу переключателя и может быть в состоянии «Включена», если она нажата и «Выключена» - в противном случае. Положение кнопки сохраняется в файл конфигурации (*.wnd) и восстанавливается после запуска программы.

    1. Если кнопка включена и «Общий фильтр клиентов» вынесен на панель инструментов программы, то заполнение кодов клиентов и торговых счетов в формах подачи заявок происходит следующим образом:
      • При вводе заявки для фьючерсов и опционов, значение из фильтра подставляется в поле «Торговый Счет», поле «Поручение» заполняется значением, указанным в файле настроек автоподстановки (см. Настройка автозаполнения полей ввода заявки). Поле «Код Клиента» не заполняется.
        При вводе маклерской заявки для фьючерсов и опционов с мультиброкерского Рабочего места значение из фильтра подставляется в поле «Торговый Счет», поле «Организация» заполняется значением идентификатора фирмы, соответствующей данному торговому счету.
      • Для остальных форм ввода заявок значение из фильтра заполняет поле «Код Клиента». Поле «Поручение» заполняется значением, указанным в файле настроек автоподстановки (см. Настройка автозаполнения полей ввода заявки).
    2. Если кнопка отключена и/или фильтр отсутствует на панели инструментов, то на заполнение полей в формах подачи заявок данный фильтр не влияет.

    Если текстовое поле фильтра заполнено одним из кодов клиентов, то во всех таблицах на данной вкладке включается фильтр клиентов по этому коду. Благодаря этому можно устанавливать разные фильтры на разных вкладках. Если при выборе кода клиента удерживать нажатой клавишу «Shift», то фильтр применится ко всем вкладкам.

    В списке клиентов указаны коды клиентов или их фамилии (если включен режим замены, подробнее см. Описание клиентов и рынков) в алфавитном порядке. Предусмотрен контекстный поиск, то есть для поиска нужного клиента достаточно набрать в окне первые символы из его кода или фамилии, и курсор перемещается на строку списка с совпадающими символами.

    Для снятия фильтра выберите из списка значение <Не указан> или нажмите на кнопку [image].

    1. Функция общего фильтра по коду клиента «Подставлять код клиента из фильтра в формы подачи заявок» имеет приоритет перед параметром «Значение по умолчанию» / «Код клиента» в Настройках ввода заявки и Автозаполнением кода клиента из файла.
    2. Установка или снятие этого фильтра заменяет настройки Фильтра клиентов в таблицах и не влияет на работу фильтров по другим параметрам.
    3. В момент выбора общего фильтра произойдет изменение Фильтра клиентов во всех таблицах, отображаемых «на всех вкладках».
    4. Действие общего фильтра распространяется на вновь создаваемые таблицы.

    Фильтр по классу инструментов/рынку

    Общий фильтр по классу инструментов (рынку) может быть вынесен на панель инструментов программы. Для этого выберите в контекстном меню панели инструментов пункт пункт «Общий фильтр рынков».

    В фильтре содержится список доступных классов инструментов. Если выбран один из классов, то во всех таблицах на данной вкладке отображаются значения, соответствующие выбранному классу. Благодаря этому можно устанавливать разные фильтры на разных вкладках. Если при выборе класса инструментов удерживать нажатой клавишу «Shift», то фильтр применяется ко всем вкладкам.

    В разворачивающемся списке указаны классы инструментов или названия рынков (если найден файл с описаниями markets.ini, подробнее см. Описание клиентов и рынков) в алфавитном порядке. Предусмотрен контекстный поиск, то есть для поиска нужного класса инструментов и рынка, достаточно набрать в окне первые символы его названия, и курсор перемещается на строку списка с совпадающими символами.

    Для снятия фильтра выберите из списка значение <Не указан> или нажмите на кнопку [image] .


Быстрый поиск инструмента

  • Назначение
  • Формат окна
  • Настройка окна
  • Доступные функции

    • Назначение

    Быстрый поиск инструмента предназначен для упрощения доступа к информации по какому-либо инструменту.

    Окно поиска инструмента открывается двумя способами:

    • С помощью специальной панели, находящейся на панели инструментов: .

      Нажмите кнопку [image] или введите в поле часть названия либо кода инструмента и нажмите клавишу «Enter».

    • С помощью комбинации клавиш «Ctrl»+«Shift»+«F». В открывшемся окне уточняются критерии поиска.

    Формат окна

    Окно поиска инструмента представляет собой таблицу со списком найденных инструментов:

    На экране может отображаться только одно окно поиска инструмента. Данные в таблице обновляются по каждому новому запросу на поиск инструмента.

    Инструменты, которые уже получены с сервера QUIK, имеют стандартное отображение в таблице. Доступные инструменты (инструменты, которые находятся в справочнике доступных инструментов и открыты для дозаказа с сервера QUIK) отображаются в таблице серым цветом шрифта.

    В столбцах таблицы отображаются следующие параметры:

    Название поля | Значение
    * Краткое название | Краткое наименование инструмента
    * Полное название | Полное наименование инструмента
    * Код инстр-та | Биржевой идентификатор, присвоенный инструменту
    * Название класса | Наименование класса инструментов
    * Код класса | Идентификатор класса в торговой системе
    Получен Признак того, что инструмент получен с сервера QUIK. Возможные значения:
    • «Да» – инструмент получен с сервера QUIK;
    • «» (пусто) – инструмент из справочника доступных инструментов
    * Размер лота | Минимально допустимое количество инструмента в одной заявке, штук
    * Дата погашения | Дата погашения (для инструментов с фиксированным сроком обращения)
    * ISIN | ISIN-код инструмента
    * Рег. номер | Идентификатор инструмента
    * CFI | CFI-код инструмента
    Stockcode | Биржевой тикер инструмента
    RIC | RIC-код инструмента
    CUSIP | CUSIP-код инструмента
    SEDOL | SEDOL-код инструмента
    LocalCode | Локальный код инструмента
    StockName | Код деривативного контракта в формате системы QUIK
    Bloomberg ID | Идентификатор инструмента в Bloomberg
    Сложный продукт Тип сложного финансового продукта. Возможные значения:
    • «-100» – без ограничений;
    • «-1» – не попадает под тесты из Базового стандарта, недоступно для неквалифицированных инвесторов, не прошедших тестирование;
    • «0» – предназначено для квалифицированных инвесторов согласно 39-ФЗ или эмиссионным документам;
    • «4» – структурные облигации, не предназначенные для квалифицированных инвесторов;
    • «5» – инвестиционные паи закрытых паевых инвестиционных фондов, непредназначенных для квалифицированных инвесторов;
    • «6» – облигации российских эмитентов, которым не присвоен кредитный рейтинг, либо кредитный рейтинг которых ниже установленного уровня;
    • «7» – облигации иностранных эмитентов, обязательства по которым исполняются за счет юридического лица, созданного в соответствии с законодательством РФ, не имеющего кредитный рейтинг, либо кредитный рейтинг которого ниже установленного уровня;
    • «8» – облигации со структурным доходом;
    • «9» – акции, не включенные в котировальные списки;
    • «10» – иностранные акции, требующие проведения тестирования;
    • «11» – сделки по приобретению паев иностранных ETF, требующие проведения тестирования;
    • «800» – облигации, запрещенные к приобретению с 01.10.2021 до 01.04.2024 для инвесторов, успешно прошедших тестирование по тесту 8

    * - параметры, выбранные по умолчанию

    Настройка окна

    Для выполнения действий с результатами поиска таблица имеет собственную панель инструментов. Назначения кнопок:

    Кнопка | Назначение
 | Добавить инструмент в Таблицу текущих торгов. Если таблицы нет, то она будет создана
 | Построить график цены и объема сделок по инструменту
 | Открыть Таблицу котировок с очередями лучших заявок по инструменту
 | Открыть Таблицу обезличенных сделок, отфильтрованную по данному инструменту
 | Открыть окно с информацией по данному инструменту

    Поле [image] предназначено для корректировки параметров поиска:

    • Для изменения инструмента введите в поле часть названия либо кода инструмента и нажмите кнопку [image] либо клавишу «Enter».
    • Для очищения строки поиска нажмите кнопку [image].
    • Для выбора критериев поиска нажмите кнопку [image]. Доступны следующие критерии:

      Стандартный поиск по параметрам:

      • «По названию инструмента»;
      • «По коду инструмента»;
      • «По ISIN»;
      • «По гос. рег. номеру»;
      • «По названию класса»;
      • «По коду класса»;
      • «По CFI»;
      • «По тикеру инструмента»;
      • «По RIC»;
      • «По CUSIP»;
      • «По SEDOL»;
      • «По Local code»;
      • «По BSID» –идентификатор инструмента в Bloomberg;
      • «По Stock name».

      Поиск во внешнем справочнике – поиск инструментов во внешнем справочнике.

      Выбранные критерии помечаются установленным флажком. Если выбраны не все критерии, то кнопка [image] меняется на [image]. Должен быть выбран хотя бы один из критериев.

      При нажатии кнопки «Применить» данные в таблице обновляются в соответствии с выбранными критериями поиска. Нажатие кнопки «Отмена» закрывает панель выбора критериев без сохранения изменений.

      Доступные функции

      Данные таблицы доступны для копирования и вывода через DDE-сервер.

      Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

      1. «Текущие торги» * – добавить инструмент в Таблицу текущих торгов. Если таблицы нет, то она будет создана.
      2. «Графики цены и объема» – построить график цены и объема сделок для инструмента.
      3. «[<Класс>] <Наименование инструмента>» (или двойное нажатие левой кнопкой мыши на строке таблицы) – открыть Таблицу котировок с очередями лучших заявок по инструменту.
      4. «Таблица обезличенных сделок» – открыть Таблицу обезличенных сделок, отфильтрованную по данному инструменту.
      5. «Информация об инструменте» (или «Alt»+«I») – открыть окно информации об инструменте.
      6. «Получить» (или двойное нажатие левой кнопки мыши) * – заказать инструмент с сервера QUIK, по указанному в строке классу. При заказе инструмента у пользователя запрашивается подтверждение на выполнение операции. Результат выполнения операции:
        • Заполняются ключевые параметры инструмента;
        • Значение в поле «Получен» изменяется на «Да»;
        • Цвет шрифта строки изменяется на стандартный;
        • Для инструмента становятся доступными остальные пункты контекстного меню таблицы.
          Функция предназначена только для доступных к дозаказу с сервера QUIK инструментов.
      7. «Очистить результаты поиска» – очистить таблицу поиска по инструменту.
      (*) Операции могут выполняться для нескольких выделенных строк. Чтобы выделить сразу несколько инструментов по порядку, держите нажатой клавишу «Shift». Чтобы выделить выборочно несколько инструментов, держите нажатой клавишу «Ctrl». Если для команды «Текущие торги» в диапазон выделенных строк попадают инструменты, которые еще не заказаны с сервера QUIK (доступные инструменты), то для них команда не выполняется. Если для команды «Получить» в диапазон выделенных строк попадают уже полученные с сервера QUIK инструменты, то для них команда не выполняется.

      Дополнительно:

      • Описание стандартных функций контекстного меню для таблиц.
      • Описание применения быстрого фильтра.
      • Описание применения пользовательских фильтров и условного форматирования таблиц.
      • Полный список управляющих клавиш для всех типов таблиц.


Заказ данных

  • Перезаказ данных
  • Замена инструментов
  • Склейка архивов графиков

    • Руководство пользователя QUIK © ARQA Technologies / www.arqatech.com/ru/products/quik/


Перезаказ данных

меню Система / Заказ данных / Перезаказать данные…

Выбор типа данных, которые необходимо перезаказать:

  1. «Торговые данные текущей сессии» – очистить архив торговых данных и заказать заново данные с сервера.
    • «Локальные справочники» – очистить архив локальных справочников и заказать заново данные с сервера.
  2. «Архив данных для построения графиков» – очистить архив графиков и заказать заново данные с сервера.
    ВАЖНО! На Рабочем месте QUIK хранится до 65000 свечей. При перезаказе архива графиков с сервера QUIK загружается не более 3000 свечей, остальные свечи, хранившиеся на Рабочем месте QUIK, удаляются.

См. также Структура данных.


Замена инструментов

меню Система / Заказ данных / Замена инструментов

Замена инструментов с истекающим сроком обращения на инструменты с аналогичными параметрами (класс, базовый актив), но более поздней датой погашения.

Проверка инструментов с коротким периодом обращения (фьючерсы, опционы) выполняется за указанное количество дней в настройке «За … дней до погашения». Для формирования сообщений с предложением о замене инструментов необходимо включить настройку «Предлагать замену инструментов с истекающим сроком обращения».

Проверка инструментов выполняется во время загрузки WND-файла настроек на основании открытых таблиц, графиков цены и объема, графиков по параметру.

Диалог «Инструменты с наступающим сроком погашения» содержит следующие параметры:

  1. «Выберите инструменты для замены в таблицах и графиках» – список инструментов с истекающим сроком погашения. В столбцах таблицы отображаются следующие параметры:
    Название поля | Значение
    Выбор инструмента для замены в таблицах и графиках. При выключенном флажке замена инструмента не производится. По умолчанию флажок включен
    Инструмент | Наименование инструмента, подлежащего замене
    Код класса | Код класса, в котором находится заменяемый инструмент
    Новый инструмент | Наименование инструмента, выбранного для замены
    Склейка Признак склейки архивов графиков. Возможные значения:
    • «Да» – флажок «Склейка архивов графиков» включен;
    • «Нет» – флажок «Склейка архивов графиков» выключен

    Сведения в таблице обновляются после подключения к серверу QUIK.

  2. Слева в диалоге отображаются информационные поля, содержащие данные по выбранному в таблице инструменту с наступающим сроком погашения:
    • «Инструмент» – наименование инструмента;
    • «Инструмент сокр.» – краткое наименование инструмента;
    • «Дата погашения» – дата погашения инструмента.
  3. Справа отображаются поля, содержащие данные по инструменту, выбранному для замены:
    • Поле со списком «Новый инструмент» – наименование инструмента. Список содержит перечень инструментов, у которых класс и базовый актив совпадают с заменяемым инструментом. Инструменты в списке сортируются по возрастанию срока погашения;
    • «Инструмент сокр.» – краткое наименование инструмента;
    • «Дата погашения» – дата погашения инструмента.
  4. Флажок «Склейка архивов графиков» – признак необходимости проведения склейки графиков, см. Склейка архивов графиков .

Для замены инструментов нажмите кнопку «Заменить», В таблицах и табличных фильтрах, графиках, фильтрах заказа потока котировок и потока обезличенных сделок (пункт меню Система/Заказ данных) старые инструменты будут заменены новыми.

Замена инструментов НЕ выполняется в следующих таблицах:
  • «Позиции по клиентским счетам»;
  • «Доска опционов»;
  • «Обязательства ММ по фондовому и валютному рынкам»;
  • «Расширенные обязательства ММ по фондовому и валютному рынкам»;
  • «Обязательства маркет-мейкера по срочному рынку»;
  • «Позиции участника по инструментам»;
  • «Позиции участника по торговым счетам».

Если у заменяемого инструмента настроен экспорт в системы технического анализа, то тикер данного инструмента не заменяется.


Склейка архивов графиков

меню Система / Заказ данных / Склейка архивов графиков

Объединение («склейка») графиков автоматически заменяемых инструментов с коротким периодом обращения (фьючерсы).

Если заменяемый инструмент находится в обращении, то при склейке на графике отображаются все свечи по заменяемому инструменту, за исключением свечей за текущую торговую сессию, и свечи по заменяющему инструменту, начиная с текущей торговой сессии.
Если заменяемый инструмент вышел из обращения, то при склейке на графике отображаются все свечи по заменяемому инструменту, а также все имеющиеся свечи по заменяющему инструменту, начиная с даты, следующей за датой погашения заменяемого инструмента.

Диалог «Склейка архивов графиков» содержит следующие параметры:

  1. «Класс» – код класса заменяемого инструмента.
  2. «Инструмент» – наименование заменяемого инструмента.
  3. «Дата погашения» – дата погашения заменяемого инструмента.
  4. «Новый инструмент» – наименование заменяющего инструмента.
  5. «Дата погашения» – дата погашения заменяющего инструмента.

Чтобы склеить графики, нажмите кнопку «Выполнить».


Экранные вкладки

меню Окна / Показать вкладки

меню Окна / Убрать вкладки

  • Доступные функции
  • Функции, доступные из контекстного меню вкладки

    • Для оптимизации рабочего пространства системы QUIK предусмотрена возможность группировки окон с помощью экранных вкладок. Вкладка представляет собой ярлык на специальной панели вкладок. Нажатие левой кнопкой мыши на ярлык вкладки делает видимой связанную с ним группу окон. При этом окна, относящиеся к другим вкладкам, становятся невидимыми.

    Часть окон программы могут быть не включены пользователем в какую-либо группу. Такие окна видны на любой вкладке.

    Для изменения порядка вкладок воспользуйтесь режимом «drag-and-drop»: перемещайте ярлык вкладки, удерживая нажатой левую кнопку мыши.

    Доступные функции

    • «Ctrl» + «G» - настроить Общие фильтры для всех таблиц на вкладке.
    • «Alt» + «1» .. «Alt» + «9» - переключиться на вкладку с соответствующим порядковым номером.
    • Двойное нажатие левой кнопки мыши на ярлыке вкладки – изменение названия вкладки.

    Функции, доступные из контекстного меню вкладки

    Функции контекстного меню доступны при нажатии правой кнопкой мыши на ярлык вкладки:

    1. «Добавить» – создание новой вкладки. Новая вкладка с названием «Вкладка <N>» добавляется в конец списка существующих вкладок. «N» – порядковый номер вкладки.
    2. «Переименовать» – изменение названия выделенной вкладки.
    3. «Удалить» – удаление выделенной вкладки. Все окна, расположенные на удаляемой вкладке, закрываются. Последнюю существующую вкладку удалить нельзя.

      Если включена настройка «Запрашивать подтверждение при перемещении и удалении объектов с помощью drag-and-drop», то у пользователя запрашивается подтверждение на удаление данной вкладки.
    4. «Показать сверху» – расположение панели вкладок сверху или снизу относительно рабочего пространства программы. Если вкладки располагаются сверху, то данный пункт контекстного меню помечается символом «v».
    5. «В один ряд» – расположение панели вкладок в один ряд или несколькими рядами в случае, когда вкладки не помещаются в одну строку. Если вкладки располагаются в один ряд, то используются кнопки прокрутки видимых вкладок вправо и влево, и данный пункт контекстного меню помечается символом «v».
    6. «Закрепить окна» – зафиксировать размер и расположение окон на выделенной вкладке. Не действует на окна, видимые на всех вкладках.
    7. «Освободить окна» – отключить фиксацию размера и расположения окон на выделенной вкладке. Не действует на окна, видимые на всех вкладках.
    8. «Убрать заголовок» – отключить отображение строки с заголовком для всех окон на выделенной вкладке. Не действует на окна, видимые на всех вкладках.
    9. «Показать заголовок» – включить отображение строки с заголовком для всех окон на выделенной вкладке. Не действует на окна, видимые на всех вкладках.
    10. «Список окон» – список окон, отображаемых на выделенной вкладке, в алфавитном порядке. Выбор определенного значения из списка активирует соответствующее окно.
    11. «Сохранить вкладку в файл» – сохранить выделенную вкладку и расположенные на ней окна в указанный файл. Файл имеет расширение .TAB и содержит информацию об одной сохраненной вкладке (включая фильтр по коду клиента, заданный для данной вкладки) и об окнах, которые в момент сохранения файла были расположены на данной вкладке. Окна, видимые на всех вкладках, в файл не сохраняются.
    12. «Загрузить вкладку из файла» – при загрузке файла сохраненная в нем вкладка с окнами добавляется в список существующих вкладок. Если в момент загрузки вкладки из файла в терминале существует окно или вкладка с совпадающим наименованием, то она переименовывается в соответствии с правилами переименования совпадающих названий в терминале (например, вторая «Вкладка1» переименовывается во «Вкладка1 #2»).


Работа с окнами

  • Настройка расположения окон
  • Вынесенные окна
  • Менеджер окон

    • Руководство пользователя QUIK © ARQA Technologies / www.arqatech.com/ru/products/quik/


Настройка расположения окон

меню Окна

Для оптимизации рабочего пространства предусмотрена возможность настройки отображения окон на экране.

Значения пунктов меню:

  1. «Закрепить окно» (или «Alt»+ «L») – зафиксировать размер и расположение активного окна.
  2. «Убрать заголовок» (или «Alt»+ «B») – отключить отображение строки с заголовком для активного окна.
  3. «Поверх всех окон» (или «Alt»+ «T») – расположить активное окно поверх всех остальных окон.
  4. «Переместить окно на вкладку» – отображает список вкладок. Перенос окна на вкладку осуществляется выбором названия нужной вкладки. Выбором пункта «Показывать на всех» отменяется привязка окна к текущей вкладке, и окно отображается на всех вкладках.
  5. «Убрать вкладки» (или «Ctrl»+ «B») – скрыть все вкладки.
  6. «Показать вкладки» (или «Ctrl»+ «B») – показать все вкладки.
  7. «Стопкой» * – расположить окна по порядку, одно над другим.
  8. «Колонками» * – расположить окна равномерно по горизонтали.
  9. «Рядами» * – расположить окна равномерно по вертикали.
  10. «Выровнять значки» – упорядочить свернутые в значки окна внизу экрана.
  11. «Закрыть все» – закрыть все окна.
  12. «Менеджер окон» (или «Alt»+ «M») – открыть таблицу «Менеджер окон».
(*) Настройка не изменяет положение окон с установленным признаком «Поверх всех окон».
Когда из двух открытых окон одно развернуто на весь экран, при его закрытии второе окно разворачивается на весь экран автоматически.


Менеджер окон

меню Окна / Менеджер окон

  • Назначение
  • Формат таблицы
  • Параметры настройки таблицы
  • Доступные функции

    • Назначение

    Таблица «Менеджер окон» содержит список всех открытых окон.

    Таблица всегда отображается поверх всех открытых окон. К таблице нельзя применить функции «Закрепить окно» и «Убрать заголовок», иконка таблицы отображается на панели задач ОС.

    Формат таблицы

    Каждая строка таблицы соответствует отдельному открытому окну. В столбцах таблицы отображаются следующие параметры:

    Название поля | Значение
    Название окна | Название окна
    Тип окна | Краткое описание типа окна
    Монитор | Номер монитора
    Вынесено Тип окна. Возможные значения:
    • «Да» – окно вынесено за пределы основного рабочего окна программы;
    • <пусто> – обычное окно
    Вкладка | Название вкладки
    Поверх всех окон | Признак отображения данного окна поверх всех открытых окон («Да»/<пусто>)
    Без заголовка | Признак отображения окна без заголовка («Да»/<пусто>)
    Закреплено | Признак фиксации размера и положения окна («Да»/<пусто>)
    Видимо в панели задач | Признак наличия иконки окна на панели задач («Да»/<пусто>)
    Excel экспорт Состояние экспорта по DDE. Возможные значения:
    • «Недоступен»;
    • «Запущен»;
    • «Остановлен»;
    • «Не настроен»
    ODBC экспорт Состояние экспорта по ODBC. Возможные значения:
    • «Недоступен»;
    • «Запущен»;
    • «Остановлен»;
    • «Не настроен»

    Параметры настройки таблицы

    1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

    Значения настроек сохраняются и подставляются при повторном открытии диалога.

    Доступные функции

    Функции, доступные для данной таблицы, могут быть вызваны из контекстного меню (нажатием правой кнопки мыши на таблице) либо нажатием соответствующей кнопки на панели инструментов таблицы:

    • «Активировать», кнопка [image] – активировать окно. Двойное нажатие левой кнопки мыши на строке с названием окна также позволяет активировать данное окно.
    • «Вынести», кнопка [image] – вынести окно за пределы основного рабочего окна программы.
    • «Закрепить окно», кнопка [image] – зафиксировать размер и положение окна.
    • «Поверх всех окон», кнопка [image] – располагать окно поверх всех открытых окон.
    • «Убрать заголовок», кнопка [image] – не отображать заголовок окна.
    • «Показать на панели задач», кнопка [image] – отображать иконку вынесенного окна на панели задач. Функция доступна только для вынесенных окон. Значение по умолчанию определяется настройкой «Показывать иконку вынесенного окна в панели задач».
    1. Чтобы выделить сразу несколько строк таблицы по порядку, удерживайте нажатой клавишу «Shift». Чтобы выделить выборочно несколько строк таблицы, удерживайте нажатой клавишу «Ctrl».
    2. При выделении нескольких строк таблицы функции контекстного меню применяются к тем из выделенных окон, к которым данная функция не была применена ранее.
    3. Для отмены определенной функции для нескольких строк таблицы: если хотя бы к одному из группы выделенных окон функция не была применена (соответствующая кнопка на панели инструментов не нажата, и в контекстном меню данная команда не отмечена флажком), то сначала необходимо применить функцию к группе выделенных окон, после чего становится доступной отмена функции для группы окон.

    См. также:

    • Описание стандартных функций контекстного меню для таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.


Вынесенные окна

Вынести окно за пределы основного рабочего окна программы можно одним из следующих способов:

  • Удерживая нажатой клавишу «Ctrl», перетащить окно с помощью мыши, держа за заголовок, за пределы основного рабочего окна программы. Во время перетаскивания курсор принимает вид руки.
  • Выбрать пункт контекстного меню «Вынести» в таблице «Менеджер окон» на строке с выбранным окном.
  • Нажать кнопку [image] на панели инструментов таблицы «Менеджер окон» для выделенной строки.

Отображение на панели задач иконки вынесенного окна определяется настройкой «Показывать иконку вынесенного окна в панели задач».

  1. При вынесении окно удаляется с вкладки, а при внесении окно прикрепляется к текущей активной вкладке.
  2. Вынесенное окно, раскрытое на весь размер монитора, внести обратно можно с помощью команды системного меню таблицы «Переместить на вкладку», либо с помощью функций «Менеджера окон».
  3. При наличии на экране открытого окна диалога возможно только изменение размера и положения вынесенных окон. Остальные функции для вынесенных окон в это время недоступны.
  4. Режим связанных окон доступен для вынесенных окон при включенной настройке «Связывать вынесенные окна» (пункт меню Система/Настройки/Основные настройки..., раздел «Окна»). При включении данной настройки отключается тема «Aero» на операционной системе Windows 7.


Дополнительные функции окон

При нажатии на иконку в верхнем левом углу окна доступен вызов контекстного меню со следующими возможными функциями:

  1. «Восстановить» – вернуть окно к предыдущему размеру.
  2. «Переместить» – переместить окно.
  3. «Размер» – изменить размер окна.
  4. «Свернуть» – скрыть окно с рабочего стола.
  5. «Развернуть» – развернуть окно на весь экран.
  6. «Закрыть» (или «Alt»+«F4») – закрыть окно.
  7. «Закрепить окно» (или «Alt»+«L») – зафиксировать размер и расположение окна.
  8. «Поверх всех окон» (или «Alt»+«T») – расположить окно поверх всех остальных окон.
  9. «Убрать заголовок» (или «Alt»+«B») – отключить отображение строки с заголовком для окна.
  10. «Переместить окно на вкладку» – отображает список вкладок. Перенос окна на вкладку осуществляется выбором названия нужной вкладки. Выбором пункта «Показывать на всех» отменяется привязка окна к текущей вкладке, и окно отображается на всех вкладках.


Таблицы

  • Настройка таблиц
  • Редактирование таблиц
  • Правила работы с фильтрами в таблице
  • Операции над таблицами

    • Все получаемые с сервера данные отображаются в виде таблиц. В строках таблиц отображаются инструменты, либо другие элементы списков в зависимости от типа таблицы (номера счетов, сделок и т.п.), в столбцах таблицы отображаются параметры элементов списка.

    Таблицы всех типов можно минимизировать (сворачивать в иконки), перемещать по экрану с помощью мыши, просматривать информацию в окне с помощью линеек прокрутки и использовать другие стандартные возможности работы с окнами в среде Windows.

    Помимо стандартных функций в системном меню таблиц (пункт меню Окна) доступны следующие настройки:

    • «Закрепить окно» – фиксируются размер и положение окна на определенном мониторе и на определенной вкладке.
    • «Поверх всех окон» – таблица отображается поверх всех открытых окон при любых перемещениях.
    • «Убрать заголовок» – отключается отображение строки с заголовком окна.
    • «Переместить на вкладку» – перенос окна на вкладку осуществляется выбором названия нужной вкладки. Выбором пункта «Показывать на всех» отменяется привязка окна к текущей вкладке, и окно отображается на всех вкладках.

    В таблицах помимо стандартного контекстного меню предусмотрен вызов контекстного меню столбцов таблицы.

    1. Любая таблица может объединять данные из разных классов инструментов. При этом классы инструментов могут иметь разные наборы параметров. Ячейки, относящиеся к классу, не содержащему выбранный параметр, остаются пустыми.
    2. В Рабочем месте QUIK можно создавать несколько таблиц одинакового типа для разных наборов данных. Создание нескольких одинаковых таблиц не влечет за собой увеличения объема информации, принимаемой с сервера.
    3. При выборе пункта меню Система/Заказ данных/Перезаказать данные... из всех таблиц и фильтров удаляются те инструменты, которые исчезли из торговой системы.

    Настройка таблиц

    В системе QUIK существует несколько типов таблиц, каждый из которых имеет особенности, однако принцип их настройки одинаков.

    1. Чтобы создать таблицу, выберите в меню программы соответствующий тип таблицы. Если требуется предварительная настройка, то откроется окно настройки таблицы выбранного типа.
    2. В поле «Имя таблицы» указывается заголовок таблицы. Как правило, заголовок доступен для редактирования. По умолчанию заголовок соответствует типу таблицы.
    3. Выбор параметров, отображаемых в столбцах и строках таблицы, осуществляется в соответствии с правилами работы с классами. Если в списке «Заголовки столбцов» выделен хотя бы один элемент, при нажатии кнопки «Добавить» элемент из списка «Доступные параметры» добавляется после выделенного элемента, иначе – в конец списка.
    4. Если в списке доступных параметров выделен хотя бы один элемент, при нажатии кнопки «Добавить» элемент из списка доступных добавится в список выбранных. При этом элемент в список выбранных добавляется в конец списка или, если в списке выбранных был выделен элемент, новый элемент добавится после выделенного. Очередность элементов в списке выбранных параметров можно менять с помощью кнопок со стрелками, расположенных справа - на одну позицию вверха/вниз или в начало/конец списка в зависимости от выбранной кнопки.
    5. В некоторых таблицах помимо выбора параметров возможно применение фильтра на значения параметров, например, отображение заявок только по определенному счету или только со статусом «Активна».

    Редактирование таблиц

    Чтобы отредактировать существующую таблицу, сделайте ее активной и нажмите кнопку [image] на панели управления, либо комбинацию клавиш «Ctrl»+«E». Команда «Редактировать таблицу» также доступна в контекстном меню операций с выбранной таблицей.

    Правила работы с фильтрами в таблице

    1. Для настройки фильтра нажмите кнопку «…» в диалоге редактирования таблицы.
    2. В открывшемся окне сформируйте список получаемых параметров, выделяя их поочередно среди доступных и нажимая кнопку «Добавить». Иной способ: нажать кнопку «Добавить все» и затем исключить ненужные, выделив их нажатием на кнопку «Убрать».
      Чтобы выделить сразу несколько параметров по порядку, держите нажатой клавишу «Shift». Чтобы выделить выборочно несколько параметров, держите нажатой клавишу «Ctrl».
    3. Для завершения формирования фильтра нажмите кнопку «Да».

    Настройки фильтров могут включать дополнительные свойства:

    • «Включать в фильтр выбранные» - означает, что в списке «Выбранные» задаются значения, разрешенные для отображения в настраиваемой таблице (по умолчанию),
    • «Исключать из фильтра выбранные» - означает, что в списке «Выбранные» задаются те значения, отображение которых необходимо отключить,
    • «Фильтровать по префиксу» - если признак выключен, то фильтр распространяется на точные совпадения значений с указанными в списке «Выбранные»; если признак включен, то фильтр распространяется на все значения, начинающиеся с указанных в фильтре комбинаций символов.

    Статусы фильтров:

    • - фильтр установлен,
    • - фильтр отменен.

    Чтобы отменить фильтр, нужно снять с него флажок [image] нажатием левой кнопки мыши, либо очистить список выбранных параметров в окне настройки фильтра.

    1. Список инструментов либо параметров может изменяться со временем, например, с включением в листинг биржи новых инструментов. Если по списку настроен фильтр, т.е. количество элементов в нем ограничено выбранными, то данные, относящиеся к новым инструментам в таблице не отображаются. Чтобы новые данные отображались, необходимо либо добавить их вручную в настроенный фильтр, либо в пункте меню Система/Настройки/Основные настройки… в разделе «Программа»/«Получение данных» включить флажок «Добавлять его во все таблицы».
    2. При выборе пункта меню Система/Заказ данных/Перезаказать данные… из всех фильтров и таблиц удаляются те инструменты, которые исчезли из торговой системы.

    Операции над таблицами

    В системе QUIK над таблицами можно выполнять следующие операции:

    • Контекстное меню столбцов
    • Вывод данных
    • Сортировка строк таблицы по значениям
    • Создание копии таблицы
    • Печать таблицы
    • Поиск значения в ячейках таблицы
    • Настройка шрифтов в таблицах
    • Настройка цвета в таблицах и графиках
    • Работа с таблицами в режиме «drag-and-drop»
    • Режим связанных окон
    • Контекстный фильтр в списках
    • Пользовательские фильтры
    • Быстрый фильтр
    • Условное форматирование таблиц


Операции над таблицами

  • Контекстное меню столбцов
  • Вывод данных
  • Сортировка строк таблицы по значениям
  • Создание копии таблицы
  • Печать таблицы
  • Поиск значения в ячейках таблицы
  • Настройка шрифтов в таблицах
  • Настройка цвета в таблицах и графиках

    • В таблицах («Клиентский портфель») назначение каждого столбца подсвечивается подсказкой при наведении курсора на заголовок.


Контекстное меню столбцов

В таблицах помимо стандартного контекстного меню предусмотрен вызов контекстного меню столбцов таблицы (которое вызывается при наведении курсора мыши на заголовок столбца и нажатии на правую кнопку мыши). Контекстное меню столбцов содержит перечень основных операций, которые можно выполнять с выбранным столбцом:

  • Сортировка строк таблицы по возрастанию либо убыванию значений в выбранном столбце.
  • Настройка фильтрации на столбец.
  • Настройка быстрого фильтра таблиц.
  • Настройка условного форматирования.
  • «Закрепить столбец» – закрепить положение столбца в таблице. При закреплении столбец всегда отображается слева и не уходит из области видимости при горизонтальной прокрутке. Можно закрепить одновременно несколько столбцов. При закреплении любого столбца в середине таблицы закрепляется весь диапазон столбцов от крайнего левого столбца до выбранного закрепленного столбца. Также доступен следующий способ закрепления столбца:
    • Навести курсор на заголовок столбца, который является первым или крайним справа от ранее закрепленного столбца, и дважды нажать левую кнопку мыши. Повторное двойное нажатие на заголовке столбца снимает закрепление положения столбца.
  • «Открепить столбец» – снять закрепление положения столбца.
  • «Подобрать ширину столбца» – изменить ширину столбца по отображаемым значениям в ячейках. Также доступны следующие способы изменения ширины столбцов:
    • Навести курсор мыши на границу заголовка столбца, захватить границу (нажав левую кнопку мыши) и «тащить» границу до необходимой ширины.
    • Навести курсор на границу заголовка столбца и дважды нажать левую кнопку мыши, то его ширина подстроится по ширине данных.

Также существует вызов контекстного меню из крайнего левого столбца таблицы, содержащего операции, которые можно применять ко всем столбцам таблицы (или выбором соответствующей операции из пункта меню Действия / [название операции]):

  • «Сортировать по умолчанию» – отменить сортировку всех столбцов активной таблицы.
  • «Отключить все» * – отключить все настроенные фильтры / условное форматирование по столбцам активной таблицы.
  • «Включить все» * – включить все настроенные фильтры / условное форматирование по столбцам активной таблицы.
  • «Очистить все» * – очистить все настроенные фильтры / условное форматирование по столбцам активной таблицы.
    (*) Операция для пользовательских фильтров помечена в контекстном меню значком [image], а для условного форматирования – значком [image].
  • «Подобрать ширину столбцов» – изменить ширину всех столбцов по отображаемым значениям в ячейках.
  • «Открепить всё» – снять закрепление положения со всех ранее закрепленных столбцов.


Вывод данных

  • Копирование в буфер обмена
  • Настройки Копирования в буфер обмена
  • Сохранение в текстовый файл
  • Экспорт данных в MS Excel и через ODBC

    • Копирование в буфер обмена

    Содержимое таблиц можно скопировать в буфер обмена операционной системы, с целью последующего использования в других приложениях.

    Копирование выделенной ячейки осуществляется одним из следующих способов:

    • Нажатием комбинации клавиш «Ctrl»+«C» или «Ctrl»+«Insert» на активном окне.
    • Выбором пункта меню Действия/Копировать ячейку.
    • Выбором пункта контекстного меню «Копировать ячейку» в активном окне.

    Для копирования диапазона ячеек выделите их, удерживая нажатой клавишу «Ctrl» и используя функцию drag-and-drop, и скопируйте одним из следующих способов:

    • Нажатием комбинации клавиш «Ctrl»+«C» или «Ctrl»+«Insert» на активном окне.
    • Выбором пункта меню Действия/Копировать ячейки.
    • Выбором пункта контекстного меню «Копировать ячейки» в активном окне.

    Копирование всего содержимого таблицы осуществляется одним из следующих способов:

    • Нажатием комбинации клавиш «Ctrl»+«Shift»+«C» или «Ctrl»+«Shift»+«Insert» на активном окне.
    • Выбором пункта меню Действия/Копировать все .
    • Выбором пункта контекстного меню «Копировать все» в активном окне.

    Настройки копирования в буфер обмена

    Настройки осуществляются через пункт меню Система/Настройки/Основные настройки...раздел «Программа» / «Буфер обмена».

    • «Выводить заголовки строк» – таблицы копируются вместе с заголовками строк.
    • «Выводить заголовки столбцов» - таблицы копируются вместе с заголовками столбцов.
    • «Формальное представление данных» – данные копируются в служебном формате: заголовки представляются идентификаторами, текстовые переменные – численными значениями. При копировании в буфер численные данные отображаются без разделителей, а строковые в зависимости от контекста таблицы.
      • «Формальное представление заголовков строк и столбцов» — при копировании в буфер данные заголовков отображаются в формальном виде (в служебном формате), в зависимости от контекста таблицы (например, для Таблицы текущих торгов вместо названий параметров отображается их наименование в базе данных). Настройка доступна при включенной настройке «Формальное представление данных».
      • «Выводить пустые ячейки вместо нулей» – ячейка, содержащая значение «0», остается пустой. Настройка доступна при включенной настройке «Формальное представление данных».
    При отключенных настройках «Формальное представление данных» и «Формальное представление заголовков строк и столбцов» при копировании в буфер данные отображаются так, как они видны в таблице, без изменений.

    Как правило, используется копирование таблицы вместе с заголовками строк и столбцов.

    Сохранение в текстовый файл

    Данные из таблицы могут быть сохранены в виде текстового файла. Формат файла индивидуален для каждого типа таблиц и описан в свойствах конкретной таблицы. Сохранение осуществляется командой «Сохранить в файл» из контекстного меню, или через пункт меню программы Действия . Используется кодировка CP-1251 (Windows).

    По умолчанию, в качестве разделителя параметров в строке используется символ «,» (запятая). Символ разделителя можно изменить в настройках программы, выбрав пункт меню Система/Настройки/Основные настройки... , раздел «Программа» / «Экспорт данных», подраздел «Экспорт в текстовые файлы», параметр «Использовать в качестве разделителя значений символ».

    Экспорт данных в MS Excel и через ODBC

    Кроме просмотра данных в таблицах, система QUIK обладает возможностью динамического экспорта получаемой с сервера информации в другие приложения Windows. Используется два способа для экспорта данных:

    • вывод данных в таблицы MS Excel – осуществляется командой «Вывод через DDE-сервер» из контекстного меню или из пункта меню программы Действия, а также нажатием кнопки [image] на панели управления;
    • использование ODBC («Open DataBase Connectivity», стандарт обмена информацией между различными форматами данных от компании Microsoft) – осуществляется командой «Вывод по ODBC» из контекстного меню или из пункта меню программы Действия, а также нажатием кнопки [image] на панели управления.

    Подробное описание экспорта данных см. Совместная работа с другими приложениями.


Сортировка строк таблицы по значениям

В некоторых таблицах предусмотрена возможность сортировки строк в зависимости от значений в определенном столбце. Столбец, по значениям которого упорядочена таблица, помечен символом, указывающим направление сортировки:

  • - строки упорядочены по убыванию значений от верхних строк к нижним,
  • - строки упорядочены по возрастанию значений.

Сортировка осуществляется одним из следующих способов:

  • Выбрать пункт меню Действия/Сортировать по, затем заголовок столбца из открывшегося списка. Повторный выбор столбца меняет порядок сортировки на обратный. Выбор значения «умолчанию» отменяет сортировку.
  • Выбрать пункт контекстного меню столбца «Сортировать по [параметр]» на определенном столбце (вызывается при наведении курсора мыши на заголовок столбца и нажатием правой кнопкой мыши). При этом значок на пункте меню показывает направление сортировки. При повторном выборе пункта меню направление сортировки меняется. Для отмены сортировки выберите пункт контекстного меню «Сортировать по умолчанию» или нажмите кнопкой мыши на крайнем слева заголовке столбцов (пустом).
  • Нажать левую кнопку мыши на заголовке столбца. Повторное нажатие меняет направление сортировки. Для отмены сортировки нужно выполнить эту операцию на крайнем слева заголовке столбцов (пустом). Выбор другого столбца в таблице отменяет настройки сортировки по предыдущему столбцу. Данный способ доступен, если в основных настройках программы отключен флажок «Сортировать по столбцу, удерживая Ctrl» (пункт меню Система / Настройки / Основные настройки…, раздел «Окна» / «Таблицы»).
  • Удерживая нажатой клавишу «Ctrl», нажать левую кнопку мыши на заголовке столбца. Повторное нажатие меняет направление сортировки. Для отмены сортировки нужно выполнить эту операцию на крайнем слева заголовке столбцов (пустом). Выбор другого столбца в таблице отменяет настройки сортировки по предыдущему столбцу. Сортировка с удерживанием нажатой клавиши «Ctrl» доступна, если в основных настройках программы установлен флажок «Сортировать по столбцу, удерживая Ctrl» (пункт меню Система / Настройки / Основные настройки…, раздел «Окна» / «Таблицы»).

Одновременная сортировка данных по нескольким столбцам осуществляется следующим способом:

  • Удерживая нажатой клавишу «Shift», нажать левую кнопку мыши на заголовке столбца. В этом случае будет выполняться одновременная сортировка данных по нескольким столбцам. Последовательность сортировки зависит от порядка нажатия заголовков – сначала выполняется сортировка таблицы по значениям первого столбца, затем по второму, и так далее.

    Первый столбец, по которому выполняется сортировка, помечается значком [image], столбцы дополнительной сортировки помечаются значком с цифрой «2»…«5», означающей очередность сортировки. Начиная с 6-го столбца, используется значок [image] с многоточием «…».

    Повторное нажатие левой кнопкой мыши на заголовок с нажатой клавишей «Shift» меняет направление сортировки.

    Для отмены сортировки по нескольким столбцам нужно выполнить эту операцию с нажатой клавишей «Ctrl» или «Shift» на крайнем слева заголовке столбцов (пустом). Для отмены сортировки по одному столбцу удерживайте нажатой клавишу «Alt» и кликните левой кнопкой мыши на заголовке столбца.

Для столбцов таблицы с численными значениями первоначально включается режим сортировки по убыванию, для столбцов таблицы со строковыми значениями первоначально включается режим сортировки по возрастанию (по алфавиту).

Режим сортировки таблицы сохраняется в файле настройки конфигурации окон и вступает в силу сразу после запуска Рабочего места QUIK или загрузки файла настройки.


Создание копии таблицы

Данная операция подразумевает создание новой таблицы на основе уже существующей. Создание копии таблицы осуществляется одним из следующих способов:

  • Выбором пункта «Создать копию» из контекстного меню таблицы;
  • Выбором пункта «Создать копию» в меню программы Действия;
  • Нажатием комбинации клавиш «Ctrl»+«N».

Аналогичная операция применима к окнам графиков.

Рекомендуется использовать данную операцию в следующих случаях:

  • Если требуется создать таблицу с аналогичными параметрами, но с другим набором инструментов либо счетов;
  • Если требуется создать отдельную таблицу с фильтром по выбранному параметру. Например, требуется разделить таблицу сделок на две, по разным счетам;
  • Если требуется создать аналогичную таблицу на другой вкладке.


Печать таблицы

В Рабочем месте QUIK предусмотрена печать данных из таблицы на принтер. Окно настройки печати вызывается выбором пункта меню Действия/Печать... или нажатием клавиш «Ctrl»+«P». При печати каждая страница содержит заголовок таблицы и нумерацию страниц.

Для просмотра и изменения настроек принтера (выбор принтера, ориентации листа бумаги и т.п.) используйте кнопку «Настройка» в окне настройки печати. По умолчанию используются настройки принтера из операционной системы.

Предварительный просмотр результата печати доступен через пункт меню Действия/Предварительный просмотр и позволяет оценить расположение таблицы на бумаге.

Назначение кнопок в окне «Предварительный просмотр»:

Кнопка | Назначение
Печать | Закрыть окно просмотра и отправить таблицу на печать
Следующая | Отобразить в окне просмотра следующую страницу
Предыдущая | Отобразить предыдущую страницу
Увеличить | Показать страницу в более крупном масштабе
Уменьшить | Показать страницу в более мелком масштабе
Закрыть | Закрыть окно без печати таблицы
Если таблица содержит выделение ячеек цветом, то это выделение воспроизводится на печати.


Поиск значения в ячейках таблицы

Функция предназначена для поиска определенного значения в ячейках таблицы. Поиск возможен во всех таблицах Рабочего места QUIK.

Поиск производится по всему содержимому таблицы, включая заголовки строк и заголовки столбцов.

Окно настройки параметров поиска вызывается из пункта меню Действия/Найти... или при нажатии клавиш «Ctrl»+«F».

Назначение параметров поиска:

  • «Найти» – строка с искомым значением в виде текстового или числового значения.
  • «Учитывать регистр» – поиск значения осуществляется с учетом регистра (прописные/строчные буквы). По умолчанию флажок снят.
  • «Только слово целиком» – искомое значение должно соответствовать целому слову. При снятом флажке допускается вхождение искомого значения в состав слова, поиск по подстроке (по умолчанию).
  • «Форматировать как число» – искомое значение является числовым (по умолчанию). При поиске числовых значений в качестве десятичного разделителя используется символ «.» (точка) или «,» (запятая). Рекомендуется использовать это свойство для поиска числовых значений с условным форматированием, таких как «цена», «объем», «количество инструментов».

    Если флажок снят, то поиск чисел ведется по текстовому представлению числа. Рекомендуется снимать флажок для поиска параметров с текстовым представлением, например «дата», «время».

  • «Направление» – указывает направление поиска:
    • «Назад» - вверх построчно, в ;каждой строке по ячейкам справа налево;
    • «Вперед» (по умолчанию) - вниз построчно, в каждой строке по ячейкам слева направо.

Для нахождения следующего значения в таблице, удовлетворяющего условию поиска, воспользуйтесь пунктом меню Действия/Найти далее или нажмите клавишу «F3».


Настройка шрифтов в таблицах

Для удобства представления данных в таблицах предусмотрена возможность настройки шрифтов.

Настройка осуществляется через пункт меню программы Система/Настройки/Основные настройки..., раздел «Программа» / «Шрифты».

В таблицах допускается использование разных шрифтов для заголовков столбцов, заголовков строк, числовых данных, текстовых данных. Настройка «Высота строки» позволяет изменить межстрочный интервал в таблицах.

Результат выбранных настроек отображается в окне «Пример таблицы».

Отдельной настройкой устанавливается шрифт для окон диалогов, а также шрифт и высота строки для таблицы котировок.

При нажатии кнопки «Стандартные» устанавливаются настройки по умолчанию.


Настройка цвета в таблицах и графиках

В некоторых таблицах и графиках предусмотрена настройка пользователем элементов изображения - цвета символов, фона и т.п. Настройка осуществляется нажатием кнопки [image] в диалоге редактирования окна. Появляется палитра из 48 стандартных цветов, а также 16 дополнительных, доступных для редактирования. Чтобы выбрать цвет из палитры, нажмите на квадратике требуемого цвета.

Добавление цвета в палитру

  1. Нажмите кнопку «Выбрать другой» в палитре цветов.
  2. В открывшемся диалоге нажатием левой кнопки мыши выберите для редактирования ячейку в палитре «Дополнительные цвета». Если ячейка не выбрана, редактируется первая по порядку ячейка.
  3. Перемещая курсор мыши по гамме цветов и по шкале справа, подберите нужный цвет. Полученный цвет отображается в поле «Цвет|Заливка».
  4. Если необходимо ввести цвет по заранее известной схеме, воспользуйтесь полями «Оттенок», «Контраст», «Яркость» (система цвета HSB) либо «Красный», «Зеленый», «Синий» (система цвета RGB).
  5. Нажмите кнопку «Добавить в набор». Одна из ячеек в палитре «Дополнительные цвета» закрашивается выбранным цветом.
  6. При нажатии кнопки «ОК» диалог закрывается, и новый цвет появляется в палитре цветов.


Работа с таблицами в режиме «drag-and-drop»

  • Перемещение окон между вкладками
  • Добавление инструментов в таблицу
  • Удаление инструмента из таблицы
  • Замена инструмента в таблице котировок
  • Изменение порядка столбцов и их удаление из таблицы
  • Изменение порядка строк в таблице

    • Перемещение окон между вкладками

    Для перемещения окна с одной вкладки на другую поместите курсор на заголовок окна, нажмите кнопку «Ctrl». Удерживая левую кнопку мыши и кнопку «Ctrl», переместите окно на нужную вкладку (во время перемещения курсор принимает вид [image] ). При этом вкладка выделяется цветом, и курсор меняет вид на [image] . Отпустите левую кнопку мыши.

    Если курсор имеет вид [image], то перемещение окна на вкладку невозможно.

    Сделать окно видимым на всех вкладках с помощью данной операции невозможно.

    Добавление инструментов в таблицы

    Для таблиц, содержащих только один столбец, данный функционал режима «drag-and-drop» не работает.

    Добавить инструменты можно из/в следующие таблицы:

    • «Купить/Продать»;
    • Таблицы текущих торгов;
    • таблицы с результатом поиска инструментов.

    Добавить инструменты из/в таблицу «Купить/Продать» можно, только если в настройках таблицы включена опция «Выбрать инструменты вручную».

    Поместите курсор на строку с выбранным инструментом. Нажмите на левую кнопку мыши и, удерживая эту кнопку, перемещайте курсор в нужную таблицу. При перемещении курсор принимает вид [image] . Если возможно добавление инструмента в данную таблицу, то вид курсора меняется на [image] , и появляется окно с названием инструмента. Отпустите левую кнопку мыши, строка с новым инструментом добавится в указанное подчеркиванием место таблицы.

    Если вид курсора остается [image] , то добавление инструмента невозможно.

    Повторное добавление в таблицу одного и того же инструмента невозможно.

    Для добавления инструмента в таблицу, расположенную на другой вкладке, необходимо навести курсор (удерживая выбранный инструмент) на нужную вкладку, подождать, пока произойдет переключение на выбранную вкладку, и добавить инструмент в таблицу.

    Удаление инструмента из таблицы

    Для таблиц, содержащих только один столбец, данный функционал режима «drag-and-drop» не работает.

    Удалить инструмент можно из следующих таблиц:

    • Таблица текущих торгов;
    • «Купить/Продать» (если в настройках таблицы включена опция «Выбрать инструменты вручную»).

    Для удаления нажмите клавишу «Delete» или поместите курсор на выбранный инструмент, нажмите на левую кнопку мыши и, удерживая эту кнопку, переместите курсор за пределы таблицы, отпустите левую кнопку мыши. На экране появляется курсор вида [image] и окно с названием удаляемого инструмента.

    Подтверждение при удалении инструмента запрашивается в случае, если установлен флажок «Запрашивать подтверждение при удалении объектов с помощью drag-and-drop» в меню Система/Настройки/Основные настройки..., раздел «Окна» / «Таблицы».

    Замена инструмента в таблице котировок

    Для таблиц, содержащих только один столбец, данный функционал режима «drag-and-drop» не работает.

    Для замены инструмента в таблице котировок выберите инструмент из следующих таблиц:

    • Таблица текущих торгов;
    • «Купить/Продать»;
    • таблицы с результатом поиска инструментов.

    Поместите курсор на выбранный инструмент, нажмите на левую кнопку мыши и, удерживая эту кнопку, переместите курсор с выбранным инструментом в таблицу котировок, отпустите кнопку мыши.

    На экране появляется курсор вида [image] и окно с названием заменяемого инструмента.

    Заголовок окна таблицы котировок изменится на «Краткое название инструмента [Название класса] Котировки №».

    Подтверждение при замене инструмента запрашивается в случае, если установлен флажок «Запрашивать подтверждение при удалении объектов с помощью drag-and-drop» в меню Система/Настройки/Основные настройки..., раздел «Окна» / «Таблицы».

    Для замены инструмента в таблице котировок, расположенной на другой вкладке, необходимо навести курсор (удерживая выбранный инструмент) на нужную вкладку, подождать, пока произойдет переключение на выбранную вкладку и переместить инструмент в таблицу котировок.

    Изменение порядка столбцов и их удаление из таблицы

    Для таблиц, содержащих только один столбец, данный функционал режима «drag-and-drop» не работает.

    Изменение порядка столбцов и их удаление из таблицы доступно, если установлен флажок «Перемещать и удалять колонки таблицы с помощью drag-and-drop» в меню Система/Настройки/Основные настройки..., раздел «Окна» / «Таблицы».

    Для изменения порядка столбцов, поместите курсор на заголовок столбца, нажмите на левую кнопку мыши и, удерживая эту кнопку, переместите курсор с выделенным столбцом в нужное место в таблице на заголовок столбца. На экране появляется курсор вида [image] , и окно названием выделенного столбца. Отпустите кнопку мыши, и столбец добавится в указанное подчеркиванием место таблицы.

    Для удаления нажмите клавишу «Delete» или поместите курсор на заголовок столбца, нажмите на левую кнопку мыши и, удерживая эту кнопку, переместите курсор за пределы таблицы. На экране появляется курсор вида [image] и окно с названием удаляемого столбца. Отпустите левую кнопку мыши.

    Подтверждение при удалении столбца таблицы запрашивается в случае, если установлен флажок «Запрашивать подтверждение при удалении объектов с помощью drag-and-drop» в меню Система/Настройки/Основные настройки..., раздел «Окна» / «Таблицы».

    При попытке удалить столбец таблицы, значения которого используются в фильтрах других столбцов, методом «drag-and-drop» у пользователя запрашивается подтверждение. При положительном ответе столбец удаляется, а соответствующий фильтр сбрасывается. Если столбец удаляется в процессе редактирования таблицы, то соответствующий фильтр сбрасывается без предупреждения.

    Изменение порядка строк в таблице

    Изменять порядок строк можно в следующих таблицах:

    • Таблица текущих торгов;
    • «Купить/Продать» (если в настройках таблицы включена опция «Выбрать инструменты вручную»).

    Для таблицы «Купить/Продать» изменить порядок строк невозможно, если набор инструментов сформирован автоматически, а не с помощью опции «Выбрать инструменты вручную».

    Поместите курсор на строку, нажмите на левую кнопку мыши и, удерживая эту кнопку, переместите курсор в выбранную область таблицы. На экране появляется курсор вида [image] и окно с названием перемещаемого инструмента. Отпустите левую кнопку мыши, строка переместится в указанное подчеркиванием место таблицы.

    Изменить порядок строк невозможно, если в таблице включена сортировка по какому-либо столбцу.


Режим связанных окон

Для удобства работы с таблицами, отображающими ход торгов, предусмотрен режим связанных окон. К одной основной таблице может быть привязано несколько окон. При выборе какой-либо строки в основной таблице происходит фильтрация данных во всех связанных с ней окнах. Например, при выборе в Таблице текущих торгов строки, соответствующей акциям «Мосэнерго», в Таблице котировок отображается очередь лучших заявок по этим акциям, в Таблице обезличенных сделок выводятся сделки только по акциям «Мосэнерго», в окне графиков – график по этому инструменту.

Для вынесенных окон режим связанных окон работает только при включении настройки «Связывать вынесенные окна» в пункте меню Система/Настройки/Основные настройки... раздел «Окна».

Режим связанных окон недоступен для Таблицы текущих торгов при включенном признаке «Транспонировать».

Ниже приведен список таблиц, которые могут быть основными, и таблиц, которые могут быть связанными с данными основными таблицами:

Основная таблица | Фильтры | Связанные таблицы
Таблица текущих торгов Фильтр инструментов
  • Таблица котировок (очередей заявок);
  • Таблица «РПС котировки»;
  • Таблица обезличенных сделок;
  • График;
  • Доска опционов – если инструмент является базовым активом;
  • Таблица сделок;
  • Таблица заявок;
  • Таблица стоп-заявок;
  • Таблица информации об инструменте;
  • Таблица заявок на внебиржевые сделки;
  • Таблица сделок для исполнения;
  • Таблица алгоритмических заявок
Таблица заявок | Фильтрация по номеру заявки | Таблица сделок
Таблица «Состояние счета»
  • Фильтр инструментов;
  • Фильтр фирм;
  • Фильтр клиентов;
  • Фильтр счетов депо
  • Таблица котировок (очередей заявок);
  • Таблица обезличенных сделок;
  • График;
  • Таблица сделок;
  • Таблица заявок;
  • Таблица стоп-заявок;
  • Таблица информации об инструменте
Таблица «Клиентский портфель»
  • Фильтр фирм;
  • Фильтр клиентов;
  • Фильтр счетов;
  • Валюта;
  • Код позиции
  • Таблица «Позиции по инструментам»;
  • Таблица «Позиции по деньгам»;
  • Сводная таблица позиций;
  • Таблица «Купить/Продать»;
  • Таблица сделок;
  • Таблица заявок ***;
  • Таблица стоп-заявок;
  • Таблица позиций по клиентским счетам;
  • Таблица ограничений по клиентским счетам
Таблица «Торговые счета» Фильтр счетов депо
  • Таблица заявок;
  • Таблица сделок;
  • Таблица стоп-заявок;
  • Таблица заявок на внебиржевые сделки;
  • Таблица сделок для исполнения;
  • Таблица заявок-отчетов на сделки РПС
Таблица участников торгов Фильтр фирм
  • Таблица заявок;
  • Таблица сделок;
  • Таблица стоп-заявок;
  • Таблица заявок на внебиржевые сделки;
  • Таблица сделок для исполнения;
  • Таблица заявок-отчетов на сделки РПС
Таблица заявок на внебиржевые сделки | Фильтрация по номеру заявки | Таблица сделок для исполнения
Таблица заявок-отчетов на сделки РПС | Фильтрация по номеру заявки-отчета | Таблица сделок для исполнения
Таблица алгоритмических заявок * Фильтрация по номеру заявки
  • Таблица «Связанные заявки» *;
  • Таблица «Связанные заявки на внебиржевые сделки» *;
  • Таблица «Связанные сделки» *
Таблица OMS-заявок ** Фильтрация по номеру заявки
  • Таблица «Связанные заявки»**;
  • Таблица «Связанные алго-заявки»**;
  • Таблица «Связанные сделки»**;
  • График;
  • Таблица котировок;
  • Таблица обезличинных сделок

* - Описание таблицы см. в Руководстве пользователя Модуля алгоритмической торговли.

** - Описание таблицы см. в Руководстве пользователя Модуля OMS Manager.

*** - Для клиентов с настроенной единой денежной позицией в связанной Таблице заявок отображаются заявки, у которых либо код клиента совпадает с кодом клиента из выделенной строки Клиентского портфеля, либо торговый счет заявки совпадает со срочным торговым счетом из выделенной строки Клиентского портфеля.

Режим связанных окон включается в основной таблице одним из следующих способов:

  • Нажатием кнопки [image] в заголовке основной таблицы.
  • Выбором пункта контекстного меню «Открыть канал» в основной таблице.

Максимальное количество открытых каналов: 300.

Каждому открытому каналу присваивается цвет, в который окрашивается кнопка [image].

После этого на окнах, которые могут быть привязаны к данной основной таблице, появляются кнопки [image], нажатием на которые производится привязка окон к основной таблице. Также для привязки окна можно воспользоваться пунктом контекстного меню «Подключиться к каналу».

Если режим связанных окон включен более чем в одном основном окне, то при нажатии кнопки [image] или выборе пункта контекстного меню «Подключиться к каналу» появляется список каналов, доступных для подключения.

При подключении кнопка [image] заменяется на [image], окрашенную в цвет канала, к которому подключена данная таблица.

  1. Количество уникальных цветов, используемых для каналов: 48. Далее цвета используются повторно.
  2. При загрузке файла конфигурации (*.wnd) загружаемым каналам последовательно присваиваются свободные цвета каналов в существующей конфигурации.

Для отключения от канала необходимо нажать в связанной таблице на кнопку [image] или выбрать пункт контекстного меню «Подключиться к каналу» и в появившемся списке выбрать пункт «Отключить».

При отключении таблицы от канала фильтры в таблице автоматически НЕ снимаются.

В основной таблице режим связанных окон выключается одним из следующих способов:

  • Повторным нажатием кнопки [image] в заголовке основной таблицы.
  • Выбором пункта контекстного меню «Закрыть канал» в основной таблице.

После этого все связанные с данным каналом таблицы отключаются.

  1. Окна, расположенные на разных вкладках, не могут быть связаны.
  2. При переносе основного окна на другую вкладку канал остается открытым, но связанные окна от данного канала отключаются.
  3. При переносе связанного окна на другую вкладку данное окно отключается от канала.


Контекстный фильтр в списках

Для фильтрации списков возможных значений по введенным пользователем символам в диалогах настройки таблиц добавлена строка поиска.

Поиск значений из списка осуществляется по первым буквам, вводимым с клавиатуры без учета регистра. Справа в строке поиска отображается количество совпадений и общее количество вариантов. Для раскрывающихся списков количество совпадений не отображается. Для удаления текста в строке поиска нажмите на кнопку [image] .


Пользовательские фильтры

Пользователь может настроить фильтр на каждый столбец таблицы для всех таблиц, кроме следующих:

  • Таблица котировок;
  • Таблица новостей;
  • Карман транзакций;
  • Таблица истории значений параметров;
  • Таблица изменений параметров.

Управление фильтрами осуществляется из контекстного меню столбца таблицы, которое вызывается при наведении курсора мыши на заголовок столбца и нажатии на правую кнопку мыши. Контекстное меню содержит следующие операции для работы с фильтрами:

  • «Фильтр по [параметр]» – установить фильтр по столбцу;
  • «Отключить фильтр» – отключить фильтр по столбцу. При выборе данной операции фильтр отключается, но настроенные параметры фильтра сохраняются;
  • «Удалить фильтр» – отключить фильтр по столбцу с одновременным очищением настроенных параметров фильтра.

Для настройки фильтра выберите пункт контекстного меню заголовка столбца «Фильтр по [параметр]», при нажатии на который открывается форма для настройки фильтра.

Наименование выбранного столбца, для которого настраивается фильтр, указывается в заголовке окна.

В диалоге доступны следующие параметры:

  1. Флажок «Фильтр включен» – при установленном флажке фильтр включен. При выключенном флажке фильтр отключен, а остальные параметры в диалоге недоступны.
  2. «Отображать строки при выполнении»:
    • «всех условий» – в таблице отображаются строки, удовлетворяющие всем условиям фильтра;
    • «хотя бы одного условия» – в таблице отображаются строки, удовлетворяющие хотя бы одному условию.
  3. «Условия фильтра: <наименование столбца, для которого задается фильтр>»:
    • Для численных значений задаются условия вида:
      • «равно»;
      • «не равно»;
      • «меньше»;
      • «меньше либо равно»;
      • «больше»;
      • «больше либо равно»;
      • «задано»;
      • «не задано».
    • Для строковых значений задаются условия вида:
      • «равно»;
      • «не равно»;
      • «начинается с»;
      • «не начинается с»;
      • «заканчивается на»;
      • «не заканчивается на»;
      • «содержит»;
      • «не содержит»;
      • «задано»;
      • «не задано».

    Нажав кнопку [image] , можно выбрать столбец таблицы, кроме того, для которого задается фильтр, или указать значение вручную (по умолчанию). Если фильтрация задается по столбцу с датой, то для выбора доступны другие столбцы с датой (если они присутствуют в таблице) и следующие значения:

    • «Сегодня» – текущая календарная дата на компьютере пользователя;
    • «Дата торговой сессии» – текущая дата торговой сессии. Если компьютеры с сервером QUIK и Рабочим местом QUIK находятся в разных часовых поясах, то дата может отличаться от текущей календарной даты на компьютере пользователя.
    Для корректной работы фильтров НЕ указывайте в условии фильтра символы «?» и «*».

    Для удаления значения условия нажмите на кнопку [image] рядом с ним.

    4. Кнопка «Добавить условие» - добавить условие фильтра.

    Для снятия всех фильтров нажмите кнопку «Очистить все». При нажатии на кнопку «Сохранить» для столбца применяется фильтр с учетом указанных условий.

    При настроенном фильтре значок в заголовке столбца принимает вид:

    • – если фильтр включен;
    • – если фильтр отключен.

    Если хотя бы на одном из столбцов таблицы настроен пользовательский фильтр, то в заголовке крайнего левого столбца таблицы отображается значок [image] (или [image] , если фильтр отключен на всех столбцах таблицы).

    Если необходимо отключить фильтр и очистить все настройки фильтра по выбранному столбцу, то необходимо выбрать пункт контекстного меню столбца «Удалить фильтр».

    Для отключения, включения или снятия настроек фильтрации по всем столбцам выбранной таблицы вызовите контекстное меню из заголовка крайнего левого столбца или откройте пункт меню Действия/Фильтры и выберите требуемую опцию (либо воспользуйтесь «горячими клавишами»):

    • «Отключить все» («Ctrl»+«Shift»+«Y»);
    • «Включить все» («Ctrl»+«Y»);
    • «Очистить все» («Alt»+«Y»).

    Копирование таблицы в буфер обмена производится с учетом фильтрации.

    Настройки фильтров сохраняются в файле настроек и загружаются из него.


Быстрый фильтр

Включение / отключение быстрого фильтра осуществляется с помощью пункта контекстного меню «Включить быстрый фильтр» \ «Выключить быстрый фильтр», открываемого для заголовка самого левого столбца таблицы. Либо воспользуйтесь «горячими клавишами»: «Ctrl»+ «Alt» + «Y».

При включении режима быстрого фильтра активируется дополнительная фиксированная строка для ввода значения фильтрации в ячейку соответствующего столбца. В полях дат и времени и числовых полях ввода быстрого фильтра доступно указание условийсравнения: «=», «>»,«<», «>=», «<=», «!=». По умолчанию для строк используется условие «содержит», для чисел, дат и времени — «=». Для быстрой очистки данных в поле нажмите «х».

Условия «быстрой» фильтрации применяются к результатам уже заданной фильтрации по столбцам, в таблице отображаются строки, соответствующие условиям во всех заданных для таблицы фильтрах.


Условное форматирование таблиц

Параметры условного форматирования строк и ячеек можно настроить на каждый столбец таблицы для всех таблиц, кроме следующих:

  • Таблица котировок;
  • Таблица новостей;
  • Карман транзакций;
  • Таблица истории значений параметров;
  • Таблица изменений параметров.

Управление условным форматированием осуществляется из контекстного меню столбца таблицы, которое вызывается при наведении курсора мыши на заголовок столбца и нажатии на правую кнопку мыши. Контекстное меню содержит следующие операции для работы с условным форматированием:

  • «Форматирование [параметр]» – установить форматирование по столбцу;
  • «Отключить форматирование» – отключить форматирование по столбцу. При выборе данной операции форматирование отключается, но настроенные параметры форматирования сохраняются;
  • «Удалить форматирование» – отключить форматирование по столбцу с одновременным очищением настроенных параметров форматирования.

Для настройки форматирования строк и ячеек выберите пункт контекстного меню заголовка столбца «Форматирование [параметр]», при нажатии на который открывается диалог для настройки формата строк и ячеек.

Диалог настроек условного форматирования содержит следующие параметры:

  1. Флажок «Форматирование включено» - при установленном флажке форматирование включено. При выключенном флажке форматирование отключено, а остальные параметры в диалоге недоступны.
  2. «Условия форматирования» - описание условий аналогично описанию условий фильтра, приведенном в разделе «Пользовательские фильтры». Дополнительно доступны параметры:
    • Кнопка «Формат» - задать цветовые параметры шрифта текста в ячейке. Нажмите кнопку и в открывшейся форме выберите нужные цвета и шрифт.

      Выбранные настройки шрифта и цвета отображаются на кнопке «Формат».

    • Флажок «применить ко всей строке» – применить заданные для ячейки настройки ко всей строке, содержащей данную ячейку.
  1. Если опция «применить ко всей строке» включена сразу для нескольких столбцов, то при выполнении условий для нескольких ячеек в одной строке одновременно:
    • Строка отображается с настройками самого правого столбца, если заданы одни и те же настройки форматирования. Например, если в условии для двух столбцов одновременно задан цвет фона и указан признак «применить ко всей строке», то при выполнении условия для обоих столбцов строка будет нарисована цветом самого правого столбца.
    • Cтрока отображается с использованием всех правил, заданных для столбцов, если в них заданы разные настройки форматирования. Например, если в условии для одного столбца задан только цвет фона, а для другого только цвет текста, и для обоих столбцов указан признак «применить ко всей строке», то при выполнении условия для обоих столбцов, строка отображается с использованием шрифта и цвета текста, указанного для второго столбца, и цветом фона, указанного для первого столбца.
  2. Собственные свойства форматирования столбца имеют больший приоритет, чем аналогичные свойства с включенной опцией «применить ко всей строке» для другого столбца. Например, если для одного столбца задан только цвет фона, а для другого заданы цвета фона и текста, и указан признак «применить ко всей строке», то первый столбец отобразится с цветом текста, указанным в условии столбца с признаком «применить ко всей строке», и с цветом фона из собственного условия.
  3. Цветовые настройки форматирования таблицы (задаются в диалоге редактирования таблицы) применяются к строкам и столбцам, если для них не настроены аналогичные свойства условного форматирования. Например, если для таблицы «Текущие торги» задана настройка для раскраски таблицы в полоску и для каких-то столбцов таблицы определены условия форматирования, задающие цвет фона, то при выполнении данных условий для каких-то ячеек они будут отображены цветом, заданным в условии, а не цветом, заданным для раскраски таблицы в полоску.
  4. Если для столбца настроены и выполнены несколько условий форматирования одновременно, то настройки применяются по следующему правилу:
    • Настройки для строки берутся из последнего по порядку из всех выполненных условий c признаком «применить ко всей строке».
    • Настройки для столбца берутся из последнего по порядку условия из всех выполненных условий без признака «применить ко всей строке». Если таких условий нет, настройки для столбца будут взяты из последнего по порядку условия, из всех выполненных для этого столбца.

Для удаления значения условия нажмите на кнопку [image] рядом с ним.

  3. Кнопка «Добавить условие» - добавить условие форматирования.

Для снятия всех условий нажмите кнопку «Очистить все». При нажатии на кнопку «Сохранить» для столбца применяется форматирование с учетом указанных условий.

При заданных условиях значок в заголовке столбца принимает вид:

  • – если форматирование включено;
  • – если форматирование отключено.

Если хотя бы на одном из столбцов таблицы настроено условное форматирование, то в заголовке крайнего левого столбца таблицы отображается значок [image] (или [image], если условное форматирование отключено на всех столбцах таблицы).

Если необходимо отключить форматирование и очистить все настройки форматирования по выбранному столбцу, то необходимо выбрать пункт контекстного меню столбца «Удалить форматирование».

Для отключения, включения или снятия настроек условного форматирования по всем столбцам выбранной таблицы вызовите контекстное меню из заголовка крайнего левого столбца или откройте пункт меню Действия/Форматирование и выберите требуемую опцию (либо с помощью «горячих клавиш»):

  • «Отключить все» («Ctrl»+«Shift»+«R»),
  • «Включить все» («Ctrl»+«R»),
  • «Очистить все» («Alt»+«R»).

Настройки правил условного форматирования сохраняются в файле настроек и загружаются из него.


Системные сообщения

кнопка

  • Перемещение по списку сообщений
  • Настройка окна сообщений
  • Расположение окна на панели инструментов
  • Настройки
    •

    Окно сообщений

    Окно служит для отображения сообщений о работе системы QUIK, об ошибках, а также уведомлений торговой системы и администратора.

    В окне сообщений отображаются только сообщения, полученные в ходе текущего сеанса связи.

    Окно появляется автоматически при получении нового сообщения. Открыть окно вручную можно с помощью кнопки [image] или иконки [image] (окна сообщений) на панели инструментов, либо двойным нажатием левой кнопки мыши на строке в таблице сообщений.

    Функции для копирования выделенного текста сообщения доступны в контекстном меню нажатием правой кнопки мыши на сообщении:

    1. «Копировать» или «Ctrl» + «C» – копирование текста сообщения в буфер обмена. Функция доступна только для выделенного текста.
    2. «Выделить все» или «Ctrl» + «A» – выделение текста сообщения для копирования.

    Ссылки в тексте сообщения открываются в интернет-браузере, установленном по умолчанию. Для перехода по ссылке щелкните левой кнопкой мыши по тексту ссылки.

    Перемещение по списку сообщений

    Окно сообщений может содержать больше одного сообщения, при этом показывается только одно сообщение, по умолчанию – последнее из полученных. Под текстом сообщения расположен индикатор количества сообщений вида NN/MM, где NN – номер показываемого сообщения, MM – число полученных сообщений.

    1. Для просмотра остальных сообщений используйте кнопки:
      • - перейти к первому сообщению;
      • - перейти к предыдущему сообщению;
      • - перейти к следующему сообщению;
      • - перейти к последнему сообщению.
    2. Для очистки списка сообщений нажмите кнопку [image].

      При чистке списка сообщений хранилище сообщений и все открытые таблицы сообщений очищаются.
    3. Окно сообщений закрывается нажатием кнопки [image] или клавиши «Esc».

    Настройка окна сообщений

    Для настройки окна воспользуйтесь пунктом меню Система/Настройки/Основные настройки…, раздел «Сообщения»:

    • «При получении показывать в окне сообщения»:
      • «Отмеченные как важные» – окно сообщений появляется на экране при поступлении важного сообщения (отмеченного значком [image] в поле «Важность»).
      • «Ошибки транзакций» – окно сообщений появляется на экране при поступлении ответа на транзакцию с ошибкой.
      • «Обычные» – окно сообщений появляется на экране при поступлении любого сообщения, за исключением важных и ошибок транзакций.

      Чтобы получать сообщения всех типов, включите все флажки.

    • «Расширять Окно сообщений для длинных сообщений» – при получении нового сообщения изменять размер окна таким образом, чтобы в нем был виден весь текст сообщения.
    • «Очищать сообщения при запуске программы» – при запуске программы список сообщений очищается.
    • «Сохранять за последние … дней» – позволяет сохранять список сообщений за указанное количество дней.

    Расположение окна на панели инструментов

    Окно сообщений может быть помещено на панели инструментов в компактном виде.

    Нажатием левой кнопки мыши на окне сообщений открывается список предыдущих сообщений текущего сеанса связи.

    Настройки

    • Откройте пункт меню Система/Настройки/Основные настройки..., раздел «Программа» / «Панели инструментов».
    • Поставьте флажок «Окно сообщений».
    • Нажмите кнопку «Сохранить». Окно сообщений появится напанели инструментов. Разместите его на экране так, чтобы было видно сообщение целиком.
    Появление окна на экране при получении новых сообщений можно отключить (о настройке см. п. Настройка окна сообщений).

    См. также Таблица сообщений.


Настройки Рабочего места QUIK

  • Программа
  • Новости
  • Торговля
  • Сообщения
  • Окна
  • Таблицы
  • QPILE скрипты
  • Lua скрипты

    • Открытие окна настроек Рабочего места осуществляется из пункта меню Система/Настройки/Основные настройки… или нажатием клавиши «F9».

    «Программа»

    1. «Запуск и закрытие приложения»:
      • «Отображать заставку». При запуске программы показывать/не показывать заставку программы.
      • «Устанавливать соединение». При запуске программы автоматически открывается диалог установления связи с сервером. Это свойство можно отключить, сняв флажок «Устанавливать соединение».
      • «Проверять наличие обновлений». После установления соединения с сервером программа проверяет наличие на сервере новой версии, и если обнаружила ее – предлагает провести загрузку файлов и обновление программы. Если нет необходимости в обновлении версии, функцию проверки версии можно отключить в этом пункте.
      • «Запрашивать подтверждение при выходе из приложения» – при попытке закрыть программу запрашивать подтверждение.
      • «Отключаться по истечении заданного периода бездействия». Если пользователь не активен в течение указанного времени, то связь с сервером разрывается. По умолчанию флажок выключен. Период неактивности указывается в минутах в настройках файла info.ini, по умолчанию: «15». По истечении указанного периода времени открывается диалоговое окно «Терминал будет отключен через N секунд»:

        Для продолжения работы нажмите кнопку «ОК». Количество секунд, в течение которых будет открыто диалоговое окно, указывается в настройках файла info.ini, по умолчанию: «15».
    2. «Отображение данных»:
      • «Полные коды опционов» – отображение в заголовках Таблиц котировок полного кода опционов. Если флажок выключен, то в качестве названия опциона используется его краткое наименование; если включен, то название опциона формируется по следующему правилу:

        название_опциона = краткое_наименование_базового_актива + дата_погашения + тип_опциона_(p для put, с для call) + страйк

        Настройка имеет значение для различения маржируемых и немаржируемых опционов. В этом случае рекомендуется выключать флажок и различать опционы по краткому наименованию.

      • «Данные в локальной временной зоне» – при установленном флажке дата и время биржевых данных в таблицах, а также время в полях ввода транзакций и в окне сообщений системы указываются с учетом временной зоны компьютера, на котором запущен терминал QUIK. Настройка применяется к следующим таблицам:
        • «Заявки»;
        • «Сделки»;
        • «Стоп-заявки»;
        • «Таблица обезличенных сделок»;
        • «Сделки для исполнения»;
        • «Таблица заявок на внебиржевые сделки»;
        • «Отчеты по сделкам для исполнения»;
        • «Окно оповещений»;
        • «Таблица транзакций»;
        • «Таблица текущих торгов»;
        • «Таблица изменений параметров»;
        • «Таблица истории значений параметров»;
        • «Окно сообщений Трейдера»;
        • «Таблица обязательств маркет-мейкера по срочному рынку»;
        • «Таблица алгоритмических заявок» (Описание приведено в Руководстве пользователя «Алгоритмические заявки», п. 2);
        • «Таблица OMS-заявок» (Описание приведено в Руководстве пользователя «Модуль OMS Manager», п. 2).
      • «Скрывать ФИО пользователя в заголовке приложения» – настройка отображения ФИО пользователя в заголовке программы. Если флажок включен, то в заголовке программы в квадратных скобках отображается только UID пользователя. По умолчанию флажок выключен.
    3. «Элементы управления»:
      • «Строка состояния». Скрывает/показывает строку состояния внизу экрана.
      • «Полосы прокрутки». Скрывает/показывает полосы прокрутки на рабочей области программы, если окна выходят за видимую область.
    4. «Тема оформления» – выбор темы оформления интерфейса:
      • «Стандартная»;
      • «Темная».

      Изменения вступают в силу после перезапуска программы.

    5. Кнопка «Сбросить пользовательские цветовые настройки» – изменение цветов текста, фона и графических элементов открытых таблиц и диаграмм на соответствующие цветовые настройки текущей установленной темы.

    «Панели инструментов»

    1. «Панели инструментов» – выбор отображаемых панелей из списка доступных.
    2. «Большие кнопки» – выбор размера кнопок на панели.

      Выбор панелей инструментов для отображения можно осуществлять из контекстного меню на панели управления.

      «Получение данных»

      Настройка получения данных выполняется в разделе «Программа» / «Получение данных».

      «Сохранение данных»

      Настройка сохранения данных выполняется в разделе «Программа» / «Сохранение данных» .

      «Файлы настроек»

      Настройка сохранения/восстановления конфигурации из файла.

      «Замена инструментов»

      1. «Предлагать замену инструментов с истекающим сроком обращения» – при включенном флажке у пользователя на экране отображается сообщение «У <количество> инструментов истекает срок обращения. Заменить их новыми?». При выборе ответа «Да» на экран выводится диалог замены инструментов . Сообщение отображается, если в результате проверки найдены инструменты с наступающим сроком экспирации. По умолчанию флажок включен.
      2. «За … дней до погашения» – за сколько дней до погашения выполняется проверка наличия инструментов для замены и отображается сообщение с предложением о замене инструментов с истекающим сроком обращения.

        Для замены инструментов в последний день обращения необходимо указать значение «0».

        Проверка инструментов выполняется:

        • при подключении к серверу QUIK;
        • при открытии окна «Инструменты с наступающим сроком погашения» – если установлено соединение с сервером QUIK.

      «Контекстное меню»

      1. «Показывать неактивные пункты». Если флажок включен, то в контекстном меню отображаются все возможные операции с текущим окном, при этом неактивные пункты являются недоступными (серыми). Если флажок отключен, то в контекстном меню отображаются только доступные операции.
      2. «Правая клавиша «мыши». Определяет функции, доступные по нажатию правой кнопки мыши:
        • «Снятие заявки». Делает возможным снятие заявки в Таблице заявок, Таблице стоп-заявок и Таблице заявок на внебиржевые сделки двойным щелчком правой кнопки мыши.
        • «Контекстное меню». Активирует контекстное меню нажатием правой кнопки мыши.
        • «Снятие заявки и контекст. меню». Однократное нажатие правой кнопки мыши вызывает контекстное меню, двойное нажатие ;– снимает заявку в Таблице заявок, Таблице стоп-заявок или Таблице заявок на внебиржевые сделки.

      «Экспорт данных»

      Настройки параметров экспорта данных .

      «Буфер обмена»

      Настройки копирования в буфер обмена.

      «Шрифты»

      Настройка шрифтов в таблицах.

      «Звуки»

      Настройка предназначена для назначения различным событиям (получение сообщения, исполнение заявки и т.п.) соответствующих звуковых сигналов.

      1. «События и звуки» - список событий сгруппирован по группам. Чтобы развернуть группу, нажмите на значок «+» слева от имени группы.

        Чтобы задать событие звуковой сигнал, нужно установить против него флажок. При этом откроется окно выбора звукового файла формата *.wav или *.mp3 из имеющихся на компьютере пользователя. Самый простой способ – использовать стандартные звуковые схемы операционной системы Windows, которые по умолчанию расположены в следующих папках:

        • C:\windows\media - для Windows Vista\7\8.1\10.
      2. «Имя звукового файла» - выбранный звуковой файл можно прослушать нажатием кнопки [image]. Чтобы выбрать другой файл, нажмите кнопку [image]. Чтобы удалить настройку сигнала для данного события, выберите в поле «Имя звукового файла» значение «(None)».

          Помимо индивидуальной настройки сигналов для каждого события, можно установить общий сигнал для всех событий группы. Для этого достаточно установить флажок напротив имени группы. Состояние настройки для каждого события определяется видом значка:

          • - звуковой сигнал не установлен,
          • - установлен индивидуальный звуковой сигнал,
          • - установлен звуковой сигнал для группы.

          В случае, если установлен звуковой сигнал и для группы, и для конкретного события в группе, то для этого события будет использоваться индивидуальный сигнал. Для событий, не имеющих индивидуальной настройки – общий сигнал группы.
        • «Беззвучный режим» - отключает звуковые сигналы для всех сообщений и событий системы QUIK .

        «Шифрование»

        Описание настроек шифрования.

        «Новости»

        Настройки параметров новостей осуществляются в разделе «Новости»:

        1. «Сохранять за последние … дней». Указывает длительность сохранения принятых новостей. По истечении срока новости удаляются при очередном запуске программы.
        2. «Отмечать как прочитанную через … секунд». Устанавливает время, по истечении которого выбранная курсором новость считается прочитанной.
        3. «Запрашивать тело новости вместе с заголовком». Если флажок включен, то тело новости (сообщение) поступает с сервера QUIK одновременно с получением заголовка. Если флажок отключен (по умолчанию), то для получения тела новости нужно выбрать ее заголовок в окне «Новости».
        4. «Запрашивать новости с текущего момента». Если флажок включен, то новости поступают с сервера QUIK с момента установления связи с сервером. Если флажок отключен (по умолчанию), то новости отображаются с учетом последней новости, имеющейся на терминале QUIK.

        «Торговля»

        Описание настроек торговли.

        «Заявки»

        Описание настроек ввода заявок.

        Раздел включает в себя описание следующих настроек:

        • «Формы ввода»;
        • «Клиентские заявки»;
        • «Алгоритмические заявки» – описание приведено в Руководстве пользователя Модуля алгоритмической торговли», п. 9.2;
        • «ОМS-заявки» – описание приведено в Руководстве пользователя Модуля OMS Manager, п. 24;
        • «Внебиржевые заявки».
        • «Замена заявок».

        «Настройка счетов»

        Описание настройки счетов депо.

        «Закрытие позиций»

        Описание настроек закрытия позиций.

        «Клиентский портфель»

        Описание параметров работы с Клиентским портфелем.

        «Котировки»

        Описание параметров работы с котировками и с объединенными котировками.

        «Денежная единица»

        Изменение денежной единицы предназначено для пересчета всех стоимостных значений в таблицах программы в иной валюте.

        Выбор денежной единицы осуществляется следующим образом:

        1. Откройте пункт меню Система/Настройки/Основные настройки… раздел «Программа» / «Получение данных» / «Котировки». Убедитесь, что в списке присутствует класс «Кросс-курсы валют» и он выбран для получения с сервера.
        2. Откройте пункт меню Система/Настройки/Основные настройки…, раздел «Торговля» / «Денежная единица». Выберите из списка требуемую денежную единицу и нажмите кнопку «ОК».

        Для отмены пересчета стоимостных значений в иной валюте достаточно выбрать в настройках денежной единицы значение «Денежная единица по умолчанию».

        «ЭЦП»

        Описание параметров настройки ЭЦП.

        «Сообщения»

        Настройка окна сообщений.

        «Сообщения трейдера»

        Описание настроек сообщений трейдера.

        «Оповещения»

        Описание настроек локальных сообщений.

        «Окна»

        1. «Приклеивать окна при перемещении». Включение механизма «приклеивания» окон при их перемещении или изменении их границ. Если при перемещении или изменении границ окна удерживается кнопка «Shift», то «приклеивания» не происходит.
        2. «Показывать иконку вынесенного окна в панели задач». Если флажок включен, то иконка окна, вынесенного за пределы основного рабочего окна программы, отображается в строке задач операционной системы. По умолчанию флажок включен.

          Настройка действует только на вновь выносимые окна и не влияет на ранее вынесенные окна.

        3. «Связывать вынесенные окна». Возможность применять режим связанных окон для вынесенных окон. При включенной настройке меняется внешний вид окон (заголовок и кнопки). По умолчанию флажок выключен.

          Вид окна с отключенной настройкой:

          Вид окна с включенной настройкой:

        «Таблицы»

        Настройки параметров работы с таблицами осуществляются в разделе «Таблицы»:

        1. «Плавная подсветка строк». Если флажок включен, то вместо обычной подсветки строк используется плавная (постепенно исчезающая) подсветка строк (например, в Таблице текущих торгов, в Таблице заявок при исполнении заявки и тп.).
        2. «Сортировать по столбцу, удерживая Ctrl». Если флажок включен, то сортировка строк в столбцах таблиц выполняется нажатием левой кнопкой мыши на заголовке столбца с удержанием нажатой клавиши «Ctrl». По умолчанию флажок выключен.

        Настройки drag-and-drop:

        3. «Перемещать и удалять столбцы с помощью drag-and-drop». Если флажок включен, то в таблицах разрешено перемещать и удалять столбцы в режиме «drag-and-drop».
        4. «Запрашивать подтверждение при перемещении и удалении объектов с помощью drag-and-drop». Если флажок включен, то при работе в режиме «drag-and-drop» при замене инструмента в котировочном окне и удалении объектов требуется подтверждение пользователя.

        «QPILE скрипты»

        «Исполнение QPILE скриптов». Если значение настройки не указано, то при запуске QPILE скрипта запрашивается разрешение. Возможные значения:

        • «разрешено»;
        • «запрещено».

        «Lua скрипты»

        1. «Версия Lua для скриптов-индикаторов» — выбор Lua-машины для скриптов-индикаторов, заданное значение используется по умолчанию при запуске скриптов-индикаторов. Возможные значения:
          • «5.3.5»;
          • «5.4.1» (по умолчанию).
        2. «Версия Lua для скриптов пользователей»— выбор Lua-машины для пользовательских скриптов. Выбранная версия Lua-машины используется по умолчании при нажатии на кнопку «Запустить» в диалоге «Доступные скрипты». Описание приведено в п. 1.3.2 Руководства пользователя «Интерпретатор языка Lua». Возможные значения:
          • «5.3.5»;
          • «5.4.1» (по умолчанию).

          «Использование Lua скриптов». Если значение настройки не указано, то при запуске Lua скрипта запрашивается разрешение. Возможные значения:

          • «разрешено»;
          • «запрещено».


Настройки экспорта данных

Экспорт в текстовые файлы

Настройки параметров экспорта данных в текстовые файлы осуществляются через пункт меню Система/Настройки/Основные настройки..., раздел «Программа» / «Экспорт данных» подраздел «Экспорт в текстовые файлы»:

  1. «Выводить наименование фирмы вместо идентификатора». При сохранении в текстовый файл значений из таблиц заявок, сделок и таблиц РПС вместо идентификатора фирмы-контрагента в файл записывается ее символьное имя.
  2. «Использовать в качестве разделителя значений символ» - выбор символа для разделения значений в текстовом файле. По умолчанию используется «,» (запятая). Настройка имеет смысл, если данный символ может использоваться в значениях полей.

Экспорт по DDE

Настройки параметров экспорта данных по DDE осуществляются через пункт меню Система/Настройки/Основные настройки..., раздел «Программа» / «Экспорт данных» подраздел «Экспорт по DDE»:

  1. «Время ожидания подтверждения приема данных от DDE-сервера»:
    • «При выдаче целиком таблицы, секунд (1-3600)» – управляет временем ожидания при первоначальной передаче данных, рекомендуемое значение: «60».
    • «При выдаче очередной строки (1-600)» – предназначена для управления интервалом ожидания во время обновления данных, рекомендуемое значение» «30».
  2. «Количество попыток продолжить экспорт при возникновении ошибки» - количество попыток восстановить соединение в случае возникновения ошибки передачи. Значение по умолчанию: «0».
  3. «Новый поток на отдельный DDE-сервер» - включает многопоточный экспорт данных на разные DDE-серверы. Состояние по умолчанию – выключено.
  4. «MS Excel» - поддержка локализованных версий MS Excel для разных языков. Возможные значения:
    • «Английский» (по умолчанию);
    • «Русский»;
    • «Немецкий»;
    • «Французский»;
    • «Польский».

Настройки 1-3 служат для управления интервалом ожидания при занятости DDE-сервера.

Для предотвращения разрывов в передаче данных, вызванных занятостью DDE-сервера (например, при настройке формул в таблице MS Excel) можно увеличить второй параметр, например, до 40 секунд.


Изменение языка интерфейса

меню Система/Настройки/Языковые установки...

Изменение языка интерфейса осуществляется следующим способом:

  1. Выберите пункт меню Система/Настройки/Языковые установки....
  2. В открывшемся окне выберите из списка «Язык» искомое название языка.
  3. Нажмите кнопку «Установить».
  4. Для выполнения операции перезапустите программу.

Для выполнения операции необходимо, чтобы возможность изменения языка поддерживалась данным сервером QUIK.


Сохранение / восстановление конфигурации из файла

  • Сохранение конфигурации экрана
  • Восстановление конфигурации экрана
  • Автоматическое сохранение конфигурации окон

    • Сохранение конфигурации экрана

    Система QUIK может автоматически запоминать конфигурацию экрана, включая расположение окон и их настройки при каждом завершении работы с программой. Данное свойство активизируется через пункт меню Система/Настройки/Основные настройки..., раздел «Программа» / «Файлы настроек», установить флажок «Сохранять настройки в файл при выходе». В поле «Использовать файл настроек» указан файл по умолчанию, при необходимости его можно поменять на другой.

    Кроме сохранения конфигурации окон при выходе из программы, предусмотрена запись конфигурации в виде файла вручную. Для сохранения конфигурации используйте пункт меню Система/Сохранить настройки в файл.... Такая возможность предотвращает внесение случайных изменений в конфигурацию окон, а также позволяет нескольким пользователям работать за одним терминалом системы со своими индивидуальными настройками.

    Восстановление конфигурации экрана

    Чтобы загрузить конфигурацию экрана из файла, откройте пункт меню Система/Загрузить настройки из файла... и выберите нужный файл с сохраненными настройками. При загрузке настроек из файла можно либо закрывать окна предыдущей конфигурации, либо не закрывать, объединив на экране открываемую конфигурацию с предыдущей. Свойство активизируется установкой флажка «Закрывать все окна перед загрузкой файла настроек».

    При загрузке данных из файлов, созданных более поздними версиями Рабочего места QUIK относительно используемой, выдается предупреждение вида: «Файл настроек <Имя файла> сделан более поздней версией терминала QUIK, текущая версия не сможет загрузить его корректным образом. Продолжить загрузку файла настроек?».

    Пример переноса таблицы из одной конфигурации в другую:

    1. Откройте конфигурацию окон, в которой содержится переносимая таблица.
    2. Закройте в ней все окна, кроме переносимой таблицы.
    3. Сохраните конфигурацию в файл с новым именем.
    4. Откройте пункт меню Система/Настройки/Основные настройки..., раздел «Программа» / «Файлы настроек» и снимите флажок «Закрывать все окна перед загрузкой файла настроек».
    5. Загрузите из файла конфигурацию, в которую требовалось добавить переносимую таблицу. Теперь на экране все окна этой конфигурации, плюс переносимая таблица, которая не была закрыта при загрузке новой конфигурации.
    6. Сохраните конфигурацию в файл.

    Таким же образом можно переносить и объекты со сложными настройками – графики, группы окон с вкладками.

    Если тема в загружаемых настройках не совпадает с темой текущего Рабочего места QUIK, и включена настройка «Заменять сохраненные цвета при загрузке файла настроек», то для загружаемого файла цветовые настройки изменяются на соответствующие цветовые настройки текущей установленной темы. Резервная копия оригинального файла настроек сохраняется в том же каталоге, где находится исходный файл.

    Тема Рабочего места QUIK определяется настройкой «Оформление интерфейса» (Система/Настройки/Основные настройки…, раздел «Программа»).

    Автоматическое сохранение конфигурации окон

    Для устранения проблем с восстановлением конфигурации окон QUIK после различных сбоев (неожиданное выключение питания компьютера и т.п.) предусмотрена возможность автоматического сохранения резервной копии последней конфигурации окон. Она производится автоматически при выходе из QUIKа либо при сохранении пользователем настроек окон в файл. При этом предыдущая версия конфигурации сохраняется в файл с именем вида:

    <имя_файла_конфигурации>.wnd.sav

    Например, при выходе из клиентского места и автосохранении новой конфигурации в файл info.wnd будет автоматически создан резервный файл info.sav.wnd. Если установлен флажок «При сохранении файла настроек делать резервную копию», то версия конфигурации дополнительно сохраняется в подкаталог WNDSAV в файл с именем вида:

    <имя_файла_конфигурации>.<ггггммдд_ччммсс>.wnd

    Например, для info.wnd мы получаем файл с именем:

    info.20140509_210419.wnd

    При сохранении настроек окон через меню Система/Сохранить настройки в файл... предыдущая версия конфигурации сохраняется в подкаталог WNDSAV в файл с именем вида:

    <имя_файла_конфигурации>.<ггггммдд_ччммсс>.wnd

    Например, для info.wnd мы получаем файл с именем:

    info.20140509_210419.wnd

    Автоматическое сохранение конфигурации можно отключить, сняв флажок «При сохранении файла настроек делать резервную копию» в пункте меню Система/Настройки/Основные настройки..., раздел «Программа» / «Файлы настроек».


Редактор горячих клавиш

меню Система / Настройки / Редактор горячих клавиш...
  • Наборы горячих клавиш
  • Редактирование набора горячих клавиш

    • Сочетания «горячих клавиш», используемых для обращения к функциям программы с клавиатуры, могут быть изменены при помощи Редактора горячих клавиш. Предусмотрена возможность создания нескольких пользовательских наборов команд. При этом можно восстановить первоначальные настройки, выбрав набор «Горячие клавиши по умолчанию». Окно «Сочетания горячих клавиш» можно открыть нажатием клавиш «Ctrl»+«H».

    Наборы горячих клавиш

    По умолчанию в Рабочем месте QUIK применяются сочетания «горячих клавиш», перечень которых приведен в Приложении. Набор «Горячие клавиши по умолчанию» недоступен для редактирования. Чтобы открыть его для просмотра, дважды нажмите левую кнопку мыши на строке с его названием.

    Для изменения сочетания клавиш необходимо создать новый пользовательский набор клавиш, в котором производить необходимые изменения.

    Действия с набором клавиш выполняются нажатием на кнопки в нижней части окна:

    • «Добавить» - создать новый набор клавиш. При создании нового набора за основу берется набор, выбранный в списке. Это исключает необходимость повторного указания в наборе комбинаций, которые не требуется изменять,
    • «Редактировать» - изменить выбранный набор.
    • «Удалить» - удалить выбранный набор.
    • «Сохранить» - принять произведенные изменения и закрыть данное окно.
    • «Отмена» - закрыть окно без сохранения изменений.
    • «Справка» - показать справку по данной функции.

    Выбранный для использования набор клавиш отмечается в списке символом [image]. При нажатии кнопки «Сохранить» все комбинации горячих клавиш заменяются настройками из выбранного пользовательского набора.

    Редактирование набора горячих клавиш

    Окно создания / редактирования пользовательского набора горячих клавиш вызывается нажатием кнопки «Создать» / «Редактировать» в окне «Сочетания горячих клавиш».

    Окно содержит следующие настройки:

    1. «Название набора горячих клавиш» – изменить название набора горячих клавиш.
    2. Таблица с сочетаниями клавиш – список комбинаций клавиш, используемых в данном наборе. Таблица содержит столбцы:
      • Вид кнопки на панели инструментов программы, соответствующей данному действию.
      • «Сочетание клавиш» – назначенное сочетание клавиш для вызова действия.
      • «Описание команды» – текстовое описание действия.

      В таблице перечислены все доступные в Рабочем месте команды. Перечень сочетаний клавиш, используемых по умолчанию, приведен в п. «Список управляющих клавиш». Пользователь может задать новое сочетание клавиш для любой команды, а также назначить сочетания клавиш для тех команд, для которых они не были назначены по умолчанию.

    3. «Поиск по сочетаниям клавиш и описаниям команд» – найти в списке комбинацию клавиш или описание, содержащую введенную подстроку. Найденные строки отображаются в списке выше.
    4. «Новое сочетание клавиш» - ввести комбинацию клавиш для выбранного действия из списка. Для ввода необходимо переместить курсор в это поле и нажать новую комбинацию. Справа расположены кнопки для выполнения действий с введенным сочетанием клавиш:
      • «Установить» - заменить сочетание клавиш в списке на выбранное,
      • «Очистить» - стереть сочетание клавиш в окне ввода,
      • «Сбросить» - удалить настройку сочетания клавиш для данной функции.
    5. «Уже используется в команде» - информационное поле, в котором отображается описание действия, для которого уже назначено выбранное сочетание клавиш. Если поле не пустое, присвоить выбранное сочетание невозможно.

    При нажатии кнопки «Сохранить» изменения вступают в силу. Нажатием кнопки «Отмена» окно закрывается без сохранения изменений. Для сброса изменений и возвращения стандартных настроек клавиш нажмите кнопку «По умолчанию».


Приложение

  • Назначение элементов Панели управления
  • Назначение пунктов меню программы
  • Список управляющих клавиш
  • Описание настроек программы


Назначение элементов Панели управления

Панель Элемент Действие

Стандартная

 Установить соединение с сервером
Разорвать соединение с сервером
Открыть диалог создания нового окна
Открыть окно настройки нового графика
Открыть окно настройки нового графика доходности облигаций
Открыть окно настройки новой Таблицы текущих торгов
Открыть окно настройки новой Таблицы обезличенных сделок
Редактировать настройки выбранного окна
Настроить экспорт данных из выбранной таблицы по DDE
Настроить экспорт данных из выбранной таблицы через ODBC
Показать окно сообщений
Выполнить транзакцию Общим способом выполнения транзакций
Открыть окно ввода новой заявки
Снять выбранную неисполненную заявку
Заменить выбранную неисполненную заявку
Открыть окно ввода новой условной заявки

Свои таблицы

Создать Таблицу сделок
Создать Таблицу заявок
Создать Таблицу стоп-заявок
Создать таблицу «Позиции по деньгам»
Создать таблицу «Позиции по инструментам»
Создать таблицу «Клиентский портфель»
Создать таблицу «Состояние счета»

Поиск инструмента

Найти инструменты, имеющие в названии или коде указанную подстроку
Поле ввода строки для поиска

Общий фильтр клиентов

Сбросить настройки фильтра
Подставлять код клиента из фильтра в формы подачи заявок
Установить в таблицах фильтр по параметру «Код Клиента»

Общий фильтр рынков

 Сбросить настройки фильтра
Установить в таблицах фильтр по параметру «Выбранные классы»

График
Добавить новый график в выбранное окно (диаграмму)
Изменить величину интервала
Настроить отображение информации о положении курсора в области построения графика. Описание см. ниже
Отобразить всю область графика в окне, если он был увеличен или уменьшен
Увеличить масштаб графика
Уменьшить масштаб графика
Измерить расстояние между точками на графике
Включить режим ввода заявки из окна диаграммы
Перемещать график с помощью «захвата» мышью
Рисовать трендовые линии и фигуры
Нанести метку на график
Поместить на график изображение, выбранное из набора встроенных картинок
Выключить / включить отображение на графике трендовых линий, фигур и меток
Закрепить выбранный на панели инструмент
Притягивать точки трендовых линий и фигур к ближайшим ценам свечей

Окно сообщений

 Очистить все записи в Окне сообщений
Перейти к первому сообщению
Перейти к предыдущему сообщению
Перейти к следующему сообщению
Перейти к последнему сообщению


Назначение пунктов меню программы

Раздел меню | Пункт меню | Действие

Система

 Установить соединение Начать новый сеанс связи с сервером
Разорвать соединение | Прекратить текущий сеанс связи с сервером
Соединения... | Посмотреть и редактировать настройки соединения с сервером
Заказ данных | Содержит подменю:
  • Перезаказать данные…
             Очистить полученные данные и заказать их заново
    • Замена инструментов
               Заменить инструменты с истекающим сроком обращения
      • Склейка архивов графиков
                 Объединить графики автоматически заменяемых инструментов с коротким периодом обращения (фьючерсы)
        Получение файлов... | Выбрать вручную файлы для получения с сервера
        Сохранить настройки в файл… | Записать в файл настройки таблиц программы
        Загрузить настройки из файла… | Прочитать из файла настройки таблиц программы
        Настройки | Содержит подменю:
        • Основные настройки…
                   Настроить интерфейс программы, параметры приема сообщений и ввода заявок
          • Соединение с Интернетом…
                     Настроить параметры соединения через прокси-сервер
            • Языковые установки…
                       Выбрать язык интерфейса
              • Редактор горячих клавиш…
                         Настроить сочетания клавиш для быстрого вызова функций программы
                • Параметры инструментов…
                           Настроить параметры инструментов
                  Справка | Смотреть справочную информацию об использовании программы
                  О программе | Содержит подменю:
                  • Версия программы
                             Смотреть информацию об авторах и версии программы
                    • Проверить обновление программы
                               Произвести автоматическое обновление версии программы
                      • Компоненты…
                                 Смотреть информацию о компонентах и плагинах используемой версии программы
                        • Информационное окно…
                                   Настроить окно с информацией о состоянии соединения с сервером
                          Выход | Закончить работу с программой

                          Создать окно

                                   * График… Построить новый график
                          * Текущие торги… | Создать новую Таблицу текущих торгов
                          * Таблица обезличенных сделок… | Создать новую Таблицу обезличенных сделок
                          * Котировки… | Создать новую Таблицу котировок («стакан»)
                          * Состояние счета | Создать новую таблицу «Состояние счета»
                          * Заявки | Создать новую Таблицу Заявок
                          * Стоп-заявки | Создать новую Таблицу стоп-заявок
                          * Сделки | Создать новую Таблицу сделок
                          Карман транзакций… | Создать новую таблицу «Карман транзакций»
                          Доска опционов… | Создать новую таблицу «Доска опционов»
                          * Новости | Создать новую таблицу новостей
                          * Окно сообщений Трейдера | Создать новую Таблицу сообщений Трейдера
                          * Окно оповещений | Создать Окно оповещений
                          Клиентский портфель | Создать новую таблицу «Клиентский портфель»
                          Позиции по инструментам | Создать новую таблицу «Позиции по инструментам»
                          Позиции по деньгам | Создать новую таблицу «Позиции по деньгам»
                          Торговые счета | Создать новую Таблицу торговых счетов
                          Ограничения по клиентским счетам | Создать новую таблицу «Ограничения по клиентским счетам»
                          Позиции по клиентским счетам | Создать новую таблицу «Позиции по клиентским счетам»
                          Внебиржевые заявки | Создать новую Таблицу заявок на внебиржевые сделки
                          Безадресные внебиржевые заявки | Создать новую Таблицу безадресных заявок на внебиржевые сделки
                          РПС котировки… | Создать новую Таблицу котировок («стакан») для режима РПС
                          Сделки для исполнения | Создать новую Таблицу сделок для исполнения
                          Отчеты по сделкам для исполнения | Создать новую Таблицу отчетов по сделкам для исполнения
                          Информация по кодам расчетов | Создать новую таблицу «Информация по кодам расчетов» по выбранному инструменту
                          Обязательства и требования по активам [ЦК] | Создать новую таблицу обязательств и требований по активам (Центральный Контрагент)
                          Параметры процентных рисков [ЦК] | Создать новую таблицу параметров процентных рисков (Центральный Контрагент)
                          Параметры рыночных рисков [ЦК] | Создать новую таблицу параметров рыночных рисков (Центральный Контрагент)
                          Индивидуальные риск параметры [ЦК] | Создать новую таблицу индивидуальных риск параметров (Центральный Контрагент)
                          Обязательства и требования по активам [Валюта] | Создать новую таблицу обязательств и требований по активам (Валюта)
                          Параметры процентных рисков [Валюта] | Создать новую таблицу параметров процентных рисков (Валюта)
                          Параметры рыночных рисков [Валюта] | Создать новую таблицу параметров рыночных рисков (Валюта)
                          Индивидуальные риск параметры [Валюта] | Создать новую таблицу индивидуальных риск параметров (Валюта)
                          Обязательства ММ по фондовому и валютному рынкам | Создать новую Таблицу обязательств маркет-мейкера по фондовому и валютному рынкам
                          Расширенные обязательства маркет-мейкера | Создать новую таблицу «Расширенные обязательства маркет-мейкера по фондовому и валютному рынкам»
                          Обязательства маркет-мейкера по срочному рынку | Создать новую таблицу «Обязательства маркет-мейкера по срочному рынку»
                          График доходности… | Создать диаграмму доходности облигаций
                          Таблица Истории… | Создать новую Таблицу истории значений параметров
                          Таблица Изменений… | Создать новую Таблицу изменений параметров
                          Позиции участника по деньгам | Создать новую таблицу «Позиции участника по деньгам»
                          Позиции участника по инструментам | Создать новую таблицу «Позиции участника по инструментам»
                          Позиции участника по торговым счетам | Создать новую таблицу «Позиции участника по торговым счетам»
                          Позиции по инструментам на выбранных счетах | Создать новую таблицу «Позиции по инструментам на выбранных счетах»
                          Объединенные котировки… | Создать новую таблицу «Объединенные котировки»
                          Таблица транзакций | Создать новую Таблицу транзакций
                          Таблица сообщений | Создать новую Таблицу системных сообщений
                          Клиентские транзакции | Создать новую Таблицу запросов клиентов на исполнение заявок
                          Информация об участниках | Создать новую Таблицу участников торгов
                          Информационное окно… | Настроить окно с информацией о состоянии соединения с сервером
                          Переводы НКЦ | Создать новую таблицу «Переводы НКЦ»
                          Запрет на операции | Создать новую таблицу «Запрет на операции»
                          Типы переводов | Создать новую таблицу «Типы переводов»
                          Расчетные коды | Создать новую таблицу «Расчетные коды»
                          Все типы окон… | Создать новое окно по выбранной таблице
                          Настроить меню… | Настроить набор пунктов в меню «Создать окно»

                          Действия

                                   Вызов контекстного меню для активного окна

                          Брокер

                                   Загрузить позиции из файла… Загрузить из файла входящие значения остатков и позиций клиентов по инструментам и денежным средствам
                          Сохранить позиции в файл… | Записать в файл текущие значения остатков и позиций из таблицы «Позиции по деньгам» и таблицы «Позиции по инструментам»
                          Корректировать позиции через файл… | Настроить механизм динамической корректировки позиций клиентов внешней программой
                          Сохранить лимиты по срочному рынку… | Записать в файл текущие значения позиций и лимитов из таблиц «Ограничения по клиентским счетам» и «Позиции по клиентским счетам»
                          Загрузить лимиты по срочному рынку… | Загрузить из файла входящие значения позиций и лимитов для таблиц «Ограничения по клиентским счетам» и «Позиции по клиентским счетам»
                          Удалить все позиции по ден. средствам… | Удалить все значения из таблицы «Позиции по деньгам»
                          Удалить все позиции по инструментам… | Удалить все значения из таблицы «Позиции по инструментам»
                          Отчет по позициям… | Получить отчет об установленных позициях для определенного пользователя за указанный день

                          Сервисы

                                   Общие фильтры… Настроить фильтры, общие для всех таблиц либо таблиц на активной вкладке
                          Снятие заявок по условию | Отозвать группу активных заявок, удовлетворяющих заданному условию
                          Экспорт/импорт данных | Содержит подменю:
                          • Экспорт в системы тех. анализа
                                     Настроить экспорт данных для технического анализа
                            • Начать экспорт таблиц по DDE
                                       Начать вывод по DDE из всех таблиц, имеющих настройки экспорта
                              • Остановить экспорт таблиц по DDE
                                         Остановить вывод по DDE из всех таблиц, из которых выполнялся экспорт данных
                                • Начать экспорт таблиц по ODBC
                                           Начать вывод по ODBC из всех таблиц, имеющих настройки экспорта
                                  • Экспорт инструментов по ODBC…
                                             Начать вывод по ODBC очередей заявок по выбранным инструментам, без создания Таблицы котировок
                                    • Импорт транзакций из файла…
                                               Настроить механизм импорта транзакций из файла
                                      • Внешние транзакции…
                                                 Настроить импорт транзакции через API
                                        Изменить пароль | Изменить пароль пользователя
                                        QPILE скрипты… | Загрузить из файла новую структуру QPILE скрипта
                                        Lua скрипты… | Загрузить из файла новую структуру Lua скрипта

                                        Окна

                                                 Закрепить окно Зафиксировать размер и положение окна на мониторе и на вкладке
                                        Убрать заголовок | Отключение отображения строки с заголовком окна
                                        Поверх всех окон | Отображать окно поверх всех открытых окон при любых перемещениях
                                        Переместить окно на вкладку | Переместить выбранное окно с одной вкладки на другую. Содержит подменю:
                                        • Показать на всех
                                                   Отображает выбранное окно на всех вкладках
                                          • Вкладка <N>
                                                     Перемещает выбранное окно на указанную вкладку
                                            Показать / убрать вкладки | Показать / убрать отображение экранных вкладок
                                            Стопкой | Расположить окна по порядку, одно над другим
                                            Колонками | Расположить окна равномерно по горизонтали
                                            Рядами | Расположить окна равномерно по вертикали
                                            Выровнять значки | Упорядочить свернутые в значки окна внизу экрана
                                            Закрыть все | Закрыть все окна
                                            Менеджер окон | Открыть Менеджер окон

                                            * - таблицы, входящие в стандартный набор


Список управляющих клавиш

Группа | Комбинация клавиш | Действие

Общие

 «F1» Вызов справки по программе
«F3» | Продолжить поиск
«F4» | Создать Таблицу котировок (очередей заявок)
«F5» | Обновить выбранное окно
«F7» | Создать новое окно, выбрав из списка существующих окон
«F9» | Открыть окно настроек клиентского места
«Alt»+«1»...«Alt»+«9» | Перейти на вкладку с номером 1 .. 9
«Alt»+«Q» | Прекратить соединение с сервером
«Ctrl»+«C» или «Ctrl»+«Insert» | Копировать выделенную строку / диапазон строк таблицы в буфер обмена
«Ctrl»+«Shift»+«C» или «Ctrl»+«Shift»+«Insert» | Копировать содержимое таблицы в буфер обмена
«Ctrl»+«E» | Редактировать таблицу или график
«Ctrl»+«F» | Начать поиск
«Ctrl»+«G» | Настроить Общие фильтры
«Ctrl»+«H» | Настроить список горячий клавиш
«Ctrl»+«L» | Настроить вывод таблицы через DDE сервер
«Ctrl»+«N» | Создать новую таблицу на основе уже существующей
«Ctrl»+«Alt»+«A» | Создать локальное оповещение о наступлении события из таблицы
«Ctrl»+«Alt»+«S» | Создать SMS-оповещение о наступлении события из таблицы
«Ctrl»+«A» | Заменить оповещение в таблице «Окно оповещений»
«Ctrl»+«D» | Снять оповещение в таблице «Окно оповещений»
«Ctrl»+«O» | Настроить вывод таблицы по ODBC
«Ctrl»+«P» | Печать таблицы
«Ctrl»+«Q» | Установить соединение с сервером
«Ctrl»+«T» | Общий способ выполнения транзакции
«Ctrl»+«W» | Подобрать ширину столбцов в таблице
«Ctrl»+«F4» | Закрыть текущее окно
«Ctrl»+«F6» или «Ctrl»+«Tab» | Перейти к следующему окну
«Ctrl»+«F11» | Задать параметры для доступных скриптов
«Shift»+«Ctrl»+«F6» или «Shift»+«Ctrl»+«Tab» | Перейти к предыдущему окну
«Shift»+«Ctrl»+«L» | Начать вывод через DDE из всех таблиц, имеющих настройки экспорта
«Shift»+«Ctrl»+«O» | Начать вывод по ODBC из всех таблиц, имеющих настройки экспорта
«Shift»+«Ctrl»+«S» | Остановить экспорт по DDE из всех таблиц
«Ctrl»+«Shift»+«Y» | Отключить все установленные пользовательские фильтры
«Ctrl»+«Y» | Включить все пользовательские фильтры
«Alt»+«Y» | Очистить все условия пользовательских фильтров
«Ctrl»+«Shift»+«R» | Отключить условное форматирование
«Ctrl»+«R» | Включить условное форматирование
«Alt»+«R» | Очистить все условия форматирования
«Ctrl»+«Shift»+«F» | Открытие диалога поиска инструмента по коду или названию
«Alt»+«L» | Зафиксировать размер и положение окна на мониторе и на вкладке
«Alt»+«B» | Отключение отображения строки с заголовком окна
«Alt»+«T» | Отображать окно поверх всех открытых окон при любых перемещениях
«Ctrl»+«B» | Показать / убрать экранные вкладки
«Alt»+«M» | Открыть Менеджер окон

Управление заявками

 «F2» Новая заявка
«F6» | Новая стоп-заявка
«Alt»+«F2» | Показать/скрыть панель ввода заявки в котировочном окне
«Alt»+«F6» | Активировать стоп-заявку
«Ctrl»+«F2» | Новая объединенная заявка
«Ctrl»+«F8» | Снять все активные заявки из активного Окна котировок
«Ctrl»+«A» | Заменить заявку
«Ctrl»+«D» | Снять заявку
«Ctrl»+«Z» | Снять все активные заявки на покупку из активного Окна котировок
«Ctrl»+«X» | Снять все активные заявки на продажу из активного Окна котировок
«Ctrl»+«1» | Выставить лимитированную заявку на покупку с заданными ценой и количеством
«Ctrl»+«2» | Выставить рыночную заявку на покупку с указанным количеством
«Ctrl»+«3» | Выставить лимитированную заявку на продажу с заданными ценой и количеством
«Ctrl»+«4» | Выставить рыночную заявку на продажу с указанным количеством
«Shift»+«F6» | Выполнить команду «Сделать стоп-заявку своей».
«Shift»+«Alt»+«D» | Снятие заявок по условию

Окно ввода заявки

 «+» на цифровой клавиатуре Увеличить цену заявки на 1 минимальное значение шага цены
«-» на цифровой клавиатуре | Уменьшить цену заявки на 1 минимальное значение шага цены
«Ctrl»+«+» на цифровой клавиатуре | Увеличить цену заявки на 10 минимальных значений шага цены
«Ctrl»+«-» на цифровой клавиатуре | Уменьшить цену заявки на 10 минимальных значений шага цены
«PageUp» | Увеличить количество лотов в заявке на 1
«PageDown» | Уменьшить количество лотов в заявке на 1
«Ctrl»+«PageUp» | Увеличить количество лотов в заявке на 10
«Ctrl»+«PageDown» | Уменьшить количество лотов в заявке на 10
<пробел> | Изменить направление заявки на встречное (требуется настройка)
«Tab» | Переход к следующему полю заявки
«Shift»+«Tab» | Переход к предыдущему полю заявки
«Enter» | Отправить заявку
«Esc» | Закрыть окно без отправки заявки
«K» | Добавить 3 разряда («000») к ненулевому значению в поле цены, количества или объема
«T» | Добавить 3 разряда («000») к ненулевому значению в поле цены, количества или объема
«M» | Добавить 6 разрядов («000000») к ненулевому значению в поле цены, количества или объема
«B» | Добавить 9 разрядов («000000000») к ненулевому значению в поле цены, количества или объема
«Y» | Добавить 9 разрядов («000000000») к ненулевому значению в поле цены, количества или объема

Окно котировок

 «Alt»+«W» Показать посередине окна строку таблицы с ценой, равной среднему арифметическому между лучшим спросом и лучшим предложением. Действительно только при включенном режиме «Разреженный стакан»

Панель инструментов Окна котировок

 «Alt»+«Z» Взять величину отступа цены из значения «Отступ 1», указанного в настройках данного окна.
«Alt»+«X» | Взять величину отступа цены из значения «Отступ 2», указанного в настройках данного окна.
«Alt»+«C» | Взять величину отступа цены из значения «Отступ 3», указанного в настройках данного окна.
«Alt»+«V» | Взять величину отступа цены из значения «Отступ 4», указанного в настройках данного окна.
«Alt»+«A» | Взять количество инструментов из поля «Количество» в выбранной строке окна. Если включен «Режим быстрого ввода заявки», то количество инструментов берется из поля «Сумма лучших». Подробнее см. Настройка объемов заявки
«Alt»+«S» | Взять количество инструментов из значения «Объем 1», указанного в настройках данного окна
«Alt»+«D» | Взять количество инструментов из значения «Объем 2», указанного в настройках данного окна
«Alt»+«F» | Взять количество инструментов из значения «Объем 3», указанного в настройках данного окна

Окно «Состояние счета»

 «Ctrl»+«K» Закрыть позицию
«Ctrl»+«I» | Перевернуть позицию
«Ctrl»+«Shift»+«K» | Закрыть все позиции

Окно «Текущая таблица параметров»

 «Alt»+«I» Открыть окно, содержащее информацию по инструменту

График

 «Insert» Добавить график (индикатор) на текущую диаграмму
Num «+» | Увеличить горизонтальный масштаб графика
Num «-» | Уменьшить горизонтальный масштаб графика
«/» Показать весь график


Описание настроек программы

Пункт меню / Раздел | Назначение
Основные настройки... / Программа | Настройки интерфейса программы
Основные настройки... / Программа / Панели инструментов | Отображение панелей инструментов
Основные настройки... /Программа / Получение данных | Параметры получения данных с сервера
Основные настройки… / Программа / Сохранение данных | Параметры сохранения данных
Основные настройки... / Программа / Файлы настроек | Управление файлами настроек
Основные настройки… / Программа / Контекстное меню | Параметры контекстного меню
Основные настройки... / Программа / Экспорт данных | Параметры экспорта данных в Excel
Основные настройки... / Программа / Буфер обмена | Настройки записи данных в буфер обмена Windows
Основные настройки… / Программа / Шрифты | Настройка шрифтов, используемых в таблицах и диалогах
Основные настройки… / Программа / Звуки | Настройка звуковых сигналов
Основные настройки... / Программа / Шифрование | Настройка средств шифрования данных
Основные настройки… / Новости | Настройка параметров новостей
Основные настройки… / Торговля | Настройка параметров торговых операций
Основные настройки... / Торговля / Заявки | Настройки окна ввода заявки
Основные настройки… / Торговля / Заявки / Формы ввода | Настройка формы ввода заявки
Основные настройки... / Торговля / Заявки / Клиентские заявки | Настройка режима приема клиентских транзакций с подтверждением брокером
Основные настройки… / Торговля / Заявки / Алгоритмические заявки | Настройка расчета цены алгоритмических заявок типа «Волатильность». Описание приведено в Руководстве пользователя «Алгоритмические заявки», п. 8.2
Основные настройки… / Торговля / Заявки / ОМS-заявки | Настройка параметров ОМS-заявок. Описание приведено в Руководстве пользователя «Модуль OMS Manager», п. 22
Основные настройки… / Торговля / Заявки / Внебиржевые заявки | Настройка параметров внебиржевых заявок
Основные настройки… / Торговля / Настройка счетов | Настройка счетов депо
Основные настройки… / Торговля / Закрытие позиций | Настройки параметров закрытия позиций
Основные настройки… / Торговля / Клиентский портфель | Настройка параметров работы с Клиентским портфелем
Основные настройки… / Торговля / Котировки | Настройка параметров работы с котировками
Основные настройки… / Торговля / Котировки / Объединенные котировки | Настройка параметров работы с объединенными котировками
Основные настройки... / Торговля / Денежная единица | Выбор денежной единицы
Основные настройки… / Торговля / ЭЦП | Настройка параметров ЭЦП
Основные настройки… / Сообщения | Настройки сообщений
Основные настройки… / Сообщения / Сообщения трейдера | Настройки сообщений трейдера
Основные настройки… / Сообщения / Локальные оповещения | Настройки локальных оповещений
Основные настройки… / Окна | Настройка параметров окон
Основные настройки... / Окна / Таблицы | Настройка параметров работы с таблицами
Соединение с Интернетом... | Настройки параметров соединения через прокси-сервер
Языковые установки... | Выбор языка интерфейса


Раздел 3. Просмотр информации

  • Создание окна
  • Таблица текущих торгов
  • Таблица обезличенных сделок
  • Таблица котировок
  • Состояние счета
  • Таблица заявок
  • Таблица стоп-заявок
  • Таблица сделок
  • Новости
  • Окно сообщений Трейдера
  • Окно оповещений
  • Таблица «Клиентский портфель»
  • Таблица «Купить/Продать»
  • Сводная таблица позиций
  • Позиции по инструментам
  • Позиции по деньгам
  • Таблица «Торговые счета»
  • Таблица ограничений по клиентским счетам
  • Таблица позиций по клиентским счетам
  • Таблица «Доска опционов»
  • Таблица заявок на внебиржевые сделки
  • Таблица безадресных заявок на внебиржевые сделки
  • Таблица «РПС котировки»
  • Таблица котировок РЕПО
  • Таблица сделок для исполнения
  • Таблица заявок-отчетов на сделки РПС
  • Таблица «Коды расчетов»
  • Таблица «Разрешения на получение РПС-котировок»
  • Таблица «Обязательства и требования по деньгам [ЦК]»
  • Таблица «Таблица «Обязательства и требования по активам (расширенные) [ЦК]»
  • Таблица обязательств и требований по активам
  • Таблица параметров процентных рисков
  • Таблица параметров рыночных рисков
  • Таблица «Индивидуальные риск параметры»
  • Таблица «Обязательства и требования по деньгам [Валюта]»
  • Таблица «Валюта: обязательства и требования по активам»
  • Таблица «Валюта: параметры процентных рисков»
  • Таблица «Валюта: параметры рыночных рисков»
  • Таблица «Валюта: индивидуальные риск параметры»
  • Таблица «Валюта: межпродуктовые спреды»
  • Таблица обязательств маркет-мейкеров по фондовому и валютному рынкам
  • Таблица расширенных обязательств маркет-мейкеров по фондовому и валютному рынкам
  • Таблица обязательств маркет-мейкеров по срочному рынку
  • Таблица истории значений параметров
  • Таблица изменений параметров
  • Позиции участника по деньгам
  • Позиции участника по инструментам
  • Позиции участника по торговым счетам
  • Позиции участника по инструментам на выбранных счетах
  • Таблица «Объединенные котировки»
  • Таблица «Карман транзакций»
  • Таблица транзакций
  • Таблица сообщений
  • Таблица запросов клиентов на исполнение заявок
  • Таблица участников торгов
  • Таблица «Информация о трейдерах»
  • Таблица «Переводы НКЦ»
  • Таблица «Запрет на операции»
  • Таблица «Информация по кодам расчетов»
  • Таблица «Типы переводов»
  • Таблица «Расчетные коды»
  • Таблица алгоритмических заявок
  • ПРИЛОЖЕНИЕ 1. Формулы расчета параметров «Клиентского портфеля»
  • ПРИЛОЖЕНИЕ 2

В разделе описаны рабочие окна программы, предназначенные для наблюдения за рыночной информацией, получения новостей и обмена сообщениями с другими пользователями системы.

Под названием окна указан пункт меню, из которого данное окно открывается, а также соответствующая ему кнопка на панели инструментов. Все окна Рабочего места QUIK редактируются нажатием кнопки [image].

Описание общих принципов работы с таблицами Рабочего места QUIK (настройка таблиц, редактирование, правила работы с фильтрами) см. в п. Таблицы.

В данном Руководстве при указании пункта меню, из которого открывается окно, по умолчанию считается, что в меню «Создать окно» добавлены все рабочие окна программы. Если нужное окно отсутствует в меню «Создать окно», то воспользуйтесь пунктом меню «Создать окно / Все типы окон…».


Создание окна

Окно создается одним из следующих способов:

  • Выбором соответствующего пункта в меню Создать окно. В меню Создать окно по умолчанию отображается стандартный набор окон, который может быть изменен пользователем.
  • Выбором пункта меню Создать окно / Все типы окон… или нажатием кнопки [image] на панели инструментов.

    В открывшемся диалоге отображены наименования всех возможных окон, на работу с которыми у пользователя установлены права. Для создания окна выберите в списке соответствующую строку и нажмите кнопку «OK».

См. также: Настройка пункта меню «Создать окно»


Настройка пункта меню «Создать окно»

меню Создать окно / Настроить меню…

Для изменения набора окон, отображающегося в пункте меню Создать окно, выберите пункт меню Создать окно/Настроить меню....

В открывшемся окне «Настройка пункта меню "Создать окно"» из списка доступных (слева) добавьте в список выбранных (справа) необходимые окна и разделители. Для добавления группы окон выберите заголовок нужной группы и нажмите кнопку «Добавить».

Порядок следования окон в списке выбранных изменяется нажатием кнопок справа от списка:

  • – в начало списка;
  • – на одну позицию вверх;
  • – на одну позицию вниз;
  • – в конец списка.
При перемещении по списку группы выделенных окон порядок их следования сохраняется.

Для возврата к стандартному набору окон нажмите кнопку «Стандартный набор».

Доступные группы окон

  • Стандартный набор:
    • График;
    • Текущие торги;
    • Таблица обезличенных сделок;
    • Котировки;
    • Состояние счета;
    • Заявки;
    • Стоп-заявки;
    • Сделки;
    • Новости;
    • Окно сообщений Трейдера;
    • Окно оповещений.
  • Счета и позиции:
    • Клиентский портфель;
    • Позиции по инструментам;
    • Позиции по деньгам;
    • Торговые счета.
  • Фьючерсы и опционы:
    • Ограничения по клиентским счетам;
    • Позиции по клиентским счетам;
    • Доска опционов.
  • РПС и РЕПО:
    • Внебиржевые заявки;
    • Безадресные внебиржевые заявки;
    • РПС котировки;
    • РЕПО котировки;
    • Сделки для исполнения;
    • Отчеты по сделкам для исполнения;
    • Информация по кодам расчетов.
  • Режим торгов с ЦК:
    • Обязательства и требования по деньгам [ЦК];
    • Обязательства и требования по активам (расширенные) [ЦК];
    • Обязательства и требования по активам [ЦК];
    • Параметры процентных рисков [ЦК];
    • Параметры рыночных рисков [ЦК];
    • Индивидуальные риск параметры [ЦК].
  • Валюта:
    • Обязательства и требования по деньгам [Валюта];
    • Обязательства и требования по активам [Валюта];
    • Параметры процентных рисков [Валюта];
    • Параметры рыночных рисков [Валюта];
    • Индивидуальные риск параметры [Валюта];
    • Межпродуктовые спреды [Валюта].
  • Обязательства маркет-мейкера:
    • Обязательства ММ по фондовому и валютному рынкам;
    • Расширенные обязательства маркет-мейкера;
    • Обязательства маркет-мейкера по срочному рынку.
  • Прочее:
    • График доходности;
    • Таблица Истории;
    • Таблица Изменений;
    • Позиции участника по деньгам;
    • Позиции участника по инструментам;
    • Позиции участника по торговым счетам;
    • Позиции участника по инструментам на счетах;
    • Объединенные котировки;
    • Карман транзакций;
    • Таблица транзакций;
    • Информация по кодам расчетов по инструментам…;
    • Клиентские транзакции;
    • Информация об участниках;
    • Информационное окно...;
    • Информация о трейдерах;
    • Переводы НКЦ;
    • Запрет на операции;
    • Типы переводов;
    • Расчетные коды.


Таблица текущих торгов

меню Создать окно / Текущие торги... или кнопка
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Отображение последних значений параметров торгов по выбранным финансовым инструментам.

    Формат таблицы

    В заголовках строк таблицы указаны финансовые инструменты, в заголовках столбцов – параметры инструментов. Значения полей параметров указаны в Приложении к разделу.

    При осуществлении сделки по какому-либо инструменту строка с параметрами данного инструмента выделяется цветом:

    • зеленым – при повышении цены последней сделки;
    • красным – при понижении цены последней сделки;
    • желтым – если сделка совершена по цене, равной предыдущей.

    Списки инструментов и парамтеров, доступных для построения таблицы, зависят от Настройки потока данных, описанной в п. Настройка потока данных. Также на содержание таблицы и периодичность ее обновления влияют настройки получения данных, описанные в п. Подготовка к работе. По умолчанию таблица обновляется 1 раз в секунду.

    К таблице может быть применен Режим связанных окон.

    При включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» дата и время биржевых данных в таблице отображаются с учетом временной зоны компьютера, на котором запущено Рабочее место QUIK.

    Маркировка инструментов с «неточными параметрами»

    На Московской бирже существуют облигации, по которым не рассчитывается НКД / номинал и т.д.

    Информация о неточных параметрах инструмента, транслируемых с Московской биржи, отображается в поле «Неточные параметры» Таблицы текущих торгов.

    При подаче заявки или стоп-заявки (кроме стоп-заявок по исполнению) по инструменту с неточными параметрами, если у пользователя включен запрос подтверждения при отправке заявок, перед отправкой заявки и перед моментом запроса подтверждения на её отправку у пользователя запрашивается подтверждение касательно набора неточных параметров.

    Перечень обозначений неточных параметров, соответствующих маркировке Московской биржи:

    • «С» (нет информации по купону) — отсутствие значения купона на новый купонный период;
    • «G» (изменение купона) — принятие эмитентом решения о критическом изменении купона (например, уменьшение до 0,01 руб., продление срока выплаты до погашения);
    • «N» — отсутствие значения номинала /амортизации на заданную дату;
    • «F» — неверное значение номинала /амортизации;
    • «S» — прекращен расчет НКД, получена информация о некорректности НКД (например, некорректный НКД представлен эмитентом);
    • «А» — неверное значение НКД, МБ не рассчитывает НКД;
    • «M» — проведение ОСВО, наличие информации о проведении эмитентом ОСВО по вопросам, связанным с трансляцией некорректного параметра (например, об отмене амортизационной выплаты).

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE сервер, экспорта через ODBC и сохранения в текстовый файл.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Новая заявка» (или «F2») – подать новую заявку.
    • «Новая Айсберг заявка» – подать новую Айсберг заявку.
    • «Новая стоп-заявка» (или «F6») – подать новую стоп-заявку заявку.
    • «Новая безадресная заявка» – подать новую безадресную заявку.
    • «Управление сессией» – открыть диалог настройки транзакции «Управление сессией» для выбранного инструмента. Отображается, если для класса доступна транзакция «Управление сессией».
    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.
    • «[<Класс>] <Наименование инструмента>» (или двойное нажатие левой кнопкой мыши на строке таблицы)– открыть Таблицу котировок с очередями лучших заявок по инструменту.
    • «Графики <вид графика>» – открыть график.
    Для инструментов, по которым транслируется параметр «Индикативная котировка» (например, по инструментам Санкт-Петербургской биржи), строится график типа «свечи» по параметру «Индикативная котировка». Для построения по таким инструментам графика цены и объема по параметрам Таблицы обезличенных сделок пропишите в секции [general] файла info.ini параметр price-and-volume-charts-datasource=0.
    • «Диаграмма доходности облигаций» – создать график доходности облигаций по всем инструментам с типом «Облигации» из таблицы текущих торгов. Отредактировать созданную диаграмму можно используя режим «drag-and-drop», удерживая нажатой левую кнопку мыши, перемещайте необходимый инструмент в окно диаграммы из следующих таблиц:
      • Таблица текущих торгов;
      • «Купить/Продать»;
      • Таблица с результатами поиска инструментов.
    • «Информация об инструменте» (или «Alt»+«I») – открыть окно просмотра информации об инструменте.
    • «Открыть канал» / «Закрыть канал» – включить / выключить режим связанных окон в данной основной таблице.
    • «Оповещение по параметру» – создать оповещение на изменение параметра.
    • «SMS-оповещение по параметру» – создать SMS-оповещение по параметру.
    • «Информация по кодам расчетов» – создать таблицу информации по кодам расчетов выбранного инструмента.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы
    • Формат сохранения в текстовый файл


Настройка таблицы

Значение параметров окна:

  1. «Транспонировать» - при транспонировании таблицы заголовки столбцов становятся заголовками строк, заголовки строк – заголовками столбцов. Данное свойство может использоваться для настройки источников данных для экспорта.
  2. «Вывод по ODBC только изменившихся полей» - при изменении какого-либо параметра Рабочее место QUIK передает базе данных SQL-запрос с обновлением только данного параметра.
  3. «Доступные инструменты» – выбор инструментов и настройка их очередности.
    • «Сортировать по дате погашения» – сортировка инструментов в таблице по возрастанию параметра «Дата погашения». Функция доступна для инструментов с фиксированным сроком обращения.
  4. «Доступные параметры» – выбор отображаемых параметров инструментов и настройка их очередности.
    • «Сортировать по алфавиту» - список доступных параметров сортируется в алфавитном порядке. Функция полезна при редактировании таблицы, для упрощения поиска нужного параметра в списке.
    • «Короткие названия параметров» - в списках доступных и выбранных параметров полные наименования заменяются на короткие.
  5. «Цветовые настройки» – при установке признака или нажатии кнопки «Настроить» открывается окно цветовых настроек текста и фона строк таблицы:
    • «Выделять строки цветом» – включает/отключает подсветку строк таблицы выбранными цветами текста и фона при изменении параметра «Цена последней сделки»:
      • «Если цена последней сделки является минимальной или максимальной за сессию» – строка выделяется только в случае достижения ценой последней сделки нового максимального или минимального уровня.
      • «Если произошло изменение цены последней сделки к предыдущей» – строка выделяется, в зависимости от направленности изменения цены последней сделки по отношению к предыдущему значению цены последней сделки.
        1. Для отключения подсветки строк при совершении сделок по одной цене (по умолчанию выделяются желтым цветом) установите в строке «Цена последней сделки равна предыдущей» основные цвета шрифта и фона таблицы.
        2. Для корректной работы функции выделения цветом добавьте параметры «Цена последней сделки», «Количество сделок за сегодня» и «Время последней сделки» в список получаемых с сервера параметров (пункт меню Система/Настройки/Основные настройки/Программа/Получение данных/Котировки, флажок «Фильтр параметров»).

        Нажатием кнопки «По умолчанию» настройки цветов приводятся в начальное состояние.

      • «Цвет фона», «Цвет текста» – выбор основных цветов фона и шрифта таблицы.
      • «Раскрасить таблицу в полоску» - включает/отключает режим чередования цветов в таблице.
        • «Подсвечивать каждые .. строчек» – выбор интервала чередования.
        • «Цвет фона», «Цвет текста» – выбор цвета фона и шрифта для чередования.

См. также:

  • Таблица текущих значений параметров
  • Формат сохранения в текстовый файл


Информация об инструменте

  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Окно открывается выбором пункта «Информация об инструменте» контекстного меню таблицы «Текущие торги» и содержит информацию по определенному инструменту.

    Формат таблицы

    Таблица содержит список параметров выбранного инструмента. Набор отображаемых параметров определяется классом выбранного инструмента в соответствии со следующей таблицей:
    Параметр | Значение | Акции | Облигации | Фьючерсы | Опционы
Тип инстр-та | Тип инструмента | + | + | + | +
Подтип инстр-та | Подтип инструмента | + | + | + | +
Инструмент | Наименование инструмента | + | + | + | +
Инструмент сокр. | Краткое наименование инструмента | + | + | + | +
Код инструмента | Биржевой идентификатор | + | + | + | +
ISIN | ISIN-код инструмента | + | + |  |
CFI | CFI-код инструмента | + | + | + | +
Рег.номер | Идентификатор инструмента | + | + |  |
Класс | Наименование класса инструментов | + | + | + | +
Код класса | Идентификатор класса в торговой системе | + | + | + | +
Погашение | Дата погашения |  | + |  |
До погашения | Число дней до погашения |  | + |  |
Номинал | Номинальная стоимость инструмента | + | + |  |
Валюта | Символьный код валюты номинала инструмента | + | + | + | +
Точность | Количество значащих цифр после десятичного разделителя в значениях цены | + | + | + | +
Шаг цены | Минимальная величина изменения цены | + | + | + | +
Стоимость шага цены | Стоимость шага цены |  |  | + | +
Статус | Торгуется/Заморожена | + | + | + | +
Лот | Минимально допустимое количество инструментов в одной заявке, штук | + | + | + | +
НКД | Накопленный купонный доход, в ден.выражении |  | + |  |
Размер купона | Величина купона, в ден.выражении |  | + |  |
Баз.актив | Идентификатор инструмента в торговой системе, соответствующий базовому активу срочного контракта |  |  | + | +
Валюта шага цены | Валюта платежа |  |  | + | +
Дата исп. | Дата исполнения инструмента |  |  | + | +
Тип цены фьючерса | Наименование типа цены фьючерса |  |  | + |
Страйк | Цена исполнения опциона (поставки базового актива), в пунктах |  |  |  | +
Тип опциона | Тип опциона, PUT или CALL |  |  |  | +
Марж. | Опцион маржируемый/с уплатой премии |  |  |  | +
Тип | Наименование типа инструмента |  | + |  |
Объем обр. | Объем выпуска инструментов, находящийся в обращении, в штуках | + | + |  |
Тип цены | Тип цены | + | + |  |
Код расчетов | Код расчетов | + | + |  |
Объем в обр. | Объем в обращении | + | + |  |
Дата расч. | Дата расчетов |  | + |  |
Сопряженная валюта | Сопряженная валюта | + | + |  |
Длит.куп. | Продолжительность текущего купонного периода, в календарных днях |  | + |  |
Дата выпл. куп. | Дата выплаты купона |  | + |  |
Оферта | Цена оферты (предварительного выкупа) |  | + |  |
Дата расч.доход | Дата досрочного погашения номинальной стоимости облигации |  | + |  |
Комментарий | Комментарий | + | + |  |
StockCode | Тикер инструмента | + | + | + | +
SEDOL | Идентификатор инструмента из Stock Exchange Daily Official List (SEDOL) | + | + | + | +
RIC | Reuters Instrument Code (RIC) | + | + | + | +
CUSIP | CUSIP Code (идентификатор для северо-американских финансовых инструментов) | + | + | + | +
StockName | Код деривативного контракта в формате QUIK | + | + | + | +
Bloomberg ID | Идентификатор инструмента в Bloomberg (Bloomberg security identifier) | + | + | + | +
Кратность лота | Кратность при вводе количества | + | + | + | +
Агент по размещению | Код фирмы-агента по размещению инструмента | + | + | + | +
Доп. инфо | Ссылка на страницу с информацией об инструменте на сайте брокера | + | + | + | +
Сложный продукт | Тип сложного финансового продукта | + | + | + | +

    К таблице может быть применен Режим связанных окон.

    Доступные функции

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Подключиться к каналу» – привязать окно к основной таблице (подробнее см. Режим связанных окон).
      • «<Название таблицы>» – привязка окна к данной таблице;
      • «Отключить» – отключение связанной таблицы от канала.
    • «Заменить инструмент» – открыть окно замены инструмента.
    • «Копировать все» – копировать содержимое окна в буфер обмена операционной системы.


Замена инструмента

Окно открывается выбором пункта «Заменить инструмент» контекстного меню следующих таблиц:

  • «Информация об инструменте»;
  • «Таблица котировок».

В окне отображается список инструментов для замены.

Признак «Только активные инструменты» позволяет исключить из списка инструменты или контракты, не имеющие заявок, сделок или открытых позиций. Под активными инструментами понимаются такие инструменты, по которым на Бирже в текущую торговую сессию присутствовали либо присутствуют заявки, сделки или открытые позиции (для фьючерсов). Рабочее место QUIK определяет данный факт по значению параметров таблицы «Текущие торги»:

  • «Лучшая цена спроса»;
  • «Лучшая цена предложения»;
  • «Количество сделок»;
  • «Количество открытых позиций».

Если список получаемых параметров задан вручную и в него не входят параметры, указанные выше, то признак «Только активные инструменты» работает некорректно.

Для выполнения замены выберите нужный инструмент в списке и нажмите кнопку «Заменить».


Таблица обезличенных сделок

менюСоздать окно / Таблица обезличенных сделок... или кнопка
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Получение обезличенной (без указания сторон) информации по всем заключенным сделкам. Таблица является источником данных для экспорта в системы технического анализа.

    Для получения информации об источнике обезличенных сделок обратитесь к брокеру.

    Формат таблицы

    Растущая вниз таблица, строки которой идентифицируют последовательность совершенных сделок.

    В столбцах таблицы отображаются следующие парметры:

    Параметр | Значение
    *Номер | Регистрационный номер сделки в торговой системе
    Дата торгов | Дата текущей торговой сессии
    ** Дата | Дата совершения сделки
    *, ** Время | Время совершения сделки по часам торговой системы биржи с точностью до секунды. Формат определяется настройками операционной системы
    Время (мкс) | Количество микросекунд во времени совершения сделки
    Период Период торговой сессии. Возможные значения:
    • «Открытие»;
    • «Нормальный»;
    • «Закрытие»
    Класс | Наименование класса инструментов
    Код инструмента | Биржевой идентификатор, присвоенный инструменту
    Инструмент сокр. | Сокращенное наименование инструмента
    *Инструмент | Наименование инструмента
    *Цена | Цена совершенной сделки, рублей
    *Количество | Количество лотов в сделке с точностью количества инструмента или в штуках
    *Объем | Объем сделки в денежном выражении с точностью валюты цены инструмента, рублей
    *Операция Направление операции. Возможные значения:
    • «Купля» – заключена сделка путем выставления заявки на покупку против находящейся в торговой системе котировки на продажу;
    • «Продажа» – сделка на продажу;
    • «К/П» / «П/К» – «витринная» сделка (сделка вида «Сделка по операции РЕПО с ЦК» или «Адресная сделка по операции РЕПО с ЦК»). Первая буква соответствует направлению сделки первой ноги
    Код расчетов | Код расчетов по сделке для Режима переговорных сделок (РПС) и операций РЕПО
    Доходность | Доходность инструмента, рассчитанная по цене совершенной сделки, %. Параметр относится к сделкам по облигациям
    НКД | Накопленный купонный доход с точностью валюты цены инструмента, рублей. Параметр относится к сделкам по облигациям
    Ставка РЕПО(%) | Ставка РЕПО, в процентах. Параметр операций РЕПО
    Сумма РЕПО | Сумма РЕПО - сумма привлеченных/предоставленных по сделке РЕПО денежных средств, по состоянию на текущую дату с точностью валюты цены инструмента, рублей. Параметр сделок РЕПО ГЦБ
    Объем выкупа РЕПО | Объем сделки выкупа РЕПО с точностью валюты цены инструмента, рублей. Параметр сделок РЕПО ГЦБ
    Срок РЕПО | Срок РЕПО в календарных днях. Параметр сделок РЕПО
    Открытый интерес | Количество открытых позиций с точностью количества инструмента
    Код биржи | Идентификатор биржи
    Площадка исполнения | Идентификатор биржевой площадки, на которой зарегистрирована сделка
    Номинальный объем | Номинальный объем инструмента. Рассчитывается по формуле: «Номинал инструмента» * «Размер лота» * «Количество лотов»
    Расчетная сумма Возможные значения:
    • для облигаций – объем сделки с учетом НКД;
    • для акций – объем сделки
    Индикатор | Идентификатор индикативной ставки
    РЕПО с открытой датой Сделка РЕПО с открытой датой. Возможные значения:
    • «Да»;
    • «Нет»

    * - параметры, выбранные по умолчанию

    ** - при включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» значение отображается с учетом временной зоны компьютера, на котором запущен терминал QUIK

    Для некоторых торговых площадок и режимов торгов (например, для адресных заявок на Украинской бирже) отсутствует возможность получения списка обезличенных сделок.

    К таблице может быть применен Режим связанных окон.

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер, экспорта по ODBC и сохранения в текстовый файл.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Новая заявка» (или «F2») – подать новую заявку.
    • «Новая Айсберг заявка» – подать новую Айсберг заявку.
    • «Новая стоп-заявка» (или «F6») – подать новую стоп-заявку заявку.
    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.
    • «Подключиться к каналу» – привязать окно к основной таблице (подробнее см. Режим связанных окон).
      • «<Название таблицы>» – привязка окна к данной таблице;
      • «Отключить» – отключение связанной таблицы от канала.
    • «[<Класс>] <Наименование инструмента>» (или двойное нажатие левой кнопкой мыши на строке таблицы)– открыть Таблицу котировок с очередями лучших заявок по инструменту.
    • «Построить график» – открыть график.
    • «Сохранить в файл обезличенные сделки из таблицы» – сохранение обезличенных сделок из таблицы в текстовый файл. Параметры обезличенных сделок сохраняются в файл в соответствии с порядком выбранных в таблице столбцов.
    • «Сохранить в файл все обезличенные сделки» – сохранение всех обезличенных сделок из таблицы в текстовый файл.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Формат сохранения в текстовый файл


Настройка таблицы

Значение параметров окна:

  1. «Выбранные классы» – выбор классов, информация по которым отображается в таблице.
  2. «Фильтр инструментов» – настройка фильтра инструментов возможна внутри каждого класса из списка «Выбранные классы». Фильтр используется для создания Таблицы обезличенных сделок по определенному инструменту (группе инструментов).

    Изначально в диалоге создания таблицы обезличенных сделок доступны все классы, по которым у пользователя есть право на получение обезличенных сделок. Список классов, выбранных по умолчанию, формируется в диалоге настройки заказа обезличенных сделок.

  3. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

См. также:

  • Таблица обезличенных сделок
  • Формат сохранения в текстовый файл


Таблица котировок

меню Создать окно / Котировки... или клавиша «F4»
  • Назначение
  • Формат окна
  • Доступные функции

    • Назначение

    Отображение очередей заявок по одному инструменту.

    В системе QUIK возможно создание нескольких Таблиц котировок по одному и тому же инструменту для удобства группировки окон на разных экранных вкладках. Количество получаемой с сервера информации в этом случае не увеличивается.

    Открытие Таблицы котировок осуществляется одним из следующих способов:

    • Выбором пункта меню программы Создать окно/Котировки….
    • Нажатием клавиши «F4».
    • Двойным нажатием левой кнопки мыши на выбранной строке таблицы «Текущие торги». При этом:
      • Если Таблица котировок по нужному инструменту уже создана ранее, то она становится активной, и, при необходимости, переключается экранная вкладка.
      • Если Таблица котировок отсутствует в списке открытых окон, то формируется новая таблица.
      • Если при создании Таблицы котировок удерживать нажатой клавишу «Shift», то создается новая таблица, независимо от наличия созданных ранее таблиц котировок по данному инструменту.
    Не рекомендуется выводить несколько Таблиц котировок в одну и ту же таблицу базы, так как при смене инструмента в экспортируемой таблице (через контекстное меню либо режим связанных окон) таблица в базе очищается.

    Формат окна

    Таблица содержит лучшие текущие котировки на покупку/продажу, упорядоченные по параметру «Цена». Количество лучших котировок зависит от класса инструментов.

    В заголовке таблицы указывается наименование инструмента, класс. Если таблица открывается по опционам, то дополнительно указывается тип опциона (PUT / CALL). Заголовок таблицы может быть изменён пользователем с помощью параметра «Имя таблицы» в окне редактирования настроек.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
Цена покупки | Котировка на покупку, рублей
Цена продажи | Котировка на продажу, рублей
Цена | Котировка (в один столбец), рублей
Покупка | Количество инструментов в заявках на покупку по данной цене с точностью количества инструмента или в лотах
Продажа | Количество инструментов в заявках на продажу по данной цене с точностью количества инструмента или в лотах
Объем | Количество инструментов в заявках (в один столбец) по данной цене с точностью количества инструмента или в лотах
Своя покупка | Количество инструментов в собственных заявках на покупку по данной цене с точностью количества инструмента или в лотах
Своя продажа | Количество инструментов в собственных заявках на продажу по данной цене с точностью количества инструмента или в лотах
Свой объем | Количество инструментов в собственных заявках (в один столбец) по данной цене с точностью количества инструмента или в лотах
Доходность покупки | Доходность инструмента по котировке на покупку
Доходность продажи | Доходность инструмента по котировке на продажу
Доходность | Доходность инструмента по котировке (в один столбец)
Сумма лучшей покупки | Количество инструментов в заявках на покупку по цене не хуже данной с точностью количества инструмента или в лотах
Сумма лучшей продажи | Количество инструментов в заявках на продажу по цене не хуже данной с точностью количества инструмента или в лотах
Сумма лучших | Количество инструментов в заявках (в один столбец) по цене не хуже данной, лотов
Сумма РЕПО покупки | Суммарный объем котировок РЕПО на покупку по данной ставке с точностью валюты цены инструмента, рублей. Поле заполняется только для инструментов по классам «МБ ФР РЕПО с ЦК 1 день Акции» и «МБ ФР РЕПО с ЦК 1 день Облигации»
Сумма РЕПО продажи | Суммарный объем котировок РЕПО на продажу по данной ставке с точностью валюты цены инструмента, рублей. Поле заполняется только для инструментов по классам «МБ ФР РЕПО с ЦК 1 день Акции» и «МБ ФР РЕПО с ЦК 1 день Облигации»
Номинальный объем | Номинальный объем инструмента. Рассчитывается по формуле: «Номинал инструмента» * «Размер лота» * «Количество лотов». Поле доступно только для инструментов по классам с признаком «Расчет доходности в котировках»
Номинальный объем покупки | Номинальный объем инструмента на покупку. Поле доступно только для инструментов по классам с признаком «Расчет доходности в котировках»
Номинальный объем продажи | Номинальный объем инструмента на продажу. Поле доступно только для инструментов по классам с признаком «Расчет доходности в котировках»

    Суммарный объем на покупку и продажу в рыночных заявках, выставленных в период аукциона, отображается в верхней строке таблицы. При этом в поле «Цена» («Цена покупки» и «Цена продажи») отображается значение «MKT».

    К таблице может быть применен Режим связанных окон.

    Панель информации по инструменту (верхняя)

    Отображение панели информации по инструменту включается флажком «Верхняя панель» в окне редактирования Таблицы котировок.

    Панель располагается над таблицей. На данной информационной панели отображаются дополнительные параметры по инструменту. Список параметров и настройки отображения задаются в окне «Панель информации по инструменту».

    Если ширины окна недостаточно для отображения всех параметров, то параметры выводятся по одному либо группами. Переход к следующему параметру (к следующей группе параметров) осуществляется нажатием левой кнопки мыши на панели информации.

    Если ширины окна недостаточно для отображения хотя бы одного параметра, то значение параметра заменяется многоточием.

    Для выбора доступны следующие параметры:

    Параметр | Краткое наименование | Значение *
Спред | Спред | Рассчитывается следующим образом: «Лучшая цена предложения» – «Лучшая цена спроса»
Цена последней сделки | Посл. | Значение параметра «Цена последней сделки» таблицы «Текущие торги»
К закрытию пред.дня | К закр. | Значение параметра «Разница цены последней к закрытию предыдущей сессии» таблицы «Текущие торги»
К закрытию пред.дня, в % | %К закр. | Значение параметра «% изменения от закрытия» таблицы «Текущие торги»
К оценке пред.дня | К оц. | Рассчитывается следующим образом: «Цена последней сделки» – «Предыдущая оценка»
К оценке пред.дня, в % | %К оц. | Рассчитывается следующим образом: («Цена последней сделки» - «Предыдущая оценка»)/»Предыдущая оценка»*100%
Средневзвешенная цена | Ср.взв. | Значение параметра «Средневзвешенная цена» таблицы «Текущие торги»
Расчетная цена | Расч. | Значение параметра «Расчетная цена» таблицы «Текущие торги»
Общее кол-во | Общ. к-во | Объем совершенных в текущей сессии сделок, в штуках
Цена закрытия | Закр. | Цена закрытия предыдущего дня
Цена аукциона | Цена аукц. | Минимальная цена аукциона (цена отсечения), начиная с которой удовлетворяются конкурентные заявки на аукционе
Количество аукциона | Кол-во аукц. | Общее количество в сделках аукциона
Объем аукциона | Объем аукц. | Объем сделок аукциона

    * - Если значение параметра отсутствует, выводится «н/д»

    Нижняя информационная панель

    Отображение панели включается флажком «Нижняя панель» в окне редактирования Таблицы котировок.

    Панель располагается под таблицей. Настройки отображения задаются в окне «Цвета нижней панели». По умолчанию значения параметров выделяются следующими цветами:

    • Зелёный – покупка (слева);
    • Красный – продажа (справа).

    Для отображения доступны следующие параметры:

    Параметр | Краткое наименование | Значение покупки (слева) | Значение продажи (справа)
Суммарный спрос/предложение * | Лотов | Значение параметра «Общ. спрос» таблицы «Текущие торги» | Значение параметра «Общ. предложение» таблицы «Текущие торги»
Заявки на покупку/продажу | Заявок | Значение параметра «Заявки куп.» таблицы «Текущие торги» | Значение параметра «Заявки прод.» таблицы «Текущие торги»
Свои заявки/стоп-заявки | Своих | <Количество заявок клиента на покупку>/<Количество стоп-заявок клиента на покупку> | <Количество заявок клиента на продажу>/<Количество стоп-заявок клиента на продажу>

    * - Отображается по умолчанию

    Выбор отображаемых параметров осуществляется в контекстном меню нижней информационной панели. При нажатии на панели левой кнопки мыши осуществляется переход к следующему параметру.

    Доступные функции

    Данные из таблицы доступны для вывода через DDE сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Новая заявка» (или «F2») (или двойное нажатие левой кнопкой мыши на строке таблицы) – подать новую заявку.
    • «Новая Айсберг заявка» – подать новую Айсберг заявку.
    • «Заменить заявку» (или «Ctrl»+«A») – заменить (редактировать) заявку.
    • «Снять заявку» (или «Ctrl»+«D») – снять заявку.
    • «Новая стоп-заявка» (или «F6») – подать новую стоп-заявку заявку.
    • «Новая алго-заявка» – подать новую алго-заявку.
    • «Купить по рынку» (или «Ctrl»+«2», или «Ctrl»+«Num 2») – выставить рыночную заявку на покупку с указанным количеством.
    • «Выставить на покупку» (или «Ctrl»+«1», или «Ctrl»+«Num 1») – выставить лимитированную заявку на покупку с заданной ценой и количеством.
    • «Продать по рынку» (или «Ctrl»+«4», или «Ctrl»+«Num 4») – выставить рыночную заявку на покупку с указанным количеством.
    • «Выставить на продажу» (или «Ctrl»+«3», или «Ctrl»+«Num 3») – выставить лимитированную заявку на покупку с заданной ценой и количеством.
    • «Закрыть позицию» (или «Ctrl»+«K») – выставление рыночной заявки, равной величине позиции, исполнение которой приводит к закрытию текущей позиции по указанному инструменту.
      Для инструментов, по которым выполняется закрытие позиций, обязательно должны быть указаны параметры закрытия в окне «Параметры инструментов».
    • «Перевернуть позицию» (или «Ctrl»+«I») – выставление рыночной заявки, равной удвоенной величине позиции, исполнение которой приводит к «перевороту» текущей позиции (изменению отрицательной позиции на положительную, либо наоборот) по указанному инструменту.
    • «Снять все заявки» (или «Ctrl»+«F8») – снимает все активные заявки из текущего окна котировок по данному инструменту.
    • «Снять покупку» (или «Ctrl»+«Z») – снимает все активные заявки на покупку из текущего окна котировок по данному инструменту.
    • «Снять продажу» (или «Ctrl»+«X») – снимает все активные заявки на продажу из текущего окна котировок по данному инструменту.
    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.
    • «Подключиться к каналу» – привязать окно к основной таблице (подробнее см. Режим связанных окон).
      • «<Название таблицы>» – привязка окна к данной таблице;
      • «Отключить» – отключение связанной таблицы от канала.
    • «Построить график» (или двойное нажатие правой кнопкой мыши) – открыть график.
    • «Заменить инструмент» – выполнить замену инструмента. Данная возможность полезна при торговле опционами и фьючерсами, где регулярно происходит исполнение контрактов и необходимо заменять их на актуальные.
    • «Шаблоны» – применить к таблице настроенную в шаблоне конфигурацию.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    Контекстное меню панели информации по инструменту

    • «Выбрать параметры» – открыть окно настройки панели.
    • «Скрыть» – отключить отображение данной панели в Таблице котировок.

    Контекстное меню нижней информационной панели

    • Выбор отображаемой информации:
      • «Суммарный спрос/предложение» (по умолчанию);
      • «Заявки на покупку/продажу»;
      • «Свои заявки/стоп-заявки».
    • «Скрыть» – отключить отображение данной панели в Таблице котировок.

    См. также:

    • Настройка таблицы
    • Замена инструмента в Таблице котировок
    • Работа с шаблонами
    • Вывод данных через DDE-сервер


Работа с шаблонами

  • Просмотр списка шаблонов
  • Создание нового шаблона
  • Применение шаблона

    • Шаблон представляет собой конфигурацию Таблицы котировок, сохраненную под определенным именем. Такой шаблон можно применить к уже существующим Таблицам котировок, а также воспользоваться им для быстрой настройки новой таблицы.

    Просмотр списка шаблонов

    Просмотр списка шаблонов осуществляется через пункт меню Действия / Шаблоны / Настроить шаблоны..., либо из аналогичного пункта в контекстном меню, вызванном из Таблицы котировок.

    • Настройка шаблона по умолчанию. Выделите в списке доступных шаблонов требуемую конфигурацию окна и нажмите кнопку «Брать по умолчанию». Название шаблона появится в разделе «Шаблон по умолчанию».
    • Переименование шаблона. Выберите нужный шаблон и нажмите кнопку «Переименовать». В открывшемся диалоге введите новое название и нажмите кнопку «Ввод».

      Стандартные шаблоны «QUIK BOND», «QUIK CURRENCY» и «QUIK STOCK» переименованию не подлежат.
    • Удаление шаблона. Нажатие кнопки «Удалить» удаляет выделенный шаблон.
    • Применение шаблона к нескольким окнам. Нажатие кнопки «Применить ко всем окнам» изменяет настройки всех Таблиц котировок в соответствии с выбранным шаблоном, нажатие кнопки «Применить к окнам на вкладке» - к окнам на текущей вкладке.

    Создание нового шаблона

    1. Настройте в качестве образца новую Таблицу котировок или сделайте активной одну из существующих.
    2. Выберите пункт меню Действия / Шаблоны / Сохранить в шаблон..., либо аналогичный пункт из контекстного меню на Таблице котировок.
    3. Для обновления шаблона выберите его название в открывшемся окне и нажмите кнопку «Сохранить».
    4. Для создания нового шаблона нажмите кнопку «Сохранить как новый». В открывшемся диалоге введите название и нажмите кнопку «Ввод».
    5. Нажмите кнопку «Закрыть».

    Применение шаблона

    Задать настройки Таблицы котировок по шаблону можно из пункта меню Действия / Шаблоны / <Имя шаблона> либо аналогичный пункт из контекстного меню Таблицы котировок.

    См. также:

    • Настройка таблицы
    • Замена инструмента в Таблице котировок
    • Вывод данных через DDE


Настройка таблицы

  • Настройка окна создания таблицы котировок
  • Настройка окна редактирования таблицы котировок
  • Панель информации по инструменту

    • Настройка окна создания таблицы котировок

    Для создания новой Таблицы котировок выберите инструмент из раскрывающегося списка, в поле «Брать шаблон» выберите один из сохраненных шаблонов.

    Настройка окна редактирования таблицы котировок

    1. Таблица котировок может принимать вид:
      • – отображает все параметры в один столбец (1). При этом лучшая цена покупки отделена от лучшей цены продажи чертой-разделителем. Котировки на покупку и продажу по одной цене отображаются в одной строке и имеют вид: «спрос / предложение».
      • – имеет один общий столбец «Цена» (2). Параметры заявок на покупку и заявок на продажу отображаются в разных столбцах.
      • – отображает параметры спроса и предложения в разных столбцах (3). При этом котировки на покупку упорядочены по убыванию цены заявки, а котировки на продажу – по возрастанию цены заявки таким образом, что лучшие цены заявок отображаются в первой строке окна.

    2. «Лучшие котировки видны всегда» - если флажок включен, то, независимо от размера окна, строки располагаются таким образом, чтобы лучшая цена покупки и продажи были видимыми.
    3. «Покупку показывать сверху» - если флажок включен, то котировки располагаются в порядке возрастания цены заявки (сверху заявки на покупку, снизу заявки на продажу). Если флажок снят, то котировки сортируются по убыванию цены заявки.
    4. «Использовать drag-and-drop» – включение возможности замены и снятия активных заявок пользователя путем перетаскивания строки мышью.

      При использовании режима drag-and-drop цена котировки определяется следующим образом:

      • при перетаскивании котировки в верхнюю область какой-либо строки таблицы отображается цена на один шаг больше, чем цена котировки данной строки;
      • при перетаскивании котировки в центральную область какой-либо строки таблицы отображается цена котировки данной строки;
      • при перетаскивании котировки в нижнюю область какой-либо строки таблицы отображается цена на один шаг меньше, чем цена котировки данной строки.
      Если котировки в таблице отличаются на один шаг цены, то цена в нижней части строки совпадает с ценой следующей котировки, а цена в верхней части строки совпадает с ценой предыдущей котировки.
    5. «Разреженный стакан» – включить отображение цен, по которым не выставлено котировок. Если флажок включен, то между строками с котировками в окне добавляются промежуточные строки, в соответствии с шагом цены для данного инструмента, при этом поле «Количество» в них пустое.

      В данном режиме признак «Лучшие спрос и предложение видны всегда» недоступен.

      Признак «Разреженный стакан» применяется только для котировочных окон вида (1) и (2). Если включен признак «Выделять котировки цветом», то настройка цвета распространяется только на строки, по которым выставлены котировки.

    6. «Выделять котировки цветом» – выделение котировок цветом текста и цветом фона ячейки. Нажатием на кнопку «…» открывается окно «Цвет котировок» для назначения цвета текста и цвета фона отдельно для котировок на покупку и на продажу. Котировки на покупку и продажу по одной цене выделяются серым цветом.

      О работе с цветом см. Настройка цвета в таблицах и графиках.

      Cвойство недоступно для настройки Таблицы котировок с расположением цены заявок на покупку и на продажу в разных столбцах.
    7. «Выделять свои заявки» – выделение шрифтом и/или цветом заявок, выставленных самим пользователем. Нажатием на кнопку «…» открывается окно «Формат ячеек» для дополнительной настройки шрифта, а также цвета текста и фона в ячейке:

    8. «Панель торговли» – включение отображения в Таблице котировок панели инструментов для ввода заявок. Нажатием на кнопку «…» открывается окно «Настройки панели торговли».

      При использовании панели торговли в Таблице котировок становятся доступными дополнительные комбинации клавиш.

    9. «Информация по инструменту» – настройка отображения информационных панелей:
      • «Верхняя панель» – включение отображения панели информации по инструменту. Нажатием на кнопку «…» открывается окно настройки панели.
      • «Нижняя панель» – включение отображения панели информации по инструменту. Нажатием на кнопку «…» открывается окно «Цвета нижней панели» для выбора цвета текста отдельно для значений параметров покупки и продажи:

    10. «Быстрый ввод/снятие заявки» – включение режима быстрого ввода заявки.

      ВАЖНО! Перед использованием режима быстрого ввода заявки внимательно ознакомьтесь с особенностями его применения, так как ввод заявок осуществляется без подтверждения.
      • «Быстрый ввод объема заявки» – настройка предустановленных значений объема заявки, используемых в режиме быстрого ввода. Позволяет ввести до 3 величин объема, измеряемых в лотах. Подробнее см. Настройка объемов заявки.
      • «Брать отступ цены» – настройка предустановленных значений отклонения цены вводимой заявки от цены в выбранной строке Таблицы котировок. Значение указывается в количестве минимальных шагов цены. Параметр доступен при включенном режиме быстрого ввода заявки. Подробнее об использовании данной функции см. Отступ цены.
      • «Фильтрация»:
        • «Применять глобальный фильтр клиентов» – включение действия в Таблице котировок Общего фильтра по коду клиента.
        • «Фильтр клиентов» – фильтрация по коду клиента. Предназначен для выбора клиентов, заявки которых учитываются при расчёте суммарного собственного объема (столбцы «Своя покупка»/«Своя продажа» либо «Свой объем») в Таблице котировок.
      • «Доступные параметры / Заголовки столбцов» – выбор отображаемых параметров и настройка их очередности.
        • Нажатие кнопки «Перевернуть» меняет порядок следования заголовков столбцов на обратный.

      Панель информации по инструменту

      1. «Доступные параметры» – выбор отображаемых параметров и настройка их очередности. Выбранные параметры помечаются флажками.
      2. «Переносить на … строки» – если флажок включен, то информационная панель занимает указанное количество строк. Значение по умолчанию: «2». Если флажок снят, то данные располагаются в одной строке.
      3. «Название» – настройка цвета текста названий отображаемых параметров.
      4. «Значение» – настройка цвета текста значений отображаемых параметров.

      При нажатии кнопки «OK» изменения сохраняются, окно настройки закрывается. Нажатие кнопки «Отмена» закрывает окно без сохранения изменений.

      См. также:

      • Замена инструмента в Таблице котировок
      • Работа с шаблонами
      • Вывод данных через DDE


Состояние счета

меню Создать окно/Состояние счета, кнопка
  • Назначение
  • Формат окна
    •

    Назначение

    Просмотр состояния позиций по деньгам и инструментам по выбранному коду клиента в одном окне. В окне представлены все позиции по счету клиента, контролируемые по одному набору ограничений.

    1. Если для выбранного кода клиента настроена Единая денежная позиция, то в окне отображаются также позиции по срочному рынку.
    2. Если Единая денежная позиция не используется, то для отображения позиций по срочному рынку выберите в качестве кода клиента торговый счет на срочном рынке.

    Открытие окна «Состояние счета» осуществляется одним из следующих способов:

    • Выбором пункта меню программы Создать окно / Состояние счета;
    • Нажатием кнопки [image] на панели инструментов;
    • Выбором в таблице «Клиентский портфель» пункта контекстного меню «Состояние счета» или пункта меню Действия / Состояние счета.

    Для работы с двумя кодами клиентов откройте два окна для просмотра состояния счета, по одному для каждого клиента. Код клиента можно изменить в настройках окна или через глобальный фильтр клиентов.

    Глобальный фильтр клиентов применяется к таблице, если в фильтре указано только одно значение для кода клиента или фирмы, и в настройках таблицы включен признак «Параметры таблицы могут задаваться глобальным фильтром».

    Возможно сохранение таблицы в WND-файл без ключевых параметров («Фирма», «Код клиента»). В этом случае при загрузке таблицы из файла недостающие параметры заполняются, исходя из данных клиента.

    • Если клиент работает только на спот-рынке, то таблица заполняется информацией по лимитам.
    • Если клиент работает только на срочном рынке, то таблица заполняется информацией по ограничениям срочного рынка и позициям по клиентским счетам.
    • Если клиент использует Модуль единой денежной позиции, то таблица заполняется информацией как по лимитам, так и по ограничениям срочного рынка и позициям по клиентским счетам.

    Если на момент загрузки WND-файла у клиента отсутствуют лимиты, позиции и ограничения, то таблица остаётся с незаполненными ключевыми параметрами до получения данных с сервера.

    Формат окна

    Окно содержит две вкладки:

    • «Позиции» – состояние открытых позиций.
    • «Обеспечение» – расшифровка формирования обеспечения.

    В верхней части окна расположена панель инструментов для настройки таблиц. Панель инструментов является общей для вкладок «Позиции» и «Обеспечение».

    В нижней части окна отображаются итоговые показатели по каждой вкладке.

    Информация в таблице обновляется при обновлении таблицы «Клиентский портфель».

    К таблице может быть применен Режим связанных окон.


Позиции

  • Назначение
  • Формат таблицы
  • Итоговые параметры таблицы
  • Доступные функции

    • Назначение

    Отображение позиций клиента по инструментам.

    Формат таблицы

    Таблица содержит оценки стоимости позиции по одному выбранному классу.

    Строки таблицы отсортированы следующим образом: сначала отображаются денежные позиции, упорядоченные по коду валюты, затем позиции по инструментам, упорядоченные по коду инструмента.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение | Позиции по инструментам | Позиции по деньгам
    Код клиента

    Код клиента.

    Для срочного рынка – торговый счет
    Срок расчётов Срок расчётов Возможные значения:

    • «Т0» – сегодня;
    • «Т1» – позиция T+1 (завтра);
    • «Т2» – позиция T+2 (послезавтра)
             Возможные значения:

    • «Т0» – сегодня;
    • «Т1» – позиция T+1 (завтра);
    • «Т2» – позиция T+2 (послезавтра)
    Фирма | Код фирмы
    Счет депо | Счет депо | Для совокупных позиций: «Общий» | Код расчетов
    Класс оценки | Наименование класса инструментов, по которому произведена оценка позиции | Не заполняется
    * Инструмент | Краткое название инструмента | Краткое наименование инструмента класса «Кросс-курсы валют». Если инструмент не найден, то код валюты
    Код инструмента | Код инструмента | Код инструмента для фьючерсов и опционов | Код валюты
    Вид Вид инструмента Возможные значения:

    • «А» – акция;
    • «О» – облигация;
    • «Ф» – фьючерс;
    • «Пут», «Колл» – опционы;
    • «ВП» – валютная пара;
    • «Неизв.» – по коду инструмента не найден инструмент ни для одного класса
             Не заполняется – для позиций по деньгам и для ограничений срочного рынка типа «денежные средства»
    ** Вх. позиция Количество инструментов в позиции на начало дня с точностью количества инструмента Возможные значения:

    • Входящий остаток – для акций и облигаций. Соответствует значению одноименного параметра в таблице «Позиции по инструментам»;
    • Значение входящей чистой позиции – для фьючерсов и опционов. Соответствует значению параметра «Вход. чист. поз» в таблице «Позиции по клиентским счетам» .

    Положительное значение – лонг, отрицательное – шорт

             Входящий остаток с точностью валюты цены инструмента. Соответствует значению одноименного параметра в таблице «Позиции по деньгам».

    Для фьючерсного счета без использования Единой денежной позиции – текущий лимит открытых позиций. Соответствует значению параметра «Лимит откр. поз.» в таблице ограничений по клиентским счетам

    *, ** Позиция Количество инструментов в текущей позиции с точностью количества инструмента Возможные значения:

    • Текущий остаток – для акций и облигаций. Соответствует значению одноименного параметра в таблице «Позиции по инструментам»;
    • Значение текущей чистой позиции – для фьючерсов и опционов. Соответствует значению параметра «Тек. чист. поз» в таблице «Позиции по клиентским счетам».

    Положительное значение – лонг, отрицательное – шорт

             Текущий остаток. Соответствует значению одноименного параметра в таблице «Позиции по деньгам».

    Для фьючерсного счета без использования Единой денежной позиции – планируемые чистые позиции. Соответствует значению параметра «План чист. поз.» в таблице «Позиции по клиентским счетам»

    * Баланс. цена Средневзвешенная цена открытия позиции, с учетом валюты цены приобретения

    Для спот-рынка – соответствует значению параметра «Цена приобретения» в таблице «Позиции по инструментам».

    Для облигаций в зависимости от значения валюты цены приобретения значение отображается либо в % от номинала, либо в валюте, выбранной в настройках таблицы «Состояние счета», без учета НКД.

    Для срочного рынка – соответствует значению параметра «Эффект. цена поз.» в таблице «Позиции по клиентским счетам»

             Не заполняется
    * Цена Текущая цена инструмента

    Цена последней сделки по инструменту из таблицы «Текущие торги». Если такой цены нет, то цена закрытия.

    Для срочного рынка – цена последней сделки. Если такой цены нет, то указывается расчетная цена.

    Для облигаций значение указывается в % от номинала, для срочных контрактов – в пунктах.

    Для клиентов типа «МП»: лучшая цена спроса / предложения из таблицы «Текущие торги»

             Кросс-курс к выбранной валюте. Для выбранной валюты: «1»
    * Ликв.цена Цена, по которой в текущий момент возможно закрытие данной позиции по инструменту

    Для лонгов – лучшая цена спроса, для шортов – лучшая цена предложения. Если такой цены нет, то указывается цена последней сделки, если и ее нет, то цена закрытия.

    Для срочного рынка – цена встречной котировки, если такой цены нет, то указывается цена последней сделки, если и ее нет, то расчетная цена.

    Для облигаций значение указывается в % от номинала, для срочных контрактов – в пунктах. Для совокупных позиций, содержащих разнонаправленные позиции (лонги и шорты), значение не указывается

             Не заполняется
    + / - Разница между ликвидационной и балансовой ценой, с учетом валюты цены приобретения Инверсия знака для шортов Не заполняется
    Баланс. ст-ть Стоимость текущей позиции по балансовой цене с точностью валюты, выбранной в настройках, с учетом валюты цены приобретения Значение рассчитывается следующим образом:
    Баланс. цена * Позиция.

    Для облигаций:

    • если балансовая цена задана в процентах: (Баланс. цена * Номинал / 100 + НКД) * Позиция;
    • если балансовая цена задана в валюте: (Баланс. цена + НКД * Кросс-курс) * Позиция.

    Для срочных контрактов:
    Баланс. цена * Позиция * Стоимость шага цены / Шаг цены

             Не заполняется
    * Стоимость Стоимость позиции по текущей цене с точностью валюты, выбранной в настройках Значение рассчитывается следующим образом:
    Цена * Позиция.

    Для облигаций: (Цена * Номинал / 100 + НКД) * Позиция .

    Для срочных контрактов значение рассчитывается следующим образом:
    Цена * Позиция * стоимость шага цены / шаг цены

             Значение параметра Позиция. Если найден кросс-курс, то значение пересчитывается по курсу в выбранной валюте
    * % активов | Доля стоимости позиции по активу в общей стоимости активов, без учета денег | Шорты берутся без знака | «0»
    * Ликв.стоимость Стоимость позиции по ликвидационной цене с точностью валюты, выбранной в настройках Значение рассчитывается следующим образом:
    Ликв.цена * Позиция.

    Для облигаций: (Ликв. цена * Номинал / 100 + НКД) * Позиция .

    Для срочных контрактов значение рассчитывается следующим образом:
    Ликв.цена * Позиция * стоимость шага цены / шаг цены

             Позиция в выбранной валюте
    * Нереал. PL Прибыль, возникающая при закрытии позиции с точностью валюты, выбранной в настройках, с учетом валюты цены приобретения Значение рассчитывается следующим образом:
    Ликв. стоимость – Баланс. ст-ть     		Не заполняется
    НПриб.% Прибыль в % к затратам, с учетом валюты цены приобретения Значение рассчитывается следующим образом:
    Нереал. PL / Баланс.ст-ть*100     		Не заполняется
    Вар.маржа | Вариационная маржа с точностью валюты цены инструмента | Параметр позиций срочного рынка. Соответствует значению параметра «Вар.маржа» в таблице «Позиции по клиентским счетам» | Не заполняется
    НКД Сумма НКД на объем открытой позиции с точностью валюты цены инструмента Параметр облигаций. Рассчитывается как:
    НКД для одной облигации * Позиция     		Не заполняется
    *, *** В покупке Количество инструментов с точностью количества инструмента в активных операциях на покупку (учитываются заблокированные средства под заявки, стоп-заявки, внебиржевые заявки, заявки-отчеты)

    Количество инструментов в активных заявках на покупку

    Для срочного рынка соответствует значению параметра «Акт. покупка» в таблице «Позиции по клиентским счетам»

             Величина средств, заблокированных под заявки на покупку. Для фьючерсного счета значение не указывается
    *, *** В продаже Количество инструментов с точностью количества инструмента в активных операциях на продажу (учитываются заблокированные средства под заявки, стоп-заявки, внебиржевые заявки, заявки-отчеты)

    Количество инструментов в активных заявках на продажу

    Для срочного рынка соответствует значению параметра «Акт. продажа» в таблице «Позиции по клиентским счетам»

             Не заполняется
    Стоп-заявки | Количество активных стоп-заявок по инструменту | Для срочного рынка – количество активных стоп-заявок по инструменту | Не заполняется
    ** План. позиция Планируемая позиция с точностью количества инструмента, с учетом исполнения активных заявок Значение рассчитывается следующим образом:
    Позиция + В покупке – В продаже.

    Для срочных контрактов – не заполняется

             Не заполняется
    * Купить | Максимальное количество инструментов для заявки на покупку с точностью количества инструмента | Определяется с учетом маржи либо только с учетом собственных средств в соответствии с указанным в настройках способом расчета параметров (признак «С использованием заемных средств») | Не заполняется
    * Продать | Максимальное количество инструментов для заявки на продажу с точностью количества инструмента | Определяется с учетом маржи либо только с учетом собственных средств в соответствии с указанным в настройках способом расчета параметров (признак «С использованием заемных средств») | Не заполняется
    Пункт | Стоимость шага цены с точностью валюты цены инструмента | Параметр позиций срочного рынка | Не заполняется
    Цена контракта Цена контракта с учетом стоимости шага цены с точностью валюты цены инструмента Имеет смысл для контрактов, цена которых выражена в пунктах.
    Значение рассчитывается следующим образом:
    Цена в пунктах * стоимость шага цены / шаг цены     		Не заполняется

    * - параметры, выбранные по умолчанию

    ** - количество инструментов указывается в лотах или в штуках, в зависимости от настройки таблицы. При указании количества в лотах значение округляется вниз к ближайшему кратному значению

    *** - для спот-фирмы и кода клиента средства под заявки и стоп-заявки, поданные по срочному рынку, учитываются, если для данной фирмы и клиента настроена Единая денежная позиция

    Строки таблицы могут выделяться цветом в зависимости от настроек. По умолчанию используются следующие цветовые настройки:

    • Зеленый цвет шрифта – длинные позиции;
    • Красный цвет шрифта – короткие позиции;
    • Черный цвет шрифта – закрытые позиции (при выбранном режиме «Все позиции);
    • Черный шрифт на желтом фоне – денежные позиции.

    Итоговые параметры таблицы

    Возможен выбор следующих параметров:

    Параметр | Значение
    *, ** Баланс. ст-ть | Суммарная оценка стоимости позиций по ценам приобретения (по значению параметра Баланс. цена) с точностью валюты, выбранной в настройках
    Вх. стоим-ть | Суммарная оценка стоимости позиций на начало дня. Соответствует значению параметра «ВходСредства» в таблице «Клиентский портфель»
    * Ликв. ст-ть Суммарная оценка стоимости позиций по ликвидационной цене (по значению параметра Ликв.стоимость) с точностью валюты, выбранной в настройках инструмента.
    Для срочного рынка: суммарная оценка стоимости позиций по ликвидационной цене, ГО и вариационной маржи
    Обеспечение Стоимость активов клиента, принятых в обеспечение.
    Для клиентов типа «МД» и «МД+»: значение показателя «Стоимость портфеля», рассчитанное в соответствии с действующим законодательством *** согласно настройкам брокера, соответствует значению параметра «Стоимость портфеля» в таблице «Клиентский портфель»
    ГО | Гарантийное обеспечение на срочном рынке с точностью валюты цены инструмента. Соответствует значению параметра «Тек. чист. поз.» в таблице «Ограничения по клиентским счетам»
    ГО поз. Гарантийное обеспечение под открытые позиции на срочном рынке. Соответствует значению одноименного параметра в таблице «Клиентский портфель».
    Значение рассчитывается, только если настроена Единая денежная позиция
    ГО заяв. Гарантийное обеспечение под активные заявки на срочном рынке. Соответствует значению одноименного параметра в таблице «Клиентский портфель».
    Значение рассчитывается, только если настроена Единая денежная позиция
    Ур. маржи Уровень маржи. Соответствует значению одноименного параметра в таблице «Клиентский портфель».
    Для клиентов типа «МД» и «МД+» поле не заполняется
    %Исп. ГО % использования лимита срочного рынка. Значение рассчитывается следующим образом:
    (ГО поз. + ГО заяв.) / Лимит.откр.поз. * 100%
    Для срочного рынка значение рассчитывается следующим образом: Тек. чист. поз. / Лимит откр. поз.
    (параметры таблицы «Ограничения по клиентским счетам»)
    Вар. маржа Вариационная маржа по позициям срочного рынка с точностью валюты цены инструмента. Обнуляется после каждого клиринга. Соответствует значению параметра «Вариац. маржа» в таблице «Клиентский портфель».
    Для срочного рынка соответствует значению параметра «Вариац. маржа» в таблице «Ограничения по клиентским счетам»
    Фикс. маржа | Вариационная маржа, зафиксированная по итогам предыдущего клиринга. Соответствует значению параметра «Накоплен. доход» в таблице «Ограничения по клиентским счетам»
    * Прибыль дня Сумма всей прибыли за день с точностью валюты цены инструмента. Соответствует значению параметра «Прибыль/Убытки» в таблице «Клиентский портфель». Значение рассчитывается следующим образом: ТекСредства - Вх. стоим-ть
    Для срочного рынка значение рассчитывается следующим образом: Вариац. маржа + Накоплен. доход
    (параметры таблицы «Ограничения по клиентским счетам»)
    * Прибыль % | Прибыль в % к стоимости позиций на начало дня. Соответствует значению параметра «ПроцИзмен» в таблице «Клиентский портфель». Значение рассчитывается следующим образом: Прибыль дня / Вх. стоим-ть * 100
    Деньги Сумма денежных остатков по счетам клиента. Соответствует значению параметра «Сумма ден.остатков» в таблице «Клиентский портфель».
    Для срочного рынка соответствует значению параметра «Лимит откр. поз.» в таблице «Ограничения по клиентским счетам»
    Шорты | Суммарная оценка коротких позиций. Соответствует значению параметра «Шорты» в таблице «Клиентский портфель»
    Лонги | Суммарная оценка длинных позиций по инструментам, входящим в обеспечение. Соответствует значению параметра «Лонги» в таблице «Клиентский портфель»
    Лонги неликв. | Суммарная оценка длинных позиций по инструментам, не входящим в обеспечение
    В заявках Суммарная оценка средств в активных заявках. Рассчитывается как сумма оценок позиций по модулю:
    Лонги + Шорты + Неликв.
    Акт. заявок | Количество активных заявок и стоп-заявок по всем инструментам
    * Дост. лонг Доступно для открытия длинных позиций, с учетом активных заявок, с точностью валюты цены инструмента. Соответствует значению параметра «На покупку» в таблице «Клиентский портфель».
    Для клиентов типа «МД» и «МД+» поле не заполняется
    * Дост. шорт Доступно для открытия коротких позиций, с учетом активных заявок, с точностью валюты цены инструмента. Соответствует значению параметра «На продажу» в таблице «Клиентский портфель».
    Для клиентов типа «МД» и «МД+» поле не заполняется
    * Свободно Доступно для вывода средств при сохранении обеспеченности позиций либо открытия позиций по немаржинальным активам, с учетом заблокированных средств под активные заявки, с точностью валюты цены инструмента. Соответствует значению параметра «НаПокупкуНеМаржин» в таблице «Клиентский портфель».
    Для срочного рынка соответствует значению параметра «План. чист. поз.» в таблице «Ограничения по клиентским счетам»
    Кредит | Сумма задолженности клиента перед брокером с точностью валюты цены инструмента. Соответствует значению параметра «Сумма ден. остатков» в таблице «Клиентский портфель»
    Комиссия Сумма комиссии по сделкам за день.
    Для спот-рынка включает комиссию торговой системы и брокерскую комиссию.
    Для срочного рынка – комиссия торговой системы, соответствует значению параметра «Биржевые сборы» в таблице «Ограничения по клиентским счетам»
    Плечо Для клиентов типа «МЛ»: отношение «Входящего лимита» к «Входящим активам».
    Для клиентов типа «МП»: явно заданный коэффициент плеча.
    Для клиентов типа «МД» и «МД+» плечо определяет идентификатор шаблона маржинальных настроек и/или шаблона настроек комиссии в файле настроек Библиотеки расчета лимитов. Значение считается заданным для клиента, если для этого клиента было явно задано значение плеча в денежном лимите, или в файле настроек Библиотеки расчета лимитов данный клиент приписан к какому-либо маржинальному шаблону настроек. Иначе считается, что значение плеча не определено, и поле не заполняется. Значение может быть произвольным и не учитывается при расчете других параметров
    Соответствует значению параметра «Плечо» в таблице «Клиентский портфель»
    Тек. плечо Текущее плечо. Соответствует значению параметра «Тек. плечо» в таблице «Клиентский портфель».
    Для клиентов типа «МД» и «МД+» поле не заполняется
    Валюта цен | Код валюты, в которых пересчитаны стоимости позиций и цены инструментов
    Код позиции | Код позиции, по которому выбраны денежные позиции для оценки портфеля
    **** Мин.маржа Минимальный размер обеспечения, требуемый под текущий портфель клиента, рассчитывается в соответствии с действующим законодательством *** согласно настройкам брокера.
    Для клиентов типа «МД» отражает стоимость портфеля клиента (инструменты/деньги) с учетом дисконтирующих коэффициентов D min long и D min short.
    Для клиентов типа «МД+» рассчитывается как доля от объема начальной маржи (по умолчанию 50%, может быть изменена).
    Соответствует значению параметра «Мин.маржа» в таблице «Клиентский портфель».
    Для значений больше «1E25» в поле отображается «INF», но при экспорте по ODBC и DDE выводится фактическое числовое значение.
    **** Нач.маржа Значение показателя «Начальная маржа» (в единицах цены с точностью валюты цены инструмента), рассчитанное в соответствии с действующим законодательством *** согласно настройкам брокера. Отражает стоимость портфеля клиента (инструменты/деньги) с учетом дисконтирующих коэффициентов D long и D short.
    Соответствует значению параметра «Нач.маржа» в таблице «Клиентский портфель».
    Поле заполняется только для клиентов типа «МД» и «МД+». Для значений больше «1E25» в поле отображается «INF», но при экспорте по ODBC и DDE выводится фактическое числовое значение.
    **** Скор.маржа Значение показателя «Скорректированная маржа» (в единицах цены с точностью валюты цены инструмента), рассчитанное в соответствии с действующим законодательством *** согласно настройкам брокера. Вычисляется аналогично параметру «Нач.маржа» с учетом планового исполнения всех активных заявок.
    Соответствует значению параметра «Скор.маржа» в таблице «Клиентский портфель».
    Поле заполняется только для клиентов типа «МД» и «МД+». Для значений больше «1E25» в поле отображается «INF», но при экспорте по ODBC и DDE выводится фактическое числовое значение
    **** Статус Состояние стоимости портфеля относительно уровня маржи:
    • «Нормальный» – стоимость портфеля больше либо равна скорректированной марже;
    • «Ограничение» – стоимость портфеля меньше скорректированной маржи и больше либо равна начальной марже;
    • «Требование» – стоимость портфеля меньше начальной маржи и больше либо равна минимальной марже;
    • «Закрытие» – стоимость портфеля меньше минимальной маржи

    Соответствует значению параметра «Статус» в таблице «Клиентский портфель».
    Поле заполняется только для клиентов типа «МД» и «МД+»
    **** Требование Сумма маржинального требования с точностью валюты цены инструмента:
    • если НПР1 (Стоимость портфеля – Нач.маржа) < 0, то Требование = – НПР1;
    • иначе «0»

    Соответствует значению параметра «Требование» в таблице «Клиентский портфель».
    Поле заполняется только для клиентов типа «МД» и «МД+». Для значений больше «1E25» в поле отображается «INF», но при экспорте по ODBC и DDE выводится фактическое числовое значение
    **** УДС Уровень достаточности средств.
    УДС = (Стоимость портфеля - Мин.маржа)/(Нач.маржа – Мин.маржа)
    Возможные значения: от «-9.99» до «9.99» с точностью 2 знака после десятичного разделителя. Если Нач.маржа = Мин.маржа, то:
    • если Стоимость портфеля < Мин.маржа, то УДС = – 9.99;
    • иначе УДС = 9.99.

    Поле заполняется только для клиентов типа «МД и «МД+».
    • 0 <= УДС < 1 – близость к закрытию (маржин-колл);
    • УДС < 0 – принудительное закрытие

    Соответствует значению параметра «УДС» в таблице «Клиентский портфель».
    ТекСредства | Текущая оценка стоимости всех позиций клиента (с учетом вариационной маржи по счету) с точностью валюты цены инструмента. Оценка стоимости позиций клиента производится по параметру «Цена последней сделки», если этот параметр отсутствует, то используется «Лучший спрос/предложение». В случае отсутствия и этого параметра расчет производится исходя из значения «Цены закрытия предыдущего дня»
    Суммарно заблок. | Cумма заблокированных средств со всех денежных лимитов клиента, пересчитанная в валюту расчетов через кросс-курсы на сервере, с точностью валюты цены инструмента. Суммирование выполняется для всех лимитов клиента, независимо от настроек мультивалютности и дополнительных тегов расчетов в Библиотеке расчетов лимитов
    НПР1 | Норматив покрытия риска 1. Рассчитывается как разница параметров «Стоимость портфеля» и «Начальная маржа». Для клиентов типа «МД» и «МД+»
    НПР2 | Норматив покрытия риска 2. Рассчитывается как разница параметров «Стоимость портфеля» и «Минимальная маржа». Для клиентов типа «МД» и «МД+»
    БлокПокупка Оценка стоимости активов в заявках на покупку с точностью валюты цены инструмента

    «Блок. покупка»= «Блок. пок. маржин.» + «Блок. пок. обесп.»

    БлокПродажа | Оценка в денежном выражении планируемых шортов (сколько средств брокера планируется использовать при исполнении выставленных заявок на продажу) с точностью валюты цены инструмента
    ***** ПолнСтоимПорфтеля Стоимость портфеля с учётом средств на срочном рынке с точностью валюты цены инструмента. Для клиентов срочного рынка без единой денежной позиции значение соответствует значению поля «СумАктивовНаСрчРынке». Для клиентов, использующих единую денежную позицию:

    ТекЧистПоз + ЛиквСтоимОпционов + Стоимость портфеля

    * - параметры, выбранные по умолчанию

    ** – для спот-рынка значение рассчитывается корректно, если брокером используется возможность загрузки средневзвешенных цен

    *** - действующие требования Центрального банка РФ к правилам осуществления брокерской деятельности

    **** - заполняется значением для максимальной величины из доступных сроков расчётов(например, для T2 при доступных видах T0, T1, T2)

    ***** - параметр заполняется для клиентов с настроенной единой денежной позицией и для клиентов срочного рынка без единой денежной позиции.

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    • Двойное нажатие правой кнопки мыши в колонке «В покупке» / «В продаже» – снять все активные заявки на покупку / продажу. Если в настройках программы включен признак «Запрашивать подтверждение для групповых операций», то перед операцией снятия запрашивается подтверждение.
      Стоп-заявки в данном случае не снимаются.
    • Двойное нажатие правой кнопки мыши в колонке «Стоп-заявки» – снять все активные стоп-заявки по инструменту. Если в настройках программы включен признак «Запрашивать подтверждение для групповых операций», то перед операцией снятия запрашивается подтверждение.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Новая заявка» (или «F2», или двойное нажатие левой кнопки мыши) * – открыть окно ввода новой заявки по инструменту. Поля «Торговый счет» и «Код клиента» заполняются в соответствии с настройками таблицы «Состояние счета». Если курсор находится в поле с количеством («Позиция», «Купить», «Продать»), то это количество подставляется в заявку. Цена – лучшая встречная.

      Если окно ввода новой заявки открывается через двойное нажатие левой кнопки мыши и курсор находится в поле «Купить» или «Продать», то открывается окно ввода новой заявки на покупку или продажу соответственно. Количество в заявке берется из поля «Купить» / «Продать».

    • «Новая стоп-заявка» (или «F6») * – открыть окно ввода новой стоп-заявки по инструменту. Поля «Торговый счет» и «Код клиента» заполняются в соответствии с настройками таблицы «Состояние счета». Количество в заявке берется из поля «Позиция», цена – лучшая встречная.
    • «Новая OMS-заявка» - открыть окно ввода новой OMS-заявки по инструменту. Описание приведено в Руководстве пользователя «Модуль OMS Manager».
    • «Графики цены и объема» * – создать окно графиков цены и объема по инструменту.
    • «[<Класс>] <Наименование инструмента>»* – открыть окно котировок по инструменту.
    • «Информация об инструменте» (или «Alt»+«I») * – открыть окно просмотра информации об инструменте.
    • «Экспирация опционов» * – исполнить опцион. Доступно только для опционов.
    • Настройки:
      • «Количество в лотах» – отображать количество инструментов в окне в лотах.

        Для фьючерсов и опционов количество всегда отображается в лотах и не зависит от значения данной настройки.
      • «Панель инструментов» – показать/скрыть панель инструментов.
      • «Показать итоги» – показать/скрыть панель итогов.
      • «Денежные позиции» – показать/скрыть позиции по деньгам в таблице.
      • «Все позиции» – отображать позиции по всем инструментам, по которым есть лимиты (включая нулевые).
      • «С использованием заемных средств» – отображать значения параметров «Купить» и «Продать» с учетом заемных средств (маржи).
      • «Совокупная позиция» – включить/отключить объединение позиций на разных счетах по одинаковым инструментам.
    • «Открыть канал» / «Закрыть канал» – включить / выключить режим связанных окон в данной основной таблице.
    • «Закрыть позицию» (или «Ctrl»+«K») *, ** – закрытие позиции по выбранному инструменту.
    • «Перевернуть позицию» (или «Ctrl»+«I») * – переворот позиции по выбранному инструменту.
    • «Закрыть все» («Ctrl»+«Shift»+«K») ** – закрытие всех позиций клиента.
    • «Снять все заявки» – снимает все активные заявки по инструментам таблицы. Если в настройках программы включен признак «Запрашивать подтверждение для групповых операций», то перед операцией снятия запрашивается подтверждение.
    • «Обновить таблицу» (или «F5») – обновить значения в таблице.
    • Шаблоны – выбор шаблона с набором отображаемых параметров:
      • «Базовый» – отображать позиции с базовым набором параметров.
      • «Расширенный» – отображать позиции с полным набором параметров.
      • «Срочный» – отображать позиции срочного рынка.
    (*) Пункты доступны, если в активной строке позиция по инструментам.
    (**) Для инструментов, по которым выполняется закрытие позиций, обязательно должны быть указаны параметры закрытия в окне «Параметры инструментов».

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    Функции, доступные из контекстного меню итогов:

    1. «Панель инструментов» – показать/скрыть панель инструментов.
    2. «Показать итоги» – показать/скрыть панель итогов.
    3. «Обновить таблицу» – обновить значения в таблице.
    4. «Закрыть все» – закрытие всех позиций клиента.
      Для инструментов, по которым выполняется закрытие позиций, обязательно должны быть указаны параметры закрытия в окне «Параметры инструментов».
    5. «Снять все заявки» – снимает все активные заявки по инструментам таблицы. Если в настройках программы включен признак «Запрашивать подтверждение для групповых операций», то перед операцией снятия запрашивается подтверждение.
    6. «Взять настройки окна из шаблона» – сменить набор отображаемых параметров.

    См. также Состояние счета.


Обеспечение

  • Назначение
  • Формат таблицы
  • Итоговые параметры таблицы
  • Доступные функции

    • Назначение

    Отображение стоимости позиций, принятой в обеспечение.

    Формат таблицы

    Таблица содержит оценки стоимости позиции по одному (наиболее ликвидному) классу.

    Строки таблицы отсортированы следующим образом: сначала отображаются денежные позиции, упорядоченные по коду валюты, затем позиции по инструментам, упорядоченные по коду инструмента. В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Инструмент | Название инструмента
    Код инструмента | Код инструмента
    Вид Вид актива. Возможные значения:

    • «А» – акция;
    • «О» – облигация;
    • «Ф» – фьючерс;
    • «Пут», «Колл» – опционы;
    • «ВП» – валютная пара
    Класс оценки | Класс, по которому взята оценка
    Тип инструмента Тип инструмента. Возможные значения:

    • «МО» – маржинальный и принимается в обеспечение,
    • «М» – маржинальный и не принимается в обеспечение,
    • «О» – немаржинальный, но принимается в обеспечение,
    • «МШО» - маржинальный, принимается в обеспечение, запрещены короткие позиции,
    • <пусто> - немаржинальный и не принимается в обеспечение
    HC лонг Часть длинной позиции, дополнительно уменьшающая обеспечение. Значение по умолчанию: «0» (не задано).

    Значение поля рассчитывается по параметрам таблицы «Купить/продать»: 1 – Лонг (коэф)

    Для клиентов типа «МД» и «МД+» поле не заполняется
    НС шорт Часть короткой позиции, дополнительно уменьшающая обеспечение. Значение по умолчанию: «0» (не задано)

    Значение поля рассчитывается по параметрам таблицы «Купить/продать»: Шорт (коэф) - 1

    Для клиентов типа «МД» и «МД+» поле не заполняется
    Лимит лонг Предельно допустимый размер длинной позиции, принимаемый в обеспечение, в денежном выражении с точностью валюты цены инструмента. Соответствует значению параметра «Лимит (лонг)» в таблице «Купить/продать». Для активов, не принимаемых в обеспечение: «0».
    Для клиентов типа «МД» и «МД+» поле не заполняется
    Лимит шорт Предельно допустимый по данному инструменту размер короткой позиции, принимаемый в обеспечение, в денежном выражении с точностью валюты цены инструмента. Соответствует значению параметра «Лимит (шорт)» в таблице «Купить/продать». Для активов, не принимаемых в обеспечение: «0».
    Для клиентов типа «МД» и «МД+» поле не заполняется
    * Позиция | Количество инструментов в позиции с точностью валюты цены инструмента. Длинные позиции положительны, короткие – отрицательны
    Стоим-ть | Текущая стоимость открытой позиции с точностью валюты цены инструмента
    Ликвид.стоимость | Стоимость позиции по ликвидационной цене с точностью валюты цены инструмента
    Обеспечение Стоимость позиции, принимаемая в обеспечение, с точностью валюты цены инструмента. Для клиентов типа «МП» стоимость позиции соответствует значению параметра «Оценка (коэф)» в таблице «Купить/продать».
    Для клиентов типа «МД» и «МД+»: стоимость позиции, принимаемая в расчет скорректированной маржи
    % обесп. Вклад инструмента в совокупную стоимость обеспечения.
    Для клиентов типа «МД» и «МД+»: вклад инструмента в совокупную стоимость скорректированной маржи
    В покупке | Денежная оценка инструментов в активных заявках на покупку с точностью валюты цены инструмента
    В продаже | Денежная оценка инструментов в активных заявках на продажу с точностью валюты цены инструмента
    Стоп-заявки | Количество активных стоп-заявок по инструменту
    D long Текущее значение дисконтирующего коэффициента, используемого для расчета начальной и скорректированной маржи для длинных позиций. Устанавливается брокером.
    Поле заполняется только для клиентов типа «МД». При D long = 1 поле не заполняется, но при экспорте по ODBC и DDE выводится фактическое значение «1»
    D short Текущее значение дисконтирующего коэффициента, используемого для расчета минимальной, начальной и скорректированной маржи для коротких позиций. Устанавливается брокером.
    Поле заполняется только для клиентов типа «МД» и «МД+». При D short = ? поле не заполняется, но при экспорте по ODBC и DDE выводится фактическое значение «1E50»
    D min long Текущее значение дисконтирующего коэффициента, используемого для расчета минимальной маржи для длинных позиций. Рассчитывается следующим образом:
    Поле заполняется только для клиентов типа «МД» и «МД+». При D min long = 1 поле не заполняется, но при экспорте по ODBC и DDE выводится фактическое значение «1»
    D min short Текущее значение дисконтирующего коэффициента, используемого для расчета минимальной маржи для коротких позиций. Рассчитывается следующим образом:
    Поле заполняется только для клиентов типа «МД». При D min short = ? поле не заполняется, но при экспорте по ODBC и DDE выводится фактическое значение «1E50»
    ГО покупателя | Гарантийное обеспечение покупателя в денежном выражении. Отображается для срочных контрактов (фьючерсы и опционы)
    ГО продавца | Гарантийное обеспечение продавца в денежном выражении. Отображается для срочных контрактов (фьючерсы и опционы)

    * - количество инструментов указывается в лотах или в штуках, в зависимости от настройки таблицы. При указании количества в лотах значение округляется вниз к ближайшему кратному значению

    Строки таблицы могут выделяться цветом в зависимости от настроек. По умолчанию используются следующие цветовые настройки:

    • Темно-серый цвет шрифта – инструменты, не принимаемые в обеспечение;
    • Черный цвет шрифта – инструменты, принимаемые в обеспечение;
    • На желтом фоне – денежные позиции.
    Значения дисконтов D long и D short определяют тип поведения инструмента при маржинальном кредитовании:
    Обозначение | Назначение | D long | D short
<пусто> | Немаржинальный инструмент | =1,0 | +?
Д | Маржинальный инструмент, разрешенный только для покупки на заемные средства | <1,0 | +?
К | Инструмент, разрешенный только для продажи на заемные средства | =1,0 | <+?
ДК | Инструмент, разрешенный для покупки и продажи на заемные средства | <1,0 | <+?

    Итоговые параметры таблицы

    В итоговых строках таблицы отображаются следующие параметры:

    Название поля | Значение
Обеспечение | Совокупная стоимость позиций, принимаемая в обеспечение, с точностью валюты цены инструмента. Соответствует значению параметра «Стоимость портфеля» в таблице «Клиентский портфель»
Лонги | Суммарная оценка длинных позиций, входящих в обеспечение, с точностью валюты цены инструмента. Соответствует значению параметра «Лонги» в таблице «Клиентский портфель»
Шорты | Суммарная оценка коротких позиций с точностью валюты цены инструмента. Соответствует значению параметра «Шорты» в таблице «Клиентский портфель»
Деньги | Сумма денежных остатков с точностью валюты цены инструмента. Соответствует значению параметра «Сумма ден.остатков» в таблице «Клиентский портфель»
Неликв. | Совокупная стоимость позиций по инструментам, не принимаемым в обеспечение, с точностью валюты цены инструмента. Значение рассчитывается по параметрам таблицы «Купить/продать»: ТекСредства – Стоимость портфеля
В пок. неликв. | Заблокировано в заявках на покупку инструментов, не входящих в обеспечение, с точностью валюты цены инструмента. Соответствует значению параметра «БлокПокНеМарж» в таблице «Клиентский портфель»

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    • Двойное нажатие правой кнопки мыши в колонке «В покупке» / «В продаже» – снять все активные заявки на покупку / продажу. Если в настройках программы включен признак «Запрашивать подтверждение для групповых операций», то перед операцией снятия запрашивается подтверждение.

      Стоп-заявки в данном случае не снимаются.
    • Двойное нажатие правой кнопки мыши в колонке «Стоп-заявки» – снять все активные стоп-заявки по инструменту. Если в настройках программы включен признак «Запрашивать подтверждение для групповых операций», то перед операцией снятия запрашивается подтверждение.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    • «Графики цены и объема» * – создать окно графиков цены и объема по инструменту.
    • «[<Класс>] <Наименование инструмента>»* – открыть окно котировок по инструменту.
    • «Информация об инструменте» (или «Alt»+«I») * – открыть окно просмотра информации об инструменте.
    • «Экспирация опционов» * – исполнить опцион. Доступно только для опционов.
    • Настройки:
      • «Количество в лотах» – отображать количество инструментов в окне в лотах.

        Для фьючерсов и опционов количество всегда отображается в лотах и не зависит от значения данной настройки.
      • «Панель инструментов» – показать/скрыть панель инструментов.
      • «Показать итоги» – показать/скрыть панель итогов.
      • «Денежные позиции» – показать/скрыть позиции по деньгам в таблице.
      • «Все позиции» – отображать позиции по всем инструментам, по которым есть лимиты (включая нулевые).
      • «С использованием заемных средств» – отображать значения параметров «Купить» и «Продать» с учетом заемных средств (маржи).
      • «Совокупная позиция» – включить/отключить объединение позиций на разных счетах по одинаковым инструментам.
    • «Открыть канал» / «Закрыть канал» – включить / выключить режим связанных окон в данной основной таблице.
    • «Закрыть позицию» (или «Ctrl»+«K») *, ** – закрытие позиции по выбранному инструменту.
    • «Перевернуть позицию» (или «Ctrl»+«I») * – переворот позиции по выбранному инструменту.
    • «Закрыть все» («Ctrl»+«Shift»+«K») ** – закрытие всех позиций клиента.
    • «Снять все заявки» – снимает все активные заявки по инструментам таблицы. Если в настройках программы включен признак «Запрашивать подтверждение для групповых операций», то перед операцией снятия запрашивается подтверждение.
    • «Обновить таблицу» (или «F5») – обновить значения в таблице.
    (*) Пункты доступны, если в активной строке позиция по инструментам.
    (**) Для инструментов, по которым выполняется закрытие позиций, обязательно должны быть указаны параметры закрытия в окне «Параметры инструментов».

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    Функции, доступные из контекстного меню итогов:

    • «Панель инструментов» – показать/скрыть панель инструментов.
    • «Показать итоги» – показать/скрыть панель итогов.
    • «Обновить таблицу» – обновить значения в таблице.
    • «Закрыть все» – закрытие всех позиций клиента.
      Для инструментов, по которым выполняется закрытие позиций, обязательно должны быть указаны параметры закрытия в окне «Параметры инструментов».
    • «Снять все заявки» – снимает все активные заявки по инструментам таблицы. Если в настройках программы включен признак «Запрашивать подтверждение для групповых операций», то перед операцией снятия запрашивается подтверждение.
    • «Взять настройки окна из шаблона» – сменить набор отображаемых параметров.

    См. также Состояние счета.


Настройка таблиц

Панель инструментов является общей для вкладок «Позиции» и «Обеспечение».

На панели инструментов доступны следующие настройки:

  1. Кнопка [image] – обновить значения в таблицах.
  2. Переключатель «Все позиции»/«Открытые» – выбор отображаемых позиций в таблице:
    • «Все позиции» – отображаются позиции по всем инструментам, по которым есть лимиты (включая нулевые);
    • «Открытые» – отображаются только ненулевые позиции по инструментам.
  3. Поле со списком «На дату» – показ позиций по состоянию «T0» / «T1» / … / «Tx». Настройка позволяет смотреть позиции на текущий момент («T0»), на момент расчетов и после совершения всех расчетов («Tx») без настройки нескольких комплектов таблиц. При включенной настройке сервера QUIK «Вести позиции в календарных днях» в списке отображаются следующие значения:
    • «На дату» – расчет по позициям выполняется на конкретную дату. При выборе данного значения доступно поле, в котором выбирается дата. Если ранее выбирались даты, на которые существовали позиции / лимиты, то они сохраняются в списке и доступны для выбора. Если выбрана дата расчетов, совпадающая с текущей датой торгов, то в качестве выбранного значения отобразится «Сегодня». Выбранная дата запоминается и в дальнейшем, при загрузке настроек из файла или получении информации о торговой сессии, выполняется проверка, чтобы выбранная дата совпадала с текущей датой торгов или была больше, в противном случае она автоматически изменится на текущую дату торгов;
    • «Сегодня» – расчет по позициям выполняется на текущую дату торгов;
    • «Плановая» (значение по умолчанию) – расчет по позициям выполняется на плановую дату торгов.

На позиции и ограничения по срочному рынку значение данного фильтра не действует.
  4. Кнопка [image] - управление способом расчета параметров в столбцах «Купить» и «Продать». Возможные значения:
    • Кнопка нажата – значения рассчитываются с учетом заемных средств (маржи);
    • Кнопка отжата – значения рассчитываются только исходя из собственных средств.
  5. Кнопка [image] «Закрыть» * – закрытие позиции по одному инструменту, выбранному в таблице «Позиции» или «Обеспечение».
  6. Кнопка [image] «Перевернуть» – переворот позиции по одному инструменту, выбранному в таблице «Позиции» или «Обеспечение».
  7. Кнопка «Закрыть все» * – закрытие всех позиций клиента.
(*) Для инструментов, по которым выполняется закрытие позиций, обязательно должны быть указаны параметры закрытия в окне «Параметры инструментов».

См. также Состояние счета.


Настройка окна

  • Настройки окна
  • Позиции
  • Обеспечение

    • Интерфейс настроек окна разделен на страницы, переключение между которыми осуществляется в окне слева. С помощью флажков включается / отключается отображение в окне нужных вкладок. В правой части экрана отображаются параметры настройки.

    Настройки окна

    На странице выполняется настройка общих параметров окна.

    1. «Заголовок» – заголовок окна. Поле не редактируется.
    2. «Фирма» – выбор кода фирмы.
    3. «Код клиента» – выбор кода клиента. Если Единая денежная позиция не используется, то для отображения позиций по срочному рынку выберите в качестве кода клиента торговый счет на срочном рынке.
    4. «Параметры таблицы могут задаваться глобальным фильтром» – признак распространения на данную таблицу действия Общего фильтра по коду клиента и/или по фирме. Если флажок установлен, то при смене в Общем фильтре кода клиента, фирма в таблице устанавливается автоматически по выбранному коду клиента по имеющимся лимитам.
    5. «Валюта цен» – выбор валюты, в которой указаны цены инструментов и стоимости позиций в таблице.
    6. «Срок расчетов» – выбор срока расчетов.
    7. «Код позиции» – выбор кода позиции, по которому фильтруются денежные позиции.
    8. «Совокупная позиция» – объединять позиции по разным счетам депо.
    9. «С использованием заемных средств» – отображать значения параметров «Купить» и «Продать» с учетом заемных средств (маржи).
    10. «Показывать»:
      • «Количество в лотах» – отображать в таблице количество инструментов в лотах;
      • «Панель инструментов» – отображать панель инструментов таблицы;
      • «Все позиции» – отображать в таблице позиции по всем инструментам, по которым есть лимиты (включая нулевые).

    Позиции

    На странице выполняется настройка параметров вкладки «Позиции». Настройки разделены на закладки «Параметры» и «Оформление», переключение между которыми выполняется нажатием на ярлык с соответствующим названием.

    Закладка «Параметры»

    • «Набор» – выбор из выпадающего списка шаблона с набором отображаемых параметров. Для создания нового шаблона установите нужные значения параметров и нажмите кнопку «Сохранить». При нажатии кнопки «…» открывается окно редактирования наборов параметров, в котором можно изменить название набора, удалить набор либо назначить набор по умолчанию. При выборе встроенных наборов «Базовый», «Расширенный», «Срочный» кнопки «Переименовать» и «Удалить» неактивны.

      Набор «Срочный» содержит параметры срочного рынка. В таблице «Позиции» отображаются следующие параметры:

      • «Инструмент»;
      • «Вид»;
      • «Позиция»;
      • «Баланс.цена»;
      • «Ликв.цена»;
      • «Вар.маржа»;
      • «В покупке»;
      • «В продаже»;
      • «Стоп-заявки».

      Итоговые параметры:

      • «Деньги»;
      • «ГО»;
      • «Свободно»;
      • «Прибыль дня»;
      • «Комиссия»;
      • «% исп. ГО».

      При загрузке параметров из шаблона в диалоге редактирования отображаются сначала параметры, включенные в шаблон, затем все остальные параметры.

    • «Денежные позиции» – признак отображения в таблице позиций по деньгам. При выборе шаблона «Срочный» признак отключен.
    • «Параметры:» – признак отображения выбранных параметров на вкладке. Выбор набора параметров для отображения осуществляется в поле ниже.
    • «Итоги:» – признак отображения выбранных итоговых параметров на вкладке. Выбор набора параметров для отображения осуществляется в поле ниже.

    Закладка «Оформление»

    • Рамка «Параметры»:
      • Флажок «Выделять строки, если позиция:» – выбор разных цветов текста и фона для разных типов позиций. О работе с цветом см. «Настройка цвета в таблицах и графиках».
    • Рамка «Итоги» – выбор цветов текста и фона для названий итоговых параметров и их значений. О работе с цветом см. «Настройка цвета в таблицах и графиках».

    Нажатием кнопки «По умолчанию» настройки цветов приводятся в начальное состояние.

    Обеспечение

    На странице выполняется настройка параметров вкладки «Обеспечение». Диалог настроек аналогичен диалогу настроек вкладки «Позиции», описанному выше.

    См. также Состояние счета.


Таблица заявок

меню Создать окно / Заявки... или кнопка
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Контроль состояния исполнения заявок, отправленных на биржу. Управление активными заявками.

    Если количество строк таблицы превышает пороговое значение, заданное в файле info.ini (без учёта глобальных фильтров), то при вызове пункта меню «Создать окно / Заявки» открывается окно редактирования таблицы. Иначе – открывается сформированная Таблица заявок.

    По умолчанию пороговое значение равно «100000».

    Формат таблицы

    Каждой заявке соответствует отдельная строка таблицы.

    Строки таблицы могут выделяться цветом в зависимости от настроек. По умолчанию используются следующие цветовые настройки:

    • Красный цвет шрифта – активные заявки;
    • Синий цвет шрифта – исполненные заявки;
    • Черный цвет шрифта – снятые заявки;
    • Для частично исполненных заявок используется желтый цвет фона.

    К таблице может быть применен Режим связанных окон.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    * Номер | Регистрационный номер заявки в торговой системе биржи
    * Код биржи Идентификатор биржи. Для срочного рынка Московской Биржи:
    • дата экспирации в формате <ГГММДД> - при выставлении заявки с переносом;
    • дата экспирации и номер исходной заявки в формате <ГГММДД> - при переносе заявки в основной клиринг;
    • поле не заполняется – при выставлении заявки без переноса
    Дата торгов | Дата текущей торговой сессии
    **Дата | Дата регистрации заявки
    *, ** Выставлена (время) | Время регистрации заявки в торговой системе. Формат определяется настройками операционной системы
    Выставлена (мкс) | Количество микросекунд во времени регистрации заявки
    * Период Период торговой сессии. Возможные значения:
    • «Открытие»;
    • «Закрытие»;
    • «Нормальный»
    ** Время активации | Время активации заявки. Формат определяется настройками операционной системы
    ** Дата снятия | Дата отмены заявки
    ** Снята (время) | Время отмены заявки в торговой системе с точностью до секунды. Формат определяется настройками операционной системы
    Снята (мкс) | Количество микросекунд во времени отмены заявки
    Инструмент сокр. | Сокращенное наименование инструмента
    * Инструмент | Наименование инструмента
    Код инструмента | Идентификатор инструмента в торговой системе
    Класс | Наименование класса, к которому относится инструмент
    Код класса | Код класса в торговой системе
    * Операция | Направление операции («Купля», «Продажа»)
    * Счет | Код торгового счета, по которому подана заявка
    * Цена | Цена заявки, за единицу инструмента
    * Количество | Количество инструментов с точностью количества инструмента или в лотах
    * Видимое кол-во | Количество инструментов с точностью количества инструмента или в лотах, отображаемое в торговой системе. Поле заполняется только для заявок типа «Айсберг»
    * Остаток | Объем неисполненной части заявки, выраженный в лотах
    * Объем | Объем заявки в денежном выражении с точностью валюты цены инструмента
    Средневзвешенная цена приобретения | Средняя цена исполнения заявки, с точностью до 8 знаков после десятичного разделителя
    Валюта | Валюта цены, например «SUR» - российский рубль
    Доходность | Доходность в %, рассчитанная по цене заявки
    НКД | Накопленный купонный доход, рассчитанный для указанного в заявке количества инструментов , в денежном выражении с точностью валюты цены инструмента
    Трейдер | Идентификатор трейдера, подавшего заявку. Для рынков РТС и УБ – код выпуска инструмента
    Дилер | Идентификатор фирмы, от имени которой подана заявка
    Орг-я трейдера | Идентификатор фирмы трейдера
    UID | Код пользователя на сервере QUIK
    UID снявшего заявку | Код на сервере QUIK пользователя, снявшего заявку
    Код клиента | Код клиента, по которому установлен лимит средств
    * Комментарий Дополнительная справочная информация (заполняется трейдером), например:
    <код клиента>/<номер поручения>
    Исходный номер | Исходный номер заявки с указанной датой исполнения при замене заявки в ходе клиринга. Параметр заявок срочного рынка Московской Биржи
    Стоп-заявка | Номер стоп-заявки, породившей данную заявку
    Срок | Срок исполнения заявки
    Время окончания срока | Время действия заявки, для заявок со сроком действия «До времени»
    Тип

    Тип заявки, код из трех букв:

    • 1-я буква (тип заявки): «А» – айсберг-заявка, «Л» – лимитированная, «М» - рыночная
    • 2-я буква (разбиение цены): «Р» – по разным ценам, «Н» – все сделки по одной цене
    • 3-я буква (условие исполнения): «С» – немедленно или отклонить, «О» – поставить в очередь, «П» – только пассивная, «У» - снять остаток.

    Для заявок с признаком «Рыночная», выставленных на срочном рынке Московской Биржи, отображается тип «ЛРУ».
    Для заявок без признака «Рыночная», выставленных на срочном рынке Московской Биржи, отображается тип «ЛРО»

    * Состояние | Состояние заявки («Активна», «Исполнена», «Снята»)
    Расширенный статус

    Расширенный статус заявки. Возможные значения:

    • «» (пусто);
    • «Заявка активна»;
    • «Заявка частично исполнена»;
    • «Заявка исполнена»;
    • «Заявка отменена»;
    • «Заявка заменена»;
    • «Заявка в состоянии отмены»;
    • «Заявка отвергнута»;
    • «Приостановлено исполнение заявки»;
    • «Заявка в состоянии регистрации»;
    • «Заявка снята по времени действия»;
    • «Заявка в состоянии замены»;
    • «Заявка снята по причине кросс-сделки»
    Исполнено Исполненный объем заявки с точностью количества инструмента .
    Исполнено = Количество – Остаток
    ID транзакции | Значение уникального номера заявки TRANS_ID при импорте заявок из файла
    Код расчетов | Код расчетов по сделке. Параметр заявок РПС и РЕПО.
    Цена выкупа | Цена второй части РЕПО, за единицу инструмента. Параметр заявок РПС и РЕПО
    Заявка Маркет-мейкера | Признак заявок, отправленных маркет-мейкером
    Идентификатор счета | Идентификатор счета в НКЦ (расчетный код)
    Ввод объема Признак указания объема заявки. Возможные значения:
    • «По объему» – указан объем заявки;
    • «По количеству» – объем заявки не указан
    Срок РЕПО | Срок РЕПО в календарных днях
    Сумма РЕПО | Сумма РЕПО на текущую дату с точностью валюты цены инструмента
    Объем выкупа РЕПО | Объем сделки выкупа РЕПО с точностью валюты цены инструмента
    Остаток суммы РЕПО | Остаток суммы РЕПО за вычетом суммы привлеченных / предоставленных по сделке РЕПО денежных средств в неисполненной части заявки по состоянию на текущую дату с точностью валюты цены инструмента.
    Начальный дисконт (%) | Начальное значение дисконта, в процентах
    Причина отклонения | Ответ торговой системы на транзакцию
    Режим исполнения Тип исполнения заявки. Возможные значения:
    • «Немедленно или отклонить»;
    • «Поставить в очередь»;
    • «Снять остаток»;
    • «До снятия»;
    • «До даты»;
    • «В течение сессии»;
    • «Открытие»;
    • «Закрытие»;
    • «По цене аукциона закрытия»;
    • «До времени»;
    • «Следующий аукцион»;
    • «Extended hours» – дополнительная торговая сессия»;
    • « » (пусто)
    Мин. допустимое кол-во | Минимально допустимое количество с точностью количества инструмента, которое можно указать в заявке по данному инструменту. Если значение не указано, то ограничение по количеству не задано
    Кол-во базовой валюты Количество базовой валюты в валютной паре (например, для пары USDRUB это USD) с точностью количества инструмента. Параметр заполняется только для класса «Валюта» и отображается:
    • С точностью до двух знаков – если на классе «Валюта» стоит признак «Количество в валюте»;
    • Рассчитывается по формуле: «Объем» = «Количество» * «Размер лота» – если на классе «Валюта» нет признака «Количество в валюте»
    Базовая валюта | Базовая валюта в валютной паре (например, для пары USDRUB это USD). Параметр заполняется только для класса «Валюта»
    Кол-во котируемой валюты Количество котируемой валюты в валютной паре (например, для пары USDRUB это RUB) с точностью количества инструмента. Параметр заполняется только для класса «Валюта» и отображается:
    • С точностью до двух знаков – если на классе «Валюта» стоит признак «Количество в валюте»;
    • Рассчитывается по формуле: «Объем» = «Цена» * «Количество» * «Размер лота» – если на классе «Валюта» нет признака «Количество в валюте»
    Котируемая валюта | Котируемая валюта в валютной паре (например, для пары USDRUB это RUB). Параметр заполняется только для класса «Валюта»
    Passive only Статус пассивности заявки. Возможные значения:
    • «Not passive» – без ограничений;
    • «New BBO or joining existing BBO» – заявка регистрируется только в том случае, если ее цена лучше либо равна текущей лучшей цене в данном направлении;
    • «BBO or within 1 visible price-point» – заявка регистрируется только в том случае, если ее цена равна текущей лучшей цене в данном направлении или отличается от нее не более чем на один шаг цены;
    • «BBO or within 2 visible price-points» – заявка регистрируется только в том случае, если ее цена равна текущей лучшей цене в данном направлении или отличается от нее не более чем на два шага цены;
    • «Standard» – заявка регистрируется только в том случае, если она не может быть сразу исполнена;
    • «New BBO» – заявка регистрируется только в том случае, если ее цена лучше текущей лучшей цены в данном направлении
    Валюта заявки | Валюта цены заявки
    Accepted UID | UID пользователя-менеджера, подтвердившего заявку при работе в режиме с подтверждениями
    Исполн. объем | Исполненный объем заявки в валюте цены для частично или полностью исполненных заявок с точностью валюты цены инструмента
    Валюта расчетов | Валюта расчетов по данной заявке
    On Behalf Of UID | UID пользователя, от имени которого выставлена заявка
    Client qualifier Квалификатор клиента, от имени которого выставлена заявка. Возможные значения:
    • «» (пусто);
    • «Natural Person»;
    • «Legal Entity»
    Client short code | Краткий идентификатор клиента, от имени которого выставлена заявка
    Investment decision maker qualifier Квалификатор принявшего решение о выставлении заявки. Возможные значения:
    • «» (пусто);
    • «Natural Person»;
    • «Algorithm»
    Investment decision maker short code | Краткий идентификатор принявшего решение о выставлении заявки
    Executing trader qualifier Квалификатор трейдера, исполнившего заявку. Возможные значения:
    • «» (пусто);
    • «Natural Person»;
    • «Algorithm»
    Executing trader short code | Краткий идентификатор трейдера, исполнившего заявку
    Side qualifier Квалификатор операции. Возможные значения:
    • «» (пусто);
    • «Buy»;
    • «Sell»;
    • «Sell short»;
    • «Sell short exempt»;
    • «Sell undiclosed»
    Capacity Роль в исполнении заявки. Возможные значения:
    • «» (пусто);
    • «Agent»;
    • «Principal»;
    • «Riskless principal»;
    • «CFG give up»;
    • «Cross as agent»;
    • «Matched Principal»;
    • «Proprietary»;
    • «Individual»;
    • «Agent for other member»;
    • «Mixed»;
    • «Market maker»
    Номинальный объем | Номинальный объем инструмента. Рассчитывается по формуле: «Номинал инструмента» * «Размер лота» * «Количество лотов»
    Расчетная сумма Возможные значения:
    • для облигаций – объем заявки с учетом НКД;
    • для акций – объем заявки
    Дата расчетов Дата расчетов.
    Для свопов дата расчетов первой части операции своп
    Дата расчетов второй части | Дата расчетов второй части операции своп
    Дата начала действия | Дата, начиная с которой допускается совершение валютирования. Заполняется только для контрактов типа «FLEX FORWARD»
    Тип контракта Тип совершаемой операции. Возможные значения:
    • «NOT_DEFINED»;
    • «SPOT»;
    • «FORWARD»;
    • «SWAP»;
    • «NDF»;
    • «FLEX FORWARD»
    Видимая часть в % | Видимая часть в общей сумме заявки в %
    Торговая сессия Идентификатор торговой сессии. Возможные значения:
    • «Не определено»;
    • «Основная сессия»;
    • «Дополнительная сессия»;
    • «Утренняя сессия»;
    • «Итоги дня»
    Тип ввода цены Тип ввода значения цены заявки. Возможные значения:
    • «По цене»;
    • «По доходности»;
    • «По средневзвешенной цене»
    Количество второй части | Количество второй части операции своп
    Объем второй части | Объем второй части операции своп
    Сумма РЕПО видимой части | Сумма РЕПО видимой части (точность валюты расчетов заявки/инструмента)
    Приоритетное обеспечение | Код инструмента, являющийся приоритетным обеспечением
    Ликвидность Тип ликвидности. Возможные значения:
    • «Котировка»;
    • «Внутренняя ликвидность»;
    • «Дополнительная ликвидность»
    Внешняя ссылка | Текстовый комментарий, содержащий информацию о пользователе внешней системы
    Индикатор | Идентификатор индикативной ставки
    Внешнее количество | Количество инструментов в связанной заявке. Заполняется Модулями QUIK, которые генерируют связанные заявки в торговые системы
    Причина снятия Причина снятия заявки. Возможные значения:
    • «Отменена при потере соединения»;
    • «Отменена по закрытию сессии»;
    • «Истекла по времени действия»;
    • «Заявка снята по причине кросс-сделки»

    * - параметры, выбранные по умолчанию

    ** - при включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» значение отображается с учетом временной зоны компьютера, на котором запущен терминал QUIK

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер, экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Новая заявка» (или «F2», или двойное нажатие левой кнопки мыши) – ввести новую заявку с условиями, аналогичными заявке, на которой стоит курсор. Если таблица пустая, при выборе функции открывается диалог для выбора класса и инструмента.
    • «Новая Айсберг заявка» – ввести новую Айсберг заявку.
    • «Новая стоп-заявка» (или «F6») – ввести новую стоп-заявку.
    • «Стоп-заявка «по исполнению»» – ввести новую стоп-заявку «по исполнению».
    • «Заменить заявку» (или «Ctrl»+«A») – заменить (редактировать) заявку путем снятия заявки из торговой системы и последующим вводом новой, с измененными условиями.
    • «Изменить параметры заявки» – заменить существующую заявку путем поиска соответствующей транзакции с последующим открытием формы изменения заявки, на которой для редактирования доступны только те поля, которые присутствуют в найденной транзакции. Функция доступна, если в основных настройках установлен признак «Заменять заявки путем изменения их параметров» (пункт меню Система / Настройки / Основные настройки…, раздел «Торговля» / «Заявки» / «Замена заявок» / «Команды меню»).
    • «Снять заявку» (или «Ctrl»+«D») – cнять заявку.
    • «Снять активные заявки» (или «Ctrl»+«F8») – снять активные заявки, отображающиеся в таблице с учетом настроенных фильтров в данный момент.
    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.
    • «Открыть канал» / «Закрыть канал» – включить / выключить режим связанных окон в данной основной таблице.
    • «Подключиться к каналу» – привязать окно к основной таблице (подробнее см. Режим связанных окон).
      • «<Название таблицы>» – привязка окна к данной таблице;
      • «Отключить» – отключение связанной таблицы от канала.
    • «[<Класс>] <Наименование инструмента>» – открыть Таблицу котировок.
    • «Оповещение по заявке» (или «Ctrl»+«Alt»+«A») – создать оповещение на исполнение/отмену заявки клиента. Оповещение создается автоматически на основе параметров выделенной заявки. Просмотреть созданное оповещение можно из таблицы «Окно оповещений».
    • «SMS-оповещение по заявке» (или «Ctrl»+«Alt»+«S») – настроить отправку SMS-уведомлений об исполнении заявки с определенным номером.
    • «Сохранить в файл заявки из таблицы» – записать в файл только те заявки, которые отображены в таблице.
    • «Сохранить в файл все заявки» – записать в файл все имеющиеся заявки, без учета настроек таблицы».

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы
    • Формат вывода в текстовый файл


Настройка таблицы

  1. «Выбранные классы» – выбор классов, заявки по которым отображаются в таблице.
  2. «Фильтр инструментов» – настройка фильтра инструментов возможна для каждого класса из списка «Выбранные классы». Фильтр используется для создания Таблицы заявок по определенному инструменту (группе инструментов).
  3. «Фильтр фирм» * – настройка фильтрации по кодам фирм.
  4. «Фильтр счетов депо» * – настройка фильтрации по счетам депо.
  5. «Фильтр клиентов» * – настройка фильтрации по кодам клиентов.
    (*) С помощью фильтров можно настроить разные таблицы для разных групп клиентов или по разным секторам рынка.
  6. «Цветовые настройки» – открытие окна «Цветовые настройки таблицы заявок» для настройки цвета шрифта и фона строки в зависимости от состояния заявки.
  7. «Фильтр состояния» – настройка фильтрации по значению поля «Состояние» (Активные, Исполненные, Снятые).
  8. «Только частично исполненные» – признак отображения в таблице только частично исполненных заявок, у которых значение параметра «Количество» не равно значению параметра «Остаток».
  9. «Фильтр операции» – настройка фильтрации по значению поля «Операция» (Покупка, Продажа). Рекомендуется применять для создания различных таблиц для заявок на покупку и на продажу.
  10. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

См. также Формат вывода в текстовый файл


Цветовые настройки таблицы заявок

Окно вызывается нажатием кнопки «…» справа от флажка «Цветовые настройки» в диалоге редактирования Таблицы заявок. Настройки позволяют задать цвет фона и цвет текста для строк таблицы в зависимости от состояния исполнения заявок:

В окне отображается таблица с описанием состояния заявок и цвета их фона и текста.

  • «Активная заявка» - для заявок со статусом «Активна».
  • «Исполненная заявка» - для заявок со статусом «Исполнена».
  • «Снятая заявка» - для заявок со статусом «Снята».
  • «Частично исполненная активная заявка» - для активных заявок, объем которых частично исполнен.
  • «Частично исполненная снятая заявка» - для снятых заявок, объем которых частично исполнен.

Настройка цвета фона и текста осуществляется нажатием кнопки [image] в соответствующем столбце.

Для отличия частично исполненных заявок рекомендуется использовать желтый цвет фона. Кнопка «По умолчанию» возвращает стандартные настройки, значения которых приведены на рисунке.


Таблица стоп-заявок

меню Создать окно / Стоп-заявки... или кнопка
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Контроль состояния исполнения стоп-заявок и управление неисполненными стоп-заявками.

    Формат таблицы

    Каждой стоп-заявке соответствует отдельная строка таблицы.

    Строки таблицы могут выделяться цветом в зависимости от настроек. По умолчанию используются следующие цветовые настройки:

    • Красный цвет шрифта – активные заявки;
    • Синий цвет шрифта – исполненные заявки;
    • Черный цвет шрифта – снятые заявки;
    • Зеленый цвет шрифта на желтом фоне –заявки типа «тейк-профит», по которым начат расчет значений максимума/минимума цены.

    К таблице может быть применен Режим связанных окон.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Номер | Регистрационный номер стоп-заявки на сервере QUIK
    ** Дата | Дата регистрации стоп-заявки
    *, ** Время | Время регистрации стоп-заявки на сервере QUIK. Формат определяется настройками операционной системы
    * Время (мкс) | Время выставления стоп-заявки, в микросекундах
    *, ** Дата снятия | Дата снятия стоп-заявки
    *, ** Время снятия | Время снятия стоп-заявки на сервере QUIK. Формат определяется настройками операционной системы
    Снята (мкс) | Время снятия стоп-заявки, в микросекундах
    * Тип стоп-заявки

    Тип стоп-заявки. Возможные значения:

    • «Стоп-лимит» – стандартная стоп-заявка;
    • «СЦ по др. инструменту» – стоп-заявка, в которой условие стоп-цены проверяется по другому инструменту;
    • «Со связ. заявкой» – стоп-заявка, связанная с лимитированной заявкой одинаковой направленности и объема;
    • «Тейк-профит» – тейк-профит;
    • «Тейк-профит и стоп-лимит» - комбинированный тейк-профит и стоп-лимит;
    • «Стоп-лимит по заявке» – стоп-лимит, выставляемый по исполнению заявки;
    • «Тейк профит по заявке» – тейк-профит, выставляемый по исполнению заявки;
    • «Тейк-профит и стоп-лимит по заявке» - комбинированный тейк-профит и стоп-лимит, выставляемый по исполнению заявки
    Описание типа стоп-заявки | Расширенное описание типа стоп-заявки
    Инструмент сокр. | Сокращенное наименование инструмента
    * Инструмент | Наименование инструмента
    Код инструмента | Идентификатор инструмента в торговой системе
    Класс | Наименование класса, к которому относится инструмент
    Код класса | Код класса в торговой системе
    * Операция | Направление операции («Купля», «Продажа»)
    * Счет | Код торгового счета, по которому подана заявка
    Инструмент стоп-цены | Для стоп-заявок типа «СЦ по др. инструменту» указывается инструмент, по которому проверяется условие. Для других типов стоп-заявок поле пустое
    Код инструмента стоп-цены | Идентификатор инструмента, указанного в «Инструмент стоп-цены»
    Класс стоп-цены | Наименования класса инструмента, указанного в «Инструмент стоп-цены»
    Код класса стоп-цены | Код класса инструмента, указанного в «Инструмент стоп-цены»
    Направление стоп-цены | Отношение стоп-цены к цене последней сделки в виде «<=» или «>=»
    * Стоп-цена | Цена условия, при котором происходит начало расчета максимума (минимума) цены для заявок типа «тейк-профит» и «со связанной заявкой», за единицу инструмента. Для заявок типа «Стоп-цена по другому интструменту» в поле показывается значение параметра «если цена <= »
    * Стоп-лимит цена | Цена условия, при котором происходит выставление заявок типа «Тейк-профит и стоп-лимит», за единицу инструмента
    * Цена | Цена заявки, за единицу инструмента
    * Стоп-лимит по рыночной | Признак исполнения заявки «Стоп-лимит» по рыночной цене: «Да» -рыночная, «Нет» - лимитированная
    * Кол-во | Количество инструментов, указанное в заявке, с точностью количества инструмента или в лотах
    * Акт. кол-во Количество инструментов в активной условной заявке, ожидающей наступления условия, с точностью количества инструмента.
    Для связанных заявок с условием частичного исполнения показывает остаток связанной лимитированной заявки. Для заявок «по исполнению» показывает исполненный объем заявки-условия
    * Исп. кол-во | Количество инструментов в заявке, сгенерированной при исполнении условной заявки, с точностью количества инструмента или в лотах
    Дилер | Идентификатор фирмы, от имени которой подана заявка
    UID | Код пользователя на сервере QUIK
    Код клиента | Код клиента, по которому установлен лимит средств
    * Комментарий Дополнительная справочная информация (заполняется трейдером), например:
    <код клиента>/<номер поручения>
    * Номер заявки | Номер заявки в торговой системе, зарегистрированной по наступлению условия стоп-цены
    Сделка условия | Номер сделки в Таблице обезличенных сделок, значение цены которой стало достаточным условием для исполнения стоп-заявки
    ** Срок | Срок исполнения заявки в виде даты, либо значение «До отмены»
    Время действия | Признак проверки условий заявки только в течение заданного периода времени («Да»/«Нет»). Параметр заявок типов «Тейк-профит и стоп-лимит» и «Тейк-профит и стоп-лимит по заявке»
    ** Активна с | Время начала действия стоп-заявки. Формат определяется настройками операционной системы
    ** Активна по | Время окончания действия стоп-заявки. Формат определяется настройками операционной системы
    Тип

    Тип заявки, код из нескольких символов. Используется для заявок типа «тейк-профит» и «по исполнению». Используемые значения:

    • «Ч» – признак частичного исполнения заявки-условия.
    • «И» - признак использования в качестве количества инструментов в заявке «по исполнению» исполненного объема заявки-условия.
    • Единицы измерения отступа для заявок «тейк-профит». Возможные значения: «%» - в процентах, «Д» – в единицах цены.
    • Единицы измерения защитного интервала для заявок «тейк-профит». Возможные значения: «%» - в процентах, «Д» – в единицах цены
    * Состояние | Состояние заявки («Активна», «Исполнена», «Снята», «Активирована»)
    * Результат

    Результат исполнения стоп-заявки. Возможные значения:

    • «Выставлена заявка в ТС» – заявка принята торговой системой;
    • «Отвергнута ТС» – заявка отвернута торговой системой;
    • «Снята» – заявка снята пользователем;
    • «Не прошла контроль позиций» – недостаточно средств клиента для выполнения заявки;
    • «Связ. заявка снята» – лимитированная заявка, связанная со стоп-заявкой, была снята пользователем;
    • «Связ. заявка исполнена» – торговой системой была удовлетворена лимитированная заявка, связанная со стоп-заявкой;
    • «Ждет активации» – условие активации не наступило. Параметр заявок типов «Тейк-профит» и «по исполнению»;
    • «Рассчитывается min/max» - условие активации наступило, начат расчет минимума/максимума цены. Параметр заявок типов «Тейк-профит» и «Тейк-профит по заявке»;
    • «Рассчитывается min/max и ждет активации» - заявка активирована на неполный объем в результате частичного исполнения заявки-условия, начат расчет минимума/максимума цены. Параметр заявок типа «Тейк профит по заявке» с включенным признаком «Частичное исполнение заявки учитывается»
    Связ. заявка | Регистрационный номер заявки в торговой системе, присвоенный связанной заявке
    Цена связ. заявки | Цена, указанная в связанной заявке
    ID транзакции | Значение уникального номера заявки TRANS_ID при импорте заявок из файла
    Отступ от min/max | Величина отступа. Параметр заявок типа «Тейк-профит»
    Единицы отступа Единица измерения параметра «Отступ от min/max». Возможные значения:
    • «Д» – в валюте цены;
    • «%» - в процентах
    Защитный спред | Дополнительное отклонение цены заявки от цены последней сделки, инициировавшей исполнение условной заявки. Параметр заявок типа «Тейк-профит»
    Единицы спреда Единица измерения параметра «Защитный спред». Возможные значения:
    • «Д» – в валюте цены;
    • «%» - в процентах
    Тейк-профит по рыночной | Признак исполнения заявки «Тейк-профит» по рыночной цене: «Да» - рыночная, «Нет» - лимитированная
    Заявка условия | Регистрационный номер заявки-условия в торговой системе. Параметр заявок типа «по исполнению»
    Сервер Сервер, на котором выставлена стоп-заявка. Возможные значения:
    • «Текущий»;
    • «Другой»
    UID снявшего заявку | Код на сервере QUIK пользователя, снявшего стоп-заявку
    *, ** Дата активации | Дата активации стоп-заявки
    *, ** Время активации | Время активации стоп-заявки
    Время активации (мкс) | Время активации стоп-заявки, в микросекундах
    Номинальный объем | Номинальный объем инструмента. Рассчитывается по формуле: «Номинал инструмента» * «Размер лота» * «Количество лотов»

    * - параметры, выбранные по умолчанию

    ** - при включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» значение отображается с учетом временной зоны компьютера, на котором запущен терминал QUIK

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер, экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    • «Новая стоп-заявка» (или «F6», или двойное нажатие левой кнопки мыши) – ввести новую стоп-заявку с условиями, аналогичными заявке, на которой стоит курсор. Если таблица пустая, при выборе функции открывается диалог для выбора класса и инструмента.
    • «Активировать стоп-заявку» (или «Alt»+«F6») – принудительное исполнение условия стоп-заявки.
    • «Сделать стоп-заявку своей» (или «Shift»+«F6») – особая операция при работе с разными серверами брокера. Меняет значение параметра «Сервер» с «Другой» на «Текущий».
    • «Заменить стоп-заявку» (или «Ctrl»+«A») – редактировать неисполненную стоп-заявку.
    • «Снять стоп-заявку» (или «Ctrl»+«D», или двойное нажатие правой кнопки мыши) – снять неисполненную стоп-заявку.
    • «Снять активные стоп-заявки» (или «Ctrl»+«F8») – снять активные заявки, отображающиеся в таблице стоп-заявок с учетом настроенных фильтров в данный момент.
    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.
    • «Подключиться к каналу» – привязать окно к основной таблице (подробнее см. Режим связанных окон).
      • «<Название таблицы>» – привязка окна к данной таблице;
      • «Отключить» – отключение связанной таблицы от канала.
    • «[<Класс>] <Наименование инструмента>» – открыть Таблицу котировок.
    • «Оповещение по стоп-заявке» (или «Ctrl»+«Alt»+«A») – создать оповещение на исполнение/отмену стоп-заявки клиента. Оповещение создается автоматически на основе параметров выделенной стоп-заявки. Просмотреть созданное оповещение можно из таблицы «Окно оповещений»
    • «SMS-оповещение по стоп-заявке» (или «Ctrl»+«Alt»+«S») – настроить отправку SMS-уведомлений об исполнении стоп-заявки с определенным номером.
    • «Сохранить в файл стоп-заявки из таблицы» – записать в файл только те стоп-заявки, которые отображены в таблице.
    • «Сохранить в файл все стоп-заявки» – записать в файл все имеющиеся стоп-заявки, без учета настроек таблицы».

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы
    • Формат сохранения в текстовый файл


Настройка таблицы

  1. «Выбранные классы» – выбор классов, стоп-заявки по которым отображаются в таблице.
  2. «Фильтр инструментов» – настройка фильтра инструментов возможна для каждого класса из списка «Выбранные классы». Фильтр используется для создания Таблицы стоп-заявок по определенному инструменту (группе инструментов).
  3. «Фильтр фирм» * – настройка фильтрации по кодам фирм.
  4. «Фильтр счетов депо» * – настройка фильтрации по счетам депо.
  5. «Фильтр клиентов» * – настройка фильтрации по кодам клиентов.
    (*) С помощью фильтров можно настроить разные таблицы для разных групп клиентов или по разным секторам рынка.
  6. «Фильтр состояния» – настройка фильтрации по значению поля «Состояние» (Активные, Исполненные, Снятые).
  7. «Фильтр операции» – настройка фильтрации по значению поля «Операция» (Покупка, Продажа). Рекомендуется применять для создания различных таблиц для заявок на покупку и на продажу.
  8. «Выделять состояние стоп-заявки цветоми» – открытие окна «Цветовые настройки таблицы стоп-заявок» для настройки цвета шрифта и фона строки в зависимости от состояния стоп-заявки.
  9. «Показывать стоп-заявки только с текущего сервера» – если флажок установлен, то в таблице отображаются только те условные заявки, которые отправлены на текущий сервер системы QUIK.
    Используется при работе с несколькими серверами системы QUIK (основной, резервный и т.д.).
  10. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

См. также Формат сохранения таблицы в текстовый файл


Цветовые настройки таблицы стоп-заявок

В окне отображается таблица с описанием состояния заявок и цвета их фона и текста.

Окно вызывается нажатием кнопки «…» справа от флажка «Выделять состояние стоп-заявки цветом» в диалоге редактирования Таблицы стоп-заявок. Настройки позволяют задать цвет фона и цвет текста для строк таблицы в зависимости от состояния исполнения стоп-заявок:

  • «Активная заявка» - для стоп-заявок со статусом «Активна».
  • «Исполненная заявка» - для стоп-заявок со статусом «Исполнена».
  • «Снятая заявка» - для стоп-заявок со статусом «Снята».
  • «Идет расчет min/max» - для заявок типа «тейк-профит», по которым начат расчет значений максимума/минимума цены.

Настройка цвета фона и текста осуществляется нажатием кнопки [image] в соответствующем столбце.

Кнопка «По умолчанию» возвращает стандартные настройки, значения которых приведены на рисунке.


Таблица сделок

меню Создать окно / Сделки или кнопка
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Реестр сделок, совершенных в отношении счетов клиента.

    Если количество строк таблицы превышает пороговое значение, заданное в файле info.ini (без учёта глобальных фильтров), то при вызове пункта меню «Создать окно / Сделки» открывается окно редактирования таблицы. Иначе – открывается сформированная Таблица сделок.

    По умолчанию пороговое значение равно «100000».

    Формат таблицы

    Каждой сделке соответствует отдельная строка таблицы.

    Одной исполненной заявке может соответствовать несколько сделок, если заявка была удовлетворена по частям несколькими встречными заявками. Соответствие сделок заявке определяется по регистрационному номеру заявки, указанному в поле «Заявка» Таблицы сделок.

    К таблице может быть применен Режим связанных окон.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    * Номер | Регистрационный номер сделки в торговой системе биржи
    Код биржи | Идентификатор биржи
    Дата торгов | Дата текущей торговой сессии
    **** Дата сделки | Дата регистрации сделки
    **** Дата расчетов | Дата расчетов по сделке
    *, **** Время | Время регистрации сделки в торговой системе с точностью до секунды. Формат определяется настройками операционной системы
    Выставлена (мкс) | Количество микросекунд во времени регистрации сделки
    * Период Период торговой сессии. Возможные значения:
    • «Открытие»,
    • «Закрытие»,
    • «Нормальный»
    *Заявка | Номер заявки, на основании которой заключена сделка
    Инструмент сокр. | Сокращенное наименование инструмента
    * Инструмент | Наименование инструмента
    Код инструмента | Идентификатор инструмента в торговой системе
    ISIN | ISIN-код инструмента
    Класс | Наименование класса, к которому относится инструмент
    Код класса | Код класса в торговой системе
    Тип сделки | Признак маржинальной сделки. Если результат сделки изменяет значение текущего лимита клиента, то указывается тип сделки «маржинальная», иначе поле пустое
    * Операция Направление операции:
    • «Купля» – сделка на покупку;
    • «Продажа» – сделка на продажу;
    • «К/П» / «П/К» – «витринная» сделка (сделка вида «Сделка по операции РЕПО с ЦК», «Адресная сделка по операции РЕПО с ЦК» или «Расчетная по операции своп»). Первая буква соответствует направлению сделки первой ноги
    * Счет | Код торгового счета, в отношении которого заключена сделка
    * Цена | Цена сделки, за единицу инструмента
    * Кол-во | Количество инструментов с точностью количества инструмента или в лотах
    * Объем | Объем сделки в денежном выражении с точностью валюты цены инструмента
    Валюта | Валюта цены, например «SUR» - российский рубль
    Валюта расчетов | Валюта расчетов сделки на Московской Бирже
    Код расчетов | Код проведения расчетов по сделкам в РПС (Режиме переговорных сделок)
    Доходность | Доходность в %, рассчитанная по цене сделки
    НКД | Накопленный купонный доход, рассчитанный для количества инструментов в сделке, в денежном выражении с точностью валюты цены инструмента
    Трейдер | Идентификатор трейдера, совершившего сделку
    Идентификатор рабочей станции | Идентификатор рабочей станции
    Дилер | Идентификатор фирмы, от имени которой совершена сделка
    Орг-я трейдера | Идентификатор фирмы трейдера
    Код клиента | Код клиента, по которому установлен лимит средств
    UID | Код пользователя на сервере QUIK
    * Комментарий Дополнительная справочная информация (заполняется трейдером) – как правило:
    <код клиента>/<номер поручения>
    Партнер | Идентификатор трейдера, с кем заключена сделка (только для РПС)
    Орг-я партнера | Идентификатор фирмы, с которой заключена сделка (только для РПС). Поле заполняется только для клиентов с правами на совершение активных операций
    Цена выкупа Цена выкупа второй части РЕПО, в денежном выражении.
    Для сделок по SWAP-инструментам – базовый курс валютного инструмента, указанный пользователем при подаче транзакции
    Ставка РЕПО (%) | Процентная ставка кредитования при сделках РЕПО, в % годовых
    Комиссия ТС Комиссия торговой системы, взимаемая по сделке, с точностью валюты цены инструмента. Для сделок на Московской Бирже:
    «Комиссия ТС»= «Клиринговая комиссия»+«ФБ комиссия»+«ТЦ комиссия»
    Клиринговая комиссия | Комиссия за клиринговые услуги с точностью валюты цены инструмента. Параметр сделок на Московской Бирже
    ФБ комиссия | Комиссия Фондовой биржи с точностью валюты цены инструмента. Параметр сделок на Московской Бирже
    ТЦ комиссия

    Комиссия Технического центра с точностью валюты цены инструмента. Параметр сделок на Московской Бирже

    Комиссия брокера

    Суммарная комиссия брокера и торговой системы в валюте фактического списания

    ** НКД на дату выкупа | Накопленный купонный доход по сделке на дату выкупа, в ден.выражении с точностью валюты цены инструмента
    ** Сумма РЕПО | Сумма РЕПО - сумма привлеченных/предоставленных по сделке РЕПО денежных средств, по состоянию на текущую дату с точностью валюты цены инструмента
    ** Объем выкупа РЕПО | Объем сделки выкупа РЕПО, в ден.выражении с точностью валюты цены инструмента
    ** Срок РЕПО | Срок РЕПО в календарных днях
    ** Начальный дисконт(%) | Начальный дисконт, в %
    ** Нижний дисконт(%) | Нижнее предельное значение дисконта, в %
    ** Верхний дисконт(%) | Верхнее предельное значение дисконта, в %
    ** Блокировка обеспечения | Признак блокировки финансового инструмента на специальном счете на время операции РЕПО (Да/Нет)
    *** Вид сделки Вид сделки.
    Возможные значения для сделок на Московской Бирже:
    • Обычная;
    • Адресная;
    • Первичное размещение;
    • Перевод денег / инструментов;
    • Адресная сделка первой части РЕПО;
    • Первая часть операции своп;
    • Вторая часть операции своп;
    • Первая часть внебиржевой операции своп;
    • Вторая часть внебиржевой операции своп;
    • Расчетная сделка бивалютной корзины;
    • Расчетная внебиржевая сделка бивалютной корзины;
    • Сделка по операции РЕПО с ЦК;
    • Первая часть сделки по операции РЕПО с ЦК;
    • Вторая часть сделки по операции РЕПО с ЦК;
    • Адресная сделка по операции РЕПО с ЦК;
    • Первая часть адресной сделки по операции РЕПО с ЦК;
    • Вторая часть адресной сделки по операции РЕПО с ЦК;
    • Техническая сделка по возврату активов РЕПО с ЦК;
    • Перенос позиций срочного рынка;
    • Витринная сделка по операции своп;
    • Витринная сделка по адресной операции своп.
    • Сделка исполнения фьючерса;
    • Сделка исполнения опциона;
    • Сделка истечения опциона.

    Возможные значения для сделок на бирже LSE:
    • Late correction – XLON;
    • Not to mark – XLON;
    • Previous Day Contra;
    • Ordinary trade immediate publication – XLON;
    • Inter Fund Transfer delayed publication – XOFF;
    • Negotiated Trade delayed publication – XLON;
    • Negotiated Trade immediate publication – XLON;
    • OTC Late Correction – XOFF;
    • Ordinary Trade delayed publication – XLON;
    • Ordinary Trade Immediate publication – XOFF;
    • SI Late Correction;
    • SI Trade immediate publication;
    • SI Trade delayed publication;
    • OTC Trade delayed publication – XOFF;
    • OTC MTF TBA 1;
    • OTC trade – delayed publication MTF TBA 1;
    • Inter fund cross – delayed publication requested MTF TBA 1;
    • Cancellation of OTC trade after date of publication MTF TBA 1;
    • OTC MTF TBA 2;
    • OTC trade – delayed publication MTF TBA 2;
    • Inter fund cross – delayed publication requested MTF TBA 2;
    • Cancellation of OTC trade after date of publication MTF TBA 2;
    • OTC MTF TBA 3;
    • OTC trade – delayed publication MTF TBA 3;
    • Inter fund cross - delayed publication requested MTF TBA 3;
    • Cancellation of OTC trade after date of publication MTF TBA 3;
    • OTC MTF TBA 4;
    • OTC trade – delayed publication MTF TBA 4;
    • Inter fund cross - delayed publication requested MTF TBA 4;
    • Cancellation of OTC trade after date of publication MTF TBA 4;
    • Delayed Publication Late Correction XLON;
    • No to Mark Late Correction XLON.

    Возможные значения для других бирж:
    • Витринная сделка по беспоставочному свопу;
    • Сделка FX SPOT;
    • Сделка по Беспоставочному валютному форвардному контракту;
    • Сделка FX DEPOSIT;
    • Сделка по Валютному расчетному форвардному контракту
    Идентификатор счета | Идентификатор счета в НКЦ (расчетный код)
    Исходный номер | Номер витринной сделки в ТС. Параметр сделок РЕПО с ЦК и SWAP
    Айсберг-заявка Признак совершения данной сделки айсберг-заявкой. Возможные значения:
    • «Да» – сделка совершена айсберг-заявкой;
    • «» (пусто) – иначе
    Фирма клиринга | Идентификатор фирмы - участника клиринга
    Счет клиринга | Идентификатор клирингового расчетного счета в НКЦ
    ID транзакции | Значение уникального номера заявки TRANS_ID, породившей сделку
    UID отказавшегося от сделки | Код на сервере QUIK пользователя, отказавшегося от сделки
    Дата снятия | Дата отказа от сделки
    Снята(время) | Время отказа от сделки. Формат определяется настройками операционной системы
    Снята(мкс) | Количество микросекунд во времени отказа от сделки
    Системная ссылка | Дополнительная информация по сделке, передаваемая торговой системой
    Состояние Статус сделки. Возможные значения:
    • «А» – активная сделка;
    • «П» – пассивная сделка;
    • «О» – отмененная сделка
    Приоритетное обеспечение | Приоритетный инструмент, принимаемый в обеспечение
    Кол-во базовой валюты Количество базовой валюты в валютной паре (например, для пары USDRUB это USD) с точностью количества инструмента. Параметр заполняется только для класса «Валюта» и отображается:
    • С точностью до двух знаков – если на классе «Валюта» стоит признак «Количество в валюте»;
    • Рассчитывается по формуле: «Объем» = «Количество» * «Размер лота» – если на классе «Валюта» нет признака «Количество в валюте»
    Базовая валюта | Базовая валюта в валютной паре (например, для пары USDRUB это USD). Параметр заполняется только для класса «Валюта»
    Кол-во котируемой валюты Количество котируемой валюты в валютной паре (например, для пары USDRUB это RUB) с точностью количества инструмента. Параметр заполняется только для класса «Валюта» и отображается:
    • С точностью до двух знаков – если на классе «Валюта» стоит признак «Количество в валюте»;
    • Рассчитывается по формуле: «Объем» = «Цена» * «Количество» * «Размер лота» – если на классе «Валюта» нет признака «Количество в валюте»
    Котируемая валюта | Котируемая валюта в валютной паре (например, для пары USDRUB это RUB). Параметр заполняется только для класса «Валюта»
    Биржевой номер заявки | Биржевой номер заявки, по которой исполнилась сделка
    Площадка исполнения | Идентификатор биржевой площадки, на которой зарегистрирована сделка
    Индикатор ликвидности Индикатор ликвидности сделки. Возможные значения:
    • «» (пусто);
    • «По заявке мейкера»;
    • «По заявке тейкера»;
    • «Вывод ликвидности»;
    • «По заявке в период аукциона»
    On Behalf Of UID | UID пользователя, от имени которого совершена сделка
    Client qualifier Квалификатор клиента, от имени которого совершена сделка. Возможные значения:
    • «» (пусто);
    • «Natural Person»;
    • «Legal Entity»
    Client short code | Краткий идентификатор клиента, от имени которого совершена сделка
    Investment decision maker qualifier Квалификатор принявшего решение о совершении сделки. Возможные значения:
    • «» (пусто);
    • «Natural Person»;
    • «Algorithm»
    Investment decision maker short code | Краткий идентификатор принявшего решение о совершении сделки
    Executing trader qualifier Квалификатор трейдера, исполнившего заявку, по которой совершена сделка. Возможные значения:
    • «» (пусто);
    • «Natural Person»;
    • «Algorithm»
    Executing trader short code | Краткий идентификатор трейдера, исполнившего заявку, по которой совершена сделка
    Side qualifier Результат операции сделки. Возможные значения:
    • «» (пусто);
    • «Buy»;
    • «Sell»;
    • «Sell short»;
    • «Sell short exempt»;
    • «Sell undiclosed»
    Capacity Роль в исполнении заявки. Возможные значения:
    • «» (пусто);
    • «Agent»;
    • «Principal»;
    • «Riskless principal»;
    • «CFG give up»;
    • «Cross as agent»;
    • «Matched Principal»;
    • «Proprietary»;
    • «Individual»;
    • «Agent for other member»;
    • «Mixed»;
    • «Market maker»
    Кросс-курс | Кросс-курс валюты цены сделки к валюте расчетов по сделке
    Номинальный объем | Номинальный объем инструмента. Рассчитывается по формуле: «Номинал инструмента» * «Размер лота» * «Количество лотов»
    Расчетная сумма Возможные значения:
    • для облигаций – объем сделки с учетом НКД;
    • для акций – объем сделки
    Валюта комиссии торговой системы | Код валюты комиссии торговой системы
    Валюта комиссии брокера | Код валюты комиссии брокера
    Торговая сессия Идентификатор торговой сессии. Возможные значения:
    • «Не определено»;
    • «Основная сессия»;
    • «Дополнительная сессия»;
    • «Утренняя сессия»;
    • «Итоги дня»
    Дата фиксации | Дата фиксации котировки для расчетов. Заполняется для контрактов типа «NDF»
    Дата начала действия | Дата, начиная с которой допускается совершение валютирования. Заполняется только для контрактов типа «FLEX FORWARD»
    Спот-котировка | Цена котировки по спот-инструменту в момент совершения сделки
    Тип контракта Тип совершаемой операции. Возможные значения:
    • «NOT_DEFINED»;
    • «SPOT»;
    • «FORWARD»;
    • «SWAP»;
    • «NDF»;
    • «FLEX FORWARD»
    Внешняя ссылка | Текстовый комментарий, содержащий информацию о пользователе внешней системы
    Индикатор | Идентификатор индикативной ставки
    Тип сделки депозита Тип сделки депозита. Возможные значения:
    • «» (пусто) – сделка не типа «депозит»;
    • «Намерение»;
    • «Депозит»;
    • «Изъятие»;
    • «Закрытие планового пополнения»;
    • «Принудительное закрытие»;
    • «Перенос пополнения»
    Стоимость выкупа РЕПО с открытой датой в день Т+1 | Стоимость выкупа сделки РЕПО с открытой датой в день Т+1. Точность соответствует точности валюты. Поле заполняется только для РЕПО с открытой датой
    День Т+1 для сделок РЕПО с открытой датой | День Т+1 для сделок РЕПО с открытой датой в формате <ДД.ММ.ГГГГ>. Поле заполняется только для сделок РЕПО с открытой датой
    РЕПО с открытой датой Сделка РЕПО с открытой датой. Возможные значения:
    • «Да»;
    • «Нет»

    * - параметры, выбранные по умолчанию

    ** - параметры сделок РЕПО

    *** - при получении терминалом неизвестного ему вида сделки, в данное поле выводится запись «Вид сделки XXX»

    **** - при включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» значение отображается с учетом временной зоны компьютера, на котором запущен терминал QUIK

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    • «Новая заявка» (или «F2», или двойное нажатие левой кнопки мыши) – ввести новую заявку с условиями, аналогичными сделке, на которой стоит курсор.
    • «Новая Айсберг заявка» – ввести новую Айсберг заявку.
    • «Новая стоп-заявка» (или «F6») – ввести новую стоп-заявку.
    • «[<Класс>] <Наименование инструмента>» – открыть Таблицу котировок.
    • «Построить график» (двойное нажатие правой кнопки мыши – построить график.
    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.
    • «Подключиться к каналу» – привязать окно к основной таблице (подробнее см. Режим связанных окон).
      • «<Название таблицы>» – привязка окна к данной таблице;
      • «Отключить» – отключение связанной таблицы от канала.
    • «Сохранить в файл сделки из таблицы» – записать в файл только те сделки, которые отображены в таблице.
    • «Сохранить в файл все сделки» – записать в файл все имеющиеся сделки, без учета настроек таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы
    • Формат вывода в текстовый файл


Настройка таблицы

  1. «Выбранные классы» – выбор классов, сделки по которым отображаются в таблице.
  2. «Фильтр инструментов» – настройка фильтра инструментов возможна для каждого класса из списка «Выбранные классы». Фильтр используется для создания Таблицы сделок по определенному инструменту (группе инструментов).
  3. «Фильтр фирм» * – настройка фильтрации по кодам фирм.
  4. «Фильтр счетов депо» * – настройка фильтрации по счетам депо.
  5. «Фильтр клиентов» * – настройка фильтрации по кодам клиентов.
    (*) С помощью фильтров можно настроить разные таблицы для разных групп клиентов или по разным секторам рынка.
  6. «Фильтр типа сделки» – настройка фильтрации по признаку маржинальной сделки (Немаржинальные, Маржинальные). Рекомендуется применять для создания различных таблиц для маржинальных и кассовых сделок.
  7. «Фильтр операции» – настройка фильтрации по значению поля «Операция» (Покупка, Продажа). Рекомендуется применять для создания различных таблиц для заявок на покупку и на продажу.
  8. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

См. также Формат вывода в текстовый файл


Новости

меню Создать окно / Новости
  • Назначение
  • Формат окна
  • Доступные функции
  • Поиск по новостям

    • Назначение

    Просмотр лент новостей информационных агентств.

    Условия распространения новостей (платно/бесплатно), а также их источник, определяются соглашением между информагентством и организацией, использующей систему QUIK (биржей, брокером). Для возможности получения новостей обратитесь к администратору системы QUIK.

    Формат окна

    Окно разделено на две части:

    • в верхней части окна расположены заголовки новостей, с указанием следующих параметров:

      Параметр | Значение
      *Важные | – важное сообщение
      *Непрочитанные – непрочитанная новость.
      Заголовки непрочитанных новостей выделяются в списке жирным шрифтом
      *Дата и время | Дата и время рассылки сообщения информационным агентством. Формат определяется настройками операционной системы
      *Агентство | Наименование источника информации
      *Заголовок | Текст заголовка сообщения
      *Номер | Номер сообщения, присвоенный его источником
      Страна | Список стран, связанных с новостью
      Инструмент | Список кодов инструментов, связанных с новостью

      * - параметры, выбранные по умолчанию

    • В нижней части окна отображается текст новости.

    Получение новостей:

    • Сервер системы присылает заголовок сообщения, который отображается в верхней части окна.Заголовки непрочитанных новостей выделяются в списке жирным шрифтом и значком [image].
    • При двойном нажатии на заголовке левой кнопкой мыши с сервера запрашивается текст новости, который появляется в нижней части окна новостей.
    Если в момент запроса текста сообщения произошел сбой, то появляется сообщение «Запрошенная новость отсутствует на сервере.

    В системе QUIK возможно создание нескольких таблиц новостей.О настройках получения и просмотра новостей см. Система/Настройки/Основные настройки... раздел «Новости».

    Доступные функции

    Функции, доступные для данного окна, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    1. Функции, выполняемые из контекстного меню таблицы:
      • «Сохранить в файл новости из таблицы» - сохранить в файл новости с учетом фильтров, настроенных в таблице.
      • «Сохранить в файл все новости» - сохранить в файл все новости (без учета фильтров).
    2. Функции, выполняемые из контекстного меню области просмотра сообщения:
      • «Копировать выбранное» - копировать выделенный фрагмент текста в буфер обмена.
      • «Выделить все» - выделить весь текст.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    Поиск по новостям

    Функция поиска по новостям отличается от поиска в других таблицах наличием флажка «Только в заголовках». Если флажок установлен, то искомое значение определяется только среди заголовков новостей. Если флажок снят, то поиск осуществляется как в заголовках, так и в тексте принятых (т.е. прочитанных) новостей.

    См. также Формат сохранения в текстовый файл.


Настройка таблицы

  1. «Набор параметров» – выбор параметров для отображения в верхней части окна и настройка их очередности.
  2. «Область заголовков» – настройка внешнего вида верхней части окна:
    • «Шрифт» – выбор типа шрифта и его размера;
    • «Цвет фона» – выбор цвета фона;
    • «Цвет текста» – выбор цвета текста.

    О настройке цветов см. Настройка цветов.

  3. «Область тела новости» – настройка внешнего вида нижней части окна. Параметры «Шрифт», «Цвет фона», «Цвет текста» настраиваются таким же образом, как и для «Области заголовков».
  4. «Отображать только непрочитанные» – если флажок включен, то в верхней части окна новостей отображаются заголовки только непрочитанных новостей. Если флажок снят, то отображаются заголовки всех доступных новостей.
  5. «Фильтр агентств» – настройка фильтрации заголовков сообщений в верхней части окна новостей по значению поля «Агентство».
  6. «Показать статистику» – отображать в заголовке окна количество полученных новостей, дату и время последней новости.
  7. «Контекстный фильтр» – настройка отображения в данном окне новостей только сообщений, содержащих одну из фраз, указанных в текстовом поле. Для использования фильтра по тексту новостей включите в настройках программы флажок «Запрашивать тело новости вместе с заголовком» (пункт меню Система / Настройки/Основные настройки... , раздел «Новости»). Если эта настройка отключена, фильтр работает только по заголовкам сообщений.
    • Текстовое поле – перечень ключевых фраз, разделенных символом «;».
    • «Учитывать регистр» – признак поиска ключевых фраз в тексте с соблюдением верхнего/нижнего регистра символов.
    • «Исключать выбранные» – если флажок снят, то в окне новостей отображаются сообщения, содержащие хотя бы одну из ключевых фраз; если флажок установлен, то в окне показаны сообщения, не содержащие ни одной из ключевых фраз.
    • «Поиск только в заголовках новостей» – признак поиска ключевых фраз только в заголовках новостей. При отключенной настройке «Запрашивать тело новости вместе с заголовком» (пункт меню Система/Настройки/Основные настройки…, раздел «Новости») флажок установлен и признак недоступен для редактирования.
  8. «Установить звуковой сигнал» – выбор файла со звуковым сигналом, проигрываемого при появлении очередной новости в данном окне новостей, с учетом всех фильтров. Задать звуковой сигнал на получение всех новостей (без учета настроек конкретного окна новостей), можно в пункте меню программы Система / Настройки/Основные настройки... раздел «Программа»/«Звуки».


Окно сообщений Трейдера

меню Создать окно / Окно сообщений Трейдера...
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Обмен текстовыми сообщениями с другими пользователями системы.

    Право обмена сообщениями и адресаты, доступные для переписки, определяются Администратором системы QUIK.

    Формат таблицы

    В строках таблицы отображаются сообщения в порядке их поступления. Одна таблица объединяет отправленные и полученные сообщения.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    * Дата | Дата регистрации сообщения на сервере
    * Время | Время регистрации сообщения на сервере. Формат определяется настройками операционной системы
    Тип адресата | Кем является адресат – Получатель / Отправитель / Получатель и отправитель
    Организация адресата | Название организации адресата
    UID | Идентификатор адресата в системе QUIK
    Имя адресата | Имя адресата (кому отправлено Вами или от кого получено письмо)
    Статус Состояние сообщения:
    • «Отправлено адресату» – сообщение отправлено активному пользователю без уведомления;
    • «Зарегистрировано» – сообщение отправлено неактивному пользователю и находится в состоянии ожидания подключения пользователя;
    • «Снято после регистрации» – сообщение, адресованное неактивному пользователю, не отправлено (установлен флажок «Отправлять немедленно или не отправлять совсем»);
    • «Получено адресатом» – сообщение отправлено и получено уведомление;
    • <пусто> - это сообщение принимаемое, поэтому статус не показывается.
    Сообщение | Текст сообщения
    Идентификатор | Регистрационный номер сообщения на сервере
    Отправлено | Время и дата отправления сообщения отправителем. Формат определяется настройками операционной системы
    Получено | Время и дата получения сообщения получателем. Формат определяется настройками операционной системы

    * - при включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» значение отображается с учетом временной зоны компьютера, на котором запущен терминал QUIK

    Строки таблицы выделяются цветом в зависимости от статуса сообщения:

    • Черный цвет шрифта – отправленные, но не доставленные адресату;
    • Синий цвет шрифта – отправленные и доставленные адресату;
    • Красный цвет шрифта – полученные.

    Полученные непрочитанные сообщения выделяются жирным шрифтом. При наличии непрочитанных полученных сообщений в строке состояния мигает значок [image]. Если при получении сообщения пользователь работает с другой программой, то мигает ярлык «Информационно-торговая система QUIK» в панели задач Windows.

    Ссылки в тексте сообщения открываются в интернет-браузере, установленном по умолчанию. Для перехода по ссылке откройте сообщение и щёлкните левой кнопкой мыши по тексту ссылки.

    Допускается создание нескольких таблиц сообщений с разными настройками.

    Доступные функции

    Данные из таблицы доступны для вывода через DDE-сервер.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    • «Отправить сообщение» (или двойное нажатие левой кнопкой мыши на строке таблицы) – открыть окно отправки сообщений.
    • «Сохранить в файл сообщения Трейдеров из таблицы» – сохранить в текстовый файл сообщения с учетом фильтров этой таблицы.
    • «Сохранить в файл все сообщения Трейдеров» – сохранить в файл все сообщения, без учета фильтров.
    • «Пометить все сообщения как прочитанные» – снять с непрочитанных сообщений выделение жирным шрифтом.
    • «Удалить все сообщения Трейдеров» – удалить все сообщения.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы
    • Настройка приема сообщений
    • Отправка сообщений
    • Формат сохранения в текстовый файл


Настройка таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.
  2. «Фильтр трейдеров» – настройка фильтрации по трейдерам.
  3. «Фильтр организаций» – настройка фильтрации по организациям. Если фильтр установлен, то в таблице отображается переписка только с пользователями, относящимися к указанным в фильтре организациям.
  4. «Тип адресата» – настройка фильтрации сообщений по типу адресата:
    • «Получатель» – показывать получаемые сообщения;
    • «Отправитель» - показывать отправленные сообщения.
  5. «Показывать последнее сообщение первым» – сортировать сообщения в таблице по убыванию времени поступления. При установленном флажке новые сообщения появляются сверху. Если флажок отключен, то новые сообщения добавляются снизу.

См. также:

  • Настройка приема сообщений
  • Настройка окна отправки сообщений


Настройки приема сообщений

Настройка осуществляется через пункт меню программы Система/Настройки/Основные настройки..., раздел «Сообщения» / «Сообщения трейдера»:

  • «Не активизировать приложение» – если пользователь в момент получения сообщения работает с другой программой, то Рабочее место QUIK автоматически не активизируется.
  • «Мигать в панели задач» – если пользователь работает в другом приложении Windows, то мигает ярлык «Информационная система QUIK» на панели задач.
  • «Показывать уведомление» – на экране появляется окно «Вам пришло новое сообщение».
  • «Показывать окно с новым сообщением» – автоматически открывается Окно сообщений Трейдера.
  • «Сигнализировать в окне состояния» – в строке состояния появляется мигающий значок [image].
  • «Удалять сообщения при смене сессии» – очищаются все окна сообщений при установлении связи с сервером.

См. также:

  • Окно сообщений трейдера
  • Настройка окна отправки сообщений


Отправка сообщений

  • Активные и неактивные пользователи
  • Группы пользователей
  • Настройка окна отправки сообщения

    • Вызов окна отправки сообщения осуществляется из пункта меню Действия/Отправить сообщения, либо из аналогичного пункта в контекстном меню, вызванном из таблицы «Окно сообщений Трейдера».

    В рамке «Кому» выберите адресата из списка доступных, в поле «Текст сообщения» наберите текст и нажмите кнопку «Отправить».

    Список адресатов можно сортировать нажатием левой кнопки мыши на заголовке столбца. Повторное нажатие; меняет порядок сортировки на обратный.

    Если необходимо выбрать несколько адресатов, выделите их по очереди, удерживая нажатой клавишу «Ctrl». Если нужно выделить несколько адресатов, расположенных в списке последовательно, удерживайте нажатой клавишу «Shift».

    Двойным нажатием левой кнопки мыши на строке в Окне сообщений открывается окно отправки сообщения, содержащее его текст и выбранного адресата в поле «Кому». Используйте этот способ для ответа на полученное сообщение.

    Текст сообщения выделен сразу, и если начинать ввод текста без снятия выделения, то он исчезнет и освободит место для Вашего сообщения. Если нужно использовать этот текст в качестве цитаты, то снимите выделение нажатием левой кнопки мыши и отредактируйте текст.

    Команда контекстного меню | Комбинация клавиш | Операция редактирования текста
Вырезать | «Сtrl»+«X» | Вырезать выделенный фрагмент текста с копированием в буфер обмена
Копировать | «Сtrl»+«С» | Копировать выделенный фрагмент текста в буфер обмена
Вставить | «Сtrl»+«V» | Вставить содержимое буфера обмена
Удалить | «Del» | Удалить выделенный фрагмент текста
Выделить все |  | Выделить весь текст

    Размер одного сообщения ограничен 799 символами. Сообщение большей длины обрезается при отправке.

    Активные и неактивные пользователи

    Если получатель Вашего сообщения в момент его отправки подключен к серверу (активный пользователь), тогда он получает сообщение сразу. Если получатель не соединен с сервером (неактивный пользователь), то он получает сообщение только после установки соединения.

    Список получателей в Окне отправки сообщений содержит полный перечень пользователей, которым можно отправить сообщение. При этом активные пользователи отмечены слева черным значком [image], неактивные – серым, текущий пользователь – желтым.

    Группы пользователей

    Для отправки одинакового сообщения нескольким адресатам введено понятие группы пользователей. Группа пользователей создается администратором сервера QUIK. Название группы отображается в столбце «Группа». Выделение всей группы осуществляется двойным нажатием левой кнопки мыши на одном из членов группы.

    Настройка окна отправки сообщения

    • «Показывать только работающих Трейдеров» – при включенной настройке в списке получателей отображаются только активные пользователи. Таким образом можно узнать, кто из нужных пользователей подключен к серверу в данный момент.
    • «С уведомлением о получении сообщения адресатом» – при включенной настройке в ответ на получение сообщения другим пользователем отображается уведомление. Рекомендуется использовать для отправки сообщения неактивным пользователям.
    • «Отправить немедленно или не отправлять совсем» – при включенной настройке сообщение получают только пользователи, активные на момент отправки сообщения. Рекомендуется использовать, если нужно послать срочное сообщение всем доступным пользователям.

    Настройки окна сообщения действительны для всех последующих сообщений.

    См. также Окно сообщений трейдера.


Окно оповещений

меню Создать окно / Окно оповещений...
  • Назначение
  • Формат окна
  • Доступные функции

    • Назначение

    Оповещения предназначены для извещения пользователя о наступлении событий, имеющих назначенные им условия.

    Доступны два вида оповещений:

    1. Локальные оповещения - уведомления, отображаемые в Рабочем месте QUIK. Локальные оповещения хранятся и обрабатываются непосредственно на Рабочем месте QUIK и удаляются при смене торгового дня, если не настроен параметр «Активно до». При отключении рабочего места от сервера системы исполнение локальных оповещений невозможно.
    2. SMS-оповещения - уведомления, отправляемые на мобильный телефон пользователя. Sms-оповещения хранятся и обрабатываются на сервере QUIK и не зависят от статуса подключения к серверу Рабочего места QUIK.

    Условие для локального оповещения может быть одного из следующих видов:

    • достижение параметром таблицы «Текущие торги» заданного уровня;
    • исполнение заявки с определенным номером;
    • исполнение стоп-заявки с определенным номером;
    • достижения заданного соотношения цен опционов и расчетных премий;
    • получение от сервера ответа на выставленную транзакцию.

    Условие для sms-оповещения может быть одного из следующих видов:

    • исполнение/отмена заявки клиента;
    • исполнение/отмена стоп-заявки клиента;
    • изменение значения текущего параметра (ценовые события);
    • состояние позиций на спот-рынке в установленный момент времени;
    • состояние позиций и ограничений на срочном рынке в установленный момент времени;
    • исполнение/отмена неторговых поручений;
    • заключение сделки;
    • изменение статуса подключения на сервере.

    Для отображения списка настроенных событий и их состояния используется таблица «Окно оповещений». Рабочее место QUIK поддерживает возможность создания нескольких «Окон оповещений».

    Формат окна

    Окно представляет собой таблицу, каждая строка которой содержит информацию по отдельному оповещению.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    ** Дата выставления | Дата создания оповещения
    ** Время выставления | Время создания оповещения. Формат определяется настройками операционной системы
    ** Активно до | Время жизни оповещения. Возможные значения: «дата» или «Не ограничено». Для оповещений типа «По заявке» параметр «Активно до» всегда равен дате выставления оповещения
    Номер | Уникальный номер условия
    Оповещение Вид оповещения:
    • «Локальное» - отображаемое на Рабочем месте QUIK;
    • «Sms» - отправляемое в виде SMS-сообщения
    Тип Тип условия:
    • «Параметр» – условие на значение параметра таблицы «Текущие торги»;
    • «Заявка» – условие исполнения заявки с заданным номером;
    • «Стоп-заявка» – условие исполнения стоп-заявки с заданным номером;
    • «Соотношение» - условие на соотношение цен опционов и расчетных премий;
    • «Статус транзакции» – условие на значение статуса транзакции и текста, содержащегося в транзакции;
    • «Спот позиции» – состояние позиции по активам спот-рынка в установленный момент времени;
    • «Фьючерсные позиции» – состояние позиций и ограничений по срочным контрактам в установленный момент времени
    GTC | Условие повторяемости оповещения до его отмены вручную. Возможные значения: «Да» или «Нет»
    Инструмент | Наименование инструмента
    Условие | Условие события. Для оповещений типа «параметр» выглядит как математическое условие сравнения, для оповещений типа «заявка» и «стоп-заявка» указывается номер соответствующей заявки, для оповещений типа «статус транзакции» указывается текст, заданный в оповещении
    Тип рассылки Тип рассылки оповещений по заявке:
    • «По всем сделкам» - оповещение рассылается по каждой исполненной сделке или при снятии заявки;
    • «При полном исполнении» - оповещение рассылается при полном исполнении сделки, либо при снятии заявки
    Статус Состояние исполнения условия:
    • «Активно» – событие не наступило, строка таблицы выделяется красным шрифтом;
    • «Исполнено» – событие наступило, строка таблицы выделяется синим шрифтом;
    • «Снято» – условие отменено пользователем, строка таблицы имеет черный шрифт;
    • «Не активно» – событие, для которого не определен класс, инструмент или параметр таблицы «Текущие торги», строка таблицы имеет серый цвет
    ** Время снятия | Время снятия оповещения. Формат определяется настройками операционной системы
    ** Дата срабатывания | Дата наступления события
    ** Время срабатывания | Время наступления события. Формат определяется настройками операционной системы
    *** Статус отправки Типы статусов. Содержит набор литер, отражающих способ отправки оповещения:
    • «S» – SMS-сообщением;
    • «E» – письмом на email;
    • «P» – Push-уведомлением
    Причина неотправки SMS | Причина, по которой SMS-сообщение не отправлено
    Оповещать о связ.заявке | Признак формирования SMS-оповещения по выставленной порожденной лимитированной заявке в случае исполнения оповещения по стоп-заявке
    *Фирма | Идентификатор фирмы-дилера в торговой системе
    *Код клиента | Код клиента
    UID | Идентификатор пользователя, выставившего оповещение
    *Валюта | Код валюты расчетов
    *Код позиции | Код позиции
    *Счет | Торговый счет
    *Код инструмента | Код инструмента
    ** Время отправки Время срабатывания оповещения. В указанное время SMS-оповещение срабатывает и клиенту отправляются сообщения о состоянии позиции (или позиций). В зависимости от параметра «Активно до» SMS-оповещение при срабатывании меняет свой статус на «Исполнено» либо остается в статусе «Активно».
    Формат определяется настройками операционной системы
    Комментарий | Текстовый комментарий к оповещению

    * - параметры оповещений о текущем состоянии позиций на спот-рынке, позиций и ограничений на фьючерсном рынке

    ** - при включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» значение отображается с учетом временной зоны компьютера, на котором запущен терминал QUIK

    *** - поле «Статус отправки» заполняется только для оповещений в статусе «Исполнено» и оповещений, имеющих ненулевые дату/время срабатывания, в противном случае поле отображается пустым

    Доступные функции

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    • «Создать оповещение» – задать условия для нового оповещения выбранного типа:
      • «по заявке» – исполнение заявки с определенным номером;
      • «по стоп-заявке» – исполнение стоп-заявки с определенным номером;
      • «по параметру» – изменение значения текущего параметра (ценовые события);
      • «опционы (цена/премия)» – достижение заданного соотношения цен опционов и расчетных премий;
      • «по статусу транзакции» – изменение статуса выставленной транзакции;
      • «по спот-позициям» – состояние позиций по деньгам и инструментам на спот-рынке в установленный момент времени;
      • «по фьючерсным позициям» – состояние позиций и ограничений на срочном рынке в установленный момент времени.
    • «Заменить оповещение» (или «Ctrl+«A») – заменить оповещение в выбранной строке таблицы «Окно оповещений». При замене оповещения предыдущее условие снимается (получает статус «Снято») и вместо него создается и активизируется новое, с другим номером. Доступно только для локальных оповещений.
    • «Снять оповещение» (или «Ctrl+«D», или двойное нажатие правой кнопки мыши на строке таблицы) – отозвать оповещение в выбранной строке таблицы «Окно оповещений».
    • «Запросить отчет» – заказать отчет об обработке сформированных SMS-оповещений.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Параметры настройки окна
    • Настройка режима оповещения


Параметры настройки окна

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.
  2. «Фильтр состояния» – фильтрация оповещений по значению поля «Статус». В таблице отображаются оповещения только выбранного состояния (Активные, Исполненные, Снятые, Неактивные).
  3. «Фильтр по виду» – фильтрация оповещений по значению поля «Оповещение». В таблице отображаются оповещения только выбранного вида (Локальные, SMS).
  4. «Фильтр по типу» – фильтрация оповещений по значению поля «Тип». В таблице отображаются оповещения только указанного типа.

См. также:

  • Окно оповещений
  • Настройка режима оповещения


Оповещение по заявке

меню Действия / Оповещение по заявке или аналогичный пункт в контекстном меню таблицы

Для быстрого создания оповещения данного типа из Таблицы заявок выберите в контекстном меню пункт:

  • «Оповещение по заявке» (или «Ctrl»+«Alt»+«A»);
  • «SMS-оповещение по заявке» (или «Ctrl»+«Alt»+«S»).

Оповещение на основе исполнения заявки с указанным номером, создает условие типа «Заявка».

  1. «Инструмент» – наименование инструмента, в отношении которого создается оповещение.
  2. «Условие оповещения» – информационное поле диалога, отображающее полученное в результате настроек условие оповещения.
  3. «Вид оповещения» – выбор вида оповещения:
    • «локальное» – отображается на Рабочем месте QUIK;
    • «через SMS» – отправляется в виде SMS-сообщения на номер телефона, указанный в поле «Телефон».
  4. «Класс» – выбор класса инструментов.
  5. «Активно до» – выбор даты, до которой активно оповещение. Недоступно при включенном флажке «Не ограничено».
  6. «Не ограничено» – при включенном флажке время жизни оповещения не ограничено.
  7. «Номер заявки» – ввод номера заявки, в отношении которой создается оповещение. Номер должен соответствовать номеру одной из активных заявок пользователя.
  8. «Тип рассылки» – выбор типа рассылки оповещений по заявке:
    • «по всем сделкам» – оповещение рассылается по каждой исполненной сделке или при снятии заявки;
    • «при полном исполнении» – оповещение рассылается при полном исполнении сделки, либо при снятии заявки.
  9. «Комментарий» – ввод дополнительной справочной информации к оповещению. Допустимо вводить не более 255 символов. Текст комментария отображается в поле «Комментарий» таблицы «Окно оповещений» и в диалоге оповещения.
  10. «Проиграть файл» – при установленном флажке оповещение сопровождается звуковым сигналом. Для выбора файла со звуковым сигналом нажмите кнопку [image] (поддерживаются файлы формата *.wav или *.mp3). Кнопка [image] позволяет прослушать выбранный звуковой файл.
Если персональный звуковой сигнал не выбран, то используется звуковой сигнал из основных настроек программы, заданный для всех оповещений данного типа (пункт меню Система / Настройки / Основные настройки…, раздел «Программа» / «Звуки» / «Локальные оповещения»).

Нажатием кнопки «Сохранить» новое оповещение сохраняется и активизируется. Нажатием кнопки «Отмена» окно создания оповещения закрывается без сохранения.


Оповещение по стоп-заявке

меню Действия / Оповещение по стоп-заявке или аналогичный пункт в контекстном меню таблицы

Для быстрого создания оповещения данного типа из Таблицы стоп-заявок выберите в контекстном меню пункт:

  • «Оповещение по стоп-заявке» (или «Ctrl»+«Alt»+«A»);
  • «SMS-оповещение по стоп-заявке» (или «Ctrl»+«Alt»+«S»).

Команда доступна только для активных стоп-заявок.

Оповещение на основе исполнения стоп-заявки с указанным номером, создает условие типа «Стоп-заявка».

  1. Поле «Инструмент» - наименование инструмента, в отношении которого создается оповещение.
  2. «Условие оповещения» - информационное поле диалога, отображающее полученное в результате настроек условие оповещения.
  3. «Вид оповещения» - выбор вида оповещения:
    • «локальное» – отображается на Рабочем месте QUIK;
    • «через SMS» – отправляется в виде SMS-сообщения на номер телефона, указанный в поле «Телефон».
  4. Поле «Номер стоп-заявки» – ввод номера стоп-заявки в отношении которой создается оповещение.
  5. Поле «Активно до» - выбор даты, до которой активно оповещение. Недоступно при включенном флажке «Не ограничено».
  6. «Не ограничено» - при включенном флажке время жизни оповещения не ограничено.
  7. «Создать оповещение для связанной заявки» – если флажок включен, то создается оповещение в случае, если при срабатывании стоп-заявки была выставлена лимитированная заявка.
  8. «Комментарий» – ввод дополнительной справочной информации к оповещению. Допустимо вводить не более 255 символов. Текст комментария отображается в поле «Комментарий» таблицы «Окно оповещений» и в диалоге оповещения.
  9. «Проиграть файл» – при установленном флажке оповещение сопровождается звуковым сигналом. Для выбора файла со звуковым сигналом нажмите кнопку [image] (поддерживаются файлы формата *.wav или *.mp3). Кнопка [image] позволяет прослушать выбранный звуковой файл.
Если персональный звуковой сигнал не выбран, то используется звуковой сигнал из основных настроек программы, заданный для всех оповещений данного типа (пункт меню Система / Настройки / Основные настройки…, раздел «Программа» / «Звуки» / «Локальные оповещения»).

Нажатием кнопки «Сохранить» новое оповещение сохраняется и активизируется. Нажатием кнопки «Отмена» окно создания оповещения закрывается без сохранения.


Оповещение по параметру

меню Действия / Оповещение по параметру или аналогичный пункт в контекстном меню таблицы

Для быстрого создания оповещения данного типа из таблицы «Текущие торги» выберите в контекстном меню пункт «Оповещение по параметру» или «SMS-оповещение по параметру».

Оповещение на основе таблицы «Текущие торги» создает условие типа «Параметр». Выбором из списков определяется инструмент и параметр, значение которого необходимо контролировать для данного инструмента.

  1. Поле «Инструмент» - наименование инструмента, в отношении которого создается оповещение.
  2. «Условие оповещения» - информационное поле диалога, отображающее полученное в результате настроек условие оповещения.
  3. «Оповещение активно до снятия» – при включенном флажке оповещение активно до снятия пользователем.
  4. «Вид оповещения» - выбор вида оповещения:
    • «локальное» – отображается на Рабочем месте QUIK;
    • «через SMS» – отправляется в виде SMS-сообщения на номер телефона, указанный в поле «Телефон».
  5. «Параметр» – выбор параметра инструмента, значение которого необходимо проверять.
  6. Поле «Условие для исполнения» – требуемое условие («больше или равно», либо «меньше или равно») и значение параметра, при достижении которого срабатывает оповещение. В поле автоматически подставляется последнее указанное значение (либо «0», если данных по нему нет).
  7. Поле «Активно до» – выбор даты, до которой активно оповещение. Недоступно при включенном флажке «Не ограничено».
  8. «Не ограничено» – при включенном флажке время жизни оповещения не ограничено.
  9. «Комментарий» – ввод дополнительной справочной информации к оповещению. Допустимо вводить не более 255 символов. Текст комментария отображается в поле «Комментарий» таблицы «Окно оповещений» и в диалоге оповещения.
  10. «Проиграть файл» – при установленном флажке оповещение сопровождается звуковым сигналом. Для выбора файла со звуковым сигналом нажмите кнопку [image] (поддерживаются файлы формата *.wav или *.mp3). Кнопка [image] позволяет прослушать выбранный звуковой файл.
Если персональный звуковой сигнал не выбран, то используется звуковой сигнал из основных настроек программы, заданный для всех оповещений данного типа (пункт меню Система / Настройки / Основные настройки…, раздел «Программа» / «Звуки» / «Локальные оповещения»).

Нажатием кнопки «Сохранить» новое оповещение сохраняется и активизируется. Нажатием кнопки «Отмена» окно создания оповещения закрывается без сохранения.


Оповещение на опционы (цена/премия)

меню Действия / Оповещение на величину (ЦЕНА/ПРЕМИЯ) или аналогичный пункт в контекстном меню таблицы

Для быстрого создания оповещения данного типа из таблицы «Доска опционов» выберите в контекстном меню пункт «Оповещение на величину (ЦЕНА/ПРЕМИЯ)» (или «Ctrl»+«Alt»+«A»).

Локальное оповещение на соотношение цен опционов и расчетных премий, создает условие типа «Опцион».

  1. Поле «Инструмент» - наименование инструмента, в отношении которого создается оповещение.
  2. «Условие оповещения» - информационное поле, отображающее полученное в результате настроек условие оповещения.
  3. «Оповещение активно до снятия» – при включенном флажке оповещение активно до снятия пользователем.
  4. «Оповещение на основе соотношения цен опционов и расчетных премий»:
    • «Выберите опцион» – выбор кода опциона, по которому настраивается оповещение;
    • «Условия исполнения: (Цена / Премия)» – выбор контролируемого условия значения «Цена опциона» / «Расчетная премия» по отношению к введенному значению.. Выборомусловия«>=»/«<=» указывается направление пересечения контролируемого значения, при котором исполняется оповещение.
  5. «Активно до» – дата, до которой активно оповещение. Недоступно при включенном флажке «Не ограничено».
  6. «Не ограничено» – при включенном флажке время жизни оповещения не ограничено.
  7. «Комментарий» – ввод дополнительной справочной информации к оповещению. Допустимо вводить не более 255 символов. Текст комментария отображается в поле «Комментарий» таблицы «Окно оповещений» и в диалоге оповещения.
  8. «Проиграть файл» – при установленном флажке оповещение сопровождается звуковым сигналом. Для выбора файла со звуковым сигналом нажмите кнопку [image] (поддерживаются файлы формата *.wav или *.mp3). Кнопка [image] позволяет прослушать выбранный звуковой файл.
Если персональный звуковой сигнал не выбран, то используется звуковой сигнал из основных настроек программы, заданный для всех оповещений данного типа (пункт меню Система / Настройки / Основные настройки…, раздел «Программа» / «Звуки» / «Локальные оповещения»).

Нажатием кнопки «Сохранить» новое оповещение сохраняется и активизируется. Нажатием кнопки «Отмена» окно создания оповещения закрывается без сохранения.


Оповещение по статусу транзакции

меню Действия / Оповещение по статусу транзакции или аналогичный пункт в контекстном меню таблицы

Для быстрого создания оповещения данного типа из Таблицы транзакций выберите в контекстном меню пункт «Оповещение по статусу транзакции» (или «Ctrl»+«Alt»+«A»).

Локальное оповещение на получение Рабочим местом QUIK ответа от сервера на выставленную транзакцию.

  1. «Статус ответа» – выбор статуса ответа на транзакцию, при получении которого отправляется оповещение. Список содержит статусы ответов по смыслу аналогичных статусам транзакций.
  2. «Содержит текст» – ввод текста (с учетом регистра), который должен содержаться в ответе на транзакцию. При получении ответа, содержащего данный текст, отправляется оповещение. Допустимо вводить не более 127 символов. Текст отображается в поле «Условие» таблицы «Окно оповещений» и диалоге оповещения. Если поле не заполнено, то оповещение формируется по условию «Статус ответа».
  3. «Проиграть файл» – при установленном флажке оповещение сопровождается звуковым сигналом. Для выбора файла со звуковым сигналом нажмите кнопку [image]. Кнопка [image] позволяет прослушать выбранный звуковой файл.
    Если персональный звуковой сигнал не выбран, то используется звуковой сигнал из основных настроек программы, заданный для всех оповещений данного типа (пункт меню Система / Настройки / Основные настройки…, раздел «Программа» / «Звуки» / «Локальные оповещения»).
  4. «Оповещение активно до снятия» – при включенном флажке оповещение активно до снятия пользователем.
  5. «Комментарий» – ввод дополнительной справочной информации к оповещению. Допустимо вводить не более 255 символов. Текст комментария отображается в поле «Комментарий» таблицы «Окно оповещений» и в диалоге оповещения.

Нажатием кнопки «Создать» новое оповещение сохраняется и активизируется. Нажатием кнопки «Отмена» окно создания оповещения закрывается без сохранения.


Оповещение по состоянию позиций на спот-рынке

меню Действия / Создать оповещение / по спот позициям или аналогичный пункт в контекстном меню таблицы

Создание SMS-оповещения о текущем состоянии позиций по указанному инструменту в установленный момент времени.

При срабатывании SMS-оповещения по каждой позиции отправляется отдельное SMS-сообщение.

  1. «Заполнять поля только по существующим спот-позициям» – если флажок включен, то выпадающие списки в полях ввода данного окна заполняются значениями из имеющихся позиций. Если флажок снят, то списки заполняются всеми доступными значениями параметра.
  2. «Фирма» – код фирмы-участника торгов.
  3. «Код клиента» – код клиента.
  4. «Срок расчётов» – выбор срока расчётов.
  5. «Активно до» – дата, до которой активно оповещение. Недоступно при включенном флажке «Не ограничено».
  6. «Не ограничено» – при включенном флажке время жизни оповещения не ограничено.
  7. «Время оповещения» – время отправки уведомления о текущем состоянии позиций.

    При включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» время оповещения указывается с учетом временной зоны компьютера, на котором запущено Рабочее место QUIK.
  8. «По денежной позиции» * – если флажок включен, то создается уведомление по указанной денежной позиции:
    • «Код валюты» – код валюты позиции;
    • «Код позиции» – код позиции для расчетов по обязательствам.
  9. «По позиции по инструменту» * – если флажок включен, то создается уведомление по состоянию позиции по указанному инструменту:
    • «Инструмент» – код инструмента;
    • «Счет депо» – код счета депо.
  10. «Комментарий» – ввод дополнительной справочной информации к оповещению. Допустимо вводить не более 255 символов. Текст комментария отображается в поле «Комментарий» таблицы «Окно оповещений» и в диалоге оповещения.

(*) Если в полях «Код валюты», «Код позиции», «Инструмент», «Счет депо» выбрано значение «Для всех», то уведомления формируются по позициям для всех значений соответствующего поля, которые существовали в момент отправки уведомления.


Оповещение по состоянию позиций и ограничений на срочном рынке

меню Действия / Создать оповещение / по фьючерсным позициям или аналогичный пункт в контекстном меню таблицы

Создание SMS-оповещения о текущем состоянии позиций и ограничений по указанному срочному контракту (или по всем контрактам) в установленный момент времени.

При срабатывании SMS-оповещения по каждой позиции и ограничению отправляется отдельное SMS-сообщение.

  1. «Заполнять поля только по существующим позициям и ограничениям» – если флажок включен, то выпадающие списки в полях ввода данного окна заполняются значениями из имеющихся позиций и ограничений. Если флажок снят, то списки заполняются всеми доступными значениями параметра.
  2. «Фирма» – код фирмы-участника торгов.
  3. «Счет депо» – код счета депо клиента.
  4. «Активно до» – дата, до которой активно оповещение. Недоступно при включенном флажке «Не ограничено».
  5. «Не ограничено» – при включенном флажке время жизни оповещения не ограничено.
  6. «Время оповещения» – время отправки уведомления с текущим состоянием лимитов.

    При включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» время оповещения указывается с учетом временной зоны компьютера, на котором запущен терминал QUIK.
  7. «Инструмент» – код срочного инструмента.

    Если в поле «Инструмент» выбрано значение «Для всех», то уведомления формируются по позициям и ограничениям для всех инструментов, которые существовали в момент отправки уведомления.
  8. «Комментарий» – ввод дополнительной справочной информации к оповещению. Допустимо вводить не более 255 символов. Текст комментария отображается в поле «Комментарий» таблицы «Окно оповещений» и в диалоге оповещения.


Настройка сервиса SMS-оповещений

меню Система / Настройки / Основные настройки…, раздел «Сообщения» / «Оповещения» / кнопка «Настройки SMS-оповещений…»

  1. В поле «Телефон» указывается номер сотового телефона клиента , на который отправляются SMS-оповещения. Для одного пользователя может быть указано несколько номеров через запятую.
  2. В поле «Эл. почта» указывается адрес электронной почты клиента, на который отправляются сообщения, дублирующие SMS-оповещения. Для одного пользователя может быть указано несколько адресов через запятую.
  3. Флажок «Доступность сервиса» включает возможность формирования SMS-оповещений.
  4. Флажок «Контроль дубликатов» включает контроль наличия дубликатов создаваемых SMS-оповещений. Если обнаружен дубликат, то транзакция на регистрацию нового оповещения отвергается.
    Два оповещения считаются дубликатами при полном совпадении всех параметров за исключением параметра «Активно до». Таким образом, есть возможность создать два оповещения по одной заявке, но с разными значениями типа рассылки или по одной стоп-заявке, но с разными положениями флага оповещения о связанной заявке.
  5. Флажок «Отслеживание по коду клиента» – рассылка оповещений при наступлении события с использованием кода клиента пользователя Рабочего места QUIK, инициированного другим пользователем.
  6. Рамка «Типы сервиса» – при необходимости типы уведомлений могут быть включены или отключены пользователем.
  7. Рамка «Автоматически создаваемые поручения»:
    • «Исполнение/отмена неторговых поручений» – рассылка оповещений при исполнении либо отмене неторговых поручений.
    • «Выставление заявки» – рассылка оповещений при выставлении другим пользователем заявки с использованием кода клиента пользователя Рабочего места QUIK. Флажок доступен при включенном флажке «Отслеживание по коду клиента».
    • «Заключение сделки» – рассылка оповещений при заключении сделки.
    • «Новости (только по e-mail)» – рассылка оповещений на e-mail адреса пользователей. Оповещение содержит заголовок и тело новости. При трансляции новости на сервер QUIK оповещения автоматически рассылаются на e-mail пользователей, у которых в программе QUIK Administrator включена опция «Разрешить просмотр» в разделе «Информ.агентства» и выбраны информационные агентства.
    • «Изменение статуса подключения на сервере» – рассылка оповещений при изменении статуса подключения на сервере.
  8. Рамка «Язык оповещения»:
    • «Язык» – язык SMS сообщений.


Настройки режима оповещения

Настройка осуществляется через пункт меню Система/Настройки/Основные настройки…, раздел «Сообщения» / «Оповещения», выбором условий «При исполнении локального оповещения»:

  1. «Не активизировать приложение» – если пользователь в момент получения сообщения работает с другой программой, то Рабочее место QUIK автоматически не активизируется.
  2. «Мигать в панели задач» – если пользователь работает в другом приложении Windows, то мигает ярлык «Информационная система QUIK» на панели задач.
  3. «Показывать уведомление» – на экране поверх всех остальных окон появляется уведомление со списком исполненных оповещений следующего вида:

    Новые оповещения добавляются в это же окно. Нажатие кнопки «ОК» закрывает данное окно и активирует Рабочее место QUIK. Нажатие кнопки «Cancel» закрывает окно и возвращает пользователя к тому приложению Windows, с которым он работал до получения оповещения.
  4. «Показывать окно с исполненным оповещением» – в случае наступления события система открывает таблицу «Окно оповещений» на той вкладке, на которой оно расположено или создает его, если таблица не была предварительно настроена.
  5. «Сигнализировать в строке состояния» – при наличии оповещений, не просмотренных пользователем, в строке состояния рабочего места QUIK появляется мигающий значок «звонок» [image]. Двойным щелчком левой кнопки мыши на этом значке открывается таблица «Окно оповещений» с последним непрочитанным оповещением. При этом непрочитанные оповещения выделяются жирным шрифтом.
  6. «Издавать звуковой сигнал» – оповещение сопровождается звуковым сигналом. Выбор звукового сигнала для локальных оповещений выполняется через пункт меню Система/Настройки/Основные настройки…, раздел «Программа» / «Звуки».
  7. «Переносить активные оповещения на следующий день» – если флажок установлен, то при смене даты и/или сессии активные оповещения сохраняются, а снятые и исполненные удаляются. Если флажок снят, то смена даты либо сессии сопровождается удалением всех оповещений.
  8. «Настройки SMS-оповещений…» – выполнить настройку сервиса SMS-оповещений.

См. также:

  • Окно оповещений
  • Параметры настройки окна


Отчеты по SMS-оповещениям

Отчет отображает все sms-оповещения за указанный период.

Пример отчета:


Таблица «Клиентский портфель»

меню Создать окно / Клиентский портфель... или кнопка
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Отображение денежной стоимости средств клиента, доступных заемных средств и показателей маржинального кредитования.

    Формат таблицы

    Каждая строка таблицы соответствует отдельному идентификатору клиента. В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Фирма | Идентификатор участника торгов в торговой системе
    * Код клиента Идентификатор клиента в системе QUIK.

    Для клиентов срочного рынка: торговый счет срочного рынка

    * Срок расчётов | Срок расчётов. Значение «Tx» соответствует позиции клиента после совершения всех расчетов. При включенной настройке сервера QUIK «Вести позиции в календарных днях» (пункт меню Сервер QUIK/ Библиотеки расчета лимитов..., раздел «Общие параметры», рамка «Общие настройки библиотеки, вкладка «Часть 5») срок расчетов соответствует плановой позиции
    * ПовышУрРиска Для клиентов типа «МЛ» и «МП»:
    Признак «квалифицированного» клиента, которому разрешено кредитование заемными средствами с плечом 1:3. Возможные значения:
    • «ПовышУрРиска» - квалифицированный;
    • <пусто> - нет.
    Для клиентов типа «МД+»:
    Признак клиента с повышенным уровнем риска (КПУР)
    * Тип клиента Признак используемого типа ведения позиций. Возможные значения:
    • «МЛ» – используется схема ведения позиции «по плечу», «плечо» рассчитано по значению Входящего лимита;
    • «МП» – используется схема ведения позиции «по плечу», «плечо» указано явным образом;
    • «МОП» – используется схема ведения позиции «лимит на открытую позицию»;
    • «МД» – используется схема ведения позиции «по дисконтам»;
    • «МД+» – используется схема с ограничением покупательной способности при помощи дисконтов по бумагам, валютам и фьючерсам с возможностью неттинга рисков по множествам инструментов;
    • «C» – используется схема ведения позиций «срочный рынок». Для клиентов срочного рынка без единой денежной позиции;
    • «» (пусто) – используется схема ведения позиции «по лимитам»;
    • «FX» – используется схема маржинального кредитования «Валютное лимитирование»
    Мин.маржа Минимальный размер обеспечения, требуемый под текущий портфель клиента, рассчитывается в соответствии с действующим законодательством *** согласно настройкам брокера.
    Для клиентов типа «МД» отражает стоимость портфеля клиента (инструменты/деньги) с учетом дисконтирующих коэффициентов D min long и D min short.
    Для клиентов типа «МД+» рассчитывается как доля от объема начальной маржи (по умолчанию 50%, может быть изменена).
    Для значений больше «1E25» в поле отображается «INF», но при экспорте по ODBC и DDE выводится фактическое числовое значение
    Нач.маржа Значение показателя «Начальная маржа» (в единицах цены с точностью валюты цены инструмента), рассчитанное в соответствии с действующим законодательством *** согласно настройкам брокера. Отражает стоимость портфеля клиента (инструменты/деньги) с учетом дисконтирующих коэффициентов D long и D short.
    Поле заполняется только для клиентов типа «МД» и «МД+». Для значений больше «1E25» в поле отображается «INF», но при экспорте по ODBC и DDE выводится фактическое числовое значение
    Скор.маржа Значение показателя «Скорректированная маржа» (в единицах цены с точностью валюты цены инструмента), рассчитанное в соответствии с действующим законодательством *** согласно настройкам брокера. Вычисляется аналогично параметру «Нач.маржа» с учетом планового исполнения всех активных заявок.
    Поле заполняется только для клиентов типа «МД» и «МД+». Для значений больше «1E25» в поле отображается «INF», но при экспорте по ODBC и DDE выводится фактическое числовое значение
    * Стоимость портфеля Оценка собственных средств клиента по текущим позициям и ценам с точностью валюты цены инструмента. В случае использования единой денежной позиции на спот- и срочном рынках для клиентов типа «МД» параметр включает вариационную маржу, если она отрицательная, а для клиентов типа «МД+» вариационная маржа учитывается независимо от знака.
    Для клиентов типа «МД» и «МД+» оценка не включает положительные позиции по неликвидным инструментам и валютам. Для клиентов типа «МД+» значение показателя «Стоимость портфеля» рассчитывается согласно действующему законодательству в части требований к осуществлению брокерской деятельности *** согласно настройкам брокера
    Статус Для клиентов фондового рынка с типом «МД» и «МД+» сравнивается состояние стоимости портфеля относительно уровня маржи. Возможные значения:
    • «Нормальный» – стоимость портфеля больше либо равна скорректированной марже;
    • «Ограничение» – стоимость портфеля меньше скорректированной маржи и больше либо равна начальной марже;
    • «Требование» – стоимость портфеля меньше начальной маржи и больше либо равна минимальной марже;
    • «Закрытие» – стоимость портфеля меньше минимальной маржи;
    • «Нет» – клиенты, работающие по схеме ведения позиций «По дисконтам», которые не имеют позиций и обязательств (активных заявок) на фондовом рынке (при этом они могут иметь позиции и обязательства на срочном рынке). Позиции таких клиентов не могут быть закрыты в рамках схемы ведения позиций «По дисконтам». Для определения статуса используются лимиты по инструментам и денежным средствам только по плановым позициям.

    Для клиентов срочного рынка с типом «С» статус определяется значением уровня достаточности средств, заданного в настройках (меню Система/Настройки/Основные настройки…, раздел «Торговля» / «Клиентский портфель» / «Индикация статуса в клиентском портфеле» см. п. 5.13.4 Раздела 5 «Торговые операции клиента»). Возможные значения:
    • «Нормальный» – уровень достаточности средств больше либо равен величине указанной как «Опасный» уровень;
    • «Опасный» – уровень достаточности средств меньше величины указанной как «Опасный» уровень и больше либо равен величине указанной как «Критический» уровень;
    • «Критический» – уровень достаточности средств меньше величины указанной как «Критический» уровень

    Для клиентов типа «МД» и «МД+», использующих единую денежную позицию, отображаемые значения статуса зависят от выбора настройки «Параметры фондового рынка» или «Параметры срочного рынка» (см. Индикация статуса в клиентском портфеле)
      Требование Сумма маржинального требования с точностью валюты цены инструмента:
      • если НПР1 (Стоимость портфеля – Нач.маржа) < 0, то Требование = – НПР1;
      • иначе «0»

      Поле заполняется только для клиентов типа «МД» и «МД+». Для значений больше «1E25» в поле отображается «INF», но при экспорте по ODBC и DDE выводится фактическое числовое значение
      УДС Уровень достаточности средств.
      УДС = (Стоимость портфеля - Мин.маржа)/(Нач.маржа – Мин.маржа)
      Возможные значения: от «-9.99» до «9.99» с точностью 2 знака после десятичного разделителя.
      Если Нач.маржа = Мин.маржа, то:
      • если Стоимость портфеля < Мин.маржа, то УДС= – 9.99;
      • иначе УДС = 9.99

      Поле заполняется только для клиентов типа «МД» и «МД+».
      • 0 <= УДС < 1 – близость к закрытию (маржин-колл);
      • УДС < 0 – принудительное закрытие
      НПР1 | Норматив покрытия риска 1. Рассчитывается как разница параметров «Стоимость портфеля» и «Начальная маржа». Для клиентов типа «МД» и «МД+»
      НПР2 | Норматив покрытия риска 2. Рассчитывается как разница параметров «Стоимость портфеля» и «Минимальная маржа». Для клиентов типа «МД» и «МД+»
      Сроч. счет | Счет клиента на срочном рынке
      * Вход. активы | Оценка собственных средств клиента до начала торгов с точностью валюты цены инструмента
      * Плечо Для клиентов типа «МЛ»: отношение «Входящего лимита» к «Входящим активам».
      Для клиентов типа «МП»: явно заданный коэффициент плеча.
      Для клиентов типа «МД» и «МД+» плечо определяет идентификатор шаблона маржинальных настроек и/или шаблона настроек комиссии в файле настроек Библиотеки расчета лимитов. Поле заполняется, если для клиента явно задано значение плеча в денежном лимите, или в файле настроек Библиотеки расчета лимитов данный клиент приписан к какому-либо маржинальному шаблону настроек. Значение может быть произвольным и не учитывается при расчете других параметров
      Вход. лимит Значение маржинального лимита до начала торгов с точностью валюты цены инструмента.
      Для клиентов типа «МД» и «МД+»: значение берется из поля «Входящий лимит» таблицы «Позиции по деньгам» и позволяет ограничить максимально допустимую величину используемого кредита по деньгам, если включена опция «Контролировать максимальную задолженность по деньгам и бумагам» на закладке «Настройки маржинального кредитования» настроек Библиотеки расчета лимитов (см. руководство «Настройки Библиотеки расчета лимитов», п. 21)
      * Шорты | Оценка стоимости коротких позиций (значение всегда отрицательное) с точностью валюты цены инструмента
      * Лонги Оценка стоимости длинных позиций с точностью валюты цены инструмента
      «Лонги»= «Лонги МО» + «Лонги О»
      Лонги МО | Оценка стоимости длинных позиций по маржинальным инструментам, принимаемым в обеспечение, с точностью валюты цены инструмента
      Лонги О | Оценка стоимости длинных позиций по немаржинальным инструментам, принимаемым в обеспечение, с точностью валюты цены инструмента
      * Тек. плечо Текущее отношение собственных и использованных заемных средств
      «Тек. плечо» = 100 / «Ур. маржи» – 1
      Для клиентов типа «МД» и «МД+» поле не заполняется
      * Ур. маржи Отношение собственных средств клиента (Стоимость портфеля), за исключением денежных средств, заблокированных под покупку немаржинальных инструментов («БлокПокНеМарж»), к стоимости длинных позиций и денежного остатка (если он положительный), в процентах.
      Для клиентов типа «МД» и «МД+» поле не заполняется
      Тек. лимит Текущее значение маржинального лимита с точностью валюты цены инструмента.
      Для клиентов типа «МД» и «МД+» поле не заполняется
      ДостТекЛимит Значение текущего маржинального лимита, доступное для дальнейшего открытия позиций, с точностью валюты цены инструмента.
      Для клиентов типа «МД» и «МД+» поле не заполняется
      БлокПокупка Оценка стоимости активов в заявках на покупку с точностью валюты цены инструмента
      «Блок. покупка»= «Блок. пок. маржин.» + «Блок. пок. обесп.»
      БлокПок МО | Оценка стоимости активов в заявках на покупку маржинальных инструментов, принимаемых в обеспечение (типа «МО»), с точностью валюты цены инструмента
      БлокПок О | Оценка стоимости активов в заявках на покупку немаржинальных инструментов, принимаемых в обеспечение (типа «О»), с точностью валюты цены инструмента
      БлокПокНеМарж | Оценка стоимости активов в заявках на покупку немаржинальных инструментов (тип которых не указан) с точностью валюты цены инструмента. В случае использования дисконтирующих коэффициентов при оценке позиций по инструментам, поле содержит также и сумму дисконта от стоимости короткой позиции клиента по инструментам
      БлокПродажа | Оценка в денежном выражении планируемых шортов (сколько средств брокера планируется использовать при исполнении выставленных заявок на продажу) с точностью валюты цены инструмента
      * ВходСредства | Оценка стоимости всех входящих позиций клиента в ценах закрытия предыдущей торговой сессии, включая позиции по немаржинальным инструментам, с точностью валюты цены инструмента. Для клиентов типа «МД» и «МД+» оценка производится по параметру «Цена закрытия». Если этот параметр отсутствует, то используется параметр «Цена последней сделки». Для других типов клиентов оценка стоимости позиций производится по первому найденному не нулевому параметру в следующем порядке: «Цена закрытия», «Цена последней сделки», «Лучший спрос»/«Лучшее предложение»
      * ТекСредства

      Текущая оценка стоимости всех позиций клиента (с учетом вариационной маржи по счету) с точностью валюты цены инструмента. Для клиентов типа «МД» и «МД+» оценка производится по параметру «Цена последней сделки», если этот параметр отсутствует, используется «Цена закрытия». Для остальных типов клиентов оценка стоимости позиций производится по первому найденному параметру в следующем порядке: «Цена последней сделки», «Лучший спрос/предложение», «Цена закрытия»

      * Прибыль/убытки Абсолютная величина изменения стоимости всех позиций клиента с точностью валюты цены инструмента
      «Прибыль/убытки» = «ТекСредства» - «ВходСредства»
      * ПроцИзмен Относительная величина изменения стоимости всех позиций клиента, в процентах
      «ПроцИзмен» = «Прибыль/убытки» / «ВходСредства» * 100
      На покупку Оценка денежных средств, доступных для покупки маржинальных инструментов (типа «МО»), с точностью валюты цены инструмента.
      Для клиентов типа «МД» и «МД+» поле не заполняется
      На продажу

      Оценка денежных средств, доступных для продажи маржинальных инструментов (типа «МО»), с точностью валюты цены инструмента.
      Для клиентов типа «МД» и «МД+» поле не заполняется

      НаПокупНеМаржин | Оценка денежных средств, доступных для покупки немаржинальных инструментов (тип которых не указан), с точностью валюты цены инструмента
      НаПокупОбесп Оценка денежных средств, доступных для покупки инструментов, принимаемых в обеспечение (типа «О»), с точностью валюты цены инструмента.
      Для клиентов типа «МД» и «МД+» поле не заполняется
      **** ГО поз. Размер денежных средств, уплаченных под все открытые позиции на срочном рынке, с точностью валюты цены инструмента.
      Для клиентов срочного рынка без единой денежной позиции значение соответствует значению поля «Тек.чист.поз. (под открытые позиции)» в Таблице ограничений по клиентским счетам.
      Для клиентов с единой денежной позицией рассчитывается в зависимости от параметров ведения лимитов брокером. В этом случае допускается задание отдельного значения для каждого срока расчётов
      **** ГО заяв. | Оценка стоимости активов в заявках на срочном рынке с точностью валюты цены инструмента. Для клиентов срочного рынка без единой денежной позиции значение соответствует значению поля «Тек.чист.поз. (под заявки)» в Таблице ограничений по клиентским счетам. Для клиентов с единой денежной позицией рассчитывается в зависимости от параметров ведения лимитов брокером. В этом случае допускается задание отдельного значения для каждого срока расчётов
      **** Вариац. маржа | Текущая вариационная маржа по позициям клиента, по всем инструментам с точностью валюты цены инструмента. Соответствует значению поля «Вариац. маржа» в Таблице ограничений по клиентским счетам
      Активы/ГО

      Отношение ликвидационной стоимости портфеля к ГО по срочному рынку. Поле рассчитывается следующим образом:

      «Активы/ГО» = («Стоимость портфеля» + «ГО поз.») / «ГО поз.» * 100%

      Если «ГО поз.» = 0, то в поле указывается значение «100%»,
      Если «Активы/ГО» >100%, то поле указывается значение «100%»
      Сумма ден.остатков | Сумма остатков по денежным средствам по всем лимитам без учета средств, заблокированных под исполнение обязательств, выраженная в выбранной валюте расчета, с точностью валюты цены инструмента. При расчете не используется коэффициент дисконтирования **
      Суммарно заблок. Cумма заблокированных средств со всех денежных лимитов клиента, пересчитанная в валюту расчетов через кросс-курсы на сервере, с точностью валюты цены инструмента.
      Суммирование выполняется для всех лимитов клиента, независимо от настроек мульти-валютности и дополнительных тегов расчетов в Библиотеке расчетов лимитов
      Парам. расч. | Актуальные текущие параметры расчета для данной строки в формате «<Валюта>-<Код позиции>». Пример: «SUR-EQTV».
      Шорты (нетто) | Оценка стоимости коротких позиций с точностью валюты цены инструмента. При расчете не используется коэффициент дисконтирования**
      Лонги (нетто) | Оценка стоимости длинных позиций с точностью валюты цены инструмента. При расчете не используется коэффициент дисконтирования**
      Сумма дисконтов Сумма дисконтов стоимости длинных (только по инструментам обеспечения) и коротких позиций по инструментам, дисконтов корреляции между инструментами, а также дисконтов на задолженности по валютам, не покрытые обеспечением по инструментам в этих же валютах, с точностью валюты цены инструмента.
      Для клиентов типа «МД» и «МД+» поле не заполняется
      ТекАктБезДиск Текущие активы без учета дисконтов с точностью валюты цены инструмента. Суммарная величина денежных остатков, стоимости длинных позиций по инструментам обеспечения и стоимости коротких позиций, без учета дисконтирующих коэффициентов, без учета неттинга стоимости инструментов в рамках объединенной позиции по инструментам и без учета корреляции между инструментами.
      Для клиентов типа «МД» и «МД+» поле не заполняется
      Статус счета Отношение суммы дисконтов к текущим активам без учета дисконтов.
      Для клиентов типа «МД» и «МД+» поле не заполняется
      **** ПолнСумДенОстат на нач. дня Текущие средства на счете после проведения последнего клиринга или на начало торговой сессии с точностью валюты цены инструмента.
      Для клиентов без единой денежной позиции рассчитывается как суммарное значение поля «Лимит откр. поз.» по «Залоговым ден. средствам» и «Ден. средствам» с учетом значения поля «Коэф. ликвидн.» (параметры Таблицы ограничений по клиентским счетам). Для клиентов, использующих единую денежную позицию, соответствует значению поля «Входящий остаток» таблицы «Позиции по деньгам»
      **** ПолнСумДенОстат Текущие средства на счете с точностью валюты цены инструмента.
      Для клиентов без единой денежной позиции рассчитывается как суммарное значение поля «Лимит откр. поз.» по «Залоговым ден. средствам» и «Ден. средствам» с учетом значения поля «Коэф. ликвидн.» (параметры Таблицы ограничений по клиентским счетам) и поля «ВарМаржаПромклир.» (параметр таблицы «Клиентский портфель»). Для клиентов, использующих единую денежную позицию, соответствует значению поля «Текущий остаток» таблицы «Позиции по деньгам»
      **** ПланЧистПоз Доступные (свободные) средства с точностью валюты цены инструмента.
      Для клиентов без единой денежной позиции рассчитывается как суммарное значение «План. чист. поз.» по «Залоговым ден. средствам» и «Ден. средствам» с учетом значения поля «Коэф. ликвидн.» (параметры Таблицы ограничений по клиентским счетам). Для клиентов c типом лимитирования «по плечу» или «по дисконтам», использующих единую денежную позицию, значение параметра равно значению поля «НаПокупНеМаржин» таблицы «Клиентский портфель». Для клиентов с типом лимитирования «МД+», использующих единую денежную позицию, значение параметра рассчитывается как разность значений полей «Стоимость портфеля» и «Скорректированная маржа» таблицы «Клиентский портфель»
      **** ТекЧистПоз Зарезервированные средства с точностью валюты цены инструмента.
      Для клиентов без единой денежной позиции рассчитывается как суммарное значение «Тек. чист. поз.» по «Залоговым ден. средствам» и «Ден. средствам» (параметры Таблицы ограничений по клиентским счетам).
      Для клиентов, использующих единую денежную позицию, соответствует значению поля «Тек. чист. поз.» по «Ден. средствам» в Таблице ограничений по клиентским счетам
      **** НакопВарМаржа Накопленная по сделкам вариационная маржа, которая будет списана с клиента (зачислена клиенту) в ближайший клиринг, с точностью валюты цены инструмента.
      Соответствует значению поля «Вариац. маржа» в Таблице позиций по клиентским счетам
      **** ВарМаржаПромклир. Вариационная маржа по итогам промежуточного клиринга с точностью валюты цены инструмента.
      Для клиентов без единой денежной позиции: Накоплен. доход – Биржевые сборы (параметры Таблицы ограничений по клиентским счетам) по «Ден. средствам». Для клиентов, использующих единую денежную позицию, соответствует значению поля «Накоплен. доход» по «Ден. средствам» в Таблице ограничений по клиентским счетам
      **** НакопДоход Накопленный доход с учётом премии по опционам и биржевым сборам с точностью валюты цены инструмента.
      Для клиентов без единой денежной позиции соответствует значению поля «Накоплен. доход» Таблицы ограничений по клиентским счетам. Для клиентов, использующих единую денежную позицию: Накоплен. доход– Биржевые сборы (параметры Таблицы ограничений по клиентским счетам)
      **** ЛиквСтоимОпционов | Ликвидационная стоимость опционов с точностью валюты цены инструмента. Для немаржируемых опционов рассчитывается как суммарная оценка позиций по опционам с учетом настройки «При расчёте ликвид. стоимости опционов учитывать теор. цену» на странице «Учёт операций срочного рынка» (см. руководство «Настройки Библиотеки расчета лимитов», п. 18). Для маржируемых опционов значение равно «0»
      **** СумАктивовНаСрчРынке | Сумма оценки средств клиента на срочном рынке с точностью валюты цены инструмента. Рассчитывается следующим образом: ПланЧистПоз + ТекЧистПоз + Вариац. маржа + ЛиквСтоимОпционов
      **** ПолнСтоимПортфеля Стоимость портфеля с учётом средств на срочном рынке с точностью валюты цены инструмента.
      Для клиентов срочного рынка без единой денежной позиции значение соответствует значению поля «СумАктивовНаСрчРынке».
      Для клиентов, использующих единую денежную позицию:
      ТекЧистПоз + ЛиквСтоимОпционов + Стоимость портфеля
      **** ТекЗадолжНаСрчРынке | Текущая задолженность на срочном рынке с точностью валюты цены инструмента. Рассчитывается с учетом параметров «ПланЧистПоз» и «СумАктивовНаСрчРынке»
      **** Дост. Средств | Достаточность средств с точностью валюты цены инструмента. Рассчитывается как отношение параметров «СумАктивовНаСрчРынке» и «ТекЧистПоз»
      **** Дост. Средств (ОткрПоз) | Достаточность средств (под открытые позиции) с точностью валюты цены инструмента. Рассчитывается как отношение параметров «СумАктивовНаСрчРынке» и «ГО поз.»
      **** КоэффЛикв ГО | Коэффициент ликвидности ГО. Рассчитывается следующим образом: (ПолнСумДенОстат на нач. дня + НакопДоход) / ТекЧистПоз
      **** Ожид. КоэффЛикв ГО | Ожидаемый коэффициент ликвидности ГО. Рассчитывается следующим образом: (ПолнСумДенОстат на нач. дня + НакопДоход + Вариац. маржа) / ТекЧистПоз
      **** Cash Leverage | Отношение произведения абсолютного размера позиций по активам на цену последней сделки к значению поля «СумАктивовНаСрчРынке»
      **** ТипПозНаСрчРынке Тип позиции на срочном рынке. Возможные значения:
      • «» (пусто) – позиция на срочном рынке отсутствует;
      • «Ф» – имеется ненулевая позиция по фьючерсам;
      • «О» – имеется ненулевая позиция по опционам;
      • «ФО» – имеется ненулевая позиция по фьючерсам и опционам

      * - параметры, выбранные по умолчанию

      ** - подробнее о коэффициентах дисконтирования см. п. 7 Руководства по администрированию «Настройки Библиотеки расчета лимитов»

      *** - действующие требования Центрального банка РФ к правилам осуществления брокерской деятельности

      **** - параметр заполняется для клиентов с настроенной единой денежной позицией и для клиентов срочного рынка без единой денежной позиции

      При расчете значений «Лонги», «Лонги МО», «Лонги О» в стоимость обеспечения не включаются инструменты, у которых отсутствует (или равна «0») цена закрытия предыдущего торгового дня.

      Формулы, используемые для расчета значений параметров таблицы «Клиентский портфель», приведены в Приложении.

      К таблице может быть применен Режим связанных окон.

      Доступные функции

      Данные из таблицы доступны для вывода через DDE-сервер и экспорта по ODBC .

      Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

      • «Обновить таблицу» (или «F5») – пересчитать значения в таблице.
      • «Установить лимит» – рассчитать значение Входящего лимита, исходя из величины Плеча для выбранного клиента.
      • «Установить лимит для клиентов из таблицы» – рассчитать значение Входящего лимита исходя из величины Плеча для всех клиентов, отображаемых в таблице.
      • «Установить остаток и плечо» – установить значение Входящего остатка по денежным средствам и Плеча для выбранного клиента.
      • «Установить плечо для клиентов из таблицы» – установить значение Входящего остатка по денежным средствам и Плеча для всех клиентов, отображаемых в таблице.
      • «Открыть канал» / «Закрыть канал» – включить / выключить режим связанных окон в данной основной таблице.
      • «Открыть таблицу [Купить/Продать]» (или двойное нажатие левой кнопки мыши) – открыть таблицу «Купить/Продать» с информацией по выбранному клиенту.
      • «Состояние счета» – открыть таблицу «Состояние счета» с информацией по выбранному клиенту.
      • «Открыть сводную таблицу позиций» – открыть таблицу, содержащую одновременно позиции по инструментам и денежным средствам для выбранного клиента.

      Дополнительно:

      • Описание стандартных функций контекстного меню для таблиц.
      • Описание применения быстрого фильтра.
      • Описание применения пользовательских фильтров и условного форматирования таблиц.
      • Полный список управляющих клавиш для всех типов таблиц.

      См. также:

      • Настройка таблицы
      • Установка значений лимитов
      • Установка значений остатка и плеча


Настройка таблицы

Дополнительными настройками таблицы устанавливаются фильтры по значениям полей «Фирма» и «Код клиента».

  1. «Имя таблицы».
  2. «Настройки» – выбор отображаемых параметров и настройка их очередности.
  3. «Фильтры»:
    • «Фильтр фирм» – настройка фильтрации по кодам фирм.
    • «Фильтр клиентов» – настройка фильтрации по кодам клиентов фондового рынка и по торговым счетам срочного рынка.
    • «Брать из файла» – фильтрация списка клиентов по значениям торговых счетов срочного рынка и/или кодов клиентов фондового рынка, указанным в файле. Для фильтрации используется файл, выбранный в настройке «Файл с фильтром клиентов».

    Если в настройке «Файл с фильтром клиентов» файл не выбран, то настройка «Брать из файла» недоступна для редактирования.

    Фильтрация по значению поля «Тип клиента», означающему использование клиентом схемы кредитования с контролем текущей стоимости активов.
    • «Клиенты фондового и валютного рынков» – отображение информации по клиентам фондового и валютного рынков, включая клиентов срочного рынка с настроенной единой денежной позицией;
    • «Клиенты срочного рынка без единой позиции» – отображение информации по клиентам срочного рынка без настроенной единой денежной позиции.
  4. «Параметры расчёта»:
    • «Выбор кода позиций» – выбор символьного идентификатора, присваиваемого совокупной денежной позиции брокера, для работы с торговой площадкой или классом инструментов;
    • «Срок расчетов» – настройка фильтрации по выбранному набору сроков расчета;
    • «Валюта» – выбор валюты расчета параметров портфеля. Выбранная валюта отображается в квадратных скобках в заголовке таблицы;
    • «Источник данных для расчетов CoLibri» – настройка используется и отображается в диалоге, если у пользователя установлен плагин «CoLibri» (подробное описание приведено в Руководстве пользователя Терминального модуля риск-менеджера «CoLibri»);
  5. «Цветовые настройки» – признак выделения строк таблицы цветом в зависимости от статуса портфеля. Для настройки цвета шрифта и фона нажмите кнопку «Настроить». Подробнее см. п.«Настройки цвета»
Если при редактировании таблицы выводится сообщение вида: «Вы пытаетесь изменить параметры таблицы, которая помечена как ‘Источник данных для расчетов CoLibri’. Использование этой таблицы в качестве источника данных будет прекращено.», то при нажатии кнопки «OK» изменения сохраняются, окно настройки закрывается. При нажатии кнопки «Отмена» выполняется возврат в диалог редактирования таблицы.

Периодичность вычисления значений таблицы настраивается через пункт меню Система/Настройки/Основные настройки..., раздел «Торговля»/«Клиентский портфель», флажок «Обновлять через каждые ... секунд».

Если в настройках программы (пункт меню Система/Настройки/Основные настройки... , раздел «Торговля»/«Клиентский портфель») включен флажок «Пересчитывать при изменении позиций», то значения таблицы обновляются после каждого изменения позиции у клиента. Если данный флажок отключен, то данные таблицы пересчитываются через интервал времени, установленный предыдущим пунктом, либо вручную.

См. также:

  • Таблица «Клиентский портфель»
  • Установка значений лимитов
  • Установка значений остатка и плеча


Настройки цвета

Окно вызывается нажатием кнопки «Цветовые настроийки» в диалоге редактирования таблицы «Клиентский портфель». Настройки позволяют изменить цвет фона и цвет текста, указанные по умолчанию в настройках параметров работы с Клиентским портфелем в пункте меню Система/Настройки/Основные настройки..., раздел «Торговля» / «Клиентский портфель»/ «Индикация статуса в клиентском портфеле».

О работе с настройками цвета см. Настройка цвета в таблицах и графиках .

Кнопка «По умолчанию» возвращает стандартные настройки, заданные в настройках параметров работы с Клиентским портфелем в пункте меню Система/Настройки/Основные настройки…, раздел «Торговля» / «Клиентский портфель» / «Индикация статуса в клиентском портфеле».


Таблица «Купить/Продать»

меню Создать окно / Клиентский портфель... или кнопка [image],
пункт контекстного меню Открыть таблицу [Купить/Продать]
  • Назначение
  • Формат таблицы
  • Доступные функции
    •

    Назначение

    Отображение текущих позиций клиента по инструментам и максимально возможного количества инструментов для покупки и продажи. В таблице отображаются инструменты классов, указанных в настройке Библиотеки расчета лимитов «Список классов для оценки портфеля» (подробное описание настройки см. в Руководстве «Настройки Библиотеки расчета лимитов», раздел 7 «Классы»).

    Формат таблицы

    В заголовке окна указаны коды клиента и торгового счета, например «2200 NC0080100000». Каждая строка таблицы соответствует отдельному инструменту. Одинаковые инструменты, относящиеся к разным классам, отображаются отдельными строками.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    * Инструмент | Наименование инструмента
    Код инструмента | Код инструмента
    * Класс | Наименование класса инструмента
    Код класса | Код класса инструментов
    *Срок расчётов | Срок расчётов. Значение «Tx» соответствует позиции клиента после совершения всех расчетов. При включенной настройке сервера QUIK «Вести позиции в календарных днях» (пункт меню Сервер QUIK/ Библиотеки расчета лимитов..., раздел «Общие параметры», рамка «Общие настройки библиотеки, вкладка «Часть 5») срок расчетов отображается в формате «Y0, Y1, Y2»
    *Дата расчетов | Дата расчетов для инструмента в соответствующем режиме. Значение отображается только для фирм, где используется режим ведения позиций в календарных днях
    * Тип

    Принадлежность инструмента к списку маржинальных инструментов и списку инструментов, принимаемых в обеспечение маржинального кредита. Возможные значения:

    • «МО» – маржинальный и принимается в обеспечение;
    • «М» – маржинальный и не принимается в обеспечение;
    • «Ф» – маржинальный, для фьючерсов;
    • «О» – немаржинальный, но принимается в обеспечение;
    • «Ш» – запрещены продажи без покрытия («шорт»);
    • <пусто> - немаржинальный и не принимается в обеспечение.
    Для клиентов типа «МД» и «МД+»:
    • «Д» – маржинальный, разрешенный для покупки на заемные средства;
    • «К» – маржинальный, разрешенный для продажи на заемные средства;
    • «ДК» – маржинальный, разрешенный для покупки и продажи на заемные средства;
    • <пусто> – немаржинальный
    * Остаток | Текущая позиция клиента по инструменту с точностью количества инструмента
    Вход. оценка | Оценка стоимости позиции клиента до совершения операций. Для ценных бумаг рассчитывается по цене закрытия предыдущей торговой сессии, для фьючерсов по цене предыдущего клиринга
    * Оценка | Оценка стоимости позиции по цене последней сделки
    * Покупка | Максимально возможное количество в заявке на покупку этого инструмента на этом классе, без учета комиссии торговой системы и комиссии брокера, с точностью количества инструмента. Для клиентов всех типов, кроме «МД+», количество рассчитывается исходя из значения параметра «Лучшая цена предложения», при условии, что торговая сессия имеет статус «Открыта». Если параметр отсутствует, и торговая сессия имеет любой из следующих статусов: «Открыта», «Закрыта», «Период закрытия», максимальное количество в заявке на покупку рассчитывается по параметру «Цена последней сделки». Иначе количество рассчитывается по параметру «Цена закрытия». Для клиентов типа «МД+» максимальное количество в заявке на покупку рассчитывается по параметру «Цена последней сделки», если параметр отсутствует, то по параметру «Цена закрытия». Единица измерения определяется настройками таблицы
    * Продажа | Максимально возможное количество в заявке на продажу этого инструмента на этом классе, без учета комиссии торговой системы и комиссии брокера, с точностью количества инструмента. Для клиентов всех типов, кроме «МД+», количество рассчитывается исходя из значения параметра «Лучшая цена спроса», при условии, что торговая сессия имеет статус «Открыта». Если параметр отсутствует, и торговая сессия имеет любой из следующих статусов: «Открыта», «Закрыта», «Период закрытия», максимальное количество в заявке на продажу рассчитывается по параметру «Цена последней сделки». Иначе количество рассчитывается по параметру «Цена закрытия». Для клиентов типа «МД+» максимальное количество в заявке на продажу рассчитывается по параметру «Цена последней сделки», если параметр отсутствует, то по параметру «Цена закрытия». Единица измерения определяется настройками таблицы
    Покупка(Собств.) | Максимально возможное количество в заявке на покупку этого инструмента на этом классе на собственные средства клиента, с точностью количества инструмента. Количество рассчитывается исходя из значения параметра «Лучшая цена предложения», при условии, что торговая сессия имеет статус «Открыта». Если параметр отсутствует, и торговая сессия имеет любой из следующих статусов: «Открыта», «Закрыта», «Период закрытия», максимальное количество в заявке на покупку рассчитывается по параметру «Цена последней сделки». Иначе количество рассчитывается по параметру «Цена закрытия». Единица измерения определяется настройками таблицы
    Продажа(Собств.) | Максимально возможное количество в заявке на продажу этого инструмента на этом классе из собственных активов клиента, с точностью количества инструмента. Количество рассчитывается исходя из значения параметра «Лучшая цена спроса», при условии, что торговая сессия имеет статус «Открыта». Если параметр отсутствует, и торговая сессия имеет любой из следующих статусов: «Открыта», «Закрыта», «Период закрытия», максимальное количество в заявке на продажу рассчитывается по параметру «Цена последней сделки». Иначе количество рассчитывается по параметру «Цена закрытия». Единица измерения определяется настройками таблицы
    Лимит (лонг) Коэффициент дисконтирования, применяемый для длинных позиций по данному инструменту.
    Для клиентов типа «МД» и «МД+» поле не заполняется
    Лимит (шорт) Предельный размер короткой позиции по данному инструменту.
    Для клиентов типа «МД» и «МД+» поле не заполняется
    **Лонг (коэф) Коэффициент дисконтирования, применяемый для длинных позиций по данному инструменту.
    Для клиентов типа «МД» и «МД+» поле не заполняется
    **Шорт (коэф) Коэффициент дисконтирования, применяемый для коротких позиций по данному инструменту.
    Для клиентов типа «МД» и «МД+» поле не заполняется
    Оценка (коэф) | Оценка стоимости позиции по цене последней сделки, с учетом дисконтирующих коэффициентов. Параметр используется только для схемы ведения позиции «по плечу» («МП»)
    Вход. оценка (коэф) | Оценка стоимости позиции клиента до совершения операций, рассчитанная по цене закрытия предыдущей торговой сессии с учетом дисконтирующих коэффициентов с точностью валюты цены инструмента. Параметр используется только для схемы ведения позиции «по плечу» («МП»)
    Доля | Процентное отношение стоимости позиции по данному инструменту к стоимости всех активов клиента, рассчитанное по текущим ценам
    Средневзвешенная цена коротких позиций | Средневзвешенная стоимость коротких позиций по инструментам
    Средневзвешенная цена длинных позиций | Средневзвешенная стоимость длинных позиций по инструментам
    Прибыль/убытки | Разница между средневзвешенной ценой приобретения инструментов и их рыночной оценкой с точностью валюты цены инструмента, с учетом валюты цены приобретения. Рыночная оценка инструментов для длинных позиций считается исходя из текущей цены спроса, а для коротких позиций – исходя из текущей цены предложения
    **Дисконт корреляции Для инструментов, не участвующих в настройках корреляции, значение данного параметра равно нулю и означает, что оценка этой позиции, при расчёте покупательной способности, учитывается в полном размере.
    Ненулевое значение параметра показывает, что данный инструмент входит в пару инструментов, для которой производится частичное неттирование разнонаправленных позиций (формулы для расчёта оценки короткой и длинной позиций в паре даны в руководстве «Настройки Библиотеки расчета лимитов», раздел 7 «Инструменты»). Коэффициент корреляции определяет долю от суммы неттирования, которая остается в оценке короткой позиции. Указывается в относительных единицах, долях целого. Например, при значении коэффициента корреляции 0.1 в оценке короткой позиции останется 10% суммы, на которую уменьшена оценка длинной позиции
    D long Текущее значение дисконтирующего коэффициента, используемого для расчета начальной и скорректированной маржи для длинных позиций. Устанавливается брокером.
    Поле заполняется только для клиентов типа «МД» и «МД+». При D long = 1 поле не заполняется, но при экспорте по ODBC и DDE выводится фактическое значение «1»
    D short Текущее значение дисконтирующего коэффициента, используемого для расчета минимальной, начальной и скорректированной маржи для коротких позиций. Устанавливается брокером.
    Поле заполняется только для клиентов типа «МД» и «МД+». При D short = + [image] поле не заполняется, но при экспорте по ODBC и DDE выводится фактическое значение «1E50»
    D min long Текущее значение дисконтирующего коэффициента, используемого для расчета минимальной маржи для длинных позиций. Рассчитывается следующим образом:
    Поле заполняется только для клиентов типа «МД». При D min long = 1 поле не заполняется, но при экспорте по ODBC и DDE выводится фактическое значение «1»
    D min short Текущее значение дисконтирующего коэффициента, используемого для расчета минимальной маржи для коротких позиций. Рассчитывается следующим образом:
    Поле заполняется только для клиентов типа «МД». При D min short = + [image] поле не заполняется, но при экспорте по ODBC и DDE выводится фактическое значение «1E50»
    ГО покупателя | Гарантийное обеспечение покупателя в денежном выражении. Отображается для срочных контрактов (фьючерсы и опционы)
    ГО продавца | Гарантийное обеспечение продавца в денежном выражении. Отображается для срочных контрактов (фьючерсы и опционы)

    * - параметры, выбранные по умолчанию

    ** - параметры, значения которых отображаются с точностью до 6 знаков после десятичного разделителя (при этом не учитываются незначащие нули справа)

    К таблице может быть применен Режим связанных окон.

    Значения дисконтов D long и D short определяют тип поведения инструмента при маржинальном кредитовании:
    Обозначение | Назначение | D long | D short
<пусто> | Немаржинальный инструмент | =1,0 | +
Д | Маржинальный инструмент, разрешенная только для покупки на заемные средства | <1,0 | +
К | Инструмент, разрешенный только для продажи на заемные средства | =1,0 | <+
ДК | Инструмент, разрешенный для покупки и продажи на заемные средства | <1,0 | <+

    Доступные функции

    Данные из таблицы доступны для экспорта через DDE-сервер.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Обновить таблицу» (или «F5») – обновить значения в таблице.
    • «Новая заявка» (или «F2», или двойное нажатие левой кнопки мыши) * – открыть окно ввода заявки.
    • «Новая Айсберг заявка» – открыть окно ввода новой Айсберг заявки.
    • «Новая стоп-заявка» – открыть окно ввода стоп-заявки.
    • «[<Класс>] <Наименование инструмента>» – открыть окно котировок по инструменту.
    • «Глобальный фильтр» - включить/отключить действие Фильтра по коду клиента/фамилии.

    (*)
    1. При вводе заявки из поля «Покупка» в окне ввода заявки наименование инструмента и класс берутся из выбранной строчки, в цену подставляется лучшая цена предложения, в количество – значение поля «Покупка».
    2. При вводе заявки из поля «Продажа» в окне ввода заявки наименование инструмента и класс берутся из выбранной строчки, в цену подставляется лучшая цена спроса, в количество – значение поля «Продажа».

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы
    • Вычисление значений в таблице


Настройка таблицы

  1. «Имя таблицы» недоступно для редактирования.
  2. «Фирма» – идентификатор фирмы в торговой системе.
  3. «Код клиента» – идентификатор клиента в системе QUIK.
  4. «Выбрать инструменты вручную» - признак настройки списка инструментов пользователем:
    • «Доступные инструменты» - список доступных классов инструментов для отображения в таблице;
    • «Выбранные инструменты» - набор инструментов, выбранных для отображения в таблице.

    Если флажок отключен, то набор инструментов формируется автоматически.

    1. «Если для инструмента обнаруживается режим торгов, где он является маржинальным, то в таблице «Купить/Продать» отображается только данный режим.
    2. Если такой режим не обнаруживается, то в таблице отображаются все режимы торгов, где присутствует данный инструмент.
  5. «Доступные параметры / Выбранные параметры» – выбор отображаемых параметров и настройка их очередности.
  6. «Показывать позиции с нулевыми остатками» – отображать в таблице строки с инструментами, позиции по которым равны нулю.
  7. «Параметры таблицы могут задаваться глобальным фильтром» – признак распространения на данную таблицу действия Фильтра по коду клиента/фамилии (см. Общие фильтры).
  8. «Позиции по инструментам в лотах» – при установленном флажке количество доступных инструментов отображается в лотах. Если флажок не установлен, то количество доступных инструментов отображается в штуках.
    Значение по умолчанию признака «Позиции по инструментам в лотах» определяется значением признака «Рассчитывать позиции в лотах» в программе QUIK Administrator (пункт меню Сервер QUIK / Библиотеки расчета лимитов..., раздел «Общие параметры», рамка «Общие настройки библиотеки, вкладка «Часть 3»).
  9. «Показывать информационные классы» – при установленном флажке в таблице отображаются инструменты по информационным классам.

Настройки и список инструментов сохраняются в файле настройки конфигурации и загружаются из него.

См. также Таблица «Купить/Продать».


Вычисление значений в таблице

  1. Вычисляется предполагаемая стоимость продажи 1 лота, исходя из лучшей цены предложения, умноженной на количество инструментов в лоте. Если значения лучшей цены предложения нет, то берется цена последней сделки, если ее тоже нет – то принимается значение цены закрытия предыдущего дня.
  2. Значение поля «Покупка» вычисляется на основе значений таблицы «Клиентский портфель».
    • для маржинальных инструментов (МО): «На покупку» / «Стоимость продажи лота»;
    • для немаржинальных инструментов (пусто или М): «НаПокупНеМарж» / «Стоимость продажи лота»;
    • для инструментов обеспечения (О): «НаПокупОбесп» / «Стоимость продажи лота».

    В стоимость обеспечения не включаются инструменты, у которых отсутствует (или равна «0») цена закрытия предыдущего торгового дня.

    Общая формула для вычисления значения поля «Покупка»:

    («Стоимость портфеля» + «ДостТекЛимит») / [1 + (1 – «Лонг (коэф)») * «Плечо»] / «Стоимость продажи лота»

  3. Вычисляется предполагаемая стоимость покупки 1 лота, исходя из лучшей цены спроса, умноженной на количество инструментов в лоте. Если значения лучшей цены спроса нет, то берется цена последней сделки, если ее тоже нет – то принимается значение цены закрытия предыдущего дня.
  4. Значение поля «Продажа» также вычисляется по данным «Клиентского портфеля».
    • для всех маржинальных инструментов (МО и М): «На продажу» / «Стоимость покупки лота» + «Тек.остаток по инструменту»;
    • для немаржинальных инструментов и входящих в обеспечение (О): «Тек.остаток по инструменту».

    В стоимость обеспечения не включаются инструменты, у которых отсутствует (или равна «0») цена закрытия предыдущего торгового дня.

    Общая формула для вычисления значения поля «Продажа»:

    «ДостТекЛимит» / [1 + («Шорт (коэф)» - 1) * «Плечо»] / «Стоимость продажи лота»

  5. При этом величина комиссий не учитывается.

См. также Таблица «Купить/Продать».


Сводная таблица позиций

меню Создать окно / Клиентский портфель... или кнопка [image],
пункт контекстного меню Открыть сводную таблицу позиций
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Единая таблица для контроля количества денежных средств и инструментов, доступных для совершения торговых операций на фондовом рынке. Таблица содержит информацию по какому-либо одному коду клиента.

    Формат таблицы

    В заголовке окна указаны коды клиента и торгового счета, например «2200 NC0080100000». Каждая строка соответствует позиции по отдельному инструменту. Денежная позиция имеет «Название инструмента», равное «SUR». Позиции и лимиты по одному и тому же инструменту, отраженные на разных счетах, могут суммироваться (определяется настройками).

    В столбцах таблицы отображаются следующие параметры:

    Значения остатков и позиций по инструментам выражены в лотах.

    Параметр | Значение
Название инструмента | Наименование инструмента в торговой системе. Для позиций по денежным средствам отображается код валюты расчетов, например SUR – рубли РФ, USD – доллары США
Код инструмента | Регистрационный код инструмента в торговой системе
Счет депо | Счет депо, на котором учитываются средства клиента. Для позиций по денежным средствам отображается код позиции, например EQTV – Фондовая биржа МБ. Если в строке объединены позиции по разным счетам депо, то поле имеет значение «Общий»
Срок расчётов | Срок расчётов. Значение «Tx» соответствует позиции клиента после совершения всех расчетов
* Входящий остаток | Сумма собственных средств клиента до совершения операций
* Входящий лимит | Разрешенная сумма заемных средств до совершения операций
* Текущий остаток | Сумма собственных средств клиента на текущий момент (с учетом исполненных сделок)
* Текущий лимит | Разрешенная сумма заемных средств на текущий момент (с учетом сделок)
* В продаже | Сумма средств, заблокированных под исполнение заявок клиента на продажу
* Всего | Сумма собственных и заемных средств «Всего» = «Текущий остаток» + «Текущий лимит»
* Доступно | Сумма средств, доступных для заявок на покупку «Доступно» = «Всего» - «Заблокировано»
* Баланс | Средства клиента после совершения сделок, за вычетом заемных средств «Баланс» = «Всего» - «Входящий лимит»
Цена приобретения | Средневзвешенная цена приобретения, рассчитанная по сделкам клиента

    * - значение отображается с точностью валюты цены инструмента

    К таблице может быть применен Режим связанных окон.

    Доступные функции

    Данные из таблицы доступны для вывода через DDE сервер.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Подключиться к каналу» – привязать окно к основной таблице (подробнее см. Режим связанных окон).
      • «<Название таблицы>» – привязка окна к данной таблице;
      • «Отключить» – отключение связанной таблицы от канала.
    • «Глобальный фильтр» - включить/отключить действие Фильтра по коду клиента/фамилии.
    • «Совокупная позиция» – включить/отключить объединение позиций на разных счетах по одинаковым инструментам.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Имя таблицы» – недоступно для редактирования.
  2. «Набор параметров» – выбор отображаемых параметров и настройка их очередности. По умолчанию выбраны все параметры.
  3. «Код клиента (фирмы) может задаваться глобальным фильтром» – признак распространения на данную таблицу действия Фильтра по коду клиента/фамилии.
  4. «Объединять позиции с одинаковым инструментом» – признак объединения позиций клиентов по инструментам с одинаковым кодом, отраженных на разных счетах депо. Для объединенных позиций поле «Счет депо» имеет значение «Общий».


Позиции по инструментам

меню Создать окно / Позиции по инструментам, кнопка
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Контроль количества инструментов, доступных для совершения торговых операций на фондовом рынке.

    Для операций на срочном рынке см. Позиции по клиентским счетам, Ограничения по клиентским счетам.

    Чтобы иметь возможность совершения торговых операций, пользователь должен иметь назначенный администратором лимит по инструментам (допускается нулевой).

    Из таблицы Клиентский портфель можно вызвать Сводную таблицу позиций, включающую позиции по инструментам и денежным средствам для определенного клиента.
    Если количество строк таблицы превышает пороговое значение, заданное в файле info.ini (без учёта глобальных фильтров), то при вызове пункта меню «Создать окно / Позиции по инструментам» открывается окно редактирования таблицы. Иначе – открывается таблица «Позиции по инструментам».

    По умолчанию пороговое значение равно «100000».

    Формат таблицы

    Каждая строка таблицы содержит информацию о позициях по отдельному коду клиента.

    Строки таблицы могут выделяться цветом в зависимости от настроек. По умолчанию используются следующие цветовые настройки:

    • Зеленый цвет – значение поля «Баланс» положительное;
    • Красный цвет – значение поля «Баланс» отрицательное.

    В столбцах таблицы отображаются следующие параметры:

    Значения остатков и лимитов в таблице «Позиции по инструментам» могут быть выражены как в штуках, так и в лотах, в зависимости от настроек сервера QUIK для конкретного участника торгов. За подробной информацией обратитесь к своему брокеру.

    Параметр | Значение
Фирма | Идентификатор участника торгов в торговой системе биржи
Полное название инструмента | Полное наименование инструмента в торговой системе
Название инструмента | Краткое наименование инструмента в торговой системе
Код инструмента | Регистрационный код инструмента в торговой системе
Счет депо | Счет депо, на котором учитываются средства клиента
Код клиента | Код клиента в системе QUIK, на которого установлен лимит
ISIN | ISIN-код инструмента
*, ** Входящий остаток | Собственные средства клиента до совершения операций (на начало торгов)
*, ** Входящий лимит | Заемные средства, доступные клиенту до совершения операций (на начало торгов)
*, ** Текущий остаток | Собственные средства клиента на текущий момент (с учетом совершенных операций)
*, ** Текущий лимит | Заемные средства, доступные клиенту на текущий момент (с учетом совершенных операций)
* В продаже | Количество инструментов, заблокированное под исполнение заявок клиента на продажу
* В покупке | Количество инструментов в активных заявках клиента на покупку
* Всего | Количество собственных и доступных для займа инструментов «Всего» = «Текущий остаток» + «Текущий лимит»
* Доступно | Количество инструментов, доступное для заявок на продажу «Доступно» = «Всего» - «В продаже»
Баланс | Количество инструментов после совершения сделок, за вычетом заемных средств «Баланс» = «Всего» - «Входящий лимит»
Цена приобретения | Средневзвешенная цена приобретения, рассчитанная по сделкам клиента
Срок расчётов | Срок расчётов. Значение «Tx» соответствует позиции клиента после совершения всех расчетов
Дата расчетов | Дата расчетов. Значение отображается только для фирм, где используется режим ведения позиций в календарных днях
Валюта цены приобретения | Валюта, в которой отображается значение цены приобретения инструмента. Для облигаций, цена которых выражена в процентах от номинала, отображается значение «%»
Наименование фирмы | Наименование фирмы трейдера

    * - значение отображается с точностью количества инструмента

    ** - подробнее о работе с лимитами клиентов см. в Операции брокера

    К таблице может быть применен Режим связанных окон.

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    • «Задать позиции по инструментам» - установить новое значение позиции.
    • «Удалить позиции по инструментам» – удалить выбранное значение позиции.
    • «Корректировать через файл» - настроить механизм динамической корректировки позиций клиентов внешней программой.
    • «Новая заявка» - открыть окно ввода новой заявки по инструменту, по которому задана позиция в выбранной строке таблицы. Если данный инструмент присутствует в нескольких классах, то его нужно выбрать из подменю со списком классов. Если инструмент входит только в один класс, то подменю не отображается. При этом в поля заявки автоматически подставляются данные из выбранной строки таблицы, соответствующие закрытию позиции по данному инструменту: если «Текущий остаток» положителен, то выбирается направление операции «Продажа», если отрицателен, то выбирается «Покупка».
    Для возможности ввода заявок по режимам РПС и РЕПО из контекстного меню таблицы «Позиции по инструментам» включите флажок «Возможность ставить заявки на РПС и РЕПО режимах из таблицы позиций по инструментам» в настройках программы (меню Система/Настройки/Основные настройки…, раздел «Торговля»).
    • «Новая стоп-заявка» - открыть окно ввода новой условной заявки по инструменту.
    • «Новая OMS-заявка» - открыть окно ввода новой OMS-заявки по инструменту. Описание приведено в Руководстве пользователя «Модуль OMS Manager».
    • «Котировки» - открыть Таблицу котировок по выбранному инструменту.
    • «Подключиться к каналу» – привязать окно к основной таблице (подробнее см. Режим связанных окон).
      • «<Название таблицы>» – привязка окна к данной таблице;
      • «Отключить» – отключение связанной таблицы от канала.
    • «SMS-оповещение по бумажным позициям» (или «Ctrl»+«Alt»+«S») - настроить отправку SMS-уведомлений о текущем значении позиции по инструменту в установленный момент времени.
    • «Сохранить в файл позиции из таблицы» - записать позиции из таблицы в текстовый файл (с учетом настроек и фильтров).
    • «Сохранить все позиции в таблицу» - записать в текстовый файл все позиции.
    • «Загрузить позиции из файла» - загрузить позиции из текстового файла.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.
    • Описание функций администратора по управлению позициями и лимитами.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности. По умолчанию выбраны все параметры.
  2. «Фильтр фирм» * – настройка фильтрации по кодам фирм.
  3. «Фильтр счетов депо» * – настройка фильтрации по счетам депо.
  4. «Фильтр инструментов» * – настройка фильтрации по кодам инструментов.
  5. «Фильтр клиентов» * – настройка фильтрации по кодам клиентов.
    (*) Фильтры предназначены в основном для нужд администраторов брокера, контролирующих большое количество счетов клиентов.
  6. «Показывать нулевые позиции» – признак отображения в таблице нулевых позиций(например, чтобы посмотреть, назначено ли ограничение данному пользователю). Если флажок снят, то в таблице не отображаются строки, содержащие нулевые позиции. Если по результатам сделок позиция становится отличной от нуля, она появляется в таблице.
  7. «Выделять строки цветом, если» – настройка выделения строк таблицы цветом, в зависимости от значения (положительное, отрицательное, нулевое) выбранного числового поля. О работе с настройками цвета читайте Настройка цветов в таблицах и графиках.


Изменение лимитов в зависимости от операций клиентов

Операция | Поле «Всего» | Поле «Заблокировано»
Ввод заявки на покупку | Не меняется | Не меняется
Ввод заявки на продажу | Не меняется | + объем заявки
Исполнение заявки на покупку | + исполненный объем заявки | Не меняется
Исполнение заявки на продажу | - исполненный объем заявки | - исполненный объем заявки
Снятие заявки на покупку | Не меняется | Не меняется
Снятие заявки на продажу | Не меняется | - остаток объема отозванной заявки

Значения параметров «Входящий остаток» и «Входящий лимит» не изменяются при вводе заявок и совершении сделок.

Когда значение параметра «В продаже» превышает параметр «Всего», равный сумме параметров «Текущий остаток» и «Текущий лимит», система выдает сообщение о том, что лимит превышен и блокирует возможность совершения сделок.


Позиции по деньгам

меню Создать окно / Позиции по деньгам, кнопка
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Контроль количества денежных средств, доступных для совершения торговых операций на фондовом рынке. Для операций на срочном рынке см. Позиции по клиентским счетам, Ограничения по клиентским счетам.

    Чтобы иметь возможность совершения торговых операций, пользователь должен иметь назначенный администратором лимит по инструментам (допускается нулевой).

    Из таблицы «Клиентский портфель» можно вызвать Сводную таблицу позиций, включающую позиции по инструментам и денежным средствам для определенного клиента.
    Если количество строк таблицы превышает пороговое значение, заданное в файле info.ini (без учёта глобальных фильтров), то при вызове пункта меню «Создать окно / Позиции по деньгам» открывается окно редактирования таблицы. Иначе – открывается таблица «Позиции по деньгам».

    По умолчанию пороговое значение равно «100000».

    Формат таблицы

    Каждая строка таблицы содержит информацию о позициях по отдельному коду клиента.

    Строки таблицы могут выделяться цветом в зависимости от настроек. По умолчанию используются следующие цветовые настройки:

    • Зеленый цвет – значение поля «Баланс» положительное;
    • Красный цвет – значение поля «Баланс» отрицательное.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
Фирма | Идентификатор участника торгов в торговой системе биржи
Валюта | Код валюты расчетов, например SUR – рубли РФ, USD – доллары США
Код позиции | Символьный идентификатор, присваиваемый совокупной денежной позиции брокера для работы с торговой площадкой или классом инструментов, например EQTV – Фондовая биржа МБ
Код клиента | Код клиента в системе QUIK, для которого установлено ограничение
* , **Входящий остаток | Собственные средства клиента до совершения операций (на начало торгов)
* , **Входящий лимит | Заемные средства, доступные клиенту до совершения операций (на начало торгов)
* , **Текущий остаток | Собственные средства клиента на текущий момент (с учетом совершенных операций)
* , **Текущий лимит | Заемные средства, доступные клиенту на текущий момент (с учетом совершенных операций)
*Заблокировано | Сумма средств, заблокированных под исполнение заявок клиента на продажу
*Всего | Сумма собственных и заемных средств «Всего» = «Текущий остаток» + «Текущий лимит»
*Доступно | Сумма средств, доступных для совершения операций «Доступно» = «Всего» - «Заблокировано»
*Баланс | Средства клиента после совершения сделок за вычетом заемных средств «Баланс» = «Всего» - «Входящий лимит»
Плечо | Значение плеча, заданное при загрузке лимитов по денежным средствам
Срок расчётов | Срок расчётов. Значение «Tx» соответствует позиции клиента после совершения всех расчетов. Значение не заполняется при использовании режима ведения позиций в календарных днях
Дата расчетов | Дата расчетов. Значение отображается только для фирм, где используется режим ведения позиций в календарных днях
Наименование фирмы | Наименование фирмы трейдера

    * - значение отображается с точностью валюты цены инструмента

    ** - подробнее о работе с лимитами клиентов см. в Операции брокера

    К таблице может быть применен Режим связанных окон.

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Задать позицию по денежным средствам» - установить новое значение позиции.
    • «Установить остаток и плечо» – установить значение Входящего остатка по денежным средствам и Плеча для выбранного клиента.
    • «Удалить позицию по денежным средствам» – удалить выбранное значение позиции.
    • «Корректировать через файл» - настроить динамическую загрузку коррекций позиций из файла.
    • «Новая заявка» (или «F2») – открыть форму выбора инструмента с последующим открытием формы ввода новой заявки по данному инструменту.
    • «Подключиться к каналу» – привязать окно к основной таблице (подробнее см. Режим связанных окон).
      • «<Название таблицы>» – привязка окна к данной таблице;
      • «Отключить» – отключение связанной таблицы от канала.
    • «SMS-оповещение по денежным позициям» (или «Ctrl»+«Alt»+«S») – настроить отправку SMS-уведомлений о текущем значении денежной позиции в установленный момент времени.
    • «Сохранить в файл позиции из таблицы» - записать позиции из таблицы в текстовый файл (с учетом настроек и фильтров).
    • «Сохранить все позиции в файл» - записать в текстовый файл все позиции.
    • «Загрузить позиции из файла» - загрузить позиции из текстового файла.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.
    • Описание функций администратора по управлению позициями и лимитами.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности. По умолчанию выбраны все параметры.
  2. «Фильтр фирм» * – настройка фильтрации по кодам фирм.
  3. «Фильтр кодов позиций» * – настройка фильтрации по кодам позиции.
  4. «Фильтр валют» * – настройка фильтрации по кодам валют.
  5. «Фильтр клиентов» * – настройка фильтрации по кодам клиентов.
    (*) Фильтры предназначены в основном для нужд администраторов брокера, контролирующих большое количество счетов клиентов.
  6. «Показывать нулевые позиции» – признак отображения в таблице всех позиций, включая нулевые (например, чтобы посмотреть, назначено ли ограничение данному пользователю). Если флажок снят, то в таблице не отображаются строки, содержащие нулевые позиции. Если по результатам сделок позиция становится отличной от нуля, она появляется в таблице.
  7. «Выделять строки цветом, если» – настройка выделения строк таблицы цветом, в зависимости от значения (положительное, отрицательное, нулевое) выбранного числового поля. О работе с настройками цвета читайте Настройка цветов в таблицах и графиках.


Изменение лимитов в зависимости от операций клиентов

Операция | Поле «Всего» | Поле «Заблокировано»
Ввод заявки на покупку | Не меняется | + объем заявки + комиссия
Ввод заявки на продажу | Не меняется | Не меняется
Исполнение заявки на покупку | - (исполненный объем заявки + комиссия) | - (исполненный объем заявки + комиссия)
Исполнение заявки на продажу | + исполненный объем заявки - комиссия | Не меняется
Снятие заявки на покупку | Не меняется | - (остаток объема отозванной заявки + комиссия)
Снятие заявки на продажу | Не меняется | Не меняется

Значения параметров «Входящий остаток» и «Входящий лимит» не изменяются при вводе заявок и совершении сделок.

Когда значение параметра «Заблокировано» превышает параметр «Всего», равный сумме параметров «Текущий остаток» и «Текущий лимит», система выдает сообщение о том, что лимит превышен, и блокирует возможность совершения сделок.


Таблица «Торговые счета»

меню Создать окно / Торговые счета…
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр информации по доступным пользователю торговым счетам.

    Формат таблицы

    В строках таблицы перечислены доступные пользователю торговые счета.

    В столбцах таблицы отображаются параметры счетов:

    Параметр | Значение
    Фирма | Идентификатор участника торгов в торговой системе
    Счет | Торговый счет
    Основной счет

    Основной торговый счет

    Счет депо | Счет депо в депозитарии
    Код позиции | Код дополнительной позиции по денежным средствам
    Описание | Описание позиции
    Тип торг. счета Тип торгового счета. Возможные значения:
    • «Не определен»;
    • «Спец. Счет для перевода (ден. средства)»;
    • «Основной счет (кред. орг.)»;
    • «Клиентский счет»;
    • «Корр. Клиентский счет»;
    • «Основной счет (некред. орг.)»;
    • «Счет ДУ (некред. орг.)»;
    • «Счет ДУ (кред. орг.)»;
    • «Технологический счет»;
    • «Колл. клир. обеспеч.»;
    • «Обеспеч. под стресс»;
    • «Расчетный код»;
    • «Клиенты 2-го и 3-го уровней»;
    • «Основной, депозиты»;
    • «Технический счет ЕП»;
    • «Комиссионный, депозиты»;
    • «Эмиссионный счет, собств.»;
    • «Эмиссионный счет, кл.»;
    • «Обеспечение, риски концентр.»;
    • «Казначейский счет, собств.»;
    • «Казначейский счет, кл.»;
    • «Клиент, депозиты»;
    • «ДУ, депозиты»;
    • «Обеспечение, налоги РФ»
    Тип счета депо Тип депозитарного счета. Возможные значения:
    • «Не определен»;
    • «Счет владельца»;
    • «Корреспондентский счет»;
    • «Счет ДУ»;
    • «Эмиссионный счет»;
    • «Клиентский счет»;
    • «Счет по умолчанию для валютного рынка»;
    • «Клиринговый»
    Статус Статус торгового счета. Возможные значения:
    • «Операции запрещены»;
    • «Операции разрешены»
    Тип раздела Тип раздела. Возможные значения:
    • «Раздел обеспечения»;
    • «Торговый раздел»;
    • « » (пусто) – не указан
    Запрет необеспеч-х продаж Признак запрета необеспеченных продаж. Возможные значения:
    • «Да»;
    • «Нет»;
    • « » (пусто) – не указан
    Расч-я орг-я по Т0 | Идентификатор расчетной организации по расчетам «Т0»
    Расч-я орг-я по Т+ | Идентификатор расчетной организации по расчетам «Т+»
    Раздел счета Депо | Раздел счета Депо
    Рынок депозитов Рынок депозитов. Возможные значения:
    • «Да»;
    • «Нет»

    К таблице может быть применен Режим связанных окон.

    Доступные функции

    Данные таблицы доступны для копирования, вывода через DDE сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    • «Открыть канал» / «Закрыть канал» – включить / выключить режим связанных окон в данной основной таблице.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.
  2. «Фильтр счетов» – настройка фильтрации по счетам клиентов.
  3. «Фильтр фирм» – настройка фильтрации по кодам фирм.
  4. «Статус» – настройка фильтрации по статусу торгового счета:
    • «Операции разрешены»;
    • «Операции запрещены»;
    • «Заблокировано для торгов».


Ограничения по клиентским счетам

меню Создать окно / Ограничения по клиентским счетам...
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр информации о текущей стоимости открытых позиций клиента по всем инструментам. Таблица по назначению равносильна таблице Позиции по деньгам при операциях на фондовом рынке.

    Формат таблицы

    Каждая строка таблицы соответствует отдельному торговому счету.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Фирма | Идентификатор фирмы брокера в системе QUIK
    Торговый счет | Внутренний составной параметр сервера QUIK, содержащий обозначение торговой площадки, например – SPBFUT00, и идентификатор клиента на бирже, например - 001
    Тип лимита Тип лимита для срочного рынка Московской Биржи:
    • «Ден.средства» - стоимость денежных средств в обеспечении;
    • «Залоговые средства в иностранной валюте» – стоимость залоговых средств в иностранной валюте;
    • «Суммарные залоговые средства в иностранной валюте (в рублях)» – суммарная стоимость залоговых средств в рублях, сконвертированных по курсу, по всем валютным залогам;
    • «Клиринговые ден.средства» - зафиксированные торговой системой срочного рынка Московской Биржи параметры последнего основного клиринга;
    • «Прогнозируемое состояние средств» - прогнозируемое состояние свободных средств после изменения максимального/минимального ценового лимита (планки) по инструментам на срочном рынке Московской Биржи
    Коэф. ликвидн. | Коэффициент, определяющий какая часть средств блокируется из залогового, а какая из собственного денежного лимита. Коэффициент представляет собой число от 0 до 1. Например, если коэффициент равен 0.7, то заблокируется 70% в собственном денежном лимите и 30% - в залоговом. Параметр относится к срочному рынку Московской Биржи
    Предыд. лимит откр. поз. | Сумма денежных остатков на начало предыдущей торговой сессии (не транслируется для счета единой денежной позиции)
    Лимит откр. поз. | Сумма денежных остатков на начало текущей торговой сессии (не транслируется для счета единой денежной позиции)
    Тек. чист. поз. | Средства, заблокированные под открытые позиции, активные заявки и отрицательную вариационную маржу (для счета единой денежной позиции заполняется либо остается пустым в зависимости от настроек, заданных брокером)
    Тек.чист.поз. (под заявки) | Средства, заблокированные под активные заявки, в денежном выражении (транслируется только для счета единой денежной позиции, заполняется либо остается пустым в зависимости от настроек, заданных брокером)
    Тек.чист.поз. (под открытые позиции) | Средства, заблокированные под открытые позиции и активные заявки, в денежном выражении (для счета единой денежной позиции - средства, заблокированные под открытые позиции, заполняется либо остается пустым в зависимости от настроек, заданных брокером)
    План. чист. поз. Прогнозируемые свободные денежные средства после исполнения всех активных заявок. Свободные средства:
    «План. Чист. Поз» = «Лимит откр. поз.» - «Тек. Чист. Поз»
    Вариац. маржа | Суммарная вариационная маржа по всем инструментам (прибыль/убыток, образовавшийся с момента последнего клиринга, зачисляется/списывается со счета во время следующего клиринга)
    Накоплен. доход | Величина вариационной маржи, зафиксированной по итогам промежуточного (дневного) клиринга либо при закрытии позиции
    Премия по опционам | Премия по опционным позициям, рассчитанная по правилам торговой системы. Для типов лимита «Клиринговые Ден.средства» соответствует параметру «Биржевые сборы» срочного рынка Московской Биржи. При использовании единой денежной позиции после вечернего клиринга транслируется суммарная вариационная маржа дневной сессии
    Биржевые сборы Сумма, взимаемая биржевым комитетом за проведение биржевых сделок. Параметр срочного рынка Московской Биржи. Значение равно:
    • «Снятые биржевые сборы по фьючерсам и опционам после образования позиций (loss)» - для типа лимита «Ден.средства»;
    • «Фьючерсный биржевой сбор + Опционный биржевой сбор» - для типа лимита «Клиринговые ден.средства»
    Коэфф-нт кл-го ГО | Коэффициент клиентского гарантийного обеспечения (влияет на размер зарезервированного ГО, задается брокером)
    Валюта позиции | Валюта, в которой транслируется ограничение
    Реальная в.маржа | Не используется, транслируется «0»

    К таблице может быть применен Режим связанных окон.

    Доступные функции

    Данные из таблицы доступны для копирования в буфер обмена, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    • «Задать лимит» (или «F2», или двойное нажатие левой кнопки мыши на строке) – создать новый лимит.
    • «Удалить лимит» (или «Ctrl»+«D») – удалить выделенный лимит клиента.
    • «Подключиться к каналу» – привязать окно к основной таблице (подробнее см. Режим связанных окон).
      • «<Название таблицы>» – привязка окна к данной таблице;
      • «Отключить» – отключение связанной таблицы от канала.
    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.
    • «SMS-оповещение по фьючерсным ограничениям» (или «Ctrl»+«Alt»+«S») – настроить отправку SMS-уведомления о значении выбранного ограничения в установленный момент времени.
    • «Загрузить лимиты по срочному рынку» – загрузить лимиты из файла.
    • «Сохранить лимиты по срочному рынку» – сохранить лимиты в файл.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.
    • О функциях администратора по управлению лимитами на срочном рынке читайте Операции над лимитами клиентов на срочном рынке.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Доступные параметры / Выбранные параметры» – выбор отображаемых параметров и настройка их очередности.
  2. «Показывать ограничения по» – настройка фильтрации по значению параметра «Тип лимита»:
    • «денежным средствам» (по умолчанию);
    • «прогнозируемому состоянию средств»;
    • «клиринговым денежным средствам»;
    • «залоговым денежным средствам в иностранной валюте»;
    • «суммарным залоговым денежным средствам в иностранной валюте (в рублях)».
  3. «Выделять строки цветом, если» – настройка выделения строк таблицы цветом, в зависимости от значения (положительное, отрицательное, нулевое) выбранного числового поля. О работе с настройками цветов см. Настройка цветов в таблицах и графиках.
  4. «Фильтр фирм» – настройка фильтрации по кодам фирм.

    С помощью фильтра можно выделить позиции клиентов только данного брокера (субброкера), либо разделить по разным таблицам операции на разных торговых площадках.

  5. «Фильтр счетов» – настройка фильтрации по торговым счетам клиентов.

См. также Ограничения по клиентским счетам.


Позиции по клиентским счетам

меню Создать окно / Позиции по клиентским счетам
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр информации о текущем состоянии и изменении параметров клиентских счетов по инструментам срочного рынка. Таблица по назначению равносильна Таблице Позиции по инструментам при операциях на фондовом рынке.

    В одной таблице могут отображаться позиции клиентов на разных рынках.

    Формат таблицы

    Каждая строка таблицы отображает наличие открытых позиций по определенному контракту на счете клиента.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
Фирма | Идентификатор фирмы брокера в системе QUIK
Торговый счет | Внутренний составной параметр сервера QUIK, содержащий обозначение торговой площадки, например - SPBFUT00, и идентификатор клиента на бирже, например - 001
Код инструмента | Идентификатор инструмента в торговой системе
Краткое название | Наименование инструмента в торговой системе, совпадает с кодом инструмента
Дата погашения | Дата погашения контракта
Тип | Тип группировки торговых счетов. Для счета клиента – значение <пусто>
Вход. длин. поз. | Количество контрактов в открытых длинных (на покупку) позициях до совершения сделок в текущей сессии
Вход. кор. поз. | Количество контрактов в открытых коротких (на продажу) позициях до совершения сделок в текущей сессии
Вход. чист. поз. | Общее количество контрактов в открытых позициях на начало торгов. «Чистые позиции на начало торгов» = «Длинные позиции на начало торгов» - «Короткие позиции на начало торгов»
Тек. длин. поз. | Количество контрактов, купленных в текущей торговой сессии
Тек. кор. поз. | Количество контрактов, проданных в текущей торговой сессии
Тек. чист. поз. | Общее количество контрактов в открытых позициях на текущий момент, с учетом сделок «Текущие чистые позиции» = «Входящие чистые позиции» + «Текущие открытые длинные позиции» - «Текущие открытые короткие позиции»
Акт. покупка | Количество контрактов в активных заявках на покупку
Акт. продажа | Количество контрактов в активных заявках на продажу
Оценка тек. чист. поз. | Стоимостная оценка текущих чистых позиций
* План. чист. поз. | Стоимостная оценка планируемых (с учетом исполнения заявок) чистых позиций. Для рынка RTS Standard отображается значение «Лимит открытых позиций по спотам базового актива»
* Вариац. Маржа | Прибыль/убыток, образовавшийся с момента последнего клиринга, зачисляется на счет при следующем клиринге (рассчитывается и транслируется торговой системой)
* Эффект. цена поз. | Цена, при закрытии позиции по которой вариационная маржа равна нулю (средневзвешенное значение оценки позиции с учетом входящей позиции по цене последнего клиринга и ценам сделок после него)
* Стоимость позиций | Значение вариационной маржи, зафиксированной (зачисленной/списанной со счета) по итогам промежуточного (дневного) клиринга
Суммарная в.маржа | Значение вариационной маржи, зафиксированной (зачисленной/списанной со счета) по итогам основного (вечернего) клиринга
Реальная в.маржа | Вариационная маржа, зачисленная/списанная со счета в случае, если рыночная котировка находится за пределами коридора цен (минимального/максимального значения цены, установленных биржей)

    * - параметр доступен только в торговой системе Секции срочного рынка Московской Биржи (стандартные контракты)

    К таблице может быть применен Режим связанных окон.

    Доступные функции

    Данные из таблицы доступны для копирования вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    • «Установить позицию» (или двойное нажатие левой кнопки мыши на строке) – задать лимит открытых позиций по данному инструменту. Доступно для контрактов срочного рынка (изменение значения «Входящей чистой позиции» по данному инструменту).
    • «Подключиться к каналу» – привязать окно к основной таблице (подробнее см. Режим связанных окон).
      • «<Название таблицы>» – привязка окна к данной таблице;
      • «Отключить» – отключение связанной таблицы от канала.
    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.
    • «[<Класс>] <Наименование инструмента>» – открыть Таблицу котировок.
    • «Новая заявка» (или «F2») – открыть форму ввода новой заявки.
    • «Досрочное исполнение» – инициировать экспирацию опциона.
    • «SMS-оповещение по фьючерсным позициям» (или «Ctrl»+«Alt»+«S») – настроить отправку SMS-уведомления о значении выбранной позиции в установленный момент времени.
    • «Загрузить лимиты по срочному рынку» – загрузить лимиты из файла.
    • «Сохранить лимиты по срочному рынку» – сохранить лимиты в файл.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.
    • О функциях администратора по управлению лимитами на срочном рынке см. Операции над лимитами клиентов на срочном рынке.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Выбор параметров» – выбор отображаемых параметров и настройка их очередности.
  2. «Фильтр фирм» – настройка фильтрации по кодам фирм.

    С помощью данного фильтра можно выделить позиции клиентов только данного брокера (субброкера), либо разделить по разным таблицам операции на разных торговых площадках.

  3. «Фильтр инструментов» – настройка фильтрации по инструментам.
  4. «Фильтр счетов» – настройка фильтрации по торговым счетам.
  5. «Выделять строки цветом если» – настройка выделения строк таблицы цветом, в зависимости от значения (положительное, отрицательное, нулевое) выбранного числового поля. О работе с настройками цветов см. Настройка цветов в таблицах и графиках.

См. также Позиции по клиентским счетам.


Таблица «Доска опционов»

меню Создать окно / Доска опционов...
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Отображение в удобной форме спроса и предложения по разным опционным контрактам на один и тот же базовый актив. Позволяет оперативно отслеживать возможность создания сложной опционной позиции, состоящей из определенного набора опционов различных типов и страйков.

    Формат таблицы

    В заголовке таблицы указывается базовый актив, дата экспирации опциона и класс. Каждая строка таблицы соответствует отдельному виду опционного контракта. Строки содержат информацию о лучших контрактах PUT и СALL на общий базовый актив и отсортированы по возрастанию величины страйка.

    В верхней части таблицы расположена панель инструментов для настройки таблицы.

    Центральный страйк (страйк, отличающийся от текущей цены базового актива на минимальную величину) по умолчанию выделяется изменением шрифта и цветом фона всей строки (жёлтый). Строка таблицы, соответствующая центральному страйку, настраивается пользователем .

    К таблице может быть применен Режим связанных окон. Смена инструмента при включенном режиме связанных окон производится, если выбранный в таблице «Текущие торги» инструмент входит в список базовых активов опционов.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
Код CALL | Наименование опциона CALL
Ро CALL | Значение коэффициента «ро» CALL, измеряется в пунктах
Вега CALL | Значение коэффициента «вега» CALL, измеряется в пунктах
Тэта CALL | Значение коэффициента «тэта» CALL, измеряется в пунктах
Гамма (%) CALL | Значение коэффициента «гамма» CALL, в %
Дельта CALL | Значение коэффициента «дельта» CALL
* Спрос CALL | Лучшая покупка для опциона CALL
* Предложение CALL | Лучшая продажа для опциона CALL
Цена посл. сделки CALL | Цена последней сделки по опциону CALL
Открытых позиций CALL | Количество открытых позиций по опциону CALL
Сделок за сегодня CALL | Количество совершенных сделок за текущую сессию по опциону CALL
Задан. волатильность CALL | Значение волатильности по опциону CALL, заданное пользователем
* Теор.цена CALL | Значение расчетной премии по опциону CALL, транслируемое из торговой системы
* Расч. премия CALL | Расчетная премия для опциона CALL, вычисляемая по заданной волатильности, в копейках
Внутр. ст-ть CALL | Поле рассчитывается: «Внутр. ст-ть CALL» = «Цена баз. актива» – «Страйк»
Врем. ст-ть CALL | Поле рассчитывается: «Врем. ст-ть CALL» = «Теор.цена CALL» – «Внутр. ст-ть CALL»
Позиция CALL | Собственная позиция по контракту CALL – сумма позиций по данному контракту по торговым счетам, доступным пользователю (по умолчанию суммируются позиции по всем торговым счетам)
Безриск. ставка CALL | Безрисковая ставка по контракту CALL, значение отображается в процентах
* Страйк | Страйк опционов, в единицах измерения цены контракта
Дата исполнения | Дата исполнения контракта
До исполнения | Количество дней до исполнения контракта
Волатильность | Значение волатильности, транслируемое из торговой системы
Цена баз. актива | Цена последней сделки по базовому активу
Позиция PUT | Собственная позиция по контракту PUT – сумма позиций по данному контракту по торговым счетам, доступным пользователю (по умолчанию суммируются позиции по всем торговым счетам)
Врем. ст-ть PUT | Поле рассчитывается: «Врем. ст-ть PUT» = «Теор.цена PUT» – «Внутр.ст-ть PUT»
Внутр. ст-ть PUT | Поле рассчитывается: «Внутр. ст-ть PUT» = «Страйк» – «Цена баз. актива»
* Расч. премия PUT | Расчетная премия для опциона PUT, вычисляемая по заданной волатильности, в копейках
* Теор.цена PUT | Значение расчетной премии по опциону PUT, транслируемое из торговой системы
Задан. волатильность PUT | Значение волатильности по опциону PUT, заданное пользователем
Сделок за сегодня PUT | Количество совершенных сделок за текущую сессию по опциону PUT
Открытых позиций PUT | Количество открытых позиций по опциону PUT
Цена посл. сделки PUT | Цена последней сделки по опциону PUT
* Предложение PUT | Лучшая продажа для опциона PUT
* Спрос PUT | Лучшая покупка для опциона PUT
Дельта PUT | Значение коэффициента «дельта» PUT
Гамма (%) PUT | Значение коэффициента «гамма» PUT, в %
Тэта PUT | Значение коэффициента «тэта» PUT, измеряется в пунктах
Вега PUT | Значение коэффициента «вега» PUT, измеряется в пунктах
Ро PUT | Значение коэффициента «ро» PUT, измеряется в пунктах
Код PUT | Наименование опциона PUT
Безриск. ставка PUT | Безрисковая ставка по контракту PUT, значение отображается в процентах

    * - параметры, выбранные по умолчанию.

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    • «<Наименование опциона> <Тип опциона> [<Класс>]»( или двойное нажатие левой кнопки мыши) – открыть Таблицу котировок по выбранному опционному контракту,
    • «Графики цены и объема» (или двойное нажатие правой кнопки мыши) – открыть график цены и объема.
    • «График [<Параметр Доски опционов>]» – открыть график по параметру. График строится по тому параметру, из ячейки которого вызвано контекстное меню. Доступно только для числовых параметров.
    • «Оповещение на величину (ЦЕНА/ПРЕМИЯ)» (или «Ctrl»+«Alt»+«A») – назначить оповещение на соотношение цены опциона и расчетной премии.
    • «Установить параметры опционов» – открыть окно расчета премии для опционов. Недоступно, если в настройках таблицы включен флажок «Автоматически брать заданную волатильность из системы».
    • «Подключиться к каналу» – привязать окно к основной таблице (подробнее см. Режим связанных окон).
      • «<Название таблицы>» – привязка окна к данной таблице;
      • «Отключить» – отключение связанной таблицы от канала.
    • «Показывать панель инструментов» – включить отображение панели инструментов в таблице.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Настройка таблицы.


Настройка таблицы

  • Цветовые настройки Доски опционов
  • Панель инструментов таблицы

    1. «Имя таблицы» – позволяет изменить редактируемую часть наименования таблицы.
    2. «Класс» – выбор наименования класса типа «Опционы».
    3. «Базовый актив» – выбор базового актива. В списке отображаются активные инструменты классов типа «Опционы», кроме классов режима переговорных сделок.
    4. «Дата экспирации» – список дат исполнения контрактов по выбранному базовому активу.
    5. «Количество страйков» – выбор количества строк в таблице, включая центральный страйк. Значение можно установить вручную.
    6. «Шаг страйка» – значение кратности страйка, в соответствии с которым фильтруются записи для отображения в таблице.
    7. «Сортировать страйки по убыванию» – при включенном флажке строки в таблице сортируются по убыванию страйков. Если флажок отключен, то строки в таблице сортируются по возрастанию страйков. По умолчанию флажок отключен.
    8. «Все страйки со своими позициями» – при включенном флажке дополнительно к выбранному количеству строк, отфильтрованных по значению, указанному в поле «Шаг страйка», отображаются строки, не входящие в указанный диапазон, но имеющие контракты с ненулевыми собственными позициями. Флажок недоступен, если в поле «Количество страйков» выбрано значение «Все».
    9. «Центральный страйк виден всегда» – при включенном флажке независимо от размера окна строки располагаются таким образом, чтобы центральный страйк был виден.
    10. «Автоматически брать заданную волатильность из системы» – при включенном флажке используется значение волатильности из торговой системы.
    11. «Фильтр фирм» – если флажок отключен, то при расчете собственных позиций по контракту суммируются позиции по всем кодам фирм, доступным пользователю. При включенном флажке используются коды фирм с учетом настроенного фильтра.
    12. «Фильтр счетов» – если флажок отключен, то при расчете собственных позиций по контракту суммируются позиции по всем торговым счетам, доступным пользователю. При включенном флажке используются счета с учетом настроенного фильтра.
    13. «Цветовые настройки» – настройка выделения цветом строк таблицы, раздельно для опционов PUT, CALL и страйков.
    14. «Доступные параметры / Выбранные параметры» – выбор отображаемых параметров и настройка их очередности.
    15. «Сортировать по алфавиту» – упорядочить список доступных параметров для заголовков столбцов в алфавитном порядке.
    16. «Тип опциона в конце заголовка» - показывать тип опциона в конце заголовка, например, «Предложение CALL» вместо «CALL Предложение». По умолчанию флажок включен.

    Цветовые настройки Доски опционов

    1. «Выделять значение цветом» – при включенном флажке строки таблицы выделяются, в соответствии с настройками, цветом фона и шрифта, раздельно для опционов PUT, CALL и страйков.
    2. «Выделять центральный страйк» – при включенном флажке строка центрального страйка выделяется в соответствии с настройками:
      • «Текст» – цвет шрифта;
      • «Фон» – цвет фона строки;
      • «Шрифт» – выбор используемого шрифта, размера шрифта, отображения шрифта (жирный/курсив).

    Подробнее о настройке цветов см. Настройка цвета в таблицах и графиках.

    Панель инструментов таблицы

    Отображение панели инструментов регулируется выбором в таблице пункта контекстного меню «Показывать панель инструментов».

    На панели инструментов доступны следующие настройки:

    1. Список базовых активов. Позволяет выбрать один актив из списка. Список заполнен при наличии инструментов.
    2. Список дат экспирации. Позволяет выбрать одну дату экспирации. Если инструмент не выбран, то поле пустое. Список обновляется при изменении инструмента.
    3. «Страйков» – выбор количества строк в таблице, включая центральный страйк.
    4. Поле «Посл.» – цена последней сделки по базовому активу. Если данных нет, то поле пустое.Недоступно для редактирования.
    5. Поле «Спрос» – лучшая цена спроса. Если данных нет, то поле пустое. Недоступно для редактирования.
    6. Поле «Предл.» – лучшая цена предложения. Если данных нет, то поле пустое. Недоступно для редактирования.

    См. также Таблица «Доска опционов».


Таблица заявок на внебиржевые сделки

меню Создать окно / Внебиржевые заявки

  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр состояния полученных и отправленных адресных заявок, поданных с начала торговой сессии, а также внебиржевых сделок, введенных с терминала вручную.

    Формат таблицы

    Каждая строка таблицы соответствует отдельной заявке (сделке).

    В столбцах таблицы отображаются следующие параметры заявок (сделок):

    Параметр | Значение
    Номер | Регистрационный номер заявки в торговой системе
    *** Дата | Дата регистрации заявки в торговой системе
    *** Выставлена(время) | Время регистрации заявки в торговой системе. Формат определяется настройками операционной системы
    *** Снята(время) | Время отзыва заявки из торговой системы (для заявок со статусом «Снята»). Формат определяется настройками операционной системы
    Инструмент сокр. | Сокращенное наименование инструмента
    Инструмент | Наименование инструмента
    Код инструмента | Код инструмента в торговой системе
    Класс | Наименование класса инструментов
    Код класса | Код класса в торговой системе
    Операция | Направление операции – «Купля» либо «Продажа»
    Счет | Счет депо участника торгов, в отношении которого осуществляется заявка
    Цена | Цена заявки, за единицу инструмента
    Количество | Количество инструментов в заявке с точностью количества инструмента или в лотах
    Остаток | Объем неисполненной части заявки с точностью количества инструмента или в лотах
    Трейдер | Идентификатор трейдера фирмы-участника торгов, отправившего заявку
    Дилер | Идентификатор участника торгов, отправившего заявку
    Орг-я трейдера | Наименование участника торгов, отправившего заявку
    UID | Код пользователя на сервере QUIK
    Трейдер партнера | Идентификатор трейдера фирмы, которому адресована заявка. Поле обычно не используется и пустое
    Партнер | Идентификатор участника торгов, которому адресована заявка
    Орг-я партнера | Наименование участника торгов, которому адресована заявка. Поле заполняется только для клиентов с правами на совершение активных операций
    Код клиента | Код клиента, указанный в заявке
    Комментарий | Составное поле, отображающее код клиента и текстовый комментарий к заявке, разделенные символом «/»
    Ссылка | Текст-связка для однозначного соответствия двух встречных адресных заявок
    Состояние

    Состояние заявки. Возможные значения:

    • «Активна» – неисполненная заявка;
    • «Исполнена» – заявка удовлетворена;
    • «Снята» – заявка снята отправителем
    Код расчетов | Код расчетов по сделке
    Направленность

    Направленность заявки. Возможные значения:

    • «Отправлена» – собственная заявка, адресованная другому участнику торгов;
    • «Получена» – заявка другого участника торгов, адресованная вам;
    • «Отправлена и получена» – заявка, адресованная самому себе
    Доходность | Доходность по цене заявки, в %
    Объем | Объем заявки в денежном выражении с точностью валюты цены инструмента
    Цена выкупа Цена выкупа второй части РЕПО, в денежном выражении.
    Для заявок по SWAP-инструментам – базовый курс валютного инструмента, указанный пользователем при подаче транзакции
    НКД | Накопленный купонный доход по облигациям в денежном выражении с точностью валюты цены инструмента
    Ставка возмещения (%) | Ставка возмещения в случае отказа от исполнения сделки, в % годовых
    * Ставка РЕПО (%) | Ставка кредитования РЕПО, в % годовых
    ID транзакции | Значение уникального номера заявки «TRANS_ID» при импорте заявок из файла
    ** Сумма РЕПО | Сумма РЕПО - сумма привлеченных/предоставленных по сделке РЕПО денежных средств, по состоянию на текущую дату с точностью валюты цены инструмента
    ** Объем выкупа РЕПО | Объем сделки выкупа РЕПО, в денежном выражении с точностью валюты цены инструмента
    ** Тип ввода заявки РЕПО

    Тип ввода заявки РЕПО. Возможные значения:

    • «Цена1+Ставка»;
    • «Ставка+Цена2»;
    • «Цена1+Цена2»;
    • «Сумма РЕПО + Количество»;
    • «Сумма РЕПО + Дисконт»;
    • «Количество + Дисконт»;
    • «Сумма РЕПО»;
    • «Количество»
    ** Срок РЕПО | Срок РЕПО в календарных днях
    ** Начальный дисконт(%) | Начальный дисконт, в %
    ** Нижний дисконт(%) | Нижнее предельное значение дисконта, в %
    ** Верхний дисконт(%) | Верхнее предельное значение дисконта, в %
    ** Блокировка обеспечения | Признак блокировки финансового инструмента на специальном счете на время операции РЕПО («Да», «Нет»)
    Сумма РЕПО первоначальная | Первоначальное, указанное при регистрации, значение Суммы РЕПО с точностью валюты цены инструмента. Только для заявок модифицированного РЕПО, для других заявок (или если значение не было указано) — пусто.
    Кол-во первоначальное | Первоначальное, указанное при регистрации, количество инструментов (с точностью количества инструмента или в лотах). Только для заявок модифицированного РЕПО, для других заявок (или если значение не было указано) — пусто.
    Дисконт (%) первоначальный | Первоначальное, указанное при регистрации, значение дисконта. Только для заявок модифицированного РЕПО, для других заявок (или если значение не было указано) — пусто.
    Валюта | Код валюты расчетов, например «SUR» – рубли РФ, «USD» – доллары США
    От имени

    Лицо, от имени которого и за чей счет регистрируется сделка. Возможные значения:

    • От своего имени, за свой счет;
    • От своего имени, за счет клиента;
    • От своего имени, за счет доверительного управления;
    • От имени клиента, за счет клиента
    Крупная сделка | Признак крупной сделки (Да/Нет)
    Рег. номер | Номер государственной регистрации инструмента
    Дата расчетов Дата расчетов.
    Для свопов дата расчетов первой части операции своп
    *** Дата активации | Дата активации заявки
    *** Время активации | Время активации заявки. Формат определяется настройками операционной системы
    Встречная безадресная заявка | Номер встречной безадресной заявки. Если она отсутствует, то передается значение 0.
    Валюта расчетов | Код валюты расчетов по сделке, порожденной данной заявкой
    Идентификатор счета | Идентификатор счета в НКЦ (расчетный код)
    *** Дата снятия | Дата отмены заявки в формате <ГГГГММДД DESIGNTIMESP=4640>
    Исходный номер | Номер исходной заявки в ТС
    Приоритетное обеспечение | Приоритетный инструмент, принимаемый в обеспечение
    UID снявшего заявку | Код на сервере QUIK пользователя, снявшего заявку
    Системная ссылка | Дополнительная информация по заявке, передаваемая торговой системой
    Валюта цены | Валюта цены заявки
    Биржевой номер заявки | Биржевой номер заявки
    Период | Период торговой сессии, в который подана заявка
    Client qualifier Квалификатор клиента, от имени которого выставлена заявка. Возможные значения:
    • «» (пусто);
    • «Natural Person»;
    • «Legal Entity»
    Client short code | Краткий идентификатор клиента, от имени которого выставлена заявка
    Investment decision maker qualifier Квалификатор принявшего решение о выставлении заявки. Возможные значения:
    • «» (пусто);
    • «Natural Person»;
    • «Algorithm»
    Investment decision maker short code | Краткий идентификатор принявшего решение о выставлении заявки
    Executing trader qualifier Квалификатор трейдера, исполнившего заявку. Возможные значения:
    • «» (пусто);
    • «Natural Person»;
    • «Algorithm»
    Executing trader short code | Краткий идентификатор трейдера, исполнившего заявку
    Внешняя ссылка | Текстовый комментарий, содержащий информацию о пользователе внешней системы
    Индикатор | Идентификатор индикативной ставки
    Причина отклонения | Причина, по которой заявка была отклонена торговой системой
    Стоимость выкупа РЕПО с открытой датой в день Т+1 | Стоимость выкупа сделки РЕПО с открытой датой в день Т+1. Точность соответствует точности валюты. Заполняется только для сделок РЕПО с открытой датой
    День Т+1 для сделок РЕПО с открытой датой | День Т+1 для сделок РЕПО с открытой датой в формате <ДД.ММ.ГГГГ>. Заполняется только для сделок РЕПО с открытой датой
    РЕПО с открытой датой Сделка РЕПО с открытой датой. Возможные значения:
    • «Да»;
    • «Нет»

    * - параметр используется только в заявках на сделки РЕПО

    ** - параметр заявок на сделки РЕПО ГЦБ

    *** - при включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» значение отображается с учетом временной зоны компьютера, на котором запущен терминал QUIK

    К таблице может быть применен Режим связанных окон.

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер, экспорта по ODBC и сохранения в текстовый файл.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    • «Новая заявка на внебиржевую сделку» (или «F2», или двойное нажатие левой кнопки мыши на строке) – подать новую заявку с условиями, аналогичными заявке, на которой стоит курсор. Если таблица пустая, при выборе функции открывается диалог для выбора класса и инструмента.
    • «Снять заявку на внебиржевую сделку» (или «Ctrl»+«D») – снять выбранную заявку.
    • «Снять активные заявки» – снять все активные заявки.
    • «Открыть канал» / «Закрыть канал» – включить / выключить режим связанных окон в данной основной таблице.
    • «Подключиться к каналу» – привязать окно к основной таблице (подробнее см. Режим связанных окон).
      • «<Название таблицы>» – привязка окна к данной таблице;
      • «Отключить» – отключение связанной таблицы от канала.
    • «Ввод встречных адресных заявок» – открывается диалог ввода встречных адресных заявок. Пункт доступен при наличии в таблице хотя бы одной выделенной строки. Чтобы выделить сразу несколько строк по порядку, удерживайте нажатой клавишу «Shift». Чтобы выделить выборочно несколько строк, удерживайте нажатой клавишу «Ctrl».
    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.
    • «Сохранить в файл заявки на внебиржевые сделки из таблицы» – записать в файл только те заявки, которые отображены в таблице.
    • «Сохранить в файл все заявки на внебиржевые сделки» – записать в файл все имеющиеся заявки, без учета настроек таблицы.

    Функции, доступные для данной таблицы, также могут быть вызваны из контекстного меню нажатием правой кнопки мыши на таблице.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы
    • Ввод внебиржевой сделки
    • Формат сохранения в текстовый файл


Настройка таблицы

  1. «Выбранные классы» – выбор классов инструментов для отображения в таблице. Перечень доступных классов и инструментов в них зависит от установленных фильтров на прием данных с сервера (меню программы Система/Настройки/Основные настройки… раздел «Программа» / «Получение данных» / «Котировки»).
  2. «Фильтр инструментов» – настройка фильтра инструментов возможна для каждого класса из списка «Выбранные классы». Фильтр используется для создания Таблицы сделок по определенному инструменту (группе инструментов).
  3. «Фильтр фирм» – настройка фильтрации по идентификаторам участников торгов, отображаемым в поле «Дилер».
  4. «Фильтр клиентов» – настройка фильтрации по кодам клиентов, отображаемым в столбце «Комментарий».
  5. «Фильтр счетов депо» – настройка фильтрации по счетам депо.
  6. «Показывать полученные» * – включает отображение в таблице заявок со значением «Получена» в поле «Направленность».
  7. «Показывать отправленные» * – включает отображение в таблице заявок со значением «Отправлена» в поле «Направленность».
    (*) Рекомендуется применять для настройки отображения отправленных и принятых заявок в разных таблицах.
  8. «Выделять состояние цветом» – если флажок установлен, то открывается окно настройки цвета фона и шрифта, также открывается по кнопке «…», описание окна цветовых настроек таблицы. Если флажок снят, то цвет шрифта соответствует установкам операционной системы.
  9. «Фильтр состояния» – настройка фильтрации по значению поля «Состояние» (Активные, Исполненные, Снятые).
  10. «Фильтр операции» – настройка фильтрации по значению поля «Операция» (Покупка, Продажа). Рекомендуется применять для создания различных таблиц для заявок на покупку и на продажу.
  11. «Доступные параметры / Заголовки столбцов» – выбор отображаемых параметров и настройка их очередности.

См. также

  • Таблица заявок на внебиржевые сделки
  • Формат сохранения в текстовый файл


Цветовые настройки таблицы заявок на внебиржевые сделки

Окно вызывается нажатием кнопки «…» справа от флажка «Выделять состояние цветом» в диалоге редактирования Таблицы заявок на внебиржевые сделки. Настройки позволяют задать цвет фона и цвет текста для строк таблицы в зависимости от состояния исполнения заявок:

В окне отображается таблица с описанием состояния заявок и цвета их фона и текста.

  • «Активная адресная заявка» – для заявок со статусом «Активна».
  • «Снятая адресная заявка» – для заявок со статусом «Снята».
  • «Исполненная адресная заявка» – для заявок со статусом «Исполнена».

Настройка цвета фона и текста осуществляется нажатием кнопки [image] в соответствующем столбце.

Кнопка «По умолчанию» возвращает стандартные настройки, значения которых приведены на рисунке.


Ввод встречных адресных заявок

Для быстрой подготовки и выставления нескольких встречных заявок из Таблицы заявок на внебиржевые сделки выберите в контекстном меню пункт «Ввод встречных адресных заявок».

В диалоге отображается количество выделенных в таблице встречных заявок, встречной считается адресная активная заявка, у которой фирма партнера в заявке совпадает с фирмой, заданной на классе адресной заявки для текущего пользователя.

  1. «Торговый счет» — торговый счет, который подставляется в качестве торгового счета во встречную адресную заявку. Если указано значение «По умолчанию», во встречной заявке указывается торговый счет, который подставляется в форму ввода адресной заявки при двойном клике по обрабатываемой адресной заявке.
  2. «Код клиента» — код клиента, который подставляется в качестве кода клиента во встречную адресную заявку. Если указано значение «По умолчанию», во встречной заявке указывается код клиента, который подставляется в форму ввода адресной заявки при двойном клике по обрабатываемой адресной заявке.

Нажатием кнопки «Ввести» начнется процесс выставления встречных заявок, если в терминале включена настройка «Запрашивать подтверждение для групповых операций» («Настройки» / «Основные» / «Торговля» / «Заявки»), то перед началом выставления встречных заявок будет запрошено подтверждение. Нажатием кнопки «Отмена» окно закрывается без сохранения.


Таблица безадресных заявок на внебиржевые сделки

меню Создать окно / Безадресные внебиржевые заявки

  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр состояния собственных безадресных заявок, отправленных с начала торговой сессии.

    Формат таблицы

    Каждая строка таблицы содержит информацию об отдельной заявке.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Номер | Регистрационный номер заявки в торговой системе
    Дата | Дата регистрации заявки в торговой системе
    Время | Время регистрации заявки в торговой системе. Формат определяется настройками операционной системы
    Инструмент сокр. | Сокращенное наименование инструмента
    Инструмент | Наименование инструмента
    Код инструмента | Код инструмента в торговой системе
    Класс | Наименование класса инструментов
    Код класса | Код класса в торговой системе
    Операция | Направление операции – «Купля» либо «Продажа»
    Цена | Цена заявки, за единицу инструмента
    Кол-во | Количество инструментов в заявке с точностью количества инструмента или в лотах
    Объем | Объем заявки в денежном выражении с точностью валюты цены инструмента
    Дилер | Идентификатор участника торгов, отправившего заявку
    Орг-я дилера | Наименование участника торгов, подавшего заявку
    Состояние

    Состояние заявки. Возможные значения:

    • «Активна» – неисполненная заявка;
    • «Исполнена» – заявка удовлетворена;
    • «Снята» – заявка снята отправителем
    Код расчетов | Код расчетов по сделке
    * Цена выкупа | Цена второй части РЕПО, за единицу инструмента
    * Ставка РЕПО (%) | Ставка кредитования РЕПО, в % годовых
    * Сумма РЕПО | Сумма привлеченных/предоставленных по сделке РЕПО денежных средств, по состоянию на текущую дату с точностью валюты цены инструмента
    * Объем выкупа РЕПО | Объем сделки выкупа РЕПО, в денежном выражении с точностью валюты цены инструмента
    * Тип ввода заявки РЕПО | Тип ввода заявки РЕПО
    * Срок РЕПО | Срок РЕПО в календарных днях
    * Дисконт (%) | Дисконт при заключении сделки РЕПО
    * Сумма РЕПО первоначальная | Первоначальное, указанное при регистрации, значение Суммы РЕПО с точностью валюты цены инструмента. Только для заявок модифицированного РЕПО, для других заявок (или если значение не было указано) — пусто
    * Кол-во первоначальное | Первоначальное, указанное при регистрации, количество инструментов (с точностью количества инструмента или в лотах). Только для заявок модифицированного РЕПО, для других заявок (или если значение не было указано) — пусто
    * Дисконт (%) первоначальный | Первоначальное, указанное при регистрации, значение дисконта. Только для заявок модифицированного РЕПО, для других заявок (или если значение не было указано) — пусто

    * - параметры сделок РЕПО

    К таблице может быть применен Режим связанных окон.

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер, экспорта по ODBC и сохранения в текстовый файл.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    • «Новая безадресная внебиржевая заявка» (или «F2», или двойное нажатие левой кнопки мыши на строке) – подать новую заявку.
    • «Снять безадресную внебиржевую заявку» (или «Ctrl»+«D») – снять выбранную заявку.
    • «Снять активные заявки» – снять все активные заявки.
    • «Заменить безадресную внебиржевую заявку» (или «Ctrl»+«A») – заменить выбранную заявку.
    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.
    • «Сохранить в файл безадресные заявки на внебиржевые сделки из таблицы» – записать в файл только те заявки, которые отображены в таблице.
    • «Сохранить в файл все безадресные заявки на внебиржевые сделки» – записать в файл все имеющиеся заявки, без учета настроек таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы
    • Формат сохранения в текстовый файл


Настройка таблицы

  1. «Выбранные классы» – выбор классов инструментов для отображения в таблице. Перечень доступных классов и инструментов в них зависит от установленных фильтров на прием данных с сервера (меню программы Система/Настройки/Основные настройки… раздел «Программа» / «Получение данных» / «Котировки»).
  2. «Фильтр инструментов» – настройка фильтра инструментов возможна для каждого класса из списка «Выбранные классы». Фильтр используется для создания Таблицы безадресных заявок на внебиржевые сделки по определенному инструменту (группе инструментов).
  3. «Фильтр фирм» – настройка фильтрации по идентификаторам участников торгов, отображаемым в поле «Дилер».
  4. «Выделять состояние цветом» – если флажок установлен, то открывается окно настройки цвета фона и шрифта, также открывается по кнопке «…», описание окна цветовых настроек таблицы. Если флажок снят, то цвет шрифта соответствует установкам операционной системы.
  5. «Фильтр состояния» – настройка фильтрации по значению поля «Состояние» (Активные, Исполненные, Снятые).
  6. «Фильтр операции» – настройка фильтрации по значению поля «Операция» (Покупка, Продажа). Рекомендуется применять для создания различных таблиц для заявок на покупку и на продажу.
  7. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

См. также:

  • Таблица безадресных заявок на внебиржевые сделки
  • Формат сохранения в текстовый файл


Цветовые настройки таблицы безадресных заявок на внебиржевые сделки

Окно вызывается нажатием кнопки «…» справа от флажка «Выделять состояние цветом» в диалоге редактирования Таблицы безадресных заявок на внебиржевые сделки. Настройки позволяют задать цвет фона и цвет текста для строк таблицы в зависимости от состояния исполнения заявок:

В окне отображается таблица с описанием состояния заявок и цвета их фона и текста.

  • «Активная безадресная внебиржевая заявка» – для заявок со статусом «Активна».
  • «Снятая безадресная внебиржевая заявка» – для заявок со статусом «Снята».
  • «Исполненная безадресная внебиржевая заявка» – для заявок со статусом «Исполнена».

Настройка цвета фона и текста осуществляется нажатием кнопки [image] в соответствующем столбце.

Кнопка «По умолчанию» возвращает стандартные настройки, значения которых приведены на рисунке.


Таблица «РПС котировки»

меню Создать окно / РПС котировки...
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр всех активных безадресных заявок по определенному инструменту, с указанием отправителя заявки.

    Формат таблицы

    Таблица содержит 10 лучших котировок на покупку/продажу, упорядоченных по параметру «Цена». Вид котировочного окна может изменяться пользователем (подробнее см. Параметры настройки таблицы).

    В отличие от Таблицы котировок, заявки в таблице «РПС котировки» не агрегируются по цене, и каждая строка соответствует одной заявке.

    Столбцы таблицы имеют различный набор параметров для заявок РПС и операций РЕПО:

    Параметр | Значение
Номер (К) | Номер безадресной заявки на покупку
Дисконт (%) (К) | Дисконт безадресной заявки на покупку
* Срок РЕПО (К) | Срок РЕПО безадресной заявки на покупку
* Сумма РЕПО (К) | Сумма РЕПО безадресной заявки на покупку
* Цена выкупа (К) | Цена второй части РЕПО для заявки на покупку, за единицу инструмента
* Ставка РЕПО(%) (К) | Ставка РЕПО для заявки на покупку, в %
Код расчетов (К) | Код расчетов, указанный в заявке на покупку
Дилер (К) | Идентификатор участника торгов, подавшего заявку на покупку
Орг-я дилера (К) | Наименование участника торгов, подавшего заявку на покупку
Объем (К) | Объем заявки на покупку в денежном выражении
Кол-во (К) | Количество инструментов в заявке на покупку, выраженное в лотах
Купля | Цена заявки на покупку за единицу инструмента
Продажа | Цена заявки на продажу за единицу инструмента
Кол-во (П) | Количество инструментов в заявке на продажу, выраженное в лотах
Объем (П) | Объем заявки на продажу в денежном выражении
Орг-я дилера (П) | Наименование участника торгов, подавшего заявку на продажу
Дилер (П) | Идентификатор участника торгов, подавшего заявку на продажу
Код расчетов (П) | Код расчетов, указанный в заявке на продажу
* Ставка РЕПО(%) (П) | Ставка РЕПО для заявки на продажу, в %
* Цена выкупа (П) | Цена второй части РЕПО для заявки на продажу, за единицу инструмента
Номер (П) | Номер безадресной заявки на продажу
* Сумма РЕПО (П) | Сумма РЕПО безадресной заявки на продажу
* Срок РЕПО (П) | Срок РЕПО безадресной заявки на продажу
Дисконт (П) | Дисконт безадресной заявки на продажу

    * - параметры заявок на сделки РЕПО

    К таблице может быть применен Режим связанных окон.

    Доступные функции

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    • «Новая заявка» (или «F2», или двойное нажатие левой кнопки мыши на строке – подать новую заявку.
    • «Новая безадресная заявка» – подать новую безадресную заявку.
    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    Для возможности ввода заявок из таблицы «РПС котировки» по классу инструментов UA (Украинский рынок котировок) необходимо в файле настроек info.ini в секции [transactions] добавить следующую строку:

    use-order-trans-instead-of-neg-deal-trans-classes-list=UA

    При выставлении адресной заявки из таблицы «РПС котировки» будет проверяться наличие соответствия для класса инструмента выбранной котировки, заданного в секции [QUOTES_EXECUTION] файла настроек info.ini. Если задано соответствие, выставляется адресная заявка по классу, указанному в настройке как класс исполнения. Если код фирмы отсутствует, то код фирмы контрагента в безадресной котировке учитываться не будет. Если соответствие не задано, заявки выставляются стандартно.

    При выставлении адресной заявки из таблицы «РПС котировки» и при включенном специализированном режиме отображения форм ввода открывается новая форма ввода адресной заявки с возможностью выбора класса исполнения, заданного в секции [QUOTES_EXECUTION] файла настроек info.ini. Если информация о купонном расписании и базисе РЕПО не получена, то поле «Доходность» и кнопка «Задать цену» на форме ввода недоступны.

    Формат ключа с учетом фирмы:

    <КОД_КЛАССА DESIGNTIMESP=8201>|<КОД_ФИРМЫ DESIGNTIMESP=8202>=<КОД_КЛАССА_ИСПОЛНЕНИЯ DESIGNTIMESP=8203>

    Где:

    • <КОД КЛАССА DESIGNTIMESP=8207> – код класса выбранной безадресной котировки.
    • <КОД ФИРМЫ DESIGNTIMESP=8209> – код фирмы контрагента.
    • <КОД КЛАССА ИСПОЛНЕНИЯ DESIGNTIMESP=8211> – код класса подачи адресной заявки.

    Формат ключа без учета фирмы:

    <КОД_КЛАССА DESIGNTIMESP=8215>=<КОД_КЛАССА_ИСПОЛНЕНИЯ DESIGNTIMESP=8216>

    Где:

    • <КОД КЛАССА DESIGNTIMESP=8220> – код класса выбранной безадресной котировки.
    • <КОД КЛАССА ИСПОЛНЕНИЯ DESIGNTIMESP=8222> – код класса подачи адресной заявки.
    Если точность цены в классе безадресной котировки выше, чем точность в классе исполнения, цена конвертируется из значения с большей точностью в значение с меньшей точностью по математическим правилам. Например, 1.236450 округлится до 1.2365, а 1.236440 до 1.2364.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Выбор инструмента» – список классов инструментов, доступных для выбора одного инструмента и отображения информации по нему в таблице. Список доступен только при создании таблицы и недоступен при ее редактировании.
  2. «Выделять котировки цветом» – если флажок установлен, то ячейки таблицы, соответствующие заявкам на покупку/продажу, выделяются цветом шрифта и/или фона. Подробнее о настройке цветов см. Настройка цвета в таблицах и графиках .
  3. «Фильтр фирм» – настройка фильтрации по идентификаторам участников торгов, отображаемым в поле «Дилер».
  4. «Фильтр операции» – настройка фильтрации по значению поля «Операция» (Покупка, Продажа). Рекомендуется применять для создания различных таблиц для заявок на покупку и продажу.
  5. «Вид котировочного окна» – выбор вида таблицы «РПС котировки»:
    • – имеет один общий столбец «Цена» (1). Параметры заявок на покупку и заявок на продажу отображаются в разных столбцах;
    • – отображает параметры спроса и предложения в разных столбцах (2). При этом котировки на покупку упорядочены по убыванию цены заявки, а котировки на продажу – по возрастанию цены заявки таким образом, что лучшие цены заявок отображаются в первой строке окна;
    • «Покупку показывать сверху» - если флажок установлен, то параметры заявок на покупку отображаются в верхней части таблицы. Доступен для таблиц вида (1).
  6. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

См. такжеТаблица «РПС котировки»


Сводные котировки РПС и РЕПО

меню Создать окно / Сводные котировки РПС и РЕПО...
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр активных котировок безадресных заявок по инструментам всех доступных пользователю РПС и РЕПО классов.

    Формат таблицы

    Таблицы котировок РПС и РЕПО строятся в разрезе выбранных инструментов.

    В отличие от Таблицы котировок, заявки в Сводной таблице котировок РПС и РЕПО не агрегируются по цене, и каждая строка соответствует одной заявке.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
Номер | Номер адресной заявки
Код класса | Код класса инструмента
Класс | Наименование класса, к которому относится инструмент
Код инструмента | Идентификатор инструмента
Инструмент | Наименование инструмента
Инструмент сокр. | Сокращенное наименование инструмента
Дилер | Идентификатор участника торгов, отправившего заявку
Орг-я дилера | Наименование участника торгов, отправившего заявку
Операция | Направление операции («Купля», «Продажа»)
Ставка РЕПО(%) | Ставка РЕПО, в %
Срок РЕПО | Срок РЕПО адресной заявки
Кол-во | Количество инструментов в заявке
Сумма РЕПО | Сумма РЕПО адресной заявки
Код расчетов | Код расчетов, указанный в заявке
Цена | Цена котировки, отображается с точностью котировки инструмента

    Доступные функции

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    • «Котировки» – открыть Таблицу котировок по выбранному инструменту.
    • «Новая заявка» (или «F2», или двойное нажатие левой кнопки мыши на строке – подать новую заявку.
    • «Новая безадресная заявка» – подать новую безадресную заявку.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    При выставлении адресной заявки из таблицы «Сводные котировки РПС и РЕПО» будет проверяться наличие соответствия для класса инструмента выбранной котировки, заданного в секции [QUOTES_EXECUTION] файла настроек info.ini. Если задано соответствие, выставляется адресная заявка по классу, указанному в настройке как класс исполнения. Если код фирмы отсутствует, то код фирмы контрагента в безадресной котировке учитываться не будет. Если соответствие не задано, заявки выставляются стандартно.

    Формат ключа с учетом фирмы:

    <КОД_КЛАССА>|<КОД_ФИРМЫ>=<КОД_КЛАССА_ИСПОЛНЕНИЯ>

    Где:

    • <КОД КЛАССА> – код класса выбранной безадресной котировки.
    • <КОД ФИРМЫ> – код фирмы контрагента.
    • <КОД КЛАССА ИСПОЛНЕНИЯ> – код класса подачи адресной заявки.

    Формат ключа без учета фирмы:

    <КОД_КЛАССА>=<КОД_КЛАССА_ИСПОЛНЕНИЯ>

    Где:

    • <КОД КЛАССА> – код класса выбранной безадресной котировки.
    • <КОД КЛАССА ИСПОЛНЕНИЯ> – код класса подачи адресной заявки.
    Если точность цены в классе безадресной котировки выше, чем точность в классе исполнения, цена конвертируется из значения с большей точностью в значение с меньшей точностью по математическим правилам. Например, 1.236450 округлится до 1.2365, а 1.236440 до 1.2364.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Выбранные классы» – выбор классов инструментов для отображения в таблице. В списке отображаются все доступные пользователю РПС и РЕПО классы.
  2. «Фильтр инструментов» – настройка фильтра инструментов возможна для каждого класса из списка «Выбранные классы». Фильтр используется для создания Сводной таблицы котировок РПС и РЕПО по определенному инструменту (группе инструментов).
  3. «Фильтр фирм» – настройка фильтрации по идентификаторам участников торгов, отображаемым в поле «Дилер».
  4. «Фильтр операции» – настройка фильтрации по значению поля «Операция» (Покупка, Продажа). Рекомендуется применять для создания различных таблиц для заявок на покупку и продажу.
  5. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

См. также Таблица котировок РЕПО


Сделки для исполнения

меню Создать окно / Сделки для исполнения
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр состояния исполнения сделок РПС с наступившим сроком исполнения. Просмотр состояния сделок по исполнению второй части РЕПО.

    Формат таблицы

    Каждая строка таблицы соответствует отдельной сделке.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Номер | Регистрационный номер сделки в торговой системе
    Номер заявки | Номер заявки, на основании которой была заключена данная сделка
    Дата торгов | Дата заключения сделки
    *** Дата расчетов | Дата расчетов по сделке
    Класс | Наименование класса инструментов
    Код класса | Код класса инструментов
    Инструмент сокр. | Сокращенное наименование инструмента
    Инструмент | Наименование инструмента
    Код инструмента | Код инструмента в торговой системе биржи
    Операция | Направление операции: «Купля» либо «Продажа»
    Код клиента | Код клиента
    Комментарий | Текстовый комментарий к заявке
    Дилер | Идентификатор участника торгов
    Орг-я трейдера | Наименование участника торгов
    Счет депо | Счет депо участника торгов
    Партнер | Идентификатор участника торгов, являющегося партнером по сделке
    Орг-я партнера | Наименование участника торгов, являющегося партнером по сделке. Поле заполняется только для клиентов с правами на совершение активных операций
    Счет депо партнера | Счет депо участника торгов, являющегося партнером по сделке
    Цена | Цена сделки, за единицу инструмента. Для операций РЕПО – цена исполнения второй части РЕПО на текущую дату, за единицу инструмента
    Количество | Количество инструментов с точностью количества инструмента или в лотах
    Объем | Объем сделки в денежном выражении с точностью валюты цены инструмента
    Состояние

    Состояние подтверждения сделки. Возможные значения:

    • «Не исполнена» – сделка не подтверждена отчетом;
    • «Включена в отчет» – сделка включена в отчет одним контрагентом;
    • «Исполнена» – сделка подтверждена отчетами обоими контрагентами;
    • «Отменена пользователем»;
    • «Взнос»;
    • «Отказ»
    НКД | Накопленный купонный доход по облигациям в денежном выражении с точностью валюты цены инструмента
    * Цена 1ой части РЕПО | Цена первой части сделки РЕПО, за единицу инструмента
    Цена выкупа | Цена исполнения второй части сделки РЕПО на дату истечения срока исполнения, за единицу инструмента
    * Номер сделки 1ой части РЕПО | Регистрационный номер сделки первой части РЕПО в торговой системе
    * Ставка РЕПО(%) | Ставка кредитования РЕПО, в %
    Код расчетов | Код расчетов по сделке
    Отчет | Номер отчета по сделке в торговой системе
    Отчет партнера | Номер отчета партнера по сделке
    Комиссия ТС | Величина комиссии торговой системы, в денежном выражении с точностью валюты цены инструмента
    ** Остаток | Объем неисполненной части заявки с точностью количества инструмента или в лотах
    **, *** Время исполнения | Время исполнения. Формат определяется настройками операционной системы
    ** Сумма обязательства | Обязательство или требование (в зависимости от направления сделки) по деньгам (для сделок второй части РЕПО - значение обязательства РЕПО на текущую дату) с точностью валюты цены инструмента
    ** Сумма РЕПО | Сумма РЕПО - сумма привлеченных/предоставленных по сделке РЕПО денежных средств, по состоянию на текущую дату с точностью валюты цены инструмента
    ** Срок РЕПО | Срок РЕПО в календарных днях
    ** Объем выкупа РЕПО | Текущее значение стоимости выкупа по сделке РЕПО, рассчитанное на дату исполнения (по условию сделки) второй части РЕПО, с точностью валюты цены инструмента
    ** Сумма возврата РЕПО | Текущее значение суммы возврата по сделке РЕПО, рассчитанное на дату исполнения (по условию сделки) второй части РЕПО, с точностью валюты цены инструмента
    ** Дисконт(%) | Для сделок первой части РЕПО - начальный дисконт. Для сделок второй части РЕПО - текущий дисконт, в %
    ** Нижний дисконт(%) | Нижнее предельное значение дисконта, в %
    ** Верхний дисконт(%) | Верхнее предельное значение дисконта, в %
    ** Блокировать обеспечение | Признак блокировки финансового инструмента на специальном счете на время операции РЕПО («Да», «Нет»)
    ** Исполнить | Признак наступления срока исполнения обязательств по второй части РЕПО («Да», «Нет»)
    ** Исполнить завтра | Признак, информирующий о наступлении завтра срока исполнения обязательств по второй части РЕПО («Да», «Нет»)
    ** Тип

    Тип сделки. Возможные значения:

    • Внесистемная сделка;
    • Первая часть сделки РЕПО;
    • Вторая часть сделки РЕПО;
    • Компенсационный взнос;
    • Адресная сделка;
    • Первичное размещение;
    • Первая часть адресной сделки РЕПО с ЦК;
    • Вторая часть адресной сделки РЕПО с ЦК;
    • Возврат выплат;
    • Дефолтер: отложенные обязательства и требования;
    • Пострадавший: отложенные обязательства и требования;
    • Первая часть сделки РЕПО с ЦК;
    • Вторая часть сделки РЕПО с ЦК
    ** Направленность | Тип операции: «Зачислить» или «Списать»
    ** Дисконт после взноса(%) Значение дисконта после уплаты компенсационного взноса, в %.
    Параметр сделок типа Компенсационный взнос
    ** Количество после взноса Количество инструментов после уплаты компенсационного взноса с точностью количества инструмента или в лотах.
    Параметр сделок типа Компенсационный взнос
    ** Сумма РЕПО после взноса

    Сумма после уплаты компенсационного взноса с точностью валюты цены инструмента. Параметр сделок типа Компенсационный взнос

    ** Стоимость выкупа после взноса | Объем сделки выкупа РЕПО после уплаты компенсационного взноса с точностью валюты цены инструмента. Параметр сделок типа Компенсационный взнос
    ** Сумма возврата после взноса Объем сделки после уплаты компенсационного взноса, в денежном выражении с точностью валюты цены инструмента.
    Параметр сделок типа Компенсационный взнос
    *, *** Дата заключения | Для компенсационных взносов — дата заключения исходной сделки РЕПО, пусто для остальных случаев.
    Состояние расчётов | Состояние расчетов по сделке
    Тип клиринга Тип процедуры расчетов по сделке. Возможные значения:

    • Не установлен;
    • Простой;
    • Многосторонний;
    • Внешний;
    • Централизованный
    Комиссия за отчёт | Размер комиссионного вознаграждения за исполнение сделки срочным отчетом, в денежном выражении с точностью валюты цены инструмента
    Купонная выплата | Объем купонной выплаты, прошедшей со дня последних торгов по инструментам, входящим в обеспечение сделки РЕПО, с точностью валюты цены инструмента
    *** Дата купонной выплаты | Дата прошедшей купонной выплаты
    Выплата по основному долгу | Объем выплаты по основному долгу, прошедшей со дня последних торгов по инструментам, входящим в обеспечение сделки РЕПО, с точностью валюты цены инструмента
    *** Дата выплаты по основному долгу | Дата прошедшей выплаты по основному долгу (амортизации)
    Валюта расчетов | Код валюты расчетов по сделке
    Подтверждена Признак подтверждения сделки. Возможные значения:
    • «Да»;
    • «Нет»
    Подтверждена контрагентом Признак подтверждения сделки контрагентом. Возможные значения:
    • «Да»;
    • «Нет»
    Номер поручения | Идентификатор отчета по подтверждению сделки
    Время подтверждения | Время подтверждения сделки отчетом. Формат определяется настройками операционной системы
    Код позиции | Код позиции
    Кол-во к исполнению | Количество инструментов к исполнению
    Расчетная организация | Идентификатор клиринговой организации
    Сумма отступного | Сумма отступного в валюте сделки с точностью валюты цены инструмента
    Номер витринной сделки | Идентификатор витринной сделки
    Индикатор | Идентификатор индикативной ставки
    Дата изменения индикатора | Дата изменения индикатора в формате <ГГГГММДД DESIGNTIMESP=9749>
    Значение индикатора | Значение индикатора, в %
    Причина отмены | Причина, по которой заявка была отклонена
    Тип сделки депозита Тип сделки депозита. Возможные значения:
    • «» (пусто) – сделка не типа «депозит»;
    • «Намерение»;
    • «Депозит»;
    • «Изъятие»;
    • «Закрытие планового пополнения»;
    • «Принудительное закрытие»;
    • «Перенос пополнения»
    Стоимость выкупа РЕПО с открытой датой в день Т+1 | Стоимость выкупа сделки РЕПО с открытой датой в день Т+1. Точность соответствует точности валюты. Поле заполняется только для сделок РЕПО с открытой датой
    День Т+1 для сделок РЕПО с открытой датой | День Т+1 для сделок РЕПО с открытой датой в формате <ДД.ММ.ГГГГ>. Заполняется только для сделок РЕПО с открытой датой
    Отчет на закрытие сделки РЕПО с открытой датой | Отчет на закрытие сделки РЕПО с открытой датой. Поле заполняется только для РЕПО с открытой датой
    Статус РЕПО с открытой датой Статус сделки РЕПО с открытой датой. Возможные значения:
    • «Да»;
    • «Нет»;
    • «Срочная»

    * - параметр используется только в сделках РЕПО

    ** - параметр РЕПО ГЦБ

    *** - при включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» значение отображается с учетом временной зоны компьютера, на котором запущен терминал QUIK

    К таблице может быть применен Режим связанных окон.

    Доступные функции

    Данные таблицы доступны для копирования, вывода через DDE-сервер, экспорта по ODBC и сохранения в текстовый файл.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    • «Ввести поручение на закрытие сделки» – подать поручение на закрытие сделки РЕПО с открытой датой. Функция доступна в контекстном меню, вызванным по сделке для исполнения со значением «Да» в поле «Статус РЕПО с открытой датой» и только для сделок типа «Вторая часть адресной сделки по операции РЕПО с ЦК» и «Вторая часть сделки РЕПО». Если сделка другого типа и/или значение «Нет» либо «Срочная», то функция не отображается.
    • «Подтвердить отчетом» (или «F2», или двойное нажатие левой кнопки мыши на строке) - сформировать заявку-отчет, подтверждающую выбранную сделку.
    • «Подтвердить срочным отчетом» - сформировать срочный отчет, подтвердающий выбранную сделку. Эта команда позволяет добавить выбранную сделку в режим расчетов по правилам простого клиринга.
    • «Ввести поручение на подтверждение» - отправить запрос на формирование расчетной заявки-отчёта по транзакции «Ввод поручения на подтверждение внебиржевой сделки».
    • «Ввод заявки-отчета (макс. 4 сделки)» - открыть окно ввода расчетной заявки-отчета.
    • «Подтвердить все сделки из таблицы» - отправить запрос на формирование заявок-отчетов на исполнение всех неисполненных сделок, с учетом установленных в настройках таблицы фильтров. Эта функция системы позволяет облегчить подтверждение вторых частей РЕПО, например, в ситуации переноса клиентских позиций.
    • «Подключиться к каналу» – привязать окно к основной таблице (подробнее см. Режим связанных окон).
      • «<Название таблицы>» – привязка окна к данной таблице;
      • «Отключить» – отключение связанной таблицы от канала.
    • «Новая заявка на внебиржевую сделку» - открыть окно ввода заявки на внебиржевую сделку. Пункт меню доступен, если пользователю разрешен ввод адресных заявок по классу инструментов, определяемому по исходной сделке для исполнения.
    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.
    • «Сохранить в файл сделки для исполнения РПС из таблицы» – записать в файл только те сделки, которые отображены в таблице.
    • «Сохранить в файл все сделки для исполнения РПС» – записать в файл все имеющиеся сделки, без учета настроек таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы
    • Формат сохранения в текстовый файл


Настройка таблицы

  1. «Выбранные классы» – список классов инструментов, доступных для отображения в таблице. Перечень классов и инструментов в них зависит от установленных фильтров на прием данных с сервера (меню программы Система/Настройки/Основные настройки… раздел «Программа» / «Получение данных» / «Котировки»).
  2. «Фильтр инструментов» – настройка фильтра инструментов возможна для каждого класса из списка «Выбранные классы». Фильтр используется для создания Таблицы сделок по определенному инструменту (группе инструментов).
  3. «Фильтр фирм» – настройка фильтрации по идентификаторам участников торгов, отображаемым в поле «Дилер».
  4. «Фильтр счетов депо» – настройка фильтрации по счетам депо.
  5. «Фильтр клиентов» – настройка фильтрации по кодам клиентов, отображаемым в поле «Комментарий».
  6. «Только сделки, требующие исполнения на текущую дату» – при установленном флажке в таблице отображаются только сделки с датой исполнения, совпадающей с текущей.
  7. «Выделять состояние цветом» – если флажок установлен, то открывается окно настройки цвета фона и шрифта, также открывается по кнопке «…», описание окна цветовых настроек таблицы заявок. Если флажок снят, то цвет шрифта соответствует установкам операционной системы.
  8. «Фильтр состояния» – выбор отображаемых заявок по значению поля «Состояние». В таблице отображаются заявки только выбранного состояния (Активные, Исполненные, Снятые).
  9. «Фильтр операции» – выбор заявок по значению поля «Операция». В таблице отображаются заявки только выбранной направленности (Покупка, Продажа). Рекомендуется применять для создания различных таблиц для заявок на покупку и продажу.
  10. «Фильтр по типу» – фильтрация заявок по значению поля «Тип». В таблице отображаются заявки только выбранных типов.
  11. «Доступные параметры / Заголовки столбцов» – выбор отображаемых параметров и настройка их очередности.

См. также:

  • Сделки для исполнения
  • Формат сохранения в текстовый файл


Таблица заявок-отчетов на сделки РПС

меню Создать окно / Отчеты по сделкам для исполнения
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр отправленных и принятых расчетных заявок-отчетов на исполнение сделок РПС и второй части сделок РЕПО. В таблице отображаются отчеты обеих сторон по сделке.

    Формат таблицы

    Каждая строка таблицы содержит информацию об одной заявке-отчете. Каждой сделке соответствует два таких отчета.

    В столбцах таблицы отображаются следующие параметры отчетов:

    Параметр | Значение
    Номер | Регистрационный номер расчетной заявки-отчета в торговой системе
    * Дата | Дата регистрации заявки-отчета
    * Выставлен(время) | Время регистрации заявки-отчета. Формат определяется настройками операционной системы
    * Снят(время) | Время отзыва заявки-отчета из торговой системы (для заявок со статусом «Снят»). Формат определяется настройками операционной системы
    Класс | Наименование класса инструментов
    Код класса | Код класса инструмента
    Инструмент сокр. | Сокращенное наименование инструмента
    Инструмент | Наименование инструмента
    Код инструмента | Код инструмента
    Трейдер | Идентификатор трейдера, зарегистрировавшего отчет
    Дилер | Идентификатор участника торгов
    Орг-я партнера | Наименование участника торгов. Поле заполняется только для клиентов с правами на совершение активных операций
    Счет депо | Счет депо, в отношении которого осуществляется сделка
    Партнер | Идентификатор участника торгов, являющегося партнером по сделке
    Орг-я партнера | Наименование участника торгов, являющегося партнером по сделке
    Счет депо партнера | Счет депо партнера по сделке
    Количество | Количество инструментов в сделке с точностью количества инструмента или в лотах
    Объем | Объем сделки в денежном выражении с точностью валюты цены инструмента. При выполнении операции «Купля» указывается отрицательным
    Направленность Направленность заявки. Возможные значения:
    • «Отправлена» - собственная заявка, адресованная другому участнику торгов;
    • «Получена пользователем» - заявка другого участника торгов, адресованная вам;
    • «Отправлена и получена» - заявка, адресованная самому себе
    Состояние

    Состояние подтверждения заявки-отчета:

    • «Ждет исполнения» – сделка не подтверждена отчетом;
    • «Снят» – отчет по сделке отменен;
    • «Исполнен» – отчет принят торговой системой к исполнению
    Тип отчета Тип отчета. Возможные значения:
    • «Исполнена»;
    • «Отказ от исполнения»;
    • «Закрытие»
    Комиссия | Объем комиссии по сделке, в денежном выражении с точностью валюты цены инструмента
    Вид отчёта | Вид отчёта
    Сумма отступного | Сумма отступного в валюте сделки с точностью валюты цены инструмента
    Направленность отступного Тип операции. Возможные значения:
    • «Заплатить»;
    • «Получить»;
    • « » (пусто) – не определен

    * - при включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» значение отображается с учетом временной зоны компьютера, на котором запущен терминал QUIK

    К таблице может быть применен Режим связанных окон.

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер, экспорта по ODBC и сохранения в текстовый файл.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    • «Снять отчет» (или «Ctrl» + «D», или двойное нажатие правой кнопки мыши на строке) – снять выбранный отчет по сделке.
    • «Снять активные заявки» (или «Ctrl»+«F8») – снять все активные заявки.
    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.
    • «Открыть канал» / «Закрыть канал» – включить / выключить режим связанных окон в данной основной таблице.
    • «Подключиться к каналу» – привязать окно к основной таблице (подробнее см. Режим связанных окон).
      • «<Название таблицы>» – привязка окна к данной таблице;
      • «Отключить» – отключение связанной таблицы от канала.
    • Сохранить в файл отчеты на сделки для исполнения РПС из таблицы» – записать в файл только те отчеты, которые отображены в таблице.
    • «Сохранить в файл все отчеты на сделки для исполнения РПС» – записать в файл все имеющиеся отчеты, без учета настроек таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы
    • Формат сохранения в текстовый файл


Настройка таблицы

  1. «Выбранные классы» – список классов инструментов, доступных для отображения в таблице. Перечень классов и инструментов в них зависит от установленных фильтров на прием данных с сервера (меню программы Система/Настройки/Основные настройки… раздел «Программа» / «Получение данных» / «Котировки»).
  2. «Фильтр инструментов» – настройка фильтра инструментов возможна для каждого класса из списка «Выбранные классы». Фильтр используется для создания Таблицы заявок-отчетов по определенному инструменту (группе инструментов).
  3. «Фильтр фирм» – настройка фильтрации по идентификаторам участников торгов, отображаемым в поле «Дилер».
  4. «Фильтр счетов депо» – настройка фильтрации по счетам депо.
  5. «Фильтр состояния» – выбор отображаемых отчетов по значению поля «Состояние». В таблице отображаются заявки только выбранного состояния (Активные, Исполненные, Снятые).
  6. «Показывать отправленные» * – включает отображение в таблице заявок со значением «Отправлена» в поле «Направленность».
  7. «Показывать полученные» * – включает отображение в таблице заявок со значением «Получена» в поле «Направленность».
    (*) Рекомендуется применять для настройки отображения отправленных и принятых заявок в разных таблицах.
  8. «Выделять состояние цветом» – если флажок установлен, то открывается окно настройки цвета фона и шрифта, также открывается по кнопке «…», описание окна цветовых настроек таблицы заявок. Если флажок снят, то цвет шрифта соответствует установкам операционной системы.
  9. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

См. также:

  • Таблица заявок-отчетов на сделки РПС
  • Формат сохранения в текстовый файл


Таблица «Коды расчетов»

меню Создать окно / Информация по кодам расчетов по инструментам...
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр информации по величине накопленного купонного дохода и ставкам РЕПО на даты, соответствующие кодам расчетов для выбранного инструмента.

    Формат таблицы

    Одна таблица содержит информацию по одному инструменту. Каждая строка соответствует отдельному коду расчетов. Строки таблицы отсортированы по возрастанию кодов расчетов.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Код инструмента | Код инструмента в торговой системе биржи
    Код расчетов | Код расчетов, используемый в адресной сделке
    Дата расчетов | Дата расчетов по первой части сделки РЕПО
    НКД | Накопленный купонный доход по облигациям на дату расчетов по первой части сделки РЕПО
    Дата расчетов РЕПО | Дата расчетов по второй части сделки РЕПО, соответствующая коду расчетов
    НКД2 | Накопленный купонный доход по облигациям на дату расчетов по второй части сделки РЕПО
    Цена выкупа | Цена исполнения второй части РЕПО
    Срок РЕПО | Срок сделки РЕПО в календарных днях
    Ставка РЕПО | Ставка кредитования РЕПО, в %
    РЕПО с открытой датой Сделка РЕПО с открытой датой. Возможные значения:
    • «Да»;
    • «Нет»

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Выбор инструмента» – выбор инструмента из списка доступных, по которому создается Таблица кодов расчетов. При выборе нескольких инструментов создается отдельная таблица для каждого выбранного инструмента.
  2. «Столбцы» – выбор отображаемых параметров и настройка их очередности.
  3. «Фильтр кодов расчетов» – настройка фильтрации по кодам расчетов.

См. также Таблица «Коды расчетов»


Таблица «Разрешения на получение РПС-котировок»

меню Создать окно / Разрешения на получение РПС-котировок
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Добавление и удаление разрешений на получение РПС-котировок по выбранным классам для определенных фирм.

    Формат таблицы

    Таблица содержит записи об установленных разрешениях. Каждая строка соответствует отдельному разрешению.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
Класс | Наименование класса, для которого было задано разрешение
Код класса | Код класса
Фирма | Наименование фирмы-отправителя РПС-котировок
Код фирмы | Код фирмы-отправителя РПС-котировок
Контрагент | Наименование фирмы-получателя РПС-котировок
Код контрагента | Код фирмы-получателя РПС-котировок

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Добавить разрешение» – добавление разрешения, открывает окно «Добавление разрешения на получение РПС-котировок» со следующими параметрами:
      • «Класс» – выбор класса из списка доступных, по которому будут отправляться РПС-котировки. Значение по умолчанию: «Все».
      • «Контрагент» – выбор фирмы контрагента из списка доступных, для которой добавляется разрешение на получение РПС-котировок по выбранному классу.
    • «Удалить разрешение» – удаление выбранной строки с разрешением.
    Добавить и/или удалить разрешение можно общим способом выполнения транзакций или горячей клавишей «Ctrl»+«T».

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.
  2. «Фильтр по контрагентам» – настройка фильтрации по кодам контрагентов.

См. также Таблица «Разрешения на получение РПС-котировок»


Таблица «Обязательства и требования по деньгам [ЦК]»

меню Создать окно / Обязательства и требования по деньгам [ЦК]
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Таблица содержит информацию об обязательствах и требованиях по деньгам на фондовом рынке.

    Формат таблицы

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
Класс | Код класса инструмента
Фирма | Идентификатор фирмы
Код инструмента | Код инструмента
Код позиции | Идентификатор расчетного счета/кода в клиринговой организации
Дата расчетов | Дата расчетов
Вх. по требованиям | Размер денежных требований на начало дня, с точностью до 2 знака после десятичного разделителя
Вх. по обязательствам | Размер денежных обязательств на начало дня, с точностью до 2 знака после десятичного разделителя
Нетто | Нетто
Требования | Размер денежных требований
Обязательства | Размер денежных обязательств
В заявках на покупку | Количество инструментов с точностью количества инструмента в заявках на покупку
В заявках на продажу | Количество инструментов с точностью количества инструмента в заявках на продажу
Плановая Т+ | Плановая позиция Т+
Лимит обеспеченных продаж | Лимит обеспеченных продаж

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

См. также Таблица «Обязательства и требования по деньгам [ЦК]».


Таблица «Обязательства и требования по активам (расширенные) [ЦК]»

меню Создать окно / Обязательства и требования по активам (расширенные) [ЦК]
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Таблица содержит расширенную информацию об обязательствах и требованиях по активам.

    Формат таблицы

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Фирма | Идентификатор фирмы
    Торговый счет | Торговый счет
    Код позиции | Идентификатор расчетного счета/кода в клиринговой организации
    Счет депо | Номер счета депо в Депозитарии (НДЦ)
    Тип раздела Возможные значения:
    • «Обеспечение» – раздел обеспечения;
    • «Торговый» – торговый раздел
    Код класса актива 1 | Код класса инструмента 1
    Код инструмента актива 1 | Код инструмента 1
    Код класса актива 2 | Код класса инструмента 2
    Код инструмента актива 2 | Код инструмента 2
    Дата расчетов | Дата расчетов
    Входящие требования (актив 1) | Размер денежных требований по активу 1 на начало дня, с точностью до 2 знаков после десятичного разделителя
    Входящие обязательства (актив 1) | Размер денежных обязательств по активу 1 на начало дня, с точностью до 2 знаков после десятичного разделителя
    Нетто (актив 1) | Нетто по активу 1
    Требования (актив 1) | Размер денежных требований по активу 1
    Обязательства (актив 1) | Размер денежных обязательств по активу 1
    Требования в заявках (актив 1) | Размер денежных требований в заявках по активу 1
    Обязательства в заявках (актив 1) | Размер денежных обязательств в заявках по активу 1
    Входящие требования (актив 2) | Размер денежных требований по активу 2 на начало дня, с точностью до 2 знаков после десятичного разделителя
    Входящие обязательства (актив 2) | Размер денежных обязательств по активу 2 на начало дня, с точностью до 2 знаков после десятичного разделителя
    Нетто (актив 2) | Нетто по активу 2
    Требования (актив 2) | Размер денежных требований по активу 2
    Обязательства (актив 2) | Размер денежных обязательств по активу 2
    Требования в заявках (актив 2) | Размер денежных требований в заявках по активу 2
    Обязательства в заявках (актив 2) | Размер денежных обязательств в заявках по активу 2
    Плановая Т+ | Плановая позиция Т+
    Лимит обеспеченных продаж | Лимит обеспеченных продаж

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

См. также Таблица «Обязательства и требования по активам (расширенные) [ЦК]».


Таблица «Обязательства и требования по активам [ЦК]»

меню Создать окно / Обязательства и требования по активам [ЦК]
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Таблица содержит информацию об обязательствах и требованиях по активам.

    Формат таблицы

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Фирма | Идентификатор фирмы
    Код инструмента | Код инструмента
    Торговый счет | Торговый счет
    Дата расчетов | Дата расчетов
    Инструмент сокр. | Краткое наименование инструмента
    Инструмент | Полное наименование инструмента
    Код класса | Код класса инструмента
    Класс | Наименование класса инструмента
    Счет депо | Номер счета депо в Депозитарии (НДЦ)
    Код позиции | Идентификатор расчетного счета/кода в клиринговой организации
    Количество в сделках | Количество инструментов с точностью количества инструмента в сделках
    Количество в заявках на покупку | Количество инструментов с точностью количества инструмента в заявках на покупку
    Количество в заявках на продажу | Количество инструментов с точностью количества инструмента в заявках на продажу
    Сумма в сделках | Сумма денежных средств в сделках
    В сделках на покупку | Сумма денежных средств в заявках на покупку
    В сделках на продажу | Сумма денежных средств в заявках на продажу
    Плановая Т+ | Плановая позиция Т+
    Тип раздела Возможные значения:
    • «Обеспечение» – раздел обеспечения;
    • «Торговый» – торговый раздел
    Лимит обеспеченных продаж | Лимит обеспеченных продаж

    Доступные функции

    Данные из таблицы доступны для вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы


Настройка таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

См. также Таблица обязательств и требований по активам.


Таблица параметров процентных рисков

меню Создать окно / Параметры процентных рисков [ЦК]
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Таблица содержит информацию по текущим параметрам процентных рисков сделок РЕПО.

    Формат таблицы

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Код инструмента | Код инструмента
    Инструмент сокр. | Краткое наименование инструмента
    Инструмент | Полное наименование инструмента
    Код класса | Код класса инструмента
    Класс | Наименование класса инструмента
    Дата расчетов | Дата расчетов
    Диапазон | Диапазон количества инструментов
    Начало диапазона | Минимальное количество инструментов
    Конец диапазона | Максимальное количество инструментов
    Дисконт, % | Ставка процентного риска, %
    Нижняя граница, руб | Нижняя граница цены, руб
    Расчетная ставка РЕПО, руб | Расчетная ставка РЕПО, руб
    Верхняя граница, руб | Верхняя граница цены, руб
    Нижняя граница, % | Нижняя граница цены, %
    Расчетная ставка РЕПО, % | Расчетная ставка РЕПО, %
    Верхняя граница, % | Верхняя граница цены, %
    Начало диапазона, руб | Минимальное количество инструментов, руб
    Конец диапазона, руб | Максимальное количество инструментов, руб
    Расчетная цена, руб | Цена единицы инструмента в заявках/сделках РЕПО, руб
    Расчетная цена РЕПО, руб | Цена единицы инструмента, используемая при расчете процентных рисков
    Ставка риска падения цены, % | Ставка риска падения цены, %
    Ставка риска роста цены, % | Ставка риска роста цены, %
    * Время изменения ставок риска | Время изменения ставок риска. Формат определяется настройками операционной системы
    Базовая точка Признак того, что текущие параметры процентных рисков являются базовой (исходной) точкой. Возможные значения:
    • «Да»;
    • «Нет»

    * - при включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» значение отображается с учетом временной зоны компьютера, на котором запущен терминал QUIK

    Доступные функции

    Данные из таблицы доступны для вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы


Настройка таблицы

  1. «Набор параметров» - выбор отображаемых параметров и настройка их очередности.

См. также Таблица параметров процентных рисков.


Таблица параметров рыночных рисков

меню Создать окно / Параметры рыночных рисков [ЦК]
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Таблица содержит информацию о диапазоне оценки рыночных рисков сделок РЕПО.

    Формат таблицы

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
Код инструмента | Код инструмента
Инструмент сокр. | Краткое наименование инструмента
Инструмент | Полное наименование инструмента
Код класса | Код класса инструмента
Класс | Наименование класса инструмента
Диапазон | Диапазон количества инструментов
Начало диапазона | Минимальное количество инструментов
Конец диапазона | Максимальное количество инструментов
Дисконт, % | Ставка рыночного риска, %
Ставка риска падения цены, % | Ставка риска падения цены, %
Ставка риска роста цены, % | Ставка риска роста цены, %
Нижняя граница, руб | Нижняя граница цены, руб
Верхняя граница, руб | Верхняя граница цены, руб
Начало диапазона, руб | Минимальное количество инструментов, руб
Конец диапазона, руб | Максимальное количество инструментов, руб
Расчетная цена | Расчетная цена с точностью инструмента, руб
* Время изменения ставок риска | Время изменения ставок риска в формате «ЧЧММСС»
Валюта ставки риска | Валюта ставки риска

    * - при включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» значение отображается с учетом временной зоны компьютера, на котором запущен терминал QUIK

    Доступные функции

    Данные из таблицы доступны длявывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы


Настройка таблицы

  1. «Набор параметров» - выбор отображаемых параметров и настройка их очередности.

См. также Таблица параметров рыночных рисков.


Таблица «Индивидуальные риск параметры»

меню Создать окно / Индивидуальные риск параметры [ЦК]
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Таблица содержит информацию об индивидуальных параметрах риска для сделок РЕПО.

    Формат таблицы

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Фирма | Идентификатор фирмы
    Торговый счет | Торговый счет
    Код позиции | Идентификатор расчетного счета в НКЦ
    Код инструмента | Код инструмента
    Инструмент сокр. | Краткое наименование инструмента
    Инструмент | Полное наименование инструмента
    Код класса | Код класса инструмента
    Класс | Наименование класса инструмента
    Коэф. НКЦ | Коэффициент, установленный Клиринговым центром на текущую дату
    Коэф. НКЦ на завтра | Коэффициент, установленный Клиринговым центром на дату, следующую за текущей
    Коэф. пользователя | Коэффициент, установленный пользователем на текущую дату
    Коэф. Пользователя на завтра | Коэффициент, установленный пользователем на дату, следующую за текущей
    Прием в обеспечение Признак приема в обеспечение. Возможные значения:
    • «Да»;
    • «Нет»

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы


Настройка таблицы

  1. «Набор параметров» - выбор отображаемых параметров и настройка их очередности.

См. также Таблица «Индивидуальные риск параметры».


Таблица «Обязательства и требования по деньгам [Валюта]»

меню Создать окно / Обязательства и требования по деньгам [Валюта]
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Таблица содержит информацию об обязательствах и требованиях по деньгам на валютном рынке.

    Формат таблицы

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
Класс | Код класса инструмента
Фирма | Идентификатор фирмы
Код инструмента | Код инструмента
Код позиции | Идентификатор расчетного счета/кода в клиринговой организации
Дата расчетов | Дата расчетов
Вх. по требованиям | Размер денежных требований на начало дня, с точностью до 2 знака после десятичного разделителя
Вх. по обязательствам | Размер денежных обязательств на начало дня, с точностью до 2 знака после десятичного разделителя
Нетто | Нетто
Требования | Размер денежных требований
Обязательства | Размер денежных обязательств
В заявках на покупку | Количество инструментов с точностью количества инструмента в заявках на покупку
В заявках на продажу | Количество инструментов с точностью количества инструмента в заявках на продажу
Плановая Т+ | Плановая позиция Т+
Входящая позиция под исполнение | Обязательства и требования на утро текущего дня. Рассчитывается по формуле: «Входящие требования» + «Входящие обязательства»
Плановая позиция под исполнение | Обязательства и требования на текущий момент с исполнением «сегодня», с учётом активных заявок. Рассчитывается по формуле: «Сумма в заявках на покупку» + «Сумма в заявках на продажу»

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание применения быстрого фильтра.
    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

См. также Таблица «Обязательства и требования по деньгам [Валюта]».


Таблица «Обязательства и требования по активам [Валюта]»

меню Создать окно / Обязательства и требования по активам [Валюта]
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Таблица содержит информацию об обязательствах и требованиях по активам на валютном рынке.

    Формат таблицы

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
Фирма | Идентификатор фирмы
Код инструмента | Код инструмента
Торговый счет | Торговый счет
Дата расчетов | Дата расчетов
Инструмент сокр. | Краткое наименование инструмента
Инструмент | Полное наименование инструмента
Код класса | Код класса инструмента
Класс | Наименование класса инструмента
Код позиции | Идентификатор расчетного счета в НКЦ
Обязательства | Размер денежных обязательств
Требования | Размер денежных требований
Сумма в заявках на покупку | Сумма денежных средств в заявках на покупку
Сумма в заявках на продажу | Сумма денежных средств в заявках на продажу
Возврат КВ | Сумма возврата компенсационного перевода
Плановая Т+ | Плановая позиция Т+
Входящие обязательства | Размер денежных обязательств на начало дня, с точностью до 2 знака после десятичного разделителя
Входящие требования | Размер денежных требований на начало дня, с точностью до 2 знака после десятичного разделителя
Входящая позиция под исполнение | Обязательства и требования на утро текущего дня. Рассчитывается по формуле: «Входящие требования» + «Входящие обязательства»
Текущая позиция под исполнение | Обязательства и требования на текущий момент. Рассчитывается по формуле: «Требования» + «Обязательства»
Плановая позиция под исполнение | Обязательства и требования на текущий момент с исполнением «сегодня», с учётом активных заявок. Рассчитывается по формуле: «Сумма в заявках на покупку» + «Сумма в заявках на продажу»

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы


Настройка таблицы

  1. «Набор параметров» - выбор отображаемых параметров и настройка их очередности.

См. также Таблица «Валюта: обязательства и требования по активам».


Таблица «Валюта: параметры процентных рисков»

меню Создать окно / Параметры процентных рисков [Валюта]
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Таблица содержит информацию по текущим параметрам процентных рисков валютных сделок.

    Формат таблицы

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
Код инструмента | Код инструмента
Инструмент сокр. | Краткое наименование инструмента
Инструмент | Полное наименование инструмента
Код класса | Код класса инструмента
Класс | Наименование класса инструмента
Дата расчетов | Дата расчетов
Диапазон | Диапазон количества инструментов
Начало диапазона | Минимальное количество инструментов
Конец диапазона | Максимальное количество инструментов
Нижняя граница курса | Нижняя граница изменения курса
Центральный курс | Центральный курс
Верхняя граница курса | Верхняя граница изменения курса
Начало диапазона, руб | Минимальное количество инструментов, руб
Конец диапазона, руб | Максимальное количество инструментов, руб
Время изменения ставок риска | Время изменения ставок риска. Формат определяется настройками операционной системы

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы


Настройка таблицы

  1. «Набор параметров» - выбор отображаемых параметров и настройка их очередности.

См. также Таблица «Валюта: параметры процентных рисков».


Таблица «Валюта: параметры рыночных рисков»

меню Создать окно / Параметры рыночных рисков [Валюта]
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Таблица содержит информацию о диапазоне оценки рыночных рисков валютных сделок.

    Формат таблицы

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
Код инструмента | Код инструмента
Инструмент сокр. | Краткое наименование инструмента
Инструмент | Полное наименование инструмента
Код класса | Код класса инструмента
Класс | Наименование класса инструмента
Диапазон | Диапазон количества инструментов
Начало диапазона | Минимальное количество инструментов
Конец диапазона | Максимальное количество инструментов
Нижняя граница курса | Нижняя граница изменения курса
Верхняя граница курса | Верхняя граница изменения курса
Начало диапазона, руб | Минимальное количество инструментов, руб
Конец диапазона, руб | Максимальное количество инструментов, руб
Центральный курс | Центральный курс
* Время изменения ставок | Время изменения ставок риска. Формат определяется настройками операционной системы
Ставка риска падения курса, % | Ставка риска падения курса, %
Ставка риска роста курса, % | Ставка риска роста курса, %
Валюта ставки риска | Валюта ставки риска

    * - при включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» значение отображается с учетом временной зоны компьютера, на котором запущен терминал QUIK

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы


Настройка таблицы

  1. «Набор параметров» - выбор отображаемых параметров и настройка их очередности.

См. также Таблица «Валюта: параметры рыночных рисков».


Таблица «Валюта: индивидуальные риск параметры»

меню Создать окно / Индивидуальные риск параметры [Валюта]
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Таблица содержит информацию об индивидуальных параметрах риска на валютном рынке.

    Формат таблицы

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Фирма | Идентификатор фирмы
    Код инструмента | Код инструмента
    Торговый счет | Торговый счет
    Код позиции | Идентификатор расчетного счета в НКЦ
    Инструмент сокр. | Краткое наименование инструмента
    Инструмент | Полное наименование инструмента
    Код класса | Код класса инструмента
    Класс | Наименование класса инструмента
    Коэффициент для нижней границы курса | Коэффициент для нижней границы курса
    Коэффициент для верхней границы курса | Коэффициент для верхней границы курса
    Коэф. НКЦ | Коэффициент, установленный Клиринговым центром на текущую дату
    Коэф. НКЦ на завтра | Коэффициент, установленный Клиринговым центром на дату, следующую за текущей
    Коэф. пользователя | Коэффициент, установленный пользователем на текущую дату
    Коэф. Пользователя на завтра | Коэффициент, установленный пользователем на дату, следующую за текущей
    Прием в обеспечение Признак приема в обеспечение. Возможные значения:
    • «Да»;
    • «Нет»

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы


Настройка таблицы

  1. «Набор параметров» - выбор отображаемых параметров и настройка их очередности.

См. также Таблица «Валюта: индивидуальные риск параметры».


Таблица «Валюта: межпродуктовые спреды»

меню Создать окно / Межпродуктовые спреды [Валюта]
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Таблица содержит информацию о межпродуктовых спредах на валютном рынке.

    Формат таблицы

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
Фирма | Идентификатор фирмы
Код инструмента | Код инструмента
Код инструмента 2 | Код второго инструмента
Код класса | Код класса инструментов
Класс | Наименование класса инструментов
Ставка скидка | Ставка скидки по межпродуктовому спреду

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы


Настройка таблицы

  1. «Набор параметров» - выбор отображаемых параметров и настройка их очередности.

См. также Таблица «Валюта: межпродуктовые спреды».


Таблица обязательств маркет-мейкеров по фондовому и валютному рынкам

меню Создать окно / Обязательства ММ по фондовому и валютному рынкам
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Таблица предназначена для отслеживания выполнения маркет-мейкером своих обязательств на рынке ценных бумаг.

    Формат таблицы

    Каждая строка таблицы отображает информацию о выполнении маркет-мейкером обязательств по отдельному инструменту.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    * Фирма | Идентификатор участника торгов в торговой системе
    * Класс | Наименование класса инструментов
    * Код инструмента | Код инструмента в торговой системе
    * Инструмент сокр. | Краткое наименование инструмента
    Нарушение МДО-Покупка Индикатор нарушения минимально допустимого объема (МДО) на покупку:
    • «Да» - МДО-Покупка нарушен;
    • «Нет» - не нарушен
    Нарушение МДО-Продажа Индикатор нарушения минимально допустимого объема на продажу:
    • «Да» - МДО-Продажа нарушен;
    • «Нет» - не нарушен
    * Покупка | Объем активных лимитированных заявок на покупку, выраженный в лотах
    * Продажа | Объем активных лимитированных заявок на продажу, выраженный в лотах
    * МДО-Покупка | Минимально допустимый объем в лотах на покупку для маркет-мейкера
    * МДО-Продажа | Минимально допустимый объем в лотах на продажу для маркет-мейкера
    Минимум | Минимальная цена активной лимитированной заявки на покупку
    Максимум | Максимальная цена активной лимитированной заявки на продажу
    Минимум доп. | Минимальная допустимая цена активной лимитированной заявки на покупку
    Максимум доп. | Максимальная допустимая цена активной лимитированной заявки на продажу
    * Спред, % | Величина текущего спреда маркет-мейкера в процентах
    * Спред макс., % | Допустимый коридор колебания цены в процентах
    Время перерыва | Общее время нарушения маркет-мейкером своих обязательств по поддержке котировок
    * Нарушение обязательств Индикатор нарушения маркет-мейкером своих обязательств в данный момент
    • «Да» - обязательства маркет-мейкера нарушены;
    • «Нет» - не нарушены
    * Время выполнения | Общее время выполнения обязательств по МДО и спреду
    * Исполнение обязательства Индикатор исполнения маркет-мейкером своих обязательств в данный момент
    • «Да» - обязательства маркет-мейкера исполняются;
    • «Нет» - не исполняются
    * Объем | Текущий объем заключенных сделок в лотах
    * Объем пред. | Установленный объем сделок, при достижении которого изменяется тип котирования с двухстороннего на одностороннее или на освобождение от котирования, в лотах
    Котировальный перерыв | Максимально допустимое время нарушения маркет мейкером своих обязательств по поддержке котировок
    * Котирование Тип котирования в текущий момент:
    • «Пусто» – не требуется;
    • «Одностороннее» - только покупка или продажа;
    • «Двухстороннее» - покупка и продажа
    * Тип обязательств Тип обязательства:
    • «обязательство маркет-мейкера»;
    • «обязательство специалиста»
    * Процент исполнения | Выполнение обязательств, в процентах
    * Оставшееся время до исполнения | Оставшееся время до исполнения обязательств
    * Время обновления | Время обновления. Формат определяется настройками операционной системы

    * - параметры, выбранные по умолчанию

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Параметры настройки таблицы


Параметры настройки таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.
  2. «Фильтр фирм» – настройка фильтрации по кодам фирм.
  3. «Фильтр инструментов» – настройка фильтрации по кодам инструментов.
  4. «Выделять нарушение» – включает выделение красным цветом строк с информацией об инструментах, по которым маркет-мейкер нарушил свои обязательства (в соответствии со значением поля «Нарушение обязательств»).

См.также Таблица обязательств маркет-мейкеров по фондовому и валютному рынкам.


Таблица расширенных обязательств маркет-мейкеров по фондовому и валютному рынкам

меню Создать окно / Расширенные обязательства маркет-мейкера
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Таблица предназначена для отслеживания выполнения маркет-мейкером своих обязательств на рынке ценных бумаг.

    Обязательства по кодам клиентов и инструментам транслируются пользователям с правами на класс и соответствующий код клиента.

    Формат таблицы

    Каждая строка таблицы отображает информацию об обязательствах по отдельному коду клиента.

    В столбцах таблицы отображаются следующие параметры:
    Параметр | Значение
    * Фирма | Идентификатор участника торгов в торговой системе
    * Код класса | Код класса инструментов
    Класс | Наименование класса инструментов
    * Код инструмента | Код инструмента в торговой системе
    Инструмент | Наименование инструмента
    Инструмент сокр. | Краткое наименование инструмента
    * Идентификатор | Идентификатор записи маркет-мейкинга в ТС
    * Идентификатор родительской записи | Идентификатор родительской записи маркет-мейкинга в ТС
    * Торговый счет | Код торгового счета клиента
    * Код клиента | Код клиента
    * Схема | Наименование схемы маркет-мейкинга
    * Договор | Номер договора с маркет-мейкером
    * Дата договора | Дата подписания договора с маркет-мейкером
    * МДО-Покупка | Минимально допустимый объем в лотах на покупку для маркет-мейкера
    * МДО-Покупка, руб | Минимально допустимый объем в рублях на покупку для маркет-мейкера
    * МДО-Продажа | Минимально допустимый объем в лотах на продажу для маркет-мейкера
    * МДО-Продажа, руб | Минимально допустимый объем в рублях на продажу для маркет-мейкера
    * ДО | Установленный объем сделок, при достижении которого изменяется тип котирования с двухстороннего на одностороннее или на освобождение от котирования, в лотах
    * ДО, руб | Установленный объем сделок, при достижении которого изменяется тип котирования с двухстороннего на одностороннее или на освобождение от котирования, в рублях
    * Мин.пассив.объем, руб | Минимальный объем пассивных сделок, выраженный в рублях
    * Макс.спред, % | Допустимый коридор колебания цены в процентах
    * Макс.спред на покупку, % | Предельное отклонение цены заявки на покупку от расчетной цены, в процентах
    * Макс.спред на продажу, % | Предельное отклонение цены заявки на продажу от расчетной цены, в процентах
    * Макс.спред | Допустимый коридор колебания цены, в рублях
    * Мин.время поддерж. | Минимальное время поддержания. Формат определяется настройками операционнойсистемы
    * Мин. % исполнения | Минимальный процент исполнения
    * Спред, % | Величина текущего спреда маркет-мейкера, в процентах
    * Спред на покупку, % | Отклонение цены заявки на покупку от текущей цены, в процентах
    * Спред на продажу, % | Отклонение цены заявки на продажу от текущей цены, в процентах
    * Спред | Величина текущего спреда маркет-мейкера, в рублях
    * Минимум | Минимальная цена активной лимитированной заявки на покупку
    * Максимум | Максимальная цена активной лимитированной заявки на продажу
    * Покупка | Объем активных лимитированных заявок на покупку, в лотах
    * Продажа | Объем активных лимитированных заявок на продажу, в лотах
    * Текущая цена | Текущая расчетная цена
    Нарушение обязательств Индикатор нарушения маркет-мейкером своих обязательств в данный момент. Возможные значения:
    • «Да» – обязательства маркет-мейкера нарушены;
    • «Нет» – не нарушены
    * Перерыв, время | Общее время нарушения маркет-мейкером своих обязательств по поддержке котировок. Формат определяется настройками операционнойсистемы
    * Выполнение, время | Общее время выполнения обязательств по МДО и спреду. Формат определяется настройками операционнойсистемы
    * Выполнение на покупку, время | Фактическое время поддержания заявок на покупку. Формат определяется настройками операционнойсистемы
    * Выполнение на продажу, время | Фактическое время поддержания заявок на продажу. Формат определяется настройками операционнойсистемы
    * Объем | Текущий объем заключенных сделок, в лотах
    * Объем, руб. | Текущий объем заключенных сделок, в рублях
    * Пассивное количество | Текущий объем заключенных пассивных сделок, в лотах
    * Пассивный объем | Текущий объем заключенных пассивных сделок, в рублях
    * Котирование Тип котирования в текущий момент. Возможные значения:
    • «Не требуется»;
    • «Одностороннее» – только покупка или продажа;
    • «Двухстороннее» – покупка и продажа;
    • «Не применимо»
    * % исполнения | Процент исполнения
    * % исполнения на покупку | Процент исполнения на покупку
    * % исполнения на продажу | Процент исполнения на продажу
    * До исполнения, время | Время, оставшееся до исполнения обязательств. Формат определяется настройками операционнойсистемы
    *, ** Время обновления | Время обновления. Формат определяется настройками операционнойсистемы
    * Обязательства исполнены Признак исполнения обязательств. Возможные значения:
    • «Да» – обязательства исполнены;
    • «Нет» – не исполнены
    * Минимум доп. | Минимальная допустимая цена активной лимитной заявки на покупку
    * Максимум доп. | Максимальная допустимая цена активной лимитной заявки на продажу
    * Покупка, руб. | Объем активных лимитированных заявок на покупку, в рублях
    * Продажа, руб. | Объем активных лимитированных заявок на продажу, в рублях
    * Тип поддерживаемого спреда | Тип поддерживаемого спреда
    Фикс. ставка РЕПО ЦБ ON, % | Фикс. ставка РЕПО ЦБ ON, в процентах
    Ставка RuRepo ON, % | Ставка RuRepo ON, в процентах
    Ставка MosPrime ON, % | Ставка MosPrime ON, в процентах
    Мин. обяз. кол-во выпусков | Минимальное обязательное количество выпусков
    Выполн. по кол-ву выпусков | Количество выполненных выпусков

    * - параметры, выбранные по умолчанию

    ** - при включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» значение отображается с учетом временной зоны компьютера, на котором запущен терминал QUIK

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Параметры настройки таблицы


Параметры настройки таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.
  2. «Фильтр фирм» – настройка фильтрации по кодам фирм.
  3. «Фильтр инструментов» – настройка фильтрации по кодам инструментов.
  4. «Фильтр клиентов» – настройка фильтрации по полю кодам клиентов.
  5. «Выделять нарушение» – включает выделение красным цветом строк с информацией об инструментах, по которым маркет-мейкер нарушил свои обязательства (в соответствии со значением поля «Нарушение обязательств»).

См.также Таблица расширенных обязательств маркет-мейкеров по фондовому и валютному рынкам.


Таблица обязательств маркет-мейкеров по срочному рынку

меню Создать окно / Обязательства маркет-мейкера по срочному рынку
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Таблица предназначена для отслеживания выполнения маркет-мейкером своих обязательств на срочном рынке.

    Формат таблицы

    Каждая строка таблицы отображает информацию о выполнении маркет-мейкером обязательств по отдельному инструменту.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Фирма | Идентификатор участника торгов в торговой системе
    Класс | Наименование класса инструментов
    Код инструмента | Идентификатор инструмента в торговой системе
    Торговый счет | Код торгового счета клиента
    Спред по договору | Величина текущего спреда маркет-мейкера по договору
    Кол-во по договору | Количество спредов по договору
    Спред в пунктах | Величина спреда, в пунктах
    *Дата начала периода | Дата начала периода действия правил маркет-мейкера
    *Дата окончания периода | Дата окончания периода действия правил маркет-мейкера
    *Время начала периода | Время начала периода действия правил маркет-мейкера. Формат определяется настройками операционной системы
    *Время окончания периода | Время окончания периода действия правил маркет-мейкера. Формат определяется настройками операционной системы
    Спред (нарушение) Признак того, держится спред или нет. Возможные значения:
    • «Нет» – спред держится;
    • «Да» – спред не держится
    Кол-во (нарушение) Признак того, держится количество или нет. Возможные значения:
    • «Нет» – количество держится;
    • «Да» – количество не держится
    Продажа (Цена худшей заявки) | Цена худшей заявки на продажу, вошедшей в спред
    Покупка (Цена худшей заявки) | Цена худшей заявки на покупку, вошедшей в спред
    Продажа (Кол-во контрактов в заявках) | Количество контрактов в заявках на продажу, входящих в спред
    Покупка (Кол-во контрактов в заявках) | Количество контрактов в заявках на покупку, входящих в спред
    Процент выполнения Обязательств | Выполнение обязательств, в процентах
    Смещение от центрального страйка | Смещение от центрального страйка (действительно только для опционов)
    % min исполнения обязательств | роцент минимального исполнения обязательств за торговую сессию
    % частичного исполнения обязательств | Процент частичного исполнения обязательств за торговую сессию
    % полного исполнения обязательств | Процент полного исполнения обязательств за торговую сессию
    Идентификатор обязательства ММ | Идентификатор обязательства ММ

    * - при отображении параметров учитывается настройка клиентского места «Показывать дату и время торговых данных с учетом локальной временной зоны» см. Настройки клиентского места системы QUIK

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Параметры настройки таблицы


Параметры настройки таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.
  2. «Фильтр фирм» – настройка фильтрации по кодам фирм.
  3. «Фильтр инструментов» – настройка фильтрации по кодам инструментов.
  4. «Выделять нарушение» – включает выделение красным цветом строк с информацией об инструментах, по которым маркет-мейкер нарушил свои обязательства (в соответствии со значением поля «Нарушение обязательств»).

См.также Таблица обязательств маркет-мейкеров по срочному рынку.


Таблица истории значений параметров

меню Создать окно / Таблица Истории...
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Отслеживание динамики изменения параметров инструментов в табличной форме.

    Формат таблицы

    Столбцы таблицы задаются парами данных инструмент - параметр, определяемыми пользователем. Строки таблицы содержат время изменения параметров. Новая строка формируется при изменении какого-либо параметра в столбцах таблицы. Таким образом, каждая ячейка таблицы отображает состояние выбранного параметра инструмента в определенный момент времени.

    Значения полей параметров указаны в Приложении. Списки доступных для построения таблицы инструментов и параметров зависят от настройки потока данных.

    Рекомендации:
    1. В большинстве случаев не требуется отслеживать в одной таблице изменение параметров по разным инструментам, поэтому рекомендуется создавать для каждого инструмента отдельную таблицу.
    2. Не включайте в Таблицу статические параметры типа «Цена открытия», которые не изменяются в течение сессии.
    3. Таблица истории формируется на сервере QUIK опросом состояния параметров торгов через малые интервалы времени и может пропускать изменения параметров, следующие одно за другим в течение малого промежутка времени (например, несколько последовательных сделок по одному инструменту). Для экспорта информации по сделкам используйте Таблицу обезличенных сделок.
    4. Если Таблица истории используется для экспорта данных и произошел обрыв связи с сервером, то для корректного заполнения пропущенных данных необходимо после восстановления связи с сервером прекратить экспорт, дождаться получения пропущенных данных и начать экспорт данных заново. Флажок «Получать пропущенные данные» в меню Система/Настройки/Основные настройки..., раздел «Программы» / «Сохранение данных» должен быть включен.

    При включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» дата и время биржевых данных в таблице отображаются с учетом временной зоны компьютера, на котором запущен терминал QUIK.

    Доступные функции

    Данные из таблицы доступны для копирования и вывода через DDE-сервер.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Формат сохранения в текстовый файл.


Параметры настройки таблицы

  1. «Доступные инструменты» – выбор инструмента, значения параметров которого необходимо отслеживать.
  2. «Сортировать по дате погашения» – включает сортировку инструментов в таблице по возрастанию параметра «Дата погашения». Функция доступна для инструментов с фиксированным сроком обращения.
  3. «Доступные параметры», «Отслеживаемые параметры» – выбор отслеживаемых параметров из списка доступных и настройка их очередности. Список доступных параметров определяется выбранным инструментом.

См.также Таблица истории значений параметров.


Таблица изменений параметров

меню Создать окно / Таблица Изменений...
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Отслеживание динамики изменения однотипных параметров для разных инструментов в табличной форме.

    Формат таблицы

    Растущая вниз таблица, столбцами которой являются выбранные пользователем параметры, а строки фиксируют изменения этих параметров в определенный момент времени по какому-либо инструменту, выбранному пользователем. Отличается от таблицы истории тем, что один параметр может относиться к разным инструментам, при этом инструмент отображается во втором фиксированном столбце таблицы.

    Значения полей параметров указаны в Приложении. Списки доступных для построения таблицы инструментов и параметров зависят от Настройки потока данных.

    1. Используйте данный тип таблицы для экспорта параметров спроса и предложения, а также суммарной информации по рынку. Для экспорта информации о сделках используйте Таблицу обезличенных сделок.
    2. Если таблица изменений используется для экспорта данных, и произошел обрыв связи с сервером, то для корректного заполнения пропущенных данных необходимо после восстановления связи с сервером прекратить экспорт, дождаться получения пропущенных данных (флажок «Получать пропущенные данные» в меню Система/Настройки/Основные настройки..., раздел «Программы» / «Сохранение данных» должен быть включен) и начать экспорт данных заново.

    При включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» дата и время биржевых данных в таблице отображаются с учетом временной зоны компьютера, на котором запущен терминал QUIK.

    Доступные функции

    Данные из таблицы доступны для копирования и вывода через DDE-сервер.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Формат сохранения в текстовый файл.


Параметры настройки таблицы

Для таблицы определяется список инструментов, по которым отображаются изменения параметров. Список настраивается с помощью Фильтра инструментов по стандартным правилам работы с фильтрами.

См.также Таблица изменений параметров.


Позиции участника по деньгам

меню Создать окно / Позиции участника по деньгам
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр денежных остатков участника торгов на счетах в торговой системе.

    Формат таблицы

    Каждая строка таблицы отображает состояние отдельного счета в торговой системе.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Фирма | Идентификатор участника торгов в торговой системе
    Валюта | Код валюты, в которой выражен остаток на счете
    Код позиции | Код позиции (например, ГЦБ, НГЦБ, РПС), по сделкам на которой осуществляются расчеты с данного счета
    Описание | Описание кода позиции
    * Входящий | Остаток денежных средств на счете участника торгов в Расчетной системе до начала торгов
    * Текущий | Текущий остаток денежных средств участника торгов с учетом сделок за день
    * Плановый Остаток денежных средств с учетом исполнения активных заявок на покупку
    «Плановый» = «Текущий» - «На покупку (в заявках)»
    * на покупку (в заявках) | Суммарный объем активных заявок на покупку в денежном выражении
    * на продажу (в заявках) | Суммарный объем активных заявок на продажу в денежном выражении
    Нетто Нетто-позиция,
    «Нетто» = «Текущий» - «На покупку (в заявках)» + «На продажу (в заявках)»
    Внутр. огр. | Собственное ограничение по деньгам. Параметр устанавливается с рабочего места Московской Биржи
    Внеш. огр. | Внешнее ограничение для фирмы (работает только на рынке ГЦБ и на валютном рынке)
    Депонировано на продажу | Не используется
    Депонировано на покупку | Не используется
    * Всего на счете Суммарный объем средств,
    «Всего на счете» = «Текущий» – «Внеш.огр.»
    * Доступно Объем средств, доступных для ввода новых заявок
    «Доступно» = «Плановый» – «Внеш.огр.»
    В заявках на покупку | Объем активных заявок на покупку - суммарный неудовлетворенный объем всех активных заявок на покупку, в денежном выражении. Объем заявки в денежном выражении рассчитывается с учетом комиссионного сбора Биржи и накопленного купонного дохода
    В заявках на продажу | Объем активных заявок на продажу - суммарный неудовлетворенный объем всех активных заявок на продажу, в денежном выражении. Объем заявки в денежном выражении рассчитывается с учетом комиссионного сбора Биржи и накопленного купонного дохода
    Контрольная Контрольная позиция простого клиринга.
    «Контрольная» = «Входящая позиция» - «Плановая позиция»
    Дебет | Суммарный объем зачисленных на счет денежных средств
    Кредит | Суммарный объем списанных со счета денежных средств
    Идентификатор счета | Идентификатор расчетного счета в НКЦ (расчетный код)
    Марж. требование | Маржинальное требование на начало торгов
    Расчетная | Плановая позиция после проведения расчетов
    Флаг включенного внешнего ограничения Признак установленного внешнего ограничения. Возможные значения:
    • «Да»;
    • «Нет»
    Флаг включенного внутреннего ограничения Признак установленного внутреннего ограничения. Возможные значения:
    • «Да»;
    • «Нет»
    Группа позиций Наименование группы денежной позиции. Возможные значения:
    • «Позиции по лимитам»;
    • «Позиции по средствам»;
    • «Позиции по инструментам»;
    • «Позиции по сделкам»;
    • «Позиции под исполнение»;
    • «Позиции по валютам»;
    • «Позиции для ФК»

    * - с учетом комиссии биржи и накопленного купонного дохода

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер, экспорта по ODBC и сохранения в текстовый файл.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Сохранить в файл денежные позиции из таблицы» – записать в файл только те позиции, которые отображены в таблице.
    • «Сохранить в файл все денежные позиции» – записать в файл все имеющиеся позиции без учета настроек таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Параметры настройки таблицы
    • Формат сохранения в текстовый файл


Параметры настройки таблицы

  1. «Имя таблицы» позволяет задать разные названия для таблиц одинакового типа, например, «Денежные позиции ММВБ», «Денежные позиции РТС».
  2. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.
  3. «Фильтр фирм» – настройка фильтрации по кодам фирм.
  4. «Фильтр валют» – настройка фильтрации по кодам валют. Настройка позволяет разнести счета, номинированные в разных валютах, в разные таблицы.
  5. «Фильтр кодов позиции» – фильтрация по кодам позиций. Если фильтр установлен, то в таблице отображается информация только по счетам, предназначенным для работы с определенными режимами торгов (например, для расчетов в РПС).

См. также:

  • Позиции участника по деньгам
  • Формат сохранения в текстовый файл


Позиции участника по инструментам

меню Создать окно / Позиции участника по инструментам
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр суммарных позиций участника торгов, выраженных в единицах инструментов, на счетах депо.

    Формат таблицы

    Каждая строка таблицы отображает позиции по отдельному инструменту.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
Фирма | Идентификатор участника торгов в торговой системе
Название инструмента | Наименование инструмента
Код инструмента | Код инструмента в торговой системе биржи
Входящий | Количество инструментов на начало торгов (до совершения сделок)
Текущий | Количество инструментов с учетом заключенных сделок за текущую торговую сессию
Покупка план. | Количество инструментов в активных заявках на покупку
Продажа план. | Количество инструментов в активных заявках на продажу
Куплено | Купленное в течение торговой сессии количество инструментов, включенное в многосторонний клиринг
Продано | Проданное в течение торговой сессии количество инструментов, включенное в многосторонний клиринг

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Двойное нажатие левой кнопки мыши» – открыть таблицу «Позиции участника по торговым счетам» для инструмента, указанного в выбранной строке.
    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Параметры настройки таблицы.


Параметры настройки таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.
  2. «Фильтр фирм» – настройка фильтрации по кодам фирм.
  3. «Фильтр инструментов» – настройка фильтрации по кодам инструментов.

См. также Позиции участника по инструментам.


Позиции участника по торговым счетам

меню Создать окно / Позиции участника по торговым счетам...
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр позиций по одному инструменту на разных счетах депо.

    Формат таблицы

    Наименование инструмента указывается в заголовке таблицы. Каждая строка таблицы содержит информацию об остатках этого инструмента на отдельном счете депо.

    В столбцах таблицы отображаются следующие параметры, отражающие состояние счета:

    Список отображаемых параметров зависит от выбранного инструмента и не редактируется.

    Параметр | Значение
    Код инструмента | Код инструмента в торговой системе
    Название инструмента | Наименование инструмента в торговой системе
    Фирма | Код участника торгов в торговой системе
    Торговый счет | Счет депо в торговой системе
    Счет депо | Счет депо в депозитарии
    Входящий | Количество инструментов на начало торгов (до совершения сделок)
    Текущий | Количество инструментов с учетом заключенных сделок за текущую торговую сессию
    Покупка план. | Количество инструментов в активных заявках на покупку
    Продажа план. | Количество инструментов в активных заявках на продажу
    Контрольный | Контрольный остаток простого клиринга. Контрольный остаток равен входящему остатку минус плановая позиция на продажу, включенная в простой клиринг
    Куплено | Купленное в течение торговой сессии количество инструментов, включенное в многосторонний клиринг
    Продано | Проданное в течение торговой сессии количество инструментов, включенное в многосторонний клиринг
    Плановый | Плановый остаток. Плановый остаток равен текущему остатку минус плановая позиция на продажу
    Идентификатор счета | Идентификатор счета в НКЦ (расчетный код)
    Тип счета Тип счета. Возможные значения:
    • «Торговый»;
    • «Обеспечение»
    Расчетный | Плановая позиция после проведения расчетов
    Плановая позиция Т+ | Плановая позиция Т+
    Внеш. огр. плановой позиции | Внешнее ограничение плановой позиции
    Лимит необеспеченных продаж КЦ | Лимит необеспеченных продаж клирингового центра
    Лимит необеспеченных продаж участника | Лимит необеспеченных продаж участника

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Параметры настройки таблицы.


Параметры настройки таблицы

  1. «Строки» – выбор инструмента из списка доступных, по которому создается таблица. При выборе нескольких инструментов создается отдельная таблица для каждого выбранного инструмента.
  2. «Фильтр фирм» – настройка фильтрации по кодам фирм.
  3. «Фильтр текущих счетов» – настройка фильтрации по счетам депо.

См. также Позиции участника по торговым счетам.


Позиции участника по инструментам на выбранных счетах

меню Создать окно / Позиции участника по инструментам на счетах
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр позиций по инструментам на выбранных счетах депо.

    Формат таблицы

    Строки таблицы соответствуют позициям по определенному инструменту, указанному в поле «Название инструмента», на определенном счете, указанном в поле «Торговый счет». Строки таблицы отсортированы сначала по значению поля «Торговый счет», затем по значению поля «Название инструмента».

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Код инструмента | Код инструмента в торговой системе
    Название инструмента | Наименование инструмента в торговой системе
    Фирма | Код участника торгов в торговой системе
    Торговый счет | Счет депо в торговой системе
    Счет депо | Счет депо в депозитарии
    Входящий | Количество инструментов на начало торгов (до совершения сделок)
    Текущий | Количество инструментов с учетом заключенных сделок за текущую торговую сессию
    Покупка план. | Количество инструментов в активных заявках на покупку
    Продажа план. | Количество инструментов в активных заявках на продажу
    Контрольный | Контрольный остаток простого клиринга. Контрольный остаток равен входящему остатку минус плановая позиция на продажу, включенная в простой клиринг
    Куплено | Купленное в течение торговой сессии количество инструментов, включенное в многосторонний клиринг
    Продано | Проданное в течение торговой сессии количество инструментов, включенное в многосторонний клиринг
    Плановый | Плановый остаток. Плановый остаток равен текущему остатку минус плановая позиция на продажу
    Идентификатор счета | Идентификатор счета в НКЦ (расчетный код)
    Тип счета Тип счета. Возможные значения:
    • «Торговый»;
    • «Обеспечение»
    Расчетный | Плановая позиция после проведения расчетов
    Плановая позиция Т+ | Плановая позиция Т+
    Внеш. огр. плановой позиции | Внешнее ограничение плановой позиции
    Лимит необеспеченных продаж КЦ | Лимит необеспеченных продаж клирингового центра
    Лимит необеспеченных продаж участника | Лимит необеспеченных продаж участника

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Параметры настройки таблицы.


Параметры настройки таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.
  2. «Фильтр торг. счетов» – настройка фильтрации по счетам депо.
  3. «Фильтр фирм» – настройка фильтрации по кодам фирм.
  4. «Фильтр инструментов» – настройка фильтрации по инструментам.

См. также Позиции участника по инструментам на выбранных счетах.


Таблица «Объединенные котировки»

меню Создать окно / Объединенные котировки...
  • Назначение
  • Формат окна
  • Доступные функции

    • Назначение

    Отображение очередей заявок по нескольким инструментам или по инструментам на разных рынках и на разных режимах торгов.

    Возможность ввода заявки с разбиением объема по нескольким классам (торговым площадкам или режимам торгов), подробнее см. Ввод заявки из окна «Объединенные котировки».

    В системе QUIK возможно создание нескольких Таблиц котировок по одному и тому же инструменту для удобства группировки окон на разных экранных вкладках. При этом количество получаемой с сервера информации не увеличивается.

    Формат окна

    Таблица содержит лучшие текущие котировки на покупку/продажу по включенным в нее инструментам, упорядоченные по параметру «Цена». В таблице отображаются все лучшие котировки, транслируемые торговыми системами по выбранным классам.

    В столбцах таблицы отображаются следующие параметры:

    1. В таблице «Объединенные котировки» все объемы отображаются в штуках (а не в лотах), все цены – в рублях.
    2. Если выбран тип окна (2) или (3) с отображением параметров в разных столбцах, то выводится двойной набор параметров: отдельно на покупку и на продажу.

    Параметр | Значение
Цена | Цена котировки, рублей
Количество | Количество в заявках по данной цене, в штуках
Объем | Объем инструментов в заявках по данной цене, в денежных средствах. Котировки по разным классам с одинаковой ценой отображаются отдельными строками
Свой объем | Количество инструментов в штуках, которое суммарно во всех заявках, выставленных по данной цене
Доходность | Доходность инструмента по котировке
Сумма лучших | Количество инструментов в заявках по цене не хуже данной, в штуках. Для котировок с одинаковой ценой отображается сумма лучших по заданной цене
Суммарный объем | Объем в заявках накопленным итогом, в денежных средствах
Символ | Обозначение инструмента, в виде «[код класса] код инструмента»

    Доступные функции

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Новая заявка» (или «F2») (или двойное нажатие левой кнопкой мыши на строке таблицы) – подать новую заявку.
    • «Новая стоп-заявка» (или «F6») – подать новую стоп-заявку.
    • «Объединенная заявка» (или «Ctrl»+«F2») – подать новую объединенную заявку (в зависимости от значения параметра «Разделение объема заявки»).
    • «Выполнить транзакцию» (или «Ctrl»+«T») – выполнить транзакцию, используя Общий способ выполнения транзакций.
    • «Котировки» – открыть обособленное Окно котировок по данному инструменту.
    • «Построить график» (или двойное нажатие правой кнопкой мыши) – открыть график.
    • «Шаблоны» – применить к таблице настроенную в шаблоне конфигурацию.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    Таблица «Объединенные котировки» недоступна для экспорта и сохранения в файл.

    См. также:

    • Настройка таблицы
    • Работа с шаблонами.


Настройка таблицы

  1. «Вид котировочного окна» – настройка расположения котировок в окне:
    • Таблица объединенных котировок может принимать вид:
      • – (1) отображает все параметры в один столбец. При этом лучшая цена покупки отделена от лучшей цены продажи чертой-разделителем.
      • – (1) имеет один общий столбец «Цена». Параметры заявок на покупку и заявок на продажу отображаются в разных столбцах.
      • – (1) отображает параметры спроса и предложения в разных столбцах. При этом котировки на покупку упорядочены по убыванию цены заявки, а котировки на продажу – по возрастанию цены заявки таким образом, что лучшие цены заявок отображаются в первой строке окна.
    • «Взять настройки из шаблона» - загрузить настройки данного окна из ранее сохраненного шаблона.
    • «Покупку показывать сверху» – располагать котировки по возрастанию цены заявки (сверху заявки на покупку, снизу заявки на продажу). Если флажок снят, то котировки располагаются по убыванию цены заявки.
  2. «Выделять котировки цветом» - настройка цвета текста и цвета фона отдельно для котировок на покупку и на продажу. О работе с цветом см. п. Настройка цвета в таблицах и графиках.
    • «Показывать цены с точностью» - количество знаков после десятичного разделителя, отображаемых в поле «Цена».
    • «Набор инструментов» - настройка списка инструментов, котировки по которым включаются в таблицу.

      Для добавления нового инструмента в список нажмите кнопку «Добавить». В открывшемся окне выберите нужный инструмент из списка. Значение параметров окна:

      Параметр | Значение
      Обозначение | Наименование инструмента, которое будет отображаться в окне «Объединенные котировки»
      Счет депо (для заявок) | Счет депо, указываемый при выставлении заявки по данному инструменту
      Код клиента (для заявок) | Код клиента, указываемый в заявке
      Коэффициент пересчета цены * | Коэффициент приведения цен разных торговых систем (режимов торгов)
      Коэффициент пересчета кол-ва *, ** | Коэффициент пересчета объема в лотах в количество единиц инструментов
      Сортировать по дате погашения | Признак автоматической сортировки инструментов в таблице по возрастанию параметра «Дата погашения». Функция доступна для инструментов с фиксированным сроком обращения

      * - коэффициенты используются для сопоставления ликвидности на разных режимах торгов и приведения ценовых показателей к общему знаменателю

      ** - для корректного пересчета цен из других валют в настройках принимаемых данных (меню программы Система/Настройки/Основные настройки… раздел «Программа» / «Получение данных» / «Котировки») должен быть выбран класс «Кросс-курсы валют»; в получаемых параметрах инструментов должны быть выбраны параметры «Валюта номинала» и «Размер лота»

      Изменения сохраняются нажатием кнопки «Да». Нажатием кнопки «Отмена» окно закрывается без сохранения.

      Для изменения настроек инструмента выделите его в списке и нажмите кнопку «Изменить». Кнопка «Удалить» служит для исключения выбранного инструмента из списка, кнопка «Очистить» - для удаления всех инструментов из списка.

      Очередность инструментов в списке изменяется нажатием кнопок [image] и [image] справа от списка. Если для одной и той же цены оказываются действительными несколько различных котировок, то они отображаются раздельно в порядке, заданном в списке. Первые упомянутые инструменты отображаются ближе к середине окна.

      Таблица не может содержать одновременно инструменты класса РЕПО с ЦК и других классов.
    • «Доступные параметры / Заголовки столбцов» – выбор отображаемых параметров и настройка их очередности.

      Нажатие кнопки «Перевернуть» меняет порядок следования заголовков столбцов на обратный.


Работа с шаблонами

  • Просмотр списка шаблонов
  • Создание нового шаблона
  • Применение шаблона
    •

    Шаблон представляет собой конфигурацию таблицы «Объединенные котировки», сохраненную под определенным именем. Такой шаблон можно применить к уже существующим таблицам, а также воспользоваться им для быстрой настройки новой таблицы.

    Просмотр списка шаблонов

    Просмотр списка шаблонов осуществляется через пункт меню Действия / Шаблоны котировочных окон..., либо из аналогичного пункта в контекстном меню, вызванном из таблицы «Объединенные котировки».

    • Настройка шаблона по умолчанию. Выделите в списке доступных шаблонов требуемую конфигурацию окна и нажмите кнопку «Брать по умолчанию». Название шаблона появится в разделе «Шаблон по умолчанию».
    • Переименование шаблона. Выберите нужный шаблон и нажмите кнопку «Переименовать». В открывшемся диалоге введите новое название и нажмите кнопку «Ввод».
    • Удаление шаблона. Нажатие кнопки «Удалить» удаляет выделенный шаблон.
    • Применение шаблона к нескольким окнам. Нажатие кнопки «Применить ко всем окнам» изменяет настройки всех таблиц «Объединенные котировки» в соответствии с выбранным шаблоном, нажатие кнопки «Применить к окнам на вкладке» - к окнам на текущей вкладке. Будьте внимательны при использовании данной функции, поскольку она приводит к изменению списка отображаемых инструментов.

    Создание нового шаблона

    1. Настройте в качестве образца новую таблицу «Объединенные котировки» или сделайте активной одну из существующих.
    2. Выберите пункт Действия / Сохранить в шаблон..., либо аналогичный пункт из контекстного меню на таблице.
    3. Для обновления шаблона выберите его название в открывшемся окне и нажмите кнопку «Сохранить».
    4. Для создания нового шаблона нажмите кнопку «Сохранить как новый». В открывшемся диалоге введите название и нажмите кнопку «Ввод».
    5. Нажмите кнопку «Закрыть».

    Применение шаблона

    Задать настройки ранее сформированной таблицы по шаблону можно из пункта контекстного меню Шаблоны / <Имя шаблона>. При создании новой таблицы также можно вызвать настройки всех параметров окна из шаблона. В поле «Взять настройки из шаблона» отображается список сохраненных шаблонов. Выбором строки этого списка настройки текущего окна изменяются на те, что были сохранены в выбранном шаблоне.

    См. также Настройка таблицы «Объединенные котировки»


Таблица «Карман транзакций»

меню Создать окно / Карман транзакций...
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Формирование списка отложенных заявок и отправка этих заявок в торговую систему выборочно либо одновременно. Таблица «Карман транзакций» представляет собой хранилище сформированных, но не отправленных на сервер заявок пользователя.

    «Карман транзакций» рекомендуется применять для решения следующих задач:

    1. Одновременный ввод большого количества заявок в момент начала торгов. Например, ввод клиентских заявок, принятых брокером до начала торгов. Такие заявки могут быть приняты с голоса и введены непосредственно в окно «Карман транзакций», а затем одномоментно активизированы командой «Достать все из кармана».
    2. Перенос неисполненных поручений предыдущего дня на текущий. До момента закрытия торгов в файл сохраняется содержимое Таблицы заявок, предварительно настроенной на отображение только активных заявок. Перед началом следующей торговой сессии в «Кармане транзакций» выполняется команда «Положить в карман из файла», чтобы прочитать сохраненные активные заявки. При этом параметру «Количество» таблицы «Карман транзакций» сопоставляется параметр «Остаток» из сохраненных заявок.
    3. Одновременный ввод большого количества заявок может быть осложнен необходимостью подтверждения условий каждой заявки. Чтобы избежать этого, отключите флажок «Запрашивать подтверждение» в пункте меню Система/Настройки/Основные настройки..., раздел «Торговля» / «Заявки».
    4. Если требуется создать несколько разных пакетов заявок, отправляемых на биржу одновременно, создайте несколько таблиц «Карман транзакций», например, отдельные таблицы для разных режимов торгов. Для удобства обращения с несколькими однотипными таблицами их можно переименовать по своему усмотрению (поле «Имя таблицы» в диалоге настройки таблицы).

    Формат таблицы

    Каждой заявке в таблице соответствует отдельная строка.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Класс | Наименование класса, к которому относится инструмент в заявке
    Транзакция | Тип операции
    Торговый счет | Код торгового счета, в отношении которого подается поручение
    К/П Направление операции. Возможные значения:
    • «Купля»;
    • «Продажа»
    * Тип Тип заявки. Возможные значения:
    • «рыночная»;
    • «лимитированная»
    * Признак расщепления цены Условие разбиения заявки по ценам. Возможные значения:
    • «По разным ценам»;
    • «По одной цене»
    * Условие исполнения Условие исполнения заявки. Возможные значения:
    • «Поставить в очередь»;
    • «Немедленно или отклонить»;
    • «Снять остаток»;
    • «Аукцион периода закрытия»
    * Тип ввода значения цены Значение какого параметра указано в поле «Цена». Возможные значения:
    • «Цена»;
    • «Доходность»;
    • «Средневзвешенная цена»
    Заявка Маркет-мейкера | Признак заявки маркет-мейкера
    Инструмент | Наименование инструмента в торговой системе
    Цена | Цена за единицу инструмента
    Количество | Количество инструмента в лотах
    Примечание | Код клиента и текстовое примечание, разделенные символом «/»

    * - описание назначений см. Окно «Ввод заявки»

    Доступные функции

    Данные таблицы доступны для копирования. Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Положить в карман» (или «F2», или двойное нажатие левой кнопки мыши) – ввести новую заявку с условиями, аналогичными заявке, на которой стоит курсор.
    • «Изменить в кармане» (или «Ctrl»+«A») – изменить заявку. Недоступно для загруженных из tri-файла транзакций на ввод айсберг-заявки, ввод VWAP-заявки, ввод TWAP-заявки и снятие алго-заявки.
    • «Загрузить заявки из файла» - добавить в таблицу заявки из текстового файла. Формат файла импортируемого должен соответствовать формату файла Таблицы заявок.
    • «Загрузить стоп-заявки из файла» - добавить в таблицу заявки из текстового файла. Формат файла импортируемого должен соответствовать формату файла Таблицы стоп-заявок.

    Файл с загружаемыми стоп-заявками должен быть сформирован текущей версией Рабочего места QUIK. Загрузка данных из файлов, созданных предыдущими версиями программы может быть некорректна.
    • «Загрузить безадресные заявки из файла» - добавить в таблицу заявки из текстового файла. Формат файла импортируемого должен соответствовать формату файла Таблицы безадресных заявок.
    • «Загрузить адресные заявки из файла»– добавить в таблицу заявки из текстового файла. Формат импортируемого файла должен соответствовать формату файла Таблицы заявок на внебиржевые сделки.
    • «Загрузить транзакции из tri-файла» – добавить в таблицу транзакции из tri-файла.
    • «Сохранить транзакции в tri-файл» – сохранить содержимое таблицы «Карман транзакций» в формат универсального tri-файла.
    • «Убрать из кармана» (или «Ctrl»+«D», или двойное нажатие правой кнопки мыши) * – удалить из таблицы выделенную заявку / заявки.
    • «Очистить карман» – удалить из таблицы все заявки.
    • «Достать из кармана» *,** – отправить в торговую систему выделенную заявку / заявки.
    • «Достать все из кармана» ** – отправить в торговую систему все заявки из таблицы.

    (*)
    1. Чтобы выделить сразу несколько параметров по порядку, удерживайте нажатой клавишу «Shift». Чтобы выделить выборочно несколько параметров, удерживайте нажатой клавишу «Ctrl».
    2. Запрос подтверждения при выполнении групповых операций определяется настройкой «Запрашивать подтверждение для групповых операций».
    (** ): Если выделенная заявка (заявки) не прошла контроль дополнительных ограничений, установленных брокером, то на экране отображается диалог с описанием нарушенных ограничений. Исполнение заявки зависит от выбранного в диалоге действия, (настройка «Контроль дополнительных ограничений »). Если в диалоге нажать на кнопку «Закрыть», то завершить обработку транзакции / транзакций можно будет только из Таблицы транзакций.
    Отправленные заявки из таблицы автоматически не удаляются.

    См. также:

    • Описание стандартных функций контекстного меню для таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    Перетаскивание заявок мышью (drag-and-drop)

    Заявки из Таблицы заявок, Таблицы стоп-заявок и Таблицы безадресных заявок на внебиржевые сделки можно переносить в «Карман транзакций». Переносить можно заявки любого статуса (Активна, Исполнена, Снята). Перенос осуществляется следующим образом:

    1. Поместить курсор на выбранную заявку в Таблице заявок (Таблице стоп-заявок, Таблицы безадресных заявок на внебиржевые сделки) и нажать левую кнопку мыши.
    2. Удерживая левую кнопку мыши нажатой, переместить курсор в «Карман транзакций».
    3. Отпустить левую кнопку мыши. Заявка появится в таблице.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Доступные классы» – выбор наименования класса, по инструментам которого планируется создавать поручения.
  2. «Доступные транзакции» – выбор типа операции. Например, для создания заявок – «Ввод заявки».
  3. «Столбцы» – выбор отображаемых параметров и настройка их очередности. Список доступных параметров определяется выбранной транзакцией.

См. также Таблица «Карман транзакций»


Таблица транзакций

меню Создать окно / Таблица транзакций...
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр информации об отправленных транзакциях пользователя. Для пользователя с правом «Показывать клиентские ошибки» данная таблица содержит информацию об отвергнутых транзакциях клиентов его фирмы и его собственных транзакциях.

    Формат таблицы

    Каждой транзакции соответствует отдельная строка таблицы.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    ID транзакции | Уникальный номер транзакции
    Исходный номер | Идентификатор исходной транзакции, присвоенный сервером QUIK. Поле заполняется только для транзакций, которые нарушили дополнительные ограничения
    UID | Код пользователя на сервере QUIK
    Статус Статус транзакции. Возможные значения:
    • «0» - транзакция отправлена серверу;
    • «1» - транзакция получена на сервер QUIK от клиента;
    • «2» - ошибка при передаче транзакции в торговую систему. Так как отсутствует подключение шлюза Московской Биржи, повторно транзакция не отправляется;
    • «3» - транзакция выполнена;
    • «4» - транзакция не выполнена торговой системой. Более подробное описание ошибки отображается в поле «Сообщение»;
    • «5» - транзакция не прошла проверку сервера QUIK по каким-либо критериям. Например, проверку на наличие прав у пользователя на отправку транзакции данного типа;
    • «6» - транзакция не прошла проверку лимитов сервера QUIK;
    • «10» - транзакция не поддерживается торговой системой;
    • «11» - транзакция не прошла проверку правильности электронной цифровой подписи;
    • «12» - не удалось дождаться ответа на транзакцию, т.к. истек таймаут ожидания. Может возникнуть при подаче транзакций из QPILE;
    • «13» - транзакция отвергнута, так как ее выполнение могло привести к кросс-сделке (т.е. сделке с тем же самым клиентским счетом);
    • «14» – транзакция не прошла контроль дополнительных ограничений;
    • «15» – транзакция принята после нарушения дополнительных ограничений;
    • «16» – транзакция отменена пользователем в ходе проверки дополнительных ограничений.

    Статусы 14, 15 и 16 транслируются только пользователям, имеющим право игнорировать дополнительные ограничения на подачу транзакций. Дополнительные ограничения – некоторые из настроенных на сервере QUIK ограничений на подачу транзакций, (подробнее см. руководство «Настройки Библиотеки расчета лимитов», п. 32). Список пользователей, имеющих право игнорировать дополнительные ограничения, определяется брокером. Для пользователей, не имеющих такого права, на транзакциях, нарушающих дополнительные ограничения, транслируется статус 6 (транзакция не прошла проверку лимитов сервера QUIK)
    Статус расширенный | Строка, соответствующая численному значению поля «Статус»
    Сообщение | Сообщение системы при отправке транзакции
    * Дата | Дата выставления транзакции
    * Время | Время отправки транзакции. Формат определяется настройками операционной системы
    Время (мкс) | Время выставления транзакции, в микросекундах
    Номер заявки | Номер заявки в торговой системе
    Код класса | Код класса в торговой системе
    Код инструмента | Идентификатор инструмента в торговой системе
    Операция | Направление операции
    Цена | Цена сделки, за единицу инструмента
    Количество | Количество инструментов с точностью количества инструмента или в лотах
    Остаток | Объем неисполненной части заявки с точностью количества инструмента или в лотах
    Фирма | Идентификатор фирмы в торговой системе
    Счет | Код торгового счета, по которому подана заявка
    Код клиента | Идентификатор клиента в системе QUIK
    Комментарий | Текстовый комментарий
    Биржевой номер | Биржевой номер заявки
    Код ошибки | Численный код ошибки
    Источник ошибки Источник ошибки. Возможные значения:
    • «Торговая система»;
    • «Сервер QUIK»;
    • «Библиотека расчета лимитов»;
    • «Шлюз торговой системы»
    * Дата шлюза | Дата получения ответа шлюзом
    * Время шлюза | Время получения ответа на транзакцию шлюзом
    Время шлюза (мкс) | Время получения ответа на транзакцию шлюзом, в микросекундах
    Транзакция | Наименование транзакции
    ** Номер заявки2 | Номер заявки в торговой системе
    ** Операция2 | Направление операции
    ** Цена2 | Цена сделки, за единицу инструмента
    ** Количество2 | Количество инструментов с точностью количества инструмента или в лотах
    ** Остаток2 | Объем неисполненной части заявки с точностью количества инструмента или в лотах
    ** Фирма2 | Идентификатор фирмы в торговой системе
    ** Счет2 | Код торгового счета, по которому подана заявка
    ** Код клиента2 | Идентификатор клиента в системе QUIK
    ** Код инструмента2 | Идентификатор инструмента в торговой системе
    ** Комментарий2 | Текстовый комментарий
    ** Код биржи2 | Идентификатор биржи
    Время выполнения (мкс) | Разница между локальным временем отправки транзакции и временем ее получения, в микросекундах

    * - при включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» значение отображается с учетом временной зоны компьютера, на котором запущен терминал QUIK

    ** - поля заполняются, если в результате транзакции формируются две заявки

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    • «Новая заявка» (или «F2», или двойное нажатие левой кнопки мыши на строке) – открыть форму ввода новой заявки с условиями, аналогичными транзакции, на которой стоит курсор. Доступно для транзакций ввода заявок, стоп-заявок и адресных заявок.
    • «Оповещение по статусу транзакции» (или «Ctrl»+«Alt»+«A») – создать оповещение по статусу транзакции. Оповещение создается автоматически на основе параметров выделенной транзакции. Просмотреть созданное оповещение можно из таблицы «Окно оповещений».
    • «Контроль дополнительных ограничений» – открыть диалог с описанием нарушенных дополнительных ограничений и запросом на исполнение заявки. Исполнение заявки зависит от выбранного в диалоге действия:
      • «Да» – игнорировать ограничения. Если в процессе проверки исходной транзакции, которая не прошла контроль дополнительных ограничений, сервером QUIK дополнительно найдены нарушенные дополнительные ограничения (отличные от проигнорированных), то в Таблицу транзакций добавляется строка с ответом на транзакцию (при этом исходная транзакция остаётся без изменений), и на экране снова отображается диалог с описанием нарушенных ограничений. Процесс повторяется до выполнения исходной транзакции или до отмены транзакции пользователем. При выполнении статус исходной транзакции изменяется на значение «15» – Транзакция принята после нарушения дополнительных ограничений;
      • «Нет» – отменить транзакцию на подачу заявки. При отмене статус исходной транзакции изменится на значение «16» – Транзакция отменена пользователем в ходе проверки дополнительных ограничений;
      • «Закрыть» – закрыть диалог без исполнения транзакции (с возможностью обработки транзакции позже).

      Функция доступна для транзакций, не прошедших контроль дополнительных ограничений, и только пользователям, имеющим право игнорировать дополнительные ограничения на подачу транзакций. Дополнительные ограничения – некоторые из настроенных на сервере QUIK ограничений на подачу транзакций (подробнее см. руководство «Настройки Библиотеки расчета лимитов», п. 32). Список пользователей, имеющих право игнорировать дополнительные ограничения, определяется брокером.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также: Настройка таблицы


Настройка таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.
  2. «Фильтр счетов» – настройка фильтрации по счетам депо.
  3. «Фильтр кодов клиентов» – настройка фильтрации по кодам клиентов.
  4. «Фильтр фирм» – настройка фильтрации по кодам фирм.
  5. «Статус» – настройка фильтрации по значению поля «Статус»:
    • «Успешные» – в таблице отображаются транзакции только со статусами «3», «15» и «16» (см. поле Статусы);
    • «Отвергнутые» – в таблице отображаются транзакции со статусами, которые отличаются от статусов «3», «15» и «16» (см. поле Статусы).
  6. «Тип» – настройка фильтрации по типу транзакций:
    • «На выставление заявки» – в таблице отображаются транзакции на выставление новых заявок, адресных заявок и стоп-заявок. При этом транзакции на выставление новых заявок, которые привели к нарушению дополнительных ограничений, в таблице не отображаются;
    • «Контроль дополнительных ограничений» – в таблице отображаются транзакции только на выставление новых заявок, которые привели к нарушению дополнительных ограничений (транзакции со статусами «14», «15» и «16» и исходные транзакции – с заданным Исходным номером);
    • «Служебные» – в таблице отображаются технические транзакции;
    • «Прочие» – в таблице отображаются транзакции, которые отличаются от условий «На выставление заявки», «Контроль дополнительных ограничений» и «Служебные».
  7. «Полный текст сообщения» – признак отображения в нижней части таблицы поля с полным текстом сообщения для выбранной транзакции. В поле отображается текст с результатом выполнения транзакции, а для транзакций с нарушением дополнительных ограничений отображается описание всех нарушенных дополнительных ограничений.


Таблица сообщений

меню Создать окно / Таблица сообщений…
  • Назначение
  • Формат таблицы
  • Доступные функции
  • Настройка таблицы сообщений

    • Назначение

    Просмотр всех системных сообщений об ошибках, о загрузке/отключении Плагинов, уведомлений торговой системы и администратора. В таблице отображаются сообщения системы QUIK и Плагинов (модулей и приложений системы QUIK), полученные в ходе текущего сеанса связи, а также сохраненные сообщения предыдущих сеансов.

    Сообщения, отображаемые в данной таблице, также доступны для просмотра в окне «QUIK: окно сообщений».

    Формат таблицы

    Каждая строка таблицы соответствует отдельному системному сообщению.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    * Тип Тип системного сообщения. Возможные значения:
    • – информационное сообщение;
    • – предупреждение;
    • – сообщение об ошибке
    Важность Важность сообщения. Возможные значения:
    • – важное сообщение;
    • <пусто> – обычное сообщение
    *Дата | Дата создания сообщения
    *Время | Время создания сообщения. Формат определяется настройками операционной системы
    *Сообщение | Текст сообщения
    Источник Источник сообщения.
    • для сообщений с сервера QUIK поле не заполняется;
    • для сообщений, поступающих с Плагинов, отображается наименование Плагина
    Категория | Категория сообщения. Используется только для сообщений от Плагинов

    * - параметры, выбранные по умолчанию

    Доступные функции

    Данные таблицы доступны для копирования, вывода через DDE, экспорта через ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Очистить сообщения» – удаление всех сообщений из хранилища и из всех открытых таблиц.
    • «Сохранить в файл сообщения из таблицы» – сохранение сообщений из таблицы в текстовый файл. Параметры сообщений сохраняются в файл в соответствии с порядком выбранных в таблице столбцов.
    • «Сохранить в файл все доступные сообщения» – сохранение всех доступных сообщений из таблицы в текстовый файл. Параметры сообщений сохраняются в файл в следующем формате:

      Параметр | Значение
      Тип Тип системного сообщения. Возможные значения:
      • «1» – информационное сообщение;
      • «2» – предупреждение;
      • «3» – сообщение об ошибке
      Важность Важность сообщения. Возможные значения:
      • «0» – обычное;
      • «1» – важное
      Дата | Дата создания сообщения
      Время | Время создания сообщения. Формат определяется настройками операционной системы
      Сообщение | Текст сообщения
      Источник | Источник сообщения. Для сообщений с сервера QUIK указывается пустая строка, для сообщений, поступающих с Плагинов, отображается наименование Плагина
      Категория | Категория сообщения. Используется только для сообщений от Плагинов

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    Настройка таблицы сообщений

    Для настройки таблицы сообщений воспользуйтесь пунктом меню Система/Настройки/Основные настройки…, раздел «Сообщения»:

    • «Очищать сообщения при запуске программы» – удаление из таблицы сообщений при запуске программы всех сообщений за предыдущие сеансы связи.
    • «Сохранять за последние … дней» – указывает длительность сохранения полученных сообщений. По истечении срока сообщения удаляются при очередном запуске программы.

    См. также:

    • Параметры настройки таблицы
    • Окно сообщений


Параметры настройки таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.
  2. «Контекстный фильтр» – фильтрация по тексту сообщений. В таблице отображаются сообщения, в тексте которых найдено совпадение по подстроке хотя бы с одним значением из заданного набора значений. Значения разделяются символом «;» (точка с запятой).
    • «Учитывать регистр» – при фильтрации учитывается регистр (прописные/строчные буквы) искомого значения. При снятом флажке фильтрация производится без учета регистра;
    • «Исключать выбранные» – в списке задаются те значения, отображение которых необходимо отключить.

См. также:

  • Таблица сообщений
  • Окно сообщений


Таблица запросов клиентов на исполнение заявок

меню Создать окно / Клиентские транзакции
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр заявок клиентов, направленных в режиме приема клиентских транзакций с подтверждением брокером.

    Формат таблицы

    Каждая строка таблицы содержит информацию об одной заявке клиента.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Код клиента | Код клиента, зарегистрированный на сервере QUIK
    Время получения сервером | Время получения заявки клиента сервером QUIK по часам сервера
    Время подтверждения | Время подтверждения заявки клиента по часам сервера QUIK
    Состояние

    Состояние подтверждения заявки. Возможные значения:

    • «Не подтверждена» – заявка клиента отвергнута;
    • «Подтверждена» – заявка подтверждена брокером и передана в торговую систему;
    • «Зарегистрирована» – заявка принята сервером и ожидает подтверждения брокером;
    • «Снята клиентом» – заявка отозвана клиентом до ее подтверждения брокером
    Трейдер | Описание пользователя системы QUIK, с терминала которого отправлена транзакция
    Транзакция | Тип транзакции, например «Ввод заявки»
    Класс | Класс инструмента
    Инструмент | Наименование инструмента
    Торговый счет | Код торгового счета
    Комментарий | Текстовое примечание в поручении
    Описание заявки | Составное поле, содержащее остальные условия заявки клиента
    Идентификатор | Порядковый номер транзакции

    Доступные функции

    Данные таблицы доступны для копирования, вывода через DDE-сервер и экспорта через ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Подтвердить/Отклонить кл. транзакцию» (или двойное нажатие левой кнопки мыши на строке) – показать окно с параметрами заявки для подтверждения.
    • «Подтвердить клиентскую транзакцию» – подтвердить выбранную транзакцию.
    • «Отклонить клиентскую транзакцию» – отклонить выбранную транзакцию.
    • «Подтвердить все кл. транзакции из таблицы» – подтвердить все активные транзакции в таблице.
    • «Отклонить все кл. транзакции из таблицы» – отклонить все активные транзакции в таблице.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.
  2. «Фильтр клиентов» – настройка фильтрации по кодам клиентов.

См. также Таблица запросов клиентов на исполнение заявок.


Таблица участников торгов

меню Создать окно / Информация об участниках
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр списка участников биржевых торгов. Используется для совершения адресных сделок.

    Информация об участниках торгов отправляется сервером на Рабочее место клиента только в том случае, если у клиента есть права на совершение активных операций.

    Формат таблицы

    Каждая строка таблицы содержит информацию об отдельном участнике торгов. Строки таблицы отсортированы в алфавитном порядке сначала по полю «Биржа», затем по полю «Название участника».

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Биржа

    Место аккредитации участника торгов:

    • «EICX» - Уральская региональная валютная биржа, г. Екатеринбург;
    • «GICX» - Нижегородская валютно-фондовая биржа, г. Нижний Новгород;
    • «MICX» - Московская Биржа, г. Москва;
    • «NICX» - Сибирская межбанковская валютная биржа, г. Новосибирск;
    • «PICX» - Санкт-Петербургская валютная биржа, г. Санкт-Петербург;
    • «RICX» - Ростовская валютно-фондовая биржа, г. Ростов;
    • «SICX» - Самарская валютная межбанковская биржа, г. Самара;
    • «VICX» - Азиатско-Тихоокеанская межбанковская валютная биржа, г. Владивосток
    Название участника | Сокращенное наименование участника торгов
    Идентификатор участника | Код участника торгов в торговой системе биржи
    Статус

    Возможность совершения участником активных операций:

    • «Активная» - операции разрешены;
    • «Неактивная» - операции запрещены
    Запрет необеспеченных торгов

    Признак запрета для участника торгов без обеспечения. Возможные значения:

    • «Да» – торги без обеспечения запрещены;
    • «» (пусто) – разрешены
    Доступен в утренней сессии

    Признак доступности участника торгов в утренней сессии. Возможные значения:

    • «Да» – доступен;
    • «» (пусто) – недоступен

    К таблице может быть применен Режим связанных окон.

    Доступные функции

    Данные таблицы доступны для копирования, вывода через DDE-сервер и экспорта через ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Сохранить в файл информацию об участниках торгов из таблицы» – записать в файл только те строки, которые отображены в таблице.
    • «Сохранить в файл всю информацию об участниках торгов» – записать в файл все имеющиеся строки, без учета настроек таблицы.
    • «Открыть канал» / «Закрыть канал» – включить / выключить режим связанных окон в данной основной таблице.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы
    • Формат сохранения в текстовый файл


Настройка таблицы

  1. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.
  2. «Фильтр бирж» –настройка фильтрации по биржам.
  3. «Фильтр фирм» – настройка фильтрации по фирмам-участникам торгов.
  4. «Фильтр статуса» – настройка фильтрации по полю «Статус» (Активные, Неактивные).

См. также:

  • Таблица участников торгов
  • Формат сохранения в текстовый файл


Таблица «Информация о трейдерах»

меню Создать окно / Информация о трейдерах
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр информации о трейдерах с возможностью запрещения / разрешения торговых операций.

    Формат таблицы

    Параметр | Значение
    Класс | Код класса
    Фирма | Идентификатор фирмы
    Идентификатор трейдера | Код участника торгов
    Наименование | Наименование участника торгов
    Операции Признак разрешения / запрета на выполнение трейдером торговых операций. Возможные значения:
    • «Не определено»;
    • «Операции разрешены»;
    • «Операции запрещены»
    Статус фирм Признак разрешения / запрета на выполнение торговых операций управляющим фирмы. Возможные значения:
    • «Не определено»;
    • «Операции разрешены»;
    • «Операции запрещены»
    Группа | Идентификатор группы, которой принадлежит трейдер
    COD-подписка Тип подписки на COD-режим *. Возможные значения:
    • «Не определено»;
    • «Не используется»;
    • «Всегда»;
    • «По требованию»
    COD-режим Индикатор работы в COD-режиме *. Возможные значения:
    • «Не определено»;
    • «Выключено»;
    • «Включено»
    Первый Мастер | Идентификатор участника торгов, с которым трейдер подключается к торговой системе при использовании спонсируемого доступа
    Второй Мастер | Второй идентификатор участника торгов, с которым трейдер подключается к торговой системе при использовании спонсируемого доступа
    CODCD-режим Индикатор работы в CODCD -режиме **. Возможные значения:
    • «Не определено»;
    • «Выключено»;
    • «Включено»
    Контролирующий Мастер Признак того, что трейдер является Мастером (предоставляет идентификатор для спонсируемого доступа). Возможные значения:
    • «Не определено»;
    • «Нет»;
    • «Да»
    Код Клиента | Код клиента, присвоенный брокером данному идентификатору трейдера
    Сервер доступа | Наименование сервера доступа
    Рабочая станция | Идентификатор рабочей станции
    Подключение к ТС Признак подключения трейдера к торговой системе. Возможные значения:
    • «Не определено»;
    • «Не установлено» – трейдер не подключен к ТС;
    • «Установлено» – трейдер подключен к ТС
    Внешний адрес | Внешний IP-адрес

    *COD-режим (Cancel on Disconnect) – автоматическое снятие заявок, выставленных с идентификатора трейдера, при отключении или потере соединения с ТС или при неактивности, превышающей заданный порог

    **CODCD-режим (Cancel On Drop-Copy Disconnect) – автоматическое снятие заявок, выставленных по поручениям с идентификатора трейдера, при выполнении хотя бы одного из следующих условий для идентификатора, с которым трейдер подключается к торговой системе при использовании спонсируемого доступа («Первый Мастер» и/или «Второй Матер»):
    - отключение или потеря соединения с ТС;
    - неактивность, превышающая заданный порог

    Доступные функции

    Данные таблицы доступны для копирования, вывода через DDE-сервер и экспорта через ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы:

    • «Разрешить операции» – разрешить трейдеру выполнение торговых операций. Отображается для трейдеров, для которых торговые операции запрещены. Доступно для трейдеров с маклерскими правами.
    • «Запретить операции» – запретить трейдеру выполнение торговых операций. При выборе пункта меню открывается окно «Запретить операции» для подтверждения запрета с возможностью снятия всех активных заявок данного трейдера (флажок «Снять все активные заявки»).

      Отображается для трейдеров, для которых торговые операции разрешены. Доступно для трейдеров с маклерскими правами.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы


Настройка таблицы

  1. «Имя таблицы» – позволяет изменить редактируемую часть наименования таблицы.
  2. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

См. также:

  • Таблица «Информация о трейдерах»


Таблица «Переводы НКЦ»

меню Создать окно / Переводы НКЦ
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр информации о технологических сделках перевода активов в рамках Единого пула обеспечения.

    Формат таблицы

    Каждая строка таблицы описывает отдельную операцию перевода.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    *Код класса | Код класса в торговой системе
    Код инструмента | Идентификатор инструмента в торговой системе
    Дилер | Идентификатор фирмы, от имени которой совершена сделка
    Партнер | Идентификатор трейдера, с кем заключена сделка (только для РПС)
    *Номер | Регистрационный номер сделки в торговой системе биржи
    *Заявка | Номер заявки, на основании которой заключена сделка
    ***Дата сделки | Дата регистрации сделки
    ***Время | Время регистрации сделки в торговой системе с точностью до секунды. Формат определяется настройками операционной системы
    Время (мкс) | Количество микросекунд во времени регистрации сделки
    Операция

    Направление операции. Возможные значения:

    • «Купля» – сделка на покупку;
    • «Продажа» – сделка на продажу
    Комментарий | Дополнительная справочная информация (заполняется трейдером) – как правило: <код клиента > / <номер поручения >
    Счет | Код торгового счета, в отношении которого заключена сделка
    Цена | Цена сделки, за единицу инструмента
    Кол-во | Количество инструментов, выраженное в лотах
    Объем | Объем сделки в денежном выражении
    Валюта | Валюта цены, например «SUR» – российский рубль
    НКД | Накопленный купонный доход, рассчитанный для количества инструментов в сделке, в денежном выражении
    Код расчетов | Код проведения расчетов по сделкам в РПС (Режиме переговорных сделок)
    ***Дата расчетов | Дата расчетов по сделке
    **Вид сделки | Вид сделки. Значение: «Перевод денег / инструментов»
    Системная ссылка | Дополнительная информация по сделке, передаваемая торговой системой
    Идентификатор счета | Идентификатор расчетного счета в НКЦ
    Фирма клиринга | Идентификатор фирмы - участника клиринга
    Счет клиринга | Идентификатор клирингового расчетного счета в НКЦ
    Тип перевода | Идентификатор типа перевода
    Состояние

    Статус сделки. Возможные значения:

    • «Исполнена»;
    • «Не исполнена»;
    • «Отменена системой»;
    • «Включена в отчет»;
    • «Не определено»
    Информация о переводе | Код операции и дополнительная информация

    * - параметры, выбранные по умолчанию

    ** - при получении терминалом неизвестного ему вида сделки, в данное поле выводится запись «Вид сделки XXX»

    *** - при включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» значение отображается с учетом временной зоны компьютера, на котором запущен терминал QUIK

    Доступные функции

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:Настройка таблицы


Настройка таблицы

  1. «Имя таблицы» – позволяет изменить редактируемую часть наименования таблицы.
  2. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

См. также:таблица «Переводы НКЦ».


Таблица «Запрет на операции»

меню Создать окно / Запрет на операции
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр информации о запретах на операции клиентов.

    Формат таблицы

    Каждая строка таблицы описывает отдельный запрет на операции клиента. В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Фирма | Идентификатор фирмы
    Тип контракта Тип контракта. Возможные значения:
    • «Фьючерсы»;
    • «Опционы»
    Правило № | Номер правила запрета
    Тип правила Тип запрета. Возможные значения:
    • «Глобальное» – запрет распространяется на все инструменты;
    • «На инструмент» – запрет распространяется на определенный инструмент
    Код инструмента | Код инструмента, на который распространяется запрет. Для типа правила «Глобальное» поле не заполняется
    Код базового актива | Заполняется для правил по базовым активам
    Секция Тип секции торговой площадки. Возможные значения:
    • «Фондовая»;
    • «Денежная»;
    • «Товарная»
    Счет | Код торгового счета
    Приоритет Приоритет правила. Возможные значения (в порядке убывания приоритета):
    • «Высокий пользовательский приоритет»;
    • «Средний пользовательский приоритет»;
    • «Низкий пользовательский приоритет»;
    • «Клиентский код, инструмент»;
    • «Клиентский код»;
    • «Клиентский код, все БА»;
    • «Код БФ, инструмент»;
    • «Код БФ, БА»;
    • «Код БФ, все БА»;
    • «Код РФ, инструмент»;
    • «Код РФ, БА»;
    • «Код РФ, все БА»
    Тип состояния Возможные значения:
    • «Всё разрешено»;
    • «Запрет открытия позиций»;
    • «Запрет всех торговых операций»;
    • «Запрет открытия позиций в продажу»;
    • «Запрет брокера на подачу заявок на экспирацию»;
    • «Заявки на экспирацию разрешено подавать только Главному трейдеру»
    Состояние исполнения Статус правила. Возможные значения:
    • «Не разрешено»;
    • «Разрешено»
    Инициатор Инициатор запрета. Возможные значения:
    • «БФ»;
    • «Главный трейдер РФ»;
    • «Администратор КЦ»;
    • «Администратор ТС»
    Тип инициатора Тип инициатора запрета. Возможные значения:
    • «Запрет был выставлен Администратором торгов или клиринга и не может быть изменён участником торгов»;
    • «Запрет был выставлен участником торгов и может быть изменён»

    Доступные функции

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также:

    • Настройка таблицы


Настройка таблицы

  1. «Имя таблицы» – позволяет изменить редактируемую часть наименования таблицы.
  2. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.
  3. «Фильтрация»:
    • «Фильтр торговых счетов» – настройка фильтрации по торговым счетам. При установленном признаке в таблице отображается информация только по выбранным счетам. Фильтр настраивается с помощью кнопки «…»;
    • «Фильтр фирм» – настройка фильтрации по кодам фирм. При установленном признаке в таблице отображается информация только по выбранным кодам фирм. Фильтр настраивается с помощью кнопки «…».
  4. «Тип контракта» – настройка фильтрации по типу контракта. В таблице отображается информация только по выбранным типам:
    • «Фьючерсы»;
    • «Опционы».

См. также:

  • Таблица «Запрет на операции»


Таблица «Информация по кодам расчетов»

меню Создать окно / Информация по кодам расчетов
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр информации по кодам расчетов в разрезе классов.

    Формат таблицы

    Таблица не имеет настроек.

    Каждая строка таблицы описывает отдельный код расчета. В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
Код класса | Код класса
Код | Код расчетов по сделке
Дата | Дата расчетов адресной сделки или первой части сделки РЕПО
Описание | Дополнительная информация

    Доступные функции

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.


Таблица «Типы переводов»

меню Создать окно / Типы переводов
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр информации о типах технологических сделок перевода активов в рамках Единого пула обеспечения.

    Формат таблицы

    Каждая строка таблицы описывает отдельный тип перевода. В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
Класс | Код класса
Фирма | Идентификатор фирмы
Тип | Идентификатор типа перевода
Описание | Дополнительная информация

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Имя таблицы» – позволяет изменить редактируемую часть наименования таблицы.
  2. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

См. также Таблица «Типы переводов».


Таблица «Расчетные коды»

меню Создать окно / Расчетные коды
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр общей информации по расчетным кодам фирмы.

    Формат таблицы

    Каждая строка таблицы описывает отдельный расчетный код. В столбцах таблицы отображаются следующие параметры:

    Параметр | Значение
    Класс | Код класса инструмента
    Фирма | Идентификатор фирмы
    Код позиции | Код дополнительной позиции по денежным средствам
    Описание | Описание позиции
    Принудительное закрытие | Признак принудительного закрытия счета в случае непогашения отрицательной позиции
    Ранние расчеты | Признак ранних расчетов
    Торги закончены Признак окончания торгов. Возможные значения:
    • «» - не определено;
    • «Нет» – торги не закончены;
    • «Да» – торги закончены
    Состояние Признак допустимости торговых операций. Возможные значения:
    • «» - не определено;
    • «Операции разрешены»;
    • «Операции запрещены»
    Запрет необеспеченных покупок Признак запрета торгов без обеспечения. Возможные значения:
    • «» - не определено;
    • «Нет» – торги без обеспечения разрешены;
    • «Да» – запрещены
    Код клиента | Код клиента, присвоенный брокером
    Клиринговая фирма | Идентификатор фирмы-участника Клиринга
    Клиринговый расчетный код | Идентификатор клирингового расчетного счета в НКЦ
    Тип Тип расчетного кода. Возможные значения:
    • «» - не определено;
    • «Средства, переданные в ДУ»;
    • «Коллективное клиринговое обеспечение»;
    • «Средства клиентов»;
    • «Собственные средства»:
    • «Обеспечение под стресс»;
    • «Технологический»;
    • «Клиенты 2-го и 3-го уровней»
    Идентификатор пула | Идентификатор пула
    Единый пул Признак единого пула. Возможные значения:
    • «» - не определено;
    • «Нет»;
    • «Да»
    Время ранних расчетов | Время ранних расчетов в формате <ЧЧММСС>
    Время прекращения торгов | Время прекращения торгов в формате <ЧЧММСС>
    Идентификатор расчетного счета/кода | Идентификатор расчетного счета/кода в клиринговой организации для списания оборотной комиссии
    Учитывать процентный риск Признак учета процентного риска. Возможные значения:
    • «» – не определено;
    • «Нет»;
    • «Да»
    Доступен в утреннюю сессию Признак доступности расчетного кода для торгов в утреннюю сессию. Возможные значения:
    • «» – не определено;
    • «Нет»;
    • «Да»
    Счет типа “С” Признак счета типа «С». Возможные значения:
    • «» – не определено;
    • «Нет»;
    • «Да»

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE-сервер и экспорта по ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из пункта меню Действия или контекстного меню таблицы.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Описание применения быстрого фильтра.
    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Имя таблицы» – позволяет изменить редактируемую часть наименования таблицы.
  2. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

См. также Таблица «Расчетные коды».


Таблица алгоритмических заявок

меню Создать окно/ Таблица алго-заявок

Для отображения в разделе меню «Создать окно» пункта «Таблица алго-заявок» выберите пункт меню Создать окно/Настроить меню… и добавьте Таблицу алго-заявок в список выбранных.

  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Таблица предназначена для отображения алгоритмических заявок и состояния их исполнения. В таблице доступно выполнение типовых функций, таких как подача алго-заявок, отмена, составление отчетов.

    Формат таблицы

    Таблица содержит перечень внутренних и внешних алгоритмических заявок в хронологическом порядке. Каждой алго-заявке в таблице соответствует отдельная строка. Столбцы обозначают параметры алго-заявок. Описание параметров таблицы приведены в Руководстве пользователя Модуля алгоритмической торговли. Перечень параметров для внешних алгоритмических заявок зависит от доступных пользователю классов с возможностью выставлять алгоритмические заявки во внешние системы.

    Доступные функции

    Данные из таблицы доступны для копирования в Буфер обмена Windows и вывода через DDE-сервер.

    Описание стандартных функций контекстного меню для таблиц.

    Функции, доступные из контекстного меню таблицы или меню программы Действия (при активной таблице):

    • «Новая алго-заявка» – открыть форму ввода новой алго-заявки. Если тип новой алго-заявки совпадает с типом заявки, на которой установлен курсор, то все поля новой заявки автоматически заполняются данными из исходной заявки. Иначе в новую алго-заявку подставляется только тот же инструмент, что и у исходной заявки.
    • «Изменить алго-заявку» – открыть форму изменения параметров алго-заявки. Для редактирования доступны поля «Видимое кол-во», «Кол-во», «Агрессивность», «Цена», а так же динамические поля, специфичные для данного вида алго-заявок.
    • «Снять алго-заявку» – отозвать из торговой системы выделенную алгоритмическую заявку.
    • «Снять активные заявки» – отозвать из торговой системы алгоритмические заявки.
    • «Возобновить выполнение» – возобновить выполнение выделенной алгоритмической заявки со статусом «Снята», если срок ее действия не истек (для алго-заявок типа «TWAP», «VWAP», «Заявка со сроком действия» и «Стоп-заявка») или заявка подана в текущую торговую сессию (для алго-заявок типа «Айсберг» и «Волатильность»). Действие недоступно для внешних алго-заявок.
    • «Запросить отчет» – отправить запрос на получение отчета по выбранной алгоритмической заявке. Действие недоступно для внешних алго-заявок.
    • «Запросить отчет за прошедший период» – отправить запрос на получение отчета по алгоритмической заявке за прошедший период. Действие недоступно для внешних алго-заявок.
    • «Связанные заявки» – открыть таблицу «Связанные заявки. Алго заявка <Номер заявки>» для просмотра связанных заявок, сгенерированных выбранной алго-заявкой. Для связанных заявок, выставленных по РПС-классам, открывается таблица «Связанные заявки на внебиржевые сделки. Алго заявка <Номер заявки>». Действие недоступно для внешних алго-заявок.
    • «Связанные сделки» – открыть таблицу «Связанные сделки. Алго заявка <Номер заявки>» для просмотра заключенных сделок по выбранной алго-заявке.

    Подробное описание доступных функций таблицы приведено в Руководстве пользователя Модуля алгоритмической торговли.

    Дополнительно:

    • Описание применения пользовательских фильтров и условного форматирования таблиц.
    • Описание применения быстрого фильтра.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Настройка таблицы.


Настройка таблицы

  1. «Имя таблицы» – заголовок таблицы.
  2. Раздел «Выбранные классы» — выбор классов алго-заявок и внешних алго-заявок, отображаемых в таблице.
  3. Раздел «Набор параметров» – выбор параметров для отображения в таблице и настройка их очередности. Список доступных параметров зависит от выбранных классов в разделе «Выбранные классы».
  4. Флажок «Фильтр инструментов» — настройка фильтра инструментов возможна для каждого класса из списка «Выбранные классы». Фильтр используется для создания Таблицы алгоритмических заявок по определенному инструменту (группе инструментов).
  5. «Фильтр состояния» — признак отображения алго-заявок по состоянию их исполнения («Активные», «Исполненные», «Снятые»).
  6. «Фильтр операции» — признак отображения алго-заявок в зависимости от направления операции («Покупка»/«Продажа»).
  7. «Фильтр клиентов» — выбор кодов клиентов для отображения в таблице.
  8. «Цветовые настройки» — настройка цвета фона строки в зависимости от состояния исполнения алго-заявок.

См. также Таблица алгоритмических заявок.


Приложение 1

Формулы расчета параметров таблицы «Клиентский портфель»

  • Используемые переменные и функции
  • Значения параметров таблицы «Клиентский портфель»
  • Пример расчета основных маржинальных показателей

    • Используемые переменные и функции

    Переменная | Значение
 | первоначальная позиция по i -ому инструменту (может быть отрицательной)
 | цена закрытия предыдущей торговой сессии по i -ому инструменту
 | текущая позиция по i -ому инструменту (может быть отрицательной)
 | лучшая цена предложения по i -ому инструменту
 | лучшая цена спроса по i -ому инструменту
 | совокупное количество по активным заявкам на покупку по i -ому инструменту
 | совокупное количество по активным заявкам на продажу по i -ому инструменту
positive(x) | функция, которая возвращает x, если x > 0 и возвращает 0, если x < 0
negative(x) | функция, которая возвращает x, если x < 0 и возвращает 0, если x > 0
Pos_Depoi | текущий остаток плановой позиции по i -ому инструменту
Pos_Moneyi | текущий остаток плановой позиции по i -й валюте
Lasti | цена последней сделки в основной валюте по курсу сервера QUIK по i -ому инструменту
Di | коэффициент дисконтирования по i -ому инструменту

    Значения параметров таблицы «Клиентский портфель»

    Параметр | Формула расчета
    Мин.маржа
    Вычисляется аналогично размеру начальной маржи, но при использовании минимальных ставок риска. Дисконты для вычисления минимальной маржи определяются следующим образом:

    • в случае длинной позиции по инструменту: ;
    • в случае короткой позиции по инструменту:
    Нач.маржа
    Фактически размер начальной маржи является размером стоимости портфеля клиента с учетом дисконтирующих коэффициентов D long и D short. При этом:

    • в случае длинной позиции по инструменту используется D long;
    • в случае короткой позиции по инструменту используется – D short (со знаком «минус»);
    • для основной валюты используется нулевой дисконт: D long = D short = 0
    Стоимость портфеля «Стоимость портфеля» = («Тек.остаток по деньгам» – «Блок. пок. немарж.») + «Лонги» + «Шорты»

    Для клиентов типа «МД»:

    Фактически сумма первых двух слагаемых является текущими активами клиента, рассчитанными без использования дисконтирующих коэффициентов. Третье слагаемое уменьшает активы на размер отрицательных позиций по немаржинальным инструментам

    Вход. активы | «Вход. активы» = «Вх. остаток по деньгам» +
    Плечо | «Плечо» = «Вход. Лимит» / «Вход. активы»
    Вход. лимит | «Вход. Лимит» = «Вх.лимит по деньгам»
    Шорты | «Шорты» =
    Лонги | «Лонги» = «Лонги МО» + «Лонги О»
    Лонги МО | «Лонги МО» = [image] - сумма оценок инструментов типа МО
    Лонги О | «Лонги О» = [image] - сумма оценок инструментов типа О
    Ур. Маржи «Ур. Маржи» = ( [image] + «Лонги» + «Шорты») / ( [image] + «Лонги»)

    Рассчитывается с учётом дисконтирующих коэффициентов

    Тек. лимит | «Тек. Лимит» = «Стоимость портфеля» * «Плечо»
    ДостТекЛимит | «ДостТекЛимит» = «Тек. Лимит» + «Шорты» – «Блок. Продажа» + negative ((«Тек. остаток по деньгам» – «Блок. пок. немарж.») + «Шорты» – «Блок. Покупка»)
    Блок. покупка | «Блок. Покупка» = «Блок. пок. маржин.» + «Блок. пок. обесп.»
    Блок. пок. маржин. | «Блок.пок.маржин.» =
    Блок. пок. обесп. | «Блок.пок.обесп.» =
    Блок. пок. немарж. * | «Блок.пок. немарж.» =
    Блок. продажа | «Блок.Продажа» =
    ВходСредства | «Вход. Средства» = «Вх.остаток по деньгам» +
    ТекСредства | «ТекСредства» = («Тек.остаток по деньгам» – «Блок. пок. немарж.») + [image] + «Шорты»
    Прибыль/убытки | «Прибыль/убытки» = «ТекСредства» - «ВходСредства»
    ПроцИзмен | «ПроцИзмен» = «Прибыль/убытки» / «ВходСредства» * 100
    На покупку | «На покупку» = «ДостТекЛимит» + positive ((«Тек.остаток по деньгам» – «Блок. пок. немарж.») + «Шорты» – «Блок. Покупка»))
    На продажу | «На продажу» = «ДостТекЛимит»
    НаПокупНеМаржин | Оценка денежных средств, доступных для покупки немаржинальных инструментов (тип которых не указан)
    НаПокупОбесп «НаПокупОбесп» = «Стоимость портфеля» + negative («Тек. Лимит» – OpenPos) – «Лонги О» – «Блок.пок.обесп.»,
    где OpenPos учитывает открытые позиции по маржинальным инструментам (нужно учесть короткие позиции, длинные позиции и количество заблокированных средств как на покупку, так и на продажу) - OpenPos = - «Шорты» + «Блок.Продажа» + «Лонги МО» + «Блок.пок.маржин.»

    * - в случае использования дисконтирующих коэффициентов при оценке позиций по инструментам, поле содержит также и сумму дисконта от стоимости короткой позиции клиента по инструментам. Пример расчета основных маржинальных показателей см. ниже

    Пример расчета основных маржинальных показателей

    Исходные данные:

    • Курс SUR/USD = 0.0183516.
    • Позиции:
      • Тек.остаток по деньгам = -10000 USD;
      • Лонги LKOH = 900;
      • Шорты SNGS = -10000.

    Для схемы «по плечу» оценка позиций выполняется:

    • по цене последней сделки для поля «Оценка» в таблице «Купить/Продать» – оценка с точки зрения фактической текущей стоимости позиции.
    • по цене bid/offer для использования в расчетах таблицы «Клиентский портфель» – оценка с точки зрения возможного закрытия позиции, для обеспечения клиентских операций или ликвидации маржинальной задолженности.

    Получаем:

    • Лонги LKOH = 900 * bid 3022.1 * 0.0183516 = 49914.33 USD
      С учетом дисконта 10% оценка равна 44922.90 USD.
      Дисконт 4991.43 USD – уменьшает размер обеспечения клиента.
    • Шорты SNGS = -10000 * last 36.850 (так как offer=0) * 0.0183516 = 6762.56 USD
      С учетом дисконта 10% оценка равна 7100.69 USD.
      Дисконт 338.13 USD – учитывается в параметре «Блок. пок. немарж.».

    Заявки:

    • Покупка ARMD на 60000 SUR.
      Инструмент немаржинальный, то есть в параметр «Блок. пок. немарж.» попадает вся сумма, которая после исполнения заявки будет выведена из обеспечения:
      Блок. пок. немарж. = 60000 SUR * 0.0183516 = 1101.10 USD
    • Покупка LKOH на 20000 SUR.
      Инструмент маржинальный, то есть в параметр «Блок. пок. немарж.» попадает дисконт 10%, который после исполнения заявки будет выведен из обеспечения:
      Блок. пок. немарж. = 20000 SUR * 10% * 0.0183516 = 36.70 USD

    Стоимость портфеля определяется как разность обеспечения, явных задолженностей, временно недоступных для заемных операций средств:

    «Стоимость портфеля» = («Тек.остаток по деньгам» – «Блок. пок. немарж.») + «Лонги» + «Шорты» = -10000 – (338.13 + 1101.10 + 36.70) + 44922.90 – 6762.56 = 26684.41 USD.


Приложение 2

Значения параметров (столбцов) таблицы «Текущие торги», Таблицы истории значений параметров, Таблицы изменений параметров

Полное название параметра | Название параметра в таблице | Значение
Заголовок строки таблицы «Текущие торги» | Инструмент | Сокращенное наименование инструмента
Заголовок строки Таблицы истории значений параметров и Таблицы изменений параметров | Время | Время обновления параметров. Формат определяется настройками операционной системы
Общие параметры
Полное название инструмента | Инструмент | Наименование инструмента *
Краткое название инструмента | Инструмент сокр. | Краткое наименование инструмента
Код инструмента | Код инструмента | Биржевой идентификатор, присвоенный инструменту
ISIN | ISIN | ISIN-код инструмента
CFI | CFI | CFI-код инструмента
Регистрационный номер | Рег.номер | Идентификатор инструмента
Название класса | Класс | Наименование класса инструментов
Код класса | Код класса | Идентификатор класса в торговой системе
Дата торгов | Дата торгов | Дата текущей торговой сессии
Дата погашения | Погашение | Дата погашения (для инструментов с фиксированным сроком обращения)
Число дней до погашения | До погашения | Число дней до погашения
Номинал инструмента | Номинал | Номинальная стоимость инструмента. Поле не заполняется, если значение не задано
Валюта номинала | Валюта | Символьный код валюты номинала инструмента, например «SUR» - рубли
Точность количества | Точн. кол-ва | Количество значащих цифр после десятичного разделителя в значениях количества
Точность цены | Точность | Количество значащих цифр после десятичного разделителя в значениях цены
Минимальный шаг цены | Шаг цены | Минимальная величина изменения цены
Тип инструмента | Тип инструмента | Тип и подтип инструмента
Тип инстр-та | Тип инстр-та | Тип инструмента
Подтип инстр-та | Подтип инстр-та | Подтип инструмента
Статус торговли инструментом | Статус | Торгуется/Заморожена
Размер лота | Лот | Минимально допустимое количество инструментов в одной заявке, штук
Лучшая цена спроса | Спрос | Лучшая (максимальная) цена среди заявок на покупку, в ден.выражении
Спрос по лучшей цене | Кол. спрос | Количество инструментов в заявках с максимальной ценой покупки, в лотах
Суммарный спрос | Общ. спрос | Количество инструментов во всех заявках на покупку, в лотах
Количество заявок на покупку | Заявки куп. | Общее количество заявок на покупку по этому инструменту, штук
Лучшая цена предложения | Предл. | Лучшая (минимальная) цена среди заявок на продажу, в ден.выражении
Предложение по лучшей цене | Кол. предл. | Количество инструментов в заявках с минимальной ценой продажи, в лотах
Суммарное предложение | Общ. предл. | Количество инструментов во всех заявках на продажу, в лотах
Количество заявок на продажу | Заявки прод. | Общее количество заявок на продажу по этому инструменту, штук
Цена открытия | Откр. | Цена первой сделки, в ден.выражении
Максимальная цена сделки | Макс. цена | Максимальная цена, по которой были совершены сделки в текущей сессии, в ден.выражении
Минимальная цена сделки | Мин. цена | Минимальная цена, по которой были совершены сделки в текущей сессии, в ден.выражении
Цена последней сделки | Цена послед. | Цена последней совершенной сделки по этому инструменту, в ден.выражении
Разница цены последней к закрытию предыдущей сессии | Измен. к закр. | Разница между ценой последней сделки и средневзвешенной ценой предыдущей сессии, в ден.выражении
Количество в последней сделке | Кол-во послед. | Количество инструментов в последней сделке, в лотах
Время последней сделки | Время послед. | Время совершения последней сделки. Формат определяется настройками операционной системы
Количество во всех сделках | Общее кол-во | Объем совершенных в текущей сессии сделок, штук
Оборот в деньгах | Оборот | Объем совершенных в текущей сессии сделок в ден. выражении
Состояние сессии | Сессия | Состояние торговой сессии
Оборот в деньгах последней сделки | Оборот посл. | Объем последней совершенной сделки в ден. выражении
Средневзвешенная цена | Ср. взв. цена | Отношение оборота текущей сессии в деньгах к инструментам во всех сделках, в ден.выражении
Лучшая цена спроса сегодня | Лучш. спрос | Лучшая (максимальная) цена среди заявок на покупку за текущую сессию, в ден.выражении
Лучшая цена предложения сегодня | Лучш. пред | Лучшая (минимальная) цена среди заявок на продажу за текущую сессию, в ден.выражении
Количество сделок за сегодня | Кол-во сделок | Количество совершенных сделок за текущую сессию, штук
Цена закрытия | Цена закр. | Цена последней сделки за предыдущую торговую сессию, в ден.выражении
Предыдущая оценка | Пред. оц. | Средневзвешенная цена предыдущей торговой сессии в ден.выражении (для инструментов) либо Цена закрытия контракта (для срочных инструментов)
Рыночная цена вчера | Вч.рын.цена | Рыночная цена предыдущего дня, в ден.выражении
Рыночная цена | Рын.цена | Рыночная цена инструмента, рассчитанная по официальной методике, в ден.выражении
Рыночная цена 2 | Рын.цена2 | Рыночная цена инструмента, рассчитанная по официальной методике для оценки стоимости инвестиционного портфеля, сформированного за счет средств пенсионных накоплений, в ден.выражении
Признаваемая котировка | Призн.котир. | Признаваемая котировка, рассчитываемая по официальной методике, в ден.выражении
Лучший спрос заверш. торгов | Спрос сессии | Лучшая котировка на покупку на момент завершения периода торгов, в ден.выражении
Лучшее предложение заверш. торгов | Предл. сессии | Лучшая котировка на продажу на момент завершения периода торгов, в ден.выражении
Цена закрытия предыдущего дня | Пред.цена закр | Цена закрытия предыдущего дня, в ден.выражении
Базовый курс | Баз.курс | Базовый курс инструмента, в ден.выражении
Начало основной сессии | Начало | Время начала основной сессии. Формат определяется настройками операционной системы
Окончание основной сессии | Окончание | Время окончания основной сессии. Формат определяется настройками операционной системы
Начало вечерней сессии | Начало веч. | Время начала дополнительной вечерней сессии. Формат определяется настройками операционной системы
Окончание вечерней сессии | Окончание веч. | Время окончания дополнительной вечерней сессии. Формат определяется настройками операционной системы
Начало утренней сессии | Начало утр. | Время начала дополнительной утренней сессии. Формат определяется настройками операционной системы
Окончание утренней сессии | Окончание утр. | Время окончания дополнительной утренней сессии. Формат определяется настройками операционной системы
Цена предторгового периода | Цена предторг. | Цена предторгового периода, в ден.выражении
Минимальная текущая цена | Мин.тек.цена | Минимальная текущая цена, в ден.выражении
Код расчетов по умолчанию | Код расч. | Код расчетов по умолчанию: «T0», «S0», «S01», «S02», иначе «*»
Цена аукциона Цена аукц. Минимальная цена аукциона (цена отсечения), начиная с которой удовлетворяются конкурентные заявки на аукционе

Количество аукциона | Кол-во аукц. | Общее количество в сделках аукциона
Дисбаланс ПА | Дисбаланс ПА | Суммарный объем заявок, которые остались бы неисполненными при завершении аукциона по ожидаемой цене
Рыночных на покупку | Рын.пок. | Суммарный объем рыночных заявок на покупку по ожидаемой цене
Рыночных на продажу | Рын.прод. | Суммарный объем рыночных заявок на продажу по ожидаемой цене
Дисконт1 | Дисконт1 | Значение дисконта клирингового центра первого диапазона
Дисконт2 | Дисконт2 | Значение дисконта клирингового центра второго диапазона
Дисконт3 | Дисконт3 | Значение дисконта клирингового центра третьего диапазона
Величина отклонения | Отклонение | Величина отклонения для расчета страйка бинарного опциона, может быть как положительной, так и отрицательной, %
Статус хэджирования заявок | Хэдж. | Статус хэджирования заявок в SOR
Комментарий | Комментарий | Комментарий
Сопряженная валюта | Сопр.валюта | Код валюты, в которой производятся расчёты по сделке
StockCode | StockCode | Тикер инструмента
SEDOL | SEDOL | Идентификатор инструмента из Stock Exchange Daily Official List (SEDOL)
RIC | RIC | Reuters Instrument Code (RIC)
CUSIP | CUSIP | CUSIP Code (идентификатор для северо-американских финансовых инструментов)
StockName | StockName | Код деривативного контракта в формате QUIK
Bloomberg ID | Bloomberg ID | Идентификатор инструмента в Bloomberg (Bloomberg security identifier)
Кратность лота | Кратность лота | Кратность при вводе количества
Агент по размещению | Агент по размещ. | Код фирмы-агента по размещению инструмента
Макс. актуальная точность количества | Макс.акт.точ.кол. | Максимальное из значений параметра «Точность количества» в разных режимах торгов
Неточные параметры Неточ. параметры Маркировка облигаций с наличием нерасчитываемых параметров. Перечень сокращений неточных параметров:
  • «С» — нет информации по купону;
  • «N» — нет информации по номиналу (амортизации);
  • «А» — неверное значение НКД;
  • «F» — неверное значение номинала (амортизации);
  • «G» — изменение купона;
  • «M» — проведение ОСВО;
  • «S» — прекращен расчет НКД
Тип сложного финансового продукта Сложный продукт Тип сложного финансового продукта. Возможные значения:
  • «-100» – без ограничений;
  • «-1» – не попадает под тесты из Базового стандарта, недоступно для неквалифицированных инвесторов, не прошедших тестирование;
  • «0» – предназначено для квалифицированных инвесторов согласно 39-ФЗ или эмиссионным документам;
  • «4» – структурные облигации, не предназначенные для квалифицированных инвесторов;
  • «5» – инвестиционные паи закрытых паевых инвестиционных фондов, непредназначенных для квалифицированных инвесторов;
  • «6» – облигации российских эмитентов, которым не присвоен кредитный рейтинг, либо кредитный рейтинг которых ниже установленного уровня;
  • «7» – облигации иностранных эмитентов, обязательства по которым исполняются за счёт юридического лица, созданного в соответствии с законодательством РФ, не имеющего кредитный рейтинг, либо кредитный рейтинг которого ниже установленного уровня;
  • «8» – облигации со структурным доходом;
  • «9» – акции, не включенные в котировальные списки;
  • «10» – иностранные акции, требующие проведения тестирования;
  • «11» – сделки по приобретению паев иностранных ETF, требующие проведения тестирования;
  • «800» – облигации, запрещенные к приобретению с 01.10.2021 до 01.04.2024 для инвесторов, успешно прошедших тестирование по тесту 8
Эмитент | Эмитент | Код фирмы эмитента

Дополнительные параметры для инструментов Секции фондового рынка Московской Биржи и рынка государственных ценных бумаг, Режим переговорных сделок (РПС) и операции РЕПО

Цена периода закрытия | Закр. | Средневзвешенная цена периода закрытия, в ден.выражении
% изменения от закрытия | % измен. закр. | Изменение в процентах цены последней сделки от последней цены предыдущего дня, %
Дата закрытия реестра | Дата з.р. | Дата закрытия реестра
Размещение | Размещение | Цена размещения инструмента на аукционе, в ден.выражении
НКД | НКД | Накопленный купонный доход, в ден.выражении
Доходность | Доходность | Доходность инструмента по цене последней сделки, %
Размер купона | Размер купона | Величина купона, в ден. выражении
Доходность по предыдущей оценке | Доход.пред.оц. | Доходность инструмента по средневзвешенной цене предыдущей торговой сессии, %
Доходность по оценке | Доход.оц. | Доходность инструмента по средневзвешенной цене, в ден.выражении
Разница цены последней к оценке предыдущей сессии | Изм. к пред.оц. | Разница между ценой последней совершенной сделки и средневзвешенной ценой предыдущей торговой сессии
Доходность по закрытию | Доход.закр. | Доходность инструмента по цене периода закрытия, %
Дата выплаты купона | Дата выпл.куп. | Дата выплаты купона
Длительность купона | Длит.куп. | Продолжительность текущего купонного периода, в календарных днях
Цена оферты | Оферта | Цена оферты (предварительного выкупа)
Дата, к которой рассч. доходность | Дата расч.доход | Дата досрочного погашения номинальной стоимости облигации
Объем обращения | Объем обр. | Объем выпуска инструментов, находящийся в обращении, в штуках
Дата предыдущего торгового дня | Дата посл. торг. | Дата предыдущей торговой сессии
Дюрация | Дюрация | Средневзвешенный срок до погашения финансового актива, измеряемый в днях
Официальная цена открытия | Оф.цена откр. | Цена открытия, официально объявленная торговой системой
Официальная текущая цена | Оф.тек.цена | Текущая цена, официально объявленная торговой системой
Официальная цена закрытия | Оф.цена закр. | Цена закрытия, официально объявленная торговой системой
Тип цены | Тип цены | Способ указания цены инструмента. Возможные значения: «% от ном.» - процент от номинала; «Цена» - цена, за единицу инструмента
Время изм. мин. тек. цены | Вр. изм.м.т.ц. | Время изменения минимальной текущей цены. Формат определяется настройками операционной системы
Предыдущий размер лота | Пред. лот | Предыдущее значение размера лота
Дата последнего изменения размера лота | Дата изм.лота | Дата последнего изменения размера лота
Расчетная цена | Расч.цена | Текущая расчетная цена, в денежном выражении
Расчетная цена с уч.диск. | Расч.цена диск | Текущая расчетная цена, пересчитанная с учетом дисконта
Дисконт % | Дисконт % | Ставка процентного риска, %
Нижняя граница руб. | Ниж.граница руб | Нижняя граница цены, руб.
Верхняя граница руб. | Верх.граница руб | Верхняя граница цены, руб.
Конец диапазона | Кон.диапазона | Максимальное количество инструментов, руб.
Расчетная ставка РЕПО % | Расч.ст.РЕПО % | Расчетная ставка РЕПО, %
Нижняя граница процентного риска % | Ниж.гр.риска % | Нижняя граница процентного риска %
Верхняя граница процентного риска % | Верх.гр.риска % | Верхняя граница процентного риска %
Штрафная ставка за перенос позиции по бумагам% | Штраф.ст.бум. % | Штрафная ставка за перенос позиции по инструментам %
Штрафная ставка за перенос позиции по деньгам % | Штраф.ст.деньги % | Штрафная ставка за перенос позиции по деньгам %
Прием в обеспечение | Прием в обеспеч. | Прием в обеспечение
Прием в коллективное обеспечение | Коллект.обеспеч. | Прием в коллективное обеспечение
Прием в обеспечение под стресс | Обеспеч.стресс | Прием в обеспечение под стресс
Признак валютного актива | Валютный актив | Признак валютного актива
Запрет необеспеченных торгов | Запр.необ.торгов | Запрет необеспеченных торгов
Биржевой статус торговой сессии | Бирж.Сессия | Биржевой статус торговой сессии
Допуск к дополнительной сессии | Доп.сессия | Признак допуска бумаги к дополнительной (вечерней) сессии
Повышенный инвестиционный риск | П.И.Р. | Признак инструмента с повышенным инвестиционным риском
Квалифицированный инвестор Квал.инвестор Признак доступности инструмента только для квалифицированных инвесторов. Возможные значения:
  • «Для любых квал.инвесторов» – бумага предназначена к покупке всеми (любыми) квалифицированными инвесторами;
  • «Для юр.лиц - квал.инвесторов» бумага предназначена к покупке квалифицированными инвесторами, являющимися юридическими лицами;
  • «» (пустая строка) – бумага предназначена к покупке любыми инвесторами
Доступность в утренней сессии Утр.сессия Признак допуска инструмента (акций и облигаций) к торгам в утреннюю сессию. Возможные значения:
  • «Да» – наличие допуска бумаги к торгам в утреннюю торговую сессию;
  • «» (пусто) – отсутствие допуска бумаги к торгам в утреннюю торговую сессию

Дополнительные параметры для инструментов Секции фондового рынка Московской Биржи, режим Dark Pools

Время начала аукциона | Начало.аук. | Время начала аукциона. Формат определяется настройками операционной системы
Время окончания аукциона | Окончание.аук. | Время окончания аукциона. Формат определяется настройками операционной системы
Заявок на покупку АКП Заявок пок. АКП Количество заявок на покупку АКП. Возможные значения:
  • «нет»;
  • «мало»;
  • «много»
Заявок на продажу АКП Заявок пр. АКП Количество заявок на продажу АКП. Возможные значения:
  • «нет»;
  • «мало»;
  • «много»
Время начала аукциона план. | Начало аук.план | Запланированное время начала аукциона. Формат определяется настройками операционной системы
Официальная текущая цена аукц. | Оф.цена аукц. | Официальная текущая цена аукциона
Максимальная доп. цена аукц. | Макс.цена аукц. | Максимальная допустимая цена аукциона
Минимальная доп. цена аукц. | Мин.цена аукц. | Минимальная допустимая цена аукциона
Объем аукциона руб | Объем аукц.руб | Объем сделок аукциона, в рублях
Количество сделок аукциона | Кол-во сд.аукц. | Количество сделок, совершенных на аукционе
Наличие спроса/предложения АКП Нал. спр./пред. Индикатор наличия заявок на покупку или продажу на аукционе крупными лотами по данному финансовому инструменту. Возможные значения:
  • «Нет»;
  • «Мало»;
  • «Много»;
  • «Есть»
Субординированный инструмент | Суборд инстр-т | Признак субординированного инструмента
Базис РЕПО | Базис РЕПО | Базис расчета РЕПО

Дополнительные параметры для инструментов Секций срочного рынка Московской Биржи, фондового и валютного рынков

Разница цены последней к предыдущей сессии | Изм. к пр. расч. | Разница между ценой последней сделки и расчетной ценой предыдущей торговой сессии, в ден.выражении
Максимально возможная цена | Макс.возм.цена | Максимально возможная цена заявки, в пунктах
Минимально возможная цена | Мин.возм.цена | Минимально возможная цена заявки, в пунктах
Открытый интерес | Кол-во отк.поз. | Количество открытых позиций по инструменту, штук
Расчетная цена | Расч. цена | Текущая расчетная цена, в пунктах
Предыдущая расчетная цена | Пред.расч. цена | Расчетная цена предыдущей торговой сессии, в пунктах
Лимит изменения цены | Лим.изм.цены | Предел отклонения цен заявок и сделок в текущей торговой сессии от расчетной цены предыдущей торговой сессии, в ден.выражении
Лимит изменения цены Т+1 | Лим. изм. цен T+1 | Предел отклонения цен заявок и сделок в следующей торговой сессии от расчетной цены, в ден.выражении
Лимит объема активных заявок (в контрактах) | Лим. акт. заяв. | Лимит количества открытых контрактов по инструменту, штук
Оборот внесистемных в деньгах | Оборот внес. | Объем всех внесистемных сделок за текущую торговую сессию, в ден.выражении
Количество внесистемных сделок за сегодня | Кол.внес.сдел. | Количество всех внесистемных сделок за текущую торговую сессию, штук
Количество контрактов в последней сделке | Кол-во послед. | Количество контрактов в последней сделке, штук
% изменения от закрытия | % измен. закр. | Изменение цены последней сделки от цены закрытия предыдущего дня, %
Разница цен последней и предыдущей сделок | Тренд | Разница между ценой последней совершенной сделки и ценой предыдущей сделки, в ден.выражении
Гарантийное обеспечение покупателя | ГО покупателя | Гарантийное обеспечение покупателя, в ден.выражении
Гарантийное обеспечение продавца | ГО продавца | Гарантийное обеспечение продавца, в ден.выражении
Время последнего изменения | Время изм. | Время последнего изменения информации по инструменту. Формат определяется настройками операционной системы
БГО по покрытым позициям | БГОП | Базовый размер гарантийного обеспечения по покрытым позициям, в ден.выражении
БГО по непокрытым позициям | БГОНП | Базовый размер гарантийного обеспечения по непокрытым позициям, в ден.выражении
Цена страйк | Страйк | Цена исполнения опциона (цена поставки базового актива), в пунктах
Стоимость шага цены | Ст. шага цены | Изменение стоимости позиции, соответствующее минимальному шагу цены, в ден.выражении
Тип опциона | Тип опциона | Тип опциона, PUT или CALL
Базовый актив | Баз.актив | Идентификатор инструмента в торговой системе, соответствующий базовому активу срочного контракта
Волатильность опциона | Волатильность | Волатильность опциона
Теоретическая цена | Теор.цена | Теоретическая цена опциона, в пунктах
Агрегированная ставка | Ставка | Процентная ставка для расчета вариационной маржи по процентным фьючерсам
Тип цены фьючерса | Тип цены | Наименование типа цены фьючерса
Статус клиринга | Статус кл. | Статус клиринга
Котировка после последнего клиринга | Кот.клиринга | Котировка после последнего клиринга
Валюта шага цены | Валюта шага цены | Валюта платежа
Текущая рыночная котировка | Рын.котир. | Текущая рыночная котировка фьючерса
Маржируемый | Марж. | Опцион маржируемый/с уплатой премии
Дата исполнения инструмента | Дата исп. | Дата исполнения инструмента
Стоимость шага цены для клиринга | Ст. шага цены кл | Стоимость шага цены для клиринга по инструментам, номинированным в другой валюте
Стоимость шага цены для промклиринга | Ст. шага цены пр | Стоимость шага цены для промежуточного клиринга по инструментам, номинированным в другой валюте
Цена первой сделки в тек. сессии | Перв.цена сессии | Цена первой сделки в текущей сессии
Цена последней сделки в тек. сессии | Посл.цена сессии | Цена последней сделки в текущей сессии
Тип исполнения опциона Тип исп.опц. Тип исполнения опциона. Возможные значения:
  • «Расчетный»;
  • «Поставочный»

Дополнительные параметры для опционов на акции

Коэффициент объема базового актива | Коэф.объема БА | Коэффициент, указывающий на объём базового актива в котировке контракта и страйках
Сумма объявленных денежных потоков | Сум.об.ден.поток | Сумма объявленных денежных потоков
Сумма прогнозных денежных потоков | Сум.пр.ден.поток | Сумма прогнозных денежных потоков
Безрисковая процентная ставка | Безрск.пр.ставка | Безрисковая процентная ставка, параметр транслируется в долях

Дополнительные параметры для биржевых индексов

Текущее значение | Знач. | Текущее значение индекса, пунктов
Закрытие | Закр. | Значение индекса при закрытии торгов предыдущего дня, пунктов
Время закрытия предыдущих торгов | Время закр. | Время закрытия предыдущих торгов. Формат определяется настройками операционной системы
Значение индекса на момент открытия торгов | Знач. при откр. | Значение индекса на момент открытия торгов, пунктов
Изменение текущего индекса по сравнению со значением открытия | Изм. к откр. | Изменение текущего индекса по сравнению с его значением на момент открытия торгов, пунктов
Изменение текущего индекса по сравнению со значением закрытия | Изм. к закр. | Изменение текущего индекса по сравнению со значением на момент закрытия торгов, пунктов

Дополнительные параметры для инструментов на СПВБ

Доходность к погашению | Дох. к погаш. | Доходность облигаций к погашению, в ден.выражении
Цена периода закрытия | Закр. | Средневзвешенная цена периода закрытия, в ден.выражении
Номинал | Номинал | Номинальная стоимость инструмента, в ден.выражении
ID аукциона | ID аукциона | Пользовательский идентификатор аукциона

Дополнительные параметры для инструментов на LSE

Реальный шаг цены | Р. шаг цены | Реальная величина изменения цены
Рыночный размер блока | Рын. разм. блока | Минимально возможное количество в выставляемой заявке
* - Опцион обозначается следующим образом: «EERU-6.06 120406C 18500», где «EERU-6.06» – код фьючерса, «120406С» – опцион CALL с датой исполнения 12 апреля 2006 г., «18500» – величина страйка


Раздел 4. Работа с графиками

  • Окно «Графики»
  • Настройка графика
  • Инструменты технического анализа
  • Методы технического анализа
  • График доходности облигаций

В разделе описана работа с графиками, инструментами и методами технического анализа.


Окно «Графики»

меню Создать окно / График... или кнопка

Назначение

Окно «Графики» предназначено для графического отображения изменения показателей в течение торгов.

Формат окна

Окно программы, в котором рисуются графики, называется диаграммой и выглядит следующим образом:

К окну графика может быть применен Режим связанных окон.

Элементы диаграммы:

  1. Окно диаграммы. Одна диаграмма может быть разделена по вертикали на несколько окон, имеющих одинаковую шкалу времени. Таким образом, в разных окнах можно строить графики по разным параметрам (например, в одном окне отображать изменение Цены последней сделки, в другом – Объема последней сделки). Разделитель между окнами можно двигать, меняя пропорции окон. Возможно построение до 15 окон в одной диаграмме.
  2. Область построения. Область внутри окна, в которой отображаются графики.
  3. Шкала. Область построения имеет оси координат: горизонтальную – шкалу времени, и вертикальные (левую и правую), соответствующие диапазону изменения параметров диаграммы. Вертикальный масштаб левой и правой шкалы может быть разным, для удобства отображения в одном окне графиков разных параметров.
  4. Сетка. Сетка разделяет область построения вертикальными и горизонтальными линиями на равные интервалы. Шаг сетки при этом равен шагу соответствующей шкалы.
  5. График. График отображает изменение параметра в зависимости от времени. Для разных параметров предусмотрены разные типы графиков. В одной диаграмме допускается максимум 15 графиков.
  6. Тренд. Линия, служащая для обозначения общего направления изменения параметра.
  7. Легенда. Подпись к графику, определяющая соответствие линий в диаграмме и параметров.
  8. Подсказка. Всплывающее окно с численными характеристиками данного отрезка графика. Появляется при наведении курсора на график.

См. также:

  • Типы графиков
  • Настройка графика


Типы графиков

В зависимости от времени:

  1. Тиковые. Новый отрезок графика откладывается при каждом изменении параметра. Например, для графика Цены – при каждом совершении сделки.
  2. Интервальные. Новый отрезок графика откладывается через равные интервалы времени. Текущие изменения параметра отображаются соответствующим изменением последнего отрезка графика.

В зависимости от вида линий:

  1. Линии – график в виде ломаной линии (1), концами отрезков которой являются значения параметра в определенный момент времени, для интервального графика – по последнему значению параметра в интервале времени.
  2. Свечи – график типа «японские свечи» (2). Предназначен для отображения цены сделок. Каждый отрезок графика представляет собой особый элемент (свечу), имеющую следующий смысл:
    • Тело свечи – прямоугольник, характеризующий изменение цены между началом периода (цена открытия) и концом периода (цена закрытия). Закрашенная свеча означает снижение цены сделки, не закрашенная – повышение цены;
    • Тень, или Фитиль свечи – тонкая линия, отмечающая диапазон колебания цены сделки в отрезке времени. Верхний край линии показывает максимальное значение цены сделки, нижний - минимальное.

    Возможно совпадение краев тела свечи и тени свечи. Например, если закрашенная свеча не имеет верхней тени, это означает, что в этом отрезке времени цена открытия совпала с максимальной ценой сделки.

    При отображении в одной области построения более одного графика графики смещаются по горизонтали относительно друг друга на 1-2 пикселя для избежания наложения «фитилей» свечей разных графиков.
  3. Гистограмма – график в виде столбиков (3). Предназначен для отображения объемов сделок. Высота столбика характеризует объем сделок в отрезке времени.
  4. Бары – график типа т.н. «баров», или линейный график. Один элемент графика представляет собой вертикальный отрезок, концы которого соответствуют максимальному и минимальному значению цены в периоде времени. Двумя короткими горизонтальными чертами отмечены цена открытия (слева от вертикального отрезка) и цена закрытия.

См. также:

  • Окно «Графики»
  • Способы создания нового графика
  • Настройка графика


Способы создания нового графика

Существует два способа построения диаграммы:

  • Быстрый – выбором в контекстном меню на какой-либо таблице пункта построения графика.
    При построении графика из таблицы «Текущие торги» параметр и инструмент определяются ячейкой, на которой вызвано контекстное меню.

    Открывается окно диаграммы с настройками, заданными по шаблону.

  • Пошаговый – через мастер построения графиков возможно создание новой диаграммы с произвольными настройками (по умолчанию параметры соответствуют шаблону).

    Последовательность действий при создании диаграммы через мастер графиков:

    • Создать новый график, воспользовавшись одним из следующих способов:
      • Выбрать пункт меню Создать окно/График…;
      • Нажать кнопку [image] в панели инструментов;
      • Выбрать пункт меню программы Действия/Новая диаграмма… при активном окне графика.
    • Выбрать источник данных для графика из списка доступных;

      Если текст, введенный в строке поиска, присутствует в имени класса, то в качестве результата поиска выводятся все инструменты данного класса.
    • Выбрать тип источника данных для графика:
      • Из Таблицы обезличенных сделок;
      • Из Таблицы истории значений параметров.

Также новый график можно создать копированием существующего, нажав клавиши «Ctrl»+«N».

См. также:

  • Окно «Графики»
  • Типы графиков
  • Настройка графика


Отображение заявок и сделок на графике

В окне графика возможно отображение активных заявок, стоп-заявок и сделок пользователя.

Заявки и стоп-заявки отображаются на графике в виде цветных горизонтальных линий, соответствующих уровням цен заявок.

Сделки на графике показаны в виде треугольников:

  • треугольники, направленные вверх – сделки на покупку;
  • треугольники, направленные вниз – сделки на продажу.

При наведении курсором мыши на индикатор (треугольник или линию) выводится окно подсказки с информацией: номер сделки/заявки, инструмент, характер сделки/заявки (купля или продажа), цена и количество.

О настройках отображения заявок и сделок см. Настройка вида графика.

См. также:

  • Окно «Графики»
  • Типы графиков
  • Настройка графика


Ввод заявок из окна графика

Ввод заявки из окна графика выполняется одним из следующих способов:

  1. На графике навести курсор на тело свечи и нажать левую кнопку мыши, удерживая нажатой клавишу «Ctrl».
  2. Включить режим ввода заявки из окна диаграммы, нажав кнопку [image] на панели инструментов «Графики». При этом окно ввода заявки открывается по нажатию левой кнопки мыши на теле свечи графика.
  3. Выбрать пункт «Новая заявка» / «Новая стоп-заявка» в контекстном меню на линии либо на легенде графика.

В (1) и (2) способах удерживайте нажатой левую кнопку мыши. При этом на экране появляется окно подсказки «Ввод заявки», в котором указано наименование инструмента и цена, соответствующая позиции курсора на графике. При перемещении курсора мыши вверх либо вниз меняется цена заявки.

Затем отпустите нажатую левую кнопку мыши. При этом на экране появляется окно ввода заявки с выбранным значением цены. Поле «Инструмент» автоматически заполняется наименованием инструмента, с графика которой вызвана форма заявки. Остальные поля заполняются, исходя из настроек по умолчанию.

Для выхода из режима ввода заявки достаточно вывести курсор за пределы окна графика и отпустить левую кнопку мыши, когда курсор примет вид значка «Отмена».

  1. Ввод заявки возможен только при наличии соединения с сервером.
  2. Поле «Код Клиента» может заполняться автоматически:
    • значением, указанным в настройках программы (пункт меню Система/Настройки/Основные настройки… , раздел «Торговля», поле «Код клиента»).
    • значением, указанным в «общем фильтре», если в нем выбран только один код клиента, а в настройках диаграммы включен признак «Применять глобальный фильтр при отображении торговых операций».


Управление заявками с помощью курсора мыши

  • Параметры заявки
  • Ввод заявки
  • Замена и снятие заявки
  • Особенность замены условных заявок типа «со связанной заявкой»
  • Особенность условных заявок «по исполнению»
    •

    Параметры заявки

    При наведении курсора на линию заявки отображается всплывающая подсказка с параметрами заявки. Курсор при этом меняет свой внешний вид, как показано на рисунке. На линиях стоп-заявок отображаются параметры стоп-заявок.

    Заявки типа «Тейк-профит и стоп-лимит» отображаются на графике двумя линиями одинакового цвета. При наведении курсора на линию отображается всплывающая подсказка. Для линии заявки с условием «Стоп-лимит» в подсказке указаны параметры «Стоп-лимит». Для линии заявки с условием «Тейк-профит» указаны параметры «Тейк-профит».

    Если в условии стоит признак «По рыночной цене», то в подсказке вместо параметров «Цена» и «Защитный спред» отображается значение «По рыночной цене». Если цена активации заявки «Тейк-профит» и цена условия «Стоп-лимит» совпадают, то на графике отображается одна линия, в этом случае всплывающая подсказка содержит параметры обоих условий заявки.

    Ввод заявки

    Описание см. «Ввод заявок из окна графика».

    Замена и снятие заявки

    Если в окне «Графики» включено отображение горизонтальных линий, соответствующих ценам активных заявок и стоп-заявок, то передвижением такой линии при помощи курсора мыши (режим drag-and-drop) можно выполнять замену соответствующей заявки либо ее снятие.

    Замена и снятие заявки доступны только при включенном режиме ввода / изменения заявки из окна диаграммы.

    Для замены заявки с использованием биржевой транзакции необходимо, чтобы в настройках Рабочего места были включены флажки «Заменять заявки путем изменения их параметров» и «По возможности заменять заявки путем изменения их параметров» (пункт меню Система / Настройки / Основные настройки…, раздел «Торговля» / «Заявки» / «Замена заявок»). Если флажок «По возможности заменять заявки путем изменения их параметров» отключен, то выполняется снятие активной (заменяемой) заявки и выставление новой заявки с измененными параметрами.

    Удерживая нажатой левую кнопку мыши, перемещайте линию вверх или вниз по графику:

    1. Переместить линию вверх - заменить активную заявку новой с повышением цены до указанного уровня.
    2. Переместить линию вниз - заменить активную заявку новой с уменьшением цены до указанного уровня.
    3. Переместить курсор за пределы текущей области построения графика - снять активную заявку.

    Перемещение на графике линий условных заявок типа «стоп-лимит», «стоп-цена по другому инструменту» и линий заявок с условием «по исполнению» возможно как при одновременно нажатой кнопке «Ctrl», так и без нее. Возможны следующие варианты:

    • Если при перемещении линиинажата клавиша «Ctrl», то изменяются как стоп-цена, так и цена лимитированной заявки, выставляемой при исполнении условной заявки.

      В случае условных заявок типа «стоп-лимит» и заявок «по исполнению» обе цены изменяются на одинаковую величину, равную разнице значений старой и новой стоп-цены. Таким же образом изменяются цены в случае перемещения линии условной заявки типа «стоп-цена по другому инструменту», когда инструмент стоп-цены и инструмент стоп-заявки совпадают. В противном случае, когда инструменты не совпадают, цена стоп-заявки изменяется на ту же процентную величину, на которую изменилась стоп-цена.

    • Если при перемещении линии клавиша «Ctrl» не нажата, то изменяется только значение стоп-цены, при этом цена лимитированной заявки, выставляемой при срабатывании условной заявки, остается без изменения.

    Перемещение на графике линий условных заявок типа «Тейк-профит и стоп-лимит», «Тейк-профит и стоп-лимит по исполнению активной заявки» возможно как при одновременно нажатой кнопке «Ctrl», так и без нее:

    • При перемещении линии тейк-профита происходит снятие и выставление новой стоп-заявки с новой стоп-ценой тейк-профита, другие условия заявки не изменяются. Нажатие клавиши «Ctrl» при этом не имеет значения.
    • При перемещении линии стоп-лимита происходит снятие и выставление новой стоп-заявки с новой стоп-ценой стоп-лимита. При нажатой клавише «Ctrl» изменяется стоп-цена и цена заявки на величину, равную разнице значений между старой и новой стоп-ценой стоп-лимита.

    Действия по замене и снятию заявок требуют подтверждения пользователем.

    Если при перемещении линии стоп-заявки новое значение стоп-цены оказалось не кратным шагу цены, принятому для данного класса инструментов, то происходит автоматическое округление цены стоп-заявки к ближайшему кратному значению с учетом правил арифметического округления. В процессе перемещения линия заявки отображается на графике с новой ценой, кратной шагу цены, принятому для данного класса инструментов.

    Если у заявки типа «стоп-цена по другому инструменту» инструменты условия и стоп-заявки не совпадают, то при перемещении линии такой условной заявки с нажатой клавишей «Ctrl», происходит автоматическое округление цены стоп-заявки к ближайшему кратному значению с учетом правил арифметического округления.

    Если по указанному в условной заявке инструменту были установлены диапазоны приемлемых цен (меню Система/Настройки/Параметры инструментов...), то, при перемещении линии стоп-заявки, новое значение цены проверяется на соответствие заданным ценовым диапазонам. При выходе цены из допустимого диапазона значений, на экране появляется сообщение об ошибке и перестановка заявки не выполняется. В этом случае необходимо повторить операцию, указав цену в пределах допустимого диапазона.

    При замене частично исполненной стоп-заявки типа «со связанной заявкой», объем новой стоп-заявки и связанной с ней лимитированной заявки будет равен неисполненному остатку заменяемой связанной лимитированной заявки.

    Особенность замены условных заявок типа «со связанной заявкой»

    Заявка данного типа является комбинированной и состоит из двух заявок одинаковой направленности – стоп-заявки и лимитированной заявки (подробнее см. Условные (стоп-) заявки). При замене данной стоп-заявки перемещением линии на графике заменяется только стоп-цена условной заявки, цена связанной с ней лимитированной заявки остается на прежнем уровне. В случае перемещения линии лимитированной заявки, связанная с ней стоп-заявка снимается. Если при перемещении линии стоп-заявки или линии лимитированной заявки была нажата клавиша «Ctrl», то будет произведена замена обеих связанных заявок. При этом стоп-цена, цена стоп-заявки и цена связанной лимитированной заявки изменятся на одинаковую величину, равную разнице значений старой и новой цены той из заявок, линия которой была перемещена.

    Особенность условных заявок «по исполнению»

    При замене активной заявки снимаются все условные заявки типа «по исполнению», у которых условием исполнения указана заменяемая заявка.

    При замене частично исполненной условной заявки «по исполнению» объем новой стоп-заявки равен неисполненному остатку лимитированной заявки-условия.


Отображение меток на графике

Метки на график наносятся пользователем и могут быть следующих типов:

  • Текстовая метка – подпись графика либо элемента на графике.
  • Заметка – текстовое описание, отображается на графике при наведении курсором на значок метки.
  • Выноска – надпись с указателем на точку на графике.
  • Отметка цены – выноска, содержащая значение цены в точке на графике.
  • Картинка из файла – произвольное изображение, к которому можно привязать текст. Изображение загружается пользователем из файла.
  • Значок – изображение из фиксированного набора.

Для создания новой метки выберите тип метки в контекстном меню «Метка…» на нужной области построения графиков, далее:

  • для меток «Отметка цены», «Значок» – нажмите левой кнопкой мыши на месте привязки метки на графике (опорная точка метки). Для метки «Отметка цены» необходимо повторным нажатием левой кнопкой мыши на графике указать положение выноски с текстом (вторая опорная точка);
  • для меток «Текст», «Выноска», «Картинка из файла», «Заметка» – нажмите левой кнопкой мыши на месте привязки метки на графике (опорная точка метки) и настройте параметры новой метки. Далее для метки «Выноска» необходимо нажатием левой кнопкой мыши на графике указать положение выноски с текстом (вторая опорная точка).

Метка, привязанная к одному из элементов графика, смещается при перемещении данного элемента. Непривязанная метка при перемещении отображенного в окне графика инструмента остается неподвижной.

Для перемещения метки подведите курсор к месту привязки метки, нажмите левую кнопку мыши (рядом с курсором появится значок в виде руки) и тяните в нужном направлении.

Для копирования метки подведите курсор к метке, нажмите левую кнопку мыши, удерживая нажатой клавишу «Ctrl», и потяните в нужном направлении.

Для меток «Выноска» и «Указание цены» возможно изменение ширины выноски с текстом: выделите метку, нажав на нее левой кнопкой мыши, подведите курсор ко второй опорной точке метки (рядом с курсором появится значок в виде руки), нажмите левую кнопку мыши и тяните вправо/влево для увеличения/уменьшения размера выноски.

Функции, доступные из контекстного меню метки:

  • «Редактировать…» – открытие окна «Редактирование метки» для настройки параметров метки.
  • «Копировать» (или «Ctrl»+«C») – копировать выбранную метку в буфер обмена. Для вставки скопированной метки на график выберите в контекстном меню области построения пункт «Вставить» или примените комбинацию клавиш «Ctrl»+«С».
  • «Удалить метку» (или «Del») – удалить выбранную метку.

Работа с метками поддерживается языком QPILE. С его помощью можно устанавливать, или изменять метки.

См. также:

  • Окно «Графики»
  • Настройка графика


Настройка графика

Окно редактирования настроек графика вызывается одним из следующих способов:

  • Выбором пункта меню программы Действия/Редактировать… при активном окне графика. Окно настройки открывается на странице «Свойства диаграммы ».
  • Выбором пункта контекстного меню «Редактировать…» из активного графика:
    • на области построения графика – окно настройки открывается на странице редактирования настроек области построения;
    • на линии графика или на легенде графика – окно настройки открывается на странице редактирования данного графика.
  • Двойным нажатием левой кнопки мыши:
    • на области построения графика – окно настройки открывается на странице редактирования настроек области построения;
    • на линии графика или на легенде графика – окно настройки открывается на странице редактирования данного графика.

В левой части окна представлен список отображаемых на данной диаграмме графиков и индикаторов. Области построения располагаются в порядке их следования на графике. Порядок расположения объектов внутри области построения определяется настройкой «Порядок отображения слоев данных на диаграмме».

  • Для изменения порядка отображения графиков в текущем окне диаграммы используйте стрелки «вверх» и «вниз». При этом первый график в списке располагается в самом верхнем слое на диаграмме.
    Для быстрого перемещения графиков и областей построения воспользуйтесь режимом «drag-and-drop».
  • Для добавления нового графика используйте кнопку «Добавить». При этом новая область построения с графиком добавляется в конец списка, а новый график в существующую область построения добавляется в начало списка (в верхний слой окна диаграммы).
  • Для удаления графика из списка используйте кнопку «Х».
    Область построения графиков перемещается / удаляется вместе с содержащимися в ней графиками и индикаторами.

В правой части экрана отображаются параметры настройки. Окно редактирования настроек графика разделено на страницы, переключение между которыми осуществляется в окне слева.


Настройка свойств диаграммы

На странице «Диаграмма» выполняется настройка общих параметров диаграммы.

  • Вкладка «Свойства диаграммы»
  • Вкладка «Внешний вид»

    • Вкладка «Свойства диаграммы»

    1. «Заголовок» – заголовок диаграммы.
      • «Авто» – если флажок установлен, то заголовок присваивается автоматически и недоступен для редактирования.
        Если включен режим связанных окон, то при смене инструмента значение поля изменяется автоматически.
    2. «Инструмент» – название инструмента, по которому построен график. Если на диаграмме построены графики по разным инструментам, то значение поля: «Несколько инструментов».
      • «Изменить» – изменить инструмент, к которому относятся кривые на графике. Диалог замены инструмента содержит следующие поля:

        • «Заменить» – инструмент (или список инструментов), выбранный источником данных в диаграмме. Если инструментов больше одного, то по умолчанию выбран инструмент, являющийся источником для наибольшего количества графиков на диаграмме. При отсутствии приоритета по количеству графиков инструменты сортируются по алфавиту;
        • «Новый инструмент» – список инструментов, сгруппированный по классам;
        • Признак «Только активные инструменты» позволяет исключить из списка бумаги или контракты, не имеющие заявок, сделок или открытых позиций. Под активными инструментами понимаются такие инструменты, по которым на Бирже в текущую торговую сессию присутствовали либо присутствуют заявки, сделки или открытые позиции (для фьючерсов). Рабочее место QUIK определяет данный факт по значению параметров таблицы Текущих торгов: «Лучшая цена спроса», «Лучшая цена предложения», «Количество сделок», «Количество открытых позиций».
          Если список получаемых параметров задан вручную, и в него не входят параметры, указанные выше, то признак «Только активные инструменты» работает некорректно.
    3. «Интервал» – устанавливает промежутки времени, через которые откладываются новые отрезки на диаграмме. При выборе значения «Тиковый» создается тиковый график. Величина интервала отображается в квадратных скобках справа от заголовка окна диаграммы и отделяется от заголовка знаком «-».
    4. «Диапазон данных» – диапазон отображаемых значений:
      • «не ограничен» – показать значения за весь доступный период времени;
      • «последние ... интервалов» – отображать на графике указанное количество интервалов. Данные за более ранние периоды времени удаляются из области построения. Рекомендуется для наблюдения за краткосрочной динамикой изменения параметра;
      • «за период ... – ...» – установить для диаграммы указанный интервал дат;
      • «Сегодня» – при установленном флажке отображаются данные за текущий день;
      • «Фильтр по времени ... – ...» – при установленном флажке отображаются данные за указанный интервал времени.
    5. «Шкала времени»:
      • «Начальный масштаб: … интервалов» – минимально допустимое количество интервалов на графике. Параметр имеет значение в начале торговой сессии для предотвращения растягивания интервалов во всю ширину области построения;
      • «Правый край … интервалов» – количество пустых интервалов на графике, добавляемых справа. Используется для продления линий трендов на будущие периоды;
      • «Показывать пустые интервалы» – если флажок включен, то на шкале времени отображаются все интервалы времени; если флажок выключен, то отображаются только интервалы, содержащие сделки. По умолчанию флажок снят;
      • «Прерывать линию на пустых интервалах более … мин» – не рисовать линию при построении графика типов «Линии» или «Пунктир», если последовательность пустых интервалов больше указанной величины. Параметр доступен для заполнения при включенном флажке «Показывать пустые интервалы».
    6. «Применять глобальный фильтр при отображении торговых операций» – признак отображения заявок и сделок на графике в соответствии с общими фильтрами.

      Если в общем фильтре выбран только один код клиента, то при установленном признаке «Применять глобальный фильтр при отображении торговых операций» автоматически заполняется поле «Код клиента» на форме ввода заявки, открытой из окна графика (см. Ввод заявок из окна графика).

    7. «Оставлять трендовые линии, фигуры и метки при смене инструмента» – признак отображения трендовых линий, фигур и меток на графике после смены инструмента. По умолчанию флажок включен.

    При нажатии кнопки «Применить» данные на диаграмме обновляются в соответствии с изменением настроек. Кнопка «ОК» закрывает окно редактирования графика с сохранением изменений, кнопка «Отмена» – без сохранения изменений.

    Вкладка «Внешний вид»

    Настройки позволяют задать цвета для элементов диаграммы (фона, осей, сетки, шрифтов, цвет и толщину линий трендов). Правила настройки цвета описаны в п. Настройка цвета в таблицах и графиках.

    Дополнительные параметры:

    1. «Показывать на графике» – настройка отображения элементов графика:
      • «Шкалу времени» – показывать значения на шкале времени (горизонтальная ось);
      • «Вертикальную сетку» – показывать вертикальные линии сетки на области построения.
    2. «Показывать подсказку» – выбор способа отображения параметров выбранной свечи:
      • «Рядом с указателем» – при наведении курсора на свечу отображается всплывающая подсказка рядом с ней;
      • «Вверху слева» – параметры отображаются в верхнем левом углу диаграммы.
    3. «Порядок отображения слоев данных на диаграмме» – в окне настраивается порядок отображения слоев диаграммы. Для изменения порядка отображения слоев используйте стрелки «вверх» и «вниз». При этом самый верхний слой в списке является нижним слоем на диаграмме.

    При нажатии кнопки «Применить» данные на диаграмме обновляются в соответствии с изменением настроек. Кнопка «ОК» закрывает окно редактирования графика с сохранением изменений, кнопка «Отмена» – без сохранения изменений.

    См. также:

    • Добавление графика в диаграмму
    • Настройка вида графика
    • Рекомендации по работе с графиками


Настройка области построения графика

На странице «Область <номер области>» выполняется настройка параметров области построения диаграммы.

  1. «Легенда» – включение отображения легенды графика и настройка ее расположения относительно области построения:
    • «Над графиком» – над областью построения;
    • «Под графиком» – под областью построения.
  2. «Левая / Правая шкала»:
    • «Максимум» – установить максимальное значение шкалы;
    • «Минимум» – установить минимальное значение шкалы;
    • «Логарифмическая» – выбор типа шкалы графика. Если флажок не установлен, то используется линейная шкала;
    • «Горизонтальная сетка» – включение отображения горизонтальных линий сетки на области построения;
    • «Шаг сетки»:
      • «Авто» – автоматическое определение масштаба вертикальной шкалы (шага сетки, максимального и минимального значений параметров в отображаемом диапазоне времени);
      • «Шаг цены инструмента» – масштаб вертикальной шкалы определяется исходя из минимального шага цены инструмента;
      • Значение шага цены, задаваемого вручную.
  3. «Автоматический масштаб по вертикали»:
    • «По видимым значениям» – вертикальный масштаб графика подбирается автоматически по диапазону максимального и минимального значений свечек, находящихся в видимой области диаграммы;
    • «По всем значениям» – вертикальный масштаб графика подбирается по максимуму/минимуму значений всех свечек на диаграмме;
    • «С учётом цен заявок и позиций» – при установленном флажке вертикальный масштаб графика подбирается с учетом значений цены заявок и сделок, отображаемых линиями и метками. При снятом флажке вертикальный масштаб графика определяется настройками предыдущих пунктов.

См. также:

  • Добавление графика в диаграмму
  • Настройка вида графика
  • Рекомендации по работе с графиками


Настройка вида графика

На странице «<Наименование инструмента> [<Вид графика>]» выполняется настройка параметров внешнего вида определенного графика.

  • Вкладка «Свойства»
  • Вкладка «Параметры»
  • Вкладка «Дополнительно»
  • Вкладка «Уровни»

    • Вкладка «Свойства»

    1. «Подпись» – редактирование подписи к линии графика, например, чтобы сделать легенду более компактной.
    2. «Вид графика» – выбор типа графика:
      • «Свечи»;
      • «Линии»;
      • «Линия с подсветкой»;
      • «Линия с градиентом»;
      • «Гистограммы»;
      • «Бары»;
      • «Точки»;
      • «Пунктир».
    3. «Цвет линии» – выбор цвета толщины линии графика.
    4. «Цвет градиентной заливки» – выбор цвета градиентной заливки графика. По умолчанию используется цвет линии. Доступно для редактирования при выборе вида графика «Линия с подсветкой» или «Линия с градиентом».
    5. «Выделять цветом» – признак раскраски элементов графика разными цветами в зависимости от направления изменения значений индикатора в соответствующем интервале времени.
      • «Рост» – выбор цвета, демонстрирующего повышение значения;
      • «Падение» – выбор цвета, демонстрирующего понижение значения.

      Графики Price и Volume изменяют цвет в зависимости от направления изменения цены в данном интервале.

      Настройка доступна для графиков видов «Свечи», «Бары» и «Гистограммы». Для графиков вида «Свечи» возможен выбор различных цветов для раскраски тела и границы свечи.
    6. «Масштаб графика» – выбор оси (левой или правой), по которой выполняется масштабирование графика по вертикали.
    7. «Показывать последнее значение» – признак отображения последнего значения цены (или настраиваемого индикатора) на оси графика.
    8. «Учитывать при автомасштабировании» – учитывать данный график при автомасштабировании, если на диаграмме отображается несколько графиков. По умолчанию флажок включен.

      Настройка должна быть включена хотя бы для одного графика на каждой оси.

    Вкладка «Параметры»

    Вкладка содержит параметры настройки индикаторов. Доступна для индикаторов технического анализа.

    Вкладка «Дополнительно»

    1. «Сдвиг графика» – позволяет сдвигать график по оси времени на указанное количество интервалов. Для сдвига вперед (в будущее) используйте положительные значения, для сдвига назад – отрицательные.
    2. «Процентное изменение» – при установленном флажке на оси значений (ординат) графика откладывается не абсолютное значение параметра, а его относительное отклонение от начального значения, в процентах. В качестве исходного значения используется:
      • «Абсолютное значение» – значение, указанное в поле ниже;
      • «Цена закрытия» – цена закрытия предыдущего дня.
    3. «Идентификатор» – уникальный строковый идентификатор, присваиваемый графику. Идентификатор используется при получении доступа к указанному графику средствами языка QLua или QPILE.
    4. «Заявки» – настройка отображения заявок на графике:
      • «Показывать заявки» – отображать на графике горизонтальные линии, соответствующие ценам активных заявок клиента;
      • «Цвет покупки», «Цвет продажи» – цвета линий для заявок на покупку и на продажу.
    5. «Стоп-заявки» – настройка отображения стоп-заявок на графике:
      • «Показывать стоп-заявки» – отображать на графике горизонтальные линии, соответствующие ценам активных стоп-заявок пользователя;
      • «Цвет покупки», «Цвет продажи» – цвета линий для заявок на покупку и на продажу.

      В зависимости от типа условной заявки, линии на графике отображаются на следующих уровнях:

      • «Стоп-лимит», «Со связанной заявкой» – на уровне стоп-цены;
      • «Стоп-цена по другому инструменту» – на уровне стоп-цены (линия отображается на графике инструмента, по которому задано условие);
      • «Тейк-профит» и «Тейк-профит и стоп-лимит» – на уровне стоп-цены тейк-профита.

    6. «Сделки» – настройка отображения сделок на графике:
      • «Показывать сделки» – отображать на графике сделки пользователя. Сделки отображаются маркером в виде треугольника, показывающего направленность сделки (вверх – покупка, вниз – продажа);
      • «Цвет покупки», «Цвет продажи» – цвета маркеров для сделок по цене покупки и по цене продажи.

    Вкладка «Уровни»

    На вкладке задаются значения для горизонтальных линий (уровней), отображаемых на графике. Уровни откладываются по значениям той оси, к которой привязан график.

    Чтобы задать новый уровень, в поле «Введите значение:» укажите его значение и нажмите кнопку «Добавить». Значение добавится в список, расположенный ниже.

    Значение указывается в единицах цены, кроме случая, когда для графика на вкладке «Дополнительно» включен признак «Процентное изменение».

    Чтобы удалить уровень, выберите его в списке и нажмите кнопку «Удалить».

    Флажки в разделе «Показывать» позволяют отобразить на графике следующие уровни значений и выбрать их цвет:

    Настройки недоступны для графика, построенного по параметру, отличному от «Price».
    • «Уровень цены» - показать линию на уровне цены последней сделки. Если вместо графика цены будет создан график по параметру, то линия будет соответствовать последнему значению параметра.
    • «Уровень позиции» - показать линию на уровне значения цены приобретения, взятой из таблицы «Позиции по инструментам» по данному коду клиента и данному инструменту.
    • «Значение позиции» - показать на вертикальной шкале значение позиции.

    Настроенные уровни цен запоминаются в шаблоне графика. При копировании окна графика нажатием клавиш «Ctrl»+«N» они переносятся в новое окно.

    См. также:

    • Настройка параметров диаграммы
    • Добавление графика в диаграмму


Добавление графика в диаграмму

Добавление графика в диаграмму осуществляется одним из следующих способов:

  • Нажать кнопку [image] на панели инструментов «График».
  • Выбрать пункт контекстного меню «Добавить график (индикатор)…» в активном графике.
  • Выбрать пункт меню программы Действия/Добавить график (индикатор)… при активном окне графика.
  • Нажать кнопку «Insert» при активном окне графика.
  • Нажать кнопку «Добавить» в левой части окна редактирования графика.

  1. График добавляется в новую область построения.
  2. Индикаторы Alligator, AMA, Bollinger Bands, Envelopes, Fractals, Ichimoku, Parabolic SAR, Price Channel добавляются на график цены выбранного инструмента. Остальные индикаторы добавляются в новую область построения.

Окно добавления графика в диаграмму содержит следующие настройки:

  1. «Источник данных» – выбор инструмента и параметра, используемых в качестве источника данных для графика. В списке доступны все источники, отображаемые на данном графике. Для добавления нового источника данных нажмите кнопку «Новый»:

    Окно выбора нового источника данных содержит следующие настройки:

    • «Инструмент» – выбор инструмента из списка доступных. По умолчанию выбирается инструмент, по которому в диаграмме построен график цены.
    • «Только активные инструменты» – позволяет исключить из списка бумаги или контракты, не имеющие заявок, сделок или открытых позиций.
      Если выбранный инструмент не найден в справочнике, то выводится предупреждение вида: «При создании диаграммы <…> не удалось создать график <…> для инструмента <…>, так как данный инструмент отсутствует в справочнике инструментов». Легенда такого графика выглядит следующим образом: .
    • «Тип источника данных» – выбор источника данных для графика. Для смены источника данных нажмите кнопку «Изменить».

      • Выбор Таблицы обезличенных сделок позволяет строить график цены и объема сделки (рекомендуется).
      • Выбор Таблицы истории значений параметров дает возможность строить графики по большему количеству параметров, список которых отображается ниже.

      Рекомендации к выбору типа источника данных:
      • В Таблице истории значений параметров учитываются изменения параметров через определенные периоды времени, поэтому некоторые сделки могут быть пропущены. Для построения графика цены и объема сделок используйте источник «Таблица обезличенных сделок».
      • Данные в Таблице истории накапливаются в течение сеанса связи с сервером и могут иметь пропуски в тех периодах времени, когда связь с сервером отсутствовала. Чтобы получить непрерывный ряд данных, поставьте флажок «Получать пропущенные данные» в пункте меню Система / Настройки / Основные настройки..., раздел «Программа» / «Сохранение данных».
      • Данные из Таблицы истории не накапливаются в архиве и недоступны для построения графика за несколько дней.
      • При построении графика по «Таблице обезличенных сделок» данные берутся из этой таблицы, если пользователем была создана хотя бы одна таблица такого типа. При отсутствии Таблицы обезличенных сделок данные заказываются с сервера в виде интервалов требуемой дискретности, для минимизации трафика.
  2. «Тип графика» – выберите тип графика из предлагаемого списка.

    Значение «Price» соответствует графику цены последней сделки, «Volume» – графику объема последней сделки. Остальные типы графиков представляют собой различные индикаторы технического анализа.

  3. При установленном признаке «Поместить график в новую область» для нового графика на диаграмме создается новая область построения.

См. также:

  • Использование панелей инструментов
  • Инструменты технического анализа
  • Методы технического анализа


Работа с графиками в режиме «drag-and-drop»

Изменение порядка отображения графика в текущем окне диаграммы

Для изменения порядка отображения графиков в режиме «drag-and-drop» необходимо, чтобы в окне диаграммы отображались легенды графиков.

Графики и индикаторы отображаются в порядке расположения легенд на диаграмме. Таким образом, график, легенда которого находится в конце списка, отображается поверх всех остальных графиков и индикаторов.

Если при перемещении легенды графика курсор принял вид [image] , то перемещение невозможно. В этом случае при отпускании кнопки мыши не производится никаких действий.

Последовательность действий:

  1. Поместите курсор на выбранную легенду и нажмите левую кнопку мыши (на экране появится курсор [image] ).
  2. Удерживая левую кнопку мыши нажатой, переместите курсор с легендой выбранного графика в нужное место в списке легенд диаграммы. Отпустите левую кнопку мыши.

    Пример:

Перемещение графика

Для перемещения графика в окне диаграммы из одной области построения в другую или для его перемещения в другое окно диаграммы, поместите курсор на легенду выбранного графика, нажмите на левую кнопку мыши и, удерживая эту кнопку, переместите курсор с легендой в нужное место, затем отпустите левую кнопку мыши. Легенда перемещенного графика становится последней в панели диаграммы.

При переносе графика на другую панель диаграммы переносятся следующие связанные объекты:

  • заявки;
  • стоп-заявки;
  • сделки;
  • уровни пользователя;
  • уровень цены;
  • уровни позиций;
  • трендовые линии.

Подтверждение на перемещение графика при установленном флажке «Запрашивать подтверждение при перемещении и удалении объектов с помощью drag-and-drop» в меню Система / Настройки/Основные настройки..., раздел «Таблицы» запрашивается в случае, если:

  • перемещение происходит в окно, в настройках которого выключено отображение легенд;
  • график перемещается в окно другой диаграммы.

Удаление графика

Для удаления графика, поместите курсор на легенду выбранного графика и нажмите левую кнопку мыши (на экране появится курсор [image]). Удерживая кнопку мыши нажатой, переместите курсор с легендой за пределы окна диаграммы (курсор изменит вид на [image] ) и отпустите кнопку мыши.

Подтверждение при удалении графика запрашивается в случае, если установлен флажок «Запрашивать подтверждение при перемещении и удалении объектов с помощью drag-and-drop» в меню Система / Настройки/Основные настройки..., раздел «Окна» / «Таблицы».


Рекомендации по работе с графиками

Какую из двух возможных таблиц назначить источником данных для графика?

  • Для графиков цены и объема сделки рекомендуется использовать Таблицу обезличенных сделок, содержащую полную информацию о заключенных сделках. Для прочих параметров – Таблицу истории значений параметров.

Как переименовать подпись параметра в легенде?

  • Откройте пункт контекстного меню «Редактировать…» и на странице редактирования настроек данного графика поменяйте название в поле «Подпись».

Как расположить графики по разным инструментам в одной области построения?

  • Постройте стандартный график,
  • Выберите пункт контекстного меню «Добавить график (индикатор)…».
  • Нажмите кнопку «Новый», выберите инструмент для добавления и нажмите кнопку «Выбрать».
  • С помощью мыши перетащите созданный график в нужную область построения.

Как разместить графики цены и объема в одной области построения?

  • Постройте график цены и объема.
  • Двойным нажатием левой кнопки мыши на легенде созданного графика вызовите окно настроек.
    • В левой части окна с помощью мыши перетащите график объема в область построения, в которой расположен график цены;
    • В правой части окна выберите «Масштаб графика» «по левой шкале».
  • Нажмите кнопку «Сохранить».

Как оптимально разместить несколько диаграмм на экране?

  • Если настроено много диаграмм и они не умещаются на экране, расположите их на разных вкладках. Система QUIK не имеет ограничений на число настроенных диаграмм и экранных вкладок. При разрешении экрана 800х600 рекомендуемое количество диаграмм на одной вкладке – от 2 до 4.

Как сделать, чтобы на диаграмме отображались все имеющиеся данные без прокрутки изображения?

  • Откройте контекстное меню графика и выберите пункт «Весь график» либо нажмите кнопку [image].

Как изменить инструмент на созданном графике?

  • Двойным нажатием левой кнопки мыши на свободном месте графика вызовите окно настроек. На странице «Диаграмма» нажмите кнопку «Изменить» и выберите из списка новый инструмент для отображения графика с текущими настройками. Описание диалога замены инструмента см. в п. Свойства диаграммы.

Как перенести настройки графика в новое окно?

  • Нажатием клавиш «Ctrl»+«N» создайте копию окна с графиком. Затем, если требуется в новом окне изменить инструмент, см. описание в предыдущем пункте.


Работа с шаблонами графиков

  • Просмотр списка шаблонов
  • Создание нового шаблона
  • Применение шаблона

    • Шаблон представляет собой конфигурацию окна «График», сохраненную под определенным именем. Такой шаблон можно применить к уже существующим окнам, а также воспользоваться им для быстрой настройки нового графика.

    Просмотр списка шаблонов

    Просмотр списка шаблонов осуществляется через пункт контекстного меню Шаблон диаграммы/Шаблоны... на окне графика или пункт меню программы Действия/Шаблон диаграммы/Шаблоны….

    • Настройка шаблона по умолчанию. Выделите в списке доступных шаблонов требуемую конфигурацию окна и нажмите кнопку «Брать по умолчанию». Название шаблона появится в разделе «Шаблон по умолчанию».
    • Переименование шаблона. Выберите нужный шаблон и нажмите кнопку «Переименовать». В открывшемся диалоге введите новое название и нажмите кнопку «Ввод».
    • Удаление шаблона. Нажатие кнопки «Удалить» удаляет выделенный шаблон.
    • Применение шаблона к нескольким окнам. Нажатие кнопки «Применить ко всем окнам» изменяет настройки всех графиков в соответствии с выбранным шаблоном, нажатие кнопки «Применить к окнам на вкладке» - к окнам на текущей вкладке.

    Создание нового шаблона

    1. Настройте в качестве образца новое окно графика котировок или выберите одно из существующих.
    2. Выберите из контекстного меню на графике пункт Шаблон диаграммы/Сделать шаблоном....
    3. Для обновления шаблона выберите его название в открывшемся окне и нажмите кнопку «Сохранить».
    4. Для создания нового шаблона нажмите кнопку «Сохранить в новый». В открывшемся диалоге введите название и нажмите кнопку «Ввод».
    5. Нажмите кнопку «Закрыть».

    Применение шаблона

    Задать настройки графика по шаблону можно из пункта контекстного меню Шаблон диаграммы / <Имя шаблона> или аналогичного пункта из меню программы Действия.


Использование панели инструментов

Для работы с графиками рекомендуется включить на панели инструментов панель «График»:

Назначение кнопок на панели «График»:

Кнопки, отображение которых отличается для темной темы оформления интерфейса приведены в таблице через символ «/».

Кнопка Назначение
/ Добавить новый график в выбранное окно (диаграмму)
Изменить величину интервала
Настроить отображение информации о положении курсора в области построения графика. Описание см. ниже
/ Отобразить всю область графика в окне, если он был увеличен или уменьшен
/ Увеличить масштаб графика
/ Уменьшить масштаб графика
Измерить расстояние между точками на графике
/ Включить режим ввода / изменения заявки из окна диаграммы. Если настройка выключена, то невозможно перемещать и выставлять заявки из окна диаграммы
/ Перемещать график с помощью «захвата» мышью
Рисовать трендовые линии и фигуры
Рисовать трендовую линию
Рисовать горизонтальную линию
Рисовать горизонтальный луч
Рисовать вертикальную линию
Рисовать прямоугольник
Рисовать треугольник
Рисовать эллипс
Рисовать дуги Фибоначчи
Рисовать скоростные линии
Рисовать веер Фибоначчи
Рисовать уровни Фибоначчи
Рисовать временные зоны Фибоначчи
Рисовать канал
Рисовать глубину рынка
Нанести метку на график
Поместить на график текстовую метку
Поместить на график заметку
Поместить на график текстовую выноску
Поместить на график выноску с указанием цены
Поместить на график изображение, загруженное из файла
Поместить на график изображение, выбранное из набора встроенных картинок
Выключить / включить отображение на графике трендовых линий, фигур и меток
Закрепить выбранный на панели инструмент
Притягивать точки трендовых линий и фигур к ближайшим ценам свечей

На панели расположена кнопка "Перекрестие" [image], которая включает отображение информации о положении курсора в области построения графика. При включении кнопки «Перекрестие» автоматически появляется выпадающее меню, из которого пользователь выбирает способ отображения координат курсора.

Возможен выбор одного или нескольких способов. Если ни один из способов не выбран, то кнопка «Перекрестие» не активна. При отключении кнопки «Перекрестие» настройки пользователя сохраняются. Возможные способы отображения координат курсора:

  • «Показывать перекрестие» - включает отображение линий перекрестия с осями (1) .
  • «Значение рядом с курсором» - информация отображается рядом с курсором в виде прямоугольника (2) со значением в формате:
    [значение оси]
    ДД.ММ.ГГ ЧЧ:ММ
    Если на графике есть привязка к левой и к правой оси (в случае расположения в одном окне двух графиков), то значение указывается в формате:
    [значение левой оси] [значение правой оси]
    ДД.ММ.ГГ ЧЧ:ММ
  • «Значение на оси» - информация отображается на осях в виде прямоугольных выносок (3), в которых указываются значения даты и времени (ось абсцисс) и соответствующего им значения (ось ординат). Выноски перемещаются по осям при движении курсора по графику.

См. также:

  • Редактирование графика при помощи «мыши»
  • Доступные функции
  • Рисование линий
  • Линейные инструменты


Редактирование графика при помощи «мыши»

Просмотр и редактирование:

  • Навести курсор мыши на график – получить окно подсказки с числовыми значениями параметров для данного отрезка графика.
  • Двойное нажатие левой кнопки мыши – открыть окно редактирования графика.

Масштабирование графика:

  • Нажать левую кнопку мыши на вертикальной шкале и тянуть вверх/вниз – регулировка масштаба графика по вертикали. Вернуться к автоматическому масштабированию можно двойным нажатием левой кнопки мыши на этой шкале.
  • Нажать левую кнопку мыши на горизонтальной шкале и тянуть влево/вправо – изменять масштаб графика по оси времени.

Управление графиком вращением колесика мыши:

  • Над областью построения графика – прокручивать график влево/вправо.
  • Над областью построения графика, если график выходит за пределы области построения по вертикали – прокручивать график вверх/вниз.
  • Над вертикальной полосой прокрутки окна графика – прокручивать график вверх/вниз.
  • Над горизонтальной шкалой графика – прокручивать график влево/вправо.

См. также:

  • Использование панелей инструментов
  • Доступные функции


Доступные функции

  • «Линейка» – измерение расстояния между точками графика. Функция доступна из панели инструментов «График» (см. п. «Измерение расстояния»).

Функции, доступные для графика, могут быть вызваны из пункта меню Действия или контекстного меню области построения графика:

(*) Функция доступна только из меню Действия.
(**) Функция доступна только из контекстного меню.
  • «Новая диаграмма...» * – построить новую диаграмму.
  • «Новая диаграмма доходности облигаций…» * – создать новую диаграмму доходности облигаций.
  • «Добавить график (индикатор)…» (или «Insert») – добавить новый график (индикатор) в текущее или новое окно диаграммы.
  • «Нарисовать» ** – добавить элемент на график:
    • «Линия тренда»;
    • «Горизонтальная линия»;
    • «Горизонтальный луч»;
    • «Вертикальная линия»;
    • «Прямоугольник»;
    • «Треугольник»;
    • «Эллипс»;
    • «Дуги Фибоначчи»;
    • «Скоростные линии»;
    • «Веер Фибоначчи»;
    • «Уровни Фибоначчи»;
    • «Временные зоны Фибоначчи»;
    • «Канал»;
    • «Глубина рынка».
  • «Метка…» – выбрать тип пользовательской метки. При нажатии левой кнопки мыши на графике (в точке привязки метки) открывается окно настройки выбранного типа метки.
    • «Текст…»;
    • «Заметка…»;
    • «Выноска…»;
    • «Отметка цены…»;
    • «Картинка из файла…»;
    • «Значок».
  • «Добавить новую область…» – добавить на текущую диаграмму новую область построения графиков.
  • «Вставить» (или «Ctrl»+«V») – установить на графике скопированный элемент: линию тренда, фигуру или метку.
    Копия элемента помещается поверх исходного элемента и имеет аналогичные параметры.
  • «Удалить» – удалить элемент диаграммы:
    • «Область <номер области>» – удаление области построения графиков. При удалении области построения удаляются все содержащиеся в ней графики;
    • «<Название графика>» – удаление графика;
    • «Все линии трендов и фигуры» ** – удаление всех трендов, каналов, линий, уровней Фибоначчи с текущей области построения. График цены/объема и индикаторы при этом не затрагиваются. Тренды удаляются с предварительным подтверждением;
    • «Все метки в диаграмме» – удаляет все метки, установленные на данном графике. Метки удаляются с предварительным подтверждением.
  • «Подключиться к каналу» – привязать окно графика к основной таблице (подробнее см. Режим связанных окон).
    • «<Название таблицы>» – привязка окна графика к данной таблице;
    • «Отключить» – отключение окна графика от канала.
  • «Скрыть рисунки» / «Показать рисунки» – выключить / включить отображение на графике трендовых линий, фигур и меток.
    При добавлении на график нового элемента все элементы становятся видимыми.
  • «Закрепить инструмент» – если режим включен (установлен флажок слева), то выбранный на панели инструмент для работы с трендовыми линиями, фигурами или метками считается включенным и используется повторно. Отключить выбранный инструмент можно одним из следующих способов:
    • повторным нажатием кнопки включения данного инструмента на панели инструментов;
    • нажатием кнопки «Esc».
    Если режим выключен (флажок слева снят), то выбранный инструмент используется однократно.
  • «Магнит» – если режим включен, при создании и перемещении элементов на графике узловые точки объектов рисования притягиваются к ценам ближайших свечей:
    • Цена открытия свечи (Open);
    • Максимальная цена свечи (High);
    • Наименьшая цена свечи (Low);
    • Цена закрытия свечи (Close).
    Включить режим можно нажатием на кнопку [image] или при перемещении узловой точки объекта на графике кнопкой мыши, удерживая нажатой клавишу «Ctrl». Для настройки расстояния действия магнита доступны следующие параметры:
    • Расстояние от курсора до ближайшей точки экстремума в пикселях:
      • «5px» (по умолчанию);
      • «10px»;
      • «20px»;
      • «40px».
    • «Сильный магнит» – точки объектов рисования примагничиваются к экстремумам ближайших свечей на графике.
    При использовании режима «Магнит» для горизонтальной линии, на выбранной линии отображается центральная точка, которая притягивается к ценам ближайших свечей.
    Режим «Магнит» недоступен для вертикальных линий.

    Если режим включен, при перемещении в пустой области графика узловая точка фигуры или линии притягивается к пересечениям вертикальных (по времени) и горизонтальных (по шагу цены) разделителей сетки. При этом, по горизонтали точка примагничивается с учетом временных интервалов, а по вертикали притягивается к оси (справа или слева), к которой привязан график инструмента, с учетом шага цены инструмента графика.

  • «Редактировать…» – открыть окно настройки:
    • на странице редактирования настроек области построения – при вызове функции из контекстного меню области построения графика;
    • на странице редактирования общих параметров диаграммы – при вызове функции из пункта меню Действия.
  • «Обновить» (или «F5») – обновление содержимого окна графика. Доступно для графиков, созданных по данным Таблицы текущих торгов.
  • «Интервал» – выбрать величину интервала (тиковый, 1 минута и т.д.).
  • «Увеличить» – увеличить горизонтальный масштаб графика.
  • «Уменьшить» – уменьшить горизонтальный масштаб графика.
  • «Показать весь график» – показать весь график в окне.
  • «Создать копию» (или «Ctrl»+«N») – создать новое окно графика на основе уже существующего.
  • «Показать легенду» ** – включить/отключить отображение легенды в текущей области построения.
  • «Показывать подсказку» ** – включить/отключить отображение всплывающей подсказки на свечке.
  • «Шаблон диаграммы» – настройка используемого шаблона:
    • «Сделать шаблоном…» – сохранить настройки диаграммы в шаблон;
    • <Название шаблона> – применить к диаграмме сохраненные в выбранном шаблоне настройки графика;
    • «Шаблоны…» – открыть окно управления шаблонами графиков.
  • «Сохранить изображение…» – сохранение изображения диаграммы в файл. Возможные форматы: Microsoft Bitmap (BMP), Microsoft Enhanced Metafile (EMF).

Контекстное меню линии (или легенды для линии) на графике:

  • «Новая заявка» – открыть окно ввода новой заявки по инструменту, по которому построен график.
  • «Новая стоп-заявка» – открыть окно ввода новой условной заявки по инструменту, по которому построен график.
  • «Котировки инструмент» – открыть окно котировок по соответствующему инструменту.
  • «Глубина рынка» – добавить на график гистограмму «Глубина рынка».
  • «Редактировать…» – открыть окно настройки на странице редактирования вида данного графика.
  • «Заменить инструмент» – изменить инструмент, по которому построен график. Диалог замены инструмента описан в п. Свойства диаграммы .
  • «Удалить график» – удалить текущую линию графика.
  • «Сохранить данные в файл» – сохранить данные диаграммы в файл в формате *.txt.

См. также:

  • Использование панелей инструментов
  • Редактирование графика при помощи «мыши»


Сохранение изображения графика в файл

Настроенное изображение в окне графика может быть сохранено в файле графического формата Microsoft Bitmap (BMP) и Microsoft Enhanced Metafile (EMF). Действие выполняется из контекстного меню на графике, выбором пункта «Сохранить изображение...».

График сохраняется в том виде, как он виден на экране, с учетом наложенных меток, индикаторов и прочих элементов. При сохранении графика в файл записывается не только видимая часть изображения, а весь график целиком - по всем периодам, которые можно увидеть путем прокрутки изображения в окне. При этом масштаб графика по вертикали подбирается так, чтобы были видны все свечи графика.

Сохранение изображения в файл размером до 1ГБ выполняется без запроса подтверждения пользователя. Если размер изображения от 1ГБ до 4ГБ, то пользователь получает сообщение: «Итоговое изображение имеет слишком большие размеры. Рекомендуем уменьшить масштаб графика, иначе возможны проблемы с просмотром. Продолжить сохранение?».

Сохранение изображения в формат EMF позволяет уменьшить размер файла и упрощает его редактирование в сторонних программах обработки изображений.

См. также: Сохранение данных графика в файл


Сохранение данных графика в файл

Численные значения, по которым построен график, могут быть сохранены в файл. Для сохранения доступны данные по котировкам и по индикаторам. Формат файла для значений цены/объема и индикаторов различается. В файл записывается информация с такой глубиной истории, какая отображена на графике.

Способ выполнения:

  1. Выберите линию графика, данные по которому должны быть сохранены.
  2. Из контекстного меню на линии выберите пункт «Сохранить данные в файл».
  3. В открывшемся окне укажите название сохраняемого файла и выберите папку на диске для записи.

Формат файла значений цены и объема имеет вид, совместимый с форматом Equis Metastock:

<TICKER> | <PER> | <DATE> | <TIME> | <OPEN> | <HIGH> | <LOW> | <CLOSE> | <VOL>
Тикер | Период | Дата | Время | Цена открытия | Максимум цены | Минимум цены | Цена закрытия | Объем

Где:

  • Тикер – «<код инструмента> [<код класса>]»

Пример файла:

<TICKER>,<PER>,<DATE>,,<TIME>,<OPEN>,,<HIGH>,<LOW>,,<CLOSE>,<VOL>
HYDR [TQBR],5,20100921,125500,2.072000,2.073500,.2068700,2.069000,29419.000000
HYDR [TQBR],5,20100921,130000,2.069000,2.071400,2.067000,2.071400,44473.000000

Формат файла для значений индикаторов:

<TICKER> | <PER> | <DATE> | <TIME> | Line 1 | Line 2 | Line 3 | … | Line N
Тикер | Период | Дата | Время | Линия №1 | Линия №2 | Линия №3 | … | Линия №N

Где:

  • Тикер – «<код инструмента> [<код класса>]»

Пример файла для индикатора Alligator:

<TICKER>,<PER>,<DATE>,<TIME>,<LINE_LIPS>,<LINE_JAW>,<LINE_TEETH>
HYDR [TQBR],5,20100921,133500,2.072900,2.072268,2.072268
HYDR [TQBR],5,20100921,134000,2.071000,2.072015,2.072015


Настройка пользовательских меток

  • Вкладка «Вид»
  • Вкладка «Координаты»
  • Вкладка «Интервалы»
  • Шаблон

    • Подробнее об отображении меток на графике см. «Отображение меток на графике».

    Окно «Редактирование метки» открывается одним из следующих способов:

    • Для создания новой метки – выбором типа метки в контекстном меню «Метка…» на нужной области построения графиков и нажатием левой кнопкой мыши на месте привязки метки на графике (опорная точка метки).
    • Для редактирования существующей метки:
      • выбором пункта контекстного меню «Редактировать…» на нужной метке;
      • двойным нажатием левой кнопки мыши на нужной метке.

    Окно «Редактирование метки» содержит следующие параметры:

    По умолчанию используются значения параметров, заданные при создании предыдущей метки.

    Вкладка «Внешний вид»

    • Метка «Текст»:

      • Настройки текста метки: цвет, шрифт, размер, начертание.
      • Поле для ввода текста метки.
      • «Граница» – включение отображения границы метки и настройка цвета и толщины линии границы.
      • «Заливка» – включение использования заливки для фона метки и настройка цвета заливки.
    • Метка «Заметка»:

      • «Текст подсказки» – текст подсказки, отображаемой при наведении курсора мыши на метку.
      • «Цвет 1» – основной цвет метки.
      • «Цвет 2» – цвет внутренней части метки.
    • Метка «Выноска»:

      • Настройки текста метки: цвет, шрифт, размер, начертание.
      • Поле для ввода текста метки.
      • «Граница» – настройка цвета и толщины линии границы.
      • «Заливка» – настройка цвета заливки фона.
    • Метка «Отметка цены»:

      • «Шрифт» – настройки текста метки: цвет, шрифт, размер, начертание.
      • «Граница» – настройка цвета и толщины линии границы.
      • «Заливка» – настройка цвета заливки фона.
    • Метка «Картинка из файла»:

      • «Файл картинки» – выбор файла с изображением. Возможные форматы файла: *.bmp, *.jpeg.
      • «Текст подсказки» – текст подсказки, отображаемой при наведении курсора мыши на метку.
      • «Текст подписи» – текст, который отображается рядом с картинкой.
      • «Положение» – размещение метки на графике относительно опорной точки:
        • «слева от точки»;
        • «справа от точки»;
        • «над точкой»;
        • «под точкой».
      • «Шрифт» – настройки текста метки: цвет, шрифт, размер, начертание.
    • Метка «Значок»:

      • «Текст подсказки» – текст подсказки, отображаемой при наведении курсора мыши на метку.
      • «Цвет» – цвет метки.

    Вкладка «Координаты»

    1. «Привязать к графику» – выбор графика, к которому привязана метка.
    2. «Точка 1» – координаты опорной точки метки:
      • «Цена» – значение по вертикальной оси координат. Доступно для редактирования при включенном признаке «Перемещать со шкалой цены».
      • «№ интервала» – номер интервала, в котором расположена опорная точка.
      • «Дата и Время» – дата и время начала интервала, в котором расположена опорная точка. Если точка попадает на интервал времени в будущем, то в поле отображается количество интервалов сдвига в будущее со знаком «+» (плюс). Недоступно для редактирования.
    3. «Точка 2» – координаты второй опорной точки метки (точка привязки выноски с текстом). Отображается для меток вида «Выноска», «Отметка цены».
      • «Цена» – значение по вертикальной оси координат. Доступно для редактирования при включенном признаке «Перемещать со шкалой цены».
      • «№ интервала» – номер интервала, в котором расположена опорная точка.
      • «Дата и Время» – дата и время начала интервала, в котором расположена опорная точка. Если точка попадает на интервал времени в будущем, то в поле отображается количество интервалов сдвига в будущее со знаком «+» (плюс). Недоступно для редактирования.
    4. «Перемещать со шкалой времени» – привязать метку к шкале времени на графике.
    5. «Перемещать со шкалой цены» – привязать метку к шкале цены на графике.

    Вкладка «Интервалы»

    На вкладке выполняется настройка видимости метки на разных длинах интервалов. Возможные значения:

    • «Тиковый»;
    • «Минуты» (от 1 до 6, 10, 15, 20, 30);
    • «Часы» (1, 2, 4);
    • «Дневной»;
    • «Недельный»;
    • «Месячный».

    Шаблон

    Настройка используемого шаблона метки:

    • «По умолчанию» – применить к метке настройки по умолчанию.
    • «Сохранить как…» – сохранить настройки метки в шаблон. В открывшемся диалоге задаётся наименование шаблона.
    • <Название шаблона> – применить к метке сохраненные в выбранном шаблоне настройки. Для удаления шаблона из списка используйте кнопку «Х» в строке с названием шаблона.

    См. также:

    Отображение меток на графике


 Измерение расстояния

Измерение расстояния

Измерить расстояние между точками на графике можно одним из следующих способов:

  • Выбором функции «Линейка» в панели инструментов «График»:
    • Нажать в панели инструментов на кнопку «Линейка» [image] ;
    • В окне графика указать первую точку нажав левой кнопкой мыши, не отпуская кнопки мыши тянуть в требуемом направлении до второй точки, отпустить кнопку мыши.

    Чтобы переместить линейку, нажмите левую кнопку мыши на линейке и потяните в нужную сторону.

  • С помощью колёсика мыши:
    • В окне графика указать первую точку нажав колёсико мыши, не отпуская колёсика мыши тянуть в требуемом направлении до второй точки, отпустить колёсико мыши.

При измерении расстояния на графике отображаются следующие элементы:

  • Область между точками отображается в виде прямоугольника. Цвет заливки области соответствует выбранному цвету сетки графика с прозрачностью 50%, без границ;
  • От начальной точки до конечной рисуется пунктирная линия;
  • Подпись с результатом измерения:
    • Первая строка (измерение по вертикали) – разница значения параметра в конечной точке относительно начальной точки. Отображается с учетом знака (для значений цены - с точностью инструмента). В скобках показывается изменение в % (с точностью до двух знаков после запятой);
    • Вторая строка (измерение по горизонтали) – количество интервалов, разница во времени. Разница во времени отображается в днях, часах и минутах. Если единица измерения содержит нулевое значение, то она не показывается (например, вместо «1ч 00 м» отобразится «1 ч»).

    Если на графике существует объект, привязанный к другой шкале, то подпись содержит три строки. В первой строке отображаются значения левой шкалы, во второй – значения правой шкалы, а в третьей значения шкалы времени.

Для сброса измерений необходимо нажать левой кнопкой мыши в любой точке области построения графика.

См. также:

Использование панелей инструментов


Гистограмма «Глубина рынка»

  • Настройка гистограммы
  • Вкладка «Свойства»
  • Вкладка «Внешний вид»
  • Вкладка «Интервалы»
  • Шаблон
  • Функции, доступные из контекстного меню

    • Для добавления гистограммы выполните следующие действия:

    1. В панели инструментов «График» в пункте меню «Нарисовать» или из контекстного меню линии на графике выберите пункт «Глубина рынка».
    2. Нажмите левой кнопкой мыши в нужном месте диаграммы.

    Элементы гистограммы:

    1. Область гистограммы.Область внутри области построения графика, в которой отображаются объём заявок, максимальный объём и собственные заявки.
    2. Объём заявок.
    3. Суммарный объём.
    4. Максимальный объём.
    5. Собственные заявки.

    При наведении курсора на бары под заголовком гистограммы отображается всплывающая подсказка с указанием направления, цены и объёма заявки.

    Чтобы переместить гистограмму, наведите курсор на ее заголовок, нажмите левую кнопку мыши и потяните в нужном направлении. Чтобы изменить область гистограммы, наведите курсор на левую/правую границу гистограммы, нажмите левую кнопку мыши и потяните в нужном направлении.

    Настройка гистограммы

    Окно «Свойства диаграммы “Глубина рынка”» вызывается одним из следующих способов:

    • Нажатие правой кнопкой мыши на заголовке или границе гистограммы и выбор пункта меню «Редактировать…».
    • Двойное нажатие левой кнопки мыши на заголовке или границе гистограммы.

    Вкладка «Свойства»

    Доступные параметры:

    1. «Привязать к графику» – выбор графика, к которому привязана гистограмма.
    2. «Направление гистограммы»:
      • «Слева направо»;
      • «Справа налево».
    3. «Масштаб по горизонтали: <значение в процентах от области построения графика».
    4. «Масштабировать по максимальному значению суммарного объёма» – если флажок включен и на вкладке «Внешний вид» флажок «Суммарный объём» включен, то объём текущих активных заявок отображается в масштабе с учетом значения максимального объёма. Если флажок выключен, а на вкладке «Внешний вид» флажок «Суммарный объём» включен, то объём текущих активных заявок отображается в масштабе с учетом значения максимального объёма, а суммарный объём отображается на всей доступной области графика.
    5. «Масштабирование длин баров»:
      • «Линейное»;
      • «Нелинейное» – рекомендуется использовать, если для инструмента на рынке присутствуют заявки с объёмом, значительно превышающим объёмы остальных заявок.

    Вкладка «Внешний вид»

    Настройки позволяют задать цвета и шрифты для индикаторов фигуры. Правила настройки цвета описаны в Настройка цвета в таблицах и графиках.

    Доступные параметры:

    1. «Индикаторы» – значения индикаторов для покупки и продажи:
      • «Объём» – цвет для объёмов заявок;
      • «Подписывать значения» – цвет и шрифт текста подписи;
      • «Суммарный объём» – цвет для суммарного объёма заявок;
      • «Максимальный объём» – цвет для максимального объёма заявок;
      • «Подписывать значения» – цвет и шрифт текста подписи.

    Вкладка «Интервалы»

    На вкладке выполняется настройка видимости гистограммы на разных длинах интервалов. Возможные значения:

    • «Тиковый»;
    • «Минуты» (от 1 до 6, 10, 15, 20, 30);
    • «Часы» (1, 2, 4);
    • «Дневной»;
    • «Недельный»;
    • «Месячный».

    Шаблон

    Настройка используемого шаблона гистограммы:

    • «По умолчанию» – применить к гистограмме настройки по умолчанию.
    • «Сохранить как…» – сохранить настройки гистограммы в шаблон. В открывшемся диалоге задаётся наименование шаблона.
    • <Название шаблона> – применить к гистограмме сохраненные в выбранном шаблоне настройки. Для удаления шаблона из списка используйте кнопку «Х» в строке с названием шаблона.

    Кнопка «ОК» закрывает окно редактирования с сохранением изменений, кнопка «Отмена» – без сохранения изменений.

    Функции, доступные из контекстного меню

    • «Редактировать…» – открытие окна «Свойства диаграммы “Глубина рынка”» для настройки параметров гистограммы.
    • «Копировать» (или «Ctrl»+«C») – копировать выбранную гистограмму в буфер обмена.
    • «Удалить фигуру» (или «Del») – удалить с графика выбранную гистограмму.


Инструменты технического анализа

Для исследования поведения цен сделок при помощи графиков, в системе QUIK может применяться рисование линий и наложение индикаторов технического анализа.

  • Рисование линий
  • Рисование фигур
  • Линейные инструменты
  • Функции по работе с линиями трендов и фигурами
  • Настройка фигур и линий трендов
  • Скользящие средние

    • Руководство пользователя QUIK © ARQA Technologies / www.arqatech.com/ru/products/quik/


Рисование линий

  1. Рисование горизонтальной линии:
    • Нажать кнопку [image] на панели инструментов или выбрать пункт «Нарисовать/Горизонтальная линия» в контекстном меню области построения графика;
    • В окне графика нажать левую кнопку мыши, подвести появившуюся линию к требуемому уровню, затем отпустить левую кнопку мыши.
  2. Рисование вертикальной линии:
    • Нажать кнопку [image] на панели инструментов или выбрать пункт «Нарисовать/Вертикальная линия» в контекстном меню области построения графика;
    • В окне графика нажать левую кнопку мыши, подвести появившуюся линию к требуемому значению, затем отпустить левую кнопку мыши.
  3. Рисование линий трендов:
    • Первый способ: удерживая нажатой клавишу «Shift», нажать левую кнопку мыши в точке начала линии и тянуть в требуемом направлении для рисования линии.
    • Второй способ:
      • нажать кнопку [image] на панели инструментов или выбрать пункт «Нарисовать/Линия тренда» в контекстном меню области построения графика;
      • нажать левую кнопку мыши в точке начала линии и тянуть в требуемом направлении для рисования линии.
  4. Рисование каналов:
    • Нажать кнопку [image] на панели инструментов или выбрать пункт «Нарисовать/Канал» в контекстном меню области построения графика;
    • В окне графика нажать левую кнопку мыши в точке начала линии и тянуть в требуемом направлении для рисования линии. После отпускания левой кнопки мыши первая линия канала зафиксируется;
    • Перемещая курсор вверх-вниз, сформируйте ширину канала и нажмите левую кнопку мыши. Вторая линия канала зафиксируется.
  5. Рисование горизонтального луча:
    • Нажать кнопку [image] на панели инструментов или выбрать пункт «Нарисовать/Горизонтальный луч» в контекстном меню области построения графика;
    • В окне графика нажать левую кнопку мыши в точке начала луча, после чего построится горизонтальный луч вправо. Направление луча (вправо, влево или оба направления) задается в настройках линий трендов на вкладке «Координаты».

См. также:

  • Использование панелей инструментов
  • Линейные инструменты


Рисование фигур

  1. Рисование прямоугольника:
    • Нажать кнопку [image] на панели инструментов или выбрать пункт «Нарисовать/Прямоугольник» в контекстном меню области построения графика;
    • В окне графика нажать левую кнопку мыши в начальной точке прямоугольника (например, верхний левый угол) и тянуть в требуемом направлении для рисования прямоугольника. После отпускания левой кнопки мыши конечная точка прямоугольника (например, нижний правый угол) зафиксируется.

      При рисовании на осях отображаются метки цены и времени, соответствующие четырём узловым точкам прямоугольника.

  2. Рисование треугольника:
    • Нажать кнопку [image] на панели инструментов или выбрать пункт «Нарисовать/Треугольник» в контекстном меню области построения графика;
    • В окне графика нажать левую кнопку мыши в начальной точке треугольника, не отпуская кнопки мыши тянуть в требуемом направлении до второй точки треугольника, и, отпустив левую кнопку мыши, зафиксировать вторую точку треугольника. Протянуть мышь по направлению к третьей точке и нажать левой кнопкой мыши для закрепления третьей точки.

      При рисовании на осях отображаются метки цены и времени, соответствующие трём узловым точкам треугольника.

  3. Рисование эллипса:
    • Нажать кнопку [image] на панели инструментов или выбрать пункт «Нарисовать/Эллипс» в контекстном меню области построения графика;
    • В окне графика нажать левую кнопку мыши в начальной точке эллипса, не отпуская кнопки мыши задать продольный диаметр эллипса растягивая в требуемом направлении до второй точки, и, отпустив левую кнопку мыши, зафиксировать вторую точку эллипса. Двигая мышью задать поперечный диаметр эллипса и нажать левой кнопкой мыши для закрепления поперечного диаметра.

      При рисовании на осях отображаются метки цены и времени, соответствующие двум узловым точкам эллипса.

См. также:

  • Использование панелей инструментов


Линейные инструменты

Линейными инструментами называются геометрические фигуры, наносящиеся на графики цен или индикаторов, например, «линии Фибоначчи».

Числа Фибоначчи представляют собой последовательность, в которой каждое последующее число является суммой двух предыдущих: 1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89, 144 и т.д. Эта последовательность обладает рядом внутренних взаимозависимостей. Например, всякое число данного ряда, кроме первых трех, приблизительно в 1.618 раз больше предыдущего и примерно в 0.618 раз меньше следующего числа. Применение линий Фибоначчи основывается на предположении, что узловые моменты поведения цен располагаются рядом с линиями Фибоначчи.

Доступные виды линий:

  1. - «Дуги Фибоначчи» (Fibonacci Arcs) представляет собой три дуги с радиусами в 38.2%, 50.0% и 61.8% от разницы значений цены в начале и конце линии.
  2. - «Веер Фибоначчи» (Fibonacci Fan) представляет собой три наклонных линии пересекающие вертикаль, отложенную от более поздней точки, на уровнях в 38.2%, 50.0% и 61.8% от разницы значений цены в начале и конце линии.
  3. - «Уровни Фибоначчи» (Fibonacci Retracement) это девять горизонтальных линий, проходящих на уровнях, заданных числами Фибоначчи: 0.0, 23.6, 38.2, 50.0, 61.8, 100, 161.8, 261.8 и 423.6%.
  4. - «Временные зоны Фибоначчи» (Fibonacci Time Zones) представляют из себя серию вертикальных линий, проходящих через интервалы, соответствующие числам 1,2,3,5,8,13,21,34 и т.д.
  5. - «Скоростные линии» (Speed Resistance Lines) представляет собой три наклонных линии, пересекающие вертикаль, отложенную от более поздней точки, на уровнях 1/3, 2/3 и 1 от разницы значений цены в начале и конце линии.

Использование линейных инструментов аналогично рисованию линий:

  • Выберите тип линии нажатием кнопок на панели инструментов или выбором соответствующего пункта меню «Нарисовать» в контекстном меню области построения графика.
  • Проведите на графике линию, соединяющую экстремумы цен (минимум и максимум).

См. также:

  • Рисование линий
  • Использование панелей инструментов


Функции по работе с линиями трендов и фигурами

  • Функции, доступные из контекстного меню
  • Дополнительные функции
  • Свойства линий трендов

    • Функции, доступные из контекстного меню

    • «Редактировать…» – открытие окна «Свойства тип линии (фигуры)» для настройки параметров линии тренда или фигуры.
    • «Копировать» (или «Ctrl»+«C») – копировать выбранную линию тренда или фигуру в буфер обмена.

      Для вставки скопированного элемента на график выберите в контекстном меню области построения пункт «Вставить» или примените комбинацию клавиш «Ctrl»+«С».

    • «Удалить тренд» / «Удалить горизонтальный луч» / «Удалить фигуру» (или «Del») – удалить с графика выбранную линию тренда или фигуру.

    Дополнительные функции

    1. Выделить линию тренда или фигуру – визуально выделить узловые точки, подведя курсор к линии или к границе фигуры и нажав левую кнопку мыши:

      Выделение можно осуществить одним из следующих способов:

      • Навести курсор на линию тренда (границу фигуры). Для снятия выделения уберите курсор с линии тренда (границы фигуры);
      • Навести курсор на линию тренда (границу фигуры), нажать левую кнопку мыши. Выделение снимается после щелчка левой или правой кнопкой мыши на области графика за пределами линии тренда (границы фигуры).
    2. Изменить линию тренда или фигуру – подвести курсор к изменяемой узловой точке (рядом с курсором появится значок в виде руки), нажать левую кнопку мыши и тянуть в нужную сторону для изменения фигуры. Удерживая нажатой клавишу «Shift», можно перемещать линию тренда и фигуры вдоль оси времени без изменения уровня цены. Прямоугольник рисуется параллельно линиям сетки, наклон фигуры не предусмотрен.

      При редактировании фигуры на осях отображаются метки цены и времени, соответствующие узловым точкам фигуры.

    3. Изменить наклон и/или ширину канала – выделить канал, затем:
      • для изменения наклона линий канала – нажать левую кнопку мыши в узловой точке линии, имеющей две узловые точки (рядом с курсором появится значок в виде руки), и тянуть в требуемом направлении;
      • для изменения расстояния между линиями канала – нажать левую кнопку мыши в узловой точке линии, имеющей одну узловую точку (рядом с курсором появится значок в виде руки), и перемещать курсор вверх-вниз, формируя ширину канала.
    4. Переместить линию тренда или фигуру – нажать левую кнопку мыши на середине линии тренда или на границе фигуры (рядом с курсором появится значок в виде перекрестия), тянуть в нужную сторону для перетаскивания.
    5. Копировать линию тренда или фигуру – удерживать нажатой клавишу «Ctrl» и нажать левую кнопку мыши:
      • на линии тренда или на границе фигуры – для параллельного переноса;
      • на узловой точке – для создания новой линии или фигуры, имеющей общую вершину с предыдущей.
    6. Удалить линию тренда или фигуру – удаление элемента можно осуществить одним из следующих способов:
      • Выбрать пункт контекстного меню для элемента «Удалить тренд» / «Удалить горизонтальный луч» / «Удалить фигуру»;
      • Выделить элемент и нажать клавишу «Delete». Линия / фигура удаляется с предварительным подтверждением.

    Свойства линий трендов

    1. При перемасштабировании диаграммы тренды изменяют вид вместе с графиками, к которым они относятся.
    2. Если на диаграмме отображены два графика в одной области построения, то для правильного масштабирования линии тренда необходимо указать, к какому из графиков она относится. Настройка выполняется в окне «Свойства тип линии (фигуры)», поле «Привязать к …».
    3. При удалении графика, к которому привязан тренд, линии тренда тоже удаляются.
    4. При отсутствии графиков в области построения нарисовать линию тренда невозможно.
    5. При закрытии программы линии тренда не сохраняются.
    6. Задать цвет и толщину линий тренда по умолчанию можно на странице «Свойства диаграммы» окна редактирования настроек графика, вкладка «Внешний вид».
    7. Копирование настроек текущего тренда. Заданные настройки текущего тренда (через диалог «Свойства <тип линии (фигуры)») автоматически устанавливаются для следующих созданных трендов того же типа. В противном случае используются настройки по умолчанию.

    См. также:

    • Рисование линий
    • Использование панелей инструментов


Настройка фигур и линий трендов

  • Вкладка «Внешний вид»
  • Вкладка «Координаты»
  • Вкладка «Уровни Фибоначчи»
  • Вкладка «Уровни коррекции»
  • Вкладка «Интервалы»
  • «Шаблон»
  • «Текст»

    • Окно «Свойства <тип линии (фигуры)>» вызывается одним из следующих способов:

    • Нажатие правой кнопкой мыши на выделенной линии тренда или на границе фигуры и выбор пункта меню «Редактировать…».
    • Двойное нажатие левой кнопки мыши на выделенной линии тренда или на границе фигуры.
    Набор отображаемых параметров на вкладках зависит от вида настраиваемых линий трендов или фигур.

    Вкладка «Внешний вид»

    На вкладке «Внешний вид» настраивается внешний вид линий и фигур:

    1. «Стиль» – выбор цвета, стиля и толщины основной линии. Настраивается для линий типа «Линия тренда», «Горизонтальная линия», «Горизонтальный луч», «Вертикальная линия», «Временные зоны Фибоначчи».
    2. «Продлевать влево» – продление линии влево, превращая линию тренда в луч. Настраивается для линий типа «Линия тренда».
    3. «Продлевать вправо» – продление линии вправо, превращая линию тренда в луч. Настраивается для линий типа «Линия тренда».
    4. «Всегда показывать значение на оси цены» – отображение значения для тренда по вертикальной оси координат. Если флажок отключен, то значение на вертикальной оси отображается только при выделении тренда. Настраивается для линий типа «Горизонтальная линия», «Горизонтальный луч».
    5. «Основная линия» – выбор цвета, стиля и толщины основной линии. Настраивается для линий типа «Дуги Фибоначчи», «Веер Фибоначчи», «Уровни Фибоначчи», «Скоростные линии».
    6. «Линия сопротивления» – выбор цвета, стиля и толщины линии сопротивления. Настраивается для линий типа «Дуги Фибоначчи», «Веер Фибоначчи», «Уровни Фибоначчи», «Скоростные линии», «Канал».
    7. «Линия поддержки» – выбор цвета, стиля и толщины линии поддержки. Настраивается для линий типа «Канал», «Дуги Фибоначчи», «Веер Фибоначчи», «Уровни Фибоначчи», «Скоростные линии».
    8. «Заливка» – выбор цвета и уровня прозрачности для фона. Настраивается для фигур «Прямоугольник», «Треугольник», «Эллипс».
    9. «Граница» – выбор цвета, стиля и толщины границы фигуры. Настраивается для фигур «Прямоугольник», «Треугольник», «Эллипс».
    10. «Строить по контртренду» – построение по противоположно направленному тренду. Настраивается для линий типа «Веер Фибоначчи».
    11. «Подписи к уровням» – отображение подписей к линиям на графике:
      • «слева»;
      • «справа».

      Настраивается для линий типа «Уровни Фибоначчи».

    Правила настройки цвета описаны в п. Настройка цвета в таблицах и графиках.

    Вкладка «Координаты»

    1. «Привязать к графику» – выбор графика, к которому привязана линия тренда или фигура.
    2. Координаты узловых точек линии тренда или фигуры:
      • «Цена» – значение по вертикальной оси координат. Для прямоугольника отображается по нижней и верхней границам;
      • «№ интервала» – номер интервала, в котором расположена узловая точка;
      • «Дата и Время» – дата и время начала интервала, в котором расположена узловая точка. Если точка попадает на интервал времени в будущем, то в поле отображается количество интервалов сдвига в будущее со знаком «+» (плюс), например «+2». Для прямоугольника отображается по левой и правой границам. Недоступно для редактирования.

      Количество узловых точек зависит от вида графика:

      • «Горизонтальная линия», «Горизонтальный луч», «Вертикальная линия» – одна узловая точка;
      • «Линия тренда», «Прямоугольник», «Дуги Фибоначчи», «Скоростные линии», «Веер Фибоначчи», «Уровни Фибоначчи», «Временные зоны Фибоначчи» – две узловые точки;
      • «Эллипс», «Треугольник», «Канал» – три узловые точки.
    3. Направление горизонтального луча:
      • «Луч вправо» – луч направлен вправо. Настраивается для линий типа «Горизонтальный луч»;
      • «Луч влево» – луч направлен влево. Настраивается для линий типа «Горизонтальный луч».

      Допустимо использовать оба направления.

    Вкладка «Уровни Фибоначчи»

    На вкладке выполняется настройка каждого уровня Фибоначчи. Вкладка отображается для линий типа «Дуги Фибоначчи», «Веер Фибоначчи», «Уровни Фибоначчи».

    1. «Значение (%)» – значение уровня.
    2. «Рисовать» – выбор линии:
      • «отключить» – отключение отображения уровня;
      • «основная линия»;
      • «линия сопротивления»;
      • «линия поддержки».

    Минимальное количество уровней: 1.

    Для добавления нового уровня измените параметры уровня в нижней части окна и нажмите кнопку «Добавить».

    Для удаления уровня нажмите на «Х» справа либо отключите его отображение и установите значение в «0» – уровни с такими параметрами удаляются из списка автоматически.

    Вкладка «Уровни коррекции»

    На вкладке выполняется настройка уровней коррекции. Вкладка отображается для линий типа «Скоростные линии».

    1. «Значение (%)» – значение уровня.
    2. «Рисовать» – выбор линии:
      • «отключить» – отключение отображения уровня;
      • «основная линия»;
      • «линия сопротивления»;
      • «линия поддержки».

    Минимальное количество уровней: 3.

    Для добавления нового уровня измените параметры уровня в нижней части окна и нажмите кнопку «Добавить».

    Для удаления уровня нажмите на «Х» справа либо отключите его отображение и установите значение в «0» – уровни с такими параметрами удаляются из списка автоматически.

    Вкладка «Интервалы»

    На вкладке выполняется настройка видимости линии тренда или фигуры на разных длинах интервалов. Возможные значения:

    • «Тиковый»;
    • «Минуты» (от 1 до 6, 10, 15, 20, 30);
    • «Часы» (1, 2, 4);
    • «Дневной»;
    • «Недельный»;
    • «Месячный».

    «Вкладка Текст»

    На вкладке задаются настройки текстовой надписи для линий типа «Горизонтальный луч».

    1. «Показывать текст» – признак отображения надписи для горизонтального луча. При установленном признаке доступны остальные параметры настройки отображения текста.
    2. «Шрифт» – настройка цвета, шрифта, размера и начертания надписи. Правила настройки цвета описаны в п. Настройка цвета в таблицах и графиках.
    3. Поле для ввода текста надписи.
    4. «Выравнивание» – выравнивание надписи относительно горизонтального луча:
      • «Сверху» / «Снизу»;
      • «Слева» / «Справа».

    «Шаблон»

    Настройка используемого шаблона линии тренда или фигуры:

    • «По умолчанию» – применить к линии тренда или к фигуре настройки по умолчанию.
    • «Сохранить как…» – сохранить настройки линии тренда или фигуры в шаблон. В открывшемся диалоге задаётся наименование шаблона.
    • <Название шаблона> – применить к линии тренда или к фигуре сохраненные в выбранном шаблоне настройки. Для удаления шаблона из списка используйте кнопку «Х» в строке с названием шаблона.

      См. также:

      • Рисование линий
      • Рисование фигур
      • Использование панелей инструментов


Скользящие средние

Линии, построенные методом скользящих средних значений, показывают среднюю величину цены за несколько предыдущих периодов.

Добавление в график индикатора технического анализа осуществляется выбором пункта контекстного меню Добавить график (индикатор)... и выбором в списке доступных параметров значения «Moving Average».

Параметры настройки индикаторов расположены на закладке «Параметры» следующего шага настройки графика.

В QUIK доступны следующие типы скользящих средних:

Название индикатора Вычисление Параметры настройки
Простая скользящая средняя
Simple Moving Average (SMA) 		SMA = sum(Pi) / n,
где Pi - значение цены в i-том периоде
  • «Количество периодов»: целое положительное число n.
  • «Метод»: выбор способа расчета скользящей средней (Simple, Exponential, Vol. Adjusted, Smoothed).
  • «Поле цены»: выбор значения цены, применяемого в формуле.
    • «Open» – цена открытия (первой сделки) в периоде,
    • «High» - максимальная цена,
    • «Low» – минимальная цена,
    • «Close» – цена закрытия (последней сделки),
    • «Median» = (High+Low)/2,
    • «Typical» = (High+Low+Close)/3.
Экспоненциальная скользящая средняя
Exponential Moving Average (EMA) 		EMAi = (EMAi-1*(n-1)+2*Pi) / (n+1),
где Pi - значение цены в текущем периоде,
EMAi - значение EMA текущего периода,
EMAi-1 - значение EMA предыдущего периода

Начальное значение равно параметру, по которому рассчитывается индикатор:
EMA0=P0 – при расчете по цене

Объемо-зависимая скользящая средняя
Volume Adjusted Moving Average (VMA) 		VMA = sum(Pi*Vi) / sum(Vi),
где Pi - значение цены в i-ом периоде,
Vi - значение объема в i-ом периоде.
Сглаженная скользящая средняя
Smoothed Moving Average (SMMA) 		SMMAi = (sum(Pi) - SMMAi-1 + Pi) / n,
где Pi - значение цены в i-ом периоде.

Начальное значение равно параметру, по которому рассчитывается индикатор:
SMMA0=sum(Pi) / n – при расчете по цене


Методы технического анализа

  • AC («Ускорение/Замедление»)
  • ADX («Индекс направления движения усредненной цены»)
  • A/D («Накопление/распределение»)
  • Alligator («Аллигатор»)
  • AMA (Adaptive Moving Average)
  • AO («Чудесный осциллятор»)
  • ATR (Average True Range)
  • Bears Power («Сила медведей»)
  • Bollinger Bands («Полосы Боллинджера»)
  • Bulls Power («Сила быков»)
  • CCI («Индекс товарного канала»)
  • Chaikin Oscillator («Осциллятор Чайкина»)
  • Chaikin’s Volatility («Волатильность Чайкина»)
  • CMO («Осциллятор ценовых моментов Чанде»)
  • Elder's Force Index («Индекс силы Элдера»)
  • Envelopes («Конверты»)
  • Fractals («Фракталы»)
  • Ichimoku («Ишимоку»)
  • MACD («Схождение-расхождение скользящих средних»)
  • MACD-Histogram
  • BW MFI («Bill Williams Market Facilitation Index»)
  • Momentum («Темп движения»)
  • Money Flow Index («Индекс денежных потоков»)
  • On Balance Volume («Балансовый объем»)
  • Parabolic SAR («Параболическая система»)
  • Price Channel («Ценовой канал»)
  • Price Oscillator («Ценовой осциллятор»)
  • Rate Of Change («Скорость изменения»)
  • Relative Strength Index («Индекс относительной силы»)
  • Relative Vigor Index («Индекс относительной бодрости»)
  • Smoothed Rate Of Change («Сглаженная скорость изменения»)
  • Standard Deviation («Стандартное отклонение»)
  • Stochastic Oscillator («Стохастический осциллятор»)
  • TRIX («Triple Exponential Moving Average»)
  • Vertical Horizontal Filter («Вертикально-горизонтальный фильтр»)
  • Volume Oscillator («Осциллятор объема»)
  • Williams’ % Range («Процентный диапазон Уильямса»)
  • Williams’ A/D («Кумулятивное накопление/распределение Уильямса»)


AC («Ускорение/Замедление»)

Индикатор AC (Accelerator/Decelerator Oscillator) измеряет текущее ускорение/замедление движущей силы рынка. Изменение движущей силы рынка предшествует изменению цены. Перед тем, как движущая сила изменит свое направление, ее ускорение должно замедлиться и дойти до нуля. Затем она начинает ускоряться в противоположном направлении до тех пор, пока цена не начнет изменять свое направление.

Индикатор АС меняет свое направление перед изменением движущей силы, а она в свою очередь меняет свое направление перед изменением цены. Использование АС в качестве раннего предупреждающего сигнала может дать определенные преимущества.

Вычисление:

AC = AO — SMA (AO, S)

где:

  • AO = SMA (MEDIAN PRICE, S) — SMA (MEDIAN PRICE, L);
  • S – длительность короткого периода. Значение по умолчанию: «5»;
  • L – длительность длинного периода. Значение по умолчанию: «34»;
  • MEDIAN PRICE — медианная цена, MEDIAN PRICE = (HIGH + LOW) / 2;
  • HIGH — максимальная цена бара;
  • LOW — минимальная цена бара;
  • SMA — скользящее среднее;
  • AO — индикатор Awesome Oscillator.

В значениях по умолчанию, гистограмма АС представляет собой разность между значением 5/34 гистограммы движущей силы и 5-периодным экспоненциальным скользящим средним, взятым от этой гистограммы.

Параметры настройки:

  1. «Короткий период» - длительность короткого периода S для расчета MA.
  2. «Длинный период» - длительность длинного периода L для расчета MA.
  3. «Метод» - метод расчета МА (Simple, Exponential, Vol.Adjusted, Smoothed), по умолчанию используется метод «Exponential».

См. также Настройка вида графика.


ADX («Индекс направления движения усредненной цены»)

Индикатор ADX (Average Directional Movement Index) предназначен для определения направления движения среднего значения цены на основе сравнения двух индикаторов направленности – +DI (положительного изменения цены) и -DI (отрицательного изменения цены), построенных по 14 периодам. По рекомендации автора индикатора Уэллса Уайлдера преобладание линии +DI над -DI является сигналом «покупать», и «продавать» если значение -DI поднимается выше значения +DI.

Вычисление:

ADXj = EMA (DXj , N) ,

Где DXj вычисляется следующим образом:

DXj = |(+DIj - -DIj)| / (+DIj + -DIj) * 100

+DIj = EMA ( +SDIj , N)

-DIj = EMA (-SDIj , N)

+SDIj = +DMj / TRj *100 если TRj<> 0, иначе +SDIj = 0

-SDIj = -DMj/ TRj *100 если TRj <> 0, иначе -SDIj = 0

TRj = max(|HIGHj - LOWj|, |HIGHj - CLOSEj-1|, |LOWj - CLOSE j-1|)

+DMj = |HIGHj - HIGHj-1| если HIGHj > HIGHj-1, иначе +DMj = 0

-DMj = |LOWj-1 - LOWj| если LOWj < LOWj-1, иначе -DMj = 0

если +DMj > -DMj, то -DMj = 0

если -DMj > +DMj, то +DMj =0

если +DMj = -DMj, то +DMj =0, -DMj =0

где:

  • CLOSE — цена закрытия;
  • LOW — минимальная цена интервала;
  • HIGH — максимальная цена интервала.
Значения индикаторов +DI и –DI учитываются с двумя знаками после запятой.

Параметры настройки:

  1. «Кол-во периодов» - количество периодов N для расчета MA.
  2. «Метод» - метод расчета МА (Simple, Exponential, Vol.Adjusted, Smoothed), по умолчанию используется метод «Exponential».
  3. «Цвет +DI» - выбор цвета линии +DI.
  4. «Цвет -DI» - выбор цвета линии -DI.

См. также Настройка вида графика.


A/D («Накопление/распределение»)

Индикатор «Accumulation/Distribution» определяется изменением цены и объема. Объем выступает в роли весового коэффициента при изменении цены - чем больше коэффициент (объем), тем значительнее вклад изменения цены (за данный промежуток времени) в значение индикатора.

Рост индикатора означает накопление (покупку) инструмента, поскольку подавляющая доля объема торгов связана с восходящим движением цен. Когда индикатор падает, это означает распределение (продажу) инструмента, поскольку подавляющая доля объема торгов связана с нисходящим движением цен.

Вычисление:

CumAD = ADn + CumADn-1,

где:

  • ADn = (2*CLOSEn – LOWn – HIGHn) * VOLUMEn / (HIGHn – LOWn),

    причем CumAD0 = AD1;

  • CLOSE — цена закрытия;
  • LOW — минимальная цена интервала;
  • HIGH — максимальная цена интервала;
  • VOLUME – объем.

Параметров настройки нет.

Если значение HIGHn – LOWn в знаменателе оказалось равно нулю, то вычисляется значение индикатора для предыдущей свечи. Если предыдущая свеча отсутствует, то значение индикатора равно нулю.

См. также Настройка вида графика.


Alligator («Аллигатор»)

Индикатор Alligator представляет собой комбинацию линий баланса (Скользящих средних, Moving Averages) , использующих фрактальную геометрию и нелинейную динамику.

  • Синяя линия (Челюсть Аллигатора) — линия баланса для временного периода, использованного для построения графика, 13-периодное сглаженное скользящее среднее, смещенное в будущее на 8 интервалов;
  • Красная линия (Зубы Аллигатора) — линия баланса для временного периода на порядок ниже, 8-периодное сглаженное скользящее среднее, смещенное в будущее на 5 интервалов;
  • Зеленая линия (Губы Аллигатора) — линия баланса для временного периода на порядок ниже предыдущей, 5-периодное сглаженное скользящее среднее, смещенное в будущее на 3 интервала.

Вычисление:

ALLIGATORS JAW = SMMA (MEDIAN PRICE, 13, 8)

ALLIGATORS TEETH = SMMA (MEDIAN PRICE, 8, 5)

ALLIGATORS LIPS = SMMA (MEDIAN PRICE, 5, 3)

где:

  • MEDIAN PRICE — медианная цена, MEDIAN PRICE = (HIGH + LOW) / 2;
  • HIGH — максимальная цена периода;
  • LOW — минимальная цена периода;
  • SMMA (A, B, C) — сглаженное скользящее среднее, где: A — сглаживаемое значение, B — количество периодов сглаживания, C — сдвиг в будущее;
  • ALLIGATORS JAW — Челюсти Аллигатора;
  • ALLIGATORS TEETH — Зубы Аллигатора;
  • ALLIGATORS LIPS — Губы Аллигатора.

Параметры настройки:

  1. «Челюсть» - параметры для ALLIGATORS JAW:
    • «Кол-во периодов» - количество периодов сглаживания B;
    • «Сдвиг» - количество периодов сдвига C;
    • «Цвет линии» - выбор цвета Синей линии.
  2. «Зубы» - параметры для ALLIGATORS TEETH:
    • «Кол-во периодов» - количество периодов сглаживания B;
    • «Сдвиг» - количество периодов сдвига C;
    • «Цвет линии» - выбор цвета Красной линии;
    • «Метод» - метод расчета МА (Simple, Exponential, Vol.Adjusted, Smoothed), по умолчанию используется метод «Smoothed».
  3. «Губы» - параметры для ALLIGATORS LIPS:
    • «Кол-во периодов» - количество периодов сглаживания B;
    • «Сдвиг» - количество периодов сдвига C;
    • «Цвет линии» - выбор цвета Зеленой линии.

См. также Настройка вида графика.


AMA (Adaptive Moving Average)

Индикатор AMA («Адаптивное скользящее среднее») используется для построения скользящей средней с малой чувствительностью к шумам в ценовых сериях и характеризуется минимальным запаздыванием для определения тренда. Один из недостатков различных алгоритмов сглаживания ценовых рядов заключается в том, что случайные всплески цены могут приводить к появлению ложных сигналов о появлении тренда. С другой стороны, сглаживание приводит к неизбежному запаздыванию сигнала об остановке или развороте тренда. Данный индикатор был разработан Перри Кауфманом, чтобы обойти два этих недостатка.

Вычисление:

AMAi = AMAi-1 + SSCi2 * (Pi - AMAi-1),i>n – текущее значение AMA

AMAi=Pi, i=n

SSCi = ERi * (fSC – sSC) + sSC – изменяющаяся сглаживающая константа

ERi = Signali / Noisei– коэффициент эффективности

fSC = 2 / (fn + 1)

sSC = 2/ (sn + 1)

Signali = abs(Pi – Pi-n) – текущее значение сигнала

Noisei = [image] – текущее значение шума

где:

  • sn – Slow EMA period;
  • fn – Fast EMA period.

Параметры настройки:

  1. «AMA периодов» – количество периодов n для расчета AMA.
  2. «Fast EMA периодов» – количество периодов для расчета Fast EMA.
  3. «Slow EMA периодов» – количество периодов для расчета Slow EMA.
  4. «Поле цены» – используемое для P значение цены интервала (Open, High, Low, Close, Median, Typical), по умолчанию принимается «Close».

См. также Настройка вида графика


AO («Чудесный осциллятор»)

«Чудесный осциллятор» (Awesome Oscillator), разработанный Биллом Уильямсом, помогает определить текущее поведение движущей силы рынка.

Вычисление:

AO = SMA (MEDIAN PRICE, S) — SMA (MEDIAN PRICE, L)

где:

  • S – длительность короткого периода, по умолчанию равна 5;
  • L – длительность длинного периода, по умолчанию равна 34;
  • MEDIAN PRICE — медианная цена, MEDIAN PRICE = (HIGH + LOW) / 2;
  • HIGH — максимальная цена бара;
  • LOW — минимальная цена бара;
  • SMA — скользящая средняя.

Параметры настройки:

  1. «Короткий период» - длительность короткого периода S для расчета MA.
  2. «Длинный период» - длительность длинного периода L для расчета MA.
  3. «Метод» - метод расчета МА (Simple, Exponential, Vol.Adjusted, Smoothed), по умолчанию используется метод «Exponential».

См. также Настройка вида графика.


ATR (Average True Range)

Индикатор ATR – осциллятор, который определяет степень волатильности рынка. Индикатор ATR необходим для нахождения сопротивления и поддержки. Поскольку индикатор ATR является осциллятором, то к нему применим анализ, используемый для анализа классических осцилляторов.

  • Низкий уровень ATR показывает отсутствие тренда и тихую торговлю в небольшом диапазоне.
  • Высокий уровень ATR показывает наличие ярко выраженного тренда и интенсивную торговлю.

Индикатор ATR не показывает предполагаемое направление и продолжительность движения, а лишь показывает уровень активности рынка.

    Вычисление:

    Параметры настройки:

    «Кол-во периодов» - количество периодов n.

    См. также Настройка вида графика.


Bears Power («Сила медведей»)

Осциллятор Bears Power разработан Александром Элдером для оценивания баланса сил «медведей» и прогнозирования возможного изменения направления тренда. Индикатор базируется на разнице между минимальной ценой и 13-периодной экспоненциальной скользящей средней EMA. В сочетании со 13-периодной EMA и осциллятором Bulls Bower образует метод технического анализа Elder Ray («биржевой рентген»).

Вычисление:

Bearsi = Li – EMAi

где:

  • L - минимальная цена текущего периода;
  • EMA - значение EMA текущего периода.

Параметры настройки:

«Кол-во периодов» - количество периодов n для расчета EMA.

См. также Настройка вида графика.


Bollinger Bands («Полосы Боллинджера»)

«Полосы Боллинджера» строятся в поле графика цены и представляют собой каналы с шириной, пропорциональной стандартному отклонению цен. Ширина полос зависит от устойчивости рынка - полоса расширяется при нестабильности рынка и сужается при более устойчивых ценах.

Вычисление:

BBLower = MA(P,N) – k * StDev(P,N) - нижняя ограничительная линия,

ВВMiddle = MA(P,N) - cредняя скользящая,

BBUpper = MA(P,N) + k * StDev(P,N) - верхняя ограничительная линия,

где:

  • P - цена;
  • N - число периодов для расчета средней скользящей;
  • k - число стандартных отклонений.

Параметры настройки:

  1. «Кол-во периодов» - количество периодов N для расчета MA.
  2. «Отклонения» - число стандартных отклонений (k).
  3. «Метод» - метод расчета МА (Simple, Exponential, Vol.Adjusted, Smoothed), по умолчанию используется метод «Simple».
  4. «Поле цены» - используемое для P значение цены интервала (Open, High, Low, Close, Median, Typical), по умолчанию принимается «Close».

См. также Настройка вида графика.


Bulls Power («Сила быков»)

Осциллятор Bulls Power разработан Александром Элдером для оценивания баланса сил «быков» и прогнозирования возможного изменения направления тренда. Индикатор базируется на разнице между максимальной ценой и 13-периодной экспоненциальной скользящей средней EMA. В сочетании со 13-периодной EMA и осциллятором Bears Bower образует метод технического анализа Elder Ray («биржевой рентген»).

Вычисление:

Bullsi = Hi – EMAi

где:

  • H – максимальная цена текущего периода;
  • EMA – значение EMA текущего периода.

Параметры настройки:

«Кол-во периодов» - количество периодов n для расчета EMA.

См. также Настройка вида графика.


CCI («Индекс товарного канала»)

«Индекс товарного канала» (Commodity Channel Index - CCI) измеряет отклонение цены инструмента от его среднестатистической цены. Высокие значения индекса указывают на то, что цена необычно высока по сравнению со средней, а низкие - что она слишком занижена. Несмотря на название, применим не только к товарам, но и к финансовым инструментам.

Вычисление:

CCI = (TP - MA (TP, N)) / (MD * 0.015)

где:

  • MD = SUM (ABS (MA (TP, N) - TPi)) / N - вероятное отклонение;
  • TP = (HIGH + LOW + CLOSE) / 3 - типичная цена;
  • MA - скользящее среднее;
  • N - количество периодов.

Параметры настройки:

  1. «Кол-во периодов» - количество периодов N для расчета MA.
  2. «Метод» - метод расчета МА (Simple, Exponential, Vol.Adjusted, Smoothed), по умолчанию используется метод «Exponential».

См. также Настройка вида графика.


Chaikin Oscillator («Осциллятор Чайкина»)

Индикатор «Осциллятор Чайкина» рассчитывается как разница экспоненциальных скользящих средних индикатора «Аккумуляции/Дистрибуции» с периодами усреднения 3 (короткий период) и 10 (длинный период) соответственно.

Вычисление:

CO = MA (Nshort, CumAD) – MA (Nlong, CumAD)

где:

  • MA (N, CumAD) – скользящее среднее от CumAD за N периодов;
  • CumAD – значение индикатора Accumulation/Distribution;
  • Nshort – количество интервалов в коротком периоде;
  • Nlong – количество интервалов в длинном периоде.

Параметры настройки:

  1. «Короткий период» - изменение значения Nshort, по умолчанию равен 3.
  2. «Длинный период» - изменение значения Nlong, по умолчанию равен 10.
  3. «Метод» - метод расчета МА (Simple, Exponential, Vol.Adjusted, Smoothed), по умолчанию используется метод «Exponential».

См. также Настройка вида графика.


Chaikin’s Volatility («Волатильность Чайкина»)

Индикатор «Волатильности Чайкина» (Chaikin's Volatility) реагирует на изменения разности между максимальной и минимальной ценой. Волатильность в этом индикаторе представлена как ширина диапазона между этими экстремальными значениями.

Вычисление:

CV = (MAn(i, SPn) - MAn-i(i, SPn)) * 100 / MAn-i(i, SPn)

где:

  • SPn = HIGHn - LOWn;
  • MA (i, SP) – скользящее среднее от SP с периодом i;
  • HIGHn – максимальное значение цены сделки в n-ом интервале;
  • LOWn - минимальное значение цены сделки в n-ом интервале.

Параметры настройки:

  1. «Количество периодов» - изменение количества периодов i усреднения МА, по умолчанию = 10.
  2. «Метод» - метод расчета МА (Simple, Exponential, Vol.Adjusted, Smoothed), по умолчанию используется метод «Exponential».

См. также Настройка вида графика.


CMO («Осциллятор ценовых моментов Чанде»)

Основные методы использования «Осциллятора ценовых моментов Чанде» (Chande Momentum Oscillator):

  • Обычный метод интерпретации CMO - поиск «перекупленности»/«перепроданности». «Перекупленность» - при уровне +50 и выше, «перепроданность» при уровне -50 и ниже. Эти уровни соответствуют уровням 70/30 на индикаторе RSI.
  • Индикатор тренда. Покупка - при пересечении CMO длинного периода с CMO короткого периода, продажа - наоборот, при пересечении CMO короткого периода с CMO длинного периода.

Вычисление:

CMO = (SUM1 - SUM2) / (SUM1 + SUM2) * 100

где:

  • SUM1 = SUM (CMO1, n) - суммарное значение CMO1 за n периодов;
  • SUM2 = SUM (CMO2, n) - суммарное значение CMO2 за n периодов;
  • diff = Pi - Pi-1:
    • Если diff > 0, то CMO1I = diff, CMO2I = 0;
    • Если diff < 0, то CMO2I = -diff, CMO1I = 0.
  • Pi - цена (обычно закрытия) текущего периода;
  • Pi-1 - цена (обычно закрытия) предыдущего периода.

Параметры настройки:

  1. «Количество периодов» - изменение количества периодов n, по умолчанию = 14.
  2. «Поле цены» - используемое для PRICE значение цены интервала (Open, High, Low, Close, Median, Typical), по умолчанию принимается «Close».

См. также Настройка вида графика.


Elder's Force Index («Индекс силы Элдера»)

Предложенный А. Элдером «Индекс силы быков/медведей» (EFI) измеряет силу быков после каждого периода поддержки и силу медведей после каждого понижения. Индикатор полезен при определении моментов открытия и закрытия позиций. Следует открываться на покупку, когда индикатор принимает отрицательные значения, и открываться на продажу при ее положительных значениях.

Вычисление:

EFIN = MA(i, FI)

где:

  • FI = (1 - PRICEn-1 / PRICEn) * VOLUMEn;
  • MA (i, FI) – скользящее среднее от FI с периодом i;
  • PRICEn – значение цены n-ого интервала;
  • VOLUMEn – значение объема сделок n-ого интервала.

Параметры настройки:

  1. «Количество периодов» - изменение количества периодов i усреднения МА, по умолчанию = 13.
  2. «Метод» - метод расчета МА (Simple, Exponential, Vol.Adjusted, Smoothed), по умолчанию используется метод «Exponential».
  3. «Поле цены» - используемое значение цены интервала PRICE (Open, High, Low, Close, Median, Typical), по умолчанию принимается «Close».

См. также Настройка вида графика.


Envelopes («Конверты»)

Индикатор «Envelopes» («Конверты», «Огибающие линии») включает три скользящие средние (MA). При этом одна МА строится со сдвигом вверх, а вторая со сдвигом вниз. Огибающие линии определяют верхнюю и нижнюю границы «обычного» торгового диапазона инструмента. Сигнал продажи генерируется, когда цена инструмента достигает верхней границы, а покупки при достижении нижней границы. Оптимальное значение сдвига (выраженного в процентах) зависит от волатильности инструмента. Чем больше волатильность, тем выше значение сдвига.

Вычисление:

Lo = MA(n, PRICE) – средняя линия

Lup = Lo * (1 + k/100) – верхняя линия

Ldown = Lo * (1 - k/100) – нижняя линия

где:

  • MA(n) – скользящее среднее от PRICE с периодом i;
  • k - коэффициент сдвига, в %;
  • PRICE – значение цены интервала.

Параметры настройки:

  1. «Коэффициент» - величина сдвига k, по умолчанию равен 2.
  2. «Количество периодов» - изменение количества периодов n усреднения МА, по умолчанию = 20.
  3. «Метод» - метод расчета МА (Simple, Exponential, Vol.Adjusted, Smoothed), по умолчанию используется метод «Exponential».
  4. «Поле цены» - используемое для PRICE значение цены интервала (Open, High, Low, Close, Median, Typical), по умолчанию принимается «Close».

См. также Настройка вида графика.


Fractals («Фракталы»)

Индикатор «Фракталы» включает в себя серию из нескольких последовательных свечей и имеет две разновидности:

  • «Фрактал вверх» — это серия из минимум пяти последовательных свечей, в которой перед средней свечой и за ней находятся свечи, чьи максимумы не выше, чем у средней свечи.
  • «Фрактал вниз» — это серия из минимум пяти последовательных свечей, в которой перед средней свечой и за ней находятся свечи, чьи минимумы не ниже, чем у средней свечи.

На графике фракталы имеют значения High и Low и отмечены стрелками вверх или вниз.


Ichimoku («Ишимоку»)

Индикатор Ишимоку Кинко Хайо (Ichimoku Kinko Hyo) предназначен для определения рыночного тренда, уровней поддержки и сопротивления и для генерации сигналов покупки и продажи. Лучше всего индикатор работает на недельных и дневных графиках.

При определении размерности параметров используется четыре временных интервала различной протяженности. На этих интервалах основываются значения отдельных линий, составляющих этот индикатор:

  1. «Tenkan-sen» (Розовая) показывает среднее значение цены за первый промежуток времени. Tenkan-sen используется как индикатор рыночного тренда. Если эта линия растет или падает — тренд существует. Когда она идет горизонтально — рынок вошел в канал.
  2. «Kijun-sen» (Красная) показывает среднее значение цены за второй промежуток времени и используется как показатель движения рынка. Если цена выше нее, цены, вероятно, будут продолжать расти. Когда цена пересекает эту линию вероятно дальнейшее изменения тренда. Другим вариантом использования Kijun-sen является подача сигналов: сигнал к покупке генерируется, когда линия Tenkan-sen пересекает Kijun-sen снизу вверх; сверху вниз — сигнал к продаже.
  3. «Senkou Span 1» (Голубая) показывает середину расстояния между предыдущими двумя линиями, сдвинутую вперед на величину второго временного интервала.
  4. «Senkou Span 2» (Зеленая) показывает среднее значение цены за третий временной интервал, сдвинутое вперед на величину второго временного интервала. Расстояние между линиями Senkou штрихуется на графике другим цветом и называется «облаком».
  5. «Chinkou Span» (Коричневая) показывает цену закрытия текущей свечи, сдвинутую назад на величину второго временного интервала. Если цена находится между линиями «облака», то рынок считается нетрендовым и тогда края «облака» образуют уровни поддержки и сопротивления. Если цена находится над «облаком», то верхняя его линия образует первый уровень поддержки, а вторая — второй уровень поддержки. Если цена находится под «облаком», то нижняя линия образует первый уровень сопротивления, а верхняя — второй. Если линия Chinkou Span пересекает график цены снизу вверх, это является сигналом к покупке. Если сверху вниз — сигналом к продаже.

Параметры настройки:

  1. «Tenkan» – длина периода для Tenkan-sen.
  2. «Kijun» - длина периода для Kijun-sen.
  3. «Senkou» - длина периода для Senkou Span 1.
  4. «Chinkou» – длина периода для Chinkou.
  5. «Горизонтальный сдвиг» - величина сдвига Senkou Span 2.
  6. «Цвета линий» - настройка цвета линий.

См. также Настройка вида графика.


MACD («Схождение-расхождение скользящих средних»)

Индикатор по умолчанию состоит из двух линий – MACD, гистограммы разницы двух экспоненциальных МА, и MACD Signal – «сигнальной» линии МА по значению MACD. Отображение индикатора может меняться в зависимости от выбранного параметра «Вид графика».

Вычисление:

в точках MACD = MA(P, Nshort) - MA(P, Nlong)

в процентах MACD = 100% * (MA(P, Nshort) - MA(P, Nlong)) / MA(P, Nlong)

MACD Signal = MA(MACD, N)

где:

  • MA(P, Nlong) - средняя скользящая цены P за Nlong периодов (обычно 26);
  • MA(P, Nshort) - средняя скользящая цены P за Nshort периодов (обычно 12);
  • MA(MACD, N) - средняя скользящая от MACD за N периодов (обычно 9).

Параметры настройки:

  1. «Скользящие средние», «Метод» - такие же, как у Price Oscillator .
  2. «Сигнальная скользящая средняя»:
    • «Кол-во периодов» - количество N периодов для расчета МА от MACD;
    • «Метод» - метод расчета МА от MACD (Simple, Exponential), по умолчанию используется «Simple»;
    • «Вид графика» - выбор вида графика, по умолчанию используется «Гистограммы»;
    • «Цвет линии» - выбор цвета сигнальной линии.

См. также Настройка вида графика.


MACD-Histogram

Гистограмма MACD строится по значению разности MACD и его сигнальной линии (по умолчанию – 9-типериодной экспоненциальной МА).

Вычисление:

MACD Histogram = MACD – MACD Signal

где:

  • MACD = MA(P, Nshort) - MA(P, Nlong);
  • MA(P, Nlong) - средняя скользящая цены P за Nlong периодов (обычно 26);
  • MA(P, Nshort) - средняя скользящая цены P за Nshort периодов (обычно 12);
  • MACD Signal = MA(MACD, N) – «сигнальная линия», средняя скользящая от MACD за Nпериодов (обычно 9).

Параметры настройки:

  1. «Скользящие средние» - такие же, как у MACD, Price Oscillator.
  2. «Сигнальная скользящая средняя», «Метод» - аналогично MACD.

См. также Настройка вида графика.


BW MFI («Bill Williams Market Facilitation Index»)

«Индекс Облегчения Рынка Билла Уильямса» показывает изменение цены за один тик. Численные значения индикатора не показательны, смысл имеет относительное изменение значений:

  • Одновременный рост BW MFI и объема (Volume) говорит о том, что все больше игроков входит в рынок (растет объем), и новые игроки открывают позиции в направлении развития бара.
  • Одновременное падение BW MFI и объема говорит о снижении интереса участников к данной динамике цены.
  • BW MFI вырос, а объем упал – рынок не поддерживает такую динамику цены. Изменение цены – результат спекуляций.
  • BW MFI упал, а объем вырос – идет ожесточенная борьба между быками и медведями (объем вырос), но силы примерно равны (индикатор упал). Такой бар Б.Вильямс называл "приседающим". Обычно прорыв такого бара очень важен с точки зрения будущей динамики цены.

Вычисление:

BW MFI = (HIGH - LOW) / VOLUME

где:

  • HIGH - максимальная цена текущего периода;
  • LOW - минимальная цена текущего периода;
  • VOLUME - объем сделок текущего периода.

Параметров настройки нет.

См. также Настройка вида графика.


Momentum («Темп движения»)

«Момент» цены (или «Темп движения» ) представляет собой отношение текущей цены к предыдущей цене, бывшей раньше на i периодов.

Вычисление:

MOMn = PRICEn / PRICEn-i * 100

где:

  • PRICEn – значение цены n-ного периода;
  • i – количество предшествующих периодов.

Параметры настройки:

  1. «Количество периодов» - количество предшествующих периодов (i), по умолчанию 5.
  2. «Поле цены» - используемое для PRICE значение цены интервала (Open, High, Low, Close, Median, Typical), по умолчанию принимается «Close».

См. также Настройка вида графика.


Money Flow Index («Индекс денежных потоков»)

Индикатор «Индекс денежных потоков» (Money Flow Index - MFI) оценивает движение денежных средств по инструменту (вложение и изъятие) на основе сравнения положительных и отрицательных денежных потоков.

Денежный поток вычисляется при помощи определения средней цены за текущий период и сравнения этой величины со средней ценой предыдущего периода.

Вычисление:

MFI = 100 - 100/(1 + Ratio)

где:

  • Ratio = Fpn / Fnn;
  • Fpn = Fpn-1 + TPn * VOLUMEn, если TPn > TPn-1 – положительный денежный поток;
  • Fnn = Fnn-1 + TPn* VOLUMEn, если TPn< TPn-1 – отрицательный денежный поток;
  • TPn = (HIGHn + LOWn + CLOSEn) / 3 – типичная цена;
  • n – количество периодов для расчета;
  • HIGHn – максимальное значение цены сделки в n-ом интервале;
  • LOWn – минимальное значение цены сделки в n-ом интервале;
  • CLOSEn – цена последней сделки в n-ом интервале;
  • VOLUMEn – объем сделок в n-ом интервале.

Параметры настройки:

«Количество периодов» - количество периодов (n), по умолчанию 3.

См. также Настройка вида графика.


On Balance Volume («Балансовый объем»)

Индикатор «Балансовый объем» показывает направление потока объема: на рынок или из него.

Если цена закрытия выше предыдущей цены закрытия, то все объемы периодов рассматриваются как рост общего объема. Если цена закрытия ниже предыдущей цены закрытия, то все объемы периодов рассматриваются как снижение общего объема.

Вычисление

OBVn = OBVn-1 + VOLUMEn, если PRICEn > PRICEn-1

OBVn = OBVn-1 - VOLUMEn, если PRICEn < PRICEn-1

OBVn = OBVn-1, если PRICEn = PRICEn-1

где:

  • VOLUMEn – объем сделок в n-ом периоде;
  • PRICEn – значение цены для n-ого периода.

Параметры настройки

«Поле цены» – используемое для PRICE значение цены интервала (Open, High, Low, Close, Median, Typical), по умолчанию принимается «Close».

См. также Настройка вида графика.


Parabolic SAR («Параболическая система»)

Parabolic SAR ( «Stop and Reverse») - система определения точек разворота позиций. Индикатор строится на ценовом графике. По своему смыслу данный индикатор аналогичен скользящей средней, с той лишь разницей, что Parabolic SAR движется с большим ускорением и может менять положение относительно цены. Если цена пересекает линии Parabolic SAR, то происходит разворот индикатора, а следующие его значения располагаются по другую сторону от цены. Переворот индикатора — это сигнал либо об окончании тренда, либо об его развороте.

Системой Parabolic SAR следует пользоваться выборочно, лишь при наличии трендов. При отсутствии тренда она дает множество ложных сигналов.

Вычисление:

  1. Для длинных позиций:
      SARi = SARi-1+ AF*(HIGHi-1 - SARi-1 )
    • Для коротких позиций:
        SARi = SARi-1 + AF*(LOWi-1 - SARi-1 )

      где:

      • HIGHi-1 - наибольшее значение цены предыдущего периода;
      • LOWi-1 - наименьшее значение цены предыдущего периода;
      • SARi-1 - значение SAR предыдущего периода, AF - фактор ускорения.

    Параметры настройки:

    1. «Шаг» - шаг изменения цены закрытия позиции (фактора ускорения AF), рекомендуемое значение 0,02.
    2. «Макс.шаг» - предельное значение шага, рекомендуемое значение 0,2.

    См. также Настройка вида графика.


Price Channel («Ценовой канал»)

Индикатор Price Channel представлен двумя граничными линиями: верхняя – ценовой максимум за N периодов, нижняя – ценовой минимум за N периодов. Линии канала можно интерпретировать как динамические линии поддержки и сопротивления. Средняя линия отображает среднее арифметическое между ними.

Вычисление:

PChi=max([Hi-n;Hi]) – верхняя линия (сопротивления)

PCli=min([Li-n;Li]) – нижняя линия (поддержки)

PCmi=(PChi+PCli)/2 – средняя линия

где: i >=n

Параметры настройки:

  1. «Кол-во периодов» – количество периодов (n), по умолчанию – «10».
  2. «Цвет upper» – цвет верхней линии.
  3. «Цвет» – цвет нижней линии.

См. также Настройка вида графика.


Price Oscillator («Ценовой осциллятор»)

Индикатор Price Oscillator представляет собой разность скользящих средних, построенных по двум периодам. Эта разница может быть выражена как в процентах, так и в абсолютных значениях.

Вычисление:

PO = MA(P, Nshort) - MA(P, Nlong)

где:

  • MA(P, Nshort) - среднее скользящее цены P за Nshort периодов;
  • MA(P, Nlong) - среднее скользящее цены P за Nlong периодов.

Параметры настройки:

  1. «Скользящие средние»:
    • «Короткий период» - значение Nshort периода для первой («короткой») МА;
    • «Длинный период» - значение Nlong периода для второй («длинной») МА;
    • «Метод» - метод расчета МА (Simple, Exponential, Vol.Adjusted, Smoothed), по умолчанию используется «Exponential»;
    • «Поле цены» - используемое для P значение цены интервала (Open, High, Low, Close, Median, Typical), по умолчанию принимается «Close».
  2. «Метод» - выбор метода сравнения МА (Проценты, Точки).

См. также Настройка вида графика.


Rate Of Change («Скорость изменения»)

Индикатор «Скорость изменения цены» (Price Rate-Of-Change - ROC) рассчитывается как отношение изменения цены закрытия за определенный период, к цене закрытия начала этого периода. Результат показывает процентное изменение цены за данное количество периодов.

Вычисление:

ROC = (PRICEn - PRICEn-i) / PRICEn-i * 100

где:

  • PRICEn – значение цены для n-ого периода;
  • i – количество периодов.

Параметры настройки:

  1. «Количество периодов» - изменение количества периодов i, по умолчанию = 5.
  2. «Поле цены» - используемое для PRICE значение цены интервала (Open, High, Low, Close, Median, Typical), по умолчанию принимается «Close».

См. также Настройка вида графика.


Relative Strength Index («Индекс относительной силы»)

Relative Strength Index (RSI) - это следующий за ценами осциллятор, который колеблется в диапазоне от 0 до 100. Распространенным методом анализа RSI является поиск расхождения между ценами и значением индикатора, при которых цена образует новый максимум, а RSI не удается преодолеть уровень своего предыдущего максимума. Подобное расхождение свидетельствует о вероятности разворота цен.

При построении индикатора на графике задаются два контрольных уровня (по умолчанию 30 и 70) с помощью горизонтальных линий. Когда RSI поднимается выше верхнего контрольного уровня, индикатор показывает перенасыщенность рынка покупками и вхождение в область продаж. Когда RSI опускается ниже нижнего контрольного уровня, индикатор показывает перенасыщенность рынка продажами и вхождение в область покупок.

Вычисление:

RSI = 100 / (1 + D(P,N) / U(P,N))

где:

  • U(P,N) - скользящее среднее роста цены P за N периодов;
  • D(P,N) - скользящее среднее падения цены P за N периодов.

Параметры настройки:

  1. «Кол-во периодов» - количество периодов N для расчета скользящих средних.
  2. «Поле цены» - используемое для P значение цены интервала (Open, High, Low, Close, Median, Typical).

См. также Настройка вида графика.


Relative Vigor Index («Индекс относительной бодрости»)

Индекс относительной бодрости измеряет уверенность текущего движения цены и вероятность продолжения этого движения.

RVI сравнивает расположение цены закрытия по отношению к диапазону цен, а результат сглаживает путем вычисления скользящего среднего от его значения. Скользящее среднее, в свою очередь, отражает среднее значение равновесия за определенный выбранный период. В данном случае в качестве сигнальной линии выступает 4-периодное скользящее среднее от значения Relative Vigor Index, которое служит для снижения неопределенности.

Быстрая линия RVI (синяя) отражает энергию рыночного движения, которая основана на том, что цены закрываются выше, чем открывались и отражает равновесие рыночной толпы за короткий период времени. Более медленная сигнальная линия отражает равновесие рыночной толпы за более длинный период. Сочетание двух линий дает типичные для осцилляторов сигналы пересечения.

Когда быстрая линия RVI пересекает медленную сигнальную линию снизу-вверх, она показывает, что на рынке сейчас сильны покупатели и лучше открывать позиции на покупку. Когда быстрая линия RVI пересекает медленную сигнальную линию сверху-вниз, она показывает, что на рынке сейчас сильнее продавцы и лучше открывать только позиции на продажу.

Вычисление:

, i <= n + 3

MoveAveragei = (Ci – Oi) + 2 (Ci-1 – Oi-1) + 2 (Ci-2 – Oi-2) + (Ci-3 – Oi-3), i > 3

RangeAveragei = (Hi – Li) + 2 (Hi-1 – Li-1) + 2 (Hi-2 – Li-2) + (Hi-3 – Li-3), i > 3

RVI_Signali = (RVIi + 2RVIi-1 + 2RVIi-2 + RVIi-3)/6, i >= (n + 3) + 3

где:

  • Сi – цена закрытия i-го периода;
  • Hi – максимальная цена i-го периода;
  • Li – минимальная цена i-го периода;
  • Oi - цена открытия i-го периода.

Параметры настройки:

  1. «Кол-во периодов» – количество периодов n для расчета скользящих средних.
  2. «Параметры Signal» – параметры отображения сигнальной линии:
    • «Вид графика» – выбор способа отображения сигнальной линии, по умолчанию – «Пунктир»;
    • «Цвет линии» – выбор цвета линии.

См. также Настройка вида графика.


Smoothed Rate Of Change («Сглаженная скорость изменения»)

Индикатор «Сглаженная скорость изменения» (S-RoC) сравнивает значения экспоненциальных движущихся средних, а не значения цен в два момента времени, Таким образом, в отличие от индикатора Rate Of Change, он реагирует на каждый элемент данных один, а не два раза. Осциллятор вырабатывает меньше сигналов, и их достоверность выше.

Вычисление:

SROC = MA(n) / MA(n-k) * 100

где:

  • MA(n) – скользящая средняя значения цены PRICE;
  • n – количество периодов усреднения MA;
  • k – сглаживающий коэффициент.

    Параметры настройки:

    1. «Коэффициент» - величина сглаживающего коэффициента k, по умолчанию равен 5.
    2. «Количество периодов» - изменение количества периодов n усреднения МА, по умолчанию = 10.
    3. «Метод» - метод расчета МА (Simple, Exponential, Vol.Adjusted, Smoothed), по умолчанию используется метод «Exponential».
    4. «Поле цены» - используемое для PRICE значение цены интервала (Open, High, Low, Close, Median, Typical), по умолчанию принимается «Close».

    См. также Настройка вида графика.


Standard Deviation («Стандартное отклонение»)

Стандартное отклонение представляет собой статистический метод измерения волатильности. Самостоятельно индикатор используется редко и чаще всего входит в состав какого-либо индикатора. Например, стандартное отклонение используется при расчете «Полос Боллинжера».

Вычисление:

StDev = SQRT(SUM((Pi – SMA(P,N))^2)/N)

где:

  • SMA – простая скользящая средняя по значению цены P за N периодов;
  • N – количество периодов;
  • SQRT () – вычисление квадратного корня.

Параметры настройки:

  1. «Кол-во периодов» - количество N периодов для расчета MA.
  2. «Поле цены» - используемое для P значение цены интервала (Open, High, Low, Close, Median, Typical), по умолчанию принимается «Close».

См. также Настройка вида графика.


Stochastic Oscillator («Стохастический осциллятор»)

Стохастический осциллятор показывает моменты, когда цена подходит близко к границе ее торгового диапазона за определенный период времени. Индикатор состоит из двух кривых: быстрой - %К, и медленной - %D.

Вычисление:

%К(m) = 100 *SMA (С – LLVn, m) / SMA (HHVn – LLVn, m)

%D = MA (%K, s)

где:

  • SMA - простая скользящая средняя (Simple Moving Average);
  • С - цена закрытия текущего периода;
  • LLVn - минимальная цена за последние n периодов;
  • HHVn - максимальная цена за последние n периодов;
  • m - сглаживание;
  • n - число периодов (обычно от 5 до 21);
  • s - число периодов для расчета средней скользящей.

Параметры настройки:

  1. «Параметры %K»:
    • «Кол-во периодов» - количество периодов n;
    • «Сглаживание» - период, используемый для внутреннего сглаживания значений %K. Значение 1 рассматривается как сильная (быстрая) стохастика. Значение 3, принятое по умолчанию, рассматривается как медленная стохастика.
  2. «Параметры %D»:
    • «Кол-во периодов» - количество периодов для расчета MA;
    • «Метод» - метод расчета МА (Simple, Exponential), по умолчанию используется «Simple»;
    • «Вид графика» - выбор вида графика (линии, точки, пунктир);
    • «Цвет линии» - выбор цвета линии.

См. также Настройка вида графика.


TRIX («Triple Exponential Moving Average»)

Индикатор TRIX - это динамический индикатор, показывающий степень процентного изменения тройной экспоненциально-сглаженной скользящей средней от цены закрытия рыночного инструмента. Колеблясь вокруг нулевой линии, индикатор TRIX предназначен отфильтровывать движения рыночного инструмента, которые являются незначительными по отношению к большему тренду рыночного инструмента.

Индикатор TRIX вычисляется по следующему алгоритму:

  1. Получают экспоненциальную MA.
  2. Получают экспоненциальную MA от EMA, полученной на этапе 2.
  3. Получают экспоненциальную MA от EMA, полученной на этапе 3.
  4. Вычисляют 1-периодную разность между результатами тройного сглаживания: для этого значение этапа 4 текущего периода вычитают из значения этапа 4 предшествующего периода.
  5. Значение, полученное на этапе 5, делят на значение этапа 4 предшествующего периода и умножают на 100 для удобства отображения на графике.

Вычисление:

TRIX(i) = (3MA(i) - 3MA(i-1)) / 3MA(i-1) * 100

где:

  • 3MA=MA(MA(MA(H / L / O / C)));

  • MA – скользящая средняя с заданными пользователем параметрами;
  • H / L / O / C – выбранное пользователем поле цены.

См. также Настройка вида графика.


Vertical Horizontal Filter («Вертикально-горизонтальный фильтр»)

Индикатор «Вертикально-горизонтальный фильтр» (Vertical Horizontal Filter - VHF) измеряет состояние «трендовости» рынка, определяет находятся ли цены в фазе тренда или в фазе «застоя». Индикатор VHF сравнивает сумму показателей ROC за определенный период с разницей между максимальной и минимальной ценой за этот период.

Вычисление:

VHF = A / B

где:

  • A = HH - LL;
  • HH – максимальная цена за выбранный период;
  • LL - минимальная цена за выбранный период;
  • B = SUM (ABS(PRICEn - PRICEn-1) ) за выбранный период.

Параметры настройки:

  1. «Кол-во периодов» - количество периодов n, по умолчанию = 28.
  2. «Поле цены» - используемое для PRICE значение цены интервала (Open, High, Low, Close, Median, Typical), по умолчанию принимается значение «Close».

См. также Настройка вида графика.


Volume Oscillator («Осциллятор объема»)

Индикатор «Осциллятор объема» (Volume Oscillator) представляет из себя разность двух МА объема сделок по инструменту, выраженную в процентах.

Разность двух МА объема с различной длиной периода может использоваться с целью определения направления движения основной тенденции объема (повышение или снижение). Повышение «Осциллятора объема» выше нуля означает, что краткосрочная МА объема находится выше долгосрочной, т.е. что краткосрочный объемный тренд по сравнению с долгосрочным трендом более высокий.

Вычисление:

VO = (MA(Nshort, VOLUME) - MA(Nlong, VOLUME) ) / MA(Nlong, VOLUME) * 100

где:

  • MA(N, VOLUME) - среднее скользящее объема VOLUME за N периодов;
  • Nshort – величина короткого периода;
  • Nlong – величина длинного периода.

Параметры настройки:

  1. «Короткий период» - значение Nshort периода для первой («короткой») МА, по умолчанию = 5.
  2. «Длинный период» - значение Nlong периода для второй («длинной») МА, по умолчанию = 10.
  3. «Метод» - метод расчета МА (Simple, Exponential, Vol.Adjusted, Smoothed), по умолчанию используется «Exponential».

См. также Настройка вида графика.


Williams’ % Range («Процентный диапазон Уильямса»)

Индикатор «Процентный диапазон Уильямса» (Williams’ Percent Range, %R) - это динамический индикатор, определяющий состояние перекупленности/перепроданности.

Данный индикатор строится на «перевернутой» шкале, где 0 находится в верхней, а 100 в нижней части шкалы, поэтому для его отображения перед каждым значением ставится знак «минус».

Вычисление:

%R = -100 * (H - C) / (H - L)

где:

  • C - текущая цена закрытия;
  • L - минимальная цена за последние n периодов;
  • H - максимальная цена за последние n периодов.

Параметры настройки:

«Количество периодов» - количество периодов n.

См. также Настройка вида графика.


Williams’ A/D («Кумулятивное накопление/распределение Уильямса»)

Индикатор «Кумулятивное накопление/распределение Уильямса» (Williams' Accumulation/ Distribution, Williams' A/D) показывает распределение инструментов, если цены сделок по инструменту формируют новые «пики», а значения индикатора не могут сформировать нового «пика». Индикатор показывает накопление инструментов, когда цены сделок достигают новых «донышек», а индикатор достигнуть новых «донышков» не может.

Вычисление:

CumWADn = CumWadn-1 + WADn

где:

  • WADn = PRICEn - TL, если PRICEn > PRICEn-1;
  • WADn = PRICEn - TH, если PRICEn < PRICEn-1;
  • WADn = 0, если PRICEn = PRICEn-1;
  • TH = max(PRICEn-1, HIGHn) - истинный диапазон пиков;
  • TL = min(PRICEn-1, LOWn) – истинный диапазон донышек;
  • PRICEn – цена закрытия в n-ом интервале;
  • HIGH – максимальное значение цены в n-ом интервале;
  • LOW – минимальное значение цены в n-ом интервале.

Параметров настройки нет.

См. также Настройка вида графика.


График доходности облигаций

меню Создать окно / График доходности... или кнопка

Назначение

График доходности облигаций отображает доходность для выбранного множества облигаций в зависимости от даты их погашения (или оферты).

Формат окна

График представляет собой множество точек, каждая из которых соответствует отдельной облигации. Положение точек на графике определяется двумя параметрами:

  • По оси времени – ближайшая из двух дат: дата погашения или дата оферты.
  • По вертикальной оси – значение параметра «Доходность последней сделки», либо значение параметра «Доходность по оценке». Выбор параметра для построения меток доходности выполняется в настройках программы.

Диаграмма имеет вид типа «Точка», размер и цвет которого определяется в зависимости от выбранных настроек, вызвать которые можно двойным кликом по метке показателя величины доходности облигации или из пункта контекстного меню «Параметры графика».

См. также Настройка графика доходности облигаций.


Настройка графика доходности облигаций

  • Настройка общих параметров диаграммы
  • Настройка параметров области построения
  • Настройка вида графика

    • Создание нового графика осуществляется одним из следующих способов:

    • Выбрать пункт меню программы Создать окно/График доходности…;
    • Нажать кнопку [image] в панели инструментов;
    • Выбрать пункт меню программы Действия/Новая диаграмма доходности облигаций… при активном окне графика;
    • Выбрать пункт контекстного меню таблицы текущих торгов Диаграмма доходности облигаций.

    Параметры диаграммы настраиваются при создании нового графика либо из контекстного меню на области построения активного графика:

    Настройка общих параметров диаграммы

    1. «Заголовок» - заголовок окна графика.
    2. «Цветовые настройки» – настройка цветов для элементов диаграммы (фона, осей, сетки, шрифтов).
    3. «Показывать на графике» – настройка отображения элементов графика:
      • «Шкалу времени» – отображать значения на шкале времени (горизонтальная ось);
      • «Вертикальную сетку» – отображать вертикальные линии сетки на области построения;
      • «Пустые интервалы» – если флажок включен, то на шкале времени отображаются все интервалы времени; если флажок выключен, то отображаются только интервалы, содержащие значения. По умолчанию флажок включен.
    4. «Показывать подсказку» – выбор способа отображения параметров облигации при наведении курсора на точку графика:
      • «Рядом с указателем» – при наведении курсора на точку графика рядом с ней отображается всплывающая подсказка;
      • «Вверху слева» – параметры отображаются в верхнем левом углу диаграммы.

    Настройка параметров области построения

    1. «Легенда» – включение отображения легенды графика и настройка ее расположения относительно области построения:
      • «Над графиком» – над областью построения;
      • «Под графиком» – под областью построения.
    2. «Шкала значений»:
      • «Верхняя граница» – установить максимальное значение шкалы;
      • «Нижняя граница» – установить минимальное значение шкалы;
      • «Горизонтальная сетка» – включение отображения горизонтальных линий сетки на области построения;
      • «Авто» – автоматическое определение масштаба вертикальной шкалы (максимального и минимального значения параметров в отображаемом диапазоне времени).

    Настройка вида графика

    1. «Подпись» – редактирование легенды графика.
    2. «Доступные инструменты», «Выбранные инструменты» – настройка списка облигаций, отображаемых на графике. Список выбранных облигаций для каждой области на диаграмме настраивается отдельно. Для этого в левой части окна выберите график в нужной области построения, затем в правой части окна настройте список облигаций для выбранного графика.
    3. «Показывать значения» – выбор и цветовые настройки параметров, отображаемых на графике:
      • «Доходность последней сделки» – показывать значения доходности, рассчитанные по цене последней сделки;
      • «Доходность по оценке» – показывать значения доходности, рассчитанные по средневзвешенной цене;
      • «Толщина меток» – настройка толщины меток на графике.


Доступные функции

Функции, доступные для графика, могут быть вызваны из пункта меню Действия или контекстного меню области построения графика:

(*) Функция доступна только из меню Действия.
(**) Функция доступна только из контекстного меню.
  1. «Новая диаграмма...» * – создать диаграмму по интересующим инструментам и параметрам.
  2. «Новая диаграмма доходности облигаций...» * – создать новую диаграмму доходности облигаций.
  3. «Добавить метку…» ** – выбрать тип пользовательской метки. При нажатии левой кнопки мыши на графике (в точке привязки метки) открывается окно настройки выбранного типа метки.
    • «Текст…»;
    • «Заметка…»;
    • «Выноска…»;
    • «Отметка цены…»;
    • «Картинка из файла…»;
    • «Значок».
  4. «Удалить» – удалить элемент диаграммы:
    • «Область <номер области >» – удаление области построения графиков. При удалении области построения удаляются все содержащиеся в ней графики;
    • «Все метки в диаграмме» – удаляет все метки, установленные на данном графике. Метки удаляются с предварительным подтверждением.
  5. «Редактировать…» – открыть окно настройки:
    • на странице редактирования настроек области построения – при вызове функции из контекстного меню области построения графика;
    • на странице редактирования общих параметров диаграммы – при вызове функции из пункта меню Действия.
  6. «Увеличить» – увеличить горизонтальный масштаб графика.
  7. «Уменьшить» – уменьшить горизонтальный масштаб графика.
  8. «Показать весь график» – показать весь график в окне.
  9. «Создать копию» (или «Ctrl»+«N») – создать новое окно графика на основе уже существующего.
  10. «Показать легенду» ** – включить/отключить отображение легенды в текущей области построения.
  11. «Показывать подсказку» ** – включить/отключить отображение всплывающей подсказки на свечке.
  12. «Сохранить изображение…» – сохранение изображения диаграммы в файл. Возможные форматы: Microsoft Bitmap (BMP), Microsoft Enhanced Metafile (EMF).
  13. «Печать» – распечатать видимую часть графика на принтере.

Действия, выполняемые из контекстного меню на точке графика:

  1. «Редактировать…» – открыть окно редактирования настроек выбранного графика.
  2. «Удалить график» – удаление текущего графика.
  3. «Сохранить данные в файл» – сохранение данных текущего графика в виде текстового файла.


Сохранение данных графика в файл

Численные значения, по которым построен график, могут быть сохранены в файл. В файл записываются данные по всем инструментам, отображенным в выбранном окне графика.

Способ выполнения:

  1. Выберите точку в том окне графика, данные по которому должны быть сохранены.
  2. Из контекстного меню на точке выберите пункт «Сохранить график».
  3. В открывшемся окне укажите название сохраняемого файла и выберите папку на диске для записи.

Формат файла имеет следующий вид:

В первой строке в угловых скобках указаны названия параметров, разделенные запятыми. В последующих строках выводятся данные по облигациям, в порядке возрастания даты пога-шения. Параметры доходности указываются те, которые были настроены для отображения на графике (Настройка параметров диаграммы).

<Инструмент>,<Погашение>,<Доходность последней сделки>,<Доходность по оценке>
Усть-Луга1,11.02.10,18.520000,0.000000
Русфинанс4,12.02.10,24.140000,0.000000


Раздел 5. Торговые операции клиента

  • Общие положения
  • Общий способ выполнения транзакций
  • Ввод заявки
  • Снятие заявки
  • Замена заявки
  • Условные (стоп-) заявки
  • Заявка с условием «по исполнению»
  • Управление заявками из Таблицы котировок
  • Перестановка заявок по опционам и фьючерсам
  • Закрытие позиции
  • Закрытие всех позиций
  • Переворот позиции
  • Расчет премии для опционов
  • Настройки параметров торговых операций
  • Настройка счетов
  • Настройка параметров инструментов
  • Снятие заявок по условию
  • Настройка автозаполнения полей ввода заявки
  • Настройка ограничений на объем заявки
  • Описания клиентов и рынков
  • Сообщения об ошибках

В разделе описан порядок осуществления наиболее часто совершаемых торговых операций. Дополнительные операции с системой QUIK (участие в аукционах по размещению инструментов, на периоде открытия и закрытия рынка, в режиме переговорных сделок (РПС) и операции РЕПО) описаны в Разделе 7, «Операции брокера».


Общие положения

В общем виде совершение сделок клиентом брокера осуществляется по следующей схеме:

  1. Брокер определяет клиенту остаток доступных ему средств на бирже, в пределах которого клиент может совершать сделки. Остаток средств выражается в деньгах либо инструментах и соответствует сумме средств, внесенных клиентом брокеру для работы на бирже (параметр «Входящий остаток» в таблице позиций).
  2. Если брокер предоставляет услугу маржинального кредитования (кредитования средствами брокера в деньгах или инструментах под залог средств клиента), то брокер определяет клиенту лимит заемных средств (параметр «Входящий лимит» в таблице позиций). Лимиты устанавливаются по тем инструментам, по которым возможно кредитование. Для просмотра остатков и лимитов служат:
    • Таблицы «Позиции по деньгам» и « Позиции по инструментам» – для схемы кредитования с контролем абсолютных значений лимитов;
    • Таблицы «Клиентский портфель» и «Купить/Продать» - для схемы кредитования с контролем текущей стоимости активов.

    Чтобы определить, по какой схеме производится кредитование, нужно открыть таблицу «Клиентский портфель». Если параметр «Тип клиента» имеет значения «МП» или «МЛ», то используется кредитование с контролем текущей стоимости активов, если значение пусто, то схема с контролем абсолютных значений лимитов.

  3. Клиент самостоятельно выбирает инструменты на бирже для их покупки/продажи. Покупка либо продажа осуществляется отправкой посредством системы QUIK поручения брокеру (заявки ), представляющей собой согласие купить/продать инструменты на указанных в поручении условиях. Заявка принимается сервером системы и проходит автоматический или ручной контроль, после чего передается в торговую систему биржи. Перечень зарегистрированных заявок отражается в Таблице заявок.
  4. Заявки могут иметь следующие состояния:
    • «Активна» – заявка зарегистрирована на бирже и поставлена в очередь, но еще не исполнена, либо исполнена не в полном объеме. Такую заявку можно снять либо отредактировать ее условия. Если заявка частично удовлетворена, то снять можно только неисполненный остаток заявки;
    • «Активирована» – стоп-заявка отправлена на биржу в виде обычной лимитированной заявки при наступлении заданного условия (см. п. 5);
    • «Исполнена» – условие заявки удовлетворено полностью, т.е. совершена сделка (или несколько сделок) на условиях, указанных в заявке. Исполненную заявку нельзя отозвать;
    • «Снята» – пользователь принял решение отменить заявку, либо изменить ее условия. При редактировании заявки она отзывается с биржи (убирается из очереди заявок для того, чтобы во время редактирования она не могла исполниться), затем формируется новое поручение с такими же условиями, которые можно редактировать.
  5. Брокер также может принять от клиента поручение, исполняемое в зависимости от достижения рыночной ценой инструмента определенного уровня – стоп-заявку (другое название – условная заявка). В такой заявке указывается два значения цены:
    • стоп-цена - условие вида «цена последней сделки не более (не менее) заданной величины». При наступлении условия заявка активируется, т.е. отправляется на биржу в виде обычной лимитированной заявки;
    • цена, указываемая в заявке при отправке на биржу.

    До наступления установленных условий стоп-заявки хранятся на сервере брокера, клиент может их видеть в Таблице стоп-заявок системы QUIK, а также редактировать или снимать их.

    При вводе заявки на счете клиента блокируются средства, необходимые для ее исполнения. Сделка, как правило, совершается при наличии в торговой системе встречных заявок (на покупку и на продажу) с взаимно удовлетворяющими условиями. Сделки, совершенные по заявкам клиента, отображены в Таблице сделок .

  6. Совокупная информация об объеме средств клиента, рыночной стоимости его инструментов и объеме задолженности брокеру приведена в окне «Клиентский портфель». Двойным нажатием левой кнопки мыши на строке таблицы открывается окно «Купить/Продать» со списком инструментов в портфеле клиента, оценкой их стоимости и доступным количеством лотов для открытия длинной и короткой позиции.
  7. Пользователь системы QUIK может также пользоваться отложенными заявками с помощью специального окна «Карман транзакций». В таком окне можно сформировать заявку с желаемыми условиями без отправки ее на биржу, и затем в нужный момент «достать из кармана» одну или несколько таких заявок.

Операции на фондовом рынке подразумевают заключение сделок с акциями и облигациями, обращаемыми на организованных биржевых рынках.

Операции на срочном рынке подразумевают торговлю производными финансовыми инструментами – опционами и фьючерсами, на организованных биржевых рынках.

Для работы на срочном рынке в системе QUIK добавлены две таблицы:

  • Таблица позиций по клиентским счетам, содержащая информацию по финансовым инструментам в распоряжении клиента;
  • Таблица ограничений по клиентским счетам, содержащая информацию по денежным средствам в распоряжении клиента.

Особенности схемы маржинальной торговли с контролем текущей стоимости активов

  1. Введены два понятия:
    • «Список маржинальных инструментов» – список инструментов, с которыми возможно осуществление сделок на заемные средства;
    • «Материальное обеспечение» – стоимость активов клиента (денежных средств и инструментов), служащих обеспечением предоставляемых заемных средств.

    При покупке инструментов, не принимаемых в обеспечение, денежная оценка активов клиента уменьшается на величину данной сделки. Список маржинальных инструментов, а также список инструментов, принимаемых в обеспечение, назначаются брокером.

  2. В соответствии с указанными признаками инструменты разделены на четыре типа. Тип инструмента отображается явно в столбце «Тип инструмента» таблицы «Купить/Продать»:

Тип инструмента | Обозначение | Доступность для покупки | Доступность для продажи | Принимается в обеспечение
Не является маржинальной, не входит в мат. обеспечение | Не указано | На собственные средства | В пределах остатка | Нет
Не является маржинальной, входит в мат. обеспечение | О | На собственные средства | В пределах остатка | Да
Является маржинальной, не входит в мат. обеспечение | М | На собственные средства | Разрешены короткие позиции | Нет
Является маржинальной и входит в мат. обеспечение | МО | Разрешены длинные позиции | Разрешены короткие позиции | Да

В обеспечение не включаются инструменты, у которых отсутствует (либо равно «0») цена закрытия предыдущего торгового дня. Оценка стоимости позиций по таким инструментам в таблице «Купить/Продать» рассчитывается по ценам лучшего спроса/предложения.


Общий способ выполнения транзакций

меню Торговля / Транзакции... или кнопка

С рабочего места пользователя QUIK можно осуществлять различные операции. Окно со списком доступных транзакций открывается одним из следующих способов:

  • Нажать кнопку [image] на панели инструментов;
  • Нажать клавиши «Ctrl»+«T»;
  • Выбрать пункт «Выполнить транзакцию» в пункте меню Действия либо в контекстном меню таблиц Рабочего места QUIK.

В результате открывается окно «Список транзакций», в левой части которого отображены классы, по которым возможно совершение операций, а в правой части – список возможных транзакций по инструментам выбранного класса.

Выбрав класс и операцию, нажмите кнопку «Выполнить» - откроется соответствующий диалог для ввода параметров операции.

Если кнопка [image] неактивна (серая), значит, пользователю недоступны активные операции. О возможных причинах см. п. Сообщения об ошибках.


Ввод заявки

кнопка

Назначение

Формирование и передача на исполнение новой заявки на покупку/продажу инструментов.

Открытие окна «Ввод заявки» осуществляется:

  • Нажатием кнопки [image] на панели инструментов;
  • Двойным нажатием левой кнопки мыши;
  • Нажатием клавиши «F2»;
  • Выбором в таблице пункта контекстного меню «Новая заявка»;
  • Выбором пункта меню Действия;
  • Использованием Общего способа выполнения транзакций с выбором операции «Ввод заявки»;
  • Из окна «Графики». Подробнее см. Ввод заявки из окна «Графики».

Если кнопка [image] на панели инструментов неактивна (серая), значит, ввод заявки по выбранному инструменту невозможен.

Ввод заявки возможен в таблицах: Таблица котировок (очередь заявок), Объединенные котировки, Таблица заявок, Таблица сделок, Таблица обезличенных сделок, Таблица текущих торгов, Карман транзакций.

Если при вводе заявки из таблицы неизвестен инструмент, по которому подается заявка (в таблице нет выделенных строк, или таблица пустая), то на экран выводится форма выбора инструмента для новой заявки:

Для выбора доступны только те классы, по которым у пользователя есть право активных операций и для которых получена соответствующая операции транзакция.

Признак «Только активные инструменты» позволяет исключить из списка инструменты или контракты, не имеющие заявок, сделок или открытых позиций.

При нажатии кнопки «Выбрать» открывается форма ввода заявки по выбранному инструменту.

См. также Управление заявками из Таблицы котировок


Окно «Ввод заявки»

Окно может иметь компактную (слева) или полную (справа) форму. Вид окна переключается нажатием кнопки «>>». Формы оптимизированы для легкого и быстрого ввода параметров и компактного расположения на экране.

Заполнение формы заявки:

  1. «Инструмент» – выбор инструмента из списка инструментов данного класса. Чтобы найти инструмент в списке, наберите с клавиатуры первые буквы его наименования.
  2. «Торговый счет» – код торгового счета, в отношении которого делается поручение.Регистр символов в поле имеет значение. Если за пользователем закреплен один счет, то поле заполняется автоматически. Если доступны несколько счетов, то требуется выбрать нужный счет из списка или воспользоваться настройкой «Указывать счет депо по коду клиента» (см. Настройки ввода заявки ). Отображение в списке возможных значений торговых счетов со статусом «Операции запрещены» включается в основных настройках (см. Параметры торговли). О настройке последовательности счетов в списке см. подробнее Настройка счетов.
  3. «Покупка» / «Продажа» - направление операции.
  4. «Цена» – цена заявки за одну единицу инструмента (либо другой параметр из п. 10).

    При включении признака «Рыночная» значение поля устанавливается равным «0» и недоступно для редактирования. При отключении признака «Рыночная» в поле автоматически подставляется значение цены, указанное в данном поле до включения признака «Рыночная». При смене инструмента запомненное значение сбрасывается.

    Если в рамке «Ввод цены» выбрано значение «По средневзвешенной цене», то поле «Цена» становится неактивным (серым).
  5. «Рыночная» – признак заявки без указания цены исполнения. Такая заявка исполняется на бирже по ценам имеющихся встречных заявок, начиная с лучшей из них.

    Если в рамке «Ввод цены» выбрано значение «По средневзвешенной цене», то признак «Рыночная» неактивен (серый).
  6. «Количество» - количество инструментов, выраженное в лотах. Количество инструментов в одном лоте указано в скобках. При подаче рыночной заявки на покупку на аукцион периода закрытия поле недоступно для заполнения.
  7. «Max» – максимально возможное количество лотов в заявке, рассчитанное из величины доступных средств клиента с учетом всех комиссий. Нажатием на кнопку указанное максимальное значение вводится в поле «Количество». Поле отображается при включенном в настройках флажке «Рассчитывать доступное количество» (см. Настройки ввода заявки). Расчет количества возможен, если необходимые параметры добавлены в список получаемых данных. Параметры, необходимые для расчета, заказываются автоматически при включенном признаке «Исходя из настроек открытых пользователем таблиц» (см. Настройка параметров получения и сохранения данных).
  8. «Код клиента» – идентификатор клиента в системе QUIK.
  9. «Комментарий» – текстовый комментарий к заявке.

Дополнительные параметры:

  1. «Ввод цены»:
    • Выбор значения в поле «Цена»:
      • «По цене» (по умолчанию) – исполнение заявки при наличии в торговой системе встречных заявок с аналогичной ценой исполнения;
      • «По доходности»* – исполнение при наличии встречных заявок с аналогичной доходностью, рассчитанной по цене заявки (для облигаций);
      • «По средневзвешенной цене»* – в качестве цены принимается средневзвешенная цена за текущую торговую сессию.

      Как правило, используется вариант «По цене». Если для данного класса или типа заявки выбор невозможен, варианты становятся неактивными (серыми).

    • Выбор цены исполнения заявки:
      • «По одной цене» – заявка исполняется по одной цене;
      • «По разным ценам» (по умолчанию) – заявка может быть исполнена по разным ценам.
  2. «Объем и комиссия» - оценка заявки в денежном выражении. Позволяет рассчитать «Количество» инструментов в заявке по известной сумме денег. Для этого нужно ввести в поле «Объем» сумму денежных средств и нажать кнопку «Задать кол-во». При этом в поле «Количество» выводится число, полученное в результате пересчета и округленное вниз до ближайшего целого, а в поле «Объем» - денежная оценка заявки при данном «Количестве».

    Объем заявки рассчитывается по формуле:

    • для акций:

      «Объем» = «Цена» * «Количество» * «Размер лота»

      результат округляется в большую сторону с точностью до двух знаков;

    • для облигаций:

      «Объем» = «Количество» * («Цена» * «Номинал» / 100 + «НКД») .

    Сумма комиссии брокера и торговой системы с объема заявки рассчитывается автоматически в соответствии с установленным алгоритмом, выводится в поле справа и отображается в валюте расчетов по инструменту.
  3. «Условие исполнения» определяет порядок обработки остатка заявки при ее частичном исполнении:
    • «Немедленно или отклонить» – заявка исполняется только полностью, т.е. при наличии в торговой системе встречных заявок по цене, не хуже указанной и с количеством инструментов, превышающим объем заявки;
    • «Поставить в очередь» – неисполненный остаток ставится в очередь с ценой, указанной в заявке. Если заявка рыночная, и встречные заявки отсутствуют, то неисполненный остаток снимается с торгов;
    • «Снять остаток» – неисполненный остаток снимается с торгов;
    • «Аукцион периода закрытия» – подача заявки на аукцион периода закрытия.
    • «Только пассивная» – подача заявки с типом «passive only».

(*) Указанные параметры отсутствуют при операциях на срочном рынке Московской Биржи.
  1. При заполнении формы заявки можно перемещаться между полями мышью, либо клавишей «Tab» в одну сторону, или «Shift»+«Tab» в обратную сторону.
  2. Стрелки «вверх» и «вниз» в полях «Цена» и «Количество» служат для изменения значений в этих полях при помощи мыши. Одно нажатие левой кнопкой мыши на стрелке меняет значение на одну минимальную величину шага, а при нажатой клавише «Ctrl» - на 10.
  3. Поля «Количество», «Код клиента», «Комментарий» могут быть заполнены автоматически. Подробнее см. Настройка автозаполнения полей ввода заявки.
  4. При заполнении формы ввода заявки в поле «Цена» (для стоп-заявок «Цена», «Стоп-цена», «Отступ от min/max», «Защитный спред») для классов рынка LSE используется параметр «Реальный шаг цены» вместо параметра «Минимальный шаг цены» в том случае, когда значение параметра «Реальный шаг цены» больше значения параметра «Минимальный шаг цены».

После нажатия на кнопку «Да»/«Отправить» форма ввода заявки закрывается только при успешном выставлении заявки. В случае получения сообщения об ошибке форма ввода заявки остается открытой с возможностью изменения неверно введенных значений.

См. также Доступные функции


Доступные функции

Управление с помощью клавиатуры:

  • «PageUp», «PageDown» - увеличить/уменьшить количество лотов на величину кратности лота;
  • «Ctrl»+«PageUp», «Ctrl»+«PageDown» - увеличить/уменьшить количество лотов на величину, в 10 раз превышающую кратность лота;
  • «+», «-» (на цифровом блоке клавиатуры) - увеличить/уменьшить цену на 1 минимальный шаг цены (пипс);
  • «Ctrl»+«+»,«Ctrl»+«-» - увеличить/уменьшить цену на 10 минимальных шагов цены (пипсов);
  • <пробел> - изменить направление заявки на обратное (включается настройками в меню Система/Настройки/Основные настройки..., раздел «Торговля» / «Заявки», флажок «Смена операции клавишей «Пробел»);
  • «Enter» - отправить заявку, «Esc» - отменить ввод новой заявки.


Быстрый ввод заявки

Быстрый ввод заявки в системе QUIK заключается:

  • в интуитивно понятном способе открытия окна из таблицы (двойное нажатие левой кнопки мыши);
  • в заполнении части полей значениями по умолчанию, или подстановки величин из выделенной строки таблицы;
  • в автоматическом позиционировании курсора на поле «Количество»;
  • в возможности быстрого изменения основных параметров заявки (направление операции, цена, количество) и ее последующего ввода или подтверждения с помощью клавиш;
  • в возможности ввода/снятия заявок в Таблице котировок ;
  • в использовании режима «Быстрый ввод заявки» в Таблице котировок .

При открытии окна «Ввод заявки» часть полей заполняется значениями по умолчанию:

Поле | Значение
Торговый счет | Первое значение из списка доступных счетов (меню Система/Настройки/Основные настройки..., раздел «Торговля»/«Настройка счетов»)
Клиент | Значение, установленное по умолчанию (меню Система/Настройки/Основные настройки..., раздел «Торговля»)
Количество лотов | Значение, установленное по умолчанию (меню Система/Настройки/Основные настройки..., раздел «Торговля»). Если количество лотов по умолчанию задано, то это значение отображается во всех вариантах ввода заявки

При вводе заявки из таблицы поля дополнительно заполняются по следующим правилам:

Таблица | Заполняемые поля
Таблица котировок
  • «Инструмент» – соответствует наименованию инструмента «Таблицы котировок»;
  • «Цена», «Количество» – равны цене и количеству инструментов в выделенной котировке. При вводе заявки из Таблицы котировок, Количество может принимать значения параметров «Объем» либо «Сумма лучших» (см. Настройки ввода заявки, параметр «Установка количества лотов транзакции»);
  • «Направление операции» – встречное по отношению к выделенной заявке, либо такое же (устанавливается настройками)
Таблица заявок | Значения всех параметров соответствуют значениям параметров выделенной заявки (сделки)
Таблица сделок
Таблица обезличенных сделок
Карман транзакций
Таблица текущих торгов | «Инструмент» - соответствует наименованию инструмента в выделенной строке


Окно ввода заявок для классов Срочного рынка Московской Биржи

Окно в зависимости от настроек может иметь компактную (слева) или полную (справа) форму. Вид окна переключается нажатием кнопки «>>». Формы оптимизированы для легкого и быстрого ввода параметров и компактного расположения на экране.

Заполнение формы заявки:

  1. «Инструмент» – выбор инструмента из списка инструментов данного класса. Чтобы найти инструмент в списке, наберите с клавиатуры первые буквы его наименования.
  2. «Торговый счет» – код торгового счета, в отношении которого делается поручение.Регистр символов в поле имеет значение. Если за пользователем закреплен один счет, то поле заполняется автоматически. Если доступны несколько счетов, то требуется выбрать нужный счет из списка или воспользоваться настройкой «Указывать счет депо по коду клиента» (см. Настройки ввода заявки). О настройке последовательности счетов в списке см. подробнее Настройка счетов.
  3. «Покупка» / «Продажа» - направление операции .
  4. «Цена» – цена заявки за одну единицу инструмента.
    При выставлении заявки с признаком «Рыночная» требуется указать такую цену, не хуже которой должны исполняться заявки (полностью либо частично).
    При включении признака «Рыночная» в пустое поле «Цена» подставляется значение «Максимально возможная цена», а при подаче заявки на продажу – «Минимально возможная цена» для данного инструмента (значение берется из Таблицы текущих торгов).
    При включении признака «Рыночная» значение поля устанавливается равным «0» и недоступно для редактирования. При отключении признака «Рыночная» в поле подставляется значение цены, указанное до включения признака «Рыночная». При смене инструмента и отключении признака «Рыночная» значение цены не восстанавливается.
  5. «Рыночная» – при установленном признаке и при наличии встречного предложения заявка исполняется по цене не хуже, чем значение, указанное в поле «Цена». Неисполненный остаток, на который отсутствует встречное предложение, снимается с торгов.
  6. «Кол-во (лот)» - количество инструментов, выраженное в лотах. Количество инструментов в одном лоте указано в скобках. При редактировании поля с помощью стрелок вверх/вниз или колесика мыши значение увеличивается или уменьшается на величину значения параметра «Кратность лота» и округляется до значения, кратного параметру «Кратность лота». Для изменения количества лотов на величину, в 10 раз превышающую кратность лота, используйте стрелки вверх/вниз с нажатой клавишей Ctrl.
  7. «Max» – максимальное возможное количество лотов в заявке, рассчитанное из величины доступных средств клиента с учетом всех комиссий. Нажатием на кнопку указанное максимальное значение вводится в поле «Количество». Поле отображается при включенном в настройках флажке «Рассчитывать доступное количество» (см. Настройки ввода заявки).
    Значение поля не рассчитывается, если значение в поле «Цена» больше максимально возможной или меньше минимально возможной цены.
  8. «Код клиента» – идентификатор клиента в системе QUIK.
  9. «Комментарий» – текстовый комментарий к заявке.

Дополнительные параметры:

  1. «Условие исполнения» определяет порядок обработки остатка заявки при ее частичном исполнении:
    • «Немедленно или отклонить» – заявка исполняется только полностью, т.е. при наличии в торговой системе встречных заявок по цене, не хуже указанной и с количеством инструментов, превышающим объем заявки;
    • «Поставить в очередь» (по умолчанию) – неисполненный остаток ставится в очередь с ценой, указанной в заявке. Если заявка рыночная, и встречные заявки отсутствуют, то неисполненный остаток снимается с торгов;
    • «Снять остаток» – неисполненный остаток снимается с торгов.
  2. «Переносить заявку» – признак выставления заявки с условием исполнения до даты, указанной пользователем.
    При установленном признаке поле для выбора даты экспирации заявки становится доступным для редактирования.
  3. «Объем» - оценка заявки в денежном выражении. Позволяет рассчитать «Количество» инструментов в заявке по известной сумме денег. Для этого нужно ввести в поле «Объем» сумму денежных средств и нажать кнопку «Задать кол-во». При этом в поле «Количество» выводится число, полученное в результате пересчета и округленное вниз до ближайшего целого, а в поле «Объем» - денежная оценка заявки при данном «Количестве».

    Объем заявки рассчитывается по формуле:

    «Объем» = «Количество» * «Стоимость шага цены» * («Цена» / «Размер шага цены»)
  4. «Объем ГО» – совокупный размер ГО, который блокируется по заявке исходя из количества контрактов и настроек брокера.
  5. «Проверять диапазон цен» – если флажок включен, то цена заявки проверяется торговой системой на соответствие диапазону допустимых значений цены по этому инструменту. Доступно только для класса «Опционы FORTS».

  1. При заполнении формы заявки можно перемещаться между полями мышью, либо клавишей «Tab» в одну сторону, или «Shift»+«Tab» в обратную сторону.
  2. Стрелки «вверх» и «вниз» в полях «Цена» и «Количество» служат для изменения значений в этих полях при помощи мыши. Одно нажатие левой кнопкой мыши на стрелке меняет значение на одну минимальную величину шага, а при нажатой клавише «Ctrl» - на 10.
  3. Поля «Количество», «Код клиента», «Комментарий» могут быть заполнены автоматически. Подробнее см. Настройка автозаполнения полей ввода заявки.

См. также п. Доступные функции


Окно ввода заявки для классов НРД

Заполнение формы заявки:

  1. «Инструмент» – выбор инструмента из списка инструментов данного класса. Чтобы найти инструмент в списке, наберите с клавиатуры первые буквы его наименования.
  2. Направление операции:
    • «Купить на сумму» – объем средств для покупки. В параметре «Максимум» отображается максимальная сумма для выбранного инструмента;
    • «Продать количество» – количество инструмента, выраженное в лотах, для продажи;
    • «Обменять количество» – количество инструмента, выраженное в лотах, для обмена на другой инструмент, указываемый в поле «на».
  3. «Максимум» – максимально возможный объем денежных средств для покупки / максимальное количество лотов в заявке, рассчитанное из величины доступных средств клиента с учетом всех комиссий (в зависимости от выбранного направления операции). Нажатием на кнопку рядом с параметром «Купить на сумму» / «Продать количество» / «Обменять количество» указанное максимальное значение вводится в поле.
  4. «Комиссия» – сумма брокерской комиссии с объема заявки. Рассчитывается автоматически в соответствии с установленным алгоритмом и выводится в поле справа.
  5. «Торговый счет» – код торгового счета, в отношении которого делается поручение. Регистр символов в поле имеет значение. Если за пользователем закреплен один счет, то поле заполняется автоматически. Если доступны несколько счетов, то требуется выбрать нужный счет из списка. О настройке последовательности счетов в списке см. подробнее в «Настройка счетов».
  6. «Код клиента» – идентификатор клиента в системе QUIK.
  7. «Комментарий» – текстовый комментарий к заявке.
    1. При заполнении формы заявки можно перемещаться между полями мышью, либо клавишей «Tab» в одну сторону, или «Shift»+«Tab» в обратную сторону.
    2. Стрелки «вверх» и «вниз» в полях «Цена» и «Количество» служат для изменения значений в этих полях при помощи мыши. Одно нажатие левой кнопкой мыши на стрелке меняет значение на одну минимальную величину шага, а при нажатой клавише «Ctrl» – на 10.
    3. Поля «Количество», «Код клиента», «Комментарий» могут быть заполнены автоматически. Подробнее см. Настройка автозаполнения полей ввода заявки.

При некорректном значении цены или количества на форме ввода заявки на экране отображается диалог с описанием ошибки.

См. также п. Доступные функции


Ввод заявки из Таблицы котировок

Ввод заявки из Таблицы котировок осуществляется одним из следующих способов:

  • Двойное нажатие левой кнопкой мыши на требуемом значении в поле таблицы.
  • Выбор пункта «Новая заявка» в контекстном меню таблицы.
  • Выбор пункта меню Действия / «Новая заявка».
  • Использование панели инструментов Таблицы котировок:

Подробнее о вводе заявок из Таблицы котировок см. Управление заявками из Таблицы котировок.


Ввод заявки из окна «Объединенные котировки»

Ввод заявки из окна «Объединенные котировки» осуществляется двойным нажатием левой кнопки мыши на значении цены.

Поведение системы QUIK при вводе заявки определяется признаком «Разделение объема заявки» в пункте меню программы Система/Настройки/Основные настройки…, раздел «Торговля» / «Котировки» / «Объединенные котировки»:

  1. Если признак отключен, то открывается окно ввода заявки с параметрами, как в выбранной строке.
  2. Если признак включен, то при вводе заявки системой QUIK выполняется разделение указанного в ней объема на несколько отдельных заявок по классам и инструментам, указанным в «Объединенных котировках», начиная от лучшей цены, до цены, выбранной пользователем. В этом случае в окне ввода «Объединенной заявки» можно указать только цену заявки и количество инструментов (в штуках) или объем (в денежных средствах), остальные параметры берутся системой из значений «Объединенных котировок».

    Поле «Объем (в ден. средствах)» доступно в окне ввода «Объединенной заявки» только при подаче заявки по классам РЕПО с ЦК. Объем и количество не могут быть заданы одновременно.

  3. Заявка отправляется с условием исполнения «Снять остаток», если признак «Снимать остаток» в пункте меню программы Система / Настройки / Основные настройки…, раздел «Торговля» / «Котировки» / «Объединенные котировки» включен, иначе – с условием исполнения «Поставить в очередь».

Подробнее о свойствах таблицы «Объединенные котировки».


Ввод заявки типа «Айсберг»

В некоторых торговых системах и режимах торгов поддерживаются транзакции типа «Айсберг». Заявки данного типа имеют дополнительное поле «Видимое кол-во». В поле «Кол-во» указывается количество инструментов в заявке, подлежащее реализации. В поле «Видимое кол-во» указывается количество инструментов (выраженное в лотах), отображаемое в торговой системе, например, в очереди заявок.

Окно ввода айсберг-заявки можно вызвать одним из способов:

  • Выбором операции «Ввод айсберг заявки», используя Общий способ выполнения транзакций;
  • Выбором пункта контекстного меню «Новая Айсберг заявка» в Таблице текущих торгов, Таблице котировок, Таблице заявок, Таблице сделок, Таблице обезличенных сделок или «Купить/продать».


Специализированное окно ввода заявок по облигациям

При использовании интерфейсов, транслирующих расширенную информацию по облигациям, и включенном режиме ввода «Специализированный» форма ввода заявки имеет следующий вид:

Если при включенном режиме ввода «Специализированный» отображается окно классического вида, то для выбранного режима торгов с облигациями «Специализированная» форма ввода не поддерживается.

Данная форма ввода заявки имеет следующие дополнительные поля:

  1. «Доходность» – доходность инструмента, соответствующая указанному значению цены. В данном поле может быть введено целевое значение доходности. При этом для расчета соответствующего значения цены нажмите на кнопку «Задать цену». При включении признака «Рыночная» значение поля устанавливается равным «0».
  2. «Объем» – значение объема заявки с учетом НКД, соответствующее указанному значению количества. В данном поле может быть введено целевое значение объема. При этом для расчета соответствующего значения количества нажмите на кнопку «Задать кол-во». В результате в поле «Лотов» отображается рассчитанное число, округленное вниз до ближайшего целого.

    Ниже отображается значение НКД на дату торгов и комиссии в валюте инструмента. Значение НКД отображается с учётом количества лотов в заявке.


Специализированное окно ввода заявок

При использовании интерфейсов, транслирующих определенный признак на инструментах, и включенном режиме ввода «Специализированный» форма ввода заявки имеет следующий вид:

Если при включенном режиме ввода «Специализированный» отображается окно классического вида, то для выбранного режима торгов «Специализированная» форма ввода не поддерживается.

Данная форма ввода заявки имеет следующие дополнительные поля:

  1. «Исп. остатка» – определяет порядок обработки остатка заявки при ее частичном исполнении:
    • «Поставить в очередь» (по умолчанию) – неисполненный остаток ставится в очередь с ценой, указанной в заявке. Если заявка рыночная, и встречные заявки отсутствуют, то неисполненный остаток снимается с торгов;
    • «AON» — все или ничего, заявка исполняется полностью или снимается с торгов.


Ввод заявки экспирации опционов

Окно ввода заявки на экспирацию опционов можно вызвать, используя Общий способ выполнения транзакций.

Заявки данного типа имеют следующие поля:

  1. «Инструмент» — выбор инструмента из списка инструментов данного класса.
  2. «Торговый счёт» — код торгового счета, в отношении которого происходит ввод заявки.
  3. *«Текущая позиция» — позиция клиента по выбранному инструменту на момент выставления заявки, в лотах.
  4. «Кол-во» — количество лотов для досрочного исполнения.
  5. *«Базовый актив» — идентификатор инструмента в торговой системе, соответствующий базовому активу контракта.
  6. *«Дата экспирации» — дата экспирации опциона.
  7. *«Цена страйк» — цена исполнения опциона (цена поставки базового актива), в пунктах.
  8. *«Тип опциона» — тип опциона, PUT или CALL.
(*) Информационное поле, недоступно для редактирования.


Ввод заявки экспирации фьючерсов

Окно ввода заявки на экспирацию фьючерсов можно вызвать, используя Общий способ выполнения транзакций.

Заявки данного типа имеют следующие поля:

  1. «Инструмент» — выбор инструмента из списка инструментов данного класса.
  2. «Торговый счёт» — код торгового счета, в отношении которого происходит ввод заявки.
  3. *«Текущая позиция» — позиция клиента по выбранному инструменту на момент выставления заявки, в лотах.
  4. «Кол-во» — количество лотов для досрочного исполнения.
  5. *«Базовый актив» — идентификатор инструмента в торговой системе, соответствующий базовому активу контракта.
  6. *«Дата экспирации» — дата экспирации фьючерса.
(*) Информационное поле, недоступно для редактирования.


Ввод заявки на аукцион по обмену государственных облигаций

При работе с торговыми системами, транслирующими инструменты с подтипом «Спреды на облигации», форма ввода заявки имеет следующий вид:

Заявки данного типа имеют следующие поля:

  1. «Инструмент» — выбор инструмента из списка инструментов данного класса.
  2. «Размещаемая облигация» – облигация, размещаемая эмитентом.
  3. <«Выкупаемая облигация» – облигация, выкупаемая эмитентом.
  4. «Цена, %» – цена от номинала размещаемой/выкупаемой облигации, в процентах.
  5. «Доходность» – эффективная доходность к погашению, соответствующая указанному значению цены размещаемой/выкупаемой облигации. Доступен расчет доходности из цены и расчет цены из доходности.
  6. «Лотов» – количество размещаемой облигации, в лотах.
  7. «Лотов к выкупу» – количество выкупаемой облигации, в лотах.
  8. «Торговый счет» – код торгового счета, в отношении которого делается поручение. Регистр символов в поле имеет значение. Если за пользователем закреплен один счет, то поле заполняется автоматически. Если доступны несколько счетов, то требуется выбрать нужный счет из списка. Подробнее о настройке последовательности счетов в списке см. «Настройка счетов».
  9. «Цена аукциона» – цена аукциона от номинала размещаемой облигации, рассчитанная для указанных значений цен размещаемой и выкупаемой облигаций, в процентах.
  10. «Расчетный объем» – расчетный объем аукциона.
  11. «Нетто объем» – разница между объемом размещаемой облигации и объемом выкупаемой облигации.
  12. «Код клиента» – идентификатор клиента в системе QUIK.
  13. «Комментарий» – текстовый комментарий к заявке.


Подтверждение заявки

Операция ввода заявки завершается нажатием кнопки «Да» / «Отправить». На экране появится сообщение следующего вида:

Также для заявок по инструментам с неточными параметрами при включенной настройке «Запрашивать подтверждение» запрашивается подтверждение неточных параметров заявки.

Подтверждение необходимо для проверки заявки пользователем на отсутствие в ней ошибок. Нажмите «ОК» для отправки заявки на исполнение, «Отмена» - для возврата в окно ввода заявки. Принятая к исполнению заявка отображается в Таблице заявок.

Подтверждение заявки может быть отключено в пункте меню Система/Настройки/Основные настройки..., раздел «Торговля»/«Заявки».

См. также Доступные функции


Снятие заявки

кнопка

Операция снятия доступна для заявок со статусом «Активна». Заявки со статусом «Исполнена» снять невозможно. Если заявка исполнена частично, то снимается только неудовлетворенный остаток.

Операция снятия заявки выполняется одним из следующих способов:

  1. Выбором операции «Снятие заявки по номеру», используя Общий способ выполнения транзакций. В открывшемся окне введите номер снимаемой заявки (указан в поле «Номер» Таблицы заявок).
  2. В «Таблице заявок»:
    • Двойным нажатием правой кнопки мыши на снимаемой заявке;
    • Нажатием клавиш «Ctrl»+«D»;
    • Нажатием кнопки [image] на панели инструментов;
    • Выбором пункта контекстного меню «Снять заявку»;
    • Выбором пункта меню Действия/Снять заявку.
  3. В окне графика, захватив курсором линию заявки и переместив ее за пределы текущей области построения графиков. Подробнее см. Управление заявками с помощью курсора мыши.
  4. В Таблице котировок:
    • Использованием специальной панели инструментов;
    • Перетаскиванием строки с заявкой мышью за границы окна.

Снятие заявки сопровождается запросом подтверждения на выполнение операции, с указанием номера заявки и наименования инструмента. Результат снятия заявки в торговой системе отображается изменением ее состояния в Таблице заявок на «Снята», а также сообщением в окне сообщений «Снято заявок <число>, невозможно снять <число>».

См. также:

  • Управление заявками из Таблицы котировок
  • Снятие заявок по условию


Замена заявки

кнопка

Если в основных настройках установлен признак «Заменять заявки путем изменения их параметров» (пункт меню Система / Настройки / Основные настройки…, раздел «Торговля» / «Заявки» / «Замена заявок» / «Команды меню»), то при замене заявки выполняется поиск соответствующей транзакции с последующим открытием формы ввода заявки, на которой для редактирования доступны только те поля, которые присутствуют в найденной транзакции.

Если признак «Заменять заявки путем изменения их параметров» в основных настройках отключен, то замена заявки производится снятием заявки из торговой системы и последующим вводом новой, с измененными условиями. Снятие заявки необходимо для того, чтобы редактируемая заявка не могла исполниться в течение того интервала времени, пока производится изменение ее условий.

Операция замены заявки выполняется одним из следующих способов:

  • В Таблице заявок:

    • Нажатием клавиш «Ctrl»+«А»;
    • Нажатием кнопки [image] на панели инструментов;
    • Выбором пункта контекстного меню «Заменить заявку»;
    • Выбором пункта контекстного меню «Изменить параметры заявки»;
    • Выбором пункта меню Действия/Заменить заявку;
    • Выбором пункта меню Действия/Изменить параметры заявки.
  • В окне графика, перемещая горизонтальную линию, соответствующую уровню цены активной заявки.
  • В Таблице котировок:
    • Нажатием на кнопку [image] на панели инструментов, выбрав строку с нужной заявкой;
    • Перетаскиванием мышью строки с заявкой пользователя в Таблице котировок.

Также изменить условия заявки можно следующим образом:

Снять активную заявку в Таблице заявок двойным нажатием правой кнопки мыши на строке, затем двойным нажатием левой кнопки мыши на той же строке вызвать окно «Ввод заявки» с параметрами снятой заявки. Изменить нужный параметр и отправить заявку на исполнение.

Если при редактировании условий заявки изменяется поле «Код клиента», то соответствующий ему код торгового счета может быть выбран автоматически. Подробнее см. Настройки ввода заявки, параметр «Указывать счет депо по коду клиента».

См. также Управление заявками из Таблицы котировок


Условные (стоп-) заявки

кнопка
  • Назначение
  • Типы условных заявок в системе QUIK
  • Уведомление о рисках

    • Назначение

    Формирование и передача на исполнение новой заявки с дополнительными условиями, контроль которых осуществляет сервер системы QUIK.

    Условная заявка (стоп-заявка) – заранее подготовленная лимитированная заявка, передаваемая в торговую систему биржи при наступлении условия (стоп-цены). Стоп-заявка используется для ограничения величины убытков при изменении цен сделок в сторону, противоположную ожидаемой.

    Стоп-цена – условие исполнения заявки в виде граничного значения цены последней сделки по инструменту.

    Типы условных заявок в системе QUIK

    В системе QUIK существуют следующие типы условных заявок:

    1. «Стоп-лимит» - стоп-заявка, порождающая при исполнении лимитированную заявку.

      НАЗНАЧЕНИЕ: Ограничение величины убытков при изменении цен сделок в сторону, противоположную ожидаемой.
    2. «Стоп-цена по другому инструменту» - заявка типа «Стоп-лимит», условие стоп-цены которой проверяется по одному инструменту, а в исполняемой лимитированной заявке указывается другой инструмент.

      НАЗНАЧЕНИЕ: Используется в специфических торговых стратегиях, например, когда условием стоп-заявки по срочному контракту является цена базового актива.
    3. «Со связанной заявкой» – две заявки по одному и тому же инструменту, одинаковые по направленности и объему. Первая заявка типа «Стоп-лимит», вторая – лимитированная заявка. При исполнении одной из заявок вторая снимается. Этот тип поручений также называют «O.C.O.» (one cancel other, «одна заявка отменяет другую»).

      НАЗНАЧЕНИЕ: Данный тип заявки предназначен для закрытия позиции. Стоп-заявка используется для фиксации убытков, а лимитированная заявка – для фиксирования прибыли. Преимуществом связанной заявки является то, что для исполнения лимитированной и стоп-заявки лимиты блокируются однократно, и при закрытии позиции в одну сторону связанная с ней заявка автоматически снимается.

      1. При исполнении стоп-заявки, связанная лимитированная заявка снимается полностью.
      2. Данный тип заявки действителен только до конца текущей торговой сессии. На срочном рынке Московской Биржи cтоп-заявка действительна также до конца текущей торговой сессии, а связанная с ней лимитированная заявка, выставленная в вечернюю сессию, остается в торговой системе срочного рынка Московской Биржи и может быть исполнена на следующий торговый день.
      3. При частичном исполнении связанной заявки стоп-заявка может либо (а) сниматься полностью, либо (б) уменьшаться на величину исполненной части связанной заявки, в зависимости от выбранных условий в заявке.
    4. «Тейк-профит» – это заявка с условием вида «исполнить при ухудшении цены на заданную величину от достигнутого максимума (на продажу) или минимума (на покупку)». Заявка работает следующим образом (пример для заявки на продажу): после достижения ценой последней сделки условия стоп-цены начинается определение максимума цены последней сделки. Если цена последней сделки снижается от максимума на величину, превышающую установленный «отступ», то создается лимитированная заявка с ценой, меньшей цены последней сделки на величину «защитного спреда». Величины «отступа» и «защитного спреда» могут указываться как в значениях цены, так и в процентах.

      Для заявки на покупку в качестве цены лимитированной заявки выбирается минимальное между следующими значениями:

      <Цена последней сделки> + <спред > и

      <Цена стоп-заявки> + <отступ> + <спред >

      НАЗНАЧЕНИЕ: Закрытие позиции по инструменту с максимальной прибылью.
    5. «Тейк-профит и стоп-лимит» - это заявка, имеющая два условия:
      • «тейк-профит», если цена последней сделки после достигнутого максимума ухудшится на величину, превышающую установленный «отступ»;
      • «стоп-лимит», если цена последней сделки ухудшится до указанного уровня.

      В случае срабатывания одного из условий прекращается проверка второго условия стоп-заявки. Одно из условий заявки можно не указывать. Если одновременно удовлетворены оба условия заявки, то заявка исполнится по условию «тейк-профит».

      НАЗНАЧЕНИЕ: Фиксация максимальной прибыли с одновременным ограничением величины убытков.

    Уведомление о рисках

    Контроль условий и исполнение стоп-заявки осуществляется сервером системы QUIK, находящимся вне торговой системы биржи. В связи с этим вероятна ситуация, при которой при наступлении условий стоп-заявки ее исполнение невозможно по техническим причинам, например, в случае сбоя в канале связи либо шлюзе между сервером QUIK и торговой системой биржи. Использование стоп-заявок также может создавать дополнительные риски, поскольку в данной ситуации подача поручений на выставление биржевых заявок, по которым могут заключаться сделки и изменяться позиция трейдера, происходит автоматически, без непосредственного участия трейдера.

    Трейдеру необходимо понимать, что соответствие между фактическим и ожидаемым результатом работы стоп-заявки в системе QUIK с тем или иным условием зависит не только от того, насколько верно было спрогнозировано развитие торгов, но и от понимания того, как работает выбранное условие стоп-заявки. Стоп-заявки в системе QUIK могут отличаться от функционала в других информационно-торговых системах и платформах.

    В связи с этим брокерам рекомендуется заключать с клиентами - пользователями системы QUIK дополнительное соглашение, уведомляющее о рисках и возлагающее на пользователя всю ответственность за последствия исполнения стоп-заявки либо ее неисполнения по каким-либо причинам.

    В случае истечения срока действующих доверенностей, или блокировки прав доступа пользователя к системе, дальнейшее хранение и исполнение стоп-заявок зависит от настроек сервера QUIK у брокера.

    См. также:

    • Заявки с условием «по исполнению»
    • Контроль условий стоп-заявки в системе QUIK
    • Создание условной (стоп-) заявки
    • Снятие и замена условной (стоп-) заявки
    • Принудительное исполнение условной заявки


Контроль условий стоп-заявки в системе QUIK

  1. При принятии условной заявки, система:
    • присваивает ей уникальный идентификационный номер;
    • осуществляет процедуру контроля лимитов, если заявка подана с указанием кода клиента;
    • блокирует количество инструментов или сумму средств, необходимую для выставления соответствующей лимитированной заявки в торговой системе биржи;
    • начинает проверку условия исполнения.

    Средства для исполнения стоп-заявки блокируются только в день принятия заявки. При переносе неисполненной стоп-заявки на следующий день блокировка средств зависит от настроек сервера системы QUIK.
  2. Стоп-заявка считается активной до момента наступления одного из следующих событий:
    • снятие заявки пользователем;
    • исполнение заявки системой QUIK;
    • истечение срока действия заявки.
  3. При исполнении стоп-заявки сервер QUIK производит следующие действия:
    • прекращает проверку условия исполнения стоп-заявки;
    • разблокирует средства, заблокированные при вводе стоп-заявки;
    • отправляет в торговую систему соответствующую лимитированную заявку и блокирует средства под ее исполнение в случае регистрации заявки в торговой системе;
    • присваивает стоп-заявке статус «Исполнена» и добавляет в описание стоп-заявки параметры:
      • «Номер заявки», соответствующий номеру, присвоенному лимитированной заявке торговой системой биржи;
      • «Сделка условия» - номер сделки (в Таблице обезличенных сделок), цена которой стала основанием для исполнения данной стоп-заявки;
      • «Результат» - результат обработки лимитированной заявки, порожденной при исполнении стоп-заявки.

    Если заявка отклонена торговой системой, то она имеет статус «Исполнена», т.к. условие стоп-заявки наступило, но в поле «Номер заявки» будет указан «0» (ноль).

Подтверждением факта выполнения условий исполненной стоп-заявки на покупку (продажу) является наличие в протоколе обезличенных сделок торговой системы биржи хотя бы одной сделки по соответствующему инструменту, совершенной в период действия стоп-заявки по цене, равной или большей (равной или меньшей) стоп-цены заявки.

См. также:

  • Условные (стоп-) заявки
  • Создание условной (стоп-) заявки
  • Снятие и замена условной (стоп-) заявки
  • Принудительное исполнение условной заявки


Создание условной (стоп-) заявки

Ввод стоп-заявки возможен в таблицах:

  • Таблица котировок (очередь заявок);
  • Таблица заявок;
  • Таблица стоп-заявок;
  • Таблица сделок;
  • Таблица обезличенных сделок;
  • Таблица текущих значений параметров;
  • Карман транзакций.

Если кнопка [image] на панели инструментов неактивна (серая), значит ввод заявки невозможен.

Открытие окна «Стоп-заявка» осуществляется одним из следующих способов:

  • Нажатием кнопки [image] на панели инструментов;
  • Двойным нажатием левой кнопки мыши в Таблице стоп-заявок;
  • Нажатием клавиши «F6»;
  • Выбором в таблице пункта контекстного меню «Новая стоп-заявка»;
  • Выбором пункта меню Действия/Новая стоп-заявка;
  • Использованием Общего способа выполнения транзакций с выбором операции «Стоп-заявка».

См. также:

  • Условные (стоп-) заявки
  • Контроль условий стоп-заявки в системе QUIK
  • Снятие и замена условной (стоп-) заявки
  • Принудительное исполнение условной заявки


Заполнение полей в окне "Стоп-заявка"

С помощью формы ввода стоп-заявки можно формировать условные заявки разных типов. Дополнительные условия заявки отображаются в расширенной форме, вызываемой нажатием кнопки "Больше >>" или выбором типа условной заявки, для которой предназначены эти дополнительные условия.

Заполнение формы заявки:

  1. «Тип стоп-заявки» – выбор одного из возможных типов поручения. Делает доступным особые поля, относящиеся к определенному типу стоп-заявки. При необходимости окно ввода заявки принимает расширенную форму.
  2. «Срок действия»:
    • «сегодня» – поручение действительно пока дата торговой сессии не станет больше текущей даты;
    • «по …» – поручение действительно пока дата торговой сессии не станет больше указанной даты;
    • «до отмены» – поручение действительно, пока не отменено.

    Стоп-заявки «Со связанной заявкой» действительны только в течение текущей торговой сессии.
  3. «Время действия заявки» - период времени, в течение которого проверяются условия стоп-заявки. Параметр поручений типа «Тейк-профит и стоп-лимит». Если флажок отключен, то параметр не используется. При включенном флажке необходимо указать в поле «с…» - время начала действия стоп-заявки, а в поле «до…» - время окончания.

    1. Параметр «Время действия заявки» определяет только интервал времени, в течение которого проверяется условие активации стоп-заявки. Если заявка активировалась, то проверка времени действия прекращается. Например, если для заявки типа «Тейк-профит и стоп-лимит» цена пробила уровень тейк-профит (заявка сработала, начался расчет минимума/максимума цены), но заявка не исполнилась до окончания заданного интервала времени внутри дня, то расчет максимума/минимума цены не прекращается по истечении заданного периода времени.
    2. Если значения времени «С…» и «До…» совпадают, или значение «С…» больше значения «До…», то считается, что задан интервал с указанного времени текущего дня, до аналогичного времени следующего дня. Если значение «До…» строго больше времени «С…», то время действия проверяется в течение текущего дня.
    3. При включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» значение параметра «Время действия заявки» указывается с учетом временной зоны компьютера, на котором запущен терминал QUIK.
  4. «Инструмент» – выбор инструмента из списка инструментов данного класса. Чтобы найти инструмент в списке, наберите с клавиатуры первые буквы его наименования.
  5. «Торговый счет» – код торгового счета, в отношении которого делается поручение. Регистр символов в поле имеет значение. Если за пользователем закреплен один счет, то поле заполняется автоматически. Если доступны несколько счетов, то требуется выбрать нужный счет из списка или воспользоваться настройкой «Указывать счет депо по коду клиента» (см. Настройки ввода заявки). Отображение в списке возможных значений торговых счетов со статусом «Операции запрещены» можно включить в основных настройках (см. Параметры торговли). О настройке последовательности счетов в списке см. Настройка счетов.
  6. «Условие активации заявки» - настройка условий активации заявки:
    • «Покупка» / «Продажа»«Операция» – выбор направления заявки.
    • Выбор контролируемого условия стоп-цены по отношению к цене последней сделки по инструменту:
        1. Для заявок типа «Стоп-цена по другому инструменту» условие имеет вид: «Если цена <=» ( или «>=») и означает исполнение заявки, если цена последней сделки по другому инструменту пересечет указанное значение;
        2. Для заявок типов «Стоп-лимит», «Со связанной заявкой» условие имеет вид «стоп-лимит, если цена <= » (или «>=») и означает выставление лимитированной заявки в случае, если цена последней сделки пересекла указанное значение;
        3. Для заявок типа «Тейк-профит» условие имеет вид «тейк-профит, если цена <=» ( или «>=») и означает начало расчета минимума (максимума) цены последней сделки, если она пересекла указанное значение;
        4. Для заявок типа «Тейк-профит и стоп-лимит» доступны условия 2) и 3), причем любое из них может не заполняться.

    Значение стоп-цены указывается в окне справа от выбора условия.

  7. «Цена» – цена лимитированной заявки, выставляемой в торговую систему при наступлении условия «Стоп-лимит», за одну единицу финансового инструмента.

    При включении признака «По рыночной цене» значение поля устанавливается в «0» и недоступно для редактирования. При отключении признака «По рыночной цене» в поле автоматически подставляется значение цены, указанное в данном поле до включения признака «По рыночной цене». При смене инструмента и отключении признака «По рыночной цене» значение цены не восстанавливается.
  8. «По рыночной цене» - признак исполнения стоп-заявки по рыночной цене. Параметр заявок типа «Тейк-профит и стоп-лимит».

    В некоторых режимах торгов использование рыночных заявок не предусмотрено.
  9. «Кол-во (лот …)» – количество инструментов, выраженное в лотах. В скобках указано количество единиц выбранного инструмента бумаг в одном лоте. При редактировании поля с помощью стрелок вверх/вниз или колесика мыши значение увеличивается или уменьшается на величину значения параметра «Кратность лота» и округляется до значения, кратного параметру «Кратность лота». Для изменения количества лотов на величину, в 10 раз превышающую кратность лота, используйте стрелки вверх/вниз с нажатой клавишей Ctrl.
  10. «max» – максимальное возможное количество лотов в стоп-заявке, рассчитанное из величины доступных средств клиента с учетом всех комиссий. Нажатием на кнопку указанное максимальное значение вводится в поле «Кол-во». Поле отображается при включенном в настройках флажке «Рассчитывать доступное количество».
  11. «Код Клиента» – идентификатор клиента в системе QUIK.
  12. «Комментарий» – текстовый комментарий к заявке.
  13. «Брать стоп-цену для инструмента» - наименование и класс инструмента, по которому осуществляется контроль условия стоп-цены. Параметр поручения типа «Стоп-цена по другому инструменту».
  14. «Выставить связанную заявку на покупку (продажу) по цене ..» - цена исполнения связанной лимитированной заявки. Параметр поручения типа «Со связанной заявкой».
  15. «При частичном исполнении связанной заявки снять стоп-заявку» – если флажок установлен, то при частичном исполнении связанной лимитированной заявки стоп-заявка становится снятой. Если флажок снят, то при частичном исполнении связанной заявки объем стоп-заявки уменьшается до величины неисполненного остатка лимитированной заявки.
  16. «Выставить «Тейк-профит» - параметры заявки типа «Тейк-профит»:
    • «Отступ от max (min)» – устанавливает значение отступа от максимума (на продажу) или минимума (на покупку) цены последней сделки, при достижении которого будет сгенерирована лимитированная заявка. Значение отступа может указываться как в виде отклонения цены, так и в процентах;
    • «Защитный спред» – устанавливает дополнительное (опережающее) отклонение цены заявки от цены последней сделки, инициировавшей заявку. Защитный спред предназначен для того, чтобы установить цену создаваемой лимитированной заявки заведомо исполнимой;
    • «По рыночной цене» - признак исполнения тейк-профита по рыночной цене. Значение параметра «Защитный спред» в данном случае не используется. Параметр заявок типа «Тейк-профит и стоп-лимит».
    В некоторых режимах торгов использование рыночных заявок не предусмотрено.
  17. «Объем и комиссия» - оценка заявки в денежном выражении. Позволяет рассчитать «Количество» инструментов в заявке по известной сумме денег. Для этого нужно ввести в поле «Объем» сумму денежных средств и нажать кнопку «Задать количество». При этом в поле «Количество» будет введено число, полученное в результате пересчета и округленное вниз до ближай-шего целого, а в поле «Объем» – денежная оценка заявки при данном «Количестве».

    Сумма брокерской комиссии с объема заявки рассчитывается автоматически в соответствии с установленным алгоритмом и выводится в поле справа.

    1. При заполнении формы заявки можно перемещаться между полями мышью, либо клавишей «Tab» в одну сторону, или «Shift»+«Tab» в обратную сторону.
    2. Поля «Количество», «Код клиента», «Комментарий» могут быть заполнены автоматически. Подробнее см. Настройка автозаполнения полей ввода заявки.
    3. В случае неблагоприятного исполнения заявки типа «Тейк-профит» на покупку, цена будет рассчитана следующим образом: <стоп-цена>+<отступ от min/max>+<защитный спрэд>.

Пример использования заявки типа «Тейк-профит»:

  1. Предположим, что куплены акции по 10 р., и планируется продать по цене не ниже 11 р. Нужно поставить тейк-профит на продажу, в котором в условии активации стоп-заявки указывается цена 11 р. Также указывается два дополнительных параметра:
    • «отступ от max» - этот параметр указывает, насколько ниже локального максимума цены может стать цена последней сделки;
    • «защитный спред» — насколько меньше цены срабатывания тейк-профита будет цена порожденной им лимитированной заявки на продажу.
  2. Предположим, что мы задаем «отступ от max» = 5 коп., «защитный спред» = 2 коп. Допустим, что наши ожидания оправдались, и рынок пошел в выгодную для нас сторону, т.е. растет. Цена достигла 11 р. — на этой точке тeйк-профит активируется и начинает проверять, будет расти цена дальше, или нет. При этом он проверяет, не стала ли цена последней сделки по инструменту ниже чем разница «локальный максимум цены»-«отступ от max».
  3. Предположим, цена растет и достигает 11,30, после чего падает до 11,26 и опять начинает расти. Тейк-профит в этом случае не превратится в лимитированную заявку, так как цена упала от максимума на 4 коп., а мы задали «отступ от max» = 5 коп., т.е. условие исполнения достигнуто не было.

    Дальше цена выросла до 11,40 и упала до 11,33 — вот тут наш тейк-профит активируется и породит лимитированную заявку на продажу с ценой, вычисляемой по следующей формуле:

    <цена последней сделки> - <защитный спред>

    Т.е. цена заявки на продажу будет 11,33–0,02=11,31. «Защитный спред» нужно указать для защиты от «проскальзывания» рынка ниже цены порожденной тейк-профитом заявки.

  4. Для ситуации с покупкой все выполняется с точностью «до наоборот» с учетом того, что цена исполнения заявки выбирается как наименьшая из двух цен:

    <Цена последней сделки> + <спред> и

    <Цена стоп-заявки> + <отступ> + <спред>.

Если для какого-то типа условной заявки не предусмотрен один из пунктов заявки, то он становится «серым» (неактивным).

Порядок подтверждения условной заявки, настройки параметров ее ввода, доступные функции и способ быстрого ввода такие же, как и при вводе заявки.


Снятие и замена условной (стоп-) заявки

Операции снятия и замены условной заявки выполняются из Таблицы стоп-заявок и окна «Графики». Операции аналогичны действиям над обычными заявками.

В отличие от обычных заявок, условные заявки могут быть сняты пользователем во время отсутствия связи сервера со шлюзом торговой системы.
Рекомендации:
  1. Для ввода стоп-заявки на покупку цену заявки рекомендуется назначать на несколько пунктов больше стоп-цены, чтобы заявка могла исполниться при дальнейшем росте цены сделки.
  2. Для ввода стоп-заявки на продажу цену заявки рекомендуется назначать на несколько пунктов меньше стоп-цены.
  3. Будьте внимательны при определении направления заявки и стоп-цены, чтобы избежать ввода стоп-заявки с уже наступившими условиями.

См. также:

  • Условные (стоп-) заявки
  • Снятие заявок по условию


Принудительное исполнение условной заявки

Активные условные заявки, хранимые на сервере QUIK, исполняются при наступлении условия стоп-цены. Если необходимо, можно исполнить активную условную заявку принудительно, отвергнув условие стоп-цены. Функция доступна в Таблице стоп-заявок и выполняется одним из следующих способов:

  • Нажатием клавиш «Alt»+«F6»;
  • Выбором пункта контекстного меню «Активировать стоп-заявку» на выделенной строке.

В случае принудительной активации заявок типа «Тейк-профит», «Тейк-профит по исполнению», «Тейк-профит и стоп-лимит», «Тейк-профит и стоп-лимит по исполнению» выставляется заявка по цене последней сделки +/- защитный спред. Если с момента выставления тейк-профита сделок по данному инструменту не было, то заявка выставляется по цене «Условие активации тейк-профита» +/- защитный спред.

См. также:

  • Условные (стоп-) заявки
  • Снятие заявок по условию


Заявка с условием «по исполнению»

  • Назначение
  • Применение заявок «по исполнению»

    • Назначение

    Заявки «по исполнению» представляют собой условные заявки, условием активации (начала проверки их стоп-цены сервером QUIK) которых является исполнение определенной активной заявки («заявки-условия»). Такие заявки могут применяться, например, для закрытия позиции по инструменту, открываемой данной активной заявкой.

    Исполнение одной активной заявки может вызывать активацию нескольких заявок «по исполнению» разных типов.

    Применение заявок «по исполнению»

    В системе QUIK предусмотрены следующие типы заявок «по исполнению»: «Стоп-лимит по заявке», «Тейк-профит и стоп-лимит по заявке» и «Тейк-профит по заявке». После исполнения заявки-условия они порождают заявки типа «Стоп-лимит», «Тейк-профит и стоп-лимит» и «Тейк-профит» соответственно, со стандартным набором параметров для этих типов заявок (см подробнее Условные (стоп-) заявки). Для просмотра списка заявок «по исполнению» и их текущего состояния используется Таблица стоп-заявок.

    Срок действия заявок «по исполнению» - до окончания текущей торговой сессии, т.е. пока заявка-условие может быть активной.

    Параметры «Класс», «Инструмент», «Счет», «Код клиента», «Комментарий» для заявки «по исполнению» заимствуются из заявки-условия.

    Направленность заявки «по исполнению» всегда противоположная к заявке-условию. Например, если заявка-условие имеет направленность «на покупку», то заявка «по исполнению» выставляется «на продажу».

    Если в момент активации заявки «по исполнению» количество доступных средств недостаточное для выполнения заявки, то такая заявка не активируется и становится «Снятой».

    Если заявка-условие снята или отвергнута торговой системой, то снимаются все связанные с ней заявки «по исполнению».

    См. также:

    • Ввод заявки «по исполнению»
    • Замена и снятие заявки «по исполнению»


Ввод заявки «по исполнению»

Ввод заявки «по исполнению» осуществляется выбором в Таблице заявок пункта контекстного меню «Стоп-заявка «по исполнению»». В окне ввода заявки слева расположены поля для ввода параметров заявки «по исполнению», а справа – параметры заявки-условия.

Значения параметров заявки «по исполнению»:

  1. «Тип стоп-заявки» – выбор типа заявки:«Стоп-лимит по заявке», «Тейк-профит и стоп-лимит по заявке» или «Тейк-профит по заявке» (см. Описание типов ).
  2. «Срок действия» – определяет срок действия заявки. Доступно значение «Сегодня».
  3. «Параметры активации стоп-заявки» определяют поведение заявки «по исполнению» в случае исполнения заявки-условия:
    • «Частичное исполнение заявки учитывается» – означает, что заявка «по исполнению» активируется при частичном исполнении заявки-условия. Если флажок снят, то заявка «по исполнению» активируется только при полном исполнении заявки-условия;
    • «Брать исполненный объем заявки в качестве количества выставляемой стоп-заявки» – в качестве количества инструментов в заявке «по исполнению» принимается исполненный объем заявки-условия. Если флажок снят, то объем заявки указывается явно, в поле «Количество».

Если установлены оба флажка, то при частичном исполнении заявки-условия происходит активация заявки «по исполнению» с указанием количества инструментов, равным объему исполненной части заявки-условия. При дальнейшем исполнении заявки-условия происходит увеличение объема заявки «по исполнению». При этом в зависимости от движения цен на рынке, возможно наступление условий исполнения заявки «по исполнению» для активированного объема, а затем снова может происходить увеличение активированного объема в результате следующего частичного исполнения заявки-условия.
  4. «Условие активации стоп-заявки» – определяет значение стоп-цены и направленность заявки.
    • Направление заявки: «ПОКУПАТЬ» или «ПРОДАВАТЬ»;
    • Выбор контролируемого условия стоп-цены по отношению к цене последней сделки по инструменту:
      • «стоп-лимит, если цена <=» ( или «>=») - выставление лимитированной заявки в случае, если цена последней сделки пересекла указанное значение;
      • «тейк-профит, если цена <=» ( или «>=») - начало расчета минимума (максимума) цены последней сделки, если она пересекла указанное значение.

      Для заявок типа «Тейк-профит и стоп-лимит» доступны оба условия, причем любое из них может не заполняться.
  5. «Цена» – цена заявки, за единицу инструмента.
  6. «По рыночной цене» - признак исполнения стоп-заявки по рыночной цене. Параметр заявок типа «Тейк-профит и стоп-лимит по заявке».

В некоторых режимах торгов использование рыночных заявок не предусмотрено.
  7. «Кол-во (лот …)» – количество инструментов в заявке, в лотах. В скобках указано количество единиц выбранного инструмента в одном лоте. При редактировании поля с помощью стрелок вверх/вниз или колесика мыши значение увеличивается или уменьшается на величину значения параметра «Кратность лота» и округляется до значения, кратного параметру «Кратность лота». Для изменения количества лотов на величину, в 10 раз превышающую кратность лота, используйте стрелки вверх/вниз с нажатой клавишей Ctrl. Параметр недоступен, если установлен флажок «Брать исполненный объем заявки в качестве количества выставляемой стоп-заявки».
  8. «Параметры «Тейк-профит» - параметры заявки типа «Тейк-профит по заявке»:
    • «Отступ» – устанавливает значение отступа от максимума (на продажу) или минимума (на покупку) цены последней сделки, при достижении которого генерируется лимитированная заявка. Значение отступа указывается в виде отклонения цены или в процентах;
    • «Спред» – устанавливает дополнительное (опережающее) отклонение цены заявки от цены последней сделки, инициировавшей заявку. Защитный спред предназначен для того, чтобы установить цену создаваемой заявки заведомо исполнимой;
    • «По рыночной цене» - признак исполнения тейк-профита по рыночной цене. Значение параметра «Защитный спред» в данном случае не используется. Параметр заявок типа «Тейк-профит и стоп-лимит по заявке».

В некоторых режимах торгов использование рыночных заявок не предусмотрено.
  9. «Объем и комиссия» - оценка заявки в денежном выражении. Позволяет рассчитать «Количество» инструментов в заявке по известной сумме денег. Для этого нужно ввести в поле «Объем» сумму денежных средств и нажать кнопку «Задать количество». При этом в поле «Количество» выводится число, полученное в результате пересчета и округленное вниз до ближайшего целого, а в поле «Объем» – денежная оценка заявки при данном «Количестве»,

    Сумма брокерской комиссии с объема заявки рассчитывается автоматически в соответствии с установленным алгоритмом и выводится в поле справа.

Значения параметров заявки-условия:

  1. «Номер» – регистрационный номер заявки-условия в торговой системе биржи.
  2. «Класс» – наименование класса в торговой системе, к которому относится инструмент.
  3. «Инструмент» – наименование инструмента, указанного в заявке.
  4. «Торговый счет» – код счета, в отношении которого совершается операция (с соблюдением регистра символов).
  5. «Операция» – направленность операции заявки-условия.
  6. «Цена» – цена заявки-условия, за единицу инструмента.
  7. «Количество» – количество инструментов в заявке, в лотах.
  8. «Баланс» – исполненная часть заявки-условия, в лотах.
  9. «Код клиента» – идентификатор клиента в системе QUIK.
  10. «Комментарий» – текстовый комментарий к заявке.

См. также:

  • Заявка с условием «по исполнению»
  • Замена и снятие заявки «по исполнению»


Замена и снятие заявки «по исполнению»

Снятие заявки «по исполнению» осуществляется из Таблицы стоп-заявок таким же образом, как и снятие условных заявок других типов.

Процедура замены заявок по условию состоит в снятии одной заявки «по условию» и создании новой, с измененными условиями. Выполняется следующим образом: двойным нажатием правой кнопки мыши на снимаемой заявке производится отзыв активной заявки, а затем двойным нажатием левой кнопки мыши на снятой заявке открывается окно ввода новой заявки с заполненными параметрами, указанными в этой снятой заявке.

См. также:

  • Заявка с условием «по исполнению»
  • Ввод заявки «по исполнению»


Управление заявками из Таблицы котировок

  • Панель торговли
  • Замена и снятие заявок перетаскиванием мышью
  • Режим «Быстрый ввод заявки»


Панель торговли

  • Цена, количество и счет
  • Панель выставления заявок
  • Панель снятия заявок по условию
  • Код клиента и Примечание
  • Панель информации о позиции
  • Отступ цены
  • Настройка панели торговли
    •

    Ввод заявок и управление активными заявками может осуществляться непосредственно из Таблицы котировок, путем включения специальной панели торговли.

    Панель торговли представляет собой набор полей ввода и кнопок для управления заявками: отправка заявки, снятие и замена собственных активных заявок, видимых в Таблице котировок, контроль величины позиции по данному инструменту, закрытие либо «переворот» позиции.

    Отображение панели торговли в Таблице котировок настраивается пользователем. Настроенное окно можно сделать шаблоном для всех открываемых «стаканов».

    Замену и снятие активных заявок в Таблице котировок можно выполнять перетаскиванием строки, содержащей собственную заявку.

    Назначение элементов на панели торговли Таблицы котировок приведено ниже.

    Цена, количество и счет

    Панель предназначена для ввода цены заявки (поле «P»), количества инструментов (поле «Q») и выбора торгового счета из списка (поле «A»). Значение счета в поле «A» должно указываться с соблюдением верхнего/нижнего регистра символов. На поле ввода торгового счета распространяются все настройки, установленные через пункт меню Система/Настройки/Основные настройки... раздел «Торговля»/«Настройка счетов».

    Если данная панель отключена, то ввод заявок из Таблицы котировок невозможен.

    Доступные действия

    • Нажатие колесика «мыши» на строке с котировкой - ввести в параметры заявки в панели инструментов цену и количество из выбранной строки. Если при этом удерживать нажатой клавишу «Ctrl», то значением количества выбирается «Сумма лучших» для этой котировки;
    • «PageUp», «PageDown» – увеличить/уменьшить количество лотов на 1;
    • «Ctrl»+«PageUp», «Ctrl»+«PageDown» – увеличить/уменьшить количество лотов на 10;
    • «+», «-» (на цифровом блоке клавиатуры) – увеличить/уменьшить цену на 1 минимальный шаг цены (пипс);
    • «Ctrl»+«+»,«Ctrl»+«-» – увеличить/уменьшить цену на 10 минимальных шагов цены (пипсов).

    Настройка объемов заявки

    Существует возможность указания в настройках до 3 стандартных значений количества инструментов в заявке, выбираемых нажатием комбинации «горячих клавиш». Для использования данной функции нужно в окне настроек Таблицы котировок включить флажок «Быстрый ввод объема заявки» и заполнить значениями поля «Объем 1» … «Объем 3». Значение указывается в лотах.

    Выбор значения объема при вводе заявки осуществляется нажатием комбинации «горячих клавиш»:

    • «Alt»+«A» - взять количество инструментов из поля «Сумма лучших» в выбранной строке таблицы;
    • «Alt»+«S» - «Объем 1»;
    • «Alt»+«D» - «Объем 2»;
    • «Alt»+«F» - «Объем 3».

    Выбранное значение объема отображается в поле «Q» на панели инструментов Таблицы котировок.

    Панель выставления заявок

    Панель предназначена для быстрой отправки поручений с заданными параметрами.

    Назначение кнопок:

    Кнопка | Действие | Горячие клавиши | Контекстное меню таблицы котировок
 | Выставляет лимитированную заявку на покупку с заданной ценой и количеством | Ctrl + 1 | Выставить на покупку
 | Выставляет рыночную заявку на покупку с указанным количеством | Ctrl + 2 | Купить по рынку
 | Снимает выделенную заявку в текущем рабочем окне | Ctrl + D | Снять заявку
 | Заменяет выделенную заявку в текущем рабочем окне | Ctrl + A | Заменить заявку
 | Выставляет лимитированную заявку на продажу с заданной ценой и количеством | Ctrl + 3 | Выставить на продажу
 | Выставляет рыночную заявку на продажу с указанным количеством | Ctrl + 4 | Продать по рынку

    Если какие-либо кнопки недоступны (серые), то выполнить данное действие невозможно (отсутсвуют необходимые параметры заявки либо не выбрана строка с активной заявкой в очереди).

    При выставлении рыночных заявок на покупку и продажу на срочном рынке Московской Биржи в качестве цены используется соответствующее предельное значение цены из Таблицы текущих торгов: «Максимально возможная цена» для заявок на покупку, «Минимально возможная цена» для заявок на продажу. Значение цены, указанное в поле «P», игнорируется.

    Для классов рынка LSE используется параметр «Реальный шаг цены» вместо параметра «Минимальный шаг цены» в том случае, когда значение параметра «Реальный шаг цены» больше значения параметра «Минимальный шаг цены».

    Панель снятия заявок по условию

    Панель предназначена для снятия нескольких заявок, объединенных одним условием (активные, на покупку, на продажу).

    Кнопка | Действие | Горячие клавиши | Контекстное меню таблицы котировок
 | Снимает все активные заявки из текущего окна котировок по данному инструменту | Ctrl + F8 | Снять все заявки
 | Снимает все активные заявки на покупку из текущего окна котировок по данному инструменту | Ctrl + Z | Снять покупку
 | Снимает все активные заявки на продажу из текущего окна котировок по данному инструменту | Ctrl + X | Снять продажу

    При выполнении команды снятия заявок с помощью кнопок снимаются все заявки, выставленные через данный стакан котировок. При заданном фильтре по коду клиента и включенной настройке «Применять глобальный фильтр клиентов» cнимаются только заявки с кодом клиента, указанным в панели.

    При выполнении любой команды снятия заявок по условию запрашивается стандартное подтверждение на снятие (если только не отключена настройка «Транзакции / Запрашивать подтверждение»).

    Код клиента и Примечание

    Панель предназначена для выбора кода клиента и указания комментария к заявке.

    Поле | Название | Действие
C | Код клиента | Поле со списком служит для выбора кода клиента
M | Примечание | Поле Примечание служит для указания комментария к заявке

    Введенное пользователем значение комментария запоминается при сохранении котировочного окна в файле настроек.

    Панель информации о позиции

    Панель информации служит для информирования пользователя о состоянии текущей позиции.

    Поле «Позиция по инструменту»

    Поле Индикация Примечание
    • зеленый фон - «длинная» позиция, значение положительно;
    • красный фон - «короткая» позиция, значение отрицательно

    Поле POS может иметь нулевое значение, если:

    • не указаны торговый счет или код клиента;
    • позиция по клиентскому счету или по инструменту для торгового счета и кода клиента не заданы брокером.

    Особенность для срочного рынка Московской Биржи: текущая позиция определяется как величина текущей чистой позиции из Таблицы позиций по клиентским счетам.

    Назначение кнопок

    Кнопка | Действие | Горячие клавиши | Контекстное меню таблицы котировок
 | Выставление рыночной заявки, равной величине позиции, исполнение которой приводит к закрытию текущей позиции по указанному инструменту | Ctrl + K | Закрыть позицию
 | Выставление рыночной заявки, равной удвоенной величине позиции, исполнение которой приводит к «перевороту» текущей позиции (изменению отрицательной позиции на положительную, либо наоборот) по указанному инструменту | Ctrl + I | Перевернуть позицию

    Если включена настройка «Торговля» / «Заявки» / «Запрашивать подтверждение», то для операций закрытия и переворота позиции отображается стандартный запрос на подтверждение условий заявки.

    Отступ цены

    Панель содержит поле «О» - [image] , в котором отображается текущее значение отступа цены выставляемой заявки от цены в выбранной строке Таблицы котировок.

    Отступ цены - отклонение цены выставляемой заявки от цены в выбранной строке Таблицы котировок. Отступ может быть полезен для реализации заявок при быстром изменении цен на рынке.

    Отступ представляет собой целочисленное значение, выраженное в количестве минимальных шагов цены. Например, если минимальный шаг цены для инструмента равен 0,01 рублей, а значение отступа указано «5», то цена заявки будет отличаться от цены в выбранной строке таблицы на 0,05 рублей.

    Положительное значение отступа означает опережающее изменение цены. Для заявок на покупку цена увеличивается на размер отступа, для заявок на продажу – уменьшается. Значение отступа может быть нулевым или отрицательным.
    Выбор одного из сохраненных значений отступа при вводе заявки осуществляется нажатием комбинации «горячих клавиш»:

    • «Alt»+«Z» - «Отступ 1»;
    • «Alt»+«X» - «Отступ 2»;
    • «Alt»+«C» - «Отступ 3»;
    • «Alt»+«V» - «Отступ 4».

    Выбранное значение отступа отображается в поле «О» на панели инструментов Таблицы котировок.

    Настройка отступов от цены

    Для каждого инструмента может указываться до 4 значений отступа. Значения указываются в настройках Таблицы котировок.

    Для этого требуется включить флажок «Брать отступ цены» и в полях «Отступ 1» .. «Отступ 4» указать значения отступа.

    Настройка панели торговли

    Первичное открытие окна настройки панели торговли осуществляется нажатием комбинации клавиш «Alt»+«F2» на Таблице котировок.

    Изменение ранее настроенной панели осуществляется нажатием кнопки «…» на свойстве «Панель торговли» в окне редактирования Таблицы котировок.

    В состав панели торговли включаются элементы панели, отмеченные «галочкой». Последовательность отображения элементов панели настраивается кнопками со стрелками «вверх» и «вниз» справа от списка доступных элементов.

    По умолчанию, панель располагается под содержимым Таблицы котировок. Включение признака «Показывать панель над котировками» позволяет расположить панель в верхней части окна.


Замена и снятие заявок перетаскиванием мышью

Режим замены и снятия заявок при помощи курсора мыши (режим drag-and-drop) включается в окне редактирования Таблицы котировок выбором признака «Использовать drag-and-drop». При замене заявки осуществляется изменение ее цены. Количество инструментов в заявке и ее направленность не изменяются.

Для замены заявки с использованием биржевой транзакции необходимо чтобы в настройках Рабочего места были включены флажки «Заменять заявки путем изменения их параметров» и «По возможности заменять заявки путем изменения их параметров» (пункт меню Система / Настройки / Основные настройки…, раздел «Торговля» / «Заявки» / «Замена заявок»). Если флажок «По возможности заменять заявки путем изменения их параметров» отключен, то выполняется снятие активной (заменяемой) заявки и выставление новой заявки с измененными параметрами.

Для замены заявки нужно:

  1. Выбрать курсором строку с активной заявкой пользователя. Чтобы выделить собственные заявки в окне, рекомендуется включить признак «Выделять свои заявки» в окне редактирования настроек Таблицы котировок, либо добавить в список отображаемых параметров значения «Свой объем» (или «Своя покупка» и «Своя продажа» - в зависимости от выбранного вида котировочного окна).

  2. Нажать левую или правую кнопку мыши и немного сдвинуть курсор мыши. В результате курсор изменит свой вид так, как показано на рисунке. Под курсором отображается подсказка вида: «новая цена заявки» и «количество лотов».
  3. Удерживая нажатой кнопку мыши, переместить ее вверх либо вниз по списку. В окне подсказки отобразится новая цена заявки.
  4. Новая цена заявки рассчитывается при пересечении курсором границы между строками. Если курсор наведен на середину строки, то для заявки выбирается цена в этой строке. Если курсор наведен на границу между строками, то выбирается цена котировки, со стороны которой произведено пересечение границы, цена корректируется на 1 шаг цены по направлению к цене следующей котировки. Для примера на рисунке, при пересечении границы вниз берется цена следующей заявки и уменьшается на 1 шаг цены, чтобы заявка пользователя разместилась между соседними котировками.
  5. Цену заявки можно изменять вращением колесика мыши. Если при этом удерживать нажатой клавишу «Ctrl», то шаг изменения цены увеличивается в 10 раз.
  6. Добившись требуемого значения цены, отпустите нажатую кнопку мыши. Если в настройках программы включен признак «Запрашивать подтверждение» (рекомендуется), то на экране появляется окно с требованием подтвердить условия новой заявки. При нажатии кнопки «Да» выполняется снятие активной заявки и выставление новой. При нажатии кнопки «Нет» замена заявки не выполняется.
  7. Если признак «Запрашивать подтверждение» отключен, то замена заявки выполняется сразу после отпускания нажатой кнопки мыши.

При изменении цены с помощью курсора мыши обратите внимание, что для классов рынка LSE используется параметр «Реальный шаг цены» вместо параметра «Минимальный шаг цены» в том случае, когда значение параметра «Реальный шаг цены» больше значения параметра «Минимальный шаг цены».

Если при нажатии кнопки мыши курсор принял вид [image], то замена заявки невозможна.

Возможные причины:

  1. На выбранной строке в Таблице котировок находится больше одной заявки пользователя.
  2. Курсор находится в недопустимом месте окна (на заголовке, границе окна или панели инструментов).

В этом случае при отпускании кнопки мыши не производится никаких действий с заявками пользователя.

Для снятия заявки нужно:

  1. Выбрать курсором строку с активной заявкой пользователя.
  2. Нажать левую или правую кнопку мыши.
  3. Переместить курсор за пределы Таблицы котировок. Курсор изменит вид так, как показано на рисунке.

  4. Отпустить нажатую кнопку мыши. Если в настройках программы включен признак «Запрашивать подтверждение» (рекомендуется), то на экране появится окно с требованием подтвердить снятие заявки. При нажатии кнопки «Да» выполняется отмена активной заявки. При нажатии кнопки «Отмена» снятие заявки не выполняется.

    Если признак «Запрашивать подтверждение» отключен, то снятие заявки выполняется сразу после отпускания нажатой кнопки мыши.

Если необходимо отказаться от замены или снятия заявки при уже нажатой кнопке мыши, то можно навести курсор на заголовок окна (он примет вид [image]) и отпустить нажатую кнопку, либо нажать клавишу «Esc».


Режим «Быстрый ввод заявки»

Если в настройках Таблицы котировок установлен флажок «Быстрый ввод/снятие заявки», то включается режим быстрого ввода заявок, который предусматривает ввод и снятие заявок в стакане котировок с помощью кнопок мыши. Данный режим требует включения панели инструментов в Таблице котировок.

Параметры заявки «Торговый счет», «Код клиента», «Примечание» заполняются значениями из полей «А», «С» и «М» на панели инструментов Окна котировок. Данные поля должны быть видимыми на панели. Если поля «С» и «М» не отображаются на панели, то параметры «Код клиента» и «Примечание» в заявке не заполняются.

Ввод заявки осуществляется ОДНИМ нажатием кнопки мыши. При этом, запрос на подтверждение операции не появляется, даже если он включен в настройках программы.

Зависимость направления операции заявки от нажатия кнопок мыши:

Вид таблицы | Нажатие кнопки мыши | В столбце | Действие
 | Левой | «Цена» | * Покупка
 | Левой | «Количество» | * Продажа
 | Правой | Любой | Снятие всех своих заявок с ценой из данной строки
 | Левой | «Покупка» | * Покупка
 | Левой | «Продажа» | * Продажа
 | Правой | Любой | Снятие всех своих заявок с ценой из данной строки
 | Левой | «Цена покупки» | * Продажа (встречная заявка)
 | Левой | «Цена продажи» | * Покупка (встречная заявка)
 | Левой | «Покупка» | * Покупка
 | Левой | «Продажа» | * Продажа
 | Правой | Любой из параметров покупки | Снятие всех своих заявок на покупку с ценой из данной строки
 | Правой | Любой из параметров продажи | Снятие всех своих заявок на продажу с ценой из данной строки

* - по цене из строки (с поправкой на отступ «O») и с количеством из поля «Q» панели инструментов Таблицы котировок

  1. При включении режима «Быстрый ввод заявки» вызов формы ввода заявки двойным нажатием левой кнопки мыши в окне котировок НЕ РАБОТАЕТ, двойное нажатие интерпретируется как две последовательных отправки заявки и не вызывается контекстное меню при нажатии на котировке.
  2. Отправка заявки происходит в момент отпускания кнопки мыши, а не в момент ее нажатия. При нажатии кнопки мыши запоминается выделенная котировка, а при отпускании выполняется проверка, что котировка под курсором мыши совпадает с котировкой в момент нажатия. Если они совпадают, то выставляется заявка.
  3. В поле «Цена» для классов рынка LSE используется параметр «Реальный шаг цены» вместо параметра «Минимальный шаг цены» в том случае, когда значение параметра «Реальный шаг цены» больше значения параметра «Минимальный шаг цены».


Перестановка заявок по опционам и фьючерсам

  • Назначение
  • Настройка операции «Перестановка заявок»
  • Применение операции «Перестановка заявок»

    • Назначение

    Операция перестановки заявок доступна для заявок с фьючерсами и опционами на срочном рынке Московской Биржи. С помощью операции можно изменить параметры одновременно в двух заявках.

    Открытие диалога «Перестановка заявок» осуществляется с использованием Общего способа выполнения транзакций, выбором операции «Переставить заявки» на классах «Опционы FORTS» и «Фьючерсы FORTS».

    Настройка операции «Перестановка заявок»

    Диалог настройки перестановки заявок на срочном рынке Московской Биржи содержит следующие параметры:

    1. «Инструмент» - выбор инструмента из списка инструментов данного класса.
    2. «Режим» - режим перестановки заявок на срочном рынке Московской Биржи. Возможные значения:
      • «0» – оставить количество в заявках без изменения;
      • «1» - изменить количества в заявках на новые;
      • «2» – при несовпадении новых количеств с текущим хотя бы в одной заявке, обе заявки снимаются;
      • «3» - установить количество в заявках равным присланному объему за вычетом сведенной части заявки (не меньше 0). Если присланный объем меньше сведенной части заявки, обе заявки снимаются.
    3. «Номер первой заявки» - номер первой заявки на покупку/продажу опционов.
    4. «Количество в первой заявке» - количество инструментов в первой заявке.
    5. «Цена в первой заявке» - цена за единицу инструмента в первой заявке.
    6. «Номер второй заявки» - номер второй заявки на покупку/продажу опционов.
    7. «Количество во второй заявке» - количество инструментов во второй заявке.
    8. «Цена во второй заявке» - цена за единицу инструмента во второй заявке.

    Операция перестановки заявок выполняется нажатием на кнопку «Выполнить».

    Применение операции «Перестановка заявок»

    Перестановка заявок на срочном рынке Московской Биржи выполняется по следующим правилам:

    • Если в настройках в поле «Режим» выбрано значение «0», то заявки с номерами, указанными в полях «Номер первой заявки» и «Номер второй заявки», снимаются. В торговую систему отправляются две новые заявки, при этом изменяется только цена заявок, количество остается прежним.
    • Если в настройках в поле «Режим» выбрано значение «1», то заявки с номерами, указанными в полях «Номер первой заявки» и «Номер второй заявки», снимаются. В торговую систему отправляются две новые заявки, при этом изменится как цена заявки, так и количество.
    • Если в настройках в поле «Режим» выбрано значение «2», то заявки с номерами, указанными в полях «Номер первой заявки» и «Номер второй заявки», снимаются. Если количество инструментов в каждой из снятых заявок совпадает со значениями, указанными в полях «Номер первой заявки» и «Номер второй заявки», то в торговую систему отправляются две новые заявки с соответствующими параметрами.
    • Если в настройках в поле «Режим» выбрано значение «3», то заявки с номерами, указанными в полях «Номер первой заявки» и «Номер второй заявки», снимаются. Новые заявки выставляются в торговую систему только в том случае, если указанное новое количество больше, чем исполненное количество в соответствующих заявках. При выставлении количество заявок определяется как разность присланного значения и значения исполненного количества заявки. Например, если прислано количество 70, а исполненное количество равно 50, то выставится заявка на 20 лотов.


Закрытие позиции

Операция закрытия позиции вызывается нажатием кнопки [image] «Закрыть» на панели инструментов вкладки «Позиции» в окне «Состояние счета».

Операция недоступна в следующих случаях:

  • Позиция в активной строке нулевая или меньше размера лота по выбранному инструменту;
  • Отсутствует встречные спрос или предложение;
  • Значение вида лимита в поле «На дату» не совпадает с видом лимита, установленным в настройках Библиотеки расчета лимитов по классу, выбранному для оценки текущей позиции;
  • Выбрана совокупная позиция, и позиции по всем счетам нулевые.

Если в настройках программы включен признак «Запрашивать подтверждение на закрытие позиции», то на экране появляется диалог закрытия позиции:

Диалог закрытия позиции содержит следующие параметры:

Значения параметров по умолчанию определяются настройками параметров инструмента. Если настройки не указаны, то используются значения по умолчанию, указанные ниже.
  1. Информационное поле – таблица, содержащая информацию по закрываемой позиции. Если закрывается совокупная позиция, то таблица содержит по строке на каждый счет депо, иначе – одну строку по указанному счету депо. В столбцах таблицы отображаются следующие параметры:

    Название поля | Значение
    Счет депо | Счет депо
    Инструмент | Краткое наименование инструмента
    Класс | Наименование класса инструмента, по которому произведена оценка позиции
    Позиция Размер позиции. Единицы измерения определяются настройками инструмента.

    Размер позиции в штуках отображается с учетом размера лота для данного инструмента

    Баланс. цена | Балансовая цена позиции, за единицу инструмента
    Снять заявок | Суммарное количество активных заявок
    Снять стоп-заявок | Суммарное количество активных стоп-заявок

  2. Переключатель «Цена» – выбор типа заявки закрытия позиции:
    • «Лимитированная, отступ» – при выборе данного типа заявки закрытия позиции доступны следующие настройки:
      • поле ввода величины отклонения цены выставляемой лимитированной заявки от лучшей встречной цены. Значение по умолчанию: «0»;
      • переключатель «шагов цены» / «%» – выбор единицы измерения значения указанного отступа. По умолчанию отступ указывается в пунктах.

      При указании отступа в процентах производится округление рассчитанной цены с учетом шага цены инструмента. При закрытии длинной позиции округление производится в большую сторону, при закрытии короткой позиции – в меньшую.

    • «Рыночная» (по умолчанию).
  3. Флажок «Снимать стоп-заявки» – признак снятия активных стоп-заявок по инструменту перед процедурой закрытия позиции. По умолчанию флажок установлен. Если в настройках программы отключен признак «Запрашивать подтверждение на закрытие позиции», и диалог закрытия позиции не отображается, то снятие активных стоп-заявок производится, исходя из настройки «Снимать стоп-заявки перед закрытием позиций».

Нажатием кнопки «Закрыть позицию» закрывается окно и выполняются следующие действия:

  • Снятие активных заявок по инструменту;
  • Снятие активных стоп-заявок по инструменту (если включена настройка «Снимать стоп-заявки»);

    В момент ожидания ответа торговой системы на снятие заявок кнопка «Закрыть позицию» меняет заголовок на «Отправить без ожидания». Нажатие на кнопку «Отправить без ожидания» ведет к закрытию диалога, не дожидаясь ответа торговой системы на снятие заявок, и началу процедуры вычисления цены заявок на закрытие позиции.
  • Ввод заявки на ликвидацию позиции – рыночной либо лимитированной с заранее установленным отклонением от лучшей встречной цены.

Нажатие кнопки «Отменить» закрывает окно без выполнения операции.

В результате операции закрытия позиции система QUIK формирует пакет поручений на отзыв тех заявок, которые соответствуют заданным условиям. Количество сформированных поручений на отзыв заявок отображается в Окне сообщений. Результат снятия каждой заявки также отображается в Окне сообщений в таком же виде, как и при отзыве заявки вручную.

См. также:

  • Закрытие всех позиций
  • Переворот позиции


Закрытие всех позиций

Операция закрытия всех позиций вызывается нажатием кнопки «Закрыть всё» на панели инструментов вкладки «Позиции» в окне «Состояние счета».

Операция доступна, если в таблице на вкладке «Позиции» есть хотя бы одна ненулевая позиция. Размер позиции должен быть больше либо равен размеру одного лота по выбранному инструменту.

Если в настройках программы включен признак «Запрашивать подтверждение на закрытие позиции», то на экране появляется диалог закрытия всех позиций:

Диалог закрытия всех позиций аналогичен диалогу закрытия одной позиции, за исключением следующих параметров:

  1. В информационном поле диалога закрытия всех позиций отображаются позиции по всем инструментам.
  2. «По умолчанию» – при установленном флажке значения параметров заявки закрытия по каждой позиции определяются настройками параметров инструмента. Если настройки не указаны, то флажок неактивен.

Строки таблицы выделяются цветом:

  • Белый фон – позиция может быть закрыта;
  • Желтый фон – значение вида лимита в поле «На дату» не совпадает с видом лимита, установленным в настройках Библиотеки расчета лимитов по классу, выбранному для оценки текущей позиции;
  • Красный фон – позиции, по которым на рынке отсутствуют встречные спрос или предложение.

При нажатии на кнопку «Закрыть позиции» выполняется закрытие всех позиций на белом фоне. Позиции, выделенные желтым и красным цветом, игнорируются.

Процедура закрытия всех позиций аналогична процедуре закрытия одной позиции

См. также:

  • Закрытие позиции
  • Переворот позиции


Переворот позиции

Операция переворота позиции вызывается нажатием кнопки [image] «Перевернуть» на панели инструментов вкладки «Позиции» в окне «Состояние счета».

Операция переворота позиции доступна при выполнении следующих условий:

  1. При перевороте длинной позиции инструмент переворачиваемой позиции является маржинальным.
  2. Текущие маржинальные показатели клиента позволяют ему совершать операции соответствующей направленности, то есть выставлять заявки на продажу для длинной позиции и заявки на покупку для короткой позиции.

Если в настройках программы включен признак «Запрашивать подтверждение на закрытие позиции», то на экране появляется диалог переворота позиции:

Диалог переворота позиции аналогичен диалогу закрытия одной позиции. Процедура переворота позиции аналогична процедуре закрытия одной позиции, за исключением:

  • Количество инструментов в выставляемой заявке определяется настройками данного инструмента и рассчитывается следующим образом:
    • Сумма размера позиции (без знака) и рабочего объема – если по инструменту указан рабочий объем открытия позиции и включен признак «Брать при перевороте позиции»;
    • Двойной размер позиции (без знака) – если признак «Брать при перевороте позиции» отключен.

Нажатие кнопки «Отменить» закрывает окно без выполнения операции.

См. также:

  • Закрытие позиции
  • Закрытие всех позиций


Расчет премии для опционов

Данное окно представляет собой «опционный калькулятор» для расчета премии по опциону на основе формулы Блэка-Шоулза. Для опционов на фьючерсы в качестве цены фьючерса используется цена последней сделки фьючерсного контракта, являющегося базовым активом. Для опционов на акции на Московской бирже используется цена базового актива, скорректированная на величину дисконтированных денежных потоков по дивидендным выплатам и коэффициент лотности базового актива в одном опционном контракте.

Открытие окна «Установить параметры опционов» осуществляется выбором пункта контекстного меню «Установить параметры опционов» из таблицы «Доска опционов».

  1. Значения полей в таблице «Выбранные опционы»:

    Параметр | Значение
    Код | Код опциона в следующем формате: «EERU-6.06 120406C 18500», где «EERU-6.06» - код фьючерса, «120406С» - опцион CALL с датой исполнения 12 апреля 2006 г., «18500» - величина страйка. В квадратных скобках указан класс инструментов
    Задан.волатильность | Значение волатильности, заданное пользователем
    Ставка | Значение безрисковой процентной ставки, используемое для вычисления расчетной премии. Значение отображается в процентах
    Премия | Расчетная премия, вычисляемая в QUIK по заданной волатильности
    Волатильность | Значение волатильности, транслируемое из торговой системы
    Теор.цена | Значение расчетной премии, транслируемое из торговой системы

  2. Значение «Заданная волатильность» для расчета премии можно ввести вручную, либо нажатием кнопки «Взять для всех из системы» принять ее равной значению волатильности из торговой системы. Нажатием кнопки «Для выбранного» значение присвоится одному контракту, нажатием кнопки «Для всех» - всем контрактам в списке.

    Если включен признак «Исходя из настроек открытых пользователем таблиц» (см. Настройка параметров получения и сохранения данных), то трансляция волатильности из торговой системы возможна только в случае, если данный параметр заказан. Если параметр не заказан, то необходимо либо открыть Таблицу текущих торгов с этим параметром, либо провести его ручной заказ.
  3. Поле «Величина изменения» позволяет скорректировать ранее введенное значение волатильности на указанное количество пунктов либо процентов.
  4. В поле «Безрисковая ставка» указывается величина безрисковой ставки в процентах.

Нажатием кнопки «Выход» окно закрывается, а результат отображается в таблице «Доска опционов».


Настройка параметров торговых операций

  • Общие настройки
  • Заявки
  • Закрытие позиций
  • Клиентский портфель
  • Индикация статуса в клиентском портфеле
  • Котировки
  • Объединенные котировки
  • ЭЦП


Общие настройки

меню Система / Настройки / Основные настройки… раздел «Торговля»

Общие параметры настройки торговых операций:

  1. Заменять коды клиентов на ФИО - указывает путь к файлу с настройками соответствия кодов клиентов и их расширенных описаний (например, фамилия и инициалы). Установка флажка включает режим замены кодов клиентов.
  2. Файл настроек рынков - указывает путь к файлу с настройками соответствия классов инструментов и рынков.
  3. Возможность ставить заявки на РПС и РЕПО режимах из таблицы позиций по инструментам - возможность ввода заявок в режимах РПС и РЕПО из контекстного меню Таблицы позиций по инструментам.
  4. Значение по умолчанию:
    • Кол-во лотов – количество лотов, автоматически заполняемое в поле «Количество» в окне ввода заявки. Введенное значение будет указываться во всех способах формирования заявки, включая быстрый ввод заявок из таблиц;
    • Код клиента – код клиента, автоматически заполняемый в поле «Код клиента» в окне ввода заявки, а также примечание, если оно указано через символ «/»;
    • Всегда брать код клиента по умолчанию – признак безусловной замены кода клиента на значение, указанное по умолчанию. При отключенном флажке код клиента по умолчанию указывается в случаях, когда поле не было заполнено другими способами (например, значением из таблицы, из которой была вызвана форма ввода транзакции).
    Если на панель инструментов программы вынесен «Общий фильтр клиентов» и кнопка «Подставлять код клиента из фильтра в формы подачи заявок» в состоянии «Включена», то настройка «Подставлять код клиента из фильтра в формы подачи заявок» имеет более высокий приоритет, чем остальные настройки раздела «Основные настройки» / «Торговля».
  5. Показывать запрещенные биржей торговые счета - при выключенной настройке торговые счета со статусом «Операции запрещены» не отображаются в диалоге настройки счетов и в полях ввода счетов в формах ввода транзакций. При включенной настройке в списке счетов отображаются все торговые счета независимо от статуса.
  6. Показывать все доступные счета при переводе средств КЦ - при включенной настройке для транзакций, которые не являются транзакциями ввода заявок, в поле ввода торгового счета отображаются все доступные счета. При выключенной настройке отображаются только счета, выбранные пользователем.

    Рекомендации:
    1. Настройте параметр «Установка операции транзакции» равным «Брать встречную к операции котировки». Тогда при вводе заявки из Таблицы котировок при выборе котировки, например, на покупку будет автоматически ставиться встречная операция «продажа», и времени на ввод заявки будет затрачено меньше.
    2. Ввод рыночной заявки на покупку. Если прием рыночных заявок на покупку запрещен брокером, используйте лимитированную заявку с ценой, несколько лучшей, чем встречная к ней. Правилами исполнения заявок в торговой системе предусмотрено, что заявка будет исполнена по ценам встречных котировок, начиная с лучшей, поэтому поведение торговой системы в этом случае будет подобно исполнению рыночной заявки.

  7. Запрашивать подтверждение при загрузке позиций - при включенной настройке запрашивается подтверждение при выполнении команды «Загрузить позиции из файла». По умолчанию настройка включена.


Заявки

меню Система / Настройки / Основные настройки… раздел «Торговля» / «Заявки»
  • Формы ввода
  • Внебиржевые заявки
  • Замена заявок

    • Параметры работы с заявками:

    1. Указывать счет депо по коду клиента – если флажок установлен, то при вводе заявки либо при замене заявки выбирается счет, соответствующий классу инструментов и коду клиента в позициях по инструментам. При снятом флажке счет должен быть выбран из списка доступных.
      • С учетом порядка из настройки счетов – настройка доступна для редактирования при установленном признаке «Указывать счет депо по коду клиента».
        • если флажок установлен, то при отсутствии у клиента позиций по инструментам подставляется первый по порядку торговый счет из списка торговых счетов, доступных для выбранного класса инструментов;
        • если флажок снят, то при отсутствии у клиента позиций по данному инструменту подставляется торговый счет с первой существующей для данного клиента позиции по инструменту, фирма которого совпадает с фирмой, указанной на классе, по которому выставляется заявка. Если у клиента отсутствуют позиции по инструментам, то подставляется первый по порядку торговый счет из списка торговых счетов, доступных для выбранного класса.
    2. Проверять попадание цены в диапазон – если флажок включен, то цена заявки проверяется на соответствие диапазону допустимых значений цены по этому инструменту. Подробнее см. «Настройка параметров инструментов».
    3. Смена операции клавишей «пробел – при установленном флажке направление операции заявки меняется нажатием клавиши «пробел» на противоположное. По умолчанию возможность отключена.
    4. Строгий контроль списка фирм – если флажок установлен, то в формах ввода в поле фирмы-партнера отображаются идентификаторы из настроек классов, для которых у данного пользователя включена опция «Специальные операции» в программе QUIK Administrator. Для корректной работы настройки требуется соблюдение следующих условий:
      • включите настройку «Динамический»;
      • выберите транзакцию «Ввод заявки маклером». Транзакция доступна пользователю при наличии права «Специальные операции» по классу транзакций.
    5. Рассчитывать доступное количество – если флажок установлен, то в окне ввода заявки появится поле «max» в котором отображается максимально возможное количество лотов в заявке, рассчитанное из величины доступных средств клиента с учетом всех комиссий. При установленном флажке становится активным дополнительный признак «Исходя только из собственных средств».
    6. Исходя только из собственных средств – если флажок установлен, то при вводе заявки или стоп-заявки максимальное количество лотов в заявке рассчитывается из величины собственных активов клиента, без учета доступных маржинальных средств.
    7. Запрашивать подтверждение – показывать окно подтверждения условий заявки при вводе / снятии заявки и для операций закрытия / переворота позиции. При снятом флажке транзакции выполняются без подтверждения. Признак не влияет на групповое снятие заявок по условию.
    8. Запрашивать подтверждение для групповых операций - показывать окно подтверждения при групповом снятии заявок по условию или при вызове из контекстного меню Таблицы котировок действий «Снять все заявки», «Снять покупку», «Снять продажу». При отключенном флажке снятие выполняется без подтверждения.
    9. Проверять количество на кратность лоту - включает проверку заявки перед отправкой в торговую систему на кратность количества инструментов величине кратности лота, установленной для данного класса инструментов. Проверка осуществляется, если для класса инструментов указана кратность лота, и она не равно 0 или 1. По умолчанию проверка включена.
      • Округлить вниз – если количество инструментов в заявке не кратно лоту, то округлить его вниз без предупреждения;
      • Округлить вверх – если количество инструментов в заявке не кратно лоту, то округлить его вверх без предупреждения;
      • Выбрать вручную – если количество инструментов в заявке не кратно лоту, то на экране появится окно с возможностью выбора количества инструментов из округленного вниз и вверх. Значение выбрано по умолчанию.
    10. Установка операции заявки - этот переключатель определяет правило, по которому выбирается направление операции заявки при открытии окна ввода из таблицы «Котировки».
      • Не указывать операцию – ни «Покупка», ни «Продажа» не выбраны;
      • Брать операцию котировки – устанавливается направление операции такое же, как и в выделенной котировке;
      • Брать встречную к операции котировки – устанавливается противоположное направление к выбранной котировке. Например, если ввод заявки осуществляется при выделенной в Таблице котировок котировке на продажу, то в заявке будет указана операция «Покупка».
    Настройка работает только при открытии окна ввода заявки из таблицы котировок. При включенном режиме «Быстрый ввод заявки» данная настройка не работает, так как в этом случае заявки выставляются без открытия формы ввода.

    Формы ввода

    меню Система / Настройки / Основные настройки… раздел «Торговля» / «Заявки» / «Формы ввода»

    Параметры форм ввода заявок:

    1. Запоминать положение на экране – при установленном флажке фиксируется положение окна ввода заявки на экране программы при последующем его открытии.
      Если при закрытии окно располагалось частично за пределами монитора, то при последующем открытии данное окно размещается так, чтобы его было видно полностью. Если включена настройка «Использовать немодальные формы ввода», то положение окна ввода заявки не фиксируется и открывается с небольшим сдвигом от предыдущего места открытия.
    2. Особо выделять ключевые параметры – если флажок включен, то текст в полях ввода цены и количества выделяется жирным шрифтом. Опция доступна при выборе динамического или классического режима отображения форм ввода.
    3. Режим отображения:
      • Динамический – поддержка совместимости с ранними (2.x) версиями системы QUIK. Динамические формы ввода поддерживаются не для всех типов транзакций, для условных заявок рекомендуется использовать специализированные формы ввода;
      • Классический – включает отображение классических форм ввода заявок;
      • Специализированный (рекомендуется) – включает отображение специализированных форм ввода заявок. В этом режиме поддерживается расчёт дополнительных параметров формы ввода заявки. Если для транзакции нет ни специализированной формы ввода, ни классической, то отображается динамическая форма ввода.
    4. Использовать немодальные формы ввода – если флажок включен, то доступно вынесение формы ввода заявки за пределы основного рабочего окна программы, также доступно открытие одновременно нескольких форм ввода заявки. Для всех немодальных форм ввода в качестве иконки окна устанавливается иконка [image]. Немодальные формы ввода заявки поддержаны для всех режимов отображения форм ввода заявок (Динамический, Классический и Специализированный).
      • Отображать поверх всех окон – если флажок включен, то немодальные формы ввода заявок отображаются поверх всех окон. Опция доступна только при включенной настройке «Использовать немодальные формы ввода».

      Немодальные формы ввода открываются для следующих заявок:

      • Обычная заявка;
      • Заявка для фьючерсов и опционов;
      • Заявка с расчетом собственного и маржинального количества;
      • Адресная заявка РЕПО с ЦК;
      • Адресная заявка РЕПО с ЦК с КСУ;
      • Адресная заявка РЕПО Банка России с корзиной ценных бумаг;
      • Адресная заявка РЕПО (ГЦБ);
      • Адресная заявка РЕПО;
      • Специализированные формы ввода заявок (формы ввода с расчетом доходности, РЕПО-М).

    Параметры ввода данных:

    1. Вводить идентификатор фирмы вручную – если флажок установлен, то в окне ввода адресных заявок не показывается список контрагентов в поле «Партнер», наименование контрагента должно вводиться вручную. Настройка предназначена для возможности ввода заявок без получения с сервера Таблицы участников торгов – источника данных для списка контрагентов.
    2. Разделители разрядов в полях ввода – отображать значения цены и количества (объема) с разделителем групп разрядов во всех окнах ввода программы. Например: «1 234 567,89».

    Внебиржевые заявки

    меню Система / Настройки / Основные настройки… раздел «Торговля» / «Заявки» / «Внебиржевые заявки»

    Параметры внебиржевых заявок:

    1. Проверять цены на min-max для РПС, РЕПО и Подставлять текущую цену в заявку РЕПО – параметры адресных заявок.

    Замена заявок

    меню Система / Настройки / Основные настройки… раздел «Торговля» / «Заявки» / «Замена заявок»

    Параметры команды меню:

    1. Заменять заявки путем изменения их параметров – если флажок установлен, то при замене заявок выполняется поиск соответствующей транзакции с последующим открытием формы ввода заявки, на которой для редактирования доступны только те поля, которые присутствуют в найденной транзакции. При установленном признаке в контекстном меню Таблицы заявок отображается дополнительный пункт «Изменить параметры заявки». По умолчанию признак отключен.

    Параметры настроек Drag-and-Drop:

    1. По возможности заменять заявки путем изменения их параметров – если флажок установлен, то в Таблице котировок и графике при замене заявок в режиме drag-and-drop выполняется поиск соответствующей транзакции замены заявки. Если соответствующая транзакция не найдена или флажок «По возможности заменять заявки путем изменения их параметров» отключен, то выполняется снятие активной (заменяемой) заявки и выставление новой заявки с измененными параметрами. По умолчанию признак включен.


Закрытие позиций

меню Система / Настройки / Основные настройки… раздел «Торговля» / «Закрытие позиций»

Параметры закрытия позиций:

  1. Запрашивать подтверждение на закрытие позиций – показывать окно подтверждения при закрытии и перевороте позиций. При отключенном флажке закрытие и переворот позиций выполняется без подтверждения. По умолчанию признак включен.
  2. Снимать стоп-заявки перед закрытием позиций – при установленном флажке перед закрытием или переворотом позиции по инструменту снимаются все активные стоп-заявки по данному инструменту.


Клиентский портфель

меню Система / Настройки / Основные настройки… раздел «Торговля» / «Клиентский портфель»

Параметры работы с Клиентским портфелем:

  1. Обновлять через … секунд - устанавливает периодичность расчета данных в таблице «Клиентский портфель». Если флажок снят, то обновление данных в окне не производится.
  2. Пересчитывать при изменении позиций - включает пересчет значений в таблице «Клиентский портфель» после каждого изменения позиций у клиента. Если флажок выключен, то пересчет выполняется через интервал времени, установленный в предыдущем пункте, либо вручную.
  3. Файл с фильтром клиентов – фильтрация списка клиентов по указанным в выбранном файле значениям.

    Загружаемый файл должен содержать одну из секций:

    • [AllowedClients] – список клиентов фондового и срочного рынков, данные по которым отображаются в таблицах «Клиентский портфель»;
    • [ExcludedClients] – список клиентов фондового и срочного рынков, которые игнорируются при формировании таблиц «Клиентский портфель».
    Если в файле одновременно присутствуют секции [AllowedClients] и [ExcludedClients], то секция [ExcludedClients] игнорируется.

    Список клиентов представляет собой строки вида:

     <Код клиента фондового рынка / Торговый счет на срочном рынкеDESIGNTIMESP=14682>=

    Пример файла:

    [AllowedClients]

    Q1=

    Q2=

    Q7=

    При первичном указании, изменении или удалении пути к файлу, на экране появляется соответствующее сообщение о необходимости перезагрузки терминала, для вступления в силу новых значений.

    Чтение содержимого файла выполняется при запуске терминала, значения запоминаются и используются при формировании таблиц «Клиентский портфель», у которых в окне редактирования таблицы включен признак «Брать из файла».

  4. Отображать в портфеле клиентов – настройка отображения клиентов в таблице «Клиентский портфель»:
    • с отрицательными позициями по деньгам или инструментам – при установленной настройке в таблице «Клиентский портфель» отображаются:
      • Записи по клиентам спот-рынка, у которых разница текущего остатка и суммы заблокированных денежных средств меньше нуля;
      • Записи по клиентам спот-рынка, у которых разница текущего остатка и количества заблокированных на продажу инструментов меньше нуля;
      • Записи по клиентам срочного рынка с/без ЕДП, имеющим либо ненулевую текущую чистую позицию, либо активную заявку по инструментам срочного рынка на покупку или продажу.
    • с ненулевыми позициями по деньгам или инструментам – при установленной настройке в таблице «Клиентский портфель» отображаются:
      • Записи по клиентам спот-рынка, имеющим позиции по инструментам и/или деньгам при условии, что текущий остаток не равен нулю;
      • Записи по клиентам срочного рынка с/без ЕДП, имеющим либо ненулевую текущую чистую позицию, либо активную заявку по инструментам срочного рынка на покупку или продажу.
    • всех доступных (по умолчанию) – при установленной настройке в таблице «Клиентский портфель» отображаются все доступные клиенты, вне зависимости от их позиций.


Индикация статуса в клиентском портфеле

меню Система / Настройки / Основные настройки… раздел «Торговля» / «Клиентский портфель»

Параметры работы с Клиентским портфелем:

  1. Параметры фондового рынка - по умолчанию параметры используются для клиентов фондового рынка, у которых не настроена единая денежная позиция. Для использования данных параметров клиентами с единой денежной позицией выберите в настройке «При наличии единой денежной позиции использовать» значение «Параметры фондового рынка»:
    • Выделять цветом статус марж. клиентов фондового рынка * - при установленном флажке строки таблицы выделяются цветом в зависимости от статуса клиента.
    • Учитывать признак квалифицированности * - признак учета цветовых настроек для квалифицированных клиентов типа «МЛ» и «МП». По умолчанию признак отключен.
    • Статус:
      • Нормальный:
        • Для клиентов типа «МД» и «МД+»: для клиентов, стоимость портфеля которых больше либо равна скорректированной марже;
        • Для клиентов типа «МЛ» и «МП»: для клиентов, уровень маржи которых больше или равен ограничительному уровню маржи.
      • Ограничение:
        • Для клиентов типа «МД» и «МД+»: для клиентов, стоимость портфеля которых меньше скорректированной маржи и больше либо равна начальной марже;
        • Для клиентов типа «МЛ» и «МП»: для клиентов, уровень маржи которых больше или равен уровню маржи для необеспеченного требования, но меньше, чем ограничительный уровень маржи.
      • Требование:
        • Для клиентов типа «МД» и «МД+»: для клиентов, стоимость портфеля которых меньше начальной маржи и больше либо равна минимальной марже;
        • Для клиентов типа «МЛ» и «МП»: для клиентов, уровень маржи которых больше или равен уровню маржи принудительного закрытия, но меньше, чем уровень маржи для необеспеченного требования.
      • Закрытие:
        • Для клиентов типа «МД» и «МД+»: для клиентов, стоимость портфеля которых меньше минимальной маржи;
        • Для клиентов типа «МЛ» и «МП»: для клиентов, уровень маржи которых меньше, чем уровень маржи принудительного закрытия.
    • Параметры Цвет фона и Цвет текста * позволяют задать цвет фона и текста для строк таблицы в зависимости от их статуса. О работе с настройками цвета см. Основные принципы работы с программой.
    • Уровень маржи * – позволяет указать уровень маржи в процентах в зависимости от статуса строки в таблице. Значение указывается с точностью до двух знаков после десятичного разделителя. Значения по умолчанию:
      • «Ограничение»: 50.00;
      • «Требование»: 35.00;
      • «Закрытие»: 25.00.
    • Квалиф. клиенты * – уровень маржи в процентах для квалифицированных клиентов типа «МЛ» и «МП» в зависимости от статусов строк в таблице. Значение указывается с точностью до двух знаков после десятичного разделителя. Поля доступны для ввода при включенном флажке «Учитывать признак квалифицированности».

      Если одно или несколько полей не заполнены, значения уровня маржи для квалифицированных клиентов с соответствующими статусами совпадают со значениями, указанными в колонке «Уровень маржи». Значения по умолчанию:

      • «Ограничение»: 25.00;
      • «Требование»: 20.00;
      • «Закрытие»: 15.00.
  2. Параметры срочного рынка - по умолчанию параметры используются для клиентов срочного рынка, у которых не настроена единая денежная позиция. Для использования данных параметров клиентами с единой денежной позицией выберите в настройке «При наличии единой денежной позиции использовать» значение «Параметры срочного рынка»:
    • Выделять цветом клиентов срочного рынка * - при установленном флажке строки таблицы выделяются цветом в зависимости от статуса.
    • Статус:
      • Нормальный - для клиентов, уровень достаточности средств которых больше либо равен опасному уровню;
      • Опасный - для клиентов, уровень достаточности средств которых меньше опасного уровня и больше либо равен критическому уровню;
      • Критический - для клиентов, уровень достаточности средств которых меньше критического уровня.
    • Параметры Цвет фона и Цвет текста * позволяют задать цвет фона и текста для строк таблицы в зависимости от их статуса. О работе с настройками цвета см. Основные принципы работы с программой.
    • Уровень достаточности средств * – позволяет указать уровень достаточности средств для указанного статуса строки в таблице. Значение указывается с точностью до четырёх знаков после десятичного разделителя. Значения по умолчанию:
      • «Опасный»: 1.0000;
      • «Критический»: 0.0000.
  3. При наличии единой денежной позиции использовать - тип параметров, который используется для клиентов с единой денежной позицией:
    • Параметры фондового рынка;
    • Параметры срочного рынка.
    • Кнопка По умолчанию возвращает стандартные настройки параметров «Учитывать признак квалифицированности», «Цвет фона», «Цвет текста», «Уровень маржи», «Квалиф. клиенты» и «Уровень достаточности средств».
      (*) Данные параметры содержат значения по умолчанию и могут быть изменены в настройках Клиентского портфеля.

      Изменения вступают в силу при новом открытии Клиентского портфеля. Для уже открытого Клиентского портфеля функция выделения строк таблицы цветом включается в окне редактирования Клиентского портфеля установкой флажка «Выделять строки цветом», а цветовые настройки задаются в окне «Настройки цвета».


Котировки

меню Система / Настройки / Основные настройки… раздел «Торговля» / «Котировки»

Параметры работы с котировками:

  1. Двойной клик левой клавишей мыши – выбор события по указанному действию:
    • Выбор действия по клику левой мыши в Таблице котировок:
      • Выставить заявку (по умолчанию) — по двойному клику левой клавиши мыши открывать форму ввода заявки по инструменту из окна котировок, в поле количества в форме ввода устанавливать значение из текущей выбранной котировки в стакане;
      • Выставить OMS-заявку —по двойному клику левой клавиши мыши открывать форму ввода OMS-заявки по инструменту из окна котировок, в поле количества в форме ввода устанавливать значение из текущей выбранной котировки в стакане.
      • + CTRL:
        • Выставить заявку на сумму лучших – заполнять поле «Количество» значением поля «Сумма лучших»;
        • Выставить алгоритмическую айсберг-заявку * – открыть форму ввода алгоритмической айсберг-заявки;
        • Выставить айсберг-заявку торговой системы * – открыть форму ввода новой айсберг-заявки.
      • + SHIFT:
        • Выставить заявку на сумму лучших – заполнять поле «Количество» значением поля «Сумма лучших»;
        • Выставить алгоритмическую айсберг-заявку * – открыть форму ввода алгоритмической айсберг-заявки;
        • Выставить айсберг-заявку торговой системы * – открыть форму ввода новой айсберг-заявки.

        (*) Форма ввода заявки открывается только при наличии у пользователя прав на активные операции по соответствующему классу инструментов.
    • Двойной клик правой клавишей мыши – выбор события по указанному действию:
      • Создание графика цены и объема – открыть окно графика;
      • Снятие заявки – отозвать из торговой системы активную заявку в выбранной строке Таблицы котировок.
  3. Установка количества лотов транзакции – определяет значение поля «Количество», заполняемое автоматически при вводе заявки из «Таблицы котировок»:
    • Брать количество – значение поля «Объем»;
    • Брать сумму лучших – значение поля «Сумма лучших».
  4. При отсутствии котировок использовать таблицу «Текущие торги» – формирование стакана по лучшим ценам спроса и предложения, полученным из Таблицы текущих торгов, в случае, когда котировки недоступны.


Объединенные котировки

меню Система / Настройки / Основные настройки… раздел «Торговля» / «Котировки» / «Объединенные котировки»

Параметры работы с объединенными котировками:

  1. Разделение объема заявки – параметр ввода заявки из таблицы «Объединенные котировки». По умолчанию признак отключен.
  2. Снимать остаток – признак снятия остатка при вводе объединенной заявки из таблицы «Объединенные котировки».


ЭЦП

меню Система / Настройки / Основные настройки… раздел «Торговля» / «ЭЦП»

Параметры настройки электронной цифровой подписи:

  1. ЭЦП – использование ЭЦП для подписи транзакций:
    • Делать ЭЦП на СКЗИ – активизирует функцию электронной цифровой подписи (ЭЦП) всех активных операций выбранной из списка системой криптографической защиты информации (СКЗИ). Применение ЭЦП регламентируется администратором системы QUIK.


Настройка счетов

меню Система/Настройки/Основные настройки... раздел «Торговля» / «Настройка счетов»

Назначение

Выбор счетов, отображаемых в окне ввода заявки, из числа доступных пользователю. Настройка очередности следования счетов в списке.

Настройка счетов не распространяется на формы ввода заявок по переводу денежных средств.

Настройка

Для настройки достаточно сформировать список выбранных счетов, выделяя в списке доступных нужные счета и нажимая кнопку «Добавить». Отображение в списке доступных значений торговых счетов со статусом «Операции запрещены» можно включить в основных настройках (см. Параметры торговли).

Нажатием кнопки «Добавить все» в список выбранных перемещаются все доступные счета депо.

Если список содержит большое количество счетов, удобно пользоваться кнопками «Добавить в начало» и «Добавить в конец». В этом случае выделенные счета в списке доступных добавляются в начало либо в конец списка выбранных.

Для удаления одного счета из списка выбранных достаточно выделить его и нажать кнопку «Убрать», либо дважды нажать на нем левую кнопку мыши. Чтобы удалить все счета из списка, нажмите кнопку «Очистить».

В диалоге настройки счетов отображается код фирмы, к которой принадлежит конкретный счет. Это облегчает задачу поиска нужных счетов в случае их дублирования в разных фирмах (например, один и тот же счет может фигурировать в разных разделах срочного рынка Московской Биржи).

Порядок следования счетов в списке выбранных изменяется нажатием кнопок справа от списка:

  • - в начало списка;
  • - на одну позицию вверх;
  • - на одну позицию вниз;
  • - в конец списка.
При перемещении по списку группы выделенных счетов порядок их следования сохраняется.


Настройка параметров инструментов

меню Система / Настройки / Параметры инструментов...

Назначение

Установление возможных границ цены заявки, параметров открытия и закрытия позиции по различным инструментам.

Если по инструменту назначена граница, то система QUIK производит проверку соответствия цены заявки заданной границе и предотвращает передачу в торговую систему биржи заявок с заведомо ошибочным значением цены.

Контроль диапазонов приемлемых цен выполняется на Рабочем месте пользователя QUIK. Это означает, что для выполнения проверки необходимо получение значений указанных параметров (в зависимости от настроек - для выбранного инструмента, для всех инструментов выбранного класса либо для всех инструментов) с сервера QUIK. Если в настройках программы включен признак получения данных «Исходя из настроек открытых пользователем таблиц» (меню Система/Настройки/Основные настройки..., раздел «Программа» / «Получение данных»), то при установке диапазонов цен нужные параметры автоматически добавятся в список получаемых данных.

Настройка

В левой части окна «Параметры инструментов» отображается список настроенных диапазонов. Кнопки в нижней части окна позволяют редактировать данный список:

  1. «Добавить» – добавить новый диапазон, При добавлении нового диапазона заполните следующие поля:

    • «Класс инструмента» – выбор названия класса либо значения «*(Любой)»;
    • «Инструмент» – выбор названия инструмента либо значения «*(Любой)».

    Возможно добавление следующих типов диапазонов:

    • «Для всех» – в диапазон включены все инструменты всех классов;
    • «Для класса» – в диапазон включены все инструменты указанного класса;
    • «Для инструмента» – в диапазон включен указанный инструмент выбранного класса или всех классов.

      Наиболее приоритетным является диапазон значений для инструмента определенного класса. Если инструмент не задан, то проверяется ограничение для всех инструментов определенного класса, и в последнюю очередь – глобальная настройка диапазона для всех инструментов по всем классам.
  2. «Удалить» – удалить выбранный диапазон.
  3. «Очистить» – удалить все диапазоны из списка.

В правой части окна «Параметры инструментов» доступны для редактирования настройки выбранного диапазона:

  1. Признак «Открытие позиции» – задание параметров новой заявки, используемых по умолчанию:
    • Поле «Количество <…> лотов» – задание рабочего количества в лотах;
    • Флажок «Брать при перевороте позиции» – использовать объем, указанный в поле «Количество <…> лотов» при выполнении операции переворота позиции, вызываемой из окна «Состояние счета» с помощью кнопки [image] «Перевернуть», расположенной на вкладке «Позиции».
  2. Признак «Контролировать цены заявок» – задание возможных границ цены заявки в виде максимального отклонения от текущего значения выбранного параметра: цены закрытия, средневзвешенной цены либо цены последней сделки.
    • Поле «MIN» – предельное отклонение цены вниз. Параметр контролируется только в заявках на продажу;
    • Поле «MAX» – предельное отклонение цены вверх. Параметр контролируется только в заявках на покупку.

    1. Если добавлено ограничение с точкой отсчета отклонения по параметрам «Средневзвешенная цена» или «Цена последней сделки», но значение этих параметров не задано или равно «0», то отклонение считается от значения параметра «Цена закрытия».
    2. При установке только одной из границ проверяется только одно предельное значение цены.
  3. Признак «Закрытие и переворот позиции» – настройка способа закрытия и переворота позиции:
    • Переключатель «Рыночной заявкой» – позиция закрывается рыночной заявкой;
    • Переключатель «Лимитированной, отступ < =» – позиция закрывается лимитированной заявкой. При выборе данного способа закрытия позиции укажите величину отклонения цены выставляемой лимитированной заявки от лучшей встречной цены в процентах или в шагах цены.

    Настройки применяются по умолчанию для закрытия и переворота позиций по командам из таблицы «Состояние счета».

  4. Поле «Глубина стакана» – задание глубины стакана котировок на покупку и на продажу. Значение по умолчанию: «0» (получение всех доступных котировок).

Параметры диапазона устанавливаются нажатием кнопки «Сохранить». Кнопка «Отменить» предназначена для закрытия окна без сохранения изменений. Нажатие кнопки «Справка» вызывает справку по данным настройкам.

По одному инструменту либо классу можно задать только один диапазон цен. Повторное назначение диапазона допустимых цен с другими параметрами приведет к отмене предыдущего ограничения и включению нового.

Проверка включается установкой флажка «Проверять попадание цены в диапазон» в меню Система/Настройки/Основные настройки..., раздел «Торговля» / «Заявки».

Если при подаче заявки не пройдена проверка на попадание цены в указанный диапазон, то на экране появляется соответствующее сообщение с запросом разрешения исполнения заявки. При нажатии кнопки «Да» проверка игнорируется, и заявка выставляется на покупку / продажу.

Сервер системы QUIK может проводить дополнительную проверку цен заявок на соответствие диапазону цен, установленных на сервере администратором системы. Эта проверка не зависит от настроек ценовых диапазонов, заданных пользователем.

См. также: Формат файла настроек.


Формат файла настроек

Настройки диапазонов допустимых цен заявок хранятся в файле price_limits.ini, расположенном в каталоге с файлами Рабочего места QUIK.

Структура файла настроек:

  1. Секция [GLOBAL_LIMITS] содержит описания диапазонов, установленных для всех инструментов:
    • «ORIGIN» – точка отсчета относительной величины. Возможные значения:
      • «last» - цена последней сделки;
      • «average» - средневзвешенная цена;
      • «close» - цена закрытия.
    • «MIN» – минимальное отклонение для заявок на продажу;
    • «MAX» – максимальное отклонение для заявок на покупку.
  2. Секция [CLASS_LIMITS] содержит описания диапазонов, установленных для классов инструментов:
    • «ORIGIN_КОД_КЛАССА» – точка отсчета относительной величины. Возможные значения:
      • «last» - цена последней сделки;
      • «average» - средневзвешенная цена;
      • «close» - цена закрытия.
    • «MIN_КОД_КЛАССА» – минимальное отклонение для заявок на продажу;
    • «MAX_КОД_КЛАССА» – максимальное отклонение для заявок на покупку.
  3. Секция [SECURITIES_LIMITS] содержит описания диапазонов, установленных для инструментов:
    • «ORIGIN_КОД_КЛАССА|КОД_ИНСТРУМЕНТА» – тип ограничения и точка отсчета относительной величины. Возможные значения:
      • «abs» - по абсолютному значению;
      • «last» - цена последней сделки;
      • «average» - средневзвешенная цена;
      • «close» - цена закрытия.
    • «MIN_КОД_КЛАССА|КОД_ИНСТРУМЕНТА» – минимальная граница (или отклонение) для заявок на продажу;
    • «MAX_КОД_КЛАССА|КОД_ИНСТРУМЕНТА» – максимальная граница (или отклонение) для заявок на покупку.

Символ «|», служащий разделителем кода класса и кода инструмента, набирается нажатием клавиш «Shift»+«\» в латинской раскладке клавиатуры.

Пример файла настроек:

[GLOBAL_LIMITS]
 ORIGIN=close
 MIN=10.00
 MAX=10.00
[CLASS_LIMITS]
 ORIGIN_RPMO=last
 MIN_RPMO=12.00
 MAX_RPMO=12.00
[SECURITIES_LIMITS]
 ORIGIN_RPMO|GAZP01=close
 MIN_RPMO|GAZP01=15.00
 MAX_RPMO|GAZP01=15.00
 ORIGIN_TQBR|LKOH=average
 MIN_TQBR|LKOH=15.00
 MAX_TQBR|LKOH=15.00


Снятие заявок по условию

меню Сервисы / Снятие заявок по условию...
  • Назначение
  • Выполнение
  • Результат выполнения

    • Назначение

    Функция позволяет отозвать группу активных заявок, удовлетворяющих заданному условию.

    Доступ к функции осуществляется из пункта меню Сервисы / Снятие заявок по условию... либо нажатием клавиш «Shift»+«Alt»+«D».

    Снятие заявок по условию (всех заявок, всех на покупку, всех на продажу по данному инструменту) может быть выполнено из Таблицы котировок, нажатием на кнопки на специальной панели инструментов.

    Выполнение

    1. «Снимать» – выбор типа снимаемых заявок:
      • «Заявки» – активные заявки в торговой системе биржи;
      • «Стоп-заявки» – активные стоп-заявки на сервере QUIK;
      • «Адресные заявки» – активные адресные заявки (для режимов РПС и РЕПО) в торговой системе биржи;
      • «Адресные заявки партнера» – активные адресные заявки партнера, выставленные на выбранную фирму, в торговой системе биржи.
      Снятие по условию для безадресных заявок РПС и РЕПО не предусмотрено.
    2. «Операция» – выбор направления операции, указанного в отзываемых заявках.
    3. «Доступные фирмы» – список для выбора кода фирмы (участника торгов). Как правило, разным рынкам соответствуют разные коды участников торгов. Чтобы снять заявки по какому-то классу, нужно выбрать тот код фирмы, при котором требуемый класс отображается в списке инструментов.
    4. «Снять все заявки по фирме» – при установленном флажке отзываются все неисполненные заявки по указанному коду фирмы.
    5. «Код клиента» – список кодов клиента, указанных пользователем в активных заявках. Если пользователю доступен только один код клиента, поле заполняется автоматически, если доступно несколько, то потребуется выбрать один из списка. Значение <Пустой элемент> заявкам, введенным без указания кода клиента.
      • «все клиенты» – при установленном флажке заявки снимаются независимо от указанного в них кода клиента.
    6. «Счет депо» – список счетов депо, доступных пользователю для совершения операций при выбранном коде фирмы. Чтобы снять заявку по определенному счету, выберите его из списка.
      • «все счета» – при установленном флажке заявки снимаются независимо от указанного в них счета депо.
    7. «Инструменты» – список инструментов, доступных для операций с выбранным кодом фирмы (см. п.1). Для снятия заявки по конкретному инструменту нужно выбрать его из списка доступных и нажать кнопку «Добавить».
      • «все инструменты» – при установленном флажке снимаются заявки по всем инструментам.
    8. Нажатие кнопки «Снять заявки» закрывает окно и выполняет отзыв заявок в соответствии с настроенными условиями. Нажатие кнопки «Отмена» закрывает окно без выполнения операции.

    Результат выполнения

    В результате операции снятия заявок система QUIK анализирует Таблицу заявок, Таблицу стоп-заявок и Таблицу безадресных заявок на внебиржевые сделки на рабочем месте клиента и формирует пакет поручений на отзыв тех заявок, которые соответствуют заданным условиям. В Окне сообщений отображается количество сформированных поручений на отзыв по каждому типу заявок, по которому производится снятие. Результат снятия каждой заявки также отображается в Окне сообщений в таком же виде, как и при отзыве заявки вручную.

    См. также Управление заявками из Таблицы котировок


Настройки автозаполнения полей ввода заявки

  • Назначение
  • Формат файла настроек автоподстановки
  • Настройка списка кодов клиента
  • Заполнение полей «Код клиента»/«Торговый счет клиента» и «Комментарий»
  • Заполнение поля «Количество»
  • Заполнение поля «Ссылка»

    • Назначение

    Функционал программы позволяет при формировании новой транзакции задавать соответствия между параметрами «Класс/Инструмент/Операция» и следующими параметрами, заполняемыми автоматически:

    • «Код клиента», «Комментарий» - при вводе транзакций типов «Ввод заявки», «Ввод адресной заявки», «Ввод стоп-заявки».
    • «Торговый счет», «Комментарий» - при вводе заявок по фьючерсам или опционам.
    • «Количество» - при вводе заявок всех типов.
    • «Ссылка» - при вводе заявок РЕПО и РПС.

    В результате, при выборе в форме ввода транзакций определенного инструмента и операции, в указанных полях подставляются определенные значения.

    Поле «Код клиента» формы ввода заявки содержит выпадающий список с доступными кодами клиентов. Этот список формируется автоматически по данным, сообщаемым сервером для всех классов, и может быть большим. Если используется несколько кодов клиента на одном классе инструментов, то настроек автозаполнения поля «Код клиента» одним значением может быть недостаточно. В этом случае можно указать в файле настроек собственные списки кодов, которые будут отображаться в форме ввода заявки в зависимости от указанного класса инструментов. При этом, все остальные настройки автозаполнения поля «Код клиента» будут действовать, если код, выбираемый по указанным правилам, присутствует в списке кодов для данного рынка.

    Формат файла настроек автоподстановки

    Соответствия задаются в текстовом файле специального формата. Имя файла и путь до него должны быть указаны в настроечном файле INFO.INI в секции [General] значением параметра «default-clients-file».

    Пример файла INFO.INI:

    [general]
    … …
    default-clients-file=D:\Program Files\QUIK\default_client_codes.ini
    … …

    Параметры подстановки описываются в файле default_client_codes.ini в виде отдельных секций для каждого класса. Секция [Global] описывает глобальные настройки автоподстановки примечания в заявке.

    Пример файла default_client_codes.ini:

    [global]
set-comment-mode=1
sell-default-client-code=//global
buy-default-client-code=//global
[TQBR]
    sell-default-client-code=Q5
    buy-lkoh=Q8/3
    msng=Q9

    [RPMA]
    sell-default-client-code=Q8
    sell-default-matchref="asdf"
    sell-default-quantity=100

    Настройка списка кодов клиентов

    Настройка перечня кодов клиентов, отображаемых в выпадающем списке в окне ввода заявки, осуществляется по следующему принципу:

    1. Классы инструментов, для которых будет использоваться один и тот же список кодов клиентов, объединяются в «рынки». Настройка осуществляется в секции [MARKETS], строками вида <название_рынка>=<список_классов_через_запятую>.
      Каждый класс может быть включен только в один «рынок». Если в настройках обнаружено вхождение одного класса в состав разных рынков, то программа выдаст сообщение об ошибке с указанием имени рынка и класса, и продолжит обработку, игнорируя повторные вхождения.

      Пример настроек:

      [MARKETS]

      FUTURES=SPBFUT

      CORPORATIVE=TQBR, SPBFUT

      BQ=BQUOTES

      OPTIONS=SPBOPT

      В примере класс SPBFUT принадлежит рынку FUTURES, в описании рынка CORPORATIVE он будет проигнорирован.

    2. Для каждого «рынка» указывается список кодов клиентов. Настройка осуществляется в секции [MARKETS_CLIENT_CODES] строками вида<название_рынка>= <список_кодов_клиентов_через_запятую>

      Пример настроек:

      [MARKETS_CLIENT_CODES]
      FUTURES =SPBFUT000121, SPBFUT000122
      CORPORATIVE =Q1, Q2, Q9
      BQ=

      В примере список кодов клиентов для рынка BQ и класса BQUOTES будет пустым. Для рынка OPTIONS список кодов клиентов не указан и по нему будут показаны все коды клиентов без применения фильтра.

    Заполнение полей «Код клиента»/«Торговый счет клиента» и «Комментарий»

    Заполнение полей «Код клиента» («Торговый счет клиента» - для срочных контрактов) и «Комментарий» может быть установлено по следующим признакам:

    1. По инструменту и направлению операции - параметрами «sell-<код инструмента>» для заявок на продажу по указанному инструменту и «buy-<код инструмента>» для заявок на покупку по указанному инструменту, код клиента и комментарий разделяются символами «/» или «//», в зависимости от настроек сервера QUIK.
    2. По классу инструмента и направлению операции - параметрами «sell-default-client-code» для заявок на продажу и «buy-default-client-code» для заявок на покупку.
    3. По инструменту вне зависимости от направления операции - параметром «<код инструмента>».
    4. Глобальной настройкой автоподстановки поля «Комментарий».

    Глобальная настройка автоподстановки указывается в секции [Global]. Применение глобальной настройки управляется параметром «set-comment-mode», который может быть указан как в секции [Global], так и в секции настроек для какого-либо класса. Параметр может принимать следующие значения:

    • «0» – применение глобальной настройки отключено;
    • «1» – включено автозаполнение поля «Комментарий» значением глобальной настройки, значение берется из параметра «sell-default-client-code» для заявок на продажу и «buy-default-client-code» для заявок на покупку в секции [Global]. Если в параметрах указан код клиента, то он игнорируется. Например, если параметром «sell-default-client-code=77//global» задана подстановка кода клиента «77» и комментария «global», то код клиента не будет использоваться для автоподстановки.

    В случае, если условиям заявки соответствует несколько настроек подстановки значений, выбирается настройка, имеющая больший приоритет (в порядке убывания):

    1. Значение из Фильтра клиента при включенной настройке «Подставлять код клиента из фильтра в формы подачи заявок».
    2. «sell-<код инструмента>» или «buy-<код инструмента>».
    3. «<код инструмента>».
    4. «sell-default-client-code» или «buy-default-client-code».
    5. Значение глобальной настройки из секции [Global].
    6. Значение из настроек программы (пункт основного меню Система / Настройки / Основные настройки... , раздел «Торговля», поле «Код клиента», при включенном флажке «Всегда брать код клиента по умолчанию»).
    Если код клиента, найденный в настройке автозаполнения, НЕ входит в пользовательский список кодов клиента (см. Настройка списка кодов клиентов ) для класса по которому подается заявка, поле «Код клиента» не заполняется автоматически.

    Пример настроек:

    [global]
    set-comment-mode=1
    sell-default-client-code=//global
    buy-default-client-code=//global

    [SPBFUT]
    sell-default-client-code=SPBFUT0001/12345
    buy-default-client-code=SPBFUT0002/6789

    [TQBR]
    sell-rtkm=Q8/2/коммент
    buy-rtkm=Q8/3/коммент
    msng=Q9

    [RPMA]
    set-comment-mode=0
    sell-default-client-code=Q8
    buy-default-client-code=Q8
    sell-default-matchref="asdf"
    buy-default-matchref="qwer"
    Комментарии к примеру:
    1. В секции [Global] включено использование глобальных настроек – в заявке заполняется комментарий «global».
    2. Для класса SPBFUT не указан параметр «set-comment-mode», его значение будет браться из секции [Global]. Значение кода клиента и комментария для SPBFUT задано и будет использоваться либо SPBFUT0001/12345 (на продажу), либо SPBFUT0002/6789 (на покупку), а не //global.
    3. Для класса TQBR не указан параметр «set-comment-mode», его значение будет браться из секции [Global]. Значение кода клиента и комментария для TQBR задано для инструмента RTKM, для всех остальных «Комментарий» будет браться из секции global.
    4. Для класса RPMA настройка «set-comment-mode» выключена, поэтому глобальная настройка игнорируется.

    При формировании транзакций (ввод заявки, ввод стоп-заявки, ввод заявок РЕПО и РПС) в поля «Код клиента» («Торговый счет клиента», в случае выбора транзакции по срочному рынку) и «Комментарий» подставляются значения в зависимости от способа вызова формы ввода транзакции и состояния флажка в настройках программы (пункт основного меню Система / Настройки / Основные настройки..., раздел «Торговля», флажок «Всегда брать код клиента по умолчанию»):

    • Включенная опция «Всегда брать клиента по умолчанию» означает, что при вызове форм ввода транзакций (заявки, стоп-заявки, заявки РЕПО или РПС) поля «Код клиента» и «Комментарий» будут заполняться значениями из файла настроек независимо от способа вызова формы (с помощью панели инструментов, через меню, двойным нажатием левой кнопки мыши на строке таблицы или Окна котировок). При смене операции или инструмента в уже открытой форме ввода транзакции будет произведено повторное обращение к файлу настроек default_client_codes.ini и, при надобности, будут изменены поля «Код клиента» и «Комментарий».
    • Отключенная опция «Всегда брать клиента по умолчанию» означает, что при вызове форм транзакций из таблиц в поля «Код клиента» и «Комментарий» будут подставлены значения из выбранной строки таблицы. Если в выбранной строке таблицы не были заполнены поля «Код клиента» и «Комментарий», то в них осуществляется автоподстановка значений из файла настроек default_client_codes.ini.
    Весь вышеупомянутый функционал распространяется на стандартные и нестандартные формы ввода транзакций.

    Заполнение поля «Количество»

    Заполнение поля «Количество» не зависит от выбранного кода клиента и может быть установлено по следующим признакам:

    1. По инструменту и направлению операции - параметрами «sell-quantity-<код инструмента>» для заявок на продажу по указанному инструменту и «buy-quantity-<код инструмента>» для заявок на покупку по указанному инструменту.
    2. По классу инструмента и направлению операции - параметрами «sell-default-quantity» для заявок на продажу и «buy-default-quantity» для заявок на покупку.
    3. По инструменту вне зависимости от направления операции - параметром «quantity-<код инструмента>».

    В случае, если условиям заявки соответствует несколько настроек подстановки значений, выбирается настройка, имеющая больший приоритет (в порядке убывания):

    1. «sell-quantity-<код инструмента>» или «buy-quantity-<код инструмента>».
    2. «quantity-<код инструмента>».
    3. «sell-default-quantity» или «buy-default-quantity».
    4. Значение количества лотов по умолчанию из настроек программы (пункт основного меню Система / Настройки / Основные настройки..., раздел «Торговля», поле «Кол-во лотов»).

    Пример настроек:

    [TQBR]
    sell-quantity-rtkm=300
    buy-quantity-rtkm=400
    quantity-lkoh=500

    [RPMA]
    sell-default-quantity=100
    buy-default-quantity=200

    Заполнение поля «Ссылка»

    Заполнение поля «Ссылка» для заявок РЕПО и РПС не зависит от выбранного кода клиента и может быть установлено по следующим признакам:

    1. По инструменту и направлению операции - параметрами «sell-matchref-<код инструмента>» для заявок на продажу по указанному инструменту и «buy-matchref-<код инструмента>» для заявок на покупку по указанному инструменту.
    2. По классу инструмента и направлению операции - параметрами «sell-default-matchref» для заявок на продажу и «buy-default-matchref» для заявок на покупку.
    3. По инструменту вне зависимости от направления операции - параметром «matchref-<код инструмента>» для всех операций по указанному инструменту.

    В случае, если условиям заявки соответствует несколько настроек подстановки значений, выбирается настройка, имеющая больший приоритет (в порядке убывания):

    1. «sell-matchref-<код инструмента>» или "buy-matchref-<код инструмента>».
    2. «matchref-<код инструмента>».
    3. «sell-default-matchref» или «buy-default-matchref».

    Настройки данных параметров действительны только для классов, по которым возможны операции РЕПО.

    Пример настроек:

    [RPMA]
    sell-default-matchref="asdf"
    buy-default-matchref="qwer"
    sell-matchref-msng="ref001"
    buy-matchref-msng="ref002"
    matchref-msng="mosenergo"


Настройка ограничений на объем заявки

  • Назначение
  • Настройка ограничений
    •

    Назначение

    Пользователь может установить ограничение на объем заявки, отправляемой в торговую систему. Данная проверка осуществляется на Рабочем месте QUIK в момент нажатия кнопки «Ввод» в окне ввода заявки, в том числе при создании отложенной заявки в «Кармане транзакций». Ограничение объема устанавливается в целом на класс с указанием валюты (в общем случае может отличаться от той, в которой торгуется инструмент). Можно задать отдельные ограничения на покупку и на продажу, либо общее ограничение (приоритет его будет ниже, чем ограничение по операции). Если ограничение не задано, то проверка не производится.

    При проверке рассчитывается объем заявки согласно правилам, приведенным в окне «Ввод заявки».

    Полученное значение объема приводится к валюте, в которой задано ограничение и осуществляется проверка. Если полученный объем превышает объем, указанный в ограничении, то будет выдано предупреждение вида «Объем заявки XXX в валюте YYY превышает максимальный допустимый объем ZZZ», а заявка не отправится. Окно ввода заявки при этом остается открытым, для возможности изменения количества инструментов в заявке.

    Настройка ограничений

    Ограничения описываются в текстовом файле специального формата. Имя файла и путь до него должны быть указаны в настроечном файле INFO.INI в секции [General] значением параметра «default-clients-file».

    Пример файла INFO.INI:

     [general]
    … …
    default-clients-file=D:\Program Files\QUIK\default_client_codes.ini
    … …

    Параметры ограничений описываются в файле default_client_codes.ini в виде отдельных секций для каждого класса. В секции указываются следующие ключи:

    • max-buy-volume – ограничение объема на покупку;
    • max-sell-volume – ограничение объема на продажу;
    • max-volume – ограничение и на покупку и продажу;
    • volume-currency – символьный код валюты, в которой указан объем («SUR», «USD», «UAH» и тд). Если валюта не указана, то считается, что объем выражен в той валюте, в которой торгуется инструмент. Если валюта указана, и она отличается от денежной единицы по умолчанию, то необходимо убедиться, что с сервера принимается класс «Кросс-курсы валют» и в нем присутствует код указанной валюты (о настройке см. «Изменение денежной единицы»).

    Значения ограничений объема могут быть указаны с любой точностью, в качестве десятичного разделителя могут использоваться символ «.» (точка) или символ, указанный в региональных настройках Windows.

    Пример настроек:

    [TQBR]
    max-buy-volume=20000.00
    max-volume=50000.00
    volume-currency=SUR


Описания клиентов и рынков

  • Замена кодов клиентов на описания
  • Группировка классов инструментов в рынки
    •

    Замена кодов клиентов / фьючерсных счетов клиентов на описания

    Вместо значений кодов клиентов или фьючерсных счетов клиентов можно использовать их описания, например, фамилии с инициалами.

    Эта возможность предназначена для пользователей, ведущих торговлю по нескольким счетам клиентов или администраторов брокера (субброкера), контролирующих действия клиентов. Замена кодов/фьючерсных счетов отображается в окне ввода заявки, таблицах программы и фильтрах. Например, вместо клиента с кодом «486/17» отображается «Петров П.П.».

    Благодаря тому, что описания хранятся в файле на компьютере пользователя, субброкер может использовать их для своего удобства, не раскрывая своему обслуживающему брокеру персональную информацию о пользователях QUIK.

    Подстановка описаний выполняется следующим образом:

    1. В папке, где установлена программа QUIK, создайте текстовый файл clients.ini, в котором пропишите коды и соответствующие им описания в виде строк <код клиента>=<описание> или <фьючерсный счет клиента>=<описание>.

      Пример файла:

      [clients_fio]

      100=Иванов А.А

      101=Петров Б.Б.

      101/2=Смирнов В.В.

      Если в файле используются русские буквы, они должны быть в windows-кодировке (CP-1251).

    2. Выберите пункт меню программы Система/Настройки/Основные настройки…, раздел «Торговля». Установите флажок «Заменять коды клиентов на их ФИО», нажмите на кнопку «…» и выберите файл с описанием кодов клиентов. Затем нажмите кнопку «ОК».
    3. Изменения вступают в силу после перезапуска программы.

    В описании клиента не допускается использование символа «/».

    Группировка классов инструментов в рынки

    Классы инструментов с одинаковыми правилами торгов либо расчетов можно объединять в «рынки», с русскоязычным текстовым наименованием, для использования в «Общем фильтре по рынкам» (меню программы Система/Настройки/Основные настройки…, раздел «Программа» / «Панели инструментов» пункт «Общий фильтр по рынкам»). Таким образом можно быстро применять фильтр по классам инструментов к открытым и вновь создаваемым таблицам.

    Подстановка описаний выполняется следующим образом:

    1. В папке, где установлена программа QUIK, создайте текстовый файл markets.ini с описанием рынков.

      Пример файла:

      [markets]
      ММВБ корп Акции и Облигации = TQBR,TQBS,TQNB,TQNE,TQNL

      ММВБ корп РПС и РЕПО = PSNO,PSAU,PSOB,PSNE

      ФОРТС = SPBFUT,SPBOPT
    2. Выберите пункт меню Система/Настройки/Основные настройки…, раздел «Торговля». Нажмите на кнопку «…» в поле «Файл настроек рынков» и выберите файл с описанием рынков. Затем нажмите кнопку «ОК».
    3. Изменения вступают в силу после перезапуска программы.


Сообщения об ошибках

  • Кнопка «Т» неактивна (серая)
  • Сообщения системы при вводе заявки
  • Сообщения системы при замене заявки

    • Кнопка «Т» неактивна (серая)

    Пользователю запрещены торговые права

    • Администратором системы не установлены пользователю права на совершение активных операций. Обратитесь к администратору системы QUIK.

    Торги закрыты

    • Во время этого сеанса связи с сервером не проводится ни одной торговой сессии и совершение операций на них невозможно.

    Нет связи между рабочим местом QUIK и сервером

    • Совершение активных операций возможно только при наличии связи между пользователем, сервером QUIK и торговой системой. Убедитесь, что связь с сервером установлена - индикатор в правом нижнем углу программы должен иметь зеленый цвет.

    Нет связи между сервером QUIK и торговой системой

    • Вероятно, произошел сбой в работе шлюза между торговой системой биржи и сервером QUIK. При отсутствии уведомлений о неполадках обратитесь к администратору сервера.

    Сообщения системы при вводе заявки

    Сообщение | Значение
Не задан лимит по инструменту | Пользователю не установлен лимит по инструменту. Обратитесь к администратору системы QUIK
Не задан лимит пользователя по деньгам | Администратором системы не установлен лимит пользователя по деньгам. Обратитесь к администратору системы
Превышен лимит по инструменту | В заявке указано количество инструментов, превышающее лимит доступных средств
Превышен лимит по деньгам | Количество денежных средств, необходимое для исполнения заявки, превышает лимит пользователя по деньгам
Вы не имеете прав для работы по данному торговому счету [ ] | Пользователю не сопоставлен счет депо. Возможно, не задан лимит по инструментам. Обратитесь к администратору системы QUIK
Вам запрещена работа по данному торговому счету | Указанный в заявке счет не соответствует номеру счета для операций клиента
Вам запрещена работа по данному инструменту | Администратором системы введен запрет на совершение операций по этому инструменту
Неверно указан финансовый инструмент | Ошибка указания в заявке кода инструмента
Невозможно выполнение транзакций по классу [имя класса]. Шлюз с торговой системой не работает | Прием заявок по данному классу инструментов невозможен из-за отсутствия связи между сервером QUIK и торговой системы биржи. Дождитесь восстановления связи (кнопка <Т> на панели инструментов должна стать активной)
Подача заявок в данный момент запрещена | Торги по инструменту приостановлены. Следите за сообщениями администратора системы о возобновлении торгов
Рыночная заявка на покупку для клиентского счета запрещена | Администратором системы установлен запрет рыночных заявок на покупку
Вы не можете выставлять заявки без покрытия | Администратором системы введен запрет продажи без покрытия (short)
Указанная в заявке цена больше установленной для данного инструмента максимально допустимой цены | Цена заявки не соответствует диапазону приемлемых значений цены, установленному пользователем
Указанная в заявке цена меньше установленной для данного инструмента минимально допустимой цены
Цена заявки не соответствует установленному диапазону | Цена заявки не соответствует диапазону приемлемых значений цены, установленному на сервере
Цена заявки должна быть положительной | Введена отрицательная цена заявки
Цена операции short выходит за установленный диапазон | Превышено ограничение цены заявки для продажи без покрытия
Превышена позиция по деньгам. Инструмент не входит в список для работы с плечом. | Использование заемных средств на покупку инструментов, не включенных в список инструментов для маржинальных операций, запрещено администратором. Покупка таких инструментов возможна только на собственные средства клиента (текущий остаток по денежным средствам).
Открыт short. Инструмент не входит в список для работы с плечом. | Запрещено использование денежных средств, полученных от продажи без покрытия, на покупку инструментов, не включенных в список инструментов для маржинальных операций. Покупка таких инструментов недоступна при использовании клиентом заемных инструментов брокера.
Ошибка при подписывании транзакции | Ошибка обращения к программному обеспечению электронной цифровой подписи
Превышено максимально возможное количество инструментов | В заявке указано количество инструментов, превышающее лимит доступных клиенту средств

    Сообщения системы при замене заявки

    Сообщение | Значение
Заявку с номером [ ] нельзя изменить, так как операция замены для инструмента [ ] не поддерживается | Данная торговая система, либо режим торгов, не поддерживают возможность замены заявки. Снимите заявку и введите новую.
Заявку с номером [ ] нельзя изменить, так как ее не удалось снять | В торговой системе нет активной заявки с таким номером. Номер заявки указан неверно, либо эта заявка уже снята.
Заявку с номером [ ] нельзя изменить, так как она полностью удовлетворена | Заявка с таким номером в торговой системе имеет статус «исполнена»


Раздел 6. Совместная работа с другими приложениями

  • Экспорт данных через DDE-сервер
  • Использование ODBC для экспорта информации
  • Экспорт инструментов по ODBC
  • Особенности при экспорте информации
  • Экспорт данных в системы технического анализа встроенными средствами
  • Настройка программы Wealth-Lab Developer
  • Настройка программы AmiBroker
  • Экспорт данных в системы технического анализа с использованием внешних программ
  • Импорт транзакций
  • Импорт транзакций через API
  • Приложение

В разделе изложены возможности системы QUIK по взаимодействию с другими программами в режиме online, порядок экспорта информации в другие Windows-приложения (MS Excel, ODBC, Wealth-Lab Developer, AmiBroker), а также использование механизма импорта транзакций из файла.


Экспорт данных через DDE-сервер

Кнопка
  • Назначение
  • Использование

    • Назначение

    Передача данных из таблиц системы QUIK во внешние программы, например, в Microsoft Excel. Экспорт осуществляется в формате XLTABLE через метод обмена данными DDE.

    Обращаем внимание, что при использовании фильтрации в таблицах некорректно экспортируются данные через DDE-сервер из таблиц, в которых возможны вставки-удаления строк в начало и середину таблицы (например, Таблицы позиций по деньгам и инструментам).

    Использование

    1. Перед тем, как настраивать экспорт данных, необходимо настроить DDE-сервер. При выводе данных в MS Excel необходимо предварительно открыть программу и загрузить в нее файл, в который будет осуществляться передача данных (если настройка «Запускать приложение DDE сервера автоматически» не включена).

    2. Функция экспорта данных из активной таблицы может быть вызвана одним из следующих способов:
      • нажатием кнопки [image] на панели инструментов;
      • выбором пункта меню Действия/Вывод через DDE-сервер...;
      • нажатием нажатием клавиш «Ctrl»+«L»;
      • выбором пункта контекстного меню «Вывод через DDE-сервер...».
      .
    3. Назначение полей окна настройки экспорта «Вывод через DDE-сервер...»:

      Поле | Значение
      Название таблицы | Название таблицы QUIK, являющейся источником данных
      DDE-сервер | Наименование DDE-сервера. Нажатием кнопки «По умолчанию» возвращается значение «excel»
      Рабочая книга | Наименование файла, в который будет выведена информация из таблицы. Кнопка «…» справа позволяет указать существующий файл, расположенный на диске, и путь до него. Если выбран DDE-сервер «excel», то файл рабочей книги должен иметь расширение .xls или .xlsx.
      Лист | Наименование листа, на который будет перенесена информация из таблицы
      Запускать приложение DDE сервера автоматически | Активизировать функцию автоматического открытия выбранной рабочей книги в MS Excel при старте экспорта. Флажок активен, если в качестве DDE сервера выбран «excel».Поля «Рабочая книга» и «Лист» могут быть не заполнены.
      Верхний левый угол
      • Ряд
      • Колонка
               Координаты начальной ячейки для передачи данных
      • Номер строки, считая сверху
      • Номер колонки, считая слева
      Выводить таблицу, начиная со строки | Выводить строки таблицы, начиная с заданного номера. Может применяться для сокращения времени повторного вывода таблиц, например Таблицы обезличенных сделок
      Вывод после создания | Активизировать функцию экспорта данных сразу после загрузки файла с конфигурацией таблиц, например, при открытии QUIK
      Вывод при нажатии Ctrl+Shift+L | При установленном флажке экспорт из таблицы может быть активизирован нажатием приведенной комбинации клавиш
      С заголовками строк Выводить в качестве первой колонки заголовки строк таблицы QUIK
      С заголовками столбцов | Выводить в качестве первой строки заголовки столбцов таблицы QUIK
      Формальные заголовки | Выводить в качестве заголовков их системные (служебные) наименования. Может использоваться для удобства программирования.
      Выводить пустые ячейки вместо нулей | Оставлять пустыми (не заполнять числовыми значениями) ячейки, содержащие нулевые значения. Данное свойство полезно при графическом отображении рядов данных средствами MS Excel, для предотвращения «провалов» линий графика в местах, где данные отсутствуют (не были получены с сервера).

    4. Нажатие кнопки «Начать вывод» приводит к старту динамического вывода данных из указанной таблицы в файл экспорта. При нажатии с установленным флагом «Запускать приложение DDE сервера автоматически» осуществляется попытка запустить MS Excel и загрузить в него указанную книгу и лист. Если MS Excel не запущен, то имя книги должно быть указано с полным путем к существующему файлу либо поле «Рабочая книга» должно быть не заполнено.

      В MS Excel имена созданных, но еще не сохранённых книг задаются без расширения, например, «Книга1». Если в качестве рабочей книги указано имя без расширения, то сначала будет выполнена попытка найти такую книгу среди уже открытых в MS Excel, а если она не найдена, то создать новую книгу. При этом совпадение имени с указанным в поле «Рабочая книга» не гарантируется.

      Если имя книги не указано, то при запуске MS Excel в нем будет создана новая книга. Если не указано имя листа, то в книге сначала ищется лист с названием экспортируемой таблицы (например, «Таблица заявок #2»), а если он не найден, то добавляется новый лист с таким названием. При запуске экспорта в MS Excel из других таблиц без указания имени рабочей книги, будет использоваться эта же рабочая книга.

      Если в поле «Рабочая книга» указано имя файла без полного пути до него, то происходит поиск файла в текущем рабочем каталоге. При неудачной попытке системой выдается сообщение об ошибке.

    5. Нажатием кнопки «Остановить вывод» вывод данных из таблицы останавливается.
    6. Кнопка «Вывести сейчас» предназначена для разового вывода данных.
    7. Нажатием кнопки «Закрыть» производится закрытие окна настройки экспорта с сохранением произведенных настроек. Если процесс экспорта начат, он будет осуществляться автоматически в фоновом режиме.
    8. Нажатие кнопки «Отменить» закрывает окно без сохранения настроек.
    9. Нажатие кнопки «Справка» вызывает справку по данной функции.

    1. Когда в MS Excel открыто любое окно для редактирования настроек, данные в его таблицы не поступают, а накапливаются в буфере DDE. В случае длительной занятости Excel передача данных может быть прервана. Время ожидания до разрыва DDE-соединения (занятости MS Excel) регулируется настройками экспорта.
    2. Каждая таблица обладает собственными настройками экспорта данных, поэтому разные таблицы могут экспортировать данные в разные DDE-сервера, файлы, листы или ячейки MS Excel.
    3. Из одной таблицы QUIK возможен экспорт данных только в один DDE-сервер.
    4. В один DDE-сервер можно экспортировать данные из разных таблиц QUIK. Например, в разные ячейки одного листа MS Excel можно выводить данные из разных таблиц QUIK.
    5. При изменении формата таблицы экспорт данных останавливается и на экран выводится окно настройки экспорта для установки новых параметров для вывода данных.
    6. При выводе данных через DDE не рекомендуется использовать фильтр в таблицах, предназначенных для экспорта. Если в настройках таблицы имеется признак «Показывать нулевые значения», то его рекомендуется включить.
    7. Вывод данных через DDE происходит в соответствии с сортировкой строк таблицы по умолчанию, а текущая сортировка, используемая в таблице, не учитывается.


Настройки вывода по DDE

меню Система/Настройки/Основные настройки..., раздел «Программа» / «Экспорт данных»

Настройки 1-3 служат для управления интервалом ожидания при занятости DDE-сервера.

  1. «Время ожидания подтверждения приема данных от DDE-сервера»:
    • «При выдаче целиком таблицы, секунд (1-3600)» – управляет временем ожидания при первоначальной передаче данных, рекомендуемое значение – 20;
    • «При выдаче очередной строки (1-600)» – предназначена для управления интерва-лом ожидания во время обновления данных, рекомендуемое значение – 5.
  2. «Количество попыток продолжить экспорт при возникновении ошибки» - количество попыток восстановить соединение в случае возникновения ошибки передачи. Значение по умолчанию – 0.
  3. «Новый поток на отдельный DDE-сервер» - включает многопоточный экспорт данных на разные DDE-сервера. Состояние по умолчанию – выключено.
  4. «MS Excel» - поддержка локализованных версий MS Excel для разных языков. По умолчанию выбран английский язык. Если используется русскоязычный MS Excel, то можно использовать значения «Английский» или «Русский».
Для предотвращения разрывов в передаче данных, вызванных занятостью DDE-сервера (например, при настройке формул в таблице MS Excel) можно увеличить второй параметр, например, до 40 секунд.


Рекомендации

  1. Для однократного вывода данных в DDE-сервер можно использовать в таблицах QUIK операцию копирования данных (пункт контекстного меню «Создать копию», или нажатие клавиш «Ctrl»+«C»). Затем достаточно переключиться в MS Excel и вставить данные (меню Правка/Вставить, или нажатием клавиш «Ctrl»+«V»).
  2. Если для обработки экспортируемых данных нужно провести настройки DDE-сервера, воспользуйтесь для начала функцией «Вывести сейчас». Таким образом, данные передадутся однократно и будут доступны для проведения настроек, и не произойдет переполнения буфера DDE и разрыва экспорта. После проведения настроек можно установить динамический вывод данных нажатием кнопки «Начать вывод».
  3. Если вывод данных в DDE-сервер оказался прерван сразу из нескольких таблиц и восстановить его вручную затруднительно, можно загрузить из файла сохраненную конфигурацию таблиц с настройками экспорта (в них должен быть включен флажок «Выводить после создания»). Экспорт восстановится автоматически.
  4. Система QUIK позволяет создавать неограниченное число таблиц одинакового типа. Поэтому для удобства работы с экспортом данных можно создать на экране отдельную вкладку, например «Для экспорта», и сложить в нее все таблицы-источники данных. Тем самым, (1) эти таблицы не будут занимать место на экране, (2) будет легче ориентироваться в том, какие таблицы используются для экспорта, (3) в случае разрыва DDE-соединения будет проще найти таблицу с приостановленным выводом данных.
  5. Если применяется экспорт из нескольких таблиц, то рекомендуется установить флажок «Вывод при нажатии Ctrl+Shift+L». В этом случае можно начинать вывод данных из таблиц вручную, одним нажатием этой комбинации клавиш.
  6. Остановить экспорт нескольких таблиц можно командой Сервисы / Экспорт/импорт данных / Остановить экспорт таблиц по DDE ими комбинацией клавиш «Ctrl» + «Shift» + «S».


Сообщения об ошибках

«Не удалось установить DDE-соединение. Либо не запущено приложение, куда будет экспортирована информация, либо в него не загружен лист [Книга][Лист]»

  • Не запущен DDE-сервер либо программа MS Excel не открыта. Откройте программу и загрузите в нее требуемый файл.
  • Неправильно указано название Рабочей книги (файла) приложения, или ее листа. В поле «Рабочая книга» необходимо указывать имя файла в точном соответствии с его наименованием в программе. Если файл был ранее сохранен, то он имеет расширение и название указывается вместе с ним, например quikexp.xls. Если рабочая книга приложения еще не была сохранена в виде файла, наименование не имеет расширения (например «Книга1») и в настройках экспорта указывается без него.

    Если настройка «Запускать приложение DDE сервера автоматически» отключена, то в поле «Рабочая книга» указывается только название файла, путь до него указывать не нужно.

  • В настройках MS Excel (пункт меню Сервис / Параметры, вкладка «Общие») включен флажок «Игнорировать DDE-запросы от других приложений». Отключите его.

«Исчерпано время для обмена данными: сервер слишком загружен»

  • Произошел обрыв DDE-соединения по причине занятости DDE-сервера (MS Excel). Если занятость была вызвана длительным использованием каких-либо окон для редактирования параметров, то их необходимо закрыть и заново начать динамический экспорт из окна «Вывод данных по DDE». Если обрывы вывода данных регулярны, увеличьте в настройках экспорта (пункт меню Система/Настройки/Основные настройки..., раздел «Программа» / «Экспорт данных») интервал ожидания при выводе очередной строки, например, до 30-40 секунд.

«Не удалось запустить Excel»

  • На компьютере пользователя не обнаружена установленная программа MS Excel.

«Не удалось открыть книгу [Книга] в Excel, таблица [Экспортируемая таблица]»

  • Файл с указанным именем не существует по указанному пути, либо (если путь к нему не указан) он не найден в текущей рабочей папке.

«Не удалось найти лист [Лист] в рабочей книге [Книга], таблица [Экспортируемая таблица]»

  • Лист с указанным именем не существует в указанной рабочей книге.


Использование ODBC для экспорта информации

Кнопка
  • Назначение
  • Использование
  • Рекомендации

    • Назначение

    Передача данных из таблиц QUIK в другие приложения для их дальнейшего использования (хранения, обработки). На основе этой функции можно осуществить непосредственную связь системы QUIK с программами, нуждающимися в оперативной биржевой информации.

    Использование

    ODBC источник следует создавать в программе Администратор источника данных ODBC 64-разрядной версии (путь: %windir%\system32\odbcad32.exe).
    1. Перед началом настройки экспорта необходимо создать таблицу - получатель данных. Структура этой таблицы должна повторять структуру той таблицы QUIK, из которой экспортируются данные. Другими словами, она должна содержать такой же перечень параметров, как и список заголовков столбцов таблицы QUIK. Перечень параметров таблиц и тип данных в них приведен в приложении к этому разделу. В качестве примера приведем настройку экспорта таблицы сделок в таблицу MS Access:

    2. Создав таблицу, необходимо зарегистрировать ее в качестве источника данных для ODBC в Панели управления Windows (меню Пуск / Настройка / Панель управления), пункт «Источники данных ODBC».
    3. В системе QUIK сделать активной таблицу, из которой будет производиться экспорт данных и открыть окно настройки экспорта ODBC одним из следующих способов:
      • нажать кнопку [image] на панели инструментов;
      • вызвать пункт контекстного меню «Вывод по ODBC»;
      • выбрать пункт меню программы Действия/Вывод по ODBC…;
      • нажать сочетание клавиш «Ctrl»+«O».
    4. В списке «Выберите имя источника данных» выберите получателя данных. Название соответствует тому имени, которое описано в п.2.
    5. Если для подключения к источнику требуется авторизация пользователя, введите имя и пароль в соответствующие поля.
    6. Нажмите кнопку «Присоединиться». В «Списке доступных таблиц» появится полный перечень таблиц в выбранном источнике.

    7. Выберите таблицу, в которую будут передаваться данные. В «Списке полей таблицы» отобразятся поля выбранной таблицы.
    8. Настройте соответствие между полями таблицы QUIK и полями таблицы-получателя последовательным выполнением следующих действий над каждым полем:
      • В «Списке параметров» выбрать поле таблицы QUIK;
      • Сопоставить ему поле из списка «Поле, соответствующее параметру». В списке отображаются поля, имеющие тип, совместимый с типом поля в таблице QUIK. Если искомого поля нет, см. Сообщения об ошибках.

      Не обязательно настраивать соответствие между всеми полями таблиц. Достаточно настроить соответствие между полями, содержащими параметры, планируемые для экспорта. Соответствие между полями, отмеченными «звездочкой» («*»), является обязательным.
    9. Чтобы удалить соответствие между двумя полями таблиц, выберите в «Списке параметров» поле таблицы QUIK и нажмите кнопку «Очистить». Чтобы удалить соответствие между всеми полями таблиц, нажмите кнопку «Очистить все».

      Если таблица-получатель была выбрана ошибочно, то при выборе другой таблицы из «Списка доступных таблиц» сохраняется настройка соответствия между полями, имеющими одинаковое название и тип данных. Для полей с отличающимися наименованиями или типами данных настройки соответствия удаляются.
    10. Назначение настроек экспорта:
      • «Чистить таблицу перед выводом» - если флажок установлен, то перед началом экспорта, при смене сессии, сервера или пользователя старые данные из таблицы будут удалены; если флажок снят, то новые данные будут замещать старые по мере поступления;
      • «Формальные имена» - если флажок установлен, то при экспорте данных вместо текстовых значений параметров передаются их системные идентификаторы, например, вместо наименования инструмента и класса выводятся их коды в торговой системе, вместо перечислимых типов, таких как «направленность заявки» – символьные коды (например, «B» – покупка, «S» – продажа);
      • «Вывод после создания» - если флажок установлен, то экспорт данных начинается одновременно с загрузкой в систему QUIK конфигурации окон, например, при запуске программы;
      • «Вывод при нажатии Ctrl+Shift+O» - при установленном флажке экспорт из таблицы может быть активизирован нажатием приведенной комбинации клавиш.
    11. Нажатие кнопки «Начать вывод данных» начинает процедуру экспорта.
      При использовании экспорта данных из Таблицы текущих торгов убедитесь, что в настройках получения информации (меню Система / Настройки / Основные настройки... , раздел «Программа» / «Сохранение данных») выбрано значение «Данные, отражающие текущее состояние и всю историю изменений».
    12. Нажатие кнопки «Прекратить» останавливает экспорт данных.
    13. Нажатие кнопки «Ок» приводит к закрытию окна настройки экспорта, при этом все сделанные изменения сохраняются. Если процесс экспорта начат, он будет осуществляться автоматически в фоновом режиме.
    14. Нажатием кнопки «Отмена» закрывается окно настройки экспорта без сохранения изменений.

    Рекомендации

    1. Не используйте для названия полей таблиц зарезервированные слова, например, «money», «group», «order», «number», «date» и т.п.
    2. Не используйте пробелы в именах таблиц, полей таблиц и путей к таблицам.
    3. Для экспорта из таблиц QUIK, содержащих параметры с символом «звездочка» («*»), рекомендуется устанавливать флажок «Чистить таблицу перед выводом». Тем самым из таблицы удаляются данные, относящиеся к предыдущим сеансам связи с сервером.
    4. Если требуется накапливать в базе данных архив информации, получаемой из QUIK, то рекомендуется сделать две таблицы одинаковой структуры. Одну из них использовать для получения данных из QUIK, вторую – для накопления архива, причем копирование данных в архив осуществлять по окончании торговой сессии, либо перед началом следующей. Таким образом можно избежать повторной записи данных, например, при необходимости перезаказать данные заново в системе QUIK.
    5. Данные из одной таблицы QUIK могут экспортироваться только в одну таблицу-получатель. Однако, можно настроить в системе QUIK две или более одинаковые таблицы для вывода в разные приложения.
    6. Если экспорт данных используется постоянно, установите в настройках экспорта флажок «Вывод после создания». В этом случае процедура экспорта будет начинаться автоматически с запуском программы.
    7. Если для экспорта данных используется несколько таблиц, то для удобства пользования рекомендуется сделать отдельную вкладку и поместить в ней таблицы, используемые только для экспорта. Тем самым достигается независимость настройки экспорта данных от возможных изменений в аналогичной таблице, используемой для просмотра рыночной информации.
    8. Если применяется экспорт из нескольких таблиц, то рекомендуется установить флажок «Вывод при нажатии Ctrl+Shift+O». В этом случае можно начинать вывод данных из таблиц вручную, одним нажатием этой комбинации клавиш.
    9. Если в базе данных используется индексация таблиц по ключевому полю, то для обеспечения уникальности, его следует настраивать по полям QUIK «Номер заявки» и «Код класса».
    10. Если в настройках таблицы имеется признак «Показывать нулевые значения», то его рекомендуется включить.

    См. также Сообщения об ошибках.


Сообщения об ошибках

«Ошибка синтаксиса при выполнении операции INSERT INTO»

  • Наиболее распространенная ошибка, вызванная несоблюдением рекомендаций 1. и 2.

«Ошибка при установлении соединения. Недостаточно сведений для подключения к DSN»

  • Не настроен источник данных ODBC или настроен неправильно. Обратитесь к п. Использование ODBC для экспорта информации.

Получатель данных не указан в списке источников данных

  • Таблица не зарегистрирована в источниках данных ODBC. Обратитесь к п. Использование ODBC для экспорта информации.
  • При сопоставлении полей таблиц отсутствует искомое наименование в списке «Поле, соответствующее параметру», хотя оно обозначено в «Списке полей таблицы».
  • Поле в таблице-получателе данных имеет тип, несовместимый с типом поля таблицы QUIK. Приведите тип поля в таблице-получателе в соответствие с его аналогом в таблице QUIK.


Экспорт инструментов по ODBC

меню Сервисы / Экспорт/импорт данных / Экспорт инструментов по ODBC…

Назначение

Экспорт очередей заявок по инструментам (т.н. «стаканов котировок») через ODBC без необходимости создания Таблиц котировок по ним.

Использование

  1. Настройте список инструментов для экспорта, сформировав список «Выбранные инструменты» из числа доступных.
  2. Настройте список экспортируемых параметров, нажав кнопку «Настроить». Порядок настройки параметров аналогичен описанию в разделе Использование ODBC для экспорта информации.
  3. Для начала экспорта нажмите кнопку «Запустить». Для прекращения экспорта нажмите кнопку «Остановить».

Нажатием кнопки «Да» окно настройки экспорта закрывается с сохранением всех параметров. Чтобы закрыть окно без сохранения настроек, нажмите кнопку «Отмена».

  1. Экспорт разреженного стакана котировок по DDE осуществляется в неразреженном виде.
  2. При экспорте точность полей типа float таблицы базы данных не должна превышать значения 6.


Особенности при экспорте информации

При экспорте информации по DDE и ODBC для таблиц, работающих в режиме «drag-and-drop» существуют ряд особенностей:

  1. При перемещении или удалении столбцов с помощью режима «drag-and-drop» (пункт меню Система/Настройки/Основные настройки... раздел «Таблицы» / «Перемещать и удалять столбцы таблицы с помощью drag-and-drop») в таблицах с настроенным экспортом по DDE и ODBC, происходит перезагрузка настроек экспорта и открывается соответствующий диалог с настройками.
  2. В случае изменения пользовательских фильтров в таблице происходит перезагрузка настроек экспорта по DDE и ODBC и открывается соответствующий диалог с настройками.
  3. В таблице текущих торгов, а также в таблицах «Таблица информации по опционам», «Купить/Продать» возможно удаление и изменение порядка строк при помощи режима «drag-n-drop». Для таблицы «Доска опционов» в этом режиме возможно только удаление строк. При выполнении данных операций происходит перезагрузка настроек экспорта и открывается соответствующий диалог с настройками.


Экспорт данных в системы технического анализа встроенными средствами

меню Сервисы / Экспорт/импорт данных / Экспорт в системы тех. анализа…
  • Назначение
  • Использование
  • Рекомендации

    • Назначение

    Использование получаемых системой QUIK данных для оперативного технического анализа в профессиональных приложениях Wealth-Lab Developer версии 6.x и AmiBroker версии 6.x

    Использование

    Функция экспорта данных встроенными средствами возможна, если доступен пункт меню Сервисы / Экспорт/импорт данных / Экспорт в системы тех. анализа….

    Для обеспечения корректной работы пакетов технического анализа требуется соответствующая настройка этих программ, подробнее см. Настройка программы Wealth-Lab Developer, Настройка программы AmiBroker.

    Следует учесть, что инсталляция других систем интернет-трейдинга с функцией вывода данных для технического анализа может привести к нарушению экспорта из системы QUIK.

    1. Откройте окно настройки экспорта с помощью пункта меню Экспорт данных / Данные для технического анализа....

    2. Создайте список экспортируемых инструментов и их параметров. Для добавления инструмента в список нажмите кнопку «Добавить». Откроется диалог выбора параметров для экспорта.

    3. В списке «Доступные инструменты» выберите инструмент. По умолчанию они отсортированы в списке в алфавитном порядке. Для удобства выбора инструментов с фиксированным сроком обращения установите флажок «Сортировать по дате погашения».
    4. В поле «Система тех.анализа» выберите название программы, в которую осуществляется экспорт.
    5. В поле «Обозначение в системе ТА» введите название инструмента, идентичное указанному в настройках источника данных для системы технического анализа.
    6. Выберите источник данных для экспорта. Из Таблицы обезличенных сделок возможен экспорт цены и объема по каждой сделке. При установленном флажке «Выводить объем сделок в лотах» данные о количестве инструментов в последней сделке будут соответствовать числу лотов в сделке, при снятом флажке – количеству единиц инструментов. Из Таблицы истории значений параметров возможен экспорт большего числа параметров, например «Лучшая цена спроса» или «Лучшая цена предложения».
    7. Параметр «Интервал» определяет периодичность формирования «свечей» графика. Выбором значения «Тиковый» назначается вывод данных по каждой сделке.
    8. Параметры «Выводить с … » и «до …» определяют начало и конец торговой сессии. Регулировкой этих параметров можно исключить сделки периода открытия и закрытия, цены которых может заметно отличаться от среднерыночной.
    9. Если установлен флажок «Не выводить данные повторно», то при разрыве связи с сервером и последующем восстановлении QUIK не передает заново ранее экспортированные данные. Если флажок снят, то при каждом восстановлении связи с сервером QUIK экспортирует все данные с начала торговой сессии. О случаях применения см. Рекомендации.
    10. Следующие параметры определяют количество экспортируемых данных:
      • «Все доступные значения» - все значения, с учетом исторических данных за предыдущие дни, если такая возможность поддерживается сервером QUIK брокера;
      • «Только за текущий торговый день» - все значения текущей торговой сессии;
      • «С …» и «по …» - значения в интервале указанных дат и времени.

      Настройки параметров пп. 7-10 по умолчанию устанавливаются в соответствии с общими настройками экспорта данных (кнопка «Общие настройки» в диалоге экспорта данных для технического анализа).
    11. Нажатием кнопки «Да» окно выбора параметров инструмента закрывается, и новый инструмент отображается в списке «Экспортируемые инструменты».
    12. Для редактирования ранее созданного инструмента нажмите кнопку «Изменить».
    13. Для редактирования общих параметров экспорта по нескольким инструментам выделите нужные инструменты в списке и нажмите на кнопку «Изменить». На экране появится диалог, в котором можно изменить настройки периода экспорта данных, повторного вывода данных, а также изменить множество выводимых значений.

    14. Для удаления выбранных инструментов из списка выделите их и нажмите на кнопку «Убрать».
    15. Кнопка «Общие настройки» позволяет задать параметры, которые будут выбраны по умолчанию при добавлении нового инструмента для экспорта. При нажатии на кнопку на экране появляется диалог следующего вида:
      • Параметр «Интервал» определяет периодичность формирования «свечей» графиков для всех экспортируемых инструментов;

      • Параметры «Выводить с … » и «до …» определяют начало и конец торговой сессии;
      • Установленный флажок «Не выводить данные повторно» означает, что при разрыве связи с сервером и последующем восстановлении QUIK не передает заново ранее экспортированные данные. Если флажок снят, то при каждом восстановлении связи с сервером QUIK экспортирует все данные с начала торговой сессии;
      • Параметры, определяющие количество экспортируемых данных (применительно ко всем содержащимся в списке инструментам):
        • «Все доступные значения» - все значения, с учетом исторических данных за предыдущие дни, если такая возможность поддерживается сервером QUIK Вашего брокера;
        • «Только за текущий торговый день» - все значения текущей торговой сессии;
        • Расписание «С … по …» предназначено для настройки интервала времени, которому соответствуют экспортируемые параметры. Например, если нужно не выводить данные о сделках, совершаемых в первую минуту торгов, то можно установить вывод данных не с самого начала торгов, а с указанного момента времени.
    16. При установленном флажке «Начинать вывод автоматически» экспорт данных начинается одновременно с запуском программы.
    17. Нажатие кнопки «Начать вывод по инструменту» начинает процедуру экспорта по выбранному инструменту. Инструменты, по которым осуществляется экспорт, отличаются в списке символом [image].
    18. Нажатие кнопки «Начать вывод» начинает процедуру экспорта данных по всем инструментам из списка.
    19. Нажатием кнопки «Прекратить вывод по инструменту» останавливается экспорт данных по выбранному в списке инструменту, нажатием кнопки «Прекратить вывод» прекращается вывод данных по всем инструментам в списке.

      При начатом экспорте данных по инструменту невозможно удалить его из списка или изменить его настройки. Если требуется внести изменения, сначала остановите вывод данных, а затем редактируйте список экспортируемых инструментов.
    20. Нажатием кнопки «Закрыть» окно настройки экспорта закрывается. Если процесс экспорта начат, он будет осуществляться автоматически в фоновом режиме.

    Рекомендации

    1. В настройках экспорта данных из QUIK рекомендуется устанавливать флажок «Не выводить данные повторно». Если связь с сервером была прервана и затем восстановлена, экспорт данных восстановится автоматически. При этом будут переданы только вновь поступившие данные.
    2. Если Рабочее место QUIK закрыто пользователем, то экспорт данных прекращается. При повторном запуске системы экспорт данных начинается с начала торговой сессии.

    См. также Сообщения об ошибках.


Настройка программы Wealth-Lab Developer

  • Подготовка к работе
  • Создание источника данных в QUIK
    •

    Подготовка к работе

    1. Установите программу Wealth-Lab Developer.
      • Скачайте дистрибутив для установки провайдера экспорта из QUIK в Wealth-Lab Developer. Его можно взять по адресу: https://arqatech.com/upload/iblock/855/WealthLabDataProvider.zip.
    2. Для осуществления экспорта данных из QUIK в программу Wealth-Lab Developer необходимо установить провайдер WealthLab.DataProviders. Провайдер WealthLab.DataProviders поддерживает два режима работы: разовое получение данных и получение данных в реальном времени. Для использования провайдера в обоих режимах работы необходимо выполнить установку следующим образом:
      • Распакуйте присланный архив и скопируйте в директорию, где установлена программа Wealth-Lab Developer следующие файлы:
        • WealthLab.DataProviders.QUIK.dll;
        • NLog.dll и NLog.xml, если они отсутствуют в дистрибутиве Wealth-Lab Developer или NLog.dll имеет более старую версию (версию NLog.dll можно проверить в свойствах файла).
      • Запустите приложение Wealth-Lab Developer через пункт меню «Пуск».
    3. Выполните настройку приложения Wealth-Lab Developer:
      • В главном меню приложения выберите пункт «Tools / Data manager»;
      • В окне «Data manager» выберите команду «Create a new DataSet»:

      • В открывшемся диалоге выберите список доступных провайдеров «QUIK Data» и нажмите на кнопку «Next»:

      • В списке символов укажите тикеры инструментов (через запятую или пробел), с которыми предполагается работать, а ниже выберите временной масштаб, который предполагается использовать (месяц, неделя, день или минутный интервал) и нажмите на кнопку «Next»:

      • Укажите имя источника данных для экспорта (например, QUIK LKOH (Minute,15)) и нажмите на кнопку «Finished»:

      • Успешное добавление данных отобразится в исходном окне «Data manager»:

      • Созданный DataSet появится в дереве DataSets программы Wealth-Lab Developer:

        Выполнив данные настройки, пользователь сможет получать данные из системы QUIK в режиме разового получения.

      • Для получения данных в режиме реального времени необходимо выполнить дополнительные настройки:
        • В главном меню приложения выберите пункт «Tools / Preferences»:

        • В открывшемся диалоге «Preferences» слева в дереве выберите «Streaming data», а справа в списке доступных провайдеров выберите «QUIK» и добавьте необходимые для обновления в режиме реального времени тикеры (например, LKOH):

        • После запуска экспорта данных необходимо в программe Wealth-Lab Developer нажать на кнопку «Stream» (в правом нижнем углу), после чего программа начнет получать данные из системы QUIK в режиме реального времени:

    Создание источника данных в QUIK

    1. В Рабочем месте QUIK откройте окно настройки экспорта с помощью пункта меню Сервисы / Экспорт/импорт данных / Экспорт в системы тех. анализа….

    2. Создайте список экспортируемых инструментов и их параметров. Для добавления инструмента в список нажмите кнопку «Добавить». Откроется диалог выбора параметров для экспорта.
    3. В списке «Доступные инструменты» выберите инструмент, например, «ЛУКОЙЛ».
      Выбираемый инструмент должен совпадать с инструментом, добавленным в приложении Wealth-Lab Developer.

      По умолчанию список упорядочен в алфавитном порядке, для сортировки инструментов с фиксированным сроком обращения предназначена опция «Сортировать по дате погашения».
    4. В поле «Система ТА» выберите значение «WealthLab».
    5. В поле «Обозначение в системе ТА» введите идентификатор инструмента в программе Wealth-Lab Developer.
    6. Выберите источник данных для экспорта. Из Таблицы обезличенных сделок возможен экспорт цены и объема по каждой сделке. При установленном флажке «Выводить объем сделок в лотах» данные о количестве инструментов в последней сделке будут соответствовать числу лотов в сделке, при снятом флажке – количеству единиц инструментов. Из Таблицы истории значений параметров возможен экспорт большего числа параметров, например «Лучшая цена спроса» или «Лучшая цена предложения».
    7. В поле «Интервал» выберите интервал вывода данных в программу Wealth-Lab Developer.
    8. Выберите время начала и конца торговой сессии.
    9. Установленный флажок «Не выводить данные повторно» означает, что при разрыве связи с сервером и последующем восстановлении QUIK не передает заново ранее экспортированные данные. Если флажок снят, то при каждом восстановлении связи с сервером QUIK экспортирует все данные с начала торговой сессии.
    10. Установите параметры, определяющие количество экспортируемых данных (применительно к выбранному инструменту).
    11. Нажатием кнопки «Да» окно выбора параметров инструмента закрывается, и новый инструмент отображается в списке «Экспортируемые инструменты».


Настройка программы AmiBroker

  • Подготовка к работе
  • Создание источника данных в QUIK
  • Настройка импорта данных в программе AmiBroker

    • Подготовка к работе

    1. Установите программу AmiBroker.
    2. Для осуществления экспорта из QUIK в программу AmiBroker необходим файл QUIK2AMIBROKER_DataPlugin.dll. Его можно взять на официальном сайте QUIK в разделе «Файловый архив».
    3. Скопируйте файл QUIK2AMIBROKER_DataPlugin.dll в папку Plugins, расположенную в каталоге хранения программы AmiBroker.

    Создание источника данных в QUIK

    1. В QUIK откройте окно настройки экспорта с помощью пункта меню Сервисы / Экспорт/импорт данных / Экспорт в системы тех. анализа….
    2. Создайте список экспортируемых инструментов и их параметров. Для добавления инструмента в список нажмите кнопку «Добавить». Откроется диалог выбора параметров для экспорта.

    3. В списке «Доступные инструменты» выберите инструмент, например, «ЛУКОЙЛ». По умолчанию список упорядочен в алфавитном порядке, для сортировки инструментов с фиксированным сроком обращения предназначена опция «Сортировать по дате погашения».
    4. В поле «Система ТА» выберите значение «AmiBroker».
    5. В поле «Обозначение в системе ТА» введите идентификатор инструмента в программе AmiBroker.
    6. Выберите источник данных для экспорта ( Таблица обезличенных сделок или Таблица истории значений параметров).
    7. В поле «Интервал» выберете интервал вывода данных в систему AmiBroker.
    8. Выберете время начала и конца торговой сессии.
    9. Установленный флажок «Не выводить данные повторно» означает, что при разрыве связи с сервером и последующем восстановлении QUIK не передает заново ранее экспортированные данные. Если флажок снят, то при каждом восстановлении связи с сервером QUIK экспортирует все данные с начала торговой сессии.
    10. Установите параметры, определяющие количество экспортируемых данных (применительно к выбранному инструменту).
    11. Нажатием кнопки «Да» окно выбора параметров инструмента закрывается, и новый инструмент отображается в списке «Экспортируемые инструменты».

    Настройка импорта данных в программе AmiBroker

    1. Запустите AmiBroker и выберите пункт меню File / New / Database….

    2. В появившемся окне в поле «Database folder» необходимо указать путь к базе данных для хранения импортируемой информации. Если базы данных не существует, то необходимо её создать, указав путь и уникальное имя базы, а затем нажав на кнопку «Create». Признак «Load this database at startup» означает загрузку указанной базы данных по умолчанию при запуске программы.
    3. Далее необходимо установить настройки импорта данных. В качестве источника данных в поле «Data source» нужно выбрать «QUIK Data Plug-in».
    4. Параметр «Local Data Storage» установить в значении «Enable» (настраивается по умолчанию).
    5. В поле «Number of bars» указать количество баров, отображаемых на графике.
    6. Установить интервал импорта данных в поле «Base time interval».

      1. Значение параметра «Base time interval» должно соответствовать значению поля «Интервал» в настройках экспорта данных в системе QUIK для программы AmiBroker (см. Создание источника данных в QUIK), в противном случае данные импортироваться не будут.
      2. В программе AmiBroker есть возможность изменения интервала графика через контекстное меню (пункт меню «Intraday») на основе глобальной настройки графика в параметрах «Database settings». После изменения настройки таймфрейма графика, график в Amibroker, как правило, не совпадает с графиком, который выгружает QUIK из-за особенностей формирования интервалов для графиков в системе QUIK. QUIK разбивает час на соответствующие графику интервалы (например, на 15-минутки), и отображает первый бар графика с ближайшего следующего интервала. В программе Amibroker такого правила построения графика нет, поэтому возможны несовпадения.
    7. Нажать на кнопку «ОК» для сохранения настроек.
    8. После сохранения настроек, станет доступной кнопка «Configure», нажатием которой открывается окно «Настройки экспорта данных из Quik в Amibroker». Признаком «Очищать данные Амиброкера после установления соединения» включается удаление всех ранее переданных данных в AmiBroker’е перед началом нового сеанса экспорта из QUIK в AmiBroker. Если флажок не установлен, то новые данные будут добавляться к предыдущим, т.е. будут накапливать историю котировок в AmiBroker’е.

    9. Далее необходимо создать новый тикер. Выберите пункт меню Symbol / New. В появившемся окне введите название тикера, идентичное указанному при настройке источника данных в системе QUIK (см. Создание источника данных в QUIK). В нашем случае туда нужно ввести значение «LKOH» и нажать «OK».

    10. В окне «Symbols» можно увидеть список всех созданных тикеров. При выборе тикера в рабочей области программы AmiBroker отображается соответствующий указанному тикеру график.

    11. Чтобы начать экспорт, следует в Рабочем месте QUIK в окне «Экспорт данных для технического анализа» нажать кнопку «Начать вывод по инструменту». При этом поступающие данные должны отображаться в реальном времени в рабочей области программы Amibroker.


Импорт транзакций

  • Универсальный формат файла импорта транзакций
  • Фиксированный формат файла импорта транзакций

    • Руководство пользователя QUIK © ARQA Technologies / www.arqatech.com/ru/products/quik/


Универсальный формат файла импорта транзакций

  • Назначение
  • Формат .tri-файла с результатами обработки транзакций

    • Назначение

    Универсальный формат позволяет отправлять любые транзакции, если известно их описание.

    Описание набора полей транзакции можно посмотреть в окне создания кармана транзакций.

    Из контекстного меню заявки в таблице «Карман транзакций» необходимо выбрать «Загрузить транзакции в tri-файл».

    Формат .tri-файла с результатами обработки транзакций

    Файл представляет собой последовательность строк, каждая из которых содержит информацию по отдельной транзакции.

    Принцип формирования строки:

    1. Строки TRANS_ID, CLASSCODE, ACTION, в качестве значения ACTION указывается имя требуемой транзакции, например: «Ввод заявки РЕПО с ЦК».
    2. Параметры транзакции описываются в виде «НАЗВАНИЕ_ПАРАМЕТРА=значение параметра» и разделяются символом «;».

    Примеры строк, которые могут содержаться в файле:
    Транзакция | Строка
Заявка на сделку РЕПО с ЦК 1 день Покупка объема 1000000.00 по цене 6.1500 | TRANS_ID=1; CLASSCODE=EQRP_BND; ACTION=Ввод заявки РЕПО с ЦК; Торговый счет=L01+00000F00; К/П=Купля; Тип=Лимитная; Тип по цене=По разным ценам; Тип по остатку=Поставить в очередь; Тип ввода значения цены=По цене; Назначение заявки=По умолчанию; Режим=EQRP_BND; Инструмент=RU000A0JRF37; Цена=6.1500; Лоты=0; Примечание=4F161/T2/; Объем заявки=1000000.00; Код внешнего пользователя=; Доп. инфо=;
Айсберг-заявка На фондовом рынке Московской Биржи, купить 100 лотов Аэрофлота по цене 70, видимое количество лотов в очереди – 10, код клиента 467 | CLASSCODE=TQBR; TRANS_ID=2; ACTION=Ввод айсберг заявки; Торговый счет=S01-00000F00; К/П=Купля;Тип=Лимитная;Тип по цене=по разным ценам; Тип по остатку=поставить в очередь; Тип ввода значения цены=По цене; Инструмент=AFLT; Цена=70; Лоты=100; Видимое количество=10; Примечание=467;
Алго-заявка типа «Айсберг» на покупку 99 AGZD по цене 111.0000, лимитированная, видимое количество – 2, снять алго-заявку при снятии связанной, агресивность – нормальный режим, с условием исполнения – до отмены | TRANS_ID=4;CLASSCODE=ALGO_ICEBERG;ACTION=Ввод алго-заявки;Торговый счет=L01-00000F00;Фирма=NC0038900000;Направление=Покупка;Тип=Лимитированная;Класс=BQUOTE;Инструмент=AGZD;Цена=111.0000;Количество=99;Видимое количество=2;Код клиента=Q3;Комментарий=;Снимать алго-заявку при снятии связанной=Y;Агрессивность=Нормальный режим;Условие исполнения=До отмены;Дата истечения=20161125;Время истечения=124141;Оповещения об исполнениях=Да;
Алго-заявка типа «VWAP» на покупку 5 AGZD, процентом исполнения для включения агрессивности – 0,000000, степенью агрессивности – 0 | TRANS_ID=2;CLASSCODE=ALGO_VWAP;ACTION=Ввод алго-заявки;Торговый счет=L01-00000F00;Фирма=NC0038900000;Направление=Покупка;Класс=BQUOTE;Инструмент=AGZD;Количество/Объем=Количество;Объем=0;Количество=5;Исполнение процента от рынка=Нет;Процент от рынка=0;Время старта=183001;Время окончания=183501;До закрытия=Нет;Тип задания времени старта=Текущее;Тип задания интервала=Количество итераций;Количество итераций=5;Время итерации=0;Отклонение от средневзвеса=0,000000;Код клиента=Q3;Комментарий=;Минимальная цена=0,000000;Максимальная цена=0,000000;Оповещения об исполнениях=Нет;CatchUp-заявка=Да;Процент исполнения для включения агрессивности=0,000000;Степень агрессивности=0;Использовать IOC-заявки=Да;Использовать ограничение внутри итераций=Да;Работать в ценовом диапазоне=Нет;Профилирование по времени=Нет;Учитывать собственные сделки=Да;
Алго-заявка типа «TWAP» на покупку 222 AGZD по цене 150.0000 | TRANS_ID=1;CLASSCODE=ALGO_TWAP;ACTION=Ввод алго-заявки;Торговый счет=L01-00000F00;Фирма=NC0038900000;Направление=Покупка;Класс=BQUOTE;Инструмент=AGZD;Количество/Объем=Количество;Объем=0.00;Количество=222;Тип=Лимитированная;Время старта=183003;Время окончания=183003;Тип задания времени старта=Текущее;Тип задания интервала=Количество итераций;Количество итераций=10;Время итерации=15;Тип ограничения цены=Проценты;Ограничение цены (проценты)=0.000000;Ограничение цены (деньги)=0.0000;Код клиента=Q3;Комментарий=;Оповещения об исполнениях=Нет;Профилирование по времени=Нет;Цена=150.0000;
Алго-заявка типа «GTD» на покупку 10 LKOH по цене 1000.00 | TRANS_ID=2;CLASSCODE=ALGO_GTD;ACTION=Ввод заявки;Торговый счет=L01-00000F00;Фирма=NC0038900000;Направление=Покупка;Класс=BQUOTE;Инструмент=LKOH;Цена=1000.00;Количество=10;Тип=Лимитированная;Код клиента=Q3;Комментарий=;Условие исполнения=До отмены;Дата истечения=20160912;Время истечения=162335;Оповещения об исполнениях=Нет;Использовать временной интервал=Нет;Время старта=0;Время окончания=0;Контрагент=NC0038900000;Код расчетов=T0;
Снятие Алго-заявки с идентификатором 000000000072ALGO_TWAP | TRANS_ID=3;CLASSCODE=ALGO_TWAP;ACTION=Снятие заявки; Идентификатор заявки=000000000072ALGO_TWAP


Фиксированный формат файла импорта транзакций

меню Сервисы / Экспорт/импорт данных / Импорт транзакций из файла…
  • Назначение
  • Использование

    • Назначение

    Автоматический ввод в торговую систему подготовленных какой-либо внешней программой транзакций. Получение отчета о результате ввода транзакции.

    Использование

    Для обмена информацией между QUIK и внешней программой используются текстовые файлы фиксированной структуры:

    • *.tri – файл с параметрами транзакций;
    • *.tro – файл с результатами посылки транзакций в торговую систему;
    • *.trr – файл, содержащий журнал обработки транзакций.
    Не рекомендуется размещать tri-файлы и tro-файлы в сети.

    Схема взаимодействия между программами выглядит следующим образом:

    1. Внешняя программа формирует транзакцию с заданными параметрами и записывает ее в виде новой строки в .tri-файл. Транзакции идентифицируются по дополнительному целочисленному параметру TRANS_ID, содержащему уникальный номер.
    2. Система QUIK опрашивает с определенной периодичностью .tri-файл с параметрами транзакций и передает в торговую систему ранее не обработанные транзакции. Если описание транзакции не соответствует принятому формату, то она отвергается.
    3. Результат действий записывается в .tro-файл в формате, приемлемом для чтения внешней программой. Каждая строка файла содержит информацию об обработке отдельной транзакции, различаемые по параметру TRANS_ID.
    4. При обработке внешней программой результатов операции (на Московской Бирже), выводимых в .tro-файл, регистрационный номер заявки в торговой системе указывается в текстовом сообщении, возвращаемом торговой системой (поле «DESCRIPTION»), а также параметром ORDER_NUMBER.

    Перед первым чтением .tri-файла QUIK обращается к .tro-файлу и считывает обработанные заявки. Заявки, содержащиеся в .tro-файле считаются обработанными, и строки в .tri-файле с тем же параметром TRANS_ID игнорируются. Если внешняя программа при каждом запуске начинает нумеровать заявки сначала, то перед ее запуском необходимо удалить .tro-файл из рабочей директории.

    См. также:

    • Формат .tri-файла с параметрами транзакций
    • Примеры строк, которые могут содержаться в файле
    • Формат .tro-файла с результатами обработки транзакций
    • Настройка импорта транзакций


Формат .tri-файла с параметрами транзакций

Файл представляет собой последовательность строк, каждая из которых содержит информацию по отдельной транзакции. Параметры транзакции описываются в виде «НАЗВАНИЕ_ПАРАМЕТРА= значение_параметра» и разделяются символом «;».

Транзакция на ввод айсберг-заявки на Московской Бирже описывается в особом формате, приведенном в примере строк файла.

Параметры и принимаемые ими значения:

Параметр | Значение
CLASSCODE | Код класса, по которому выполняется транзакция, например TQBR. Обязательный параметр
SECCODE | Код инструмента, по которому выполняется транзакция, например SBER
ACTION

Вид транзакции, имеющий одно из следующих значений:

  • «NEW_ORDER» - новая заявка;
  • «NEW_NEG_DEAL» - новая заявка на внебиржевую сделку;
  • «NEW_REPO_NEG_DEAL» – новая заявка на сделку РЕПО;
  • «NEW_EXT_REPO_NEG_DEAL» - новая заявка на сделку модифицированного РЕПО (РЕПО-М);
  • «NEW_STOP_ORDER» - новая стоп-заявка;
  • «KILL_ORDER» - снять заявку;
  • «KILL_NEG_DEAL» - снять заявку на внебиржевую сделку или заявку на сделку РЕПО;
  • «KILL_STOP_ORDER» - снять стоп-заявку;
  • «KILL_ALL_ORDERS» – снять все заявки из торговой системы;
  • «KILL_ALL_STOP_ORDERS» – снять все стоп-заявки;
  • «KILL_ALL_NEG_DEALS» – снять все заявки на внебиржевые сделки и заявки на сделки РЕПО;
  • «KILL_ALL_FUTURES_ORDERS» - снять все заявки на срочном рынке Московской Биржи;
  • «MOVE_ORDERS» - переставить заявки на срочном рынке Московской Биржи;
  • «NEW_QUOTE» - новая безадресная заявка;
  • «KILL_QUOTE» - снять безадресную заявку;
  • «NEW_REPORT» - новая заявка-отчет о подтверждении транзакций в режимах РПС и РЕПО;
  • «SET_FUT_LIMIT» - новое ограничение по фьючерсному счету
FIRM_ID | Идентификатор участника торгов (код фирмы)
ACCOUNT | Номер счета Трейдера. Параметр обязателен при «ACTION» = «KILL_ALL_FUTURES_ORDERS». Параметр чувствителен к верхнему/нижнему регистру символов
CLIENT_CODE | 20-ти символьное составное поле, может содержать код клиента и текстовый комментарий (поле «Комментарий») с тем же разделителем, что и при вводе заявки вручную. Необязательный параметр
TYPE | Тип заявки, необязательный параметр. Значения: «L» – лимитированная (по умолчанию), «M» – рыночная
MARKET_MAKER_ORDER | Признак того, является ли заявка заявкой Маркет-Мейкера. Возможные значения: «YES» или «NO». Значение по умолчанию (если параметр отсутствует): «NO»
OPERATION | Направление заявки, обязательный параметр. Значения: «S» – продать, «B» – купить
EXECUTION_CONDITION

Условие исполнения заявки, необязательный параметр. Возможные значения:

  • «PUT_IN_QUEUE» – поставить в очередь (по умолчанию);
  • «FILL_OR_KILL» – немедленно или отклонить;
  • «KILL_BALANCE» – снять остаток
QUANTITY | Количество лотов в заявке, обязательный параметр
PRICE | Цена заявки, за единицу инструмента. Обязательный параметр. При выставлении рыночной заявки (TYPE=M) на срочном рынке Московской Биржи необходимо указывать значение цены – укажите наихудшую (минимально или максимально возможную – в зависимости от направленности), заявка все равно будет исполнена по рыночной цене. Для других рынков при выставлении рыночной заявки укажите price= 0
REPOVALUE | Объем сделки РЕПО-М в рублях
START_DISCOUNT | Начальное значение дисконта в заявке на сделку РЕПО-М
LOWER_DISCOUNT | Нижнее предельное значение дисконта в заявке на сделку РЕПО-М
UPPER_DISCOUNT | Верхнее предельное значение дисконта в заявке на сделку РЕПО-М
STOPPRICE | Стоп-цена, за единицу инструмента. Используется только при «ACTION» = «NEW_STOP_ORDER»
STOP_ORDER_KIND

Тип стоп-заявки. Возможные значения:

  • «SIMPLE_STOP_ORDER» – стоп-лимит;
  • «CONDITION_PRICE_BY_OTHER_SEC» – с условием по другому инструменту;
  • «WITH_LINKED_LIMIT_ORDER» – со связанной заявкой;
  • «TAKE_PROFIT_STOP_ORDER» – тейк-профит;
  • «TAKE_PROFIT_AND_STOP_LIMIT_ORDER» - тейк-профит и стоп-лимит;
  • «ACTIVATED_BY_ORDER_SIMPLE_STOP_ORDER» – стоп-лимит по исполнению заявки;
  • «ACTIVATED_BY_ORDER_TAKE_PROFIT_STOP_ORDER» – тейк-профит по исполнению заявки;
  • «ACTIVATED_BY_ORDER_TAKE_PROFIT_AND_STOP_LIMIT_ORDER» - тейк-профит и стоп-лимит по исполнению заявки.

Если параметр пропущен, то считается, что заявка имеет тип «стоп-лимит»

STOPPRICE_CLASSCODE | Класс инструмента условия. Используется только при «STOP_ORDER_KIND» = «CONDITION_PRICE_BY_OTHER_SEC»
STOPPRICE_SECCODE | Код инструмента условия. Используется только при «STOP_ORDER_KIND» = «CONDITION_PRICE_BY_OTHER_SEC»
STOPPRICE_CONDITION Направление предельного изменения стоп-цены.
Используется только при «STOP_ORDER_KIND» = «CONDITION_PRICE_BY_OTHER_SEC».
Возможные значения: «<=» или «>= »
LINKED_ORDER_PRICE | Цена связанной лимитированной заявки. Используется только при «STOP_ORDER_KIND» = «WITH_LINKED_LIMIT_ORDER»
EXPIRY_DATE

Срок действия стоп-заявки. Возможные значения:

  • «GTC» – до отмены;
  • «TODAY» - до окончания текущей торговой сессии;
  • Дата в формате «ГГГГММДД»
STOPPRICE2 | Цена условия «стоп-лимит» для заявки типа «Тейк-профит и стоп-лимит»
MARKET_STOP_LIMIT | Признак исполнения заявки по рыночной цене при наступлении условия «стоп-лимит». Значения «YES» или «NO». Параметр заявок типа «Тейк-профит и стоп-лимит»
MARKET_TAKE_PROFIT | Признак исполнения заявки по рыночной цене при наступлении условия «тейк-профит». Значения «YES» или «NO». Параметр заявок типа «Тейк-профит и стоп-лимит»
IS_ACTIVE_IN_TIME | Признак действия заявки типа «Тейк-профит и стоп-лимит» в течение определенного интервала времени. Значения «YES» или «NO»
ACTIVE_FROM_TIME | Время начала действия заявки типа «Тейк-профит и стоп-лимит» в формате «ЧЧММСС»
ACTIVE_TO_TIME | Время окончания действия заявки типа «Тейк-профит и стоп-лимит» в формате «ЧЧММСС»
PARTNER | Код организации – партнера по внебиржевой сделке.Применяется при «ACTION» = «NEW_NEG_DEAL», «ACTION» = «NEW_REPO_NEG_DEAL» или «ACTION» = «NEW_EXT_REPO_NEG_DEAL»
ORDER_KEY | Номер заявки, снимаемой из торговой системы. Применяется при «ACTION» = «KILL_ORDER» или «ACTION» = «KILL_NEG_DEAL» или «ACTION» = «KILL_QUOTE»
STOP_ORDER_KEY | Номер стоп-заявки, снимаемой из торговой системы. Применяется только при «ACTION» = «KILL_STOP_ORDER»
TRANS_ID | Уникальный идентификационный номер заявки, значение от «1» до «2 147 483 647»
SETTLE_CODE | Код расчетов при исполнении внебиржевых заявок
PRICE2 | Цена второй части РЕПО
REPOTERM | Срок РЕПО. Параметр сделок РЕПО-М
REPORATE | Ставка РЕПО, в процентах
BLOCK_SECURITIES | Признак блокировки инструментов на время операции РЕПО («YES», «NO»)
REFUNDRATE | Ставка фиксированного возмещения, выплачиваемого в случае неисполнения второй части РЕПО, в процентах
COMMENT | Текстовый комментарий, указанный в заявке. Используется при снятии группы заявок
KILL_IF_LINKED_ORDER_PARTLY_FILLED | Признак снятия стоп-заявки при частичном исполнении связанной лимитированной заявки. Используется только при «STOP_ORDER_KIND» = «WITH_LINKED_LIMIT_ORDER». Возможные значения: «YES» или «NO»
OFFSET | Величина отступа от максимума (минимума) цены последней сделки. Используется при «STOP_ORDER_KIND» = «TAKE_PROFIT_STOP_ORDER» или «ACTIVATED_BY_ORDER_TAKE_PROFIT_STOP_ORDER»
OFFSET_UNITS

Единицы измерения отступа. Возможные значения:

  • «PERCENTS» – в процентах (шаг изменения – одна сотая процента);
  • «PRICE_UNITS» – в параметрах цены (шаг изменения равен шагу цены по данному инструменту).

Используется при «STOP_ORDER_KIND» = «TAKE_PROFIT_STOP_ORDER» или «ACTIVATED_BY_ORDER_TAKE_PROFIT_STOP_ORDER»

SPREAD | Величина защитного спреда. Используется при «STOP_ORDER_KIND» = «TAKE_PROFIT_STOP_ORDER» или ACTIVATED_BY_ORDER_TAKE_PROFIT_STOP_ORDER»
SPREAD_UNITS

Единицы измерения защитного спреда. Возможные значения:

  • «PERCENTS» – в процентах (шаг изменения – одна сотая процента);
  • «PRICE_UNITS» – в параметрах цены (шаг изменения равен шагу цены по данному инструменту).

Используется при «STOP_ORDER_KIND» = «TAKE_PROFIT_STOP_ORDER» или «ACTIVATED_BY_ORDER_TAKE_PROFIT_STOP_ORDER»

BASE_ORDER_KEY | Регистрационный номер заявки-условия. Используется при «STOP_ORDER_KIND» = «ACTIVATED_BY_ORDER_SIMPLE_STOP_ORDER» или «ACTIVATED_BY_ORDER_TAKE_PROFIT_STOP_ORDER»
USE_BASE_ORDER_BALANCE | Признак использования в качестве объема заявки «по исполнению» исполненного количества инструментов заявки-условия. Возможные значения: «YES» или «NO». Используется при «STOP_ORDER_KIND» = «ACTIVATED_BY_ORDER_SIMPLE_STOP_ORDER» или «ACTIVATED_BY_ORDER_TAKE_PROFIT_STOP_ORDER»
ACTIVATE_IF_BASE_ORDER_PARTLY_FILLED | Признак активации заявки «по исполнению» при частичном исполнении заявки-условия. Возможные значения: «YES» или «NO». Используется при «STOP_ORDER_KIND» = «ACTIVATED_BY_ORDER_SIMPLE_STOP_ORDER» или «ACTIVATED_BY_ORDER_TAKE_PROFIT_STOP_ORDER»
BASE_CONTRACT | Идентификатор базового контракта для фьючерсов или опционов. Обязательный параметр снятия заявок на срочном рынке Московской Биржи
MODE

Режим перестановки заявок на срочном рынке Московской Биржи. Параметр операции «ACTION» = «MOVE_ORDERS» Возможные значения:

  • «0» – оставить количество в заявках без изменения;
  • «1» – изменить количество в заявках на новые;
  • «2» – при несовпадении новых количеств с текущим хотя бы в одной заявке, обе заявки снимаются;
  • «3» – при выставлении количество в заявках определяется как разность нового значения и значения исполненного количества соответствующей заявки. Если хотя бы в одной заявке новое количество меньше исполненного, обе заявки снимаются
FIRST_ORDER_NUMBER | Номер первой заявки
FIRST_ORDER_NEW_QUANTITY | Количество в первой заявке
FIRST_ORDER_NEW_PRICE | Цена в первой заявке
SECOND_ORDER_NUMBER | Номер второй заявки
SECOND_ORDER_NEW_QUANTITY | Количество во второй заявке
SECOND_ORDER_NEW_PRICE | Цена во второй заявке
KILL_ACTIVE_ORDERS | Признак снятия активных заявок по данному инструменту. Используется только при «ACTION» = «NEW_QUOTE». Возможные значения: «YES» или «NO»
NEG_TRADE_OPERATION | Направление операции в сделке, подтверждаемой отчетом
NEG_TRADE_NUMBER | Номер подтверждаемой отчетом сделки для исполнения
VOLUMEMN | Лимит открытых позиций, при «Тип лимита» = «Ден.средства» или «Всего»
KGO | Коэффициент клиентского гарантийного обеспечения
USE_KGO

Параметр, который определяет, будет ли загружаться величина КГО при загрузке лимитов из файла:

  • при USE_KGO=Y – величина КГО загружает;
  • при USE_KGO=N – величина КГО не загружается.

При установке лимита на срочном рынке Московской Биржи с принудительным понижением (см. Создание лимита) требуется указать USE_KGO= Y

CHECK_LIMITS | Признак проверки попадания цены заявки в диапазон допустимых цен. Параметр срочного рынка Московской Биржи. Необязательный параметр транзакций установки новых заявок по классам «Опционы ФОРТС» и «РПС: Опционы ФОРТС». Возможные значения: «YES» - выполнять проверку, «NO» - не выполнять
MATCHREF | Ссылка, которая связывает две сделки РЕПО или РПС. Сделка может быть заключена только между контрагентами, указавшими одинаковое значение этого параметра в своих заявках. Параметр представляет собой произвольный набор символов (допускаются цифры и буквы количеством до 10). Необязательный параметр
CORRECTION

Режим корректировки ограничения по фьючерсным счетам. Возможные значения:

  • «Y» - включен, установкой лимита изменяется действующее значение;
  • «N» - выключен (по умолчанию), установкой лимита задается новое значение

Команды снятия группы заявок по условию («KILL_ALL_ORDERS», «KILL_ALL_STOP_ORDERS», «KILL_ALL_NEG_DEALS», «KILL_ALL_FUTURES_ORDERS») обрабатываются следующим образом:

  1. Параметры «CLASSCODE», «TRANS_ID», «ACTION», «ACCOUNT» являются обязательными.
  2. Возможные дополнительные параметры для команд снятия заявок по условию:
    • «KILL_ALL_ORDERS»: «SECCODE», «ACCOUNT», «OPERATION», «CLIENT_CODE», «COMMENT»;
    • «KILL_ALL_STOP_ORDERS»: «SECCODE», «ACCOUNT», «OPERATION», «CLIENT_CODE», «COMMENT», «EXPIRY_DATE»;
    • «KILL_ALL_NEG_DEALS»: «SECCODE», «ACCOUNT», «OPERATION», «CLIENT_CODE», «COMMENT», «PARTNER», «SETTLE_CODE»;
    • «KILL_ALL_FUTURES_ORDERS»: «ACCOUNT», «OPERATION», «BASE_CONTRACT».
  3. Снятию подлежат заявки, соответствующие всем указанным в транзакции параметрам (логическое «И»).

Перестановка заявок на срочном рынке Московской Биржи выполняется по следующим правилам:

  • Если MODE=0, то заявки с номерами, указанными после ключей FIRST_ORDER_NUMBER и SECOND_ORDER_NUMBER, снимаются. В торговую систему отправляются две новые заявки, при этом изменяется только цена заявок, количество остается прежним;
  • Если MODE=1, то заявки с номерами, указанными после ключей FIRST_ORDER_NUMBER и SECOND_ORDER_NUMBER, снимаются. В торговую систему отправляются две новые заявки, при этом изменится как цена заявки, так и количество;
  • Если MODE=2, то заявки с номерами, указанными после ключей FIRST_ORDER_NUMBER и SECOND_ORDER_NUMBER, снимаются. Если количество инструментов в каждой из снятых заявок совпадает со значениями, указанными после FIRST_ORDER_NEW_QUANTITY и SECOND_ORDER_NEW_QUANTITY, то в торговую систему отправляются две новые заявки с соответствующими параметрами.

См. также Примеры строк, которые могут содержаться в файле


Примеры строк, которые могут содержаться в файле

Транзакция | Строка
Заявка на продажу Ростелеком, лимитированная, 3 лота по 43.21 руб. | ACCOUNT=NL0080000043; CLIENT_CODE=467; TYPE=L; TRANS_ID=1; CLASSCODE=TQBR; SECCODE=RU0008943394; ACTION=NEW_ORDER; OPERATION=S; PRICE=43,21; QUANTITY=3;
Заявка на покупку ЛУКОЙЛ, лимитированная, 3 лота по 253.3 руб. | ACCOUNT=NL0080000043; CLIENT_CODE=467; TYPE=L; TRANS_ID=2; CLASSCODE=TQBR; SECCODE=LKOH; ACTION=NEW_ORDER; OPERATION=B; PRICE=253,3; QUANTITY=3;
Заявка на покупку Русгидро, рыночная, 15 лотов | ACCOUNT=NL0080000043; CLIENT_CODE=467; TYPE=M; TRANS_ID=7; CLASSCODE=TQBR; SECCODE=HYDR; ACTION=NEW_ORDER; OPERATION=B; PRICE=0; QUANTITY=15;
Заявка на продажу Фьючерс LKOH-3.10, рыночная, 15 контрактов | ACCOUNT=SPBFUT00009; CLIENT_CODE= SPBFUT00009; TYPE=M; TRANS_ID=8; CLASSCODE=SPBFUT; SECCODE=LKH0; ACTION=NEW_ORDER; OPERATION=S; PRICE=16231; QUANTITY=15;
Внебиржевая заявка на покупку Ростелеком, лимитированная, 1 лот по 42.81 руб. | ACCOUNT=NL0080000043; CLIENT_CODE=467; TYPE=L; TRANS_ID=3; CLASSCODE=PSEQ; SECCODE=RU0008943394; ACTION= NEW_NEG_DEAL; OPERATION=B; PRICE=42,81; QUANTITY=1; PARTNER=NC0080000000;
Внебиржевая заявка на продажу РусГидро , лимитированная, 3 лота по 1.113 руб. | ACCOUNT=NL0080000043; CLIENT_CODE=467; TYPE=L; TRANS_ID=4; CLASSCODE=PSEQ; SECCODE=HYDR; ACTION=NEW_NEG_DEAL; OPERATION=S; PRICE=1,113; QUANTITY=3; PARTNER=NC0080100000;
Заявка на сделку РЕПО Газпром, продажа 10 лотов по 100 руб. сроком на 4 дня с расчетами R90 | ACTION=NEW_REPO_NEG_DEAL; TRANS_ID=135; CLASSCODE=RPMA; SECCODE=GAZP; ACCOUNT=NL0080000043; CLIENT_CODE=E1; PARTNER=NC0038900000; OPERATION=S; QUANTITY=10; PRICE=100; SETTLE_CODE=R90; REPOTERM=4; REPORATE=5; REFUNDRATE=6;
Заявка на сделку РЕПО-М Лукойл, покупка 10 лотов на сумму 16000 руб. сроком на1 день с расчетами S0. Для заключения сделки контрагент должен подать встречную заявку с указанием в поле «Ссылка» значения «link» | ACTION=NEW_EXT_REPO_NEG_DEAL; TRANS_ID=19; CLASSCODE=RPMA; SECCODE=LKOH; ACCOUNT=NL0080000043; CLIENT_CODE=Q7; PARTNER=NC0080100000; OPERATION=B; QUANTITY=10; REPOVALUE=16000; SETTLE_CODE=S0; REPOTERM=1; REPORATE=0; REFUNDRATE=0; BLOCK_SECURITIES=NO; MATCHREF=link
Стоп-лимит РусГидро, 100 лотов на продажу по цене 7,000, стоп-цена – 7,300, срок до 19 мая 2011 г. | ACTION=NEW_STOP_ORDER; ACCOUNT= NL0080000043; TRANS_ID=17; CLASSCODE=TQBR; SECCODE=HYDR; OPERATION=S; QUANTITY=100; CLIENT_CODE=467; STOPPRICE=7.3; PRICE=7.0; EXPIRY_DATE=20110519;
Стоп-заявка с условием по другому инструменту Ростелеком -ао , продажа 15 лотов по цене 7,000, условие по Ростелеком -ап, условие стоп-цены <= 8,000 | ACTION=NEW_STOP_ORDER; STOP_ORDER_KIND=CONDITION_PRICE_BY_OTHER_SEC; ACCOUNT= NL0080000043; QUANTITY=15; TRANS_ID=15; CLASSCODE=TQBR; SECCODE=RTKM; STOPPRICE_CLASSCODE=TQBR; STOPPRICE_SECCODE= RTKMP;STOPPRICE_CONDITION=<=; OPERATION=S; CLIENT_CODE=1001; STOPPRICE=8.0; PRICE=7.0;
Стоп-заявка со связанной заявкой РусГидро, покупка 15 лотов по цене 8,500, стоп-цена >= 8,000, и лимитированная заявка по 6,000 | ACTION=NEW_STOP_ORDER; STOP_ORDER_KIND=WITH_LINKED_LIMIT_ORDER; ACCOUNT= NL0080000043; TRANS_ID=16; CLASSCODE=TQBR; SECCODE=HYDR; OPERATION=B; QUANTITY=15; CLIENT_CODE=1001; STOPPRICE=8.0; PRICE=8.5; LINKED_ORDER_PRICE= 6.0; KILL_IF_LINKED_ORDER_PARTLY_FILLED=NO;
Тейк-профит Лукойл, покупка 1 лота, активация при достижении цены 265 с отступом в 5% и защитным интервалом в 5 пипсов, срок исполнения до 06.07.2010 | ACTION=NEW_STOP_ORDER; TRANS_ID=8; STOP_ORDER_KIND=TAKE_PROFIT_STOP_ORDER; STOPPRICE=265; CLIENT_CODE=Q5; OPERATION=B; SECCODE=LKOH; CLASSCODE=TQBR; ACCOUNT=L01-00000F00; QUANTITY=1; EXPIRY_DATE=20040706; OFFSET=5; OFFSET_UNITS=PERCENTS; SPREAD=5; SPREAD_UNITS=PRICE_UNITS;
Тейк-профит и стоп-лимит Лукойл, покупка 1 лота, активация тейк-профита при достижении цены 2000 с отступом в 5% и защитным спредом в 3%, стоп-цена 2222, цена лимитированной заявки 2255, время действия с 10:00:01 по 19:45:45 | ACTION=NEW_STOP_ORDER; TRANS_ID=10055; CLASSCODE= TQBR; SECCODE=LKOH; ACCOUNT=L01-00000F00; CLIENT_CODE=Q7; OPERATION=B; QUANTITY=1; PRICE=2255; STOPPRICE=2000; STOP_ORDER_KIND=TAKE_PROFIT_AND_STOP_LIMIT_ORDER; OFFSET=5; OFFSET_UNITS=PERCENTS; SPREAD=3; SPREAD_UNITS=PERCENTS; MARKET_TAKE_PROFIT=NO; STOPPRICE2=2222; IS_ACTIVE_IN_TIME=YES; ACTIVE_FROM_TIME=100001; ACTIVE_TO_TIME=194545; MARKET_STOP_LIMIT=NO
Тейк-профит по исполнению заявки по частичному исполнению заявки с номером 81874488 выставить тейк-профит на покупку Лукойла в объеме исполненной части заявки-условия, при достижении цены 265 с отступом 10 пипсов и защитным интервалом 10 пипсов | ACTION=NEW_STOP_ORDER; TRANS_ID=11; STOP_ORDER_KIND=ACTIVATED_BY_ORDER_TAKE_PROFIT_STOP_ORDER; BASE_ORDER_KEY=81874488; USE_BASE_ORDER_BALANCE=yes; ACTIVATE_IF_BASE_ORDER_PARTLY_FILLED=yes; SPREAD=10; OFFSET=10; OFFSET_UNITS=PRICE_UNITS; SPREAD_UNITS=PRICE_UNITS; STOPPRICE=265; CLIENT_CODE=Q5; OPERATION=B; SECCODE=LKOH; CLASSCODE=TQBR; ACCOUNT=L01-00000F00;
Стоп-лимит по исполнению заявки по частичному исполнению заявки с номером 81874488 выставить стоп-лимит на покупку Лукойла в объеме исполненной части заявки-условия, со стоп-ценой 271 и ценой заявки 270 | ACTION=NEW_STOP_ORDER; TRANS_ID=12; STOP_ORDER_KIND=ACTIVATED_BY_ORDER_SIMPLE_STOP_ORDER; BASE_ORDER_KEY=81874488; USE_BASE_ORDER_BALANCE=yes; ACTIVATE_IF_BASE_ORDER_PARTLY_FILLED=yes; PRICE=270; STOPPRICE=271; CLASSCODE=TQBR; SECCODE=LKOH; ACCOUNT=L01-00000F00; OPERATION=B; CLIENT_CODE=Q5;
Тейк-профит и стоп-лимит по исполнению заявки По частичному исполнению заявки с номером 123456 выставить тейк-профит на покупку Лукойла по рыночной цене, активация при достижении цены 2000 с отступом в 5 пипсов, и стоп-лимит: стоп-цена 1990, исполнение по рыночной цене | ACTION=NEW_STOP_ORDER; TRANS_ID=10060; CLASSCODE= TQBR; SECCODE=LKOH; ACCOUNT=L01-00000F00; CLIENT_CODE=Q7; OPERATION=B; PRICE=2010; STOPPRICE=2000; STOP_ORDER_KIND=ACTIVATED_BY_ORDER_TAKE_PROFIT_AND_STOP_LIMIT_ORDER; OFFSET=5; OFFSET_UNITS=PRICE_UNITS; SPREAD=3; SPREAD_UNITS=PRICE_UNITS; BASE_ORDER_KEY=123456; USE_BASE_ORDER_BALANCE=YES; ACTIVATE_IF_BASE_ORDER_PARTLY_FILLED=YES; MARKET_TAKE_PROFIT=YES; STOPPRICE2=1990; MARKET_STOP_LIMIT=YES
Снятие заявки с номером 503983 | CLASSCODE=TQBR; SECCODE=RU0009024277; TRANS_ID=5; ACTION=KILL_ORDER; ORDER_KEY=503983;
Снятие внебиржевой заявки с номером 503984 | CLASSCODE=TQBR; TRANS_ID=6; ACTION=KILL_NEG_DEAL; ORDER_KEY=503984;
Снятие всех заявок клиента с кодом Q6 | TRANS_ID=1; CLASSCODE=TQBR; ACTION=KILL_ALL_ORDERS; CLIENT_CODE=Q6;
Снятие всех стоп-заявок с направлением «на покупку» | TRANS_ID=2; CLASSCODE=TQBR; ACTION=KILL_ALL_STOP_ORDERS; OPERATION=B;
Снятие всех адресных заявок по классу «РПС: Акции 1-го уровня» | TRANS_ID=3; CLASSCODE=PSEQ; ACTION=KILL_ALL_NEG_DEALS;
Снятие всех заявок на срочном рынке Московской Биржи на покупку контрактов на курс акций Ростелеком -ао | TRANS_ID=50; ACCOUNT=SPBFUT00001; ACTION=KILL_ALL_FUTURES_ORDERS; OPERATION=B; CLASSCODE=SPBFUT; BASE_CONTRACT=RTKM;
Перестановка заявок на срочном рынке Московской Биржи | ACTION=MOVE_ORDERS; TRANS_ID=333; CLASSCODE=SPBFUT; SECCODE=EBM6; FIRM_ID=SPBFUT389; MODE=1; FIRST_ORDER_NUMBER=21445064; FIRST_ORDER_NEW_PRICE=10004; FIRST_ORDER_NEW_QUANTITY=4; SECOND_ORDER_NUMBER=21445065; SECOND_ORDER_NEW_PRICE=10004; SECOND_ORDER_NEW_QUANTITY=4;
Безадресная заявка на покупку РусГидро, 1 лот по 15.0 руб., коду расчетов T0, с признаком снятия активных безадресных заявок «НЕТ». Транзакция применима для классов МБ | ACTION=NEW_QUOTE; TRANS_ID=779; CLASSCODE=PSEQ; SECCODE=HYDR; OPERATION=B; QUANTITY=1; PRICE=15.0; SETTLE_CODE=T0; KILL_ACTIVE_ORDERS=NO;
Безадресная заявка на покупку МосЭнерго, 1 лот по 5.0 руб., код расчетов T0 с торговый счетом клиента L01-00000F00. Транзакция применима для классов СБК | ACTION=NEW_QUOTE; TRANS_ID=29; CLASSCODE=BPSEQ; SECCODE=MSNG; OPERATION=B; QUANTITY=1; PRICE=5.0; SETTLE_CODE=T0; ACCOUNT=L01-00000F00;
Снятие безадресной заявки с номером 15919 | ACTION=KILL_QUOTE; TRANS_ID=781; CLASSCODE=PSEQ; SECCODE=EESR; ORDER_KEY=15919;
Импорт ограничений по фьючерсным счетам по счету Трейдера 389_011, где лимит открытых позиций «Всего» составляет 20 млн. рублей | ACTION=SET_FUT_LIMIT; TRANS_ID=22; CLASSCODE=SPBFUT; ACCOUNT=389_011; VOLUMEMN=20000000,00; KGO=0,00; USE_KGO= Y;FIRM_ID=SPBFUT389;CORRECTION=N,
Подтверждение отчетом сделки для исполнения с номером 179205900 | ACTION=NEW_REPORT; TRANS_ID=15; CLASSCODE=RPMA; NEG_TRADE_OPERATION=B; NEG_TRADE_NUMBER=179205900;

См. также Формат .tri-файла с параметрами транзакций


Формат .tro-файла с результатами обработки транзакций

Файл представляет собой последовательность строк, каждая из которых содержит информацию по отдельной транзакции. Параметры транзакции описываются в виде «НАЗВАНИЕ_ПАРАМЕТРА= значение_параметра» и разделяются символом «;».

Параметры и принимаемые ими значения:

Параметр | Значение
TRANS_ID | Уникальный идентификационный номер заявки
STATUS

Результат выполнения операции. Может принимать одно из следующих значений:

  • «0» - транзакция отправлена серверу;
  • «1» - транзакция получена на сервер QUIK от клиента;
  • «2» - ошибка при передаче транзакции в торговую систему, поскольку отсутствует подключение шлюза Московской Биржи, повторно транзакция не отправляется;
  • «3» - транзакция выполнена;
  • «4» - транзакция не выполнена торговой системой, код ошибки торговой системы будет указан в поле «DESCRIPTION»;
  • «5» - транзакция не прошла проверку сервера QUIK по каким-либо критериям. Например, проверку на наличие прав у пользователя на отправку транзакции данного типа;
  • «6» - транзакция не прошла проверку лимитов сервера QUIK;
  • «10» - транзакция не поддерживается торговой системой. К примеру, попытка отправить «ACTION = MOVE_ORDERS» на Московской Бирже;
  • «11» - транзакция не прошла проверку правильности электронной подписи. К примеру, если ключи, зарегистрированные на сервере, не соответствуют подписи отправленной транзакции;
  • «12» - не удалось дождаться ответа на транзакцию, т.к. истек таймаут ожидания. Может возникнуть при подаче транзакций из QPILE;
  • «13» - транзакция отвергнута, т.к. ее выполнение могло привести к кросс-сделке (т.е. сделке с тем же самым клиентским счетом);
  • «14» – транзакция не прошла контроль дополнительных ограничений;
  • «15» – транзакция принята после нарушения дополнительных ограничений;
  • «16» – транзакция отменена пользователем в ходе проверки дополнительных ограничений
TRANS_NAME | Описание выполняемой транзакции, например «Ввод заявки»
DESCRIPTION | Текстовый комментарий к полю STATUS, содержащий ответ сервера QUIK или торговой системы
ORDER_NUMBER | Регистрационный номер заявки в торговой системе

Пример строки .tro-файла:

TRANS_ID=14;STATUS=0;TRANS_NAME="Ввод заявки"; DESCRIPTION="Отправлена транзакция";

TRANS_ID=14;STATUS=3;TRANS_NAME="Ввод заявки"; DESCRIPTION="(160) Заявка на покупку N 68359610 зарегистрирована."; ORDER_NUMBER=68359610;


Настройка импорта транзакций

  1. Из пункта меню Сервисы / Экспорт/импорт данных / Импорт транзакций из файла… откройте окно настройки импорта транзакций.
  2. В поле «Файл с исходными данными о транзакциях» введите полный путь к .tri-файлу c транзакциями, например, «C:\quikdata\input.tri».
  3. В поле «Обрабатывать через .. секунд» укажите периодичность чтения файла. Рекомендуемый интервал – 5 секунд.
  4. Если установлен флажок «Оповещать об обработке файла звуковым сигналом», то при каждом обращении к файлу программа будет подавать звуковой сигнал. Используйте его при необходимости для контроля над функционированием процесса импорта транзакций.
  5. В поле «Файл с данными об успешно отправленных транзакциях» введите полный путь к .tro-файлу, например, «C:\quikdata\output.tro».
  6. В поле «Файл с журналом отправляемых транзакциях» введите полный путь к .trr-файлу, например, «C:\quikdata\log.trr».
  7. Если установлен флажок «Вести журнал отправляемых транзакций», то в .trr-файл будет записываться информация об обработанных транзакциях.
  8. Следующие параметры («Число обращений сделанных к файлу» и т.д.) используются как статистика процесса импорта транзакций.
  9. Нажатие кнопки «Начать обработку» приводит к старту процесса импорта транзакций. Нажатием кнопки «Прекратить обработку» процесс импорта останавливается.
  10. Нажмите кнопку «Закрыть» для закрытия окна настройки с сохранением выполненных настроек. Если процесс импорта начат, он будет осуществляться автоматически в фоновом режиме.

Запись данных о транзакции в текстовый файл должна осуществляться целой строкой. Если запись параметров одной сделки будет производиться несколькими обращениями к файлу, то возможна ситуация, когда QUIK начнет чтение не полностью сформированной транзакции и она будет неправильно обработана либо отвергнута.

См. также Импорт транзакций.


Экспорт данных в системы технического анализа с использованием внешних программ

  • Назначение
  • Использование программы DDE2MS
  • Использование программы MetaServer RT
  • Настройка

    • Назначение

    Использование получаемых системой QUIK данных для оперативного технического анализа в программе Equis MetaStock в случае, если использование встроенных средств экспорта невозможно.

    Существует два распространенных способа экспорта информации – с использованием программ DDE2MS и MetaServer RT. Обе программы используют следующую схему передачи информации:

    • Из QUIK выводятся данные из Таблицы текущих торгов в Microsoft Excel, используя механизм DDE;
    • DDE2MS или MetaServer RT забирают обновляемые данные из Microsoft Excel и передают их в MetaStock.

    Программа DDE2MS, как нам показалось, более удобна в работе и настройке, является более предсказуемой, но, в отличие от MetaServer RT, демо-версия которого может закачивать данные по двум инструментам, DDE2MS может работать только с одной. Вы можете выбрать любой из этих вариантов.

    Использование программы DDE2MS

    1. Запустите программу DDE2MS (она поставляется в виде автономного exe-файла, полностью готового к работе).
    2. Заполните необходимые для работы параметры:
      • В поле «Path» укажите полный путь к созданному источнику данных MetaStock (например, «C:\MetaStock Data\SBER»);
      • В поле «Symbol» укажите имя источника данных (в нашем примере это будет «SBER»);
      • В поле «Interval» выберите «1»;
      • В поле «Server» введите «Excel»;
      • В поле «Topic» определяются Книга и Лист MS Excel, из которых будут забираться данные, в формате вида «[имя_книги.xls]имя_листа», например: «[Книга1.xls]Лист1»;
      • В полях «Item-Last Price» (цена последней сделки) и «Item-Volume» (количество инструментов в последней сделке) введите адреса ячеек MS Excel в формате «RxCy», из которых надо брать соответствующие данные, где «x»-номер строки, «y»-номер столбца (цифрами).
    3. Нажмите на кнопку «Start». Если DDE2MS найдет требуемые для работы данные, то появится таблица с текущими значениями OHLCV, название кнопки изменится на «Stop» и поля ввода станут неактивными. В противном случае будет показано сообщение об ошибке.

    Использование программы MetaServer RT

    1. Запустите программу MetaServerRT.
    2. Проверьте, имеется ли созданный в MetaStock источник (в примере - «SBER») в списке доступных источников. Если этого источника нет, выберите пункт меню «Symbol-Add new» и опишите созданный Вами источник (SBER).
    3. Выберите строку таблицы, соответствующую новому источнику данных (содержащую его наименование в столбце «TS/MS Symbol») и двойным нажатием левой кнопки мыши на строке откройте окно с настройками параметров источника.
    4. В открывшемся окне выполните следующие действия:
      • в поле «Global Server/MetaStock Symbol» введите имя источника данных;
      • в поле «DDE» наберите «Excel».
    5. Перейдите на вкладку «Easy-Setup tools»:
      • в поле «Topic» укажите книгу и лист MS Excel с данными из QUIK, в формате «[имя_книги.xls]имя_листа», например: «[Книга1.xls]Лист1»;
      • в поле «Item» введите адрес ячейки с данными, формата «RxCy», где «x» - номер строки, «y» - номер столбца, например: «R1C1».
    6. Нажмите на кнопки «Set».
    7. Перейдите обратно на вкладку «Tradestation/MetaStock», и поставьте все флажки («галочки»). Нажмите кнопку «Ok».
    8. Нажмите на панели управления программы MetaServerRT зелёную кнопку (с подсказкой «Start all instruments»). Если настройки были сделаны правильно и данные по инструменту доступны, то в строке таблицы с настраиваемым источником данных параметр «*» должен принять значение «+».

    Настройка

    Для того, чтобы MetaStock правильно воспринимал дробные числа, в региональных настройках Windows поставьте в качестве разделителя для дробных чисел «.» (точка), а не «,» (запятая), иначе данные не будут передаваться правильно.


Импорт транзакций через API

меню Сервисы / Экспорт/импорт данных / Внешние транзакции…
  • Назначение
  • Настройки

    • Назначение

    Данный функционал предназначен для отправки транзакций, подготовленных программой клиента. Функционал реализован в виде библиотеки Trans2QUIK.dll. Библиотека содержит в себе функции, описание которых приводится ниже, при вызове которых можно:

    1. Установить или разорвать связь между терминалом QUIK и библиотекой Trans2QUIK.dll.
    2. Проверить наличие соединения между терминалом QUIK и библиотекой Trans2QUIK.dll и между терминалом QUIK и сервером QUIK.
    3. Отправить транзакцию.
    4. Получить информацию по заявкам и сделкам.

    Существует два способа передачи транзакций – синхронный и асинхронный, которые реализуются отдельными функциями:

    1. При синхронной передаче транзакций выход из функции осуществляется только после получения ответа от сервера QUIK. Следовательно, отправлять синхронные транзакции можно только последовательно, дожидаясь ответа о каждой отправленной транзакции – этот способ проще и более подходит для программистов с небольшим опытом разработки программ.
    2. При асинхронной передаче транзакций выход из функции осуществляется сразу же. Для получения ответа об отправленных асинхронных транзакциях используется функция обратного вызова (callback). Функция вызывается при каждом получении ответа об исполненной или отвергнутой транзакции. Значения статусов исполнения транзакции, которые возвращаются в функции обратного вызова, приведены в описании к тем же статусам, которые используются при отправке транзакций через файл. Подробнее см. Импорт транзакций.

    Также предусмотрена функция обратного вызова для контроля за соединениями между терминалом QUIK и библиотекой Trans2QUIK.dll и между Рабочим местом QUIK и сервером QUIK.

    Описание транзакций при импорте через API аналогично описанию транзакций при импорте через файл. Подробнее см. Импорт транзакций. Исключением являются следующие типы транзакций, которые не поддерживаются библиотекой Trans2QUIK.dll:

    • «KILL_ALL_ORDERS» – снять все заявки из торговой системы;
    • «KILL_ALL_STOP_ORDERS» – снять все стоп-заявки;
    • «KILL_ALL_NEG_DEALS» – снять все заявки на внебиржевые сделки и заявки на сделки РЕПО.

    Для получения информации о заявках и сделках пользователь сначала должен сформировать список получаемых инструментов, раздельно для заявок и сделок. Затем выполняется запуск процедуры получения информации с помощью функций обратного вызова. При прекращении получения информации по заявкам и сделкам очищаются списки получаемых инструментов. Подробное описание см. Получение информации о заявках и сделках.

    Настройки

    Настройка импорта транзакции через API осуществляется в диалоге «Обработка внешних транзакций» (меню Сервисы / Экспорт/импорт данных / Внешние транзакции…).

    Обработка внешних транзакций начинается после нажатия на кнопку «Начать обработку».

    При установленном флажке «Запускать процесс обработки внешних транзакций автоматически» сервис обработки внешних транзакций запускается автоматически при загрузке Рабочего места QUIK.

    Статистика по полученным и отправленным транзакциям отображается в полях «Число полученных внешних транзакций» и «Число транзакций, отправленных на сервер».

    См. также:

    • Функции для работы с транзакциями через API
    • Получение информации о заявках и сделках


Функции для работы с транзакциями через API

  • Константы
  • Функции
    •

    Константы

    Описание констант, значения которых возвращаются при выходе из функций и процедур

    Константа | Значение
TRANS2QUIK_SUCCESS | 0
TRANS2QUIK_FAILED | 1
TRANS2QUIK_QUIK_TERMINAL_NOT_FOUND | 2
TRANS2QUIK_DLL_VERSION_NOT_SUPPORTED | 3
TRANS2QUIK_ALREADY_CONNECTED_TO_QUIK | 4
TRANS2QUIK_WRONG_SYNTAX | 5
TRANS2QUIK_QUIK_NOT_CONNECTED | 6
TRANS2QUIK_DLL_NOT_CONNECTED | 7
TRANS2QUIK_QUIK_CONNECTED | 8
TRANS2QUIK_QUIK_DISCONNECTED | 9
TRANS2QUIK_DLL_CONNECTED | 10
TRANS2QUIK_DLL_DISCONNECTED | 11
TRANS2QUIK_MEMORY_ALLOCATION_ERROR | 12
TRANS2QUIK_WRONG_CONNECTION_HANDLE | 13
TRANS2QUIK_WRONG_INPUT_PARAMS | 14

    Функции

    Перечень функций для работы с транзакциями через API

    Параметр | Назначение
TRANS2QUIK_CONNECT | Установление связи библиотеки Trans2QUIK.dll с Рабочим местом QUIK
TRANS2QUIK_DISCONNECT | Разрыв соединения библиотеки Trans2QUIK.dll с Рабочим местом QUIK
TRANS2QUIK_IS_DLL_CONNECTED | Проверка соединения библиотеки Trans2QUIK.dll с Рабочим местом QUIK
TRANS2QUIK_IS_QUIK_CONNECTED | Проверка соединения терминала QUIK с сервером QUIK
TRANS2QUIK_SEND_SYNC_TRANSACTION | Отправка синхронной транзакции
TRANS2QUIK_SEND_ASYNC_TRANSACTION | Отправка асинхронной транзакции
TRANS2QUIK_CONNECTION_STATUS_CALLBACK | Описание прототипа функции обратного вызова для контроля за состоянием соединения между Trans2QUIK.dll и используемым терминалом QUIK и между используемым терминалом QUIK и сервером
TRANS2QUIK_SET_CONNECTION_STATUS_CALLBACK | Описание прототипа функции обратного вызова для обработки полученной информации о соединении
TRANS2QUIK_TRANSACTION_REPLY_CALLBACK | Описание прототипа функции обратного вызова для обработки полученной информации об отправленной транзакции
TRANS2QUIK_SET_TRANSACTIONS_REPLY_CALLBACK | Функция устанавливает функцию обратного вызова TRANS2QUIK_TRANSACTION_REPLY_CALLBACK
TRANS2QUIK_ORDER_STATUS_CALLBACK | Описание прототипа функции обратного вызова для обработки полученной информации по заявке
TRANS2QUIK_TRADE_STATUS_CALLBACK | Описание прототипа функции обратного вызова для обработки полученной информации по сделке
TRANS2QUIK_SUBSCRIBE_ORDERS | Функция создания списка инструментов по классам, по которому будут приниматься заявки
TRANS2QUIK_SUBSCRIBE_TRADES | Функция создания списка инструментов по классам, по которому будут приниматься сделки
TRANS2QUIK_START_ORDERS | Вызов функции инициирует процесс получения заявок по инструментам, список которых был сформирован предварительным вызовом функции TRANS2QUIK_SUBSCRIBE_ORDERS
TRANS2QUIK_START_TRADES | Вызов функции инициирует процесс получения сделок по инструментам, список которых был сформирован предварительным вызовом функции TRANS2QUIK_SUBSCRIBE_TRADES
TRANS2QUIK_UNSUBSCRIBE_ORDERS | Вызов функции прерывает работу функции TRANS2QUIK_START_ORDERS и производит очистку списка получаемых инструментов, сформированного функцией TRANS2QUIK_SUBSCRIBE_ORDERS
TRANS2QUIK_UNSUBSCRIBE_TRADES | Вызов функции прерывает работу функции TRANS2QUIK_START_TRADES и производит очистку списка получаемых инструментов, сформированного функцией TRANS2QUIK_SUBSCRIBE_TRADES

    См. также Импорт транзакций через API


Функция TRANS2QUIK_CONNECT

Функция используется для установления связи библиотеки Trans2QUIK.dll с Рабочим местом QUIK.

long __stdcall TRANS2QUIK_CONNECT (LPCSTR lpcstrConnectionParamsString, long* nTransactionExtendedErrorCode, LPSTR lpstrErrorMessage, DWORD dwErrorMessageSize)

Параметр | Описание
Result

Тип: Long. Возвращаемое число может принимать следующие значения:

  • TRANS2QUIK_SUCCESS – соединение установлено успешно;
  • TRANS2QUIK_QUIK_TERMINAL_NOT_FOUND – в указанном каталоге либо отсутствует INFO.EXE, либо у него не запущен сервис обработки внешних подключений, в nTransactionExtendedErrorCode в этом случае передается 0;
  • TRANS2QUIK_DLL_VERSION_NOT_SUPPORTED – используемая версия Trans2QUIK.dll не поддерживается указанным INFO.EXE, в nTransactionExtendedErrorCode в этом случае передается 0;
  • TRANS2QUIK_DLL_ALREADY_CONNECTED_TO_QUIK - соединение уже установлено, в nTransactionExtendedErrorCode в этом случае передается 0;
  • TRANS2QUIK_FAILED – произошла ошибка при установлении соединения, в nTransactionExtendedErrorCode в этом случае передается дополнительный код ошибки
lpcstrConnectionParamsString | Тип: указатель на переменную типа Строка. Полный путь к каталогу с исполняемым файлом INFO.EXE, с которым устанавливается соединение
nTransactionExtendedErrorCode | Тип: указатель на переменную типа Long. В случае возникновения ошибки может содержать расширенный код ошибки
lpstrErrorMessage | Тип: указатель на переменную типа Строка. В случае возникновения ошибки может получать сообщение о возникшей ошибке
dwErrorMessageSize | Тип: Long. Содержит длину строки, на которую ссылается указатель lpstrErrorMessage

См. также Функции для работы с транзакциями через API


Функция TRANS2QUIK_DISCONNECT

Функция используется для разрыва связи библиотеки __stdcall Trans2QUIK.dll с Рабочим местом QUIK.

long __stdcall TRANS2QUIK_DISCONNECT (long* nTransactionExtendedErrorCode, LPSTR lpstrErrorMessage, DWORD dwErrorMessageSize)

Параметр | Описание
Result

Тип: Long. Возвращаемое число может принимать следующие значения:

  • TRANS2QUIK_SUCCESS – соединение библиотеки Trans2QUIK.dll с Рабочим местом QUIK разорвано успешно;
  • TRANS2QUIK_FAILED – произошла ошибка при разрыве соединения, в nTransactionExtendedErrorCode в этом случае передается дополнительный код ошибки;
  • TRANS2QUIK_DLL_NOT_CONNECTED – попытка разорвать соединение при не установленной связи. В этом случае в nTransactionExtendedErrorCode может передаваться дополнительный код ошибки
nTransactionExtendedErrorCode | Тип: указатель на переменную типа Long. В случае возникновения ошибки может содержать расширенный код ошибки
lpstrErrorMessage | Тип: указатель на переменную типа Строка. В случае возникновения ошибки может получать сообщение о возникшей ошибке
dwErrorMessageSize | Тип: Long. Содержит длину строки, на которую ссылается указатель lpstrErrorMessage

См. также Функции для работы с транзакциями через API


Функция TRANS2QUIK_IS_QUIK_CONNECTED

Функция используется для проверки наличия соединения между терминалом QUIK и сервером.

long __stdcall TRANS2QUIK_IS_QUIK_CONNECTED (long* nTransactionExtendedErrorCode, LPSTR lpstrErrorMessage, DWORD dwErrorMessageSize)

Параметр | Описание
Result

Тип: Long. Возвращаемое число может принимать следующие значения:

  • TRANS2QUIK_QUIK_CONNECTED – соединение установлено;
  • TRANS2QUIK_QUIK_NOT_CONNECTED – соединение не установлено;
  • TRANS2QUIK_DLL_NOT_CONNECTED – не установлена связь библиотеки Trans2QUIK.dll с терминалом QUIK. В этом случае проверить наличие или отсутствие связи терминала QUIK с сервером невозможно
nTransactionExtendedErrorCode | Тип: указатель на переменную типа Long. В случае возникновения ошибки может содержать расширенный код ошибки
lpstrErrorMessage | Тип: указатель на переменную типа Строка. В случае возникновения ошибки может получать сообщение о возникшей ошибке
dwErrorMessageSize | Тип: Long. Содержит длину строки, на которую ссылается указатель lpstrErrorMessage

См. также Функции для работы с транзакциями через API


Функция TRANS2QUIK_IS_DLL_CONNECTED

Функция используется для проверки наличия соединения между библиотекой Trans2QUIK.dll и терминалом QUIK.

long __stdcall TRANS2QUIK_IS_DLL_CONNECTED (long* nTransactionExtendedErrorCode, LPSTR lpstrErrorMessage, DWORD dwErrorMessageSize)

Параметр | Описание
Result

Тип: Long. Возвращаемое число может принимать следующие значения:

  • TRANS2QUIK_DLL_CONNECTED – соединение библиотеки Trans2QUIK.dll с терминалом QUIK установлено;
  • TRANS2QUIK_DLL_NOT_CONNECTED – не установлена связь библиотеки Trans2QUIK.dll с терминалом QUIK
nTransactionExtendedErrorCode | Тип: указатель на переменную типа Long. В случае возникновения ошибки может содержать расширенный код ошибки
lpstrErrorMessage | Тип: указатель на переменную типа Строка. В случае возникновения ошибки может получать сообщение о возникшей ошибке
dwErrorMessageSize | Тип: Long. Содержит длину строки, на которую ссылается указатель lpstrErrorMessage

См. также Функции для работы с транзакциями через API


Функция TRANS2QUIK_SEND_SYNC_TRANSACTION

Синхронная отправка транзакции. При синхронной отправке возврат из функции происходит только после получения результата выполнения транзакции, либо после разрыва связи терминала QUIK с сервером.

long __stdcall TRANS2QUIK_SEND_SYNC_TRANSACTION (LPSTR lpstTransactionString, long* pnReplyCode, PDWORD pdwTransId, double* pdOrderNum, LPSTR lpstrResultMessage, DWORD dwResultMessageSize, long* nTransactionExtendedErrorCode, LPSTR lpstErrorMessage, DWORD dwErrorMessageSize)

Параметр | Описание
Result

Тип: Long. Возвращаемое число может принимать следующие значения:

  • TRANS2QUIK_SUCCESS – транзакция успешно отправлена на сервер;
  • TRANS2QUIK_WRONG_SYNTAX – строка транзакции заполнена неверно;
  • TRANS2QUIK_DLL_NOT_CONNECTED – отсутствует соединение между библиотекой Trans2QUIK.dll и терминалом QUIK;
  • TRANS2QUIK_QUIK_NOT_CONNECTED – отсутствует соединение между терминалом QUIK и сервером;
  • TRANS2QUIK_FAILED – в nTransactionExtendedErrorCode в этом случае может передаваться дополнительный код ошибки
lpstrTransactionString | Тип: указатель на переменную типа Строка. Строка с описанием транзакции. Формат строки тот же самый, что и при отправке транзакций через файл
pnReplyCode | Тип: указатель типа Long. Получает статус выполнения транзакции. Значения статусов те же самые, что и при подаче заявок через файл (см. Формат .tro-файла с результатами обработки транзакций)
pdwTransId | Тип: указатель типа Long. Получает значение TransID транзакции, указанной пользователем
pdOrderNum | Тип: указатель типа Double. В случае успеха получает номер заявки в торговой системе
lpstrResultMessage | Тип: указатель на переменную типа Строка. В случае успеха содержит сообщение торговой системы
dwResultMessageSize | Тип: Long. Содержит длину строки, на которую ссылается указатель lpstrResultMessage
nTransactionExtendedErrorCode | Тип: указатель на переменную типа Long. В случае возникновения ошибки может содержать расширенный код ошибки
lpstrErrorMessage | Тип: указатель на переменную типа Строка. В случае возникновения ошибки может получать сообщение о возникшей ошибке
dwErrorMessageSize | Тип: Long. Содержит длину строки, на которую ссылается указатель lpstrErrorMessage

См. также Функции для работы с транзакциями через API


Функция TRANS2QUIK_SEND_ASYNC_TRANSACTION

Асинхронная передача транзакции. При отправке асинхронной транзакции возврат из функции происходит сразу же, а результат выполнения транзакции сообщается через соответствующую функцию обратного вызова.

long __stdcall TRANS2QUIK_SEND_ASYNC_TRANSACTION (LPSTR lpstTransactionString, long* nTransactionExtendedErrorCode, LPSTR lpstErrorMessage, DWORD dwErrorMessageSize)

Параметр | Описание
Result

Тип: Long. Возвращаемое число может принимать следующие значения:

  • TRANS2QUIK_SUCCESS – транзакция успешно отправлена на сервер;
  • TRANS2QUIK_WRONG_SYNTAX – строка транзакции заполнена неверно;
  • TRANS2QUIK_DLL_NOT_CONNECTED – отсутствует соединение между библиотекой Trans2QUIK.dll и терминалом QUIK;
  • TRANS2QUIK_QUIK_NOT_CONNECTED – отсутствует соединение между терминалом QUIK и сервером;
  • TRANS2QUIK_FAILED – транзакцию отправить не удалось. В этом случае в переменную nTransactionExtendedErrorCode может передаваться дополнительный код ошибки
lpstrTransactionString | Тип: указатель на переменную типа Строка. Строка с описанием транзакции. Формат строки такой же, что и при отправке транзакций через файл
nTransactionExtendedErrorCode | Тип: указатель на переменную типа Long. В случае возникновения ошибки может содержать расширенный код ошибки
lpstrErrorMessage | Тип: указатель на переменную типа Строка. В случае возникновения ошибки может получать сообщение о возникшей ошибке
dwErrorMessageSize | Тип: Long. Содержит длину строки, на которую ссылается указатель lpstrErrorMessage

См. также Функции для работы с транзакциями через API


Функция TRANS2QUIK_CONNECTION_STATUS_CALLBACK

Описание прототипа функции обратного вызова для контроля за состоянием соединения между библиотекой Trans2QUIK.dll и используемым терминалом QUIK и между используемым терминалом QUIK и сервером.

void __stdcall TRANS2QUIK_CONNECTION_STATUS_CALLBACK (long nConnectionEvent, long nTransactionExtendedErrorCode, LPSTR lpstrInfoMessage)

Параметр | Описание
nConnectionEvent

Тип: Long. Возвращаемое число может принимать следующие значения:

  • TRANS2QUIK_QUIK_CONNECTED – соединение между терминалом QUIK и сервером установлено;
  • TRANS2QUIK_QUIK_DISCONNECTED – соединение между терминалом QUIK и сервером разорвано;
  • TRANS2QUIK_DLL_CONNECTED – соединение между DLL и используемым терминалом QUIK установлено;
  • TRANS2QUIK_DLL_DISCONNECTED – соединение между DLL и используемым терминалом QUIK разорвано
nTransactionExtendedErrorCode | Тип: Long. В случае возникновения ошибки может содержать расширенный код ошибки
lpstrErrorMessage | Тип: указатель на переменную типа Строка. В случае возникновения ошибки может получать сообщение о возникшей ошибке

См. также Функции для работы с транзакциями через API


Функция TRANS2QUIK_SET_CONNECTION_STATUS_CALLBACK

Описание прототипа функции обратного вызова для обработки полученной информации о соединении.

long __stdcall TRANS2QUIK_SET_CONNECTION_STATUS_CALLBACK (TRANS2QUIK_CONNECTION_STATUS_CALLBACK pfConnectionStatusCallback, long* nTransactionExtendedErrorCode, LPSTR lpstrErrorMessage, DWORD dwErrorMessageSize)

Параметр | Описание
Result

Тип: Long. Возвращаемое число может принимать следующие значения:

  • TRANS2QUIK_SUCCESS – функция обратного вызова установлена;
  • TRANS2QUIK_FAILED – функцию обратного вызова установить не удалось. В этом случае в переменную nTransactionExtendedErrorCode может передаваться дополнительный код ошибки
TRANS2QUIK_CONNECTION_STATUS_CALLBACK | Тип: указатель на функцию. Указывается адрес функции, которая будет обрабатывать информацию о состоянии связи библиотеки Trans2QUIK.dll с терминалом QUIK или терминала QUIK с сервером
nTransactionExtendedErrorCode | Тип: указатель на переменную типа Long. В случае возникновения ошибки может содержать расширенный код ошибки
lpstrErrorMessage | Тип: указатель на переменную типа Строка. В случае возникновения ошибки может получать сообщение о возникшей ошибке
dwErrorMessageSize | Тип: Long. Содержит длину строки, на которую ссылается указатель lpstrErrorMessage

См. также Функции для работы с транзакциями через API


Функция TRANS2QUIK_TRANSACTION_REPLY_CALLBACK

Описание прототипа функции обратного вызова для обработки полученной информации об отправленной транзакции.

Подача асинхронных транзакций с использованием функции обратного вызова и синхронных транзакций одновременно запрещена. Это связано с тем, что невозможно корректно вызвать функцию обратного вызова в момент, когда функция обработки синхронной транзакции еще не закончила свою работу.

void __stdcall TRANS2QUIK_TRANSACTION_REPLY_CALLBACK(long nTransactionResult, long nTransactionExtendedErrorCode, long nTransactionReplyCode, DWORD dwTransId, unsigned__int64 dOrderNum, LPSTR lpstrTransactionReplyMessage, intptr_t transReplyDescriptor)

Параметр | Описание
nTransactionResult

Тип: Long. Возвращаемое число может принимать следующие значения:

  • TRANS2QUIK_SUCCESS – транзакция передана успешно;
  • TRANS2QUIK_DLL_NOT_CONNECTED – отсутствует соединение между библиотекой Trans2QUIK.dll и терминалом QUIK;
  • TRANS2QUIK_QUIK_NOT_CONNECTED – отсутствует соединение между терминалом QUIK и сервером;
  • TRANS2QUIK_FAILED – транзакцию передать не удалось. В этом случае в переменную nTransactionExtendedErrorCode может передаваться дополнительный код ошибки
nTransactionExtendedErrorCode | Тип: Long. В случае возникновения проблемы при выходе из функции обратного вызова в переменную может быть помещен расширенный код ошибки
nTransactionReplyCode | Тип: Long. Указатель для получения статуса выполнения транзакции. Значения статусов те же самые, что и при подаче заявок через файл
dwTransId | Тип: Long. Содержимое параметра TransId, который получила зарегистрированная транзакция
dOrderNum | Тип: unsigned__int64. Номер заявки, присвоенный торговой системой в результате выполнения транзакции
lpstrTransactionReplyMessage | Тип: указатель на переменную типа Строка. Сообщение от торговой системы или сервера QUIK
transReplyDescriptor Тип: intptr_t. Дескриптор ответа на транзакцию, может использоваться для следующих специальных функций в теле функции обратного вызова:
  • LPTSTR __stdcall TRANS2QUIK_TRANSACTION_REPLY_CLASS_CODE (intptr_t transReplyDescriptor) – возвращает код класса, по которому подана транзакция;
  • LPTSTR __stdcall TRANS2QUIK_TRANSACTION_REPLY_SEC_CODE (intptr_t transReplyDescriptor) – возвращает код инструмента, по которому выставлена транзакция;
  • double __stdcall TRANS2QUIK_TRANSACTION_REPLY_PRICE (intptr_t transReplyDescriptor) – возвращает цену сделки;
  • __int64 __stdcall TRANS2QUIK_TRANSACTION_REPLY_QUANTITY (intptr_t transReplyDescriptor) – возвращает количество;
  • __int64 __stdcall TRANS2QUIK_TRANSACTION_REPLY_BALANCE (intptr_t transReplyDescriptor) – возвращает остаток;
  • LPTSTR __stdcall TRANS2QUIK_TRANSACTION_REPLY_FIRMID (intptr_t transReplyDescriptor) – возвращает код фирмы;
  • LPTSTR __stdcall TRANS2QUIK_TRANSACTION_REPLY_ACCOUNT (intptr_t transReplyDescriptor) – возвращает торговый счет;
  • LPTSTR __stdcall TRANS2QUIK_TRANSACTION_REPLY_CLIENT_CODE (intptr_t transReplyDescriptor) – возвращает код клиента;
  • LPTSTR __stdcall TRANS2QUIK_TRANSACTION_REPLY_BROKERREF (intptr_t transReplyDescriptor) – возвращает комментарий;
  • LPTSTR __stdcall TRANS2QUIK_TRANSACTION_REPLY_EXCHANGE_CODE (intptr_t transReplyDescriptor) – возвращает биржевой номер заявки;
  • short TRANS2QUIK_TRANSACTION_REPLY_ORDERS_COUNT(TransactionReplyDescriptor tradeDescriptor) – возвращает количество заявок;
  • EntityNumber TRANS2QUIK_TRANSACTION_REPLY_FIRST_ORDER_NUMBER_BY_ID(TransactionReplyDescriptor tradeDescriptor, int orderId) – возвращает исходный номер заявки;
  • EntityNumber TRANS2QUIK_TRANSACTION_REPLY_ORDER_NUMBER_BY_ID(TransactionReplyDescriptor tradeDescriptor, int orderId) – возвращает номер заявки;
  • double TRANS2QUIK_TRANSACTION_REPLY_PRICE_BY_ID(TransactionReplyDescriptor tradeDescriptor, int orderId) – возвращает цену;
  • Quantity TRANS2QUIK_TRANSACTION_REPLY_QUANTITY_BY_ID(TransactionReplyDescriptor tradeDescriptor, int orderId) – возвращает количество;
  • Quantity TRANS2QUIK_TRANSACTION_REPLY_BALANCE_BY_ID(TransactionReplyDescriptor tradeDescriptor, int orderId) – возвращает остаток;
  • LPTSTR TRANS2QUIK_TRANSACTION_REPLY_FIRMID_BY_ID(TransactionReplyDescriptor tradeDescriptor, int orderId) – возвращает код фирмы;
  • LPTSTR TRANS2QUIK_TRANSACTION_REPLY_ACCOUNT_BY_ID(TransactionReplyDescriptor tradeDescriptor, int orderId) – возвращает торговый счет;
  • LPTSTR TRANS2QUIK_TRANSACTION_REPLY_CLIENT_CODE_BY_ID(TransactionReplyDescriptor tradeDescriptor, int orderId) – возвращает код клиента;
  • LPTSTR TRANS2QUIK_TRANSACTION_REPLY_BROKERREF_BY_ID(TransactionReplyDescriptor tradeDescriptor, int orderId) – возвращает комментарий

См. также Функции для работы с транзакциями через API


Функция TRANS2QUIK_SET_TRANSACTIONS_REPLY_CALLBACK

Устанавливает функцию обратного вызова для получения информации об отправленной асинхронной транзакции.

long __stdcall TRANS2QUIK_SET_TRANSACTIONS_REPLY_CALLBACK (TRANS2QUIK_TRANSACTION_REPLY_CALLBACK pfTransactionReplyCallback, long* nTransactionExtendedErrorCode, LPSTR lpstrErrorMessage, DWORD dwErrorMessageSize)

Параметр | Описание
Result

Тип: Long. Возвращаемое число может принимать следующие значения:

  • TRANS2QUIK_SUCCESS – функция обратного вызова установлена;
  • TRANS2QUIK_FAILED – функцию обратного вызова установить не удалось. В этом случае в переменную nTransactionExtendedErrorCode может передаваться дополнительный код ошибки
TRANS2QUIK_TRANSACTION_REPLY_CALLBACK | Тип: указатель на функцию. Указывается ссылка на функцию, которая будет обрабатывать информацию об отправленной транзакции
nTransactionExtendedErrorCode | Тип: указатель на переменную типа Long. В случае возникновения ошибки может содержать расширенный код ошибки
lpstrErrorMessage | Тип: указатель на переменную типа Строка. В случае возникновения ошибки может получать сообщение о возникшей ошибке
dwErrorMessageSize | Тип: Long. Содержит длину строки, на которую ссылается указатель lpstrErrorMessage

См. также Функции для работы с транзакциями через API


Функция TRANS2QUIK_ORDER_STATUS_CALLBACK

Функция обратного вызова для получения информации о параметрах заявки.

void __stdcall TRANS2QUIK_ORDER_STATUS_CALLBACK (long nMode, DWORD dwTransID, unsigned__int64 dNumber, LPSTR lpstrClassCode, LPSTR lpstrSecCode, double dPrice, __int64 nBalance, double dValue, long nIsSell, long nStatus, intptr_t nOrderDescriptor)

Параметр | Описание
nMode | Тип: Long. Признак того, идет ли начальное получение заявок или нет, возможные значения: «0» – новая заявка, «1» - идет начальное получение заявок, «2» – получена последняя заявка из начальной рассылки
dwTransID | Тип: Long. TransID транзакции, породившей заявку. Имеет значение «0», если заявка не была порождена транзакцией из файла, либо если TransID неизвестен
dNumber | Тип: unsigned__int64. Номер заявки
lpstrClassCode | Тип: указатель на переменную типа Строка. Код класса
lpstrSecCode | Тип: указатель на переменную типа Строка. Код инструмента
dPrice | Тип: Double. Цена заявки
nBalance | Тип: __int64. Неисполненный остаток заявки
dValue | Тип: Double. Объем заявки
nIsSell | Тип: Long. Направление заявки: «0» еcли «Покупка», иначе «Продажа»
nStatus | Тип: Long. Состояние исполнения заявки: Значение «1» соответствует состоянию «Активна», «2» - «Снята», иначе «Исполнена»
nOrderDescriptor

Тип: intptr_t. Дескриптор заявки, может использоваться для следующих специальных функций в теле функции обратного вызова:

  • __int64 __stdcall TRANS2QUIK_ORDER_QTY (intptr_t nOrderDescriptor) – возвращает количество заявки;
  • long __stdcall TRANS2QUIK_ORDER_DATE (intptr_t nOrderDescriptor) – возвращает дату заявки;
  • long __stdcall TRANS2QUIK_ORDER_TIME (intptr_t nOrderDescriptor) – возвращает время заявки;
  • long __stdcall TRANS2QUIK_ORDER_ACTIVATION_TIME (intptr_t nOrderDescriptor) – возвращает время активации заявки;
  • long __stdcall TRANS2QUIK_ORDER_WITHDRAW_TIME (intptr_t nOrderDescriptor) – возвращает время снятия заявки;
  • long __stdcall TRANS2QUIK_ORDER_EXPIRY (intptr_t nOrderDescriptor) – возвращает дату окончания срока действия заявки;
  • double __stdcall TRANS2QUIK_ORDER_ACCRUED_INT (intptr_t nOrderDescriptor) – возвращает накопленный купонный доход заявки;
  • double __stdcall TRANS2QUIK_ORDER_YIELD (intptr_t nOrderDescriptor) – возвращает доходность заявки;
  • LPSTR __stdcall TRANS2QUIK_ORDER_USERID (intptr_t nOrderDescriptor) – возвращает строковый идентификатор трейдера, от имени которого отправлена заявка;
  • long __stdcall TRANS2QUIK_ORDER_UID (intptr_t nOrderDescriptor) – возвращает UserID пользователя, указанный в заявке;
  • LPSTR __stdcall TRANS2QUIK_ORDER_ACCOUNT (intptr_t nOrderDescriptor) – возвращает торговый счет, указанный в заявке;
  • LPSTR __stdcall TRANS2QUIK_ORDER_BROKERREF (intptr_t nOrderDescriptor) – возвращает комментарий заявки;
  • LPSTR __stdcall TRANS2QUIK_ORDER_CLIENT_CODE (intptr_t nOrderDescriptor) – возвращает код клиента, отправившего заявку;
  • LPSTR __stdcall TRANS2QUIK_ORDER_FIRMID (intptr_t nOrderDescriptor) – возвращает строковый идентификатор организации пользователя, отправившего заявку;
  • __int64 __stdcall TRANS2QUIK_ORDER_VISIBLE_QTY (intptr_t nOrderDescriptor) - возвращает видимое количество для заявок типа «Айсберг»;
  • long __stdcall TRANS2QUIK_ORDER_PERIOD (intptr_t nOrderDescriptor) – возвращает период, когда была выставлена заявка, возможные значения: «0» - «Открытие», «1» - «Нормальный», «2» - «Закрытие»;
  • FILETIME __stdcall TRANS2QUIK_ORDER_FILETIME (intptr_t nOrderDescriptor) – возвращает дату и время выставления заявки в формате YY.MM.DD HH:MM:SS.MS;
  • FILETIME __stdcall TRANS2QUIK_ORDER_WITHDRAW_FILETIME (intptr_t nOrderDescriptor) – возвращает дату и время снятия заявки в формате YY.MM.DD HH:MM:SS.MS;
  • long __stdcall TRANS2QUIK_ORDER_DATE_TIME (intptr_t nOrderDescriptor, long nTimeType) – возвращает временные параметры заявки в зависимости от значения параметра nTimeType. Параметр nTimeType может принимать следующие значения:
    • «0» - функция возвращает дату выставления заявки в формате YYYYMMDD,
    • «1» - функция возвращает время выставления заявки в формате HHMMSS,
    • «2» - функция возвращает микросекунды времени выставления заявки, целое число от 0 до 999999,
    • «3» - функция возвращает дату снятия заявки в формате YYYYMMDD,
    • «4» - функция возвращает время снятия заявки в формате HHMMSS,
    • «5» - функция возвращает микросекунды времени снятия заявки, целое число от 0 до 999999
  • long __stdcall TRANS2QUIK_ORDER_VALUE_ENTRY_TYPE (intptr_t nOrderDescriptor) – возвращает способ указания объема заявки; возможные значения: «0» – не определен, «1» – количество, «2» – объем;
  • long __stdcall TRANS2QUIK_ORDER_EXTENDED_FLAGS (intptr_t nOrderDescriptor) – возвращает расширенные флаги заявки;
  • __int64 __stdcall TRANS2QUIK_ORDER_MIN_QTY (intptr_t nOrderDescriptor) – возвращает минимально допустимое количество; «0» – ограничение не задано;
  • long __stdcall TRANS2QUIK_ORDER_EXEC_TYPE (intptr_t nOrderDescriptor) – возвращает тип исполнения заявки; «0» – значение не задано;
  • double __stdcall TRANS2QUIK_ORDER_AWG_PRICE (intptr_t nOrderDescriptor) – возвращает среднюю цену приобретения при частичном исполнении заявки;
  • LPTSTR __stdcall TRANS2QUIK_ORDER_REJECT_REASON (intptr_t nOrderDescriptor) – возвращает причину отклонения заявки брокером

См. также:

  • Функции для работы с транзакциями через API
  • Получение информации о заявках и сделках


Функция TRANS2QUIK_TRADE_STATUS_CALLBACK

Функция обратного вызова для получения информации о сделке.

long __stdcall TRANS2QUIK_TRADE_STATUS_CALLBACK (long nMode, unsigned__int64 dNumber, unsigned__int64 dOrderNum, LPSTR lpstrClassCode, LPSTR lpstrSecCode, double dPrice, __int64 nQty, double dValue, long nIsSell, intptr_t nTradeDescriptor)

Параметр | Описание
nMode | Тип: Long. Признак того, идет ли начальное получение сделок или нет, возможные значения: «0» – новая сделка, «1» - идет начальное получение сделок, «2» – получена последняя сделка из начальной рассылки
dNumber | Тип: unsigned__int64. Номер сделки
dOrderNum | Тип: unsigned__int64. Номер заявки, породившей сделку
lpstrClassCode | Тип: указатель на переменную типа Строка. Код класса
lpstrSecCode | Тип: указатель на переменную типа Строка. Код инструмента
dPrice | Тип: Double. Цена сделки
nQty | Тип: __int64. Количество сделки
nIsSell | Тип: Long. Направление сделки: «0» еcли «Покупка», иначе «Продажа»
dValue | Тип: Double. Объем сделки
nTradeDescriptor

Тип: intptr_t. Дескриптор сделки, может использоваться для следующих специальных функций в функции обратного вызова:

  • long __stdcall TRANS2QUIK_TRADE_DATE (intptr_t nTradeDescriptor) – возвращает дату заключения сделки;
  • long__stdcall TRANS2QUIK_TRADE_SETTLE_DATE (intptr_t nTradeDescriptor) – возвращает дату расчетов по сделке;
  • long__stdcall TRANS2QUIK_TRADE_TIME (intptr_t nTradeDescriptor) – возвращает время сделки;
  • long__stdcall TRANS2QUIK_TRADE_IS_MARGINAL (intptr_t nTradeDescriptor) – возвращает признак маржинальности сделки: «0» еcли «немаржинальная», иначе «маржинальная»;
  • LPSTR__stdcall TRANS2QUIK_TRADE_CURRENCY (intptr_t nTradeDescriptor) – возвращает валюту в которой торгуется инструмент сделки;
  • LPSTR__stdcall TRANS2QUIK_TRADE_SETTLE_CURRENCY (intptr_t nTradeDescriptor) – возвращает валюту расчетов по сделке;
  • LPSTR__stdcall TRANS2QUIK_TRADE_SETTLE_CODE (intptr_t nTradeDescriptor) – возвращает код расчетов по сделке;
  • double__stdcall TRANS2QUIK_TRADE_ACCRUED_INT (intptr_t nTradeDescriptor) – возвращает накопленный купонный доход сделки;
  • double__stdcall TRANS2QUIK_TRADE_YIELD (intptr_t nTradeDescriptor) – возвращает доходность сделки;
  • LPSTR__stdcall TRANS2QUIK_TRADE_USERID (intptr_t nTradeDescriptor) – возвращает строковый идентификатор трейдера, от имени которого заключена сделка;
  • LPSTR__stdcall TRANS2QUIK_TRADE_ACCOUNT (intptr_t nTradeDescriptor) – возвращает торговый счет сделки;
  • LPSTR__stdcall TRANS2QUIK_TRADE_BROKERREF (intptr_t nTradeDescriptor) – возвращает комментарий сделки;
  • LPSTR__stdcall TRANS2QUIK_TRADE_CLIENT_CODE (intptr_t nTradeDescriptor) – возвращает код клиента сделки;
  • LPSTR__stdcall TRANS2QUIK_TRADE_FIRMID (intptr_t nTradeDescriptor) – возвращает строковый идентификатор организации пользователя сделки;
  • LPSTR__stdcall TRANS2QUIK_TRADE_PARTNER_FIRMID (intptr_t nTradeDescriptor) – возвращает строковый идентификатор организации-партнера по сделке;
  • double__stdcall TRANS2QUIK_TRADE_TS_COMMISSION (intptr_t nTradeDescriptor) – возвращает величину суммарной комиссии по сделке;
  • double__stdcall TRANS2QUIK_TRADE_CLEARING_CENTER_COMMISSION (intptr_t nTradeDescriptor) – возвращает величину комиссии за клиринг по сделке;
  • double__stdcall TRANS2QUIK_TRADE_EXCHANGE_COMMISSION (intptr_t nTradeDescriptor) – возвращает величину комиссии за торги по сделке;
  • double__stdcall TRANS2QUIK_TRADE_TRADING_SYSTEM_COMMISSION (intptr_t nTradeDescriptor) – возвращает величину комиссии за технический доступ по сделке;
  • double;__stdcall TRANS2QUIK_TRADE_PRICE2 (intptr_t nTradeDescriptor) – возвращает цену выкупа;
  • double__stdcall TRANS2QUIK_TRADE_REPO_RATE (intptr_t nTradeDescriptor) – возвращает ставку РЕПО в процентах;
  • double__stdcall TRANS2QUIK_TRADE_REPO_VALUE (intptr_t nTradeDescriptor) – возвращает сумму РЕПО (сумма привлеченных/предоставленных по сделке РЕПО денежных средств);
  • double__stdcall TRANS2QUIK_TRADE_REPO2_VALUE (intptr_t nTradeDescriptor) – возвращает стоимость выкупа РЕПО;
  • double__stdcall TRANS2QUIK_TRADE_ACCRUED_INT2 (intptr_t nTradeDescriptor) – возвращает накопленный купонный доход при выкупе;
  • long;__stdcall TRANS2QUIK_TRADE_REPO_TERM (intptr_t nTradeDescriptor) – возвращает срок РЕПО в календарных днях;
  • double__stdcall TRANS2QUIK_TRADE_START_DISCOUNT (intptr_t nTradeDescriptor) – возвращает начальный дисконт в процентах;
  • double__stdcall TRANS2QUIK_TRADE_LOWER_DISCOUNT (intptr_t nTradeDescriptor) – возвращает нижний предел дисконта в процентах;
  • double__stdcall TRANS2QUIK_TRADE_UPPER_DISCOUNT (intptr_t nTradeDescriptor) – возвращает верхний предел дисконта в процентах;
  • LPSTR __stdcall TRANS2QUIK_TRADE_EXCHANGE_CODE (intptr_t nTradeDescriptor) – возвращает строковый код биржи;
  • LPSTR __stdcall TRANS2QUIK_TRADE_STATION_ID (intptr_t nTradeDescriptor) – возвращает строковый идентификатор рабочей станции;
  • long __stdcall TRANS2QUIK_TRADE_BLOCK_SECURITIES (intptr_t nTradeDescriptor) – возвращает признак блокировки финансового инструмента на специальном счете на время операции РЕПО: «0» еcли «не блокировать», иначе «блокировать»;
  • long __stdcall TRANS2QUIK_TRADE_PERIOD (intptr_t nTradeDescriptor) – возвращает период, когда была совершена сделка; возможные значения: «0» - «Открытие», «1» - «Нормальный», «2» - «Закрытие»;
  • FILETIME __stdcall TRANS2QUIK_TRADE_FILETIME (intptr_t nTradeDescriptor) – возвращает дату и время заключения сделки в формате YY.MM.DD HH:MM:SS.MS;
  • long __stdcall TRANS2QUIK_TRADE_DATE_TIME (intptr_t nTradeDescriptor, long nTimeType) – возвращает временные параметры сделки в зависимости от значения параметра nTimeType. Параметр nTimeType может принимать следующие значения:
    • «0» - функция возвращает дату заключения сделки в формате YYYYMMDD,
    • «1» - функция возвращает время заключения сделки в формате HHMMSS,
    • «2» - функция возвращает микросекунды времени заключения сделки, целое число от 0 до 999999;
  • long __stdcall TRANS2QUIK_TRADE_KIND (intptr_t nTradeDescriptor) – возвращает вид сделки. Возможные значения:
    • «1» - Обычная,
    • «2» - Адресная,
    • «3» - Первичное размещение,
    • «4» - Перевод денег / инструментов,
    • «5» - Адресная сделка первой части РЕПО,
    • «6» - Расчетная по операции своп,
    • «7» - Расчетная по внебиржевой операции своп,
    • «8» - Расчетная сделка бивалютной корзины,
    • «9» - Расчетная внебиржевая сделка бивалютной корзины
  • double __stdcall TRANS2QUIK_TRADE_BROKER_COMMISSION (intptr_t nTradeDescriptor) – возвращает сумму комиссии брокера;
  • long __stdcall TRANS2QUIK_TRADE_TRANSID (intptr_t nTradeDescriptor) – возвращает TRANS_ID заявки, породившей сделку

См. также:

  • Функции для работы с транзакциями через API
  • Получение информации о заявках и сделках


Функция TRANS2QUIK_SUBSCRIBE_ORDERS

Функция служит для создания списка классов и инструментов для подписки на получение заявок по ним.

long __stdcall TRANS2QUIK_SUBSCRIBE_ORDERS (LPSTR lpstrClassCode, LPSTR lpstrSeccodes)

Параметр | Описание
Result Тип: Long. Возвращаемое число может принимать следующие значения:
  • TRANS2QUIK_DLL_NOT_CONNECTED – не установлена связь библиотеки Trans2QUIK.dll с терминалом QUIK. В этом случае подписка на заявки не возможна;
  • TRANS2QUIK_QUIK_NOT_CONNECTED – не установлена связь между Рабочим местом QUIK и сервером. В этом случае подписка на заявки не возможна;
  • TRANS2QUIK_SUCCESS – подписка проведена успешно;
  • TRANS2QUIK_FAILED – попытка подписки завершилась неуспешно
lpstrClassCode | Тип: указатель на переменную типа Строка. Код класса, для которого будут заказаны заявки, если в качестве обоих входных параметров указаны пустые строки, то это означает, что заказано получение заявок по всем доступным инструментам
lpstrSeccodes | Тип: указатель на переменную типа Строка. Список кодов инструментов, разделенных символом «|», по которым будут заказаны заявки. Если в качестве значения указана пустая строка, то это означает, что заказано получение заявок по классу, указанному в параметре lpstrClassCode

См. также:

  • Функции для работы с транзакциями через API
  • Получение информации о заявках и сделках


Функция TRANS2QUIK_SUBSCRIBE_TRADES

Функция служит для создания списка классов и инструментов для подписки на получение сделок по ним.

long __stdcall TRANS2QUIK_SUBSCRIBE_TRADES (LPSTRlpstrClassCode, LPSTRlpstrSeccodes)

Параметр | Описание
Result Тип: Long. Возвращаемое число может принимать следующие значения:
  • TRANS2QUIK_DLL_NOT_CONNECTED – не установлена связь библиотеки Trans2QUIK.dll с терминалом QUIK. В этом случае подписка на заявки не возможна;
  • TRANS2QUIK_QUIK_NOT_CONNECTED – не установлена связь между Рабочим местом QUIK и сервером. В этом случае подписка на заявки не возможна;
  • TRANS2QUIK_SUCCESS – подписка проведена успешно;
  • TRANS2QUIK_FAILED – попытка подписки завершилась неуспешно
lpstrClassCode | Тип: указатель на ;переменную типа Строка. Код класса, для которого будут заказаны сделки, если в качестве обоих входных параметров указаны пустые строки, то это означает, что заказано получение сделок по всем доступным инструментам
lpstrSeccodes | Тип: указатель на переменную типа Строка. Список кодов инструментов, разделенных символом «|», по которым будут заказаны сделки. Если в качестве значения указана пустая строка, то это означает, что заказано получение сделок по классу, указанному в параметре lpstrClassCode

См. также:

  • Функции для работы с транзакциями через API
  • Получение информации о заявках и сделках


Функция TRANS2QUIK_START_ORDERS

Функция запускает процесс получения заявок по классам и инструментам, определенных функцией TRANS2QUIK_SUBSCRIBE_ORDERS.

void __stdcall TRANS2QUIK_START_ORDERS (TRANS2QUIK_ORDER_STATUS_CALLBACK pfnOrderStatusCallback)

Параметр | Описание
TRANS2QUIK_ORDER_STATUS_CALLBACK | Указатель на пользовательскую функцию обратного вызова для получения информации о заявках

См. также:

  • Функции для работы с транзакциями через API
  • Получение информации о заявках и сделках


Функция TRANS2QUIK_START_TRADES

Функция запускает процесс получения сделок с параметрами, установленными функцией TRANS2QUIK_SUBSCRIBE_TRADES.

void __stdcall TRANS2QUIK_START_TRADES (TRANS2QUIK_TRADE_STATUS_CALLBACK pfnTradesStatusCallback)

Параметр | Описание
TRANS2QUIK_TRADE_STATUS_CALLBACK | Указатель на пользовательскую функцию обратного вызова для получения информации о сделках

См. также:

  • Функции для работы с транзакциями через API
  • Получение информации о заявках и сделках


Функция TRANS2QUIK_UNSUBSCRIBE_ORDERS

Функция прерывает работу функции TRANS2QUIK_START_ORDERS и производит очистку списка получаемых инструментов, сформированного функцией TRANS2QUIK_SUBSCRIBE_ORDERS.

long __stdcall TRANS2QUIK_UNSUBSCRIBE_ORDERS ()

Параметр Описание
Result Тип: Long. Возвращаемое число может принимать следующие значения:
  • TRANS2QUIK_DLL_NOT_CONNECTED – не установлена связь библиотеки Trans2QUIK.dll с терминалом QUIK. Операция не возможна;
  • TRANS2QUIK_QUIK_NOT_CONNECTED – не установлена связь между Рабочим местом QUIK и сервером. Операция не возможна;
  • TRANS2QUIK_SUCCESS – операция проведена успешно;
  • TRANS2QUIK_FAILED – попытка завершилась неуспешно

См. также:

  • Функции для работы с транзакциями через API
  • Получение информации о заявках и сделках


Функция TRANS2QUIK_UNSUBSCRIBE_TRADES

Функция прерывает работу функции TRANS2QUIK_START_TRADES и производит очистку списка получаемых инструментов, сформированного функцией TRANS2QUIK_SUBSCRIBE_TRADES.

long __stdcall TRANS2QUIK_UNSUBSCRIBE_TRADES ()

Параметр Описание
Result Тип: Long. Возвращаемое число может принимать следующие значения:
  • TRANS2QUIK_DLL_NOT_CONNECTED – не установлена связь библиотеки Trans2QUIK.dll с терминалом QUIK. Операция не возможна;
  • TRANS2QUIK_QUIK_NOT_CONNECTED – не установлена связь между Рабо-чим местом QUIK и сервером. Операция не возможна;
  • TRANS2QUIK_SUCCESS – операция проведена успешно;
  • TRANS2QUIK_FAILED – попытка завершилась неуспешно

См. также:

  • Функции для работы с транзакциями через API
  • Получение информации о заявках и сделках


Получение информации о заявках и сделках

Для получения информации о заявках и сделках пользователь сначала должен сформировать список получаемых инструментов. Для этого он должен вызывать соответствующие функции подписки TRANS2QUIK_SUBSCRIBE_ORDERS для заявок и TRANS2QUIK_SUBSCRIBE_TRADES для сделок.

Список инструментов как по сделкам, так и по заявкам можно формировать двумя способами - подписываться сразу на весь перечень классов и инструментов, на которые есть права у пользователя, либо перечислять классы по очереди. Например, если требуется получить информацию только по двум классам TQNL и TQBR, причем по TQBR классу интересуют заявки только по инструменту LKOH, то подписка должна быть произведена следующим образом:

TRANS2QUIK_SUBSCRIBE_ORDERS ("TQNL", "");
TRANS2QUIK_SUBSCRIBE_ORDERS ("TQBR", "LKOH");

Для перечисления нескольких инструментов в классе используется символ «|», например:

TRANS2QUIK_SUBSCRIBE_ORDERS ("TQBR", "LKOH|AFLT");

Перечисление классов инструментов через разделитель «|» не допускается.

Если при вызове функции подписки указан перечень инструментов, который уже имеется в списке, то такой вызов будет проигнорирован, например:

TRANS2QUIK_SUBSCRIBE_ORDERS ("", "");
TRANS2QUIK_SUBSCRIBE_ORDERS ("TQBR", "LKOH");

Сначала была заказана подписка на получение заявок по всем доступным классам и инструментам, а затем сделана попытка подписаться на получение информации по одному конкретному классу. Этот вызов будет проигнорирован, так как он не добавляет новых инструментов в список для получения заявок. Аналогичный результат будет в следующем случае:

TRANS2QUIK_SUBSCRIBE_ORDERS ("TQBR", "");
TRANS2QUIK_SUBSCRIBE_ORDERS ("TQBR", "LKOH|AFLT");

Для запуска процесса получения информации по сделкам и заявкам пользователь должен вызвать функции TRANS2QUIK_START_ORDERS - для заявок и TRANS2QUIK_START_TRADES - для сделок.

После вызова данных функций, терминал QUIK начнет передавать в Trans2QUIK.dll информацию о заявках и сделках с помощью указанных функций обратного вызова, причем сначала будет передана информация об уже полученных заявках и сделках (параметр nMode в функциях обратного вызова будет отличен от нуля), а потом по мере поступления будет передаваться информация о новых заявках и сделках (параметр nMode в функциях обратного вызова будет равен нулю).

Для прекращения получения информации по заявкам или сделкам пользователь должен вызывать соответствующие функции отписки TRANS2QUIK_UNSUBSCRIBE_ORDERS - для заявок и TRANS2QUIK_UNSUBSCRIBE_TRADES - для сделок. Данные функции параметров не имеют, после их вызова прекращается получение информации по всем заявкам и сделкам. Допускаются многократные вызовы данной функции в процессе работы, наряду с вызовами для подписки на получение информации по сделкам и заявкам.

Например:

TRANS2QUIK_SUBSCRIBE_ORDERS ("", "");
TRANS2QUIK_START_ORDERS ();
TRANS2QUIK_SUBSCRIBE_TRADES ("", "");
TRANS2QUIK_START_TRADES ();
…
TRANS2QUIK_UNSUBSCRIBE_ORDERS ();
TRANS2QUIK_UNSUBSCRIBE_TRADES ();
TRANS2QUIK_SUBSCRIBE_ORDERS ("TQBR", "LKOH");
TRANS2QUIK_START_ORDERS ();
TRANS2QUIK_SUBSCRIBE_TRADES ("TQBR", "LKOH");
TRANS2QUIK_START_TRADES ();

См. также:

  • Импорт транзакций через API
  • Функции для работы с транзакциями через API


Приложение

  • Таблица текущих торгов
  • Таблица «Клиентский портфель»
  • Таблица обезличенных сделок
  • Таблица заявок
  • Таблица стоп-заявок
  • Таблица сделок
  • Позиции по деньгам
  • Позиции по инструментам
  • Таблица позиций по клиентским счетам (фьючерсы)
  • Таблица ограничений по клиентским счетам (фьючерсы)
  • Таблица котировок
  • Таблица заявок-отчетов на сделки РПC
  • Таблица «Сделки для исполнения»
  • Таблица обязательств и требований по активам
  • Таблица обязательств и требований по деньгам
  • Таблица параметров процентных рисков
  • Таблица параметров рыночных рисков
  • Таблица торговых счетов

    • Форматы данных для настройки экспорта через ODBC

    Таблица текущих торгов

    Параметр | Формат | Параметр | Формат
Инструмент[Класс]* | VARCHAR(200) | Дюрация | DECIMAL(15,2)
Инструмент | VARCHAR(150) | Оф.цена откр. | DECIMAL(15,6)
Инструмент сокр. | VARCHAR(20) | Оф.тек.цена | DECIMAL(15,6)
Код инструмента | VARCHAR(12) | Оф.цена закр. | DECIMAL(15,6)
ISIN | VARCHAR(15) | Тип цены | VARCHAR(128)
Рег.номер | VARCHAR(30) | Тренд | DECIMAL(15,6)
Класс | VARCHAR(128) | Призн.кот.пред. | DECIMAL(19,6)
Код класса | VARCHAR(12) | Кол-во отк.поз. | INTEGER
Дата торгов | VARCHAR(15) | Макс. возм. цен. | DECIMAL(15,6)
Погашение | VARCHAR(15) | Мин. возм. цен. | DECIMAL(15,6)
До погашения | INTEGER | ГО покупателя | DECIMAL(15,6)
Номинал | DECIMAL(15,6) | ГО продавца | DECIMAL(15,6)
Валюта | VARCHAR(4) | Время изм. | VARCHAR(15)
Точность | INTEGER | БГОП | DECIMAL(15,6)
Шаг цены | DECIMAL(15,6) | БГОНП | DECIMAL(15,6)
Статус | VARCHAR(32) | Тип опциона | VARCHAR(16)
Лот | INTEGER | Баз.актив | VARCHAR(13)
Сессия | VARCHAR(32) | Волатильность | DECIMAL(15,6)
Тип | VARCHAR(12) | Теор.цена | DECIMAL(15,2)
Спрос | DECIMAL(15,6) | Страйк | DECIMAL(15,6)
Кол. спрос | INTEGER | Ст. шага цены | DECIMAL(15,6)
Общ.спрос | INTEGER | Расч. цена | DECIMAL(15,6)
Заявки куп. | INTEGER | Кол-во послед. | INTEGER
Предл. | DECIMAL(15,6) | Изм. к пр. расч. | DECIMAL(15,6)
Кол. предл. | INTEGER | Пред. расч. цен. | DECIMAL(15,6)
Общ. предл. | INTEGER | Лим. изм.цены | DECIMAL(15,6)
Заявки прод | INTEGER | Лим. изм.цен T+1 | DECIMAL(15,6)
Откр. | DECIMAL(15,6) | Лим. акт. заяв. | DECIMAL(15,2)
Макс. цена | DECIMAL(15,6) | Оборот внес. | DECIMAL(15,0)
Мин. цена | DECIMAL(15,6) | Кол. внес. сдел. | INTEGER
Цена послед. | DECIMAL(15,6) | Знач. | DECIMAL(15,6)
Измен. к закр. | DECIMAL(15,6) | Закр. | DECIMAL(15,6)
Кол-во послед. | INTEGER | Время закр. | VARCHAR(15)
Время послед. | VARCHAR(15) | Знач. при откр. | DECIMAL(15,6)
Общ кол-во | INTEGER | Изм. к откр. | DECIMAL(15,6)
Оборот | DECIMAL(15,0) | Изм. к закр. | DECIMAL(15,6)
Оборот посл. | DECIMAL(15,6) | Спрос сессии | DECIMAL(19,0)
Ср. взв. цена | DECIMAL(15,6) | Предл. сессии | DECIMAL(19,0)
Лучш. спрос | DECIMAL(15,6) | Пред.цена закр. | DECIMAL(19,6)
Лучш. пред | DECIMAL(15,6) | Ставка | DECIMAL(15,2)
Кол-во сделок | INTEGER | Тип цены | VARCHAR(16)
Цена закр. | DECIMAL(15,6) | Статус кл. | VARCHAR(16)
Пред. оц. | DECIMAL(15,6) | Кот.клиринга | DECIMAL(15,6)
Размещение | VARCHAR(32) | Начало | VARCHAR(15)
НКД | DECIMAL(15,8) | Окончание | VARCHAR(15)
Доходность | DECIMAL(15,2) | Начало веч. | VARCHAR(15)
Размер купона | DECIMAL(15,2) | Окончание веч. | VARCHAR(15)
Доход. пред. оц. | DECIMAL(15,2) | Начало утр. | VARCHAR(15)
Доход. оц. | DECIMAL(15,2) | Окончание утр. | VARCHAR(15)
Изм. к пред. оц. | DECIMAL(15,6) | Валюта шага цены | VARCHAR(16)
Закр. | DECIMAL(15,6) | Рын котир. | DECIMAL(15,6)
Доход. закр. | DECIMAL(15,2) | Марж. | VARCHAR(16)
% измен. закр. | DECIMAL(15,2) | Дата исп. | VARCHAR(15)
Вч.рын.цена | DECIMAL(15,6) | Ст. шага цены кл | DECIMAL(15,6)
Рын. цена | DECIMAL(15,6) | Ст. шага цены пр | DECIMAL(15,6)
Рын. цена 2 | DECIMAL(15,6) | Вр. изм.м.т.ц. | VARCHAR(15)
Призн.котир. | DECIMAL(15,6) | Пред. Лот | INTEGER
Дата выпл.куп. | VARCHAR(15) | Дата изм.лота | VARCHAR(15)
Длит.куп. | INTEGER | Дата расч. доход | VARCHAR(15)
Оферта | DECIMAL(15,6) | Баз. курс | DECIMAL(19,4)
Дата оферты | VARCHAR(15) | CFI-код инструмента | VARCHAR(12)
Объем обр. | INTEGER | Наличие спроса/предложения АКП | VARCHAR(8)
Дата посл. торг. | VARCHAR(15) |  |

    Таблица «Клиентский портфель»

    Параметр | Формат | Параметр | Формат
Фирма | VARCHAR(12) | БлокПродажа | DECIMAL(20,6)
Код клиента | VARCHAR(12) | БлокПокНеМарж | DECIMAL(20,6)
ПовышУрРиска | VARCHAR(12) | ВходСредства | DECIMAL(20,6)
Тип клиента | VARCHAR(3) | ТекСредства | DECIMAL(20,6)
Сроч. счет | VARCHAR(12) | Прибыль/убытки | DECIMAL(20,6)
Вход.активы | DECIMAL(20,6) | ПроцИзмен | DECIMAL(15,8)
Плечо | DECIMAL(20,6) | На покупку | DECIMAL(20,6)
Вход.лимит | DECIMAL(20,6) | На продажу | DECIMAL(20,6)
Шорты | DECIMAL(20,6) | НаПокупНеМаржин | DECIMAL(20,6)
Лонги | DECIMAL(20,6) | НаПокупОбесп | DECIMAL(20,6)
Лонги МО | DECIMAL(20,6) | ГО поз. | DECIMAL(20,6)
Лонги О | DECIMAL(20,6) | ГО заяв. | DECIMAL(20,6)
Стоимость портфеля | DECIMAL(20,6) | Вариац. маржа | DECIMAL(20,6)
Тек.плечо | DECIMAL(20,6) | Активы/ГО | DECIMAL(20,6)
Ур.маржи | DECIMAL(20,6) | Сумма ден. остатков | DECIMAL(20,6)
Тек.лимит | DECIMAL(20,6) | Суммарно заблок. | DECIMAL(20,6)
ДостТекЛимит | DECIMAL(20,6) | Парам. расч. | VARCHAR(10)
БлокПокупка | DECIMAL(20,6) | Шорты (нетто) | DECIMAL(20,6)
БлокПок МО | DECIMAL(20,6) | Лонги (нетто) | DECIMAL(20,6)
БлокПок О | DECIMAL(20,6) | Срок расчётов | VARCHAR(5)
Мин.маржа | DECIMAL(20,6) | Нач.маржа | DECIMAL(20,6)
Скор.маржа | DECIMAL(20,6) | Статус | VARCHAR(12)
Требование | DECIMAL(20,6) | УДС | DECIMAL(20,6)
Сумма дисконтов | DECIMAL(20,6) | ТекАктБезДиск | DECIMAL(20,6)
Статус счета | DECIMAL(20,6) | ЛимОткрПозНачДня | DECIMAL(20,6)
ЛимОткрПоз | DECIMAL(20,6) | ПланЧистПоз | DECIMAL(20,6)
ТекЧистПоз | DECIMAL(20,6) | НакопВарМаржа | DECIMAL(20,6)
ВарМаржаПромклир. | DECIMAL(20,6) | НакопДоход | DECIMAL(20,6)
ЛиквСтоимОпционов | DECIMAL(20,6) | СумАктивовНаСрчРынке | DECIMAL(20,6)
ПолнСтоимПортфеля | DECIMAL(20,6) | ТекЗадолжНаСрчРынке | DECIMAL(20,6)
Дост. Средств | DECIMAL(20,6) | Дост. Средств (ОткрПоз) | DECIMAL(20,6)
КоэффЛикв ГО | DECIMAL(20,6) | Ожид. КоэффЛикв ГО | DECIMAL(20,6)
Cash Leverage | DECIMAL(20,6) | ТипПозНаСрчРынке | VARCHAR(12)

    Таблица обезличенных сделок

    Параметр | Формат | Параметр | Формат
Номер сделки | DECIMAL(19,0) | Цена | DECIMAL(15,6)
Дата торгов | VARCHAR(20) | Количество | INTEGER
Дата | VARCHAR(20) | Объем | DECIMAL(19,8)
Время | VARCHAR(15) | Операция | VARCHAR(12)
Время(мкс) | INTEGER | Код расчетов | VARCHAR(5)
Период | VARCHAR(20) | Доходность | DECIMAL(15,6)
Инструмент сокр. | VARCHAR(20) | Купонный доход | DECIMAL(15,2)
Инструмент | VARCHAR(150) | Ставка РЕПО (%) | DECIMAL(15,6)
Код инструмента | VARCHAR(12) | Сумма РЕПО | DECIMAL(15,2)
Класс | VARCHAR(130) | Объем выкупа РЕПО | DECIMAL(15,8)
Код класса | VARCHAR(12) | Срок РЕПО | INTEGER
Открытый интерес | DECIMAL(15,0) | Код биржи | VARCHAR(64)

    Таблица заявок

    Параметр | Формат | Параметр | Формат
Номер | DECIMAL(19,0) | Купонный процент | DECIMAL(15,2)
Код биржи | VARCHAR(64) | Трейдер | VARCHAR(12)
Дата торгов | VARCHAR(20) | Дилер | VARCHAR(12)
Дата | VARCHAR(20) | UID | INTEGER
Выставлена (время) | VARCHAR(10) | Код клиента | VARCHAR(20)
Выставлена(мкс) | INTEGER | Комментарий | VARCHAR(20)
Период | VARCHAR(20) | Исходный номер | DECIMAL(19,0)
Время активации | VARCHAR(10) | Срок | VARCHAR(15)
Дата снятия | VARCHAR(20) | Тип | VARCHAR(10)
Снята (время) | VARCHAR(10) | Состояние | VARCHAR(10)
Снята(мкс) | INTEGER | ID транзакции | INTEGER
Инструмент сокр. | VARCHAR(20) | Код расчетов | VARCHAR(12)
Инструмент | VARCHAR(150) | Цена выкупа | DECIMAL(15,6)
Код инструмента | VARCHAR(12) | Заявка маркет-мейкера | VARCHAR(3)
Класс | VARCHAR(130) | Идентификатор счета | VARCHAR(12)
Код класса | VARCHAR(12) | Ввод объема | VARCHAR(16)
Операция | VARCHAR(10) | Срок РЕПО | INTEGER
Счет | VARCHAR(12) | Сумма РЕПО | DECIMAL(15,8)
Цена | DECIMAL(15,6) | Объем выкупа РЕПО | DECIMAL(15,8)
Количество | INTEGER | Остаток суммы РЕПО | DECIMAL(15,8)
Видимое кол-во | DECIMAL(19,0) | Начальный дисконт (%) | DECIMAL(15,6)
Остаток | INTEGER | Причина отклонения | VARCHAR(128)
Объем | DECIMAL(15,8) | Режим исполнения | VARCHAR(64)
Валюта | VARCHAR(4) | Мин. допустимое кол-во | INTEGER
Доходность | DECIMAL(15,6) | Средневзвешенная цена приобретения | DECIMAL(15,6)
Кол-во базовой валюты | DECIMAL(15,6) | Базовая валюта | VARCHAR(16)
UID снявшего заявку | DECIMAL(15,0) | Кол-во котируемой валюты | DECIMAL(15,6)
Котируемая валюта | VARCHAR(16) | Стоп-заявка | DECIMAL(19,0)
Время окончания срока | VARCHAR(8) | Расширенный статус | VARCHAR(16)

    Таблица стоп-заявок

    Параметр | Формат | Параметр | Формат
Номер | DECIMAL(19,0) | Исп.кол-во | DECIMAL(15,0)
Дата | VARCHAR(10) | Дилер | VARCHAR(12)
Время | VARCHAR(12) | UID | DECIMAL(15,0)
Время снятия | VARCHAR(10) | Код клиента | VARCHAR(128)
Тип стоп-заявки | VARCHAR(128) | Комментарий | VARCHAR(20)
Описание типа стоп-заявки | VARCHAR(128) | Номер заявки | DECIMAL(19,0)
Инструмент сокр. | VARCHAR(16) | Сделка условия | DECIMAL(15,0)
Инструмент | VARCHAR(128) | Срок | VARCHAR(10)
Код инструмента | VARCHAR(12) | Время действия | VARCHAR(3)
Класс | VARCHAR(128) | Активна с | VARCHAR(12)
Код класса | VARCHAR(12) | Активна по | VARCHAR(12)
Операция | VARCHAR(8) | Тип | VARCHAR(4)
Счет | VARCHAR(12) | Состояние | VARCHAR(12)
Инструмент стоп-цены | VARCHAR(128) | Результат | VARCHAR(64)
Код инструмента стоп-цены | VARCHAR(12) | Связ. заявка | DECIMAL(19,0)
Класс стоп-цены | VARCHAR(128) | Цена связ.заявки | DECIMAL(15,6)
Код класса стоп-цены | VARCHAR(12) | ID транзакции | DECIMAL(15,0)
Направление стоп-цены | VARCHAR(3) | Отступ от min/max | DECIMAL(15,6)
Стоп-цена | DECIMAL(15,6) | Единицы отступа | VARCHAR(1)
Направление стоп-лимит цены | VARCHAR(3) | Защитный спред | DECIMAL(15,6)
Стоп-лимит цена | DECIMAL(15,6) | Единицы спреда | VARCHAR(1)
Цена | DECIMAL(15,6) | Тейк-профит по рыночной | VARCHAR(3)
Стоп-лимит по рыночной | VARCHAR(2) | Заявка условия | DECIMAL(19,0)
Кол-во | DECIMAL(15,0) | Сервер | VARCHAR(12)
Акт.кол-во | DECIMAL(15,0) | Дата снятия | VARCHAR(10)
UID снявшего заявку | DECIMAL(15,0) |  |

    Таблица сделок

    Параметр | Формат | Параметр | Формат
Номер | DECIMAL(19,0) | Купонный процент | DECIMAL(15,8)
Код биржи | VARCHAR(68) | Трейдер | VARCHAR(12)
Дата торгов | VARCHAR(20) | Идентификатор рабочей станции | VARCHAR(36)
Дата сделки | VARCHAR(20) | Дилер | VARCHAR(12)
Дата расчетов | VARCHAR(10) | Орг-я трейдера | VARCHAR(128)
Время | VARCHAR(15) | Код клиента | VARCHAR(20)
Время (мкс) | INTEGER | Комментарий | VARCHAR(20)
Заявка | DECIMAL(19,0) | Цена выкупа | DECIMAL(15,6)
Период | VARCHAR(20) | Ставка РЕПО (%) | DECIMAL(15,6)
Заявка | DECIMAL(19,0) | Комиссия ТС | DECIMAL(15,8)
Инструмент сокр. | VARCHAR(20) | Клиринговая комиссия | DECIMAL(15,6)
Инструмент | VARCHAR(150) | ФБ комиссия | DECIMAL(15,6)
Код инструмента | VARCHAR(12) | ТЦ комиссия | DECIMAL(15,6)
Класс | VARCHAR(130) | Доход(%) на дату выкупа | DECIMAL(15,6)
Код класса | VARCHAR(12) | Сумма РЕПО | DECIMAL(15,8)
Тип сделки | VARCHAR(12) | Объем выкупа РЕПО | DECIMAL(15,8)
Операция | VARCHAR(10) | Срок РЕПО | INTEGER
Счет | VARCHAR(12) | Начальный дисконт(%) | DECIMAL(15,6)
Цена | DECIMAL(15,6) | Нижний дисконт(%) | DECIMAL(15,6)
Количество | INTEGER | Верхний дисконт(%) | DECIMAL(15,6)
Объем | DECIMAL(15,8) | Блокировка обеспечения | VARCHAR(3)
Валюта | VARCHAR(4) | Вид сделки | VARCHAR(64)
Валюта расчетов | VARCHAR(4) | Идентификатор счета | VARCHAR(12)
Код расчетов | VARCHAR(5) | Исходный номер | DECIMAL(19,0)
Доходность | DECIMAL(15,6) | Айсберг-заявка | VARCHAR(4)
Валюта расчетов | VARCHAR(4) | Комиссия брокера | DECIMAL(15,6)
Фирма клиринга | VARCHAR(18) | Счет клиринга | VARCHAR(18)
Кол-во базовой валюты | DECIMAL(15,6) | Базовая валюта | VARCHAR(16)
ID транзакции | DECIMAL(15,0) | UID отказавшегося от сделки | DECIMAL(15,0)
Дата снятия | VARCHAR(10) | Снята(время) | VARCHAR(8)
Кол-во котируемой валюты | DECIMAL(15,6) | Котируемая валюта | VARCHAR(16)
Снята(мкс) | VARCHAR(8) | Системная ссылка | VARCHAR(15)
Статус | VARCHAR(15) | Приоритетное обеспечение | VARCHAR(15)

    Таблица «Позиции по деньгам»

    Параметр | Формат | Параметр | Формат
Фирма | VARCHAR(12) | Текущий остаток | DECIMAL(15,2)
Валюта | VARCHAR(5) | Текущий лимит | DECIMAL(15,2)
Код позиции | VARCHAR(5) | Заблокировано | DECIMAL(15,2)
Код клиента | VARCHAR(12) | Всего | DECIMAL(15,2)
Срок расчетов | VARCHAR(5) | Доступно | DECIMAL(15,2)
Входящий остаток | DECIMAL(15,2) | Баланс | DECIMAL(15,2)
Входящий лимит | DECIMAL(15,2) |

    Таблица «Позиции по инструментам»

    Параметр | Формат | Параметр | Формат
Фирма | VARCHAR(12) | Текущий остаток | INTEGER
Название инструмента | VARCHAR(150) | Текущий лимит | INTEGER
Код инструмента | VARCHAR(12) | Заблокировано | INTEGER
Счет депо | VARCHAR(12) | Всего | INTEGER
Код клиента | VARCHAR(12) | Доступно | INTEGER
Срок расчётов | VARCHAR(5) | Баланс | INTEGER
Входящий остаток | INTEGER | Цена приобретения | DECIMAL(15,6)
Входящий лимит | INTEGER | Заблокировано на покупку | DECIMAL(15,6)

    Таблица позиций по клиентским счетам (фьючерсы)

    Параметр | Формат | Параметр | Формат
Фирма | VARCHAR(12) | Тек. чист. поз. | INTEGER
Торговый счет | VARCHAR(12) | Акт. покупка | INTEGER
Код инструмента | VARCHAR(12) | Акт.продажа | INTEGER
Краткое название | VARCHAR(150) | Оценка тек. чист.поз. | DECIMAL(15,6)
Дата погашения | VARCHAR(20) | План. чист. поз. | DECIMAL(15,6)
Тип | VARCHAR(35) | Вариац. маржа | DECIMAL(15,6)
Вход.длин. поз. | INTEGER | Эффективная цена позиций | DECIMAL(15,6)
Вход.кор. поз. | INTEGER | Стоимость позиций | DECIMAL(19,4)
Вход.чист. поз. | INTEGER | Суммарная в.маржа | DECIMAL(15,2)
Тек.длин.поз. | INTEGER | Реальная в.маржа | DECIMAL(15,2)
Тек.кор. поз. | INTEGER |  |

    Таблица ограничений по клиентским счетам (фьючерсы)

    Параметр | Формат | Параметр | Формат
Фирма | VARCHAR(12) | Планируемые чистые позиции | DECIMAL(15,6)
Торговый счет | VARCHAR(12) | Вариационная маржа по позициям | DECIMAL(15,6)
Тип лимита | VARCHAR(128) | Накопленный доход | DECIMAL(15,6)
Коэфф. ликвидности | DECIMAL(15,6) | Премия по опционам | DECIMAL(19,4)
Предыдущий лимит открытых позиций | DECIMAL(15,6) | Биржевые сборы | DECIMAL(19,4)
Лимит открытых позиций | DECIMAL(15,6) | Коэфф. кл-го ГО | DECIMAL(19,6)
Текущие чистые позиции | DECIMAL(15,6) | Валюта позиции | VARCHAR(4)
Тек. чист. поз. (под заявки) | DECIMAL(19,4) | Реальная в.маржа | DECIMAL(15,2)
Тек. чист. поз. (под открытые позиции) | DECIMAL(19,4) |  |

    Таблица котировок

    Параметр | Формат | Параметр | Формат
Доходность покупки | DECIMAL(15,6) | Цена продажи | DECIMAL(15,6)
Сумма лучшей покупки | INTEGER | Продажа | INTEGER
Своя покупка | INTEGER | Своя продажа | INTEGER
Покупка | INTEGER | Сумма лучшей продажи | INTEGER
Цена покупки | DECIMAL(15,6) | Доходность продажи | DECIMAL(15,6)

    Таблица заявок-отчетов на сделки РПC

    Параметр | Формат | Параметр | Формат
Номер | DECIMAL(19,0) | Партнер | VARCHAR(12)
Дата | VARCHAR(10) | Орг-я партнера | VARCHAR(128)
Выставлен(время) | VARCHAR(8) | Счет депо партнера | VARCHAR(12)
Снят(время) | VARCHAR(8) | Кол-во | INTEGER
Класс | VARCHAR(128) | Объем | DECIMAL(15,8)
Инструмент coкр. | VARCHAR(16) | Комиссия | DECIMAL(15,6)
Инструмент | VARCHAR(128) | Направленность | VARCHAR(32)
Трейдер | VARCHAR(12) | Состояние | VARCHAR(32)
Дилер | VARCHAR(12) | Тип отчета | VARCHAR(32)
Орг-я трейдера | VARCHAR(128) | Вид отчета | VARCHAR(32)
Счет депо | VARCHAR(12) | Сумма отступного | DECIMAL(15,6)
Направленность отступного | VARCHAR(12) |  |

    Таблица «Сделки для исполнения»

    Параметр | Формат | Параметр | Формат
Номер | DECIMAL(19,0) | Остаток | INTEGER
Номер заявки | DECIMAL(19,0) | Время исполнения | VARCHAR(10)
Дата торгов | VARCHAR(10) | Сумма обязательства | DECIMAL(15,8)
Дата исполнения | VARCHAR(10) | Сумма РЕПО | DECIMAL(15,8)
Класс | VARCHAR(128) | Срок РЕПО | INTEGER
Инструмент сокр. | VARCHAR(16) | Объем выкупа РЕПО | DECIMAL(15,8)
Инструмент | VARCHAR(128) | Сумма возврата РЕПО | DECIMAL(15,8)
Операция | VARCHAR(12) | Дисконт(%) | DECIMAL(15,6)
Код клиента | VARCHAR(128) | Нижний дисконт(%) | DECIMAL(15,6)
Комментарий | VARCHAR(128) | Верхний дисконт(%) | DECIMAL(15,6)
Дилер | VARCHAR(12) | Блокировать обеспечение | VARCHAR(3)
Орг-я трейдера | VARCHAR(128) | Исполнить | VARCHAR(3)
Счет депо | VARCHAR(12) | Исполнить завтра | VARCHAR(3)
Партнер | VARCHAR(12) | Тип | VARCHAR(50)
Орг-я партнера | VARCHAR(128) | Направленность | VARCHAR(12)
Счет депо партнера | VARCHAR(12) | Дисконт после взноса(%) | DECIMAL(15,6)
Цена | DECIMAL(15,6) | Количество после взноса | INTEGER
Кол-во | INTEGER | Сумма РЕПО после взноса | DECIMAL(15,8)
Объем | DECIMAL(15,8) | Стоимость выкупа после взноса | DECIMAL(15,8)
Состояние | VARCHAR(32) | Сумма возврата после взноса | DECIMAL(15,8)
Купонный % | DECIMAL(15,8) | Дата заключения | VARCHAR(10)
Цена 1ой части РЕПО | DECIMAL(15,6) | Состояние расчетов | VARCHAR(32)
Цена выкупа | DECIMAL(15,6) | Тип клиринга | VARCHAR(32)
Номер сделки 1ой части РЕПО | DECIMAL(19,0) | Комиссия за отчет | DECIMAL(15,6)
Ставка РЕПО(%) | DECIMAL(15,6) | Купонная выплата | DECIMAL(15,6)
Код расчетов | VARCHAR(12) | Дата купонной выплаты | VARCHAR(10)
Отчет | DECIMAL(15,0) | Выплата по основному долгу | DECIMAL(15,6)
Отчет партнера | DECIMAL(15,0) | Дата выплаты по основному долгу | VARCHAR(10)
Комиссия ТС | DECIMAL(15,6) | Валюта расчетов | VARCHAR(5)
Номер поручения | DECIMAL(15,0) | Кол-во к исполнению | DECIMAL(15,0)
Расчетная организация | VARCHAR(12) | Время подтверждения | VARCHAR(15)
Сумма отступного | DECIMAL(15,6) | Номер витринной сделки | DECIMAL(19,0)
Подтверждена | VARCHAR(12) | Подтверждена контрагентом | VARCHAR(12)
Код позиции | VARCHAR(12) |  |

    Таблица обязательств и требований по активам

    Параметр | Формат | Параметр | Формат
Фирма | VARCHAR(12) | Код позиции | VARCHAR(12)
Код инструмента | VARCHAR(12) | Количество в сделках | DECIMAL(15,0)
Торговый счет | VARCHAR(12) | Количество в заявках на покупку | DECIMAL(15,0)
Дата расчетов | VARCHAR(10) | Количество в заявках на продажу | DECIMAL(15,0)
Инструмент сокр. | VARCHAR(16) | Сумма в сделках | DECIMAL(15,2)
Инструмент | VARCHAR(128) | Сумма в заявках на покупку | DECIMAL(15,2)
Код класса | VARCHAR(12) | Сумма в заявках на продажу | DECIMAL(15,2)
Класс | VARCHAR(128) | Счет депо | VARCHAR(12)

    Таблица обязательств и требований по деньгам

    Параметр | Формат | Параметр | Формат
Фирма | VARCHAR(12) | Сумма в сделках | DECIMAL(15,2)
Код позиции | VARCHAR(10) | Сумма в заявках на покупку | DECIMAL(15,2)
Дата расчетов | VARCHAR(10) | Сумма в заявках на продажу | DECIMAL(15,2)

    Таблица параметров процентных рисков

    Параметр | Формат | Параметр | Формат
Код инструмента | VARCHAR(12) | Нижняя граница, руб | DECIMAL(15,6)
Инструмент сокр. | VARCHAR(16) | Расчетная ставка РЕПО, руб | DECIMAL(15,6)
Инструмент | VARCHAR(128) | Верхняя граница, руб | DECIMAL(15,6)
Код класса | VARCHAR(12) | Нижняя граница, % | DECIMAL(15,2)
Класс | VARCHAR(128) | Расчетная ставка РЕПО, % | DECIMAL(15,2)
Дата расчетов | VARCHAR(10) | Верхняя граница, % | DECIMAL(15,2)
Диапазон | INTEGER | Начало диапазона, руб | DECIMAL(15,2)
Начало диапазона | DECIMAL(15,0) | Конец диапазона, руб | DECIMAL(15,2)
Конец диапазона | DECIMAL(15,0) | Нижняя граница, % | DECIMAL(15,2)
Дисконт, % | DECIMAL(15,1) |

    Таблица параметров рыночных рисков

    Параметр | Формат | Параметр | Формат
Код инструмента | VARCHAR(12) | Дисконт, % | DECIMAL(15,1)
Инструмент сокр. | VARCHAR(16) | Нижняя граница, руб | DECIMAL(15,6)
Инструмент | VARCHAR(128) | Верхняя граница, руб | DECIMAL(15,6)
Код класса | VARCHAR(12) | Начало диапазона, руб | DECIMAL(15,2)
Класс | VARCHAR(128) | Конец диапазона, руб | DECIMAL(15,2)
Диапазон | INTEGER
Начало диапазона | DECIMAL(15,0)
Конец диапазона | DECIMAL(15,0)

    Таблица торговых счетов

    Параметр | Формат | Параметр | Формат
Фирма | VARCHAR(12) | Описание | VARCHAR(32)
Счет | VARCHAR(12) | Тип торг. счета | VARCHAR(40)
Основной счет | VARCHAR(12) | Тип счета депо | VARCHAR(30)
Счет депо | VARCHAR(12) | Статус | VARCHAR(20)
Код позиции | VARCHAR(12) | Тип раздела | VARCHAR(12)
Запрет необеспеч-х продаж | VARCHAR(12) | Расч-я орг-я по Т0 | VARCHAR(15)
Расч-я орг-я по Т+ | VARCHAR(15) | Раздел счета Депо | VARCHAR(18)


Раздел 7. Операции брокера

  • Просмотр позиций участника биржевых торгов
  • Работа с лимитами клиентов
  • Субадминистрирование
  • Маржинальная торговля
  • Операции над позициями
  • Динамическая корректировка позиций из файла
  • Операции над лимитами клиентов на срочном рынке
  • Операции в Режиме переговорных сделок
  • Операции РЕПО
  • Внебиржевые сделки
  • Маклерская заявка
  • Маклерская стоп-заявка
  • Участие в аукционах по размещению инструментов
  • Режим приема клиентских транзакций с подтверждением брокером
  • Работа с неторговыми поручениями
  • Сообщения об ошибках при работе с позициями

Раздел посвящен операциям брокеров, а также субброкеров, работающих с системой QUIK по управлению позициями и лимитами клиентов, просмотру собственных позиций на бирже, а также операциям в режимах РПС, РЕПО и при размещении инструментов.


Просмотр позиций участника биржевых торгов

Наблюдение за позициями брокера и выполнение активных операций в системе QUIK аналогично функционалу биржевого терминала участника торгов на Московской Бирже. Таким образом, помимо обслуживания клиентов через систему QUIK, брокер может осуществлять в полном объеме собственные операции, ранее проводимые через рабочее место участника торгов.

Для просмотра позиций используются следующие таблицы (звездочкой (*) отмечены рекомендуемые таблицы):

  • «Позиции участника по деньгам»* – просмотр позиций по денежным средствам;
  • « Позиции участника по инструментам» – просмотр суммарных позиций по инструментам на всех счетах;
  • «Позиции участника по торговым счетам» – просмотр позиций по одному выбранному инструменту на различных счетах;
  • « Позиции по инструментам на выбранных счетах»* – просмотр позиций по всем инструментам в разрезе выбранных счетов.

Для отслеживания выполнения маркет-мейкером его обязательств на рынке ценных бумаг используется «Таблица обязательств маркет-мейкеров».


Работа с лимитами клиентов

Система QUIK позволяет брокеру осуществлять контроль за использованием клиентами денежных средств и инструментов. Функция контроля осуществляется с помощью установки индивидуальных ограничений (лимитов) на количество денежных средств и/или инструментов, доступных для совершения торговых операций.

Понятие остатка и лимита средств клиента

В системе QUIK предусмотрен раздельный контроль собственных и заемных средств для каждого клиента. Доступные средства клиента разделяются на собственные средства (остаток) и заемные средства (лимит).

  1. «Остаток» представляет собой величину собственных средств клиента.
    • «Входящий остаток» равен средствам клиента на текущий день до совершения торговых операций (на начало дня).
    • «Текущий остаток» равен средствам клиента с учетом проведенных сделок.
  2. «Лимит» представляет собой максимальную величину заемных средств брокера, доступных клиенту для совершения операций.
    • «Входящий лимит» равен величине заемных средств, доступных клиенту до совершения торговых операций (на начало дня).
    • «Текущий лимит» равен величине заемных средств, доступных клиенту с учетом совершенных сделок.

До совершения каких-либо сделок текущие значения остатков и лимитов равны входящим. В результате сделок изменяются текущие значения, при этом входящие остаются неизменны.

Значения остатков и лимитов клиентов по денежным средствам отображаются в таблице Позиции по деньгам. Значения остатков и лимитов клиентов по инструментам отображаются в таблице Позиции по инструментам.

Из таблицы «Клиентский портфель» можно вызвать Сводную таблицу позиций, содержащую одновременно позиции по инструментам и денежным средствам для определенного клиента.

Значения Входящего остатка и Входящего лимита устанавливаются брокером перед началом торговой сессии (см.Процедура установки значений позиций клиентов). При необходимости брокер может изменять эти значения в течение торговой сессии вручную (см. Операции над позициями) или программно (см. Динамическая корректировка позиций из файла).

Брокеру доступны следующие операции над позициями:

  • Создание позиции по денежным средствам
  • Создание позиции по инструментам
  • Изменение позиций
  • Удаление позиций
  • Удаление группы позиций по денежным средствам
  • Удаление группы позиций по инструментам
  • Отчет по позициям
  • Сохранение позиций в файл
  • Загрузка позиций из файла


Субадминистрирование

Субадминистрирование – возможность обслуживания клиентов брокера, являющегося клиентом другого брокера (далее – субброкером). Такая возможность предоставляется в виде распределения лимитов субброкера на лимиты его клиентов и контроля их использования.

Для управления позициями клиентов в системе QUIK введена следующая иерархия пользователей:

  • «Менеджер фирмы» – имеет возможность установки и изменения позиций для всех пользователей.
  • «Субадминистратор» – имеет возможность установки и изменения позиций для определенной группы пользователей.
  • «Клиент фирмы» – не имеет возможности установки и изменения позиций. Клиент фирмы может совершать торговые операции в пределах установленных ему доступных средств.

Клиенты фирмы могут выполнять активные транзакции только при условии, что Менеджер их фирмы установил им позиции по денежным средствам и по инструментам. Менеджер фирмы должен устанавливать позиции по денежным средствам и по инструментам каждому клиенту фирмы в начале торгового дня. В течение торговой сессии Менеджер может изменять позиции по любому клиентскому коду.

Менеджер может назначить клиента фирмы Субадминистратором над группой клиентов фирмы. В этом случае Субадминистратор может просматривать позиции этой группы клиентов, а также устанавливать и изменять лимиты для этих клиентов.

В системе QUIK применяются две схемы субадминистрирования, различающиеся по способу контроля размера средств Субадминистратора и приписанных ему клиентов.

См. также:

  • Схемы субадминистрирования
  • Процедура установки значений позиций клиентов
  • Автоматическое создание кодов клиентов Субадминистратором


Схемы субадминистрирования

  • «Классическая» схема субадминистрирования
  • «Новая» схема субадминистрирования

    • «Классическая» схема субадминистрирования

    • При выставлении позиций общая сумма денег или инструментов в позициях клиентов, приписанных Субадминистратору, не должна превышать позиций , установленных Менеджером фирмы самому Субадминистратору.
    • При установке позиций клиентам позиция самого Субадминистратора уменьшается на размер позиции, отданной клиенту.
    • При приеме заявки клиента Субадминистратора или самого Субадминистратора сервер QUIK контролирует достаточность средств в пределах остатков и лимитов непосредственно по их кодам клиентов и по их собственным позициям.
    • Результаты торговых операций клиентов не отражаются на величине средств Субадминистратора. Размер средств Субадминистратора соответствует нераспределенному остатку средств, выделенных Менеджером фирмы.

    «Новая» схема субадминистрирования

    • При выставлении позиций клиентам Субадминистратор может установить их в произвольном объеме, в том числе и таким образом, что общая сумма денег или инструментов в позициях приписанных ему клиентов будет превышать позицию, установленную Менеджером фирмы самому Субадминистратору.
    • При установке Субадминистратором позиции для клиента его собственная позиция не изменяется .
    • При приеме заявки клиента Субадминистратора она проверяется на достаточность средств как по позиции этого клиента, так и по позиции Субадминистратора.
    • В результате торговых операций клиентов происходит изменение величины доступных средств как клиентов, так и Субадминистратора.

    Выбор схемы субадминистрирования определяется соглашением брокера, использующего систему QUIK, и Субадминистратора. В отношении одного Субадминистратора может применяться только одна схема субадминистрирования.

    В общем случае применение субадминистрирования выглядит следующим образом:

    1. Брокер, использующий систему интернет-трейдинга QUIK, открывает другому брокеру (субброкеру) счет, на котором отражаются средства брокера и его клиентов.
    2. Брокер назначает в системе QUIK субброкера как пользователя с правами Субадминистратора над группой клиентов субброкера.
    3. Для удобства счета клиентов субброкера отображаются, как правило, в формате «NN/MM» либо «NN_MM», где NN – код счета субброкера, MM – код клиента субброкера, например «74/01», «74_02». Код клиента указывается в заявках и сделках клиентов в поле «Код клиента», а также в поле «Комментарий» в виде записи следующего вида: «код_клиента»/«текстовое примечание», например «74/01/sell 5000 rao».
    4. Субадминистратор может просматривать позиции назначенной ему группы клиентов, а также устанавливать и изменять позиции для этих клиентов.
    5. Для отражения проведенных сделок в бэк-офисе Субадминистратор может использовать функцию сохранения Таблицы сделок в текстовый файл (пункт меню Действия / Сохранить в файл все сделки или аналогичный пункт контекстного меню Таблицы сделок). Данные сохраняются в формате рабочего места Московской Биржи, распознаваемом большинством программ для бэк-офиса. Сделки клиентов идентифицируются по коду клиента, указанному в поле «Код клиента».
    6. Для контроля маржинальных позиций клиентов при использовании схемы с контролем текущей стоимости активов (новая схема) Субадминистратор может использовать специальные таблицы «Клиентский портфель» и «Купить/Продать». Также можно применять таблицу «Скрипт», параметры которой могут быть описаны самостоятельно на встроенном языке QPILE. В частности, таким образом можно осуществлять расчет текущей стоимости активов клиента и его задолженности по маржинальному кредитованию. Подробнее см. Алгоритмический язык QPILE. Кроме того, может применяться Специализированное место риск-менеджера «CoLibri».

    См. также:

    • Субадминистрирование
    • Процедура установки значений позиций клиентов
    • Автоматическое создание кодов клиентов Субадминистратором


Процедура установки значений позиций клиентов

Последовательность выполнения операций при установке начальных значений остатков и лимитов:

  1. Перед началом торгов Менеджер фирмы назначает остатки и лимиты Субадминистраторам и Клиентам фирмы. Для выполнения операции рекомендуется использовать загрузку позиций из текстового файла.
  2. После выставления остатков и лимитов Менеджером они становятся видны Клиентам фирмы и Субадминистраторам в Таблицах позиций. У клиентов Субадминистратора в этот момент в Таблицах позиций пусто и выставлять заявки они не могут.
  3. Субадминистратор назначает остатки и лимиты средств своим клиентам.

ВАЖНО!
  1. Установкой остатка и/или лимита по инструментам прописывается соответствие между кодом клиента и счетом депо, на котором будут отражаться инструменты клиента. Поэтому для возможности совершения торговых операций клиент должен иметь лимит (допускается нулевой) хотя бы по одному инструменту для указания счета, по которому клиенту разрешены торговые операции.
  2. Если клиенту не заданы остатки и/или лимиты по инструментам, то он не сможет выполнять торговые операции.
  3. Допускается отрицательное значение входящего остатка средств клиента. Это означает, что на начало дня клиент имеет задолженность перед брокером. При выделении Субадминистратором средств для клиентов значения отрицательных остатков не изменяют величину средств на счете Субадминистратора.
  4. Возможна ситуация, при которой лимит заемных средств клиента достигает отрицательной величины, например, при исполнении заявки, введенной вне системы QUIK (с биржевого терминала), в объеме, превышающем доступные средства клиента. При этом QUIK не может контролировать достаточность средств, однако позволяет отследить такую ситуацию.

См. также:

  • Субадминистрирование
  • Схемы субадминистрирования
  • Автоматическое создание кодов клиентов Субадминистратором


Автоматическое создание кодов клиентов Субадминистратором

В системе QUIK существует возможность автоматического создания Субадминистраторами произвольных кодов клиентов. Данная функция используется для:

  • создания позиций по счетам, находящимся в управлении у Субадминистратора, с целью контроля их состояния средствами системы QUIK;
  • контроля операций по счетам Субадминистратора, совершаемых без использования системы QUIK.

Функция включается администратором сервера QUIK. Если используется автоматическое создание кодов, то добавление кода нового клиента в список клиентов Субадминистратора на сервере QUIK не обязательно.

Субадминистратор может задавать позиции для клиентов, коды которых формируются следующим образом – «<код_субадминистратора>/<код_клиента> ». Например, если код Субадминистратора – «74», значит, он может устанавливать позиции для клиентов с кодами «74/CL1», «74/10345» и т.п., то есть после символа «/» может быть любая символьная строка.

См. также:

  • Субадминистрирование
  • Схемы субадминистрирования
  • Процедура установки значений позиций клиентов


Маржинальная торговля

Система QUIK поддерживает возможность кредитования клиентов средствами брокера.

Маржинальное кредитование - это кредитование денежными средствами или инструментами под залог текущей стоимости активов клиента (инструментов и/или денежных средств).

В системе QUIK предусмотрены следующие схемы маржинального кредитования операций клиентов:

  1. «По дисконтам» – обеспечивает соблюдение единых требований Центрального банка РФ к правилам осуществления брокерской деятельности.

    Проверка покупательной способности клиента выполняется в соответствии с требованиями, при выставлении клиентом поручения контролируется запрет на:

    • снижение стоимости портфеля ниже скорректированного уровня маржи;
    • образование или увеличение короткой позиции при падении рынка на 5% и более;
    • образование временно непокрытой позиции по неликвидному инструменту.

    Для оценки портфеля клиента могут использоваться как дисконты, заданные брокером, так и дисконты Центрального Контрагента (ЦК), транслируемые в режиме онлайн из ТС Московской Биржи, при этом дисконты ЦК по отдельным инструментам могут быть переопределены по правилам брокера.

  2. «МД+» – схема с ограничением покупательной способности при помощи дисконтов по бумагам, валютам и фьючерсам с возможностью неттинга рисков по множествам инструментов.
  3. «На открытую позицию» – применяется для лимитирования операций трейдеров компании или банка.

    В рамках этой схемы могут быть заданы и проконтролированы следующие ограничения на размеры позиций, заданные в деньгах:

    • на короткую или длинную позицию по инструменту;
    • на суммарный объем коротких или длинных позиций по всем инструментам;
    • на суммарный объем всех позиций — коротких и длинных по инструментам и деньгам;
    • на оборот операций за торговую сессию.
  4. «По плечу» – при использовании данной схемы максимальный размер заемных средств (маржинальный лимит) рассчитывается исходя из стоимости средств клиента и заданного коэффициента кредитования («плеча»).
  5. «По лимитам» – маржинальное кредитование реализовано в виде назначения брокером значений (лимитов) доступных клиенту заемных средств. Если значения лимитов равны нулю, то заемные средства клиенту не предоставляются.

При получении заявок от клиентов на покупку/продажу инструментов блокируются доступные средства клиента в размере, необходимом для исполнения заявки. При этом сначала используются собственные средства (Текущий остаток), и при их недостаточности для выполнения заявки используются заемные средства брокера (Текущий лимит). При недостаточности доступных средств клиента для исполнения поручения клиента, заявка отвергается системой.

  1. Значения лимитов заемных средств устанавливаются индивидуально для каждого клиента.
  2. Установкой лимитов по инструментам брокер может регулировать список инструментов, по которым клиент может совершать «короткие продажи», а также их максимальную величину.
  3. Список инструментов, разрешенных для покупки на заемные денежные средства, может ограничиваться администратором сервера QUIK.
  4. При распределении лимитов заемных средств по какому-либо инструменту стоит учитывать, что сумма значений «Текущих лимитов» может превышать величину средств брокера в торговой системе и клиентские заявки, принятые системой QUIK, могут быть отвергнуты торговой системой биржи из-за недостаточности средств для их выполнения.
  5. В течение торгов брокер может менять значения «Входящих лимитов» вручную либо используя механизм Динамической корректировки позиций из файла.

См. также:

  • Управление маржинальной торговлей
  • Установка значений лимитов
  • Установка значений остатка и плеча


Управление маржинальной торговлей

Для просмотра и контроля параметров маржинального кредитования и объема доступных средств, а также для открытия длинных и коротких позиций в QUIK предусмотрены следующие таблицы:

  • Клиентский портфель — параметрами данной таблицы являются: стоимость портфеля клиента, минимальная, начальная, скорректированная маржа, уровень достаточности средств, уровень маржи, использованное «плечо», денежная оценка активов, доступных для открытия позиций по маржинальным и не маржинальным инструментам, а также собственных активов клиента и задолженности брокеру. Набор отображаемых параметров зависит от выбранной схемы маржинального кредитования. В таблице отображается информация по всем доступным пользователю кодам клиентов, например, брокер, либо субброкер может просматривать данные по всем своим клиентам.
  • Купить/Продать — текущий размер позиции по инструментам и денежная оценка стоимости позиции по каждому инструменту в портфеле клиента, доступный объем инструментов для открытия длинных и коротких позиций. При использовании схемы маржинального кредитования «по дисконтам» в данной таблице отображаются также дисконты, которые используются при расчете маржинальных показателей.
  • Состояние счета — таблица предназначена для онлайн мониторинга собственной позиции по деньгам и инструментам. Функционал таблицы позволяет пользователю закрывать и «переворачивать» как выбранные, так и все доступные позиции.

См. также:

  • Маржинальная торговля
  • Установка значений лимитов
  • Установка значений остатка и плеча


Установка значений лимитов

  • Установка значения лимита по размеру плеча
  • Установка значений лимитов для всех клиентов в таблице

    • Установка значения лимита по размеру плеча

    Окно вызывается выбором пункта «Установить лимит» в меню Действия или контекстном меню таблицы «Клиентский портфель».

    Операция предназначена для вычисления значения Входящего лимита на основе оценки стоимости собственных средств клиента и заданной величины «Плеча».

    Выбор параметров клиента производится аналогично установке «Позиции по денежным средствам». При вводе в поле «Плечо» соотношения собственных и заемных средств, в поле «Лимит» вычисляется соответствующий размер заемных средств.

    Нажатием кнопки «Установить» окно закрывается и новое значение лимита отображается в таблице «Клиентский портфель» . Кнопка «Отмена» закрывает окно без сохранения изменений.

    Установка значений лимитов для всех клиентов в таблице

    Окно вызывается выбором пункта «Установить лимиты для клиентов из таблицы» в меню Действия или контекстном меню таблицы «Клиентский портфель».

    Операция предназначена для установки значения «Входящего лимита» для всех клиентов, отображаемых в окне «Клиентский портфель». Вычисление «Входящего лимита» производится на основе оценки стоимости собственных средств клиента и заданной величины «Плеча».

    Для расчета значений «Входящих лимитов» необходимо указать параметры:

    • «Код валюты» – выбрать из списка код валюты расчетов.
    • «Код позиции» – выбрать из списка код позиции.
    • «Срок расчётов» – выбрать из списка срок расчётов. В выпадающем списке отображаются сроки расчётов, доступные для фирмы клиента, выбранного в таблице.
    • «Плечо» – ввести соотношение собственных и заемных средств.

    Установка флажков «Устанавливать лимиты для» позволяет рассчитывать значения «Входящих лимитов» раздельно для маржинальных и/или немаржинальных клиентов.

    См. также:

    • Маржинальная торговля
    • Управление маржинальной торговлей
    • Установка значений остатка и плеча


Установка значений остатка и плеча

Окно вызывается выбором пункта «Установить остаток и плечо» в меню Действия или контекстном меню таблицы «Клиентский портфель».

Операция предназначена для ввода либо изменения значения «Входящего остатка» по денежным средствам и «Плеча». Выбор параметров клиента производится аналогично установке «Позиции по денежным средствам».

Нажатием кнопки «Установить» окно закрывается и введенное значение «Плеча» отображается в таблице «Клиентский портфель», а значение «Позиции клиента» отображается в таблице Позиций по деньгам в виде «Входящего остатка». Кнопка «Отмена» закрывает окно без сохранения изменений.

Установка значений остатка и плеча для всех клиентов в таблице

Окно вызывается выбором пункта «Установить плечо для клиентов из таблицы» в меню Действия или контекстном меню таблицы «Клиентский портфель».

Операция предназначена для установки значений Плеча для всех клиентов, отображаемых в окне «Клиентский портфель».

Для установки значения необходимо указать параметры:

  • «Плечо» – ввести соотношение собственных и заемных средств;
  • «Код валюты» – выбрать из списка код валюты расчетов;
  • «Код позиции» – выбрать из списка код позиции;
  • «Плечо» – ввести соотношение собственных и заемных средств;
  • «Срок расчётов» – выбрать из списка срок расчётов. В выпадающем списке отображаются сроки расчётов, доступные для фирмы клиента, выбранного в таблице.

Установка флажков «Устанавливать лимиты для» позволяет рассчитывать значения «Плеча» раздельно для маржинальных и/или немаржинальных клиентов.

См. также:

  • Маржинальная торговля
  • Управление маржинальной торговлей
  • Установка значений лимитов


Операции над позициями

  • Создание позиции по денежным средствам
  • Создание позиции по инструментам
  • Изменение позиций
  • Удаление позиции
  • Удаление группы позиций по денежным средствам
  • Удаление группы позиций по инструментам
  • Отчет по позициям
  • Сохранение позиций в файл
  • Загрузка позиций из файла
    •


Создание позиции по денежным средствам

Открытие окна «Установка позиции по денежным средствам» осуществляется выбором в таблице «Позиции по деньгам» пункта контекстного меню «Задать позицию по денежным средствам» или пункта меню Действия / Задать позицию по денежным средствам.

Значение параметров:

  1. «Фирма» – идентификатор участника торгов. Выберите нужный идентификатор из списка. Идентификаторы различны для разных режимов торгов или бирж. Необходимо выбрать код участника, соответствующий режиму торгов, на который назначается позиция.
  2. «Код валюты» – код валюты позиции. Выберите нужный код валюты из выпадающего списка.
  3. «Код позиции» – идентификатор торговой сессии (режима торгов), в которой ведется позиция, например, «EQTV» – Фондовая Московская Биржа.
  4. «Код клиента» – код клиента, которому назначается позиция.
  5. «Срок расчётов» – срок проведения расчётов. В выпадающем списке отображаются сроки расчётов, заданные в настройках Библиотеки расчета лимитов для указанного кода клиента. Значение «Tx» соответствует позиции клиента после совершения всех расчетов. Если в настройках Библиотеки расчета лимитов включен признак «Вести позиции в календарных датах», то выпадающий список изменится на выбор календарной даты.
  6. «Позиция клиента» – значение собственных денежных средств клиента с точностью выбранной валюты.
  7. «Лимит клиента» – максимальное значение заемных денежных средств с точностью выбранной валюты.

Назначенная позиция для нового клиента появится в таблице Позиции по деньгам в виде новой строки.


Создание позиции по инструментам

Открытие окна «Установка позиции по инструментам» осуществляется выбором в таблице «Позиции по инструментам» пункта контекстного меню «Задать позиции по инструментам» или пункта меню Действия / Задать позиции по инструментам.

Значение параметров:

  1. «Инструмент» – наименование инструмента, по которому задается позиция. Выберите нужный инструмент из списка.
  2. «Фирма» – идентификатор участника торгов. Выберите нужный идентификатор из списка. Идентификаторы различны для разных режимов торгов или бирж. Необходимо выбрать код участника, соответствующий режиму торгов, на который назначается позиция.
  3. «Счет депо» – код счета депо в торговой системе биржи для отражения приобретаемых инструментов. Выберите из списка код, соответствующий данному режиму торгов.
  4. «Код клиента» – код клиента, которому назначается позиция.
  5. «Срок расчетов» – срок проведения расчётов. В выпадающем списке отображаются сроки расчётов, заданные в настройках Библиотеки расчета лимитов для указанного кода клиента. Значение «Tx» соответствует позиции клиента после совершения всех расчетов. Если в настройках Библиотеки расчета лимитов включен признак «Вести позиции в календарных датах», то выпадающий список изменится на выбор календарной даты.
  6. «Позиция клиента» – значение собственных средств клиента по данному инструменту. Если в настройках Библиотеки расчета лимитов включен признак «Рассчитывать позиции в лотах», то позиции указываются в лотах, иначе – в штуках.
  7. «Лимит клиента» – максимальное значение заемных средств клиента по данному инструменту. Если в настройках Библиотеки расчета лимитов включен признак «Рассчитывать позиции в лотах», то лимиты указываются в лотах, иначе – в штуках.
  8. «Изменить цену и/или валюту приобретения» – при установленном флажке доступны для редактирования следующие параметры:
    • «Цена» – значение средневзвешенной цены позиции клиента по инструментам. При установке новой позиции значение по умолчанию: «0».
    • «Валюта» – валюта расчета цены приобретения инструмента. В выпадающем списке отображаются коды валют. При установке новой позиции значение по умолчанию не задано.

    При выключенном флажке установленные значения параметров «Цена» и «Валюта» не меняются.

    Точность цены равная 6 знакам используется вне зависимости от валюты приобретения, заданной пользователем.
    Если цена приобретения больше нуля, то изменение ее на <пусто> (незаданное значение) при редактировании позиции не даст результатов, значение останется прежним.

После того, как назначена позиция для нового клиента, она появится в таблице Позиции по инструментам в виде новой строки.


Изменение позиций

Изменение значений позиций клиента вручную выполняется:

  • двойным щелчком левой кнопки мыши на соответствующей строке таблицы позиций;
  • выбором пункта контекстного меню «Задать позицию по денежным средствам» (или «Задать позицию по инструментам») на соответствующей строке таблицы позиций;
  • выбором пункта меню программы Действия/Задать позицию по денежным средствам (или Действия/Задать позицию по инструментам) в соответствующей активной таблице позиций.


Удаление позиции

Удаление позиции для выбранного клиента вручную выполняется:

  • двойным щелчком правой кнопки мыши на соответствующей строке таблицы позиций;
  • выбором пункта контекстного меню «Удалить позицию по денежным средствам» (или «Удалить позиции по инструментам») на соответствующей строке таблицы позиций;
  • выбором пункта меню программы Действия / Удалить позиции по инструментам (или Действия / Удалить позицию по денежным средствам) в соответствующей активной таблице позиций.


Удаление группы позиций по денежным средствам

меню Брокер / Удалить все позиции по ден. средствам

Функция позволяет удалить группу позиций, удовлетворяющих заданным условиям.

  1. «Доступные фирмы» – в приведенном списке выберите идентификатор участника торгов, соответствующий режиму торгов, в котором удаляются позиции.
  2. «Удалить все позиции фирмы» – при установленном флажке удаляются все позиции, соответствующие выбранному идентификатору участника торгов. При снятом флажке возможна более гибкая настройка условий.
  3. «Валюта» – выбор валюты, в которой выражены денежные средства. Чтобы удалить позиции во всех валютах, установите флажок «все валюты».
  4. «Код позиции» – выбор идентификатора торговой сессии (режима торгов), соответствующего удаляемым позициям. Например, «EQTV» – Фондовая Московская Биржа. Позволяет удалять позиции всех клиентов по заданному рынку. При установленном флажке «все коды позиций» удаляются позиции вне зависимости от указанного в них идентификатора торговой сессии.
  5. «Код клиента» – поле предназначено для указания кода клиента для удаления позиций определенного пользователя. Код клиента указывается вручную (список отсутствует). Если установлен флажок «все клиенты», то позиции удаляются независимо от значения кода клиента.

Нажатием кнопки «Удалить» выполняется удаление позиций, нажатие кнопки «Отмена» закрывает окно без совершения действий с позициями.

Удаление лимитов по срочному рынку таким способом невозможно.


Удаление группы позиций по инструментам

меню Брокер / Удалить все позиции по инструментам...

Функция позволяет удалить группу позиций, удовлетворяющих заданным условиям.

  1. «Доступные фирмы» - в приведенном списке выберите идентификатор участника торгов, соответствующий режиму торгов, в котором удаляются позиции.
  2. «Удалить все позиции фирмы» - при установленном флажке удаляются все позиции, соответствующие выбранному идентификатору участника торгов. При снятом флажке возможна более гибкая настройка условий.
  3. «Инструмент» – выбор инструмента. Предназначен для удаления позиций клиентов по определенному инструменту. При установленном флажке «все инструменты» удаляются позиции по всем инструментам.
  4. «Счета депо» – выбор счета депо для удаления позиций. Если флажок «все счета» установлен, то условие не проверяется.
  5. «Код клиента» - поле предназначено для указания кода клиента для удаления позиций определенного пользователя. Код клиента указывается вручную (список отсутствует). Если установлен флажок «все клиенты», то позиции удаляются независимо от значения кода клиента.

Нажатием кнопки «Удалить» выполняется удаление позиций, нажатие кнопки «Отмена» закрывает окно без совершения действий с позициями.


Отчет по позициям

меню Брокер / Отчет по позициям...

Отчет по позициям предназначен для получения информации о действиях с позициями определенного клиента за указанный день: время установки/изменения, присвоенные значения, автор изменений, а также о динамических корректировках позиций, в том числе программой «CoLibri».

Функция запроса отчета доступна пользователям с правами Субадминистратора или Менеджера фирмы.

Назначение полей окна запроса:

  • «Заказать отчет по» – выбор действий над позициями, включаемыми в отчет;
  • «Код фирмы» – код торгового счета, к которому относится позиция;
  • «Код клиента» – код клиента для отчета, каждый отчет составляется только по одному коду;
  • «За дату» – выбор даты торгов для отчета.

Результат выполнения отчета показывается в отдельном окне следующего вида:

Результаты разных запросов отображаются в разных окнах.

Действия над отчетом, доступные из контекстного меню:

  • «Печать» – распечатать отчет на принтере;
  • «Предварительный просмотр» – открыть окно просмотра печатного варианта отчета;
  • «Сохранить в файл» – сохранить отчет в виде HTML-файла.


Сохранение позиций в файл

меню Брокер / Сохранить позиции в файл...
  • Для сохранения всех позиций в файл функция выполняется через пункт контекстного меню «Сохранить все позиции в файл» в одной из таблиц позиций или из меню программы Действия.
  • Для сохранения в файл позиций, отображающихся с учетом настроенных фильтров, в таблицах «Позиции по инструментам» и «Позиции по деньгам», функция выполняется через пункт контекстного меню «Сохранить в файл позиции из таблицы» или из меню программы Действия, если активно окно соответствующей таблицы.

В открывшемся окне необходимо указать либо выбрать имя файла для записи. В диалоге также приведены информационные поля с указанием количества строк, сохраненных в файле.

Одной операцией сохранения в файл записываются позиции как по инструментам, так и по денежным средствам.

Схемы переноса позиций

  1. Если флажок «Переносить использованные позиции» снят, то в файле сохраняются текущие значения остатка и лимита. Таким образом, при последующей загрузке позиций на следующий день, входящим (начальным) значениям остатков и лимитов будут присвоены текущие (последние) значения предыдущего дня.
    OPEN_BALANCE = Текущий остаток
    OPEN_LIMIT = Текущий лимит

    Параметр CURRENT_LIMIT не используется.
  2. Если установлен флажок «Переносить использованные позиции», то в файле сохраняются входящее и текущее значения лимита и текущее значение остатка.
    OPEN_BALANCE = Текущий остаток
    OPEN_LIMIT = Входящий лимит
    CURRENT_LIMIT = Текущий лимит

    Параметр CURRENT_LIMIT используется, если Текущий лимит строго меньше входящего.

Нажатием кнопки «Сохранить» производится запись в файл. Нажатие кнопки «Выход» приводит к закрытию окна.

Файл представляет последовательность строк, каждая из которых содержит данные по отдельной позиции, в виде «название параметра»=«значение», разделенные символом «;» через пробел. Последовательность параметров и их значения приведены в таблице.

Параметр | Соответствующее поле таблицы позиций | Параметр | Соответствующее поле таблицы позиций

Позиции по деньгам

Позиции по инструментам

MONEY: Обозначение записи, относящейся к позиции по денежным средствам DEPO: Обозначение записи, относящейся к позиции по инструментам
FIRM_ID | Фирма | FIRM_ID | Фирма
TAG | Код позиции | SECCODE | Код инструмента
CURR_CODE | Код валюты расчетов | CLIENT_CODE | Код клиента
CLIENT_CODE | Код клиента | LIMIT_KIND | Срок расчётов. Если в настройках Библиотеки расчета лимитов включен признак «Вести позиции в календарных датах», то параметр указывается в формате даты <ГГГГММДД>
LIMIT_KIND | Срок расчётов. Если в настройках Библиотеки расчета лимитов включен признак «Вести позиции в календарных датах», то параметр указывается в формате даты <ГГГГММДД> | OPEN_BALANCE | Входящий остаток
OPEN_BALANCE | Входящий остаток | OPEN_LIMIT | Входящий лимит
* OPEN_LIMIT | Входящий лимит | * CURRENT_LIMIT | Текущий лимит
* CURRENT_LIMIT | Текущий лимит | TRDACCID | Счет депо
* LEVERAGE | ** Плечо | WA_POSITION_PRICE | Цена приобретения, с точностью до 6 знаков после десятичного разделителя
WA_PRICE_CURR_CODE | Код валюты, в которой считается средневзвешенная цена приобретения позиции

* - необязательный параметр

** - параметр таблицы «Клиентский портфель»

Пример файла:

MONEY: FIRM_ID = NC0080000000; TAG = EQTV; CURR_CODE = SUR; CLIENT_CODE = 583; LIMIT_KIND = 1; OPEN_BALANCE =

200000,00; OPEN_LIMIT = 0,00; LEVERAGE = -1;

DEPO: FIRM_ID = NC0080000000; SECCODE = RU0008926621; CLIENT_CODE = 583; LIMIT_KIND = 0; OPEN_BALANCE = 300;

OPEN_LIMIT = 0; TRDACCID = NL0080000043;  WA_POSITION PRICE =  41,17; WA_PRICE_CURR_CODE = USD;

Результат операции записи в файл отображается в Окне сообщений, например:

Файл D:\74.lim обработано строк – 210, позиций записано:

по денежным средствам – 83,

по инструментам – 127


Загрузка позиций из файла

меню Брокер / Загрузить позиции из файла...

Функция может выполняться через пункт контекстного меню «Загрузить позиции из файла» в одной из таблиц позиций или из меню программы Действия. В открывшемся окне выберите файл с позициями для загрузки.

В одном файле содержатся позиции как по инструментам, так и по денежным средствам. При описании позиций все параметры являются обязательными, кроме «CURRENT_LIMIT», «LIMIT_KIND» и «LEVERAGE».

Поведение системы при загрузке из файла ранее сохраненных позиций:

  1. Если в таблице позиций уже существует позиция для данного клиента, то он изменяется, если позиции нет, то формируется новая строка.
  2. Изменение позиций осуществляется следующим образом:
    • «Текущий остаток» = («OPEN_BALANCE» - «Входящий остаток») + «Текущий остаток *»
    • «Входящий остаток» = «OPEN_BALANCE»
    • «Текущий лимит» = «CURRENT_LIMIT» - если задан «CURRENT_LIMIT»,
      «Текущий лимит» = («OPEN_LIMIT» - «Входящий лимит») + «Текущий лимит *» - иначе
    • «Входящий лимит» = «OPEN_LIMIT»

    Где Текущий остаток * и Текущий лимит * – текущие значения до изменения позиций.
  3. Если в файле позиций параметр «LEVERAGE» задан равным -1 или отсутствует, то величина «плеча» вычисляется исходя из величины «Входящего лимита по денежным средствам». Если параметр «LEVERAGE» содержит положительное значение, то величина «плеча» устанавливается явным образом.
  4. Если в файле позиций параметр «LIMIT_KIND» отсутствует, то его значение берется равным «0».
  5. В случае обнаружения ошибки в какой-либо строке при загрузке файла позиций программа выдаст сообщение следующего вида:
    Ошибка в строке <номер строки> загружаемого файла <наименование файла>. Параметр
<наименование параметра> имеет недопустимое значение <значение параметра>


Динамическая корректировка позиций из файла

меню Брокер / Корректировать позиции через файл...

Функция может выполняться через пункт контекстного меню «Корректировать через файл» в одной из Таблиц позиций или из меню программы Действия.

Стандартный механизм расчета позиций подразумевает следующую схему: при совершении сделки пользователем сервер QUIK автоматически рассчитывает позицию по деньгам для этого пользователя в соответствии с настройками сервера QUIK для конкретного рынка. В некоторых случаях эта схема может не удовлетворять. Так как политика предоставления скидок для клиентов и управления маржинальным кредитованием различается во всех фирмах, система предоставляет возможность через специальный интерфейс изменять позиции для клиента динамически.

Динамическая корректировка позиций из файла предназначена для расчета изменений позиций клиентов внешними программными средствами на основе алгоритмов, принятых у брокера.

Применение динамической корректировки позиций из файла позволяет корректировать значения всех (и «Входящих» и «Текущих») остатков и лимитов клиентов, по инструментам и денежным средствам.

Применение динамической корректировки позиций из файла

  1. Пользователь с правами Менеджера фирмы либо Субадминистратора экcпортирует необходимые для расчета позиций данные из таблиц QUIK по DDE (в MS Excel) либо через ODBC в базу данных.
  2. Средствами MS Excel (например, макросом на языке VBA) либо собственной программой отслеживается изменение параметров и вычисляется изменение позиций на основании алгоритмов, используемых брокером.
  3. Поручение на изменение позиции записывается новой строкой в исходный файл со стандартным расширением .lсi, например, limits.lсi, с присвоением ему уникального параметра «LIMIT_ID».
  4. Указанный файл считывается системой QUIK через установленные интервалы времени и при появлении в нем новых строк (имеющих ранее не обрабатывавшиеся значения параметра «LIMIT_ID») формируется команда серверу QUIK на изменение соответствующей позиции.
  5. Факт отправки коррекции позиции отражается в выходном файле (*.lco), который может использоваться для диагностики результата операции.
  6. Для внешней программы коррекция считается обработанной, если в выходном файле существует строка с параметром «LIMIT_ID», аналогичным значению этого параметра, указанного в коррекции.

См. также:

  • Формат исходного файла с корректировками позиций (*.lci)
  • Формат выходного файла с результатами корректировок (*.lco)
  • Настройка динамической корректировки позиций из файла


Формат исходного файла с корректировками позиций (*.lci)

Каждая строка файла представляет собой набор параметров, записанных в виде «наименование параметра»=«значение параметра», разделенных символом «;» через пробел.

Параметр | Назначение
LIMIT_TYPE | Тип изменяемой позиции. Возможные значения: «MONEY» – позиция по денежным средствам, «DEPO» – позиция по инструментам
LIMIT_ID | Идентификатор корректировки позиции, уникальный целочисленный параметр в интервале от 0 до 2147483648
FIRM_ID | Код участника торгов. Соответствует параметру «Фирма» Таблицы позиций
CLIENT_CODE | Код клиента. Максимум 12 символов. Обязательный параметр
OPEN_BALANCE | Изменение значения «Входящего остатка», необязательный параметр
OPEN_LIMIT | Изменение значения «Входящего лимита», необязательный параметр
CURRENT_BALANCE | Изменение значения «Текущего остатка», необязательный параметр
CURRENT_LIMIT | Изменение значения «Текущего лимита», необязательный параметр
LIMIT_OPERATION

Способ коррекции позиции, обязательный параметр. Возможные значения:

  • «CORRECT_LIMIT» (по умолчанию) – значения позиций изменяются на величину, указанную в корректировках:
    • «Входящий остаток» = «Входящий остаток» + OPEN_BALANCE;
    • «Входящий лимит» = «Входящий лимит» + OPEN_LIMIT;
    • «Текущий остаток» = «Текущий остаток» + OPEN_BALANCE + CURRENT_BALANCE;
    • «Текущий лимит» = «Текущий лимит» + OPEN_LIMIT + CURRENT_LIMIT.
  • «SET_LIMIT» – значения позиций заменяются на указанные в корректировках.
    • «Входящий остаток» = OPEN_BALANCE;
    • «Входящий лимит» = OPEN_LIMIT;
    • «Текущий остаток» = CURRENT_BALANCE;
    • «Текущий лимит» = CURRENT_LIMIT
*TRDACCID | Номер счета депо, обязательный параметр. Соответствует полю «Счет депо» таблицы «Позиции по инструментам»
* SECCODE | Код инструмента, обязательный параметр. Соответствует полю «Код инструмента» таблицы «Позиции по инструментам»
** TAG | Код позиции, обязательный параметр. Соответствует полю «Код позиции» таблицы «Позиции по деньгам»
** CURR_CODE | Код валюты, обязательный параметр. Соответствует полю «Валюта» таблицы «Позиции по деньгам»
LIMIT_KIND | Срок расчётов. Соответствует полю «Срок расчётов» таблиц «Позиции по деньгам» и «Позиции по инструментам». При включенном признаке «Вести позиции в календарных днях» в настройках Библиотеки расчета лимитов параметр указывается в формате даты <ГГГГММДД> и соответствует полю «Дата расчетов» таблиц «Позиции по деньгам» и «Позиции по инструментам»
** LEVERAGE | Плечо, необязательный параметр. Соответствует полю «Плечо» таблицы «Позиции по деньгам»
* WA_POSITION_PRICE | Средневзвешенная цена приобретения, необязательный параметр. Соответствует полю «Цена приобретения» таблицы «Позиции по инструментам», с точностью до 6 знаков после десятичного разделителя
* WA_PRICE_CURR_CODE | Код валюты, в которой считается средневзвешенная цена приобретения позиции

* - параметр корректировки позиций по инструментам (LIMIT_TYPE=DEPO)

** - параметр корректировки позиций по денежным средствам (LIMIT_TYPE=MONEY)

Несмотря на то, что параметры «OPEN_BALANCE», «OPEN_LIMIT», «CURRENT_BALANCE», «CURRENT_LIMIT» являются необязательными, по крайней мере, один из них должен быть задан для каждой коррекции позиций.

Примеры строк:

  • корректировка позиции по денежным средствам
LIMIT_TYPE=MONEY; LIMIT_ID=1; FIRM_ID=NC0038900000; TAG=EQTV; CURR_CODE=SUR; CLIENT_CODE=
SUBADM1; OPEN_LIMIT=10; CURRENT_LIMIT= 10; LIMIT_OPERATION=CORRECT_LIMIT; LIMIT_KIND= 1; LEVERAGE=0,2;
  • установка позиции по денежным средствам
LIMIT_TYPE=MONEY; LIMIT_ID=2; FIRM_ID=NC0038900000; TAG=EQTV; CURR_CODE=SUR; CLIENT_CODE= SUBADM2; OPEN_LIMIT=10000;
CURRENT_LIMIT= 5000; LIMIT_OPERATION=SET_LIMIT; LIMIT_KIND=0; LEVERAGE=0,18;
  • корректировка позиции по инструментам
LIMIT_TYPE=DEPO; LIMIT_ID=3; FIRM_ID=NC0038900000; SECCODE=RU0008926621; TRDACCID=L01-00000F00;
CLIENT_CODE=CL2; OPEN_LIMIT=1; CURRENT_LIMIT=0; OPEN_BALANCE= 10; CURRENT_BALANCE= -2;LIMIT_OPERATION=  CORRECT_LIMIT;  LIMIT_KIND= 2; WA_POSITION_PRICE= 2; WA_PRICE_CURR_CODE=USD;
  • установка позиции по инструментам
LIMIT_TYPE=DEPO; LIMIT_ID=4; FIRM_ID=NC0038900000; SECCODE=RU0009024277; TRDACCID=L01-00000F00;
CLIENT_CODE= CL3; OPEN_LIMIT=200; CURRENT_LIMIT=  100; OPEN_BALANCE=500; CURRENT_BALANCE=400; LIMIT_OPERATION=SET_LIMIT;
LIMIT_KIND=0; WA_PRICE_CURR_CODE=USD;

См. также:

  • Динамическая корректировка позиций из файла
  • Формат выходного файла с результатами корректировок (*.lco)
  • Настройка динамической корректировки позиций из файла


Формат выходного файла с результатами корректировок (*.lco)

Каждая строка файла представляет собой набор параметров, записанных в виде «наименование параметра»=«значение параметра», разделенных символом «;» через пробел.

Параметр | Назначение
LIMIT_TYPE | Тип изменяемой позиции. Возможные значения: «MONEY» – позиция по денежным средствам, «DEPO» – позиция по инструментам
LIMIT_ID | Идентификатор корректировки позиции. Соответствует значению, указанному в файле с корректировками позиции (*.lci)
STATUS

Результат обработки корректировки позиций. Возможные значения:

  • «-2» - коррекция позиции не соответствует заданному формату;
  • «0» - коррекция позиции отправлена серверу QUIK;
  • «1» - коррекция позиции успешно выполнена на сервере QUIK;
  • «2» - коррекция позиции отклонена сервером QUIK.
DESCRIPTION | Текстовый комментарий результата обработки корректировки позиций
RESULT_CODE | Код ошибки, возникшей при корректировке лимитов
RESULT_DESC | Текстовое описание результата выполнения операции корректировке лимитов

Примеры строк:

LIMIT_ID=30;LIMIT_TYPE=MONEY;STATUS=0;DESCRIPTION=Коррекция отправлена на cервер;RESULT_CODE=0;RESULT_DESC=;
LIMIT_ID=30;LIMIT_TYPE=MONEY;STATUS=1;DESCRIPTION=Коррекция успешно проведена;RESULT_CODE=0;RESULT_DESC=;

См. также:

  • Динамическая корректировка позиций из файла
  • Формат исходного файла с корректировками позиций (*.lci)
  • Настройка динамической корректировки позиций из файла


Настройка динамической корректировки позиций из файла

Настройка осуществляется одним из следующих способов:

  • Выбором пункта меню программы Брокер / Корректировать позиции через файл…;
  • Выбором контекстного меню «Корректировать через файл» в одной из Таблиц позиций или из меню программы Действия.

  1. «Файл с исходными данными о коррекциях позиций» – укажите путь к файлу с корректировками позиций (*.lci).
  2. «Обрабатывать через .. секунд» – интервал обращения системы QUIK к текстовому файлу.
  3. «Оповещать об обработке файла звуковым сигналом» – при установленном флажке обращение к тестовому файлу сопровождается звуковым сигналом.
  4. «Файл с данными об успешно отправленных коррекциях позиций» – укажите путь к файлу с результатами корректировки позиций (*.lco).
  5. «Файл с журналом отправляемых коррекций позиций» – укажите путь к файлу с журналом действий программы по корректировке позиций (*.lcr).
  6. «Вести журнал отправляемых коррекций позиций» – при установленном флажке действия программы по корректировке позиций протоколируются в файл с журналом, указанным выше. При снятом флажке протоколирование прекращается.
  7. Нажатие кнопки «Начать обработку» приводит к запуску процедуры динамической корректировки позиций. Окно настройки при этом остается открытым и может быть убрано с экрана нажатием кнопки «Закрыть».
  8. Нажатие кнопки «Прекратить обработку» останавливает процесс корректировки позиций.
  9. Для контроля за обращением программы к файлу с корректировками позиций предназначены следующие информационные поля окна:
    • «Число обращений, сделанных к файлу» – количество обращений к текстовому файлу с момента запуска процесса. При прекращении обработки значение фиксируется, при повторном запуске устанавливается нулевое значение;
    • «Число прочитанных из файла строк» – количество строк, прочитанных из файла при последнем обращении к нему;
    • «Число отправленных коррекций позиций» – количество команд серверу на корректировку позиций, сформированных в результате последнего обращения к файлу. Значение может отличаться от числа прочитанных строк, если были обнаружены ошибки или какая-либо корректировка для какой-либо транзакции уже была передана серверу;
    • «Всего отправлено коррекций позиций» – количество команд серверу на корректировку позиций, переданных с момента запуска процесса;
    • «Всего выполнено коррекций позиций» – количество исполненных команд серверу на корректировку позиций с момента запуска процесса.

См. также:

  • Динамическая корректировка позиций из файла
  • Формат исходного файла с корректировками позиций (*.lci)
  • Формат выходного файла с результатами корректировок (*.lco)


Операции над лимитами клиентов на срочном рынке

Особенности работы с лимитами клиентов на срочном рынке

В отличие от операций на фондовом рынке, функции контроля достаточности средств клиента для совершения операций выполняет не сервер системы QUIK, а непосредственно торговая система биржи.

Создание и редактирование лимитов на срочном рынке осуществляются вводом соответствующей транзакции в торговую систему. Если транзакции недоступны, то операции с лимитами невозможны.

Брокер устанавливает ограничения на счет клиента, отражающие максимальные значения собственных средств, дальнейший контроль параметров осуществляется торговой системой.

Для работы с лимитами клиентов на срочном рынке брокеру доступны следующие операции:

  • Создание лимита
  • Изменение лимита
  • Удаление лимита
  • Сохранение в файл лимитов по срочному рынку
  • Загрузка из файла лимитов по срочному рынку
  • Изменение позиции по срочному контракту


Создание лимита

Создать новое ограничение на счет клиента можно одним из следующих способов:

  • Нажатием кнопки [image] на панели инструментов, выбором класса, относящегося к срочному рынку (например, «Фьючерсы FORTS») и транзакции «Задать лимит»;
  • Нажатием кнопки [image] на панели инструментов (таблица Ограничения по клиентским счетам должна быть активна);
  • Нажатием клавиши «F2» (таблица «Ограничения по клиентским счетам» должна быть активна);
  • Двойным нажатием левой кнопки мыши на строке таблицы «Ограничения по клиентским счетам» (для этого в таблице должен присутствовать хотя бы один лимит клиента);
  • Выбором пункта контекстного меню «Задать лимит» в таблице «Ограничения по клиентским счетам».

Значения параметров окна установки лимитов:

  1. «Торговый счет» – номер счета клиента в торговой системе. Значение должно указываться с учетом регистра.
  2. «Лимит денежных средств» – для срочного рынка в поле указывается величина денежных средств клиента.
  3. «Принудительное понижение» – при установленном флажке в торговую систему подается поручение на принудительное понижение ограничения по денежным средствам клиента до заданного значения, при этом устанавливается значение КГО=0и включается параметр «Использовать КГО». Если флажок отключен, то КГО не используется и не изменяется. Параметр Секции срочного рынка Московской Биржи.

При использовании стандартной формы ввода существует возможность указания дополнительных параметров и корректировки значения лимита на срочном рынке Московской Биржи. Для этого необходимо включить в настройках программы (пункт меню Система / Настройки / Основные настройки... , раздел «Торговля» / «Заявки» / «Формы ввода») флажок «Динамический».

Дополнительные параметры, доступные в окне установки лимитов:

  1. «Коэффициент клиентского ГО» – дополнительный коэффициент гарантийного обеспечения (ГО), увеличивающий общее портфельное ГО. Указывается в относительных единицах.
  2. «Использовать КГО» – признак использования коэффициента клиентского ГО. Если флажок отключен, то корректировка величины портфельного ГО на указанный коэффициент не производится.
  3. «Скорректировать лимит». Если флажок выключен, то установкой лимита задается новое абсолютное значение действующего ограничения. Если флажок включен, то действующее значение ограничения будет увеличено на указанное значение лимита.

    Если необходимо изменить только значение «Коэффициента клиентского ГО», то в полях с лимитами необходимо указать нулевые значения и включить данный флажок.


Изменение лимита

Изменение ограничения по счету выполняется двойным нажатием левой кнопки мыши на строке с редактируемым значением.

На срочном рынке возможно изменение только входящих значений остатков и лимитов, текущие значения (с учетом сделок) изменяются торговой системой на разницу между новым и старым значением входящего остатка (или лимита).


Удаление лимита

Удалить выбранное ограничение на торговый счет клиента можно одним из следующих способов:

  • Нажатием кнопки [image] на панели инструментов;
  • Нажатием клавиш «CTRL»+«D»;
  • Двойным нажатием правой кнопки мыши на удаляемой строке таблицы Ограничения по клиентским счетам;
  • Выбором пункта контекстного меню «Удалить лимит» в таблице «Ограничения по клиентским счетам»;
  • Нажатием кнопки [image] на панели инструментов, выбором класса, относящегося к срочному рынку (например, «Фьючерсы FORTS») и транзакции «Удалить лимит», при этом появится диалог следующего вида:

Значения параметров окна:

  1. «Фирма» – идентификатор фирмы.
  2. «Тип лимита» – выбор типа удаляемого ограничения («Денежные средства»).
  3. «Торговый счет» – номер торгового счета для удаления лимита. Значение должно указываться с учетом регистра.

Операция выполняется нажатием кнопки «Выполнить». Результат выполнения операции отображается в «Окне сообщений».


Сохранение в файл лимитов по срочному рынку

меню Брокер / Сохранить лимиты по срочному рынку...

Функция выполняется через пункт контекстного меню «Сохранить лимиты по срочному рынку» в одной из таблиц ограничений или из меню программы Действия/Сохранить лимиты по срочному рынку. В открывшемся окне необходимо указать либо выбрать имя файла для записи. В файл сохраняются текущие значения ограничений по клиентским счетам.

Файл представляет последовательность строк, каждая из которых содержит данные по отдельному лимиту, в виде «название параметра»=«значение», разделенные символом «;» без пробелов. Последовательность параметров и их значения приведены в таблице.

Параметр | Назначение
CLASS_CODE

Код класса инструментов. Возможные значения:

  • «SPBFUT» – срочный рынок Московской Биржи;
  • « » (пусто) – в момент сохранения лимитов информации о коде класса не было
ACCOUNT | Торговый счет
VOLUMEMN | Лимит открытых позиций, при «Тип лимита» = «Ден.средства» или «Всего»
KGO | Коэффициент клиентского гарантийного обеспечения
USE_KGO Параметр, который определяет, будет ли загружаться величина КГО при загрузке лимитов из файла:
  • при USE_KGO=Y – величина КГО загружается;
  • при USE_KGO=N – величина КГО не загружается
FIRM_ID | Идентификатор фирмы / раздела на срочном рынке Московской Биржи, на которой устанавливается лимит
SECCODE | Код инструмента

Примеры строк:

  • Лимиты срочного рынка Московской Биржи:
CLASS_CODE=SPBFUT;ACCOUNT=589_001;VOLUMEMN=5551,00;KGO=4,00;USE_KGO=Y;FIRM_ID=SPBFUT589;

  1. Функция загрузки из файла доступна только при наличии связи с сервером.
  2. Параметр «FIRM_ID» используется в случае загрузки лимитов срочного рынка Московской Биржи на различные разделы с одного терминала.


Загрузка из файла лимитов по срочному рынку

меню Брокер / Загрузить лимиты по срочному рынку...

Функция выполняется через пункт контекстного меню «Загрузить лимиты по срочному рынку» в одной из таблиц ограничений или из меню программы Действия / Загрузить лимиты по срочному рынку. В открывшемся окне укажите следующие параметры:

  1. «Файл с исходными данными лимитов по срочному рынку» – выбор файла с лимитами для загрузки.
  2. «Ограничить скорость» – при включенном признаке количество транзакций, отправляемых на сервер в секунду, ограничивается значением, указанным в поле «Количество транзакций в секунду». По умолчанию признак выключен.
  3. «Число строк, прочитанных из файла» – количество строк, прочитанных из файла с лимитами.
  4. «Число отправленных транзакций» – количество транзакций, отправленных на сервер QUIK.

Поведение системы при загрузке из файла ранее сохраненных лимитов:

  1. При загрузке из файла устанавливаются входящие значения лимитов. Текущие значения (с учетом сделок) изменяются торговой системой на разницу между новым и старым значением входящего остатка (или лимита).
  2. Если строка файла не содержит ошибок, то формируется транзакция на создание лимита клиента. Если лимит такого клиента уже существует в системе, то производится его изменение.
  3. В случае обнаружения ошибки в какой-либо строке при загрузке файла лимитов программа выдаст сообщение следующего вида:
    Ошибка в строке <номер строки> загружаемого файла <наименование файла>. Параметр
<наименование параметра> имеет недопустимое значение <значение параметра>


Изменение позиции по срочному контракту

Операция предназначена для корректировки размера Входящей чистой позиции для фьючерсных и опционных контрактов. Окно открывается выбором пункта «Установить позицию» контекстного меню таблицы Позиции по клиентским счетам и содержит следующие параметры:

  1. «Фирма» - идентификатор фирмы-дилера в торговой системе.
  2. «Инструмент» - идентификатор инструмента в торговой системе.
  3. «Торговый счет» - код торгового счета клиента (с учетом регистра).
  4. «Вход. чист. поз.» - корректируемое значение Входящей чистой позиции (общего количества контрактов в открытых позициях на начало торгов).
В общем случае требуется скорректировать только значение Входящей чистой позиции, оставляя неизменными остальные поля в данном окне.


Операции в Режиме переговорных сделок

  • Адресные и безадресные заявки
  • Заключение сделок в РПС

    • Режим переговорных сделок (РПС) – режим сделок без предварительного депонирования средств с отложенной датой исполнения, предусматривающий возможность заключения адресных и безадресных сделок.

    В Режиме переговорных сделок предоставляется возможность заключения сделок с отложенной датой исполнения, определяемой выражением: «Т + n», где «Т» - дата заключения сделки, «n» - количество торговых дней в Торговой системе, через которое должна быть исполнена сделка. Значение «n» принимает от 0 до 30. Для обозначения даты исполнения в Торговой системе используются коды расчетов «Т0», «В0»…«В31».

    На основе кода расчётов определяется дата исполнения сделки:

    Код расчётов

             Т0 В0 В01 В02 … B31

    Дата исполнения сделки

             Т Т Т+1 Т+2 Т+31

    Адресные и безадресные заявки

    Заявки на торги по условиям своего выполнения могут быть адресными и безадресными:

    • Адресная заявка выражает намерение заключить сделку с определенным партнёром;
    • Безадресная заявка выражает согласие заключить сделку, адресованное всем участникам торгов.

    Безадресная заявка является приглашением делать встречные предложения путём подачи адресной заявки. В соответствии с правилами торгов, первая адресная заявка, посланная в качестве ответа на вашу безадресную заявку с совпадающими условиями, должна быть принята вами. При вводе в торговую систему такой адресной заявки, безадресная заявка, инициировавшая её подачу, покидает таблицу «Котировки для РПС» и Таблицу безадресных внебиржевых заявок.

    Адресная заявка, отправленная в ответ на безадресную заявку, в соответствии с правилами торгов должна быть удовлетворена партнёром на предложенных им условиях, оговоренных в безадресной заявке.

    Неисполненная адресная заявка, находящаяся в торговой системе, является активной заявкой. Участник может снять активную заявку или изменить некоторые её условия. Заключение сделки на основе активной адресной заявки требует дополнительного согласия (принятия) получившего её участника торгов. В случае её принятия партнером, в торговой системе регистрируется сделка.

    Заключение сделок в РПС

    Работа в Режиме переговорных сделок предусматривает три этапа:

    Обмен заявками между участниками торгов.

    Производится ввод заявок в торговую систему.

    Используемые таблицы:

    • « Таблица текущих торгов» – совокупная информация о безадресных заявках и исполненных сделках;
    • «Таблица обезличенных сделок» – информация об исполненных сделках без указания контрагентов;
    • «Таблица безадресных заявок на внебиржевые сделки» – информация о состоянии собственных безадресных заявок, поданных в торговую систему;
    • «Таблица заявок на внебиржевые сделки» – информация о состоянии адресных заявок, одной из сторон в которых указан данный Участник торгов (отправленные и полученные);
    • «РПС котировки» – отображение очереди безадресных заявок по выбранному инструменту;
    • «Таблица участников торгов» – список контрагентов по адресным сделкам.

    Согласование условий сделок и их заключение.

    Согласование условий осуществляется путем переговоров и вводом заявок на утвержденных условиях. Заключение сделки осуществляется вводом встречной заявки на условиях, аналогичных заявке контрагента. Информация обо всех совершенных на рынке сделках без указания их контрагентов помещается в Таблицу обезличенных сделок.

    Используемые таблицы те же.

    Исполнение заключенных сделок.

    При наступлении дня исполнения сделки в Таблице сделок для исполнения появляется строка с параметрами собственной заявки, относящейся к сделке. Каждый из контрагентов подтверждает сделку вводом заявки-отчета на исполнение сделки РПС. Сделка считается исполненной после ее подтверждения обоими контрагентами.

    Используемые таблицы:

    • «Таблица сделок для исполнения» – информация о состоянии подтверждения заключенных сделок с наступившим сроком исполнения;
    • «Таблица заявок-отчетов на сделки РПС» – информация об отправленных/принятых отчетах на исполнение сделок.

    Расчёты по сделкам, заключённым на основе заявок с кодом расчётов «Т0» проводятся автоматически при достаточности позиций в момент заключения сделок. Эти сделки не попадают в Таблицу сделок для исполнения, и отчеты в Таблице заявок-отчетов на сделки РПС по таким сделкам не формируются.

    Сделки, заключённые на основе заявок с кодом расчётов «Z0», включаются в режиме расчетов по правилам простого клиринга.

    При совершении сделок в РПС средства на счете участника торгов блокируются при подтверждении им сделок в день исполнения. Списание/зачисление средств осуществляется торговой системой биржи при подтверждении сделки обоими контрагентами.

    Если в файле info.ini в секции [transactions] значение настройки «set-for-negdeals-same-operation-as-for-negtrades» равно «1» или данная настройка отсутствует, то при подаче адресной заявки по сделке для исполнения, указывается та же операция, что и в исходной сделке для исполнения. Если значение настройки «set-for-negdeals-same-operation-as-for-negtrades» равно «0», то указывается операция, противоположная операции исходной сделки для исполнения.

    См. также:

    • Адресные заявки
    • Безадресные заявки
    • Расчетные заявки-отчеты об исполнении сделок РПС
    • Заявки исполнения без подтверждения


Операции РЕПО

  • Адресные и безадресные заявки
  • Заключение сделок в РЕПО
  • Режим модифицированного РЕПО (РЕПО-М)
  • Сделки РЕПО с Центральным Контрагентом

    • Сделка РЕПО, сделка с обратным выкупом – сделка с ценными бумагами, состоящая из двух частей:

    1. По первой части сделки РЕПО в дату ее заключения продавец ценных бумаг обязан поставить ценные бумаги, а покупатель обязан заплатить денежные средства.
    2. В дату исполнения второй части сделки РЕПО покупатель ценных бумаг по первой части сделки РЕПО обязан поставить ценные бумаги, а продавец по первой части сделки РЕПО обязан заплатить денежные средства в соответствии с условиями заключенной сделки РЕПО.

    Фактически, сделка РЕПО представляет собой краткосрочный кредит ценными бумагами, под оговоренный в условиях сделки процент («ставку РЕПО»).

    Для операций РЕПО используются коды расчетов – «R01» … «R90», обозначающие срок исполнения второй части РЕПО. Срок исполнения второй части РЕПО для облигаций не может быть указан позднее даты погашения.

    Сделки, заключённые на основе заявок с кодом расчётов "Z0", включаются в режим расчетов по правилам простого клиринга.

    Адресные и безадресные заявки РЕПО

    Безадресная заявка РЕПО выражает согласие заключить сделку РЕПО на указанных в заявке условиях, направленное всем участникам торгов.

    Адресная заявка РЕПО выражает намерение заключить сделку РЕПО с определенным партнером на указанных в заявке условиях.

    Заключение сделки РЕПО происходит на основе двух встречных адресных заявок с совпадающими условиями.

    В отличие от РПС в режиме торгов РЕПО при получении участником торгов встречной адресной заявки с совпадающими условиями к своей безадресной, последняя в торговой системе автоматически не снимается.

    Заключение сделок РЕПО

    Операции РЕПО предусматривают три этапа:

    Обмен заявками между участниками торгов.

    Производится ввод заявок в торговую систему. При получении заявки сервер QUIK блокирует средства пользователя в размере, требуемом для ее исполнения.

    Используемые таблицы:

    • « Таблица текущих торгов» – совокупная информация о безадресных заявках и исполненных сделках;
    • «Таблица обезличенных сделок» – информация об исполненных сделках без указания контрагентов;
    • «Таблица безадресных заявок на внебиржевые сделки» – информация о состоянии собственных безадресных заявок, поданных в торговую систему;
    • «Таблица заявок на внебиржевые сделки» – информация о состоянии адресных заявок, одной из сторон в которых указан данный Участник торгов (отправленные и полученные);
    • «РПС котировки» – отображение очереди безадресных заявок по выбранному инструменту (для котировок РЕПО таблица имеет представление, отличное от котировок РПС);
    • «Коды расчетов» – информация по накопленному купонному доходу и ставкам РЕПО на даты, соответствующие кодам расчетов;
    • «Таблица участников торгов» – список контрагентов по адресным сделкам.

    Заключение сделок

    Заключение сделки осуществляется вводом встречной адресной заявки на условиях, аналогичных адресной заявке контрагента. Расчеты по сделке осуществляются торговой системой биржи непосредственно при исполнении сделки. Информация обо всех совершенных на рынке сделках без указания их контрагентов помещается в Таблицу обезличенных сделок.

    Используемые таблицы те же.

    Исполнение второй части РЕПО

    Начиная с дня, следующего за днем заключения сделки, в Таблице сделок для исполнения появляется заявка с ценой второй части РЕПО, рассчитанной на текущий день. Исполнение второй части РЕПО осуществляется вводом заявки-отчета на исполнение сделки РПС обеими сторонами сделки. Сделки, порождаемые исполнением второй части РЕПО, отражаются также в Таблице обезличенных сделок, без указания сторон сделки.

    1. Если на счете участника торгов недостаточно средств, ввод заявки-отчета невозможен.
    2. Контрагент по сделке РЕПО вправе отказаться от досрочного исполнения второй части РЕПО.

    Используемые таблицы:

    • «Таблица сделок для исполнения» – информация о сделках на исполнение второй части РЕПО;
    • «Таблица заявок-отчетов на сделки РПС» – информация об отправленных/принятых отчетах на исполнение второй части РЕПО.

    Режим модифицированного РЕПО

    Система QUIK поддерживает возможность совершения сделок в режиме модифицированного РЕПО (далее – РЕПО-М). Режим модифицированного РЕПО запущен на Московской Бирже и имеет ряд особенностей по сравнению с традиционным РЕПО.

    Основные возможности РЕПО-М:

    1. Использование дисконта к рыночной цене предыдущего торгового дня при заключении сделок РЕПО (изменение механизма заключения сделки РЕПО).
    2. Использование компенсационных взносов (как опциональная возможность) в качестве стандартного биржевого механизма контроля рыночных рисков и снижения рисков неисполнения обязательств.
    3. Заключение сделок без контроля обеспечения по первой части РЕПО (код расчетов S0), а так же сделок с исполнением обязательств по первой части РЕПО в отложенный срок – 1-ый или 2-ой день после даты заключения сделки (коды расчетов S1, S2).
    4. Заключение сделок РЕПО с возможностью исполнения обязательств по ее второй части на срок до 180 календарных дней.

    В режиме модифицированного РЕПО с акциями в 1 лоте содержится 1 акция по всем ценным бумагам. Это приводит к тому, что становится невозможным ведение учета клиентских позиций на этих режимах в лотах. Например, РусГидро в режиме основных торгов имеет размер лота, равный 100 бумаг, а в режиме «РЕПО-М: Акции» один лот РусГидро равен одной бумаге. Если позиция клиента по бумаге задана в лотах, то при подаче заявки на продажу одной бумаги в режиме «РЕПО-М: Акции» сервер QUIK не имеет возможности корректно отразить эту операцию. Выходом из данной ситуации является перевод системы на учет позиций в штуках.
    За более подробной информацией по настройке рекомендуем обратиться в Службу технической поддержки QUIK – quiksupport@arqatech.com.

    Сделки РЕПО с Центральным Контрагентом

    Система QUIK поддерживает возможность совершения сделок РЕПО с Центральным Контрагентом на Московской Бирже (далее – РЕПО с ЦК).

    РЕПО с ЦК – это вид биржевого РЕПО, при котором контрагентом участника является Центральный Контрагент (ЗАО АКБ «Национальный Клиринговый Центр»). Центральный Контрагент (ЦК) исполняет обязательства перед участниками, независимо от исполнения обязательств перед ЦК. То есть, если два участника заключили между собой сделку РЕПО с ЦК, и один из них не выполнил обязательства перед ЦК, то ЦК перед вторым участником исполнит обязательства в полном объеме в любом случае.

    См. также:

    • Адресные заявки
    • Безадресные заявки
    • Расчетные заявки-отчеты на исполнение вторых частей сделок РЕПО
    • Заявки исполнения без подтверждения


Ввод заявки

Окно ввода заявки может быть вызвано одним из следующих способов:

  • Нажатием кнопки [image] на панели инструментов;
  • Двойным нажатием левой кнопки мыши;
  • Нажатием клавиши «F2»;
  • Выбором в таблице пункта контекстного меню «Новая заявка»;
  • Выбором пункта меню Действия/Новая заявка;
  • Использованием Общего способа выполнения транзакций с выбором операции «Ввод заявки»;
  • Из окна «Графики». Подробнее см. Ввод заявки из окна «Графики».

Ввод заявки возможен в таблицах: Таблица котировок (очередь заявок), Объединенные котировки, Таблица заявок, Таблица сделок, Таблица обезличенных сделок, Таблица текущих торгов, Карман транзакций.

Описание полей окна ввода заявки приведены в «Торговые операции клиента». Дополнительно отображается параметр:

  1. «Заявка маркет-мейкера» – признак подачи заявки маркет-мейкером.

    Признак отображается, если настройка enable-market-maker-fields секции [transactions] файла info.ini равна «1».
    Возможна настройка установки признака по умолчанию в файле default_client_codes.ini, имя и путь к которому необходимо указать в файле настроек info.ini в секции [General] в параметре default-clients-file. Пример файла info.ini:

    [general]
… …
default-clients-file=D:\Program Files\QUIK\default_client_codes.ini
… …
    В отдельных секциях для каждого класса указываются следующие ключи:
    • market-maker-orders – признак установки по умолчанию флажка «Заявка маркет-мейкера» для класса инструментов («0» – не установлен, «1» – установлен);
    • market-maker-orders-<Код инструмента> – признак установки по умолчанию флажка «Заявка маркет-мейкера» для определенного инструмента данного класса («0» – не установлен, «1» – установлен).

    Пример:

    [EQRP]
market-maker-orders=0
market-maker-orders-VTBR=1

    1. Если установлен признак «Динамический» в меню Система/Настройки/Основные настройки..., раздел «Торговля» / «Заявки» / «Формы ввода», то настройки market-maker-orders и market-maker-orders-<Код инструмента> в файле default_client_codes.ini игнорируются, и значение признака «Заявка маркет-мейкера» по умолчанию определяется настройками шлюза торговой системы.
    2. Если настройки market-maker-orders и market-maker-orders-<Код инструмента> в файле default_client_codes.ini не заданы, то значение признака «Заявка маркет-мейкера» по умолчанию определяется настройками шлюза торговой системы. Если перечисленные настройки не заданы, и окно ввода заявки открывается из Таблицы заявок, то значение признака «Заявка маркет-мейкера» берется из выделенной заявки.


Торговые операции в РПС, РЕПО, РЕПО-М, РЕПО с ЦК и РЕПО ЦБ с корзиной

Окно ввода новой адресной заявки может быть вызвано одним из следующих способов:

  1. Общим способом выполнения транзакций - нажатием кнопки [image] на панели инструментов, выбором соответствующего класса (например «РПС Акции 1-го уровня») и операции «Ввод адресной заявки». Эта же операция может быть выполнена горячей клавишей «Ctrl»+«T».
  2. В Таблице заявок на внебиржевые сделки (в таблице должна присутствовать хотя бы одна заявка):
    • Нажатием кнопки [image] на панели инструментов;
    • Выбором пункта контекстного меню «Новая заявка на внебиржевую сделку» или пункта меню программы Действия/Новая заявка на внебиржевую сделку;
    • Двойным щелчком левой кнопки мыши на строке с заявкой;
    • Нажатием клавиши «F2».
  3. В таблице «РПС котировки» по выбранному инструменту:
    • Нажатием кнопки [image] на панели инструментов;
    • Выбором пункта контекстного меню «Новая заявка» или пункта меню программы Действия/Новая заявка;
    • Двойным щелчком левой кнопки мыши на строке с котировкой;
    • Нажатием клавиши «F2».

В открывшемся окне ввода новой адресной заявки заполните необходимые поля и нажмите на кнопку «Ввести». После нажатия на кнопку «Ввести» окно ввода адресной заявки закрывается только при успешном выставлении адресной заявки. В случае получения сообщения об ошибке окно ввода адресной заявки остается открытым с возможностью изменения неверно введенных значений.

См. также:

  • Торговые операции в РЕПО
  • Ввод адресной заявки РЕПО
  • Ввод адресной заявки РЕПО-М
  • Ввод адресной заявки РЕПО с ЦК
  • Настройки программы, относящиеся к адресным заявкам
  • Ввод адресной заявки РЕПО Банка России с корзиной ценных бумаг
  • Отмена адресной заявки


Ввод адресной заявки в режиме РПС

  1. «Инструмент»* – выберите название инструмента из списка инструментов данного класса.
  2. «Торговый счет»* – выберите из списка номер торгового счета, в отношении которого делается поручение.
  3. «Операция»* – направление операции: «Покупка» или «Продажа».
  4. «Код расчетов» – укажите вручную либо выберите из списка код расчетов по сделке (значения: «T0», «B0», «B01», «B30», «Z0»; для валютного рынка: «T0», «T1», «F1W», «F2W», «F1M», «F2M», «F3M», «F6M», «F1D-F180D»). Если поле не заполнено, принимается значение по умолчанию: «T0».
  5. «Дата расчетов» – дата расчетов по сделке для указанного инструмента и кода расчетов (информационное поле).
  6. «Цена»* - цена заявки, за единицу финансового инструмента.
  7. «Количество»* - количество инструментов, выраженное в лотах. При редактировании поля с помощью стрелок вверх/вниз или колесика мыши значение увеличивается или уменьшается на величину значения параметра «Кратность лота» и округляется до значения, кратного параметру «Кратность лота». Для изменения количества лотов на величину, в 10 раз превышающую кратность лота, используйте стрелки вверх/вниз с нажатой клавишей Ctrl.
  8. «Лот» – количество инструментов в одном лоте (для информации).
  9. «Партнер»* – выберите из списка либо укажите вручную краткое наименование контрагента по сделке.
  10. «Код Клиента» - идентификатор клиента в системе QUIK.
  11. «Комментарий» – текстовый комментарий к заявке.
  12. «Возмещение» – ставка возмещения за просрочку исполнения обязательств по сделке РПС, выраженная в процентах.
  13. «Ссылка» – текстовая строка, служащая для сопоставления встречных заявок в сделке. Если один из контрагентов указал что-либо в этом поле, то другой контрагент обязан ввести то же самое.
  14. «Валюта расчетов» - код валюты расчетов по сделке, порожденной данной заявкой. Поле редактируемое, доступно только для шлюза «Брокерские котировки».

Звездочкой (*) отмечены обязательные поля.
Поля «Количество», «Код клиента», «Ссылка», «Комментарий» могут быть заполнены автоматически. Подробнее см. Настройка автозаполнения полей ввода заявки.

Нажатием кнопки «Ввести» заявка отправляется в торговую систему. Нажатие кнопки «Отмена» закрывает окно без отправления заявки.

Заявка, принятая торговой системой, отображается в Таблице заявок на внебиржевые сделки.

См. также:

  • Операции в Режиме переговорных сделок ММВБ
  • Адресные заявки
  • Настройки программы, относящиеся к адресным заявкам


Специализированное окно ввода адресной заявки по облигациям

При использовании интерфейсов, транслирующих расширенную информацию по облигациям, и включенном режиме ввода «Специализированный» форма ввода заявки имеет следующий вид:

Данная форма ввода заявки имеет следующие дополнительные поля:

  1. «Доходность» – доходность инструмента, соответствующая указанному значению цены. В данном поле может быть введено целевое значение доходности. При этом для расчета соответствующего значения цены нажмите на кнопку «Задать цену».
  2. «Max» – максимальное возможное количество лотов в стоп-заявке, рассчитанное из величины доступных средств клиента с учетом всех комиссий. Нажатием на кнопку указанное максимальное значение отображается в поле «Лотов». Поле отображается при включенном в настройках флажке «Рассчитывать доступное количество».
  3. «Объем» – значение объема заявки с учетом НКД, соответствующее указанному значению количества. В данном поле может быть введено целевое значение объема. При этом для расчета соответствующего значения количества нажмите на кнопку «Задать кол-во». В результате в поле «Лотов» отображается рассчитанное число, округленное вниз до ближайшего целого.

    Ниже отображается значение НКД на дату торгов и комиссии в валюте инструмента. Значение НКД отображается с учётом количества лотов в заявке.


Специализированное окно ввода адресной заявки по акциям

При использовании интерфейсов, транслирующих расширенную информацию по акциям, и включенном режиме ввода «Специализированный» форма ввода заявки имеет следующий вид:

Данная форма ввода заявки имеет следующие дополнительные поля:

  1. «Max» – максимальное возможное количество лотов в заявке, рассчитанное из величины доступных средств клиента с учетом всех комиссий. Нажатием на кнопку указанное максимальное значение отображается в поле «Лотов». Поле отображается при включенном в настройках флажке «Рассчитывать доступное количество» (см. Раздел 5 Торговые операции).
  2. «Объем» – значение объема заявки, соответствующее указанному значению количества. В данном поле может быть введено целевое значение объема. При этом для расчета соответствующего значения количества нажмите на кнопку «Задать кол-во». В результате в поле «Лотов» отображается рассчитанное число, округленное вниз до ближайшего целого.

    Ниже отображается значение комиссии в валюте инструмента.


Ввод адресной заявки РЕПО

  1. «Инструмент»* – выберите название инструмента из списка инструментов данного класса.
  2. «Торговый счет»* – выберите из списка номер торгового счета, в отношении которого делается поручение (регистр символов имеет значение).
  3. «Операция»* – направление операции: «Покупка» или «Продажа».
  4. «Код расчетов» – укажите вручную либо выберите из списка код расчетов по первой части сделки РЕПО. Возможные значения:
    • «T0» или «Rb» - расчеты «сейчас»;
    • «S0» - расчеты сегодня;
    • «S01» - расчеты осуществляются в следующий торговый день;
    • «S02» - расчеты осуществляются через один торговый день;
    • «Z0» - расчеты осуществляются по правилам простого клиринга Московской Биржи.

    Если поле не заполнено, принимается значение по умолчанию: «T0».

    Для валютного рынка используются значения: «T0», «T1», «F1W», «F2W», «F1M», «F2M», «F3M», «F6M», «F1D-F180D».
  5. «Дата расчетов» – дата расчетов по сделке для указанного инструмента и кода расчетов (информационное поле).
  6. «Цена» – цена заявки, за единицу финансового инструмента.
  7. «Количество»* – количество инструментов, выраженное в лотах. При редактировании поля с помощью стрелок вверх/вниз или колесика мыши значение увеличивается или уменьшается на величину значения параметра «Кратность лота» и округляется до значения, кратного параметру «Кратность лота». Для изменения количества лотов на величину, в 10 раз превышающую кратность лота, используйте стрелки вверх/вниз с нажатой клавишей Ctrl.
  8. «Лот» – количество инструментов в одном лоте. Информационное поле.
  9. «Партнер»* – выберите из списка либо укажите вручную краткое наименование контрагента по сделке.
  10. «Код Клиента» – идентификатор клиента в системе QUIK.
  11. «Комментарий» – текстовый комментарий к заявке.
  12. «Ссылка» – текстовая строка, служащая для сопоставления встречных заявок в сделке. Если один из контрагентов заполнил это поле, то другой контрагент обязан ввести то же значение.
  13. «Возмещение» – ставка возмещения в случае просрочки исполнения обязательств по сделке РЕПО, выраженная в процентах. Во встречных заявках значение должно совпадать. Обязательный параметр операций РЕПО.
  14. «Цена выкупа» – цена второй части РЕПО. Параметр ввода заявки РЕПО.
  15. «Ставка РЕПО» – процентная ставка платы за пользование ресурсами, в % годовых, если не выбрана индикативная ставка в поле «Индикатор». Иначе – спред к выбранному индикатору, в % годовых.
Звездочкой(*) отмечены обязательные поля.
Поля «Количество», «Код клиента», «Ссылка», «Комментарий» могут быть заполнены автоматически. Подробнее см. «Настройка автозаполнения полей ввода заявки».

Нажатием кнопки «Ввести» заявка отправляется в торговую систему. Нажатие кнопки «Отмена» закрывает окно без отправления заявки.

Заявка, принятая торговой системой, отображается в Таблице заявок на внебиржевые сделки.

См. также:

  • Ввод адресной заявки РЕПО-М
  • Ввод адресной заявки РЕПО с ЦК
  • Торговые операции в РЕПО
  • Адресные заявки
  • Настройки программы, относящиеся к адресным заявкам
  • Ввод адресной заявки РЕПО Банка России с корзиной ценных бумаг


Ввод адресной заявки РЕПО-М

  1. «Инструмент»* – выберите название инструмента из списка инструментов данного класса.
  2. «Торговый счет»* – выберите из списка номер торгового счета, в отношении которого делается поручение (регистр символов имеет значение).
  3. «Операция»* – направление операции: «Покупка» или «Продажа».
  4. «Код расчетов» – укажите вручную либо выберите из списка код расчетов по первой части сделки РЕПО-М. Возможные значения:
    • «T0» или «Rb» - расчеты «сейчас»;
    • «S0» - расчеты сегодня;
    • «S01» - расчеты осуществляются в следующий торговый день;
    • «S02» - расчеты осуществляются через один торговый день;
    • «Z0» - расчеты осуществляются по правилам простого клиринга Московской Биржи.

    Если поле не заполнено, принимается значение по умолчанию: «T0».

    Для валютного рынка используются значения: «T0», «T1», «F1W», «F2W», «F1M», «F2M», «F3M», «F6M», «F1D-F180D».
  5. «Дата расчетов» – дата расчетов по сделке для указанного инструмента и кода расчетов (информационное поле).
  6. «Блокировать инструменты на время операции РЕПО» - признак блокировки инструментов. Выставленный флажок означает, что инструменты, приобретенные по первой части РЕПО-М, блокируются в депозитарии до выполнения всех обязательств по сделке.
  7. «Сумма РЕПО»* – объем сделки РЕПО-М в денежном выражении.
  8. «Количество»* – количество инструментов, выраженное в лотах. При редактировании поля с помощью стрелок вверх/вниз или колесика мыши значение увеличивается или уменьшается на величину значения параметра «Кратность лота» и округляется до значения, кратного параметру «Кратность лота». Для изменения количества лотов на величину, в 10 раз превышающую кратность лота, используйте стрелки вверх/вниз с нажатой клавишей Ctrl.
  9. «Лот» – количество инструментов в одном лоте. Информационное поле.
  10. «Дисконт (%) начальный, нижний, верхний» – условие сделки РЕПО-М, которое может устанавливаться сторонами сделки РЕПО-М при ее заключении:
    • Начальное значение дисконта (Начальный дисконт) – условие сделки, указывается в заявке на заключение сделки в явном виде или однозначно определяется из условий заявки;
    • Нижнее предельное значение дисконта – условие сделки, выражается в процентах. Если Дисконт становится меньше Нижнего предельного значения дисконта, у Первоначального продавца возникает обязательство по внесению Компенсационного взноса в денежной форме;
    • Верхнее предельное значение дисконта – условие сделки, выражается в процентах. При превышении Дисконтом величины Верхнего предельного значения дисконта у Первоначального покупателя возникает обязательство по внесению Компенсационного взноса Облигациями.
  11. «Ставка РЕПО» – процентная ставка платы за пользование ресурсами, в % годовых, если не выбрана индикативная ставка в поле «Индикатор». Иначе – спред к выбранному индикатору, в % годовых.
  12. «Срок РЕПО (0-180)» – промежуток времени, выраженный в календарных днях, между датами исполнения первой и второй частей сделки РЕПО-М. Срок исчисляется со дня, следующего за днем исполнения первой части сделки, до дня исполнения второй части сделки включительно.
  13. «С открытой датой» – выставленный флажок означает, что часть сделки в течение максимального срока такой сделки становится срочной к исполнению на следующий торговый день. При включении флажка поле «Срок РЕПО» не заполняется. Флажок неактивен, если в транзакции нет поля для указания признака открытой даты. По умолчанию флажок выключен.
  14. «Возмещение» – ставка возмещения в случае просрочки исполнения обязательств по сделке РЕПО-M, выраженная в процентах. Во встречных заявках значение должно совпадать.
  15. «Индикатор» – идентификатор индикативной ставки. Выбор значения индикатора предполагает заключение сделки с плавающей ставкой. Поле необязательно для заполнения.
  16. «Партнер»* – выберите из списка либо укажите вручную краткое наименование контрагента по сделке.
  17. «Код Клиента» - идентификатор клиента в системе QUIK.
  18. «Комментарий» – текстовый комментарий к заявке.
  19. «Ссылка» – текстовая строка, служащая для сопоставления встречных заявок в сделке. Если один из контрагентов заполнил это поле, то другой контрагент обязан ввести то же значение.

Звездочкой (*) отмечены обязательные поля.
Поля «Количество», «Код клиента», «Ссылка», «Комментарий» могут быть заполнены автоматически. Подробнее см. п. «Настройка автозаполнения полей ввода заявки».

Нажатием кнопки «Ввести» заявка отправляется в торговую систему. Нажатие кнопки «Отмена» закрывает окно без отправления заявки.

Заявка, принятая торговой системой, отображается в Таблице заявок на внебиржевые сделки.

См. также:

  • Ввод адресной заявки РЕПО
  • Ввод адресной заявки РЕПО с ЦК
  • Торговые операции в РЕПО
  • Адресные заявки
  • Настройки программы, относящиеся к адресным заявкам
  • Ввод адресной заявки РЕПО Банка России с корзиной ценных бумаг


Специализированное окно ввода адресной РЕПО-М заявки по облигациям

При использовании интерфейсов, транслирующих расширенную информацию по облигациям, и включенном режиме ввода «Специализированный» форма ввода РЕПО-М заявки имеет следующий вид:

Данная форма ввода заявки имеет дополнительные поля о расчете и параметрах первой и второй части сделки РЕПО и предварительный расчёт параметров сделки. Данные параметры пересчитываются при изменении любого из параметров «Сумма РЕПО», «Лотов» и «Начальный дисконт».

Расчет значения поля «Цена с учетом дисконта» производится по формуле:

где:

  • P1 - цена за одну единицу инструмента по первой части сделки РЕПО в процентах от номинала;
  • S - сумма РЕПО;
  • Q - количество инструмента;
  • Nom - номинальная стоимость облигации;
  • At - НКД по одной единице инструмента на дату исполнения первой части сделки РЕПО;
  • FXRate - кросс-курс валюты, в которой выражены значения номинала и НКД инструмента к валюте сделки РЕПО.


Специализированное окно ввода адресной РЕПО-М заявки по акциям

При использовании интерфейсов, транслирующих расширенную информацию по акциям, включенном режиме ввода «Специализированный» и наличии у бумаги параметра «Базис РЕПО» форма ввода РЕПО-М заявки имеет следующий вид:

Данная форма ввода заявки имеет дополнительные поля о расчете и параметрах первой и второй части сделки РЕПО и предварительный расчёт параметров сделки. Данные параметры пересчитываются при изменении любого из параметров «Сумма РЕПО», «Лотов» и «Начальный дисконт».


Ввод адресной заявки РЕПО с ЦК

  1. «Инструмент»* – выберите название инструмента из списка инструментов данного класса.
  2. «Торговый счет»* – выберите из списка номер торгового счета, в отношении которого делается поручение.
  3. «Операция»* – направление операции: «Покупка» или «Продажа».
  4. «Код расчетов» – укажите вручную либо выберите из списка код расчетов по первой части РЕПО сделки. Возможные значения:
    • «T0» – расчеты «сейчас»;
    • «Y0» – расчеты осуществляются в текущий торговый день. Первая часть сделки заключается с частичным обеспечением;
    • «Y1» – расчеты осуществляются в следующий за датой заключения сделки торговый день;
    • «Y2» ... «Y7» – расчеты осуществляются на второй (и т.д. до седьмого) торговый день после даты заключения сделки.
  5. «Дата расчетов» – дата расчетов по сделке для указанного инструмента и кода расчетов (информационное поле).
  6. «Дисконт» ** – размер дисконта, в %.
  7. «Сумма РЕПО» ** - объем сделки в денежном выражении.
  8. «Кол-во (лот …)» ** – количество инструментов, выраженное в лотах. В скобках указано количество единиц выбранного инструмента в одном лоте.
    (**) Обязательно должны быть заполнены два поля из следующих полей: «Дисконт», «Сумма РЕПО», «Кол-во (лот …)».
  9. «Ставка РЕПО» – процентная ставка платы за пользование ресурсами, в % годовых, если не выбрана индикативная ставка в поле «Индикатор». Иначе – спред к выбранному индикатору, в % годовых.
  10. «Срок РЕПО (0-180)» – срок исполнения второй части РЕПО. Cрок указывается с учетом выходных и праздничных дней.
  11. «С открытой датой» – выставленный флажок означает, что часть сделки в течение максимального срока такой сделки становится срочной к исполнению на следующий торговый день. При включении флажка поле «Срок РЕПО» не заполняется. Флажок неактивен, если в транзакции нет поля для указания признака открытой даты. По умолчанию флажок выключен.
  12. «Ссылка» – текстовая строка, служащая для сопоставления встречных заявок в сделке. Если один из контрагентов указал что-либо в этом поле, то другой контрагент обязан ввести то же самое.
  13. «Индикатор» – идентификатор индикативной ставки. Выбор значения индикатора предполагает заключение сделки с плавающей ставкой. Поле необязательно для заполнения.
  14. «Партнер»* – выберите из списка либо укажите вручную краткое наименование партнера по сделке.
  15. «Код Клиента» - идентификатор клиента в системе QUIK.
  16. «Комментарий» – текстовый комментарий к заявке.

Звездочкой (*) отмечены обязательные поля.
Поля «Кол-во (лот ...)», «Код клиента», «Ссылка», «Комментарий» могут быть заполнены автоматически. Подробнее см. п. «Настройка автозаполнения полей ввода заявки».

Нажатием кнопки «Ввести» заявка отправляется в торговую систему. Нажатие кнопки «Отмена» закрывает окно без отправления заявки.

Заявка, принятая торговой системой, отображается в Таблице заявок на внебиржевые сделки.

См. также:

  • Ввод адресной заявки РЕПО
  • Торговые операции РЕПО
  • Адресные заявки
  • Ввод адресной заявки РЕПО-М
  • Настройки программы, относящиеся к адресным заявкам
  • Ввод адресной заявки РЕПО Банка России с корзиной ценных бумаг


Ввод айсберг заявки в режиме РЕПО с ЦК

  1. «Инструмент» – выберите название инструмента из списка инструментов данного класса.
  2. «Торговый счет» – выберите из списка номер торгового счета, в отношении которого делается поручение.
  3. «Операция» – направление операции: «Покупка» или «Продажа».
  4. «Кол-во Лот»– количество инструментов, выраженное в лотах. Справа указано количество единиц выбранного инструмента в одном лоте При редактировании поля с помощью стрелок вверх/вниз или колесика мыши значение увеличивается или уменьшается на величину значения параметра «Кратность лота» и округляется до значения, кратного параметру «Кратность лота». Для изменения количества лотов на величину, в 10 раз превышающую кратность лота, используйте стрелки вверх/вниз с нажатой клавишей Ctrl.
  5. «Сумма РЕПО» – объем сделки в денежном выражении.
  6. «Код Клиента» – идентификатор клиента в системе QUIK.
  7. «Комментарий» – текстовый комментарий к заявке.
  8. «Цена» – цена заявки за одну единицу инструмента. При включении признака «Рыночная» значение поля «Цена» устанавливается равным «0» и недоступно для редактирования. При отключении признака «Рыночная» в поле подставляется значение цены, указанное до включения признака «Рыночная». При выборе в рамке «Ввод цены» значения «По средневзвешенной цене» поле «Цена» становится неактивным (серым).
  9. «Рыночная» – признак заявки без указания цены исполнения. Такая заявка исполняется на бирже по ценам имеющихся встречных заявок, начиная с лучшей из них. Неисполненный остаток снимается с торгов. При выборе в рамке «Ввод цены» значения «По средневзвешенной цене» признак «Рыночная» становится неактивным (серым).

Дополнительные параметры:

  10. «Ввод цены»:
    • Выбор значения в поле «Цена»:
      • «По цене» – исполнение заявки при наличии в торговой системе встречных заявок с аналогичной ценой исполнения;
      • «По доходности» – исполнение при наличии встречных заявок с аналогичной доходностью, рассчитанной по цене заявки (для облигаций);
      • «По средневзвешенной цене» – в качестве цены принимается средневзвешенная цена за текущую торговую сессию.
      При подаче безадресной заявки РЕПО с ЦК всегда выбирается вариант «По цене».
    • Выбор цены исполнения заявки:
      • «По одной цене» – заявка исполняется по одной цене;
      • «По разным ценам» – заявка может быть исполнена по разным ценам.
  11. «Условие исполнения» определяет порядок обработки остатка заявки при ее частичном исполнении:
    • «Немедленно или отклонить» – заявка исполняется только полностью, т.е. при наличии в торговой системе встречных заявок по цене, не хуже указанной и с количеством инструментов, превышающим объем заявки;
    • «Поставить в очередь» – неисполненный остаток ставится в очередь с ценой, указанной в заявке. Если заявка рыночная, и встречные заявки отсутствуют, то неисполненный остаток снимается с торгов;
    • «Снять остаток» – неисполненный остаток снимается с торгов.

    По умолчанию заявка имеет условие «Поставить в очередь».
  12. «Заявка маркет-мейкера» – признак подачи заявки маркет-мейкером.

Нажатием кнопки «Ввести» заявка отправляется в торговую систему. Нажатие кнопки «Отмена» закрывает окно без отправления заявки.

См. также:

  • Ввод адресной заявки РЕПО
  • Торговые операции РЕПО
  • Адресные заявки
  • Ввод адресной заявки РЕПО-М
  • Настройки программы, относящиеся к адресным заявкам
  • Ввод адресной заявки РЕПО Банка России с корзиной ценных бумаг


Ввод адресной заявки РЕПО Банка России с корзиной ценных бумаг

  1. «Инструмент»* – название инструмента. Доступное значение: «КорзинаЦБ».
  2. «Торговый счет»* – выберите из списка номер торгового счета, в отношении которого делается поручение.
  3. «Операция»* – направление операции. Значение: «Продажа», не редактируется.
  4. «Приоритетное обеспечение» – выберите из списка приоритетный инструмент, принимаемый в обеспечение.
  5. «Код расчетов» – укажите вручную либо выберите из списка код расчетов по первой части РЕПО сделки. Возможные значения:
    • «DVP1» – расчеты осуществляются сразу после получения реестра сделок. НРД подбирает обеспечение, и при отсутствии или недостаточности ценных бумаг, подлежащих передаче по первой части сделки РЕПО, расчеты и подбор бумаг осуществляется каждые 30 минут;
    • «DVP3» – расчеты осуществляются непосредственно перед каждым клиринговым сеансом.
  6. «Сумма РЕПО»* - объем сделки в денежном выражении.
  7. «Ставка РЕПО»* – процентная ставка платы за пользование ресурсами, в % годовых.
  8. «Срок РЕПО» – срок исполнения второй части РЕПО.
  9. «Партнер»* – выберите из списка либо укажите вручную краткое наименование партнера по сделке.
  10. «Код Клиента» - идентификатор клиента в системе QUIK.
  11. «Комментарий» – текстовый комментарий к заявке.
  12. «Ссылка» – текстовая строка, служащая для сопоставления встречных заявок в сделке. Если один из контрагентов указал что-либо в этом поле, то другой контрагент обязан ввести то же самое.

Звездочкой (*) отмечены обязательные поля.
Поля «Код клиента», «Ссылка», «Комментарий» могут быть заполнены автоматически. Подробнее см. п. «Настройка автозаполнения полей ввода заявки».

Нажатием кнопки «Ввести» заявка отправляется в торговую систему. Нажатие кнопки «Отмена» закрывает окно без отправления заявки.

Заявка, принятая торговой системой, отображается в Таблице заявок на внебиржевые сделки.

См. также:

  • Ввод адресной заявки РЕПО
  • Торговые операции РЕПО
  • Адресные заявки
  • Ввод адресной заявки РЕПО-М
  • Настройки программы, относящиеся к адресным заявкам
  • Ввод адресной заявки РЕПО с ЦК


Настройки программы, относящиеся к адресным заявкам

Настройки устанавливаются через пункт меню программы Система/Настройки/Основные настройки..., раздел «Торговля» / «Заявки» / «Внебиржевые заявки»:

  • «Подставлять текущую цену в заявку РЕПО» – если флажок установлен, то в поле «Цена» автоматически подставляется цена последней сделки на этот инструмент с соответствующего обычного класса.
  • «Проверять цены на min-max для РПС, РЕПО» - проверять соответствие цены заявки РЕПО или РПС диапазонам допустимых значений «Мин.цена» и «Макс.цена» из Таблицы текущих торгов, установленных на основном классе инструментов. Например, для класса «РПС А1-Акции» основным классом является класс «А1-Акции». Если при этом какая-либо из цен диапазона нулевая, то ограничение с данной стороны не проверяется.
Функция «Автозаполнение» позволяет при формировании новой адресной заявки задавать соответствия между параметрами «Код клиента/Комментарий» и «Класс/Инструмент / Операция». В результате, при выборе в форме ввода адресной заявки определенного инструмента и операции, в полях «Код клиента» и «Комментарий» подставляются определенные значения.

См. также:

  • Торговые операции РЕПО
  • Ввод адресной заявки РЕПО
  • Ввод адресной заявки РЕПО-М
  • Ввод адресной заявки РЕПО с ЦК
  • Ввод адресной заявки РЕПО Банка России с корзиной ценных бумаг


Отмена адресной заявки

Неисполненные отправленные адресные заявки со статусом «Активна» доступны для снятия. Полученные адресные заявки недоступны для отмены.

Снятие адресной заявки может быть осуществлено одним из следующих способов:

  1. В Таблице заявок на внебиржевые сделки (снимаемая заявка должна быть выбрана):
    • Выбором пункта контекстного меню «Снять заявку на внебиржевую сделку»;
    • Двойным щелчком правой кнопки мыши на строке с заявкой;
    • Нажатием кнопки [image] на панели инструментов;
    • Нажатием клавиш «Ctrl»+«D».
  2. Общим способом выполнения транзакций - нажатием кнопки [image] на панели инструментов, выбором соответствующего класса (например «РПС: А1-Акции») и операции «Отмена адресных заявок». Эта же операция может быть выполнена горячей клавишей «Ctrl»+«T». В открывшемся окне укажите номер снимаемой заявки и код пользователя (необязательно).

См. также:

  • Торговые операции в РЕПО
  • Ввод адресной заявки РЕПО
  • Ввод адресной заявки РЕПО-М
  • Настройки программы, относящиеся к адресным заявкам
  • Ввод адресной заявки РЕПО Банка России с корзиной ценных бумаг


Ввод безадресной заявки

Окно ввода новой безадресной заявки может быть вызвано одним из следующих способов:

  1. В Таблице безадресных заявок на внебиржевые сделки (в таблице должна присутствовать хотя бы одна заявка):
    • Выбором пункта контекстного меню «Новая безадресная внебиржевая заявка» или пункта меню программы Действия/Новая безадресная внебиржевая заявка;
    • Двойным щелчком левой кнопки мыши на строке с заявкой;
    • Нажатием кнопки [image] на панели инструментов;
    • Нажатием клавиши «F2».
  2. Общим способом выполнения транзакций - нажатием кнопки [image] на панели инструментов, выбором соответствующего класса (например «РПС Акции 1-го уровня») и операции «Ввод безадресной заявки». Эта же операция может быть выполнена горячей клавишей «Ctrl»+«T».


Ввод безадресной заявки для РПС и для сделок РЕПО

Форма ввода безадресной заявки для РПС (слева) и для сделок РЕПО (справа)

Заполнение полей окна ввода заявки:

  1. «Код торгового счета» – код торгового счета, в отношении которого подается заявка.
  2. «К/П» – направление операции: «Купля» либо «Продажа».
  3. «Инструмент» - выберите название инструмента из списка инструментов данного класса.
  4. «Цена» - цена заявки, за единицу финансового инструмента.
  5. «Количество» - количество инструментов, выраженное в лотах.
  6. «Код расчетов» - укажите вручную код расчетов по сделке.
  7. «Снять активные заявки» - если флажок установлен, то ранее введенная безадресная заявка по этому инструменту отменяется, а вводимая заявка будет единственной.
  8. «Примечание» – текстовый комментарий к заявке.
  9. «Ссылка» – текстовая строка, служащая для сопоставления встречных заявок в сделке. Если один из контрагентов указал что-либо в этом поле, то другой контрагент обязан ввести то же самое.
  10. «Цена выкупа» – цена второй части РЕПО. Параметр ввода заявки РЕПО.
  11. «Ставка РЕПО» – процентная ставка платы за пользование ресурсами, в % годовых. Параметр ввода заявки РЕПО.

Нажатием кнопки «Выполнить» заявка отправляется в торговую систему. Нажатие кнопки «Отмена» закрывает окно без отправления заявки.

Заявка, принятая торговой системой отображается в Таблице безадресных заявок на внебиржевые сделки и таблице «РПС котировки».Параметры лучших заявок по каждому инструменту отображаются в Таблице текущих торгов.

См. также:

  • Торговые операции в РЕПО
  • Безадресные заявки
  • Ввод безадресной заявки РЕПО с ЦК


Ввод безадресной заявки РЕПО с ЦК

Окно в зависимости от настроек может иметь компактную (слева) или полную (справа) форму. Вид окна переключается нажатием кнопки «>>». Формы оптимизированы для легкого и быстрого ввода параметров и компактного расположения на экране.

Заполнение формы заявки:

  1. «Инструмент» – выберите название инструмента из списка инструментов данного класса.
  2. «Торговый счет» – выберите из списка номер торгового счета, в отношении которого делается поручение (регистр символов имеет значение).
  3. Направление операции: «Покупка» или «Продажа».
  4. «Цена» – цена заявки за одну единицу инструмента. При включении признака «Рыночная» значение поля «Цена» устанавливается равным «0» и недоступно для редактирования. При отключении признака «Рыночная» в поле подставляется значение цены, указанное до включения признака «Рыночная». При выборе в рамке «Ввод цены» значения «По средневзвешенной цене» поле «Цена» становится неактивным (серым).
  5. «Рыночная» – признак заявки без указания цены исполнения. Такая заявка исполняется на бирже по ценам имеющихся встречных заявок, начиная с лучшей из них. Неисполненный остаток снимается с торгов.

    При выборе в рамке «Ввод цены» значения «По средневзвешенной цене» признак «Рыночная» становится неактивным (серым).
  6. «Кол-во» – количество инструментов, выраженное в лотах. Справа указано количество инструментов в одном лоте. Если заполнено поле «Сумма РЕПО», поле недоступно для редактирования и содержит значение предполагаемого количества.
  7. «Сумма РЕПО» – объем заявки РЕПО в денежном выражении. Если заполнено поле «Кол-во», поле недоступно для редактирования и содержит значение предполагаемого объема.
  8. «Код клиента» – идентификатор клиента в системе QUIK.
  9. «Комментарий» – текстовый комментарий к заявке.

    Дополнительные параметры:

  10. «Ввод цены»:
    • Выбор значения в поле «Цена»:
      • «По цене» – исполнение заявки при наличии в торговой системе встречных заявок с аналогичной ценой исполнения;
      • «По доходности» – исполнение при наличии встречных заявок с аналогичной доходностью, рассчитанной по цене заявки (для облигаций);
      • «По средневзвешенной цене» – в качестве цены принимается средневзвешенная цена за текущую торговую сессию.
      При подаче безадресной заявки РЕПО с ЦК всегда выбирается вариант «По цене».
    • Выбор цены исполнения заявки:
      • «По одной цене» – заявка исполняется по одной цене;
      • «По разным ценам» – заявка может быть исполнена по разным ценам.
  11. «Условие исполнения» определяет порядок обработки остатка заявки при ее частичном исполнении:
    • «Немедленно или отклонить» – заявка исполняется только полностью, т.е. при наличии в торговой системе встречных заявок по цене, не хуже указанной и с количеством инструментов, превышающим объем заявки;
    • «Поставить в очередь» – неисполненный остаток ставится в очередь с ценой, указанной в заявке. Если заявка рыночная, и встречные заявки отсутствуют, то неисполненный остаток снимается с торгов;
    • «Снять остаток» – неисполненный остаток снимается с торгов.

    По умолчанию заявка имеет условие «Поставить в очередь».

  12. «Заявка маркет-мейкера» – признак подачи заявки маркет-мейкером.

Нажатием кнопки «Да» заявка отправляется в торговую систему. Нажатие кнопки «Отмена» закрывает окно без отправления заявки.

  1. При заполнении формы заявки можно перемещаться между полями мышью, либо клавишей «Tab» в одну сторону, или «Shift»+«Tab» в обратную сторону.
  2. Стрелки «вверх» и «вниз» в полях «Цена» и «Количество» служат для изменения значений в этих полях при помощи мыши. Одно нажатие левой кнопкой мыши на стрелке меняет значение на одну минимальную величину шага, а при нажатой клавише «Ctrl» - на 10.
  3. Поля «Количество», «Код клиента», «Комментарий» могут быть заполнены автоматически. Подробнее см. Настройка автозаполнения полей ввода заявки .

См. также:

  • Торговые операции в РЕПО
  • Безадресные заявки
  • Ввод безадресной заявки


Отмена безадресной заявки

Неисполненные заявки со статусом «Активна» доступны для снятия.

Снятие безадресной заявки может быть осуществлено одним из следующих способов:

  1. В Таблице безадресных заявок на внебиржевые сделки (снимаемая заявка должна быть выбрана):
    • Выбором пункта контекстного меню «Снять безадресную заявку на внебиржевую сделку» Действия/Снять безадресную внебиржевую заявку;
    • Двойным щелчком правой кнопкой мыши на строке с заявкой;
    • Нажатием кнопки [image] на панели инструментов;
    • Нажатием клавиш «Ctrl»+«D» на снимаемой заявке.
  2. Общим способом выполнения транзакций - нажатием кнопки [image] на панели инструментов, выбором соответствующего класса и операции «Отмена безадресной заявки». Эта же операция может быть выполнена горячей клавишей «Ctrl»+«T».

В открывшемся окне укажите следующие параметры:

Звездочкой (*) отмечены обязательные поля.
  1. «Заявка»* - номер заявки для снятия.
  2. «К/П» – направление операции: «Купля», «Продажа», «Любой направленности».
  3. «Инструмент»* – выберите название инструмента из списка инструментов данного класса.
  4. «Код расчетов» - укажите вручную либо выберите из списка код расчетов по сделке (значения: «T0», от «B0» до «B31»).
  5. «Трейдер» – идентификатор трейдера, подавшего заявку.
  6. «Фирма» – идентификатор фирмы-участника торгов, от имени которой подана заявка.

См. также:

  • Торговые операции в РЕПО
  • Ввод безадресной заявки
  • Ввод безадресной заявки РЕПО с ЦК
  • Редактирование заявок


Редактирование заявок

Неисполненные (активные) заявки можно редактировать. Изменение условий в заявке выполняется путем снятия старой заявки и вводом новой с измененными условиями. Такую операцию можно выполнить следующим способом:

  1. Двойным нажатием правой кнопки мыши на активной заявке - снять старую заявку.
  2. Двойным нажатием левой кнопки мыши на снятой заявке – открыть окно ввода заявки с параметрами, аналогичными снятой.
  3. Изменить нужные параметры заявки и отправить ее в торговую систему.

Изменение условий неисполненной заявки в «Таблице безадресных заявок на внебиржевые сделки» не требует снятия старой заявки и ввода новой с измененными условиями. Для редактирования безадресной внебиржевой заявки необходимо:

  1. Вызвать диалог редактирования заявки нажатием сочетания клавиш «Ctrl»+«A» или выбором пункта контекстного меню «Заменить безадресную внебиржевую заявку».
  2. Изменить нужные параметры заявки и отправить ее в торговую систему.

См. также:

  • Адресные заявки
  • Безадресные заявки


Расчетные заявки-отчеты на исполнение сделок РЕПО

Операция предназначена для ввода в Торговую систему отчетов об исполнении ранее заключенных сделок, содержащихся в таблице «Сделки для исполнения». Сделки, доступные для ввода отчёта, образуют список переговорных сделок, ещё не занятых в расчётах. В отчет включаются сделки из таблицы «Сделки для исполнения», отфильтрованные по наименованию класса, инструмента, счёту депо, партнёру и торговому счёту партнёра.

Транзакция может быть использована для пролонгации сделок РЕПО.

См. также:

  • Ввод расчетной заявки-отчета
  • Отмена расчетной заявки-отчета
  • Операции в Режиме переговорных сделок ММВБ


Ввод расчетной заявки-отчета

Подтверждение заявкой-отчетом может быть выполнено одним из следующих способов:

  1. По одной заявке: из Таблицы сделок для исполнения одним из следующих способов (в таблице должна присутствовать хотя бы одна заявка):
    • Выбором пункта контекстного меню «Подтвердить отчетом» или пункта меню программы Действия/Подтвердить отчетом;
    • Двойным щелчком левой кнопки мыши на строке с заявкой;
    • Нажатием кнопки [image] на панели инструментов;
    • Нажатием клавиши «F2».
  2. От одной до четырех заявок: общим способом выполнения транзакций - нажатием кнопки [image] на панели инструментов, выбором соответствующего класса (например «РПС: А1-Акции») и операции «Ввод расчетной заявки-отчета (макс. 4 сделки)». Эта же операция может быть выполнена горячей клавишей «Ctrl»+«T».
  3. От одной до девяноста девяти заявок: выбором пункта контекстного меню «Ввод заявки-отчета (макс. 99 сделок)» в Таблице сделок для исполнения.

Назначение полей формы ввода расчетной заявки-отчета:

Фильтры:

  1. «Класс» - выбор класса инструментов из списка.
  2. «Инструмент» - выбор инструмента в данном классе.
  3. «Клиент» – код клиента.
  4. «Партнер» - код участника торгов, являющегося контрагентом по сделке.
  5. «Счет депо» - код счета депо.
  6. «Счет депо партнера» - код счета депо партнера.
  7. «№ отчета партнера» – номер отчета партнера по сделке.
  8. «Только сделки с исполнением сегодня» - фильтр по сделкам с наступившим сроком исполнения.

Настройки фильтров формы ввода расчетной заявки-отчета сохраняются в файл конфигурации (*.wnd).

Если в таблице «Сделки для исполнения» выделена строка со сделкой и из контекстного меню таблицы открыта форма «Ввод расчетной заявки-отчета», то поля формы: «Класс», «Инструмент», «Клиент», «Партнер», «Счет депо», «Счет депо партнера», «№ отчета партнера» заполняются значениями, указанными в этой сделке.

Для подтверждения сделок выберите их, отметив флажком в первой колонке. Нажатие кнопки «Выделить все» позволяет отметить все сделки в списке. Нажатием кнопки «Снять выделение» снимаются отметки со всех сделок.

Справочные поля:

  1. «Количество сделок» отображает количество сделок, включенных в отчет.
  2. «Нетто количество» – сальдо изменения позиции по инструментам в результате исполнения выбранных сделок.
  3. «Нетто сумма» – сальдо изменения позиции по деньгам в результате исполнения выбранных сделок.

    Если количество выбранных в таблице сделок превышает максимальное количество сделок, доступное для подтверждения в одной транзакции (4 сделки), то значения в полях «Нетто количество» и «Нетто сумма» очищаются, и в левой нижней части формы выводится предупреждение «Нетто-параметры не могут быть посчитаны».

  4. «Подтверждать срочным отчетом» – признак исполнения в режиме расчетов по правилам простого клиринга.

Нажатием кнопки «Отправить» заявка-отчет отсылается в торговую систему. Нажатие кнопки «Выход» закрывает окно без отправления заявки.

Заявка-отчет, принятая торговой системой отображается в Таблице заявок-отчетов на сделки РПС. Соответствующая ей сделка в Таблице сделок для исполнения изменит статус с «Ждет исполнения» на «Включен в отчет». После того, как партнер по сделке подтвердит ее со своей стороны, статус изменится на «Исполнен» и сделка будет завершена.

См. также:

  • Отмена расчетной заявки-отчета
  • Расчетные заявки-отчеты на исполнение второй части сделок РЕПО
  • Торговые операции РЕПО


Отмена расчетной заявки-отчета

Неисполненные отправленные заявки-отчеты со статусом «Активна» доступны для снятия. Полученные заявки-отчеты для отмены недоступны.

Снятие заявки-отчета может быть произведено одним из следующих способов:

  1. В Таблице заявок-отчетов на сделки РПС (снимаемая заявка должна быть выбрана):
    • Выбором пункта контекстного меню «Снять отчет» или пункта меню программы Действия/Снять отчетом;
    • Двойным щелчком правой кнопки мыши на строке с заявкой;
    • Нажатием кнопки [image] на панели инструментов;
    • Нажатием клавиш «Ctrl»+«D» на снимаемой заявке.
  2. Общим способом выполнения транзакций - нажатием кнопки [image] на панели инструментов, выбором соответствующего класса (например «РПС Акции 1-го уровня») и операции «Отмена безадресной заявки». Эта же операция может быть выполнена горячей клавишей «Ctrl»+«T».

В открывшемся окне укажите параметры (звездочкой (*) отмечены обязательные поля):

  1. «Отчет»* – Номер отменяемой заявки-отчета.
  2. «Трейдер» – идентификатор трейдера, подавшего заявку.
  3. «Фирма» - идентификатор фирмы-участника торгов, от имени которой подана заявка.
  4. «Инструмент»* – выберите название инструмента из списка инструментов данного класса.

См. также:

  • Ввод расчетной заявки-отчета
  • Расчетные заявки-отчеты на исполнение второй части сделок РЕПО
  • Торговые операции РЕПО


Заявки исполнения без подтверждения

Заявка исполнения без подтверждения используется для исполнения сделок одного дилера или между дилерами, когда не происходит уменьшение позиции партнера по деньгам и инструментам. Для исполнения сделки требуется ввод одной заявки исполнения. Сделка совершается в момент подачи этой заявки. При постановке заявок исполнения осуществляется контроль позиций по деньгам и инструментам. Заявка исполнения направляется в адрес только конкретного партнера. В заявке исполнения отражаются нетто-сумма и нетто-количество сделок, включенных в заявку.

Ввод заявки исполнения без подтверждения

Окно ввода новой заявки исполнения без подтверждения может быть вызвано общим способом выполнения транзакций - нажатием кнопки [image] на панели инструментов, выбором соответствующего класса (например «РЕПО-M: Акции») и операции «Ввод заявки исполнения без подтверждения». Эта же операция может быть выполнена горячей клавишей «Ctrl»+«T».

Заполнение полей окна ввода заявки при вводе заявки исполнения без подтверждения общим способом выполнения операций:

Звездочкой (*) отмечены обязательные поля.
  1. «Кол-во сделок»* – Количество заключенных сделок, подтверждаемых в отчете. Значения от 1 до 4.
  2. «Сделка 1»* .. «Сделка 4» – идентификационные номера подтверждаемых сделок.
  3. «Направленность сделки 1»* .. «Направленность сделки 4» – направление операции для соответствующей сделки: «Купля» или «Продажа».

Нажатием кнопки «Выполнить» заявка отправляется в торговую систему. Нажатие кнопки «Отмена» закрывает окно без отправления заявки.

См. также Торговые операции РЕПО.


Маклерская заявка

  • Назначение
  • Ввод маклерской заявки
  • Снятие и замена маклерской заявки

    • Назначение

    Маклерская заявка - специальный вид транзакций, используемый в случае, когда один сервер QUIK используется несколькими участниками торгов для подключения к торговым системам бирж. Маклерская заявка позволяет указать код участника торгов непосредственно при вводе поручений из числа брокеров, использующих данный сервер QUIK.

    Работа с маклерскими заявками требует наличия на сервере специальной лицензии на использование мультиброкерских рабочих мест и настройки прав пользователя для работы с ними.

    Открытие окна «Ввод маклерской заявки» осуществляется:

    • Из Таблицы текущих торгов, Таблицы котировок, Таблицы заявок, Таблицы сделок, Таблицы «Купить/Продать» выполнением следующих действий:
      • нажатием кнопки [image] на панели инструментов;
      • двойным нажатием левой кнопки мыши. Из Таблицы текущих торгов подать заявку таким образом не получится, так как при выполнении этого действия откроется Окно котировок;
      • нажатием клавиши «F2»;
      • выбором в таблице пункта контекстного меню «Новая заявка» или пункта меню программы Действия/Новая заявка.
    • Использованием Общего способа выполнения транзакций с выбором операции «Ввод маклерской заявки».

    Ввод маклерской заявки

    Окно в зависимости от настроек может иметь компактную (слева) или полную (справа) форму. Вид окна переключается нажатием кнопки«>>». Формы оптимизированы для легкого и быстрого ввода параметров и компактного расположения на экране.

    Заполнение формы заявки:

    1. «Организация» - идентификатор фирмы-участника торгов, от имени которой подана заявка. Заполняется автоматически, если указан «Код клиента».
    2. «Инструмент» - выбор инструмента из списка инструментов данного класса. Чтобы найти инструмент в списке, наберите с клавиатуры первые буквы его наименования.
    3. «Торговый счет» - код торгового счета, в отношении которого подается заявка (регистр символов имеет значение). Если за пользователем закреплен один счет, то поле заполнится автоматически. Если доступны несколько счетов, потребуется выбрать нужный счет из списка или воспользоваться настройкой «Указывать счет депо по коду клиента» (см. Настройки ввода заявки). О настройке последовательности счетов в списке см. Настройка счетов.
    4. «Покупка» / «Продажа» - направление операции.
    5. «Цена» - цена заявки за одну единицу финансового инструмента. При включении признака «Рыночная» значение поля «Цена» устанавливается равным «0» и недоступно для редактирования. При отключении признака «Рыночная» в поле автоматически подставляется значение цены, указанное до включения признака «Рыночная». При смене инструмента запомненное значение сбрасывается.

      При выборе в рамке «Ввод цены» значения «По средневзвешенной цене» поле «Цена» и признак «Рыночная» становятся неактивными (серыми).
    6. «Рыночная» – признак заявки без указания цены исполнения. Такая заявка исполняется на бирже по ценам имеющихся встречных заявок, начиная с лучшей из них. Неисполненный остаток снимается с торгов.

      При выборе в рамке «Ввод цены» значения «По средневзвешенной цене» признак «Рыночная» становится неактивным (серым).
    7. «Кол-во» - количество инструментов в заявке. Поле недоступно для заполнения при подаче рыночной заявки на покупку на аукцион периода закрытия.
    8. «Код клиента» - идентификатор клиента в системе QUIK.
    9. «Комментарий» – текстовый комментарий к заявке.

    Дополнительные параметры:

    10. «Ввод цены»:
      • Выбор значения в поле «Цена»:
        • «По цене» – исполнение заявки при наличии в торговой системе встречных заявок с аналогичной ценой исполнения;
        • «По доходности» – исполнение при наличии встречных заявок с аналогичной доходностью, рассчитанной по цене заявки (для облигаций);
        • «По средневзвешенной цене» – в качестве цены принимается средневзвешенная цена за текущую торговую сессию.

        Как правило, почти всегда используется вариант «По цене», установленный в форме по умолчанию. Если для данного класса или типа заявки выбор невозможен, варианты становятся неактивными (серыми).

      • Выбор цены исполнения заявки:
        • «По одной цене» – заявка исполняется по одной цене;
        • «По разным ценам» – заявка может быть исполнена по разным ценам.
    11. «Объем и комиссия» - стоимость сделки в денежном выражении. Поле недоступно для заполнения при подаче рыночной заявки на продажу на аукцион периода закрытия. Размер комиссии рассчитывается автоматически и выводится в поле справа.
    12. «Задать количество» - задает значение полей «Объем» и «Комиссия».
    13. «Условие исполнения» - определяет порядок исполнения заявки: «Поставить в очередь», «Немедленно или отклонить», «Снять остаток», «Аукцион периода закрытия».
    Поля «Количество», «Код клиента», «Комментарий» могут быть заполнены автоматически. Подробнее см. «Настройка автозаполнения полей ввода заявки».

    Снятие и замена маклерской заявки

    Операции снятия и замены маклерской заявки выполняются из Таблицы заявок и аналогичны действиям над обычными заявками (см Снятие заявки, Замена заявки).


Ввод маклерских заявок для классов Срочного рынка Московской Биржи

Окно в зависимости от настроек может иметь компактную (слева) или полную (справа) форму. Вид окна переключается нажатием кнопки«>>». Формы оптимизированы для легкого и быстрого ввода параметров и компактного расположения на экране.

Форма ввода маклерской заявки для класса «Опционы FORTS»:

Форма ввода маклерской заявки для класса «Фьючерсы FORTS»:

Заполнение формы заявки:

  1. «Организация» – идентификатор фирмы-участника торгов, от имени которой подана заявка. Заполняется автоматически, если указан «Торговый счет».
  2. «Инструмент» - выбор инструмента из списка инструментов данного класса. Чтобы найти инструмент в списке, наберите с клавиатуры первые буквы его наименования.
  3. «Торговый счет» - код торгового счета, в отношении которого подается заявка (регистр символов имеет значение). Если за пользователем закреплен один счет, то поле заполнится автоматически. Если доступны несколько счетов, потребуется выбрать нужный счет из списка или воспользоваться настройкой «Указывать счет депо по коду клиента» (см. Настройки ввода заявки). О настройке последовательности счетов в списке см. Настройка счетов.
  4. «Покупка» / «Продажа» - направление операции.
  5. «Цена» – цена заявки за одну единицу финансового инструмента.При выставлении заявки с признаком «Рыночная» требуется указать такую цену, не хуже которой должны исполняться заявки. При включении признака «Рыночная» в пустое поле «Цена» подставляется значение «Максимально возможная цена», а при подаче заявки на продажу – «Минимально возможная цена» для данного инструмента (значение берется из Таблицы текущих торгов). При отключении признака «Рыночная» в поле автоматически подставляется значение цены, указанное в данном поле до включения признака «Рыночная». При смене инструмента запомненное значение сбрасывается.
    При включении признака «Рыночная» значение поля устанавливается равным «0» и недоступно для редактирования. При отключении признака «Рыночная» в поле автоматически подставляется значение цены, указанное в данном поле до включения признака «Рыночная». При смене инструмента запомненное значение сбрасывается.
  6. «Кол-во» – количество инструментов в заявке.
  7. «Рыночная» – при установленном признаке и при наличии встречного предложения заявка исполняется по цене не хуже, чем значение, указанное в поле «Цена». Неисполненный остаток, на который отсутствует встречное предложение, снимается с торгов.
  8. «Код Клиента» – идентификатор клиента в системе QUIK.
  9. «Комментарий» – текстовый комментарий к заявке.

Дополнительные параметры:

  10. «Условие исполнения» – порядок исполнения заявки: «Поставить в очередь», «Немедленно или отклонить», «Снять остаток».
  11. «Переносить заявку» – признак выставления заявки с условием исполнения до даты, указанной пользователем.
    При установленном признаке поле для выбора даты экспирации заявки становится доступным для редактирования.
  12. «Проверять клиентский лимит» – при установленном признаке производится проверка лимитов клиента.
  13. «Объем» – оценка заявки в денежном выражении. Позволяет рассчитать «Кол-во» инструментов в заявке по известной сумме денег. Для этого нужно ввести в поле «Объем» сумму денежных средств и нажать кнопку «Задать кол-во». При этом в поле «Кол-во» будет введено число, полученное в результате пересчета и округленное вниз до ближайшего целого, а в поле «Объем» – денежная оценка заявки при данном «Кол-ве».
    Объем заявки рассчитывается по формуле:
    «Объем» = «Количество» * «Стоимость шага цены» * («Цена» / «Размер шага цены»)
  14. «Объем ГО» – совокупный размер ГО, который блокируется по заявке, исходя из количества контрактов и настроек брокера.
  15. «Проверять диапазон цен» – если флажок включен, то цена заявки проверяется торговой системой на соответствие диапазону допустимых значений цены по этому инструменту. Признак доступен только для класса «Опционы FORTS».
Поля «Кол-во», «Код Клиента», «Комментарий» могут быть заполнены автоматически. Подробнее см. «Настройка автозаполнения полей ввода заявки».


Маклерская стоп-заявка

  • Назначение
  • Ввод маклерской стоп-заявки
  • Снятие, замена и активация маклерской стоп-заявки

    • Назначение

    Маклерская стоп-заявка – специальный вид стоп-заявки, используемый в случае, когда один сервер QUIK используется несколькими участниками торгов для подключения к торговым системам бирж. Маклерская стоп-заявка позволяет указать код участника торгов непосредственно при вводе поручений из числа брокеров, использующих данный сервер QUIK.

    Работа с маклерскими стоп-заявками требует наличия на сервере специальной лицензии на использование мультиброкерских рабочих мест и настройки маклерских прав пользователя для работы с ними.

    Открытие окна «Ввод стоп-заявки маклером» осуществляется:

    • Из Таблицы текущих торгов, Таблицы котировок, Таблицы заявок, Таблицы стоп-заявок, Таблицы сделок, Таблицы обезличенных сделок, Кармана транзакций выполнением следующих действий:
      • нажатием кнопки [image] на панели инструментов;
      • двойным нажатием левой кнопки мыши в «Таблице стоп-заявок»;
      • нажатием клавиши «F6»;
      • выбором в таблице пункта контекстного меню «Новая стоп-заявка» или пункта меню программы Действия/Новая стоп-заявка.
    • Использованием Общего способа выполнения транзакций с выбором операции «Маклерская стоп-заявка».

    Ввод маклерской стоп-заявки

    С помощью формы ввода маклерской стоп-заявки можно формировать стоп-заявки разных типов. Дополнительные условия заявки отображаются в расширенной форме, вызываемой нажатием кнопки «Больше >>» или выбором типа стоп-заявки, для которой предназначены эти дополнительные условия.

    Форма ввода маклерской стоп-заявки содержит следующие параметры:

    1. «Организация» - идентификатор фирмы-участника торгов, от имени которой подана заявка. Для срочного рынка заполняется автоматически, если указан «Торговый счет». Для спот-рынка заполняется автоматически, если указан «Код клиента».
    2. «Тип стоп-заявки» – выбор одного из возможных типов поручения. Делает доступным особые поля, относящиеся к определенному типу стоп-заявки. При необходимости окно ввода заявки принимает расширенную форму.
    3. «Срок действия». Если выбрано значение «сегодня», то поручение действительно до конца текущего дня, иначе поручение действительно до даты, выбранной в поле «по…», или до отмены поручения, если выбрано значение «до отмены».

      Стоп-заявки «Со связанной заявкой» действительны только в течение текущей торговой сессии.
    4. «Время действия заявки» - период времени, в течение которого проверяются условия стоп-заявки. Параметр поручений типа «Тейк-профит и стоп-лимит». Если флажок отключен, то параметр не используется. При включенном флажке необходимо указать в поле «с…» - время начала действия стоп-заявки, а в поле «до…» - время окончания.

      1. Параметр «Время действия заявки» определяет только интервал времени, в тече-ние которого проверяется условие активации стоп-заявки. Если заявка активировалась, то проверка времени действия прекращается. Например, если для заявки типа «Тейк-профит и стоп-лимит» цена пробила уровень тейк-профит (заявка сработала, начался расчет минимума/максимума цены), но заявка не исполнилась до окончания заданного интервала времени внутри дня, то расчет максимума/ минимума цены не прекращается по истечении заданного периода времени.
      2. Если значения времени «С…» и «До…» совпадают, то считается, что задан интервал с указанного времени текущего дня, до аналогичного времени следующего дня. Если значение «До…» строго больше времени «С…», то время действия проверяется в течение текущего дня.
      3. При включенной настройке «Показывать дату и время торговых данных с учетом локальной временной зоны» значение параметра «Время действия заявки» указывается с учетом временной зоны компьютера, на котором запущен терминал QUIK.
    5. «Инструмент» – выбор инструмента из списка инструментов данного класса. Чтобы найти инструмент в списке, наберите с клавиатуры первые буквы его наименования.
    6. «Торговый счет» – код торгового счета, в отношении которого подается заявка (регистр символов имеет значение). Если за пользователем закреплен один счет, то поле заполнится автоматически. Если доступны несколько счетов, потребуется выбрать нужный счет из списка или воспользоваться настройкой «Указывать счет депо по коду клиента» (см. Настройки ввода заявки). О настройке последовательности счетов в списке см. Настройка счетов.
    7. «Условие активации заявки» - настройка условий активации заявки:
      • «Операция» – выбор направления заявки: «Покупка» или «Продажа»;
      • Выбор контролируемого условия стоп-цены по отношению к цене последней сделки по инструменту:
          1. Для заявок типа «Стоп-цена по другому инструменту» условие имеет вид: «Если цена <=» ( или «>=») и означает исполнение заявки, если цена последней сделки по другому инструменту пересечет указанное значение;
          2. Для заявок типов «Стоп-лимит», «Со связ. заявкой» условие имеет вид «стоп-лимит, если цена <=» ( или «>=») и означает выставление лимитированной заявки в случае, если цена последней сделки пересекла указанное значение;
          3. Для заявок типа «Тейк-профит» условие имеет вид «тейк-профит, если цена <= » (или «>=») и означает начало расчета минимума (максимума) цены последней сделки, если она пересекла указанное значение;
          4. Для заявок типа «Тейк-профит и стоп-лимит» доступны условия 2) и 3), причем любое из них может не заполняться.

      Значение стоп-цены указывается в окне справа от выбора условия.

    8. «Цена» – цена лимитированной заявки, выставляемой в торговую систему при наступлении условия «Стоп-лимит», за одну единицу финансового инструмента.

      При включении признака «По рыночной цене» значение поля устанавливается равным «0» и недоступно для редактирования. При отключении признака «По рыночной цене» в поле автоматически подставляется значение цены, указанное в данном поле до включения признака «По рыночной цене». При смене инструмента и отключении признака «По рыночной цене» значение цены не восстанавливается.
    9. «По рыночной цене» - признак исполнения стоп-заявки по рыночной цене. Параметр заявок типа «Тейк-профит и стоп-лимит».

      В некоторых режимах торгов использование рыночных заявок не предусмотрено.
    10. «Кол-во (лот …)» – количество инструментов, выраженное в лотах. В скобках указано количество единиц выбранного инструмента в одном лоте.
    11. «max» – максимальное возможное количество лотов в стоп-заявке, рассчитанное из величины доступных средств клиента с учетом всех комиссий. Нажатием на кнопку указанное максимальное значение вводится в поле «Кол-во». Поле отображается при включенном в настройках флажке «Рассчитывать доступное количество».
    12. «Код Клиента» – идентификатор клиента в системе QUIK.
    13. «Комментарий» – текстовый комментарий к заявке.

    Параметры расширенной формы ввода заявки, разворачивающиеся нажатием кнопки«Больше>>»:

    1. «Брать стоп-цену для инструмента» - наименование и класс инструмента, по которому осуществляется контроль условия стоп-цены. Параметр поручения типа «Стоп-цена по другому инструменту».
    2. «Выставить связанную заявку на покупку (продажу) по цене» - цена исполнения связанной лимитированной заявки. Параметр поручения типа «Со связ. заявкой».
    3. «При частичном исполнении связанной заявки снять стоп-заявку» – если флажок установлен, то при частичном исполнении связанной лимитированной заявки стоп-заявка становится снятой. Если флажок снят, то при частичном исполнении связанной заявки объем стоп-заявки уменьшается до величины неисполненного остатка лимитированной заявки.
    4. «Выставить «тейк-профит» - параметры заявки типа «Тейк-профит»:
      • «Отступ от max (min)» – устанавливает значение отступа от максимума (на продажу) или минимума (на покупку) цены последней сделки, при достижении которого будет сгенерирована лимитированная заявка. Значение отступа может указываться как в виде отклонения цены, так и в процентах;
      • «Защитный спред» – устанавливает дополнительное (опережающее) отклонение цены заявки от цены последней сделки, инициировавшей заявку. Защитный спред предназначен для того, чтобы установить цену создаваемой лимитированной заявки заведомо исполнимой;
      • «По рыночной цене» - признак исполнения тейк-профита по рыночной цене. Значение параметра «Защитный спред» в данном случае не используется. Параметр заявок типа «Тейк-профит и стоп-лимит».
      В некоторых режимах торгов использование рыночных заявок не предусмотрено.
    5. «Объем и комиссия» - оценка заявки в денежном выражении. Позволяет рассчитать «Количество» инструментов в заявке по известной сумме денег. Для этого нужно ввести в поле «Объем» сумму денежных средств и нажать кнопку «Задать количество». При этом в поле «Количество» будет введено число, полученное в результате пересчета и округленное вниз до ближай-шего целого, а в поле «Объем» – денежная оценка заявки при данном «Количестве».

      Сумма брокерской комиссии с объема заявки рассчитывается автоматически в соответствии с установленным алгоритмом и выводится в поле справа.

    1. При заполнении формы заявки можно перемещаться между полями мышью, либо клавишей «Tab» в одну сторону, или «Shift»+«Tab» в обратную сторону.
    2. Поля «Количество», «Код клиента», «Комментарий» могут быть заполнены автоматически. Подробнее см. Настройка автозаполнения полей ввода заявки.
    3. В случае неблагоприятного исполнения заявки типа «Тейк-профит» на покупку, цена будет рассчитана следующим образом: <стоп-цена>+<отступ от min/max>+<защитный спрэд>.

    Если для какого-то типа стоп-заявки не предусмотрен один из пунктов заявки, то он становится «серым» (неактивным).

    Порядок подтверждения маклерской стоп-заявки, настройки параметров ее ввода, доступные функции и способ быстрого ввода такие же, как и при вводе заявки.

    Снятие, замена и активация маклерской стоп-заявки

    Операции снятия, замены и активации маклерской стоп-заявки выполняются из Таблицы стоп-заявок и аналогичны действиям над обычными стоп-заявками.


Участие в аукционах по размещению инструментов

Система QUIK поддерживает возможность участия в первичном размещении инструментов. Режим размещения инструментов предусматривает два этапа:

  1. Ввод участниками торгов заявок на покупку размещаемого инструмента.

    Используемые таблицы:

    • « Таблица текущих торгов» – информация о состоянии сессии, допускающем ввод заявок.
    • «Таблица заявок» или «Таблица заявок на внебиржевые сделки » – собственные заявки на покупку инструментов.
  2. Исполнение заявок клиентов андеррайтером.
    • «Таблица текущих торгов» – параметры состоявшегося размещения: объем, средневзвешенная, минимальная и максимальная цены сделок и т.п.
    • «Таблица сделок» или «Таблица сделок для исполнения» – состояние исполнения собственных заявок.

При размещении инструментов Таблица котировок (очередей заявок), как правило, не используется.

Размещение может проводиться двумя способами:

  1. В форме аукциона, путем удовлетворения конкурентных и неконкурентных заявок.
    • Конкурентная заявка – заявка с указанием цены. Ввод конкурентной заявки на аукционе осуществляется путем формирования лимитированной заявки на покупку (нажатием кнопки [image] на панели инструментов или клавиши «F2»).

    Если в заявке указан тип значения цены «Доходность» или «Средневзвешенная цена», то при приеме заявки сервером QUIK проверка достаточности средств клиента не может быть осуществлена корректно в силу недостаточности информации из торговой системы.
    • Неконкурентная заявка – заявка без указания цены, с условием исполнения по средневзвешенной цене удовлетворенных конкурентных заявок. Ввод неконкурентной заявки осуществляется Общим способом выполнения транзакций (нажатием кнопки [image] или клавиш «Ctrl»+«T») и выбором операции «Ввод неконкурентной заявки на покупку при первичном размещении».

    В окне ввода заявки необходимо указать следующие параметры:

    • «Торговый счет» – код счета депо, в отношении которого совершается сделка;
    • «Инструмент» – наименование инструмента;
    • «Примечание» – текстовый комментарий к заявке, необязательное поле;
    • «Объем заявки» – объем заявки в денежном выражении.
  2. Размещение путем удовлетворения адресных заявок в Режиме переговорных сделок (РПС).

    Ввод заявки осуществляется путем формирования адресной заявки на покупку, направленной участнику торгов - андеррайтеру размещения инструментов с условиями, указанными в проспекте эмиссии, и интересующим количеством инструментов, выраженном в лотах.


Режим приема клиентских транзакций с подтверждением брокером

Данный режим предназначен для обработки поручений клиентов, по которым недостаточно автоматического контроля позиций клиентов и требуется предварительная проверка условий заявки сотрудником брокера.

Режим приема клиентских транзакций с подтверждением брокером устанавливается Администратором системы QUIK и распространяется на все операции клиента по вводу и снятия заявок, относящихся к определенному классу инструментов.

Право на подтверждение заявок клиентов в данном режиме назначается Администратором системы QUIK пользователю с полномочиями Менеджера фирмы либо Субадминистратора (подробнее см. Субадминистрирование). Таким правом могут обладать несколько сотрудников брокера. В случае принятия решения по одной заявке клиента несколькими сотрудниками брокера, принимается подтверждение, введенное первым.

Подтверждение заявки клиента

При получении сервером новой заявки клиента, требующей подтверждения, на рабочем месте пользователя QUIK с правом подтверждения клиентских заявок отображается окно, содержащее запрос на подтверждение транзакции с перечисленными в нем параметрами.

Нажатие кнопки «Да» подтверждает заявку клиента. Нажатием кнопки «Нет» заявка отвергается. Кнопка «Отмена» служит для закрытия окна без совершения действий с заявкой.

См. также Настройка режима подтверждений.


Настройки режима подтверждений

Окно настроек открывается выбором пункта меню Система/Настройки/Основные настройки..., раздел «Торговля» / «Заявки» / «Клиентские заявки» и имеет следующие параметры:

  1. «Запрашивать подтверждение при операциях с клиентскими заявками» - признак означает, что при выборе действия «Подтвердить клиентскую транзакцию» или «Отклонить клиентскую транзакцию» в контекстном меню «Таблицы запросов клиентов на исполнение клиентских заявок (меню Создать окно/Клиентские транзакции) на экране появится окно с подтверждением/отклонением клиентской заявки.
  2. «Запрашивать подтверждение при операциях с группами клиентских заявок» – признак означает, что при выборе действия «Подтвердить все кл. транзакции из таблицы» или «Отклонить все кл. транзакции из таблицы» в контекстном меню «Таблицы запросов клиентов на исполнение клиентских заявок» (меню Создать окно/Клиентские транзакции) на экране появится окно с подтверждением/отклонением клиентских заявок.
  3. «Показывать текст с описанием клиентской заявки в стандартном окне сообщений программы» – признак позволяет настроить получение оповещения о поступлении новой заявки. Если он включен, описание клиентской заявки отображается в Окне сообщений, если выключен – на экране появится диалог «Запрос на исполнение клиентской заявки» с дополнительным подтверждением выбранного действия.
  4. «Активная кнопка в форме подтверждения клиентской заявки» – выбор кнопки в окне подтверждения клиентской заявки, являющейся активной при появлении окна на экране:
    • «Да» - подтвердить заявку;
    • «Нет» - отклонить заявку;
    • «Отмена» - закрыть окно без подтверждения заявки (действие может быть выполнено позднее или другим пользователем).

    Свойство может применяться при частом подтверждении заявок, в этом случае достаточно пользоваться клавиатурой - нажатием клавиши «Enter» выполняется нажатие активной кнопки в окне.

См. также Режим приема клиентских транзакций с подтверждением брокером.


Работа с неторговыми поручениями

Назначение

Система QUIK поддерживает работу с неторговыми поручениями, такими, как ввод/вывод средств, переводы между площадками. Принцип их использования описан в разделе «Неторговые операции и отчеты».

Прием и обработка поручений от клиентов осуществляется сотрудником брокера через Рабочее место QUIK с правами менеджера. Пользователь с правами менеджера имеет право на:

  • Управление сессией - управление режимом приема поручений;
  • Обработку поручений - подписание/отклонение поручений клиентов и взимание связанных с этим платежей;
  • Изменение кросс-курса валют – указание кросс-курса валют, используемого в поручениях типа «Конвертация валют».

Управление сессией

меню Расширения / Неторговые поручения / Управление сессией

Неторговые поручения обрабатываются системой QUIK аналогично торговым транзакциям. Для того чтобы пользователи могли отправлять поручения брокеру, должна быть открыта сессия по классу "Неторговые поручения". Состояние сессии отображается в колонке "Сессия" Таблицы текущих торгов. Если необходимо временно остановить прием поручений (например, по техническим причинам), брокер может приостановить сессию для всех типов поручений или выбрать определенный тип поручения, для которого будет приостановлена сессия, выполнить необходимые процедуры, а затем возобновить сессию.

Операции, доступные в окне «Управление сессией»:

  • «Открыть» - начать новую сессию;
  • «Закрыть» - завершить текущую сессию;
  • «Приостановить» - временно приостановить текущую сессию;
  • «Возобновить» - продолжить приостановленную ранее сессию;
  • «Загрузка справочников» - произвести обновление справочников из базы данных Модуля неторговых поручений;
  • «Загрузка поручений» - произвести обновление списка поручений из базы данных Модуля неторговых поручений;
  • «Снять активные поручения» – снять активные поручения всех видов. Если в настройках Модуля задан список классов, по которым снимаются активные поручения в соответствии с расписанием, то операция применяется к указанному списку классов;
  • «Остановить клиентскую сессию» - переводит открытую сессию в состояние «Служебная», которое означает невозможность отправки клиентами новых поручений, однако обработка поручений сотрудниками брокера не приостанавливается;
  • «Возобновить клиентскую сессию» - переводит служебную сессию в состояние «Открыта».

Обработка поручений

Обработка поручений выполняется из «Таблицы поручений». В этой таблице отображаются поручения всех типов и состояние их обработки специалистами брокера. Двойным нажатием правой кнопки мыши на строке можно открыть поручение и посмотреть его параметры. Статус поручения выделен цветом шрифта:

  • «Активные» - красным цветом;
  • «Исполненные» - синим;
  • «Снятые» - черным;
  • «Имеющие запрос на снятие» - зеленым.

Для исполнения поручения необходимо подтверждение (подпись) уполномоченных сотрудников брокера. Последовательность проверки и количество необходимых подписей настраивается на сервере QUIK для каждого вида поручений.

Подписание поручения

Чтобы подписать поручение, необходимо:

  1. Открыть его двойным нажатием левой кнопки мыши на соответствующей строке в таблице.
  2. Если пользователь имеет право на требуемую подпись, кнопка подписи будет активна и ее наименование будет соответствовать имени подписи. На приведенном примере это кнопка «Риск-менеджер». Также будут активны поля ввода налогов для соответствующей подписи.
  3. Указать, если необходимо, значения удерживаемых платежей в соответсвующих полях формы.
  4. Нажать кнопку подписи (например, «Риск-менеджер»).

В результате на соответствующей строке в «Таблице поручений» появится отметка «+» в колонке с ролью данного сотрудника (например, «Риск-менеджер»), уведомляющая о наличии подписи.

Групповая подпись поручений

Для осуществления групповой подписи надо в таблице поручений выбрать пункт контекстного меню «Подписать все поручения». Далее, в появившейся форме выбора подписей выбрать нужную подпись и нажать кнопку «Подписать». После нажатия кнопки «Подписать» будет осуществлен поиск поручений, которым требуется данная подпись. Найденные поручения подписываются с проверкой доступности ресурсов, как и при одиночной подписи.

Отклонение поручения

Если поручение клиента не может быть исполнено, оно должно быть отклонено сотрудником брокера с указанием причины. Для этого необходимо:

  1. Открыть его двойным нажатием левой кнопки мыши на соответствующей строке в таблице, либо выбрать пункт контекстного меню «Отменить».
  2. В окне с поручением нажать кнопку «Снять».

В открывшемся окне «Комментарий к отмене поручения… » написать причину отказа, которая будет сохранена в данном поручении в поле «Комментарий отмены». Возможно заполнить причину отмены выбором шаблона из справочника «Причины отмены». По умолчанию шаблон не выбран. Текст причины можно изменять в форме отмены поручения.

В результате поручение в таблице примет состояние «Снято». При этом дальнейшая обработка поручения прекращается.

Отмена подписи

Подпись поручения можно отменить, выбрав один из пунктов контекстного меню таблицы поручений:

  • «Отзыв последней подписи» - отзывает последнюю подпись в сделке для данной роли;
  • «Отзыв всех подписей» - отзывает подпись у всех сделок для данной подписи.

Также подпись можно отменить, открыв форму поручения и нажав кнопку «Отозвать».

Исполнение поручения

Поручение, имеющее все необходимые подписи, меняет статус на «Исполнено». При этом происходит изменение суммы заблокированных средств и доступных лимитов.

Изменение кросс-курса валют

меню Расширения / Неторговые поручения / Задать кросс-курс...

Данное действие позволяет изменить кросс-курс валют, используемый в поручениях типа «Конвертация валют». Настройки в данном окне:

  • В поле слева из справочника валют выбирается код валюты для указания кросс-курса;
  • В поле справа выбирается код парной валюты, в единицах которой выражен кросс-курс;
  • В среднем поле отобразится кросс-курс для указанной пары валют, указанный в спра-вочнике Модуля неторговых поручений. Для изменения кросс-курса укажите в этом поле требуемое значение и нажмите кнопку «OK».

Для закрытия окна без сохранения изменений нажмите кнопку «Cancel».


Приложение. Сообщения об ошибках при работе с позициями

  1. «Ошибка в строке <номер строки> загружаемого файла <наименование файла>. Параметр <наименование параметра> имеет недопустимое значение <значение параметра>»
    • При загрузке позиций из файла обнаружена ошибка в синтаксисе. Проверьте правильность описания лимитов в указанной строке.
  2. «Не удалось открыть файл позиций <имя файла>»
    • Невозможно открыть файл, указанный для загрузки позиций.
  3. «Ошибка записи в файл»
    • Сохранение позиций в файл невозможно. Убедитесь, что файл не занят другим приложением.
  4. «Нельзя запустить динамическую коррекцию позиций с учетом совершенных сделок»
    • Ошибка выполнения операции. Свяжитесь с разработчиком программы для разрешения проблемы.
  5. «Невозможно открыть файл <имя файла>. Повторить попытку?»
    • Файл с коррекциями позиций недоступен для чтения. Убедитесь, что он не занят другой программой.
  6. «Не указан <параметр> в коррекции позиции»
    • Пропущен обязательный параметр в файле с коррекциями позиций.
  7. «Ошибка при открытии файла с журналом коррекции позиций»
    • Файл с журналом коррекций позиций занят другим приложением либо недостаточно прав на создание/редактирование файла.
  8. «Коррекция неправильно заполнена»
    • Данные в корректировке позиций не соответствуют друг другу. Например, код инструмента не соответствует счету депо.
  9. «<параметр> превышает допустимый размер»
    • Превышен максимальный размер параметра. Убедитесь, что он указан правильно.
  10. «Указанный <параметр> не найден»
    • Пропущен обязательный параметр корректировки позиций.
  11. «Неправильно указан <параметр> коррекции позиции»
    • Значение параметра не соответствует допустимым значениям.
  12. «Нельзя начать отправку коррекции позиций из файла»
    • Ошибка выполнения операции. Свяжитесь с разработчиком программы для разрешения проблемы.
  13. «Неверный формат файла коррекции позиций»
    • Файл с коррекциями позиций имеет ошибочный формат. Убедитесь, что параметры разделены правильными разделителями, и каждая корректировка позиций описана отдельной строкой.
  14. «Не указан способ коррекции позиции»
    • Пропущен обязательный параметр «LIMIT_OPERATION».
  15. «Неправильно указан способ коррекции позиции»
    • Значение параметра «LIMIT_OPERATION» не соответствует допустимым значениям.


Раздел 8. Алгоритмический язык QPILE

  • Общие положения
  • Работа с таблицами QPILE
  • Структура файла программы
  • Конструкции языка QPILE
  • Общие функции
  • Математические функции
  • Функции для работы с коллекциями объектов (COLLECTION)
  • Функции для работы с ассоциативными массивами (MAP)
  • Функции для обращения к строкам произвольных таблиц QUIK
  • Функции для обращения к спискам доступных параметров
  • Функции для работы с программируемой таблицей
  • Функции для получения значений Таблицы текущих торгов
  • Функции для получения значений Окна котировок
  • Функции для получения значений Таблицы позиций по инструментам
  • Функции для получения значений Таблицы позиций по деньгам
  • Функции расчета маржинальных позиций
  • Функции получения значений таблиц «Клиентский портфель» и «Купить/Продать»
  • Функции для работы с файлами
  • Функции для работы со строками
  • Функции для работы с графиками
  • Функции для работы с заявками
  • Функции для работы с метками
  • Сервисные функции
  • Отладка программ QPILE
  • Приложение

Раздел описывает применение алгоритмического языка QPILE, встроенного в рабочее место системы QUIK. В начале раздела рассматривается базовый функционал клиентского места, предназначенный для работы с программируемыми таблицами. Для пользователей, заинтересованных в разработке собственных программ в документации приводится описание конструкций языка QPILE и встроенных функций языка, а также пример реализации - расчет показателей маржинального кредитования по методике ФСФР.


Общие положения

  • Назначение
  • Как работает QPILE
  • Основные возможности
  • Функциональные ограничения

    • Назначение

    Язык QPILE - (QUIK Programmable Interface and Logic Environment) представляет собой набор команд, интерпретируемых рабочим местом QUIK.

    Областью применения QPILE является создание новых таблиц для расчета в режиме реального времени собственных показателей на основе информации из других таблиц.

    Данный функционал удобен, прежде всего, для брокера, так как у каждого брокера существует своя собственная стратегия расчета показателей клиентской позиции. Применение встроенного языка позволяет реализовать практически любой алгоритм.

    Примеры использования QPILE:

    1. Динамический пересчет стоимости активов клиентов на рабочем месте брокера.
    2. Динамический пересчет стоимости активов в портфеле клиента и его суммарной стоимости.
    3. Вычисление показателей, отсутствующих в системе QUIK либо торговой системе биржи, на основе собственных алгоритмов.
    4. Расчет параметров маржинального кредитования в соответствии с принятыми нормативами.
    5. Программирование торговой стратегии, генерирующей сигналы на изменение позиций по инструментам.

    Основной областью применения языка QPILE является расчет стоимости портфелей ценных бумаг, поэтому в терминологии описания типов таблиц часто используется определение «Портфели».

    Как работает QPILE

    1. Структура таблицы (назначение столбцов, строк, и формулы для вычисления параметров) описывается в виде программы на языке QPILE. Для вычисления в формулах можно использовать стандартные математические и логические операции, использовать переменные и массивы данных, запрашивать информацию из других таблиц системы QUIK.
    2. Код программы может быть получен с сервера QUIK (серверный) или загружен с диска на компьютере пользователя (локальный). Полученный код обрабатывается интерпретатором языка QPILE на рабочем месте QUIK, который производит пересчет значений в формулах с заданной периодичностью. Таким образом формируется внутренний источник данных для отображения полученных значений в таблицах. Несколько таблиц на основе одной и той же программы используют общий источник данных, при этом вычисления не будут дублироваться и снижать производительность системы.
    3. На основе программы можно создавать таблицы, обладающие стандартными функциями при работе с таблицами в системе QUIK.
    4. Рабочее место QUIK имеет встроенный отладчик кода программ на QPILE, позволяющий вести пошаговую отладку и контролировать текущие значения переменных. Подробнее см. Отладка программ QPILE.

    Нумерация строк в таблицах QPILE начинается с единицы, а нумерация символов в строках языка QPILE начинается с нуля.

    Основные возможности

    Основные функции языка QPILE:

    1. Описание новых таблиц произвольной структуры.
    2. Вычисление полей таблиц на основе математических формул и логических выражений.
    3. Выделение ячеек таблицы цветом в зависимости от значений какого-либо показателя.
    4. Уведомление пользователя звуковым сигналом и текстовыми сообщениями.

    Таблица на языке QPILE поддерживает основные действия с таблицами в системе QUIK:

    • Редактирование, в том числе выбор параметров для отображения и настройку их очередности;
    • Управление «горячими клавишами»;
    • Размещение на «экранных вкладках»;
    • Поиск значения в ячейках таблицы;
    • Печать таблицы с предварительным просмотром;
    • Копирование данных в Буфер Обмена Windows (Clipboard);
    • Экспорт данных через DDE сервер;
    • Экспорт данных по ODBC.

    В качестве исходных данных для расчетов параметров таблиц может использоваться информация из следующих типов таблиц QUIK, а также из графиков:

    № | Таблица | № | Таблица
1. | Таблица текущих торгов | 10. | Таблица заявок на внебиржевые сделки
2. | Таблица обезличенных сделок | 11. | Таблица сделок для исполнения
3. | Таблица заявок | 12. | Таблица заявок-отчетов на сделки РПС
4. | Таблица стоп-заявок | 13. | Таблица «Клиентский портфель»
5. | Таблица сделок | 14. | Таблица «Купить/Продать»
6. | Позиции по инструментам | 15. | Позиции участника по деньгам
7. | Позиции по деньгам | 16. | Позиции участника по инструментам
8. | Позиции по клиентским счетам | 17. | Позиции участника по торговым счетам
9. | Ограничения по клиентским счетам | 18. | Таблица, создаваемая при расчете программы

    Функциональные ограничения

    Текущая версия языка QPILE и созданные на его основе таблицы не поддерживают следующих операций:

    • Сортировку в таблицах;
    • Применение фильтров;
    • Использование таблицы в качестве источника данных для построения графиков;
    • Сохранение данных из таблицы в текстовый файл через контекстное меню;
    • Экспорт данных в системы технического анализа.


Работа с таблицами QPILE

  • Загрузка программы
  • Настройка параметров программы
  • Создание таблицы
  • Функции, доступные в таблице


Загрузка программы

Этот этап добавляет описания собственных таблиц в список доступных типов. Если предполагается работа с описаниями таблиц на сервере, его можно пропустить.

Загрузка кода программы выполняется выбором пункта меню программы Сервисы/ QPILE скрипты..., или нажатие клавиш «Ctrl»+«F11».

  1. Нажмите кнопку «Добавить» и выберите файл, загружаемый с диска. Файлы имеют стандартные расширения «.QPL». Название таблицы появится в списке «Доступные скрипты».
  2. При чтении файла осуществляется проверка правильности программы. Если программа содержит ошибки, система уведомит об этом в «Окне сообщений». В сообщении указывается имя файла и номер строки, в которой обнаружена ошибка.
  3. Если файл прочитан успешно, то в полях отобразятся соответствующие параметры:

    Поле | Назначение
    Текущий скрипт | Название таблицы
    Всего параметров | Число параметров (столбцов), описанных в структуре таблицы
    Всего клиентов Количество доступных кодов клиентов, из числа перечисленных в структуре таблицы.
    В новой версии языка параметр не актуален
    Фирмы | Перечень идентификаторов фирмы в торговой системе (значения, соответствующие полю «Дилер» в Таблице заявок или Таблице сделок)
    Клиенты | Перечень идентификаторов клиентов для отображения в таблице
    Параметры скрипта | Перечень описанных параметров и расширенные сведения по ним
    Формула расчета | Исходный код программы на языке QPILE

  4. Для загрузки прочитанной из файла таблицы нажмите кнопку «Загрузить локально».
  5. Кнопка «Загрузить на сервер» позволяет загрузить программу на сервер, которая станет доступна всем его пользователям. Право загрузки программ на сервер назначается администратором системы QUIK.

При локальной загрузке код исполняется на текущем рабочем месте и просмотр таблицы на его основе доступен тоже только на этом месте.

Рекомендации:

Первую загрузку каждого нового описания настоятельно рекомендуется производить локально, а уже после просмотра и проверки корректности его работы и расчета параметров – загружать на сервер.

См. также Настройка параметров программы.


Настройка параметров программы

Этот этап определяет список обрабатываемых программ и определяет периодичность вычислений. Если программы были загружены локально, то они автоматически помечаются выбранными.

Выбор доступных программ с описаниями типов таблиц выполняется выбором пункта меню программы Сервисы/ QPILE скрипты..., или нажатием клавиш «Ctrl»+«F11».

  1. В списке «Доступные скрипты» приведены все программы, доступные пользователю для создания таблиц, как загруженные локально, так и серверные. Выберите программу из числа доступных, установив на ней флажок. В полях диалога отобразятся параметры, относящиеся к структуре программируемой таблицы.
  2. Установите период расчета значений таблицы. Для исполнения программ с большим количеством вычислений период расчета значений рекомендуется устанавливать не менее 5-10 секунд.
  3. Нажмите кнопку «Сохранить как...» для сохранения настроек.
  4. Нажатие кнопки «Удалить» приводит к удалению из списка выбранной строки. Серверные типы таблиц удалить нельзя.
  5. Нажатием кнопки «Формула» открывается окно с исходным кодом программы и описанием таблицы (справочно).
  6. Нажатие кнопки «Создать таблицу» открывается окно «Создать таблицу для просмотра параметров скрипта».
  7. Чтобы закрыть окно с сохранением настроек, нажмите кнопку «Применить». Нажатие кнопки «Отмена» закрывает окно без сохранения изменений.
Рекомендации:

Настройки данного этапа распространяются и на ранее созданные программируемые таблицы. Этот этап можно использовать для включения/отключения вычислений в таблицах, а также для регулирования частоты обновления данных в них.

Применение настроек к существующим таблицам:

  • Как отключить пересчет значений в таблице?
    • Выберите пункт контекстного меню «Приостановить расчет» либо нажмите «Ctrl»+«F11» и снимите флажок с требуемого типа таблицы. При этом в таблице будут отображены последние вычисленные значения;
    • Если по одной программе было сформировано несколько таблиц, то расчет приостановится во всех этих таблицах;
    • Для отключения пересчета во всех таблицах нужно нажать «Ctrl»+«F11» и снять все флажки.
  • Как изменить период расчета в существующей таблице?
    • Выберите пункт контекстного меню «Параметры скрипта» или нажмите «Ctrl»+«F11», затем измените значение параметра «Период расчета (сек)» и нажмите кнопку «Применить».

    См. также Загрузка программы.


Создание таблицы

Этот этап формирует таблицу на основании программы. На базе одной программы можно создать несколько таблиц для удобства их расположения на экране.

Создание программируемой таблицы выполняется нажатием кнопки «Создать таблицу» в окне «Работа со скриптами».

  1. Выберите программу в списке «Доступные скрипты». В полях раздела «Текущий скрипт» отобразятся данные по структуре таблицы.
  2. Если необходимо, ограничьте количество отображаемых строк в таблице с помощью фильтра «Фильтр клиентов».
  3. Сформируйте список столбцов таблицы из числа доступных параметров и последовательность их отображения в таблице. В поле «Описание параметра» справочно приводится расширенное описание выделенного параметра.
  4. Нажатием кнопки «Да» создается таблица.

Полученная таблица имеет такие же функции управления, как и другие таблицы системы QUIK. Например, для редактирования таблицы можно нажать кнопку [image] на панели инструментов, или клавиши «Ctrl»+«E».
Расчет параметров таблицы ведется в том числе на основе Таблицы текущих торгов. Убедитесь, что необходимые для расчета параметров данные принимаются с сервера (не отключены фильтром в списке принимаемых параметров и инструментов).

См. также Функции, доступные в таблице.


Функции, доступные в таблице

Данные таблицы доступны для копирования, также экспорта через ODBC и DDE-сервер.

Функции, доступные из контекстного меню таблицы:

  • «Приостановить расчет» – остановить вычисление параметров таблицы (при этом в таблице отображаются последние вычисленные данные);
  • «Возобновить расчет» – возобновляет вычисление параметров таблицы, если он был остановлен;
  • «Начать расчет заново» – сбросить все значения и начать расчет заново;
  • «Начать расчет в режиме отладки» – сбрасывает все значения, запускает окно отладки и начинает расчет заново;
  • «Сохранить описание в файл» – сохранить в текстовый файл программу, описывающую данную таблицу;
  • «Посмотреть формулу» – показать в окне код программы данной таблицы;
  • «Параметры скрипта» – открыть окно с параметрами программы, в том числе период расчета в секундах.

Дополнительно:

  • Описание стандартных функций контекстного меню для таблиц;
  • Описание применения пользовательских фильтров и условного форматирования таблиц;
  • Полный список управляющих клавиш для всех типов таблиц.


Структура файла программы

Файл с кодом программы представляет собой текстовый файл в кодировке CP-1251 (Windows). Один файл служит для описания одного типа таблицы. Используются стандартные расширения имени файлов «.QPL».

Описание состоит из трех частей:

  1. «Заголовок» – наименование таблицы и определение основных параметров.
  2. «Тело программы» – собственно код программы.
  3. «Описание столбцов таблицы» – определение названий столбцов и формата соответствующих им ячеек таблицы.

Все разделы являются обязательными и должны следовать строго друг за другом. Файл всегда начинается с заголовка и заканчивается строкой «END_PORTFOLIO» (в новой версии языка должно применяться «END_PORTFOLIO_EX»).

Примеры файлов см. в папке QPILE, которая поставляется вместе с Руководством пользователя.


Заголовок файла

Заголовок файла содержит основные параметры таблицы:

Параметр | Назначение
PORTFOLIO
PORTFOLIO_EX

Название таблицы – символьный идентификатор латинскими буквами без пробелов.

  • «PORTFOLIO» – параметр, применявшийся в первой версии языка;
  • «PORTFOLIO_EX» - обозначение программы на расширенной версии языка (начиная с версии QUIK 4.09)
DESCRIPTION | Текстовое описание таблицы
* CLIENTS_LIST Список кодов клиентов через запятую, для которых вычисляются значения в таблице.
Значение «ALL_CLIENTS» соответствует выбору всех кодов клиентов.
Значения по каждому счету клиента формируют новую строку таблицы
FIRMS_LIST | Список идентификаторов фирм (участников торгов) через запятую, клиентам которых будет доступна данная таблица

* - параметр предыдущей версии языка, в текущей версии является необязательным

Каждый параметр должен быть описан на отдельной строке и заканчиваться символом «;».

Пример заголовка:

PORTFOLIO AVAILABLE_MONEY;
DESCRIPTION Доступные деньги клиента;
CLIENTS_LIST ALL_CLIENTS;
FIRMS_LIST MC0012300000;

Данная таблица будет отображаться в списке доступных с именем «AVAILABLE_MONEY». При выборе доступных описаний таблиц в поле «Текущий скрипт» отобразится «Доступные деньги клиента». Это же наименование будет являться заголовком таблицы, принимаемым по умолчанию. Расчет параметров осуществляется по всем счетам клиентов, доступных пользователю в таблицах позиций и имеющих код фирмы «MC0012300000».

См. также:

  • Тело программы
  • Определение столбцов таблицы


Тело программы

Раздел содержит код программы для расчета значений в ячейках таблицы. Начало раздела обозначается строкой «PROGRAM», окончание - строкой «END_PROGRAM». Для выхода из тела программы используется оператор «RETURN».

  1. Регистр символов (верхний или нижний) в командах по умолчанию игнорируется интерпретатором. Все строковые константы переводятся автоматически в верхний регистр. Но в случае необходимости можно отменить автоматический перевод символов в верхний регистр. Для этого необходимо между заголовком и телом программы добавить следующую строку:
    USE_CASE_SENSITIVE_CONSTANTS

    При добавлении указанного ключа значения строковых переменных не будут переводиться в верхний регистр, а будут оставаться такими, какие они есть.

  2. Множественные пробелы игнорируются интерпретатором, за исключением пробелов внутри строковых переменных.
  3. Для переноса длинных строк используется комбинация «<пробел>_» в конце строки. Например:
    CLIENTS_LIST 0001, 0002, 0003, 0004, 0005, 0006, 0007, 0008, 0009, 0010, _
    0011, 0012, 0013, 0014, 0015;
  4. Символ «’» является комментарием. Комментарий распространяется до конца строки.
  5. Разделителем операторов служит перевод строки, т.е. каждый оператор описывается отдельной строкой.
  6. Нумерация символов в строке начинается с нуля.

Пример программы:

PROGRAM

 FirmCode = "MC0012300000"

 CurrentBalance = MONEY_CURRENT_BALANCE(ROWNAME,FirmCode, "EQTV", "SUR")

 CurrentLimit = MONEY_CURRENT_LIMIT(ROWNAME, FirmCode, "EQTV", "SUR")

 Locked = MONEY_LIMIT_LOCKED(ROWNAME, FirmCode, "EQTV", "SUR")

 AvailableMoney = MoneyCurrentBalance + MoneyCurrentLimit – MoneyLocked

 If AvailableMoney > 0

  Status = "Заявки доступны"

 Else

  Status = "Заявки недоступны"

  SET_ROW_COLOR(ROWNAME, "RGB(255,138,138)", "DEFAULT_COLOR")

 End If

END_PROGRAM

Пример относится к формированию таблицы «Доступные деньги клиента». Создаваемая таблица будет частично дублировать поля таблицы «Позиции по деньгам», а также содержать два вычисляемых поля.

См. также:

  • Заголовок файла
  • Определение столбцов таблицы


Определение столбцов таблицы

Для отображения в таблице вычисленных значений необходимо описать ее столбцы и формат соответствующих им ячеек таблицы. Для этого предназначен данный раздел файла.

Каждый столбец таблицы описывается следующим набором параметров:

Параметр | Назначение
PARAMETER | Название переменной в программе (максимальная длина 31 символ), значение которой будет отображаться в данном столбце
PARAMETER_TITLE | Название столбца (максимальная длина 31 символ), отображаемое в таблице
PARAMETER_DESCRIPTION | Расширенное описание параметра (максимальная длина 127 символов)
PARAMETER_TYPE

Формат данных в ячейках таблицы, относящихся к столбцу. Возможны два типа данных:

  • NUMERIC(<размер_числа_в_символах>, <кол_во_знаков_после_запятой>) - двойные с плавающей точкой (double);
  • STRING(<длина_строки>) - строковые (string)

Описание каждого параметра завершается строкой «END».

После описания параметров в конце файла обязательно должна быть строка «END_PORTFOLIO» для первой версии языка, либо «END_PORTFOLIO_EX» для его новой версии.

Пример описания:

PARAMETER AvailableMoney;
PARAMETER_TITLE Доступно;
PARAMETER_DESCRIPTION Доступные деньги клиента;
PARAMETER_TYPE NUMERIC(10,2);
END

Значения переменной «AvailableMoney» будут отображаться в столбце таблицы «Доступно». При настройке таблицы в поле «Описание параметра» отображается текст «Доступные деньги клиента». Данные в столбце будут отображаться в виде числа с двумя знаками после запятой. Этот же формат данных рекомендуется указывать при настройке экспорта из таблицы по ODBC.

См. также:

  • Заголовок файла
  • Тело программы


Подключение дополнительных файлов

Для подключения дополнительных файлов с функциями к программе используется раздел INCLUDE. Данный раздел размещается между заголовком и телом программы и описывается следующим образом:

INCLUDE file1, file2,…,fileN;

где file1, file2,…,fileN – относительные или полные пути файлов с описанием функций (прописываются через запятую).

Пример описания:

INCLUDE C:/Program Files/ADDITION/object_1, C:/Program Files/ADDITION/object_2;


Конструкции языка QPILE

  • Типы данных
  • Приведение типов
  • Выражения
  • Условия
  • Циклы
  • Функции


Типы данных

  1. Различаются следующие типы данных:
    • «STRING» - строковый;

      «Суммарный спрос»

    • «DOUBLE» - вещественный, или число с плавающей точкой.Точность – 15 десятичных разрядов, но не более 8 знаков после запятой;

      1234567.89

    • «COLLECTION» - коллекция,

      Коллекция является списком объектов, с индексацией по целочисленному ключу (начиная с 0);

      0

      1

      2

      3

      «HYDR» 12 7.890 «BUY»

    • «MAP» - ассоциативный массив.

    Ассоциативный массив (MAP) является последовательностью пар (ключ, значение), которая обеспечивает получение значения по ключу. Каждому ключу соответствует максимум одно значение, иными словами, каждый ключ в ассоциативном массиве уникален. В качестве ключа всегда выступает строковое значение.

    «NUMBER»

    «TIME»

    «OPERATION»

    67890 «12:34:56» «BUY»

  2. Типы данных «COLLECTION» и «MAP» являются структурными. Они могут:
    • Быть неоднородными, т.е. содержать значения разных типов;
    • Содержать в качестве значений элементы любых типов, в том числе и переменные типов «COLLECTION» и «MAP».
  3. Область видимости всех переменных, кроме формальных параметров, является глобальной и определяется контекстом исполнения. Если в процессе исполнения переменная была присвоена, то она считается определенной до конца исполнения программы.

    Переменные, сохраняющие свои значения между периодами расчета программы, именуются глобальными. Глобальные переменные описываются специальной функцией «NEW_GLOBAL ()» (см. Общие функции).
  4. Количество используемых в программе переменных ограничено 1000.


Приведение типов

  1. Переменные языка не типизированы и могут изменять тип данных в процессе исполнения программы.
  2. Применение операций «+», «-», «*», «/» к строковым переменным приводит их к вещественным значениям. Если такое приведение не возможно, то вещественное значение принимается равным «0.0». Для структурных переменных результат этих операций не определен.
  3. Операция сравнения вещественных и строковых переменных допустима только для переменных со значениями одного типа. Для переменных структурных типов «COLLECTION» и «MAP» результат сравнения не определен.
  4. Применение операции конкатенации строк «&» к вещественным переменным приводит их значения к строковым.
  5. При вызове внешних функций всегда осуществляется приведение типов аргументов.
  6. Изменение значений переменных структурных типов и обращение к их полям выполняется специальными функциями (см. Функции для работы с коллекциями объектов (COLLECTION), Функции для работы с ассоциативными массивами (MAP)).


Выражения

  1. Приоритет выполнения математических операций («+», «-», «*», «/», унарный «-») является стандартным.
  2. Логические операции имеют одинаковый приоритет (за исключением «AND» и «OR») и исполняются слева направо. «AND» и «OR» исполняются в последнюю очередь, слева направо.

    Например:

    A < B or A = C равносильно (A < B) or (A = C)

  3. В выражениях и сравнениях возможно использование скобок.

    Допустимые выражения:

    Операция | Значение

    Математические
    + Сложение
    - Вычитание
    * Умножение
    / Деление
    Унарный «-» | Смена знака в значении на противоположный
    D или E | Экспоненциальная форма записи числа, «3D2» равносильно 3*10^2

    Логические
    == Равенство
    = Равенство, аналогично предыдущему
    > Больше
    < Меньше
    >= Больше или равно
    <= Меньше или равно
    != Не равно
    <> Не равно , аналогично предыдущему
    AND | Логическое «И»
    OR | Логическое «ИЛИ»

    Текстовые
    & Склейка (конкатенация) строк

При присвоении значения переменной необходимо использовать приведение типов данных. Например, выражение A=«3E2»+0 даст результат 300, в отличие от А=«5E3», которым переменной будет присвоено строковое выражение «5E3».


Условия

Синтаксис оператора условия:

IF условие
                   последовательность инструкций
ELSE
                   последовательность инструкций
END IF

«Условием» является логическое выражение. Вложенность операторов условия не ограничена. В операторе «END IF» допускается только один пробел.

Пример:

IF DealerMoney =0

    Margin = 100

ELSE
    Margin=0

END IF


Циклы

Синтаксис оператора цикла:

  1. Выполняет «последовательность инструкций» для каждого значения «переменной», входящего в «список значений». «Список значений» определяется переменной типа «STRING» со значениями, перечисленными через запятую.
    FOR переменная IN список значений

                    последовательность инструкций
    END FOR
  2. Выполняет последовательность инструкций для каждого значения переменной в диапазоне от «значение1» до «значение2» с шагом 1, в качестве которых могут выступать математические выражения. Если «значение2» < «значение1», цикл не обрабатывается.
    FOR переменная FROM значение1 TO значение2

                    последовательность инструкций
    END FOR

Вложенность операторов цикла не ограничена. В операторе «END FOR» допускается только один пробел.

Пример:

FkcbSecsList = "HYDR,SBER,MSNG,LKOH,YUKO,RTKM"

FOR Sec IN FkcbSecsList

                DCPos = DEPO_CURRENT_BALANCE(ROWNAME, FirmList, Sec, DefDepoAcc)

                DCLim = DEPO_CURRENT_LIMIT(ROWNAME, FirmList, Sec, DefDepoAcc)

                DOLim = DEPO_OPEN_LIMIT(ROWNAME, FirmList, Sec, DefDepoAcc)

                SecPos = DCPos + DCLim - DOLim

                SecPos = SecPos * GET_PARAM(ClassCode, Sec, "LAST") *GET_PARAM(ClassCode, Sec, "LOTSIZE")

                DepoPos = DepoPos +ignore_negative(SecPos)

                DealerMoney = DealerMoney + dealer(SecPos)

END FOR

Данный цикл перебирает все инструменты из списка инструментов «FkcbSecsList» и по каждому инструменту обрабатывает позицию по этому инструменту для текущего рассчитываемого клиента.

Для прерывания цикла до его окончания служит оператор «BREAK». Он прерывает выполнение оператора «FOR» и передает управление следующему за ним оператору.

Для передачи управления на следующую итерацию оператора «FOR» служит оператор «CONTINUE». В операторе «FOR» следующая итерация начинается вычислением выражения цикла оператора «FOR». После вычисления условного выражения в зависимости от его результатов происходит либо прекращение выполнения оператора либо выполнение его тела.


Функции

  • Общие положения
  • Функции языка QPILE

    • Общие положения

    1. Описания функций могут находиться в любом месте программы.
    2. Все функции должны иметь различные имена – перегрузка по типу параметров и их количеству не осуществляется.
    3. Функции могут возвращать значение с помощью переменной с именем «RESULT».
    4. Все параметры передаются в функции по значению.
    5. Функция может являться процедурой. В этом случае в месте вызова такой функции не используется возвращаемое значение, и присваивание переменной с именем «RESULT» внутри такой функции не обязательно.
    6. Для выхода из тела функции может использоваться оператор «RETURN».

    1. В описании синтаксиса функций, возвращающих или принимающих переменную любого типа, для обозначения применяется тип «ANY».
    2. Таблица, создаваемая при расчете программы, обозначается «OWN».

    Функции, определенные пользователем, имеют следующий синтаксис:

    FUNC функция (список
аргументов)
    последовательность инструкций
    END FUNC

    В операторе «END FUNC» допускается только один пробел.

    Пример:

    FUNC ignore_negative(x)

               If x > 0

                          RESULT =x

               Else

                          RESULT = 0

               End If

    END FUNC

    Функции языка QPILE

    Стандартные функции языка QPILE предназначены для работы со структурными типами переменных и получения значений из таблиц QUIK.

    Функция | Назначение
    NEW_GLOBAL | Инициализация глобальной переменной
    MESSAGE | Вывод текста в Окне сообщений

    Математические функции

    ABS | Модуль
    ACOS | Арккосинус
    ASIN | Арксинус
    ATAN | Арктангенс
    CEIL | Округление вверх
    COS | Косинус
    EXP | Экспонент
    FLOOR | Округление вниз
    LOG | Логарифм
    POW | Возведение в степень
    RAND | Случайное число
    RANDOMIZE | Генерация случайных чисел
    SIN | Синус
    SQRT | Квадратный корень числа
    TAN | Тангенс

    Функции для работы с коллекциями объектов

    CREATE_COLLECTION | Определение коллекции
    GET_COLLECTION_COUNT | Количество элементов в коллекции
    REMOVE_COLLECTION_ITEM | Удаление элемента коллекции
    INSERT_COLLECTION_ITEM | Вставка элемента коллекции
    SET_COLLECTION_ITEM | Замена значения элемента коллекции
    GET_COLLECTION_ITEM | Чтение значения элемента коллекции

    Функции для работы с ассоциативными массивами

    CREATE_MAP | Определение массива
    SET_VALUE | Добавление нового элемента в массив
    GET_VALUE | Чтение значения элемента из массива

    Функции для обращения к строкам произвольных таблиц QUIK

    GET_ITEM | Строка с указанным номером из таблицы QUIK
    GET_NUMBER_OF | Количество записей в указанной таблице QUIK

    Функции для обращения к спискам доступных параметров

    GET_CLASSES_LIST | Список кодов классов, доступных в текущем сеансе связи
    GET_CLASS_SECURITIES | Список кодов инструментов для заданного списка классов
    GET_SECURITY_INFO | Информация по инструменту с определенным кодом из заданного класса

    Функции для работы с программируемой таблицей

    ADD_ITEM | Добавление новой строки в таблицу
    MODIFY_ITEM | Изменение указанной строки таблицы
    DELETE_ITEM | Удаление указанной строки таблицы
    DELETE_ALL_ITEMS | Очистка всех значений таблицы
    SET_ROW_COLOR | Указание цвета подсветки для строки таблицы
    SET_ROW_COLOR_EX | Указание цвета фона и шрифта для строки таблицы

    Функции для получения значений Таблицы текущих торгов

    GET_PARAM* | Получение значений из Таблицы текущих торгов
    GET_PARAM_EX | Получение всех значений из Таблицы текущих торгов

    Функции для получения значений Окна котировок

    GET_QUOTES_II_LEVEL_DATA | Получение значений из Таблицы котировок

    Функции для получения значений таблицы «Позиции по инструментам» *

    DEPO_OPEN_BALANCE | Входящий остаток по инструментам
    DEPO_OPEN_LIMIT | Входящий лимит по инструментам
    DEPO_CURRENT_BALANCE | Текущий остаток по инструментам
    DEPO_CURRENT_LIMIT | Текущий лимит по инструментам
    DEPO_LIMIT_AVAILABLE | Доступное количество инструментов
    DEPO_LIMIT_LOCKED | Заблокированное Количество лотов инструментов
    DEPO_LIMIT_LOCKED_BUY | Количество лотов инструментов, заблокированных на покупку
    DEPO_LIMIT_LOCKED_BUY_VALUE | Стоимость инструментов, заблокированных на покупку

    Функции для получения значений таблицы «Позиции по деньгам» *

    MONEY_OPEN_BALANCE | Входящий остаток по денежным средствам
    MONEY_OPEN_LIMIT | Входящий лимит по денежным средствам
    MONEY_CURRENT_BALANCE | Текущий остаток по денежным средствам
    MONEY_CURRENT_LIMIT | Текущий лимит по денежным средствам
    MONEY_LIMIT_AVAILABLE | Доступное количество денежных средств
    MONEY_LIMIT_LOCKED | Заблокированное в заявках на покупку количество денежных средств

    Функции расчета маржинальных позиций

    SHORT_VALUE | Стоимость всех коротких значений
    LONG_VALUE | Стоимость всех длинных позиций

    Функции получения значений таблиц «Клиентский портфель» и «Купить/Продать»

    GET_CLIENT_MARGINAL_PORTFOLIO_INFO | Значения параметров таблицы «Клиентский портфель»
    GET_CLIENT_MARGINAL_BUY_SELL_INFO | Значение параметров таблицы «Купить/Продать»

    Функции для работы с файлами

    CLEAR_FILE | Очистить файл
    WRITE | Записать строку в конец файла
    WRITELN | Записать строку с переводом строки в конец файла
    GET_FILE_LEN | Количество строк в файле
    READ_LINE | Прочитать из файла строку с заданным номером

    Функции для работы со строками

    LEN | Количество символов в строке
    TRIM | Отсечение пробелов в конце строки
    SUBSTR | Подстрока
    FIND | Поиск в строке позиции подстроки

    Функции для работы с графиками

    GET_CANDLE | Значения цен и объемов (OHLCV) «свечи» на графике и ее индикаторов
    GET_CANDLE_EX | Значения цен и объемов (OHLCV) «свечи» на графике и ее индикаторов, состоящих из нескольких линий

    Функции для работы с заявками

    SEND_TRANSACTION | Ввод новой заявки

    Функции для работы с метками

    ADD_LABEL | Добавить метку
    DELETE_LABEL | Удалить метку
    DELETE_ALL_LABELS | Удалить все метки
    GET_LABEL_PARAMS | Получить параметры метки
    SET_LABEL_PARAMS | Задать параметры метки

    Сервисные функции
    GET_TRADE_DATE | Дата текущей торговой сессии
    GET_DATETIME | Текущие дата и время
    APPLY_SCALE | Округление с заданной точностью
    IS_CONNECTED | Определить состояние подключения клиенткого места к серверу
    GET_INFO_PARAM | Позволяет получить параметры для информационного окна (пункт меню Система/О программе/Информационное окно)
    BREAKPOINT | Позволяет прервать выполнение программы и вызвать окно «Отладка»

    * - функции предыдущей версии языка QPILE, сохраненные для совместимости. Значения, возвращаемые этими функциями, также могут быть получены чтением строки таблицы функцией «GET_ITEM» и выборкой из нее значения функцией «GET_VALUE»

    Функции предыдущих версий, поддержка которых прекращена:

    • MONEY_LIMIT_LOCKED_NONMARGINAL_VALUE


Общие функции

  • NEW_GLOBAL
  • MESSAGE

    • NEW_GLOBAL

    Функция предназначена для инициализации глобальной переменной. Глобальная переменная сохраняет свое значение между итерациями вычислений значений таблицы. Инициализация может быть выполнена переменной любого типа, при этом создается глобальная переменная соответствующего типа.

    NEW_GLOBAL (STRING Name, ANY InitValue)

    Параметры:

    № | Параметр | Тип | Описание
1 | NAME | STRING | Строковое имя создаваемой переменной
2 | INITVALUE | ANY | Значение для инициализации глобальной переменной

    В качестве первого параметра может фигурировать строковая константа, либо же переменная, имеющая строковое значение. В последнем случае создается глобальная переменная с тем же именем, что и значение этой строковой переменной.

    Пример:

    ‘
    NEW_GLOBAL("GLOBAL","MyFirstGlobal")
    NEW_GLOBAL(Global,1)
    ‘

    После выполнения этих двух строк будут созданы две глобальные переменные. Строковая переменная с именем «GLOBAL» и значением «MyFirstGlobal», а также вещественная переменная с именем «MyFirstGlobal» и значением 1.

    MESSAGE

    Открывает Окно сообщений с заданным текстом.

    MESSAGE (STRING Text, DOUBLE Msg_type)

    Параметры:

    № Параметр Тип Описание
    1 TEXT STRING Текст сообщения
    2 MSG_TYPE DOUBLE

    Тип сообщения, определяющий вид иконки в Окне и звуковой сигнал. Возможные значения:

    • 1 – «Информация»;
    • 2 – «Внимание»;
    • 3 – «Ошибка»

    Пример:

    ‘
    MESSAGE ("Hello!",1)
    ‘


Математические функции

ABS

Возвращает модуль числа.

DOUBLE ABS (DOUBLE Value)

ACOS

Возвращает значение арккосинуса аргумента.

DOUBLE ACOS (DOUBLE Value)

ASIN

Возвращает значение арксинуса аргумента.

DOUBLE ASIN (DOUBLE Value)

ATAN

Возвращает значение арктангенса аргумента.

DOUBLE ATAN (DOUBLE Value)

CEIL

Возвращает ближайшее целое число, большее или равное аргументу.

DOUBLE CEIL (DOUBLE Value)

COS

Возвращает значение косинуса аргумента.

DOUBLE COS (DOUBLE Value)

EXP

Вычисление экспонента от аргумента.

DOUBLE EXP (DOUBLE Value)

FLOOR

Возвращает ближайшее целое число, меньшее аргумента.

DOUBLE FLOOR (DOUBLE Value)

LOG

Вычисление натурального логарифма от аргумента

DOUBLE LOG (DOUBLE Value)

POW

Возведение аргумента в степень.

DOUBLE POW (DOUBLE Value, DOUBLE Power)

RAND

Возвращает случайное целочисленное значение в диапазоне от 0 до 32767.

DOUBLE RAND ()

RANDOMIZE

Генерация случайных чисел.

DOUBLE RANDОMIZE ()

Функция инициализирует генератор случайных чисел для определения случайной последовательности генерируемых чисел. Функцию RANDОMIZE () необходимо вызвать до того, как будет использоваться функция RAND().

SIN

Возвращает значение синуса аргумента.

DOUBLE SIN (DOUBLE Value)

SQRT

Возвращает значение квадратного корня аргумента.

DOUBLE SQRT (DOUBLE Value)

TAN

Возвращает значение тангенса аргумента.

DOUBLE TAN (DOUBLE Value)

Пример:

MESSAGE ("ACOS 0.5 - " & acos(0.5),1)

MESSAGE ("ASIN 0.5 - " & asin(0.5),1)

MESSAGE ("ATAN 2   - " & atan(2),1)

MESSAGE ("CEIL 2.2 - " & ceil(2.2),1)

MESSAGE ("COS 0.5 - " &cos(0.5),1)

MESSAGE ("EXP 2 - " &exp(2),1)

MESSAGE ("FLOOR 4.5 - " &floor(4.5),1)

MESSAGE ("LOG 0.5 - " &log(0.5),1)

MESSAGE ("POW 2,3 - " &pow(2,3),1)

MESSAGE ("RAND - " &rand(),1)

MESSAGE ("SIN 0.5 - " &sin(0.5),1)

MESSAGE ("SQRT 2 - " &sqrt(2),1)

MESSAGE ("TAN 0.5 - " &tan(0.5),1)

При выполнении примера на экране будет появляться Окно сообщений с отображением функции и результата вычисления ее значения.


Функции для работы с коллекциями объектов (COLLECTION)

Функции из этой группы предназначены для оперирования переменными типа COLLECTION.

Коллекция является списком объектов, с индексацией по целочисленному ключу (начиная с 0). Коллекция может содержать элементы любых типов, в том числе и переменные типа COLLECTION. Коллекция может быть неоднородной, т.е. содержать объекты разных типов. В текущей реализации доступ к элементу коллекции по индексу осуществляется за линейное время.

CREATE_COLLECTION

Первая функция создает пустую коллекцию, вторая является конструктором копирования.

COLLECTION CREATE_COLLECTION ()

COLLECTION CREATE_COLLECTION (COLLECTION IntValue)

GET_COLLECTION_COUNT

Функция возвращает количество элементов в коллекции.

DOUBLE GET_COLLECTION_COUNT (COLLECTION Name)

REMOVE_COLLECTION_ITEM

Функция удаляет элемент с индексом «index» из коллекции «Name».

COLLECTION REMOVE_COLLECTION_ITEM (COLLECTION Name, DOUBLE index)

INSERT_COLLECTION_ITEM

Функция вставляет значение «value» в качестве элемента с индексом «index».

Выполняется вставка в коллекцию элемента с индексом «index», существующий элемент коллекции с индексом «index» сдвигается на единицу в элемент с индексом «index+1», и т.д. для всех существующих элементов, индекс которых равен или больше значения индекса вставки. См. Пример .

COLLECTION INSERT_COLLECTION_ITEM (COLLECTION Name, DOUBLE index, ANY value)

SET_COLLECTION_ITEM

Функция заменяет значение элемента с индексом «index» на значение «value».

COLLECTION SET_COLLECTION_ITEM (COLLECTION Name, DOUBLE index, ANY value)

GET_COLLECTION_ITEM

Функция возвращает значение элемента с индексом «index».

ANY GET_COLLECTION_ITEM (COLLECTION Name, DOUBLE index)

Параметры:

№ | Параметр | Тип | Описание
1 | INTVALUE | COLLECTION | Коллекция для инициализации вновь создаваемого объекта
2 | NAME | STRING | Имя коллекции
3 | INDEX | DOUBLE | Индекс для обращения к коллекции. Должен содержать целочисленное значение
4 | VALUE | ANY | Значение произвольного типа для включения в коллекцию

Пример:

‘

col=CREATE_COLLECTION()
FOR i FROM 0 TO 9

      col=INSERT_COLLECTION_ITEM(col,0,0)

      col=SET_COLLECTION_ITEM(col,0,i)

END FOR
s = GET_COLLECTION_ITEM(col,5)
len = GET_COLLECTION_COUNT(col)

‘

Создается пустая коллекция. Затем 10 раз в коллекцию вставляется нулевой элемент со значением 0 и тут же его значение меняется на значение переменной цикла. В результате получается коллекция из 10-ти элементов. После выполнения программы «s»=4, «len»=10, а «col» имеет следующий вид:

0

1

2

3

4

5

6

7

8

9
9 8 7 6 5 4 3 2 1 0


Функции для работы с ассоциативными массивами (MAP)

Функции из этой группы предназначены для оперирования переменными типа MAP.

Ассоциативный массив (MAP) является последовательностью пар (ключ, значение), которая обеспечивает получение значения по ключу. Каждому ключу соответствует максимум одно значение. Ассоциативный массив может содержать элементы любых типов, в том числе и переменные структурных типов, разные элементы такого массива могут содержать объекты разных типов в качестве значений. В качестве ключа всегда выступает строковое значение. В текущей реализации доступ к элементу коллекции по ключу осуществляется за линейное время.

CREATE_MAP

Первая функция создает пустой массив, вторая является конструктором копирования.

MAP CREATE_MAP ()

MAP CREATE_MAP (MAP IntValue)

SET_VALUE

Функция добавляет в массив «Name» элемент со значением «Value» и ключом «Key». Если массив уже содержал элемент с ключом «Key», то значение этого элемента заменяется на «Value». Функция возвращает модифицированный массив.

MAP SET_VALUE(MAP Name, STRING Key, ANY Value)

GET_VALUE

Функция возвращает значение элемента с ключом «Key» из массива «Name». Если элемент не найден, то возвращается пустая строка.

STRING GET_VALUE(MAP Name, STRING Key)

Параметры:

№ | Параметр | Тип | Описание
1 | INTVALUE | MAP | Массив для инициализации вновь создаваемого объекта
2 | NAME | STRING | Имя массива
3 | KEY | STRING | Значение ключа для вставки или доступа к элементу массива
4 | VALUE | ANY | Значение произвольного типа для добавления в массив

Пример:

‘
map=CREATE_MAP ()
FOR i FROM 0 TO 9

     map=SET_VALUE(map, "key" & i, i)

END FOR

s = GET_VALUE(map,"key5")

‘

Создается пустой массив. Затем, в цикле, в массив вставляются элементы со значением равным переменной цикла и ключом вида «"key" & i». После выполнения программы «s»=5.

Функция возвращает значение типа STRING, если оно не будет явно преобразовано к типу DOUBLE.

Пример:

RES=0+GET_VALUE


Функции для обращения к строкам произвольных таблиц QUIK

Функции из этой группы предназначены для доступа к данным, содержащимся в таблицах Рабочего места QUIK.

GET_ITEM

Функция возвращает ассоциативный массив (MAP), содержащий информацию о данных из строки с номером «Index» из таблицы с именем «TableName».

MAP GET_ITEM(STRING TableName,DOUBLE Index)

Возвращаемый массив, в качестве своих элементов, содержит значения ячеек таблицы клиентского места, ключами элементов являются названия колонок. Возможные значения поля «TableName» и ключей приведены ниже в таблицах. Для программируемой таблицы «OWN» значения ключей соответствуют названиям колонок, указанным в секции описания параметров.

GET_NUMBER_OF

Функция возвращает количество записей в таблице TableName.

DOUBLE GET_NUMBER_OF(STRING TableName)

Параметры:

№ | Параметр | Тип | Описание
1 | TABLENAME | STRING | Имя таблицы QUIK
2 | INDEX | DOUBLE | Индекс для обращения к коллекции. Должен содержать целочисленное значение

Пример:

‘
n=GET_NUMBER_OF("ALL_TRADES")

value=0
FOR i FROM 1 to n

        trade = GET_ITEM ("ALL_TRADES", i)

        value = value + GET_VALUE (trade, "VALUE")

END FOR

‘

В данном примере сначала запрашивается количество записей в таблице обезличенных сделок, затем в цикле для каждой записи получается соответствующий MAP из которого достается значение по ключу «VALUE». В итоге, переменная «value» содержит суммарный объем обезличенных сделок на данный момент.


Описание таблиц используемых в функциях «GET_NUMBER_OF» и «GET_ITEM»

Таблицы, используемые в функциях «GET_NUMBER_OF» и «GET_ITEM»:

TableName | Таблица
ORDERS | Заявки
STOP_ORDERS | Стоп заявки
TRADES | Сделки
ALL_TRADES | Обезличенные сделки
MONEY_LIMITS | Позиции по денежным средствам
DEPO_LIMITS | Позиции по инструментам
FUTURES_CLIENT_HOLDINGS | Позиции по клиентским счетам (фьючерсы)
FUTURES_CLIENT_LIMITS | Ограничения по клиентским счетам (фьючерсы)
NEG_DEALS | Таблица заявок на внебиржевые сделки
NEGOTIATION_TRADES | Таблица сделок для исполнения
NEG_DEAL_REPORTS | Таблица заявок-отчетов на сделки РПС
POSITIONS | Позиции участника по деньгам
FIRM_HOLDING | Позиции участника по инструментам
ACCOUNT_BALANCE | Позиции участника по торговым счетам
OWN | Таблица, создаваемая при расчете программы


Параметры Таблицы заявок, возвращаемые функцией «GET_ITEM»

№ Параметр Тип Описание Возможные значения
1 | NUMBER | DOUBLE | Номер заявки в торговой системе
2 | EXCHANGE_CODE | STRING | Код биржи в торговой системе
3 | DATE | DOUBLE | Дата выставления
4 | TIME | DOUBLE | Время выставления
5 | ACTIVATION_TIME | DOUBLE | Время активации
6 | WITHDRAW_TIME | DOUBLE | Время снятия заявки
7 | SECURITY | STRING | Краткое наименование инструмента
8 | SECCODE | STRING | Код инструмента заявки
9 | CLASS | STRING | Краткое название класса заявки
10 | CLASSCODE | STRING | Код класса заявки
11 | OPERATION | STRING | Операция | «SELL» или «BUY»
12 | ACCOUNT | STRING | Торговый счет
13 | PRICE | DOUBLE | Цена
14 | QUANTITY | DOUBLE | Количество в лотах
15 | BALANCE | DOUBLE | Остаток
16 | VALUE | DOUBLE | Объем в денежных средствах
17 | TRADE_CURRENCY | STRING | Валюта заявки
18 | YIELD | DOUBLE | Доходность
19 | ACCRUEDINT | DOUBLE | Накопленный купонный доход
20 | USERID | STRING | Идентификатор трейдера
21 | FIRMID | STRING | Идентификатор фирмы
22 | CLIENTCODE | STRING | Код клиента
23 | COMMENT | STRING | Комментарий
24 | STATUS | STRING | Статус заявки | «ACTIVE» или «KILLED» или «FILLED»
25 TYPE STRING Тип заявки

Последовательность трех символов:

  • 1-й: «L» - лимитированная, «M» - рыночная;
  • 2-й: «S» - разрешить исполнение по разным ценам, «O» - по одной цене;
  • 3-й: «N» - немедленно или отклонить, «W» - снять остаток, « » - нет условия
26 | TRANS_ID | DOUBLE | Идентификатор транзакции
27 | SETTLECODE | STRING | Код расчетов
28 | PRICE2 | DOUBLE | Цена выкупа
29 | IS_MARKET_MAKER_ORDER | STRING | Заявка Маркет-мейкера | «YES» или « »
30 | SESSION_DATE | DOUBLE | Дата текущей торговой сессии
31 | TIME_MICROSEC | DOUBLE | Количество микросекунд во времени выставления
32 | WITHDRAW_DATE | DOUBLE | Дата снятия заявки
33 | WITHDRAW_TIME_MICROSEC | DOUBLE | Количество микросекунд во времени снятия
34 PERIOD DOUBLE Период торговой сессии
  • «0» - открытие;
  • «1» - нормальный;
  • «2» - закрытие
35 | VISIBLE_QUANTITY | DOUBLE | Видимое количество. Параметр заявок типа «Айсберг»
36 | LINKED_ORDER | DOUBLE | Номер заявки в торговой системе
37 | SEC_CURRENCY | STRING | Валюта расчетов
38 | EXPIRE_DATE | DOUBLE | Срок
39 | UID | DOUBLE | UID


Параметры Таблицы сделок, возвращаемые функцией «GET_ITEM»

№ Параметр Тип Описание Возможные значения
1 | NUMBER | DOUBLE | Номер сделки в торговой системе
2 | EXCHANGE_CODE | STRING | Код биржи в торговой системе
3 | DATE | DOUBLE | Дата совершения
4 | TIME | DOUBLE | Время совершения
5 | ORDER_NUMBER | DOUBLE | Номер заявки в торговой системе
6 | SECURITY | STRING | Краткое название инструмента
7 | SECCODE | STRING | Код инструмента заявки
8 | CLASS | STRING | Краткое название класса
9 | CLASSCODE | STRING | Код класса
10 | OPERATION | STRING | Операция | «SELL» или «BUY»
11 | TYPE | STRING | Тип сделки | «MARGIN», если сделка маржинальная
12 | ACCOUNT | STRING | Торговый счет
13 | PRICE | DOUBLE | Цена
14 | QUANTITY | DOUBLE | Количество в лотах
15 | VALUE | DOUBLE | Объем в денежных средствах
16 | TRADE_CURRENCY | STRING | Валюта
17 | SETTLE_CURRENCY | STRING | Валюта расчетов
18 | SETTLE_CODE | STRING | Код расчетов
19 | YIELD | DOUBLE | Доходность
20 | ACCRUEDINT | DOUBLE | Накопленный купонный доход
21 | USERID | STRING | Идентификатор трейдера
22 | STATION_ID | STRING | Идентификатор рабочей станции
23 | FIRMID | STRING | Идентификатор дилера
24 | FIRMNAME | STRING | Идентификатор организации трейдера
25 | CLIENTCODE | STRING | Код клиента
26 | COMMENT | STRING | Комментарий
27 | PARTNER_FIRMID | STRING | Идентификатор фирмы партнера
28 | PARTNER_FIRM_NAME | STRING | Название фирмы партнера
29 | PRICE2 | DOUBLE | Цена выкупа
30 | REPORATE | DOUBLE | Ставка РЕПО(%)
31 | TS_COMISSION | DOUBLE | Комиссия торговой системы
32 | CLEARING_COMISSION | DOUBLE | Клиринговая комиссия (Московской Биржи)
33 | EXCHANGE_COMISSION | DOUBLE | Комиссия Фондовой биржи (Московской Биржи)
34 | TECH_CENTER_ COMISSION | DOUBLE | Комиссия Технического центра (Московской Биржи)
35 | ACCRUED2 | DOUBLE | Доход(%) на дату выкупа
36 | REPOVALUE | DOUBLE | Сумма РЕПО
37 | REPO2VALUE | DOUBLE | Объем выкупа РЕПО
38 | REPOTERM | DOUBLE | Срок РЕПО
39 | START_DISCOUNT | DOUBLE | Начальный дисконт(%)
40 | LOWER_DISCOUNT | DOUBLE | Нижний дисконт(%)
41 | UPPER_DISCOUNT | DOUBLE | Верхний дисконт(%)
42 | BLOCK_SECURITIES | STRING | Блокировка обеспечения | «Да» или «Нет»
43 | SESSION_DATE | DOUBLE | Дата текущей торговой сессии
44 | TIME_MICROSEC | DOUBLE | Количество микросекунд во времени совершения
45 PERIOD DOUBLE Период торговой сессии
  • «0» - открытие;
  • «1» - нормальный;
  • «2» - закрытие
46 KIND DOUBLE Вид сделки
  • «1» - обычная;
  • «2» - адресная;
  • «3» - первичное размещение;
  • «4» - перевод денег / инструментов;
  • «5» - адресная сделка первой части РЕПО;
  • «6» - расчетная по операции своп;
  • «7» - расчетная по внебиржевой операции своп;
  • «8» - расчетная сделка бивалютной корзины;
  • «9» - расчетная внебиржевая сделка бивалютной корзины;
  • «10» – сделка по операции РЕПО с ЦК;
  • «11» – первая часть сделки по операции РЕПО с ЦК;
  • «12» – вторая часть сделки по операции РЕПО с ЦК;
  • «13» – адресная сделка по операции РЕПО с ЦК;
  • «14» – первая часть адресной сделки по операции РЕПО с ЦК;
  • «15» – вторая часть адресной сделки по операции РЕПО с ЦК;
  • «16» – техническая сделка по возврату активов РЕПО с ЦК;
  • «17» – сделка по спреду между фьючерсами разных сроков на один актив;
  • «18» – техническая сделка первой части от спреда между фьючерсами;
  • «19» – техническая сделка второй части от спреда между фьючерсами;
  • «20» – адресная сделка первой части РЕПО с корзиной;
  • «21» – адресная сделка второй части РЕПО с корзиной;
  • «22» – перенос позиций срочного рынка»;
  • «23» – Late correction – XLON;
  • «24» – Not to mark – XLON;
  • «25» – Previous Day Contra;
  • «26» – Ordinary trade immediate publication – XLON;
  • «27» – Inter Fund Transfer delayed publication – XOFF;
  • «28» – Negotiated Trade delayed publication – XLON;
  • «29» – Negotiated Trade immediate publication – XLON;
  • «30» – OTC Late Correction – XOFF;
  • «31» – Ordinary Trade delayed publication – XLON;
  • «32» – Ordinary Trade Immediate publication – XOFF;
  • «33» – SI Late Correction;
  • «34» – SI Trade immediate publication;
  • «35» – SI Trade delayed publication;
  • «36» – OTC Trade delayed publication – XOFF;
  • «37» – OTC MTF TBA 1;
  • «38» – OTC trade – delayed publication MTF TBA 1;
  • «39» – Inter fund cross - delayed publication requested MTF TBA 1;
  • «40» – Cancellation of OTC trade after date of publication MTF TBA 1;
  • «41» – OTC MTF TBA 2;
  • «42» – OTC trade – delayed publication MTF TBA 2;
  • «43» – Inter fund cross - delayed publication requested MTF TBA 2;
  • «44» – Cancellation of OTC trade after date of publication MTF TBA 2;
  • «45» – OTC MTF TBA 3;
  • «46» – OTC trade – delayed publication MTF TBA 3;
  • «47» – Inter fund cross - delayed publication requested MTF TBA 3;
  • «48» – Cancellation of OTC trade after date of publication MTF TBA 3;
  • «49» – OTC MTF TBA 4;
  • «50» – OTC trade – delayed publication MTF TBA 4;
  • «51» – Inter fund cross - delayed publication requested MTF TBA 4;
  • «52» – Cancellation of OTC trade after date of publication MTF TBA 4;
  • «53» – Delayed Publication Late Correction XLON;
  • «54» – No to Mark Late Correction XLON;
  • «55» – Витринная сделка по операции своп;
  • «58» – Витринная сделка по адресной операции своп;
  • «59» – Витринная сделка по Беспоставочному свопу;
  • «60» – Сделка FX SPOT;
  • «61» – Сделка по Беспоставочному валютному форвардному контракту;
  • «62» – Сделка FX DEPOSIT;
  • «63» – Сделка по Валютному расчетному форвардному контракту


Параметры Таблицы обезличенных сделок, возвращаемые функцией «GET_ITEM»

№ Параметр Тип Описание Возможные значения
1 | NUMBER | DOUBLE | Номер сделки в торговой системе
2 | DATE | DOUBLE | Дата выставления
3 | TIME | DOUBLE | Время выставления
4 | SECURITY | STRING | Краткое название инструмента
5 | SECCODE | STRING | Код инструмента заявки
6 | CLASS | STRING | Краткое название класса
7 | CLASSCODE | STRING | Код класса
8 | PRICE | DOUBLE | Цена
9 | QUANTITY | DOUBLE | Количество в лотах
10 | VALUE | DOUBLE | Объем в денежных средствах
11 | ACCRUEDINT | DOUBLE | Накопленный купонный доход
12 | YIELD | DOUBLE | Доходность
13 | SETTLE_CODE | STRING | Код расчетов
14 | REPORATE | DOUBLE | Ставка РЕПО(%)
15 | REPOVALUE | DOUBLE | Сумма РЕПО
16 | REPO2VALUE | DOUBLE | Объем выкупа РЕПО
17 | REPOTERM | DOUBLE | Срок РЕПО
18 | OPERATION | STRING | Операция | «SELL» или «BUY»
19 | SESSION_DATE | DOUBLE | Дата текущей торговой сессии
20 | TIME_MICROSEC | DOUBLE | Количество микросекунд во времени совершения
21 PERIOD DOUBLE Период торговой сессии
  • «0» - открытие;
  • «1» - нормальный;
  • «2» - закрытие


Параметры Таблицы стоп-заявок, возвращаемые функцией «GET_ITEM»

№ Параметр Тип Описание Возможные значения
1 | NUMBER | DOUBLE | Регистрационный номер стоп-заявки на сервере QUIK
2 | DATE | DOUBLE | Дата выставления
3 | TIME | DOUBLE | Время выставления
4 | WITHDRAW_TIME | DOUBLE | Время снятия заявки
5 STOP_ORDER_TYPE DOUBLE Вид стоп заявки
  • «1» – стоп-лимит;
  • «2» – условие по другому инструменту;
  • «3» – со связанной заявкой;
  • «6» - тейк-профит;
  • «7» - стоп-лимит по исполнению активной заявки;
  • «8» - тейк-профит по исполнению активной заявки;
  • «9» - тейк-профит и стоп-лимит
6 TYPE STRING Тип заявки

Последовательность трех символов:

  • 1-й: «L» - лимитированная, «M» - рыночная;
  • 2-й: «S» - разрешить исполнение по разным ценам, «O» - по одной цене;
  • 3-й: «N» - немедленно или отклонить, «W» - снять остаток, « » - нет условия
7 | SECURITY | STRING | Краткое название инструмента
8 | SECCODE | STRING | Код инструмента заявки
9 | CLASS | STRING | Краткое название класса заявки
10 | CLASSCODE | STRING | Код класса заявки
11 | OPERATION | STRING | Операция | «SELL» или «BUY»
12 | ACCOUNT | STRING | Торговый счет
13 | CONDITION_SECURITY | STRING | Инструмент стоп-цены
14 | CONDITION_SECCODE | STRING | Код инструмента стоп-цены
15 | CONDITION_CLASS | STRING | Класс стоп-цены
16 | CONDITION_CLASSCODE | STRING | Код класса стоп-цены
17 | CONDITION | STRING | Направленность стоп-цены | «LESS_OR_EQUAL_VALUE» или «GREATER_OR_EQUAL_VALUE»
18 | CONDITION_PRICE | DOUBLE | Стоп-цена
19 | CONDITION2 | STRING | Направленность стоп-лимит цены (для заявок типа «Тейк-профит и стоп-лимит») | «LESS_OR_EQUAL_VALUE» или «GREATER_OR_EQUAL_VALUE»
20 | CONDITION_PRICE2 | DOUBLE | Стоп-лимит цена (для заявок типа «Тейк-профит и стоп-лимит»)
21 | PRICE | DOUBLE | Цена
22 | MARKET_STOP_LIMIT | STRING | Признак исполнения заявки «стоп-лимит» по рыночной цене (для заявок типа «Тейк-профит и стоп-лимит») | «Да» либо пусто
23 | QUANTITY | DOUBLE | Количество в лотах
24 | BALANCE | DOUBLE | Активное количество
25 | FILLED_VOLUME | DOUBLE | Исполненное количество
26 | FIRMID | STRING | Дилер
27 | UID | DOUBLE | UID
28 | CLIENTCODE | STRING | Код клиента
29 | COMMENT | STRING | Комментарий
30 | LINKED_ORDER | DOUBLE | Номер заявки в торговой системе, зарегистрированной по наступлению условия стоп-цены
31 | ALL_TRADE_NUMBER | DOUBLE | Сделка условия
32 | EXPIRE_DATE | DOUBLE | Срок
33 | EXPIRY_DATE_IS_TODAY | STRING | Срок действия заявки равен «Сегодня»
34 | ACTIVE_IN_TIME_INTERVAL | STRING | Признак действия заявки типа «Тейк-профит и стоп-лимит» в течение периода времени
35 | ACTIVE_FROM_TIME | DOUBLE | Время начала периода действия заявки типа «Тейк-профит и стоп-лимит»
36 | ACTIVE_TO_TIME | DOUBLE | Время окончания периода действия заявки типа «Тейк-профит и стоп-лимит»
37 | USE_BASE_ORDER_BALANCE | STRING | Брать исполненный объем в качестве количества выставляемой стоп-заявки (для заявок «по исполнению») | «Да» либо пусто
38 | KILL_IF_LINKED_ORDER_PARTLY_FILLED | STRING | При частичном исполнении связанной заявки снять стоп-заявку (для заявок «по исполнению») | «Да» либо пусто
39 | ACTIVATE_IF_BASE_ORDER_PARTLY_FILLED | STRING | Частичное исполнение учитывается (для заявок «по исполнению») | «Да» либо пусто
40 | TYPE_DESCRIPTION | STRING | Тип
41 | STATUS | STRING | Статус заявки | «ACTIVE» или «KILLED» или «FILLED»
42 RESULT_DESCRIPTION STRING Результат
  • «Отвергнута ТС»;
  • «Не прошла контроль лимитов»;
  • «Связ. заявка снята»;
  • «Связ. заявка исполнена»;
  • «Рассчитывается min\max»;
  • «Ждет активации»;
  • «Рассчитывается min\max и ждет активации»;
  • «Снята»;
  • «Выставлена заявка в ТС»
43 | CO_ORDER_NUMBER | DOUBLE | Связанная заявка
44 | CO_ORDER_PRICE | DOUBLE | Цена связанной заявки
45 | TRANS_ID | DOUBLE | Идентификатор транзакции
46 | OFFSET | DOUBLE | Отступ от min/max
47 | OFFSET_UNITS | STRING | Единицы отступа | «%» или «Д»
48 | SPREAD | DOUBLE | Защитный спред
49 | SOE_USE_SPREAD_AS_PERCENTS | STRING | Значение «защитного спреда» указано в процентах | «Да» либо пусто
50 | MARKET_TAKE_PROFIT | STRING | Признак исполнения заявки «тейк-профит» по рыночной цене (для заявок типа «Тейк-профит и стоп-лимит») | «Да» либо пусто
51 | BASE_ORDER_NUM | DOUBLE | Заявка условия
52 | OWNER_SERVER | STRING | Сервер | «Другой» или «Текущий»


Параметры таблицы «Позиции по деньгам» , возвращаемые функцией «GET_ITEM»

№ | Параметр | Тип | Описание
1 | FIRMID | STRING | Идентификатор фирмы
2 | CURRCODE | STRING | Код валюты
3 | TAG | STRING | Код позиции
4 | CLIENT_CODE | STRING | Код клиента
5 | OPEN_BALANCE | DOUBLE | Входящий остаток по деньгам
6 | OPEN_LIMIT | DOUBLE | Входящий лимит по деньгам
7 | CURRENT_BALANCE | DOUBLE | Текущий остаток по деньгам
8 | CURRENT_LIMIT | DOUBLE | Текущий лимит по деньгам
9 | LOCKED | DOUBLE | Заблокированное количество
10 | AVAILABLE | DOUBLE | Доступное количество
11 | LOCKED_VALUE | DOUBLE | Количество денежных средств, заблокированное на покупку немаржинальных инструментов
12 | LIMIT_KIND | DOUBLE | Срок расчётов


Параметры таблицы «Позиции по инструментам», возвращаемые функцией «GET_ITEM»

№ | Параметр | Тип | Описание
1 | FIRMID | STRING | Идентификатор фирмы
2 | SECCODE | STRING | Код инструмента
3 | TRDACCID | STRING | Счет депо
4 | CLIENT_CODE | STRING | Код клиента
5 | OPEN_BALANCE | DOUBLE | Входящий остаток по инструментам
6 | OPEN_LIMIT | DOUBLE | Входящий лимит по инструментам
7 | CURRENT_BALANCE | DOUBLE | Текущий остаток по инструментам
8 | CURRENT_LIMIT | DOUBLE | Текущий лимит по инструментам
9 | LOCKED_SELL | DOUBLE | Заблокировано
10 | AVAILABLE | DOUBLE | Доступное количество
11 | WA_POSITION_PRICE | DOUBLE | Цена приобретения
12 | LIMIT_KIND | DOUBLE | Срок расчётов


Параметры Таблицы ограничений по клиентским счетам, возвращаемые функцией «GET_ITEM»

№ | Параметр | Тип | Описание | Возможные значения
1 | FIRMID | STRING | Идентификатор фирмы |
2 | TRDACCID | STRING | Торговый счет |
3 | TYPE | STRING | Тип лимита | «Ден.средства» или «Всего»
4 | CBP_PREV_LIMIT | DOUBLE | Предыдущий лимит открытых позиций |
5 | CBPLIMIT | DOUBLE | Лимит открытых позиций |
6 | CBPLUSED | DOUBLE | Текущие чистые позиции |
7 | CBPLUSED_FOR_ORDERS | DOUBLE | Текущие чистые позиции (под заявки) |
8 | CBPLUSED_FOR_POSITIONS | DOUBLE | Текущие чистые позиции (под открытые позиции) |
9 | CBPLPLANNED | DOUBLE | Планируемые чистые позиции |
10 | VARMARGIN | DOUBLE | Вариационная маржа |
11 | ACCRUEDINT | DOUBLE | Накопленный доход |
12 | OPTIONS_PREMIUM | DOUBLE | Премия по опционам |
13 | TS_COMISSION | DOUBLE | Биржевые сборы |
14 | KGO | DOUBLE | Коэффициент клиентского гарантийного обеспечения |


Параметры Таблицы позиций по клиентским счетам, возвращаемые функцией «GET_ITEM»

№ | Параметр | Тип | Описание | Возможные значения
1 | FIRMID | STRING | Идентификатор фирмы |
2 | TRDACCID | STRING | Торговый счет |
3 | SECCODE | STRING | Код фьючерсного контракта |
4 | SEC_SHORT_NAME | STRING | Краткое название контракта |
5 | TYPE | STRING | Тип лимита | «Основной счет» или «Клиентские и дополнительные счета» или «Все счета торг. членов» или <пусто>
6 | START_BUY | DOUBLE | Входящие длинные позиции |
7 | START_SELL | DOUBLE | Входящие короткие позиции |
8 | START_NET | DOUBLE | Входящие чистые позиции |
9 | TODAY_BUY | DOUBLE | Текущие длинные позиции |
10 | TODAY_SELL | DOUBLE | Текущие короткие позиции |
11 | TOTAL_NET | DOUBLE | Текущие чистые позиции |
12 | OPEN_BUYS | DOUBLE | Активные на покупка |
13 | OPEN_SELLS | DOUBLE | Активные на продажу |
14 | CBPLUSED | DOUBLE | Оценка текущих чистых позиций |
15 | CBPLPLANNED | DOUBLE | Плановые чистые позиции |
16 | VARMARGIN | DOUBLE | Вариационная маржа |
17 | AVRPOSNPRICE | DOUBLE | Эффективная цена позиций |
18 | POSITIONVALUE | DOUBLE | Стоимость позиций |


Параметры Таблицы заявок на внебиржевые сделки, возвращаемые функцией «GET_ITEM»

№ | Параметр | Тип | Описание | Возможные значения
1 | NUMBER | DOUBLE | Номер |
2 | QUOTENO | DOUBLE | Встречная безадресная заявка |
3 | DATE | STRING | Дата выставления заявки |
4 | TIME | STRING | Время выставления заявки |
5 | ACTIVATION_DATE | DOUBLE | Дата активации заявки |
6 | ACTIVATION_TIME | DOUBLE | Время активации заявки |
7 | SECURITY | STRING | Краткое название инструмента |
8 | SECCODE | STRING | Код инструмента |
9 | CLASS | STRING | Класс |
10 | CLASSCODE | STRING | Код класса |
11 | OPERATION | STRING | Операция | «Купля» либо «Продажа»
12 | ACCOUNT | STRING | Счет |
13 | PRICE | DOUBLE | Цена |
14 | QUANTITY | DOUBLE | Количество |
15 | USERID | STRING | Трейдер |
16 | FIRMID | STRING | Идентификатор дилера |
17 | FIRMNAME | STRING | Идентификатор организации трейдера |
18 | UID | DOUBLE | UID |
19 | CPUSERID | STRING | Трейдер партнера |
20 | CPFIRMID | STRING | Идентификатор партнера |
21 | CPFIRMNAME | STRING | Организация партнёр |
22 | CLIENTCODE | STRING | Код клиента |
23 | COMMENT | STRING | Комментарий |
24 | MATCH_REFERENCE | STRING | Ссылка |
25 | STATUS | STRING | Состояние | «Активна», «Исполнена» или «Снята»
26 | SETTLE_CODE | STRING | Код расчетов |
27 | DIRECTION | STRING | Направленность | «Отправлена», «Получена» или «Отправлена и получена»
28 | YIELD | DOUBLE | Доходность |
29 | VALUE | DOUBLE | Объем |
30 | ACCRUEDINT | DOUBLE | Купонный процент |
31 | PRICE2 | DOUBLE | Цена выкупа |
32 | REFUNDRATE | DOUBLE | Ставка возмещения (%) |
33 | REPORATE | DOUBLE | Ставка РЕПО (%) |
34 | TRANS_ID | DOUBLE | ID транзакции |
35 | REPOVALUE | DOUBLE | Сумма РЕПО |
36 | REPO2VALUE | DOUBLE | Объем выкупа РЕПО |
37 | REPOENTRY | STRING | Тип ввода заявки РЕПО | «Цена1+Ставка», «Ставка+Цена2», «Цена1+Цена2», «Сумма РЕПО + Количество», «Сумма РЕПО + Дисконт», «Количество + Дисконт», «Сумма РЕПО», «Количество».
38 | REPOTERM | DOUBLE | Срок РЕПО |
39 | START_DISCOUNT | DOUBLE | Начальный дисконт(%) |
40 | LOWER_DISCOUNT | DOUBLE | Нижний дисконт(%) |
41 | UPPER_DISCOUNT | DOUBLE | Верхний дисконт(%) |
42 | BLOCK_SECURITIES | STRING | Блокировка обеспечения | «Да» или «Нет»
43 | ORIG_REPOVALUE | DOUBLE | Сумма РЕПО первоначальная |
44 | ORIG_VOLUME | DOUBLE | Количество первоначальное |
45 | ORIG_DISCOUNT | DOUBLE | Процент дисконта первоначальный |
46 | WITHDRAW_TIME | DOUBLE | Время снятия заявки |
47 | BALANCE | DOUBLE | Остаток |
48 | SETTLE_CURRENCY | STRING | Валюта расчетов |


Параметры Таблицы сделок для исполнения, возвращаемые функцией «GET_ITEM»

№ Параметр Тип Описание Возможные значения
1 | NUMBER | DOUBLE | Номер
2 | ORDER_NUMBER | DOUBLE | Номер заявки
3 | DATE | STRING | Дата торгов
4 | SETTLEDATE | STRING | Дата расчетов
5 | CLASS | STRING | Класс
6 | CLASSCODE | STRING | Код класса
7 | SECCODE | STRING | Код инструмента
8 | SECURITY | STRING | Краткое наименование инструмента
9 | OPERATION | STRING | Операция | «Купля» либо «Продажа»
10 | CLIENTCODE | STRING | Код клиента
11 | COMMENT | STRING | Комментарий
12 | FIRMID | STRING | Идентификатор дилера
13 | FIRMNAME | STRING | Идентификатор организации трейдера
14 | ACCOUNT | STRING | Счет депо
15 | CPFIRMNAME | STRING | Партнер
16 | CPFIRMID | STRING | Идентификатор партнера
17 | CPACCOUNT | STRING | Счет депо партнера
18 | PRICE | DOUBLE | Цена
19 | QUANTITY | DOUBLE | Количество
20 | VALUE | DOUBLE | Объем
21 STATUS STRING Состояние
  • «FILLED» - исполнена;
  • «NOT FILLED» - не исполнена;
  • «INCLUDE IN REPORT» - включена в отчет
    • 22 | ACCRUEDINT | DOUBLE | Купонный %
    23 | PRICE1 | DOUBLE | Цена 1ой части РЕПО
    24 | PRICE2 | DOUBLE | Цена выкупа
    25 | REPORTTRADENO | DOUBLE | Номер сделки 1ой части РЕПО
    26 | REPORATE | DOUBLE | Ставка РЕПО(%)
    27 | SETTLE_CODE | STRING | Код расчетов
    28 | REPORT_NUM | DOUBLE | Отчет
    29 | CPREPORT_NUM | DOUBLE | Отчет партнера
    30 | TS_COMISSION | DOUBLE | Комиссия торговой системы
    31 | BALANCE | DOUBLE | Остаток
    32 | SETTLETIME | STRING | Время исполнения
    33 | AMOUNT | DOUBLE | Сумма обязательства
    34 | REPOVALUE | DOUBLE | Сумма РЕПО
    35 | REPOTERM | DOUBLE | Срок РЕПО
    36 | REPO2VALUE | DOUBLE | Объем выкупа РЕПО
    37 | RETURN_VALUE | DOUBLE | Сумма возврата РЕПО
    38 | DISCOUNT | DOUBLE | Дисконт(%)
    39 | LOWER_DISCOUNT | DOUBLE | Нижний дисконт(%)
    40 | UPPER_DISCOUNT | DOUBLE | Верхний дисконт(%)
    41 | BLOCK_SECURITIES | STRING | Блокировать обеспечение | «Да» либо «Нет»
    42 | URGENCY_FLAG | STRING | Исполнить | «Да» либо «Нет»
    43 TRADE_TYPE STRING Тип
    • «Внесистемная сделка»;
    • «Первая часть сделки РЕПО»;
    • «Вторая часть сделки РЕПО»;
    • «Компенсационный взнос»
    44 | TRADE_OPERATION_TYPE | STRING | Направленность | «Зачислить» либо «Списать»
    45 | EXPECTED_DISCOUNT | DOUBLE | Дисконт после взноса(%)
    46 | EXPECTED_QUANTITY | DOUBLE | Количество после взноса
    47 | EXPECTED_REPOVALUE | DOUBLE | Сумма РЕПО после взноса
    48 | EXPECTED_REPO2VALUE | DOUBLE | Стоимость выкупа после взноса
    49 | EXPECTED_RETURN_VALUE | DOUBLE | Сумма возврата после взноса
    50 | REPORT_TRADE_DATE | DOUBLE | Дата заключения
    51 STATE_OF_CLEARING STRING Состояние расчетов
    • «Processed»;
    • «Not processed»;
    • «Is processing»
    52 TYPE_OF_CLEARING STRING Тип клиринга
    • «Not set»;
    • «Simple»;
    • «Multilateral»
    53 | REPORT_COMISSION | DOUBLE | Комиссия за отчет
    54 | COUPON_PAYMENT | DOUBLE | Купонная выплата
    55 | COUPON_PAYMENT_DATE | DOUBLE | Дата купонной выплаты
    56 | PRINCIPAL_PAYMENT | DOUBLE | Выплата по основному долгу
    57 | PRINCIPAL_PAYMENT_DATE | DOUBLE | Дата выплаты по основному долгу
    58 | SETTLE_CURRENCY | STRING | Валюта расчетов


Параметры Таблицы заявок-отчетов на сделки РПС, возвращаемые функцией «GET_ITEM»

№ | Параметр | Тип | Описание | Возможные значения
1 | NUMBER | DOUBLE | Номер |
2 | DATE | STRING | Дата |
3 | TIME | STRING | Время выставления заявки |
4 | CLASS | STRING | Класс |
5 | SECCODE | STRING | Код инструмента |
6 | SECURITY | STRING | Краткое наименование инструмента |
7 | USERID | STRING | Идентификатор трейдера |
8 | FIRMID | STRING | Идентификатор дилера |
9 | FIRMNAME | STRING | Идентификатор организации трейдера |
10 | ACCOUNT | STRING | Счет депо |
11 | CPFIRMNAME | STRING | Партнер |
12 | CPFIRMID | STRING | Идентификатор партнера |
13 | CPACCOUNT | STRING | Счет депо партнера |
14 | QUANTITY | DOUBLE | Количество |
15 | VALUE | DOUBLE | Объем |
16 | COMISSION | DOUBLE | Комиссия |
17 | DIRECTION | STRING | Направленность | «Отправлен» или «Получен»
18 | STATUS | STRING | Состояние | «Ждет исполнения», «Снят» либо «Исполнен»
19 | REPORT_TYPE | STRING | Тип отчета | «EXECUTION» или «CANCEL EXECUTION»
20 | REPORT_KIND | STRING | Вид отчета |


Параметры таблицы «Позиции участника по деньгам», возвращаемые функцией «GET_ITEM»

№ | Параметр | Тип | Описание | Возможные значения
1 | FIRMID | STRING | Фирма |
2 | CURRCODE | STRING | Валюта |
3 | TAG | STRING | Код позиции |
4 | DESCRIPTION | STRING | Описание |
5 | OPENBAL | DOUBLE | Входящий |
6 | CURRENTPOS | DOUBLE | Текущий |
7 | PLANNEDPOS | DOUBLE | Плановый |
8 | LIMIT1 | DOUBLE | Внешнее ограничение |
9 | ORDERBUY | DOUBLE | На покупку (в заявках) |
10 | ORDERSELL | DOUBLE | На продажу (в заявках) |
11 | NETOBLIGATION | DOUBLE | Нетто |
12 | PLANNEDBAL | DOUBLE | Контрольная |
13 | BANK_ACC_ID | STRING | Идентификатор счета |


Параметры таблицы «Позиции участника по инструментам», возвращаемые функцией «GET_ITEM»

№ | Параметр | Тип | Описание | Возможные значения
1 | FIRMID | STRING | Фирма |
2 | SEC_SHORT_NAME | STRING | Название инструмента |
3 | SECCODE | STRING | Код инструмента |
4 | OPENBAL | DOUBLE | Входящий |
5 | CURRENTPOS | DOUBLE | Текущий |
6 | PLANNEDPOSBUY | DOUBLE | Плановая покупка |
7 | PLANNEDPOSSELL | DOUBLE | Плановая продажа |
8 | USQTYB | DOUBLE | Куплено |
9 | USQTYS | DOUBLE | Продано |


Параметры таблицы «Позиции участника по торговым счетам», возвращаемые функцией «GET_ITEM»

№ | Параметр | Тип | Описание | Возможные значения
1 | SECCODE | STRING | Код инструмента |
2 | SEC_SHORT_NAME | STRING | Название инструмента |
3 | FIRMID | STRING | Идентификатор фирмы |
4 | TRDACCID | STRING | Торговый счет |
5 | DEPACCID | STRING | Счет депо |
6 | OPENBAL | DOUBLE | Входящий |
7 | CURRENTPOS | DOUBLE | Текущий |
8 | PLANNEDPOSBUY | DOUBLE | Плановая покупка |
9 | PLANNEDPOSSELL | DOUBLE | Плановая продажа |
10 | PLANBAL | DOUBLE | Контрольный |
11 | USQTYB | DOUBLE | Куплено |
12 | USQTYS | DOUBLE | Продано |
13 | PLANNED | DOUBLE | Плановый |


Функции для обращения к спискам доступных параметров

  • GET_CLASSES_LIST
  • GET_CLASS_SECURITIES
  • GET_SECURITY_INFO

    • GET_CLASSES_LIST

    Функция предназначена для получения списка кодов классов, полученных с сервера в ходе текущего сеанса связи. Разделителем в списке кодов классов выступает запятая «,».

    GET_CLASSES_LIST ()

    Пример:

    ‘
    ClassesList = GET_CLASSES_LIST ()
    ‘

    Переменной «ClassesList» присваивается список доступных классов, например «TQBR, TQBS, TQNL, TQOB, TQOS, TQNO».

    GET_CLASS_SECURITIES

    Функция предназначена для получения списка кодов инструментов для списка классов, заданного списком кодов. Разделителем в списке кодов инструментов выступает запятая «,».

    GET_CLASS_SECURITIES (STRING)

    Пример:

    ‘
    SecuritiesList =  GET_CLASS_SECURITIES ("TQBR,GKO")

‘

    Переменной «SecuritiesList» присваивается список кодов всех доступных инструментов для классов «А1-Акции» и «ГКО

    GET_SECURITY_INFO

    Функция возвращает информацию по инструменту с кодом «sec_code» из класса с кодом «class_code». Если «class_code» равен «», то ищет по всем классам до первого нахождения.

    MAP GET_SECURITY_INFO (STRING class_code, STRING sec_code)

    Параметры:

    № | Параметр | Тип | Описание
1 | CODE | STRING | Код инструмента
2 | NAME | STRING | Наименование инструмента
3 | SHORT_NAME | STRING | Краткое наименование
4 | CLASS_CODE | STRING | Код класса
5 | CLASS_NAME | STRING | Наименование класса
6 | FACE_VALUE | DOUBLE | Номинал
7 | FACE_UNIT | STRING | Код валюты номинала
8 | SCALE | DOUBLE | Количество значащих цифр после запятой
9 | MAT_DATE | STRING | Дата погашения
10 | LOT_SIZE | DOUBLE | Размер лота

    Пример:

    ‘
    SecInfo =  GET_SECURITY_INFO("", "YUKO")
    Lot = GET_VALUE (SecInfo, "LOT_SIZE")
    ‘

    Переменной «SecInfo» присваиваются значения параметров инструмента «YUKO». Переменная «Lot» содержит количество инструментов в одном лоте «YUKO».


Функции для работы с программируемой таблицей

  • ADD_ITEM
  • MODIFY_ITEM
  • DELETE_ITEM
  • DELETE_ALL_ITEMS
  • SET_ROW_COLOR
  • SET_ROW_COLOR_EX

    • Следующий набор функций оперирует только с таблицей «OWN», создаваемой при расчете программы. Данная таблица доступна не только для чтения с помощью стандартных функции «GET_ITEM» и «GET_NUMBER_OF», но также и для модификации с помощью следующих функций.

    ADD_ITEM

    Данная функция вставляет строку с индексом «Index» в таблицу «OWN». Ассоциативный массив «table_string» используется для инициализации колонок таблицы значениями. «Table_string» должен содержать элементы с ключами равными названиям колонок.

    ADD_ITEM (DOUBLE Index, MAP table_string)

    MODIFY_ITEM

    Функция модифицирует уже существующую строку с индексом «Index» с помощью массива «table_string».

    MODIFY_ITEM (DOUBLE Index, MAP table_string)

    DELETE_ITEM

    Функция предназначена для удаления строки с индексом «Index».

    DELETE_ITEM (DOUBLE Index)

    DELETE_ALL_ITEMS

    Функция полностью очищает таблицу «OWN».

    DELETE_ALL_ITEMS()

    Параметры:

    № | Параметр | Тип | Описание
1 | INDEX | DOUBLE | Индекс для обращения к коллекции. Должен содержать целочисленное значение
2 | TABLE_STRING | MAP | Массив, содержащий значения для колонок модифицируемой строки

    Пример:

    ‘
    st=CREATE_MAP()
    st=SET_VALUE(st,"Value",10)
    ADD_ITEM(1,st)
    st=GET_ITEM ("OWN",1)
    value=GET_VALUE(st,"Value")
    DELETE_ALL_ITEMS()
     ‘

    Данный пример может работать только с таблицей, содержащей единственную колонку с именем «Value». Сначала создается массив, содержащий элемент со значением «10» и ключом «Value». Затем, в таблице создается строка с индексом «1» и значением колонки «Value» равным «10». В дальнейшем строка с индексом «1» считывается обратно в массив и значение элемента с ключом «Value» попадает в переменную «value». И, наконец, все строки таблицы удаляются вызовом «DELETE_ALL_ITEMS()».

    SET_ROW_COLOR

    Функция назначения цвета фона указанной строки таблицы. Данная функция относится к предыдущей версии языка и сохранена для совместимости.

    SET_ROW_COLOR (STRING client_code, STRING background_color, STRING selected_background_color)

    Параметры:

    № | Параметр | Тип | Описание
1 | CLIENT_CODE | STRING | Код клиента, при установке этого параметра в «ROWNAME» цвет подсветки устанавливается на текущего рассчитываемого клиента
2 | BACKGROUND_COLOR | STRING | Основной цвет подсветки строки
3 | SELECTED_BACKGROUND_COLOR | STRING | Цвет подсветки строки, когда строка выделена

    Цвет фона (подсветки) задается макросом «RGB(<red>, <green>, <blue>)». Например, если в качестве параметра цвета передадите в функцию строку «RGB(255, 0, 0)», то цвет подсветки установится в красный. Для использования системного цвета по умолчанию используйте строку «DEFAULT_COLOR».

    Пример:

    ‘
    SET_ROW_COLOR (ROWNAME, "RGB(0,255,0)", "DEFAULT_COLOR")
    ‘

    Основной цвет строки таблицы для текущего рассчитываемого клиента здесь устанавливается в зеленый, цвет выделенной строки – по умолчанию.

    SET_ROW_COLOR_EX

    Функция назначения цвета фона и шрифта указанной строки таблицы.

    SET_ROW_COLOR_EX (DOUBLE row_number, STRING background_color, STRING selected_background_color, STRING font_color, STRING selected_font_color)

    Параметры:

    № | Параметр | Тип | Описание
1 | ROW_NUMBER | DOUBLE | Номер строки для подсветки
2 | BACKGROUND_COLOR | STRING | Основной цвет фона строки
3 | SELECTED_BACKGROUND_COLOR | STRING | Цвет фона строки, когда строка выделена курсором
4 | FONT_COLOR | STRING | Основной цвет шрифта строки
5 | SELECTED_FONT_COLOR | STRING | Цвет шрифта, когда строка выделена курсором

    Цвет фона (подсветки) задается макросом «RGB(<red>, <green>, <blue>)». Например, если в качестве параметра цвета передадите в функцию строку «RGB(255, 0, 0)», то цвет подсветки установится в красный. Для использования системного цвета по умолчанию используйте строку «DEFAULT_COLOR».

    Пример:

    ‘
    SET_ROW_COLOR_EX (10, "DEFAULT_COLOR", "DEFAULT_COLOR", "RGB(0,255,0)", "RGB(0,0,255)")
    ‘

    Основной цвет шрифта для 10-й строки таблицы устанавливается в зеленый. При выделении её курсором цвет шрифта станет синим.


Функции для получения значений Таблицы текущих торгов

  • GET_PARAM
  • GET_PARAM_EX

    • GET_PARAM

    Функция предназначена для получения значения параметров биржевой информации. С помощью этой функции можно получить данные из Таблицы текущих торгов для заданных кодов класса и инструмента.

    GET_PARAM (STRING classcode_list, STRING seccode, STRING param_name)

    Параметры:

    № | Параметр | Тип | Описание
1 | CLASSCODE_LIST | STRING | Список кодов классов инструментов, в которых будет искаться инструмент через запятую. Например, если в функцию передается строка «TQBR,TQBS,TQNL», то инструмент будет искаться в классах «А1-Акции», «А2-Акции» и «Б-Акции»
2 | SECCODE | STRING | Код инструмента
3 | PARAM_NAME | STRING | Идентификатор параметра

    Пример:

    ‘
    LastPrice = GET_PARAM ("TQBR", "HYDR", "last")
    ‘

    Переменной «LastPrice» присваивается значение цены последней сделки для «РусГидро» из класса «А1-Акции Московской Биржи».

    GET_PARAM_EX

    Функция предназначена для получения значений всех параметров биржевой информации из Таблицы текущих торгов. С помощью этой функции можно получить любое из значений Таблицы текущих торгов для заданных кодов класса и инструмента.

    MAP GET_PARAM_EX (STRING classcode, STRING seccode, STRING param_name)

    Если в коде программы используется команда USE_CASE_SENSITIVE_CONSTANTS, то значения параметров «classcode» и «seccode» должны быть указаны в регистре, которому они соответствуют в Таблице текущих торгов, а значение параметра «param_name» должно быть указано в верхнем регистре.

    Параметры:

    № | Параметр | Тип | Описание
1 | CLASSCODE | STRING | Код класса
2 | SECCODE | STRING | Код инструмента
3 | PARAM_NAME | STRING | Идентификатор параметра

    «MAP» имеет структуру:

    № Параметр Тип Описание
    1 RESULT DOUBLE Результат выполнения операции. Возможные значения:
    • «0» - ошибка;
    • «1» - параметр найден
    2 PARAM_TYPE DOUBLE

    Тип данных параметра, используемый в Таблице текущих торгов. Возможные значения:

    • «1» -DOUBLE;
    • «2» - LONG;
    • «3» - CHAR;
    • «4» - перечислимый тип;
    • «5» - время;
    • «6» - дата
    3 | PARAM_VALUE | DOUBLE | Значение параметра. Для строк (param_type = 3) значение равно «0». Для перечислимых типов значение равно порядковому значению перечисления
    4 | PARAM_IMAGE | STRING | Строковое значение параметра, аналогичное его представлению в таблице. В строковом представлении учитываются разделители разрядов, разделители целой и дробной части. Для перечислимых типов выводятся соответствующие им строковые значения

    Пример:

    ‘
    PARMAP=GET_PARAM_EX("TQBR","RTKM","WAPRICE")
WAPRICE=GET_VALUE(PARMAP, "PARAM_VALUE")
    ‘

    Переменной «WAPRICE» присваивается значение средневзвешенной цены по обыкновенным акциям «Ростелекома» из класса «А1-Акции Московской Биржи».

    См. также Значения параметров функций.


Значения параметров функций

  • Список возможных кодов классов инструментов «classcode_list»
  • Список возможных идентификаторов параметров
  • Список идентификаторов дополнительных параметров, доступных для функции GET_PARAM_EX

    • Список возможных кодов классов инструментов «classcode_list»:

    Код класса | Название | Код класса | Название
TQBR | МБ ФР: Т+ А1-Акции, паи и РДР | GAZP | Облигации Газпром
TQBS | МБ ФР: Т+ А2-Акции и паи | INDX | МБ ФР: Индексы ММВБ
TQNL | МБ ФР: Т+ Б-Акции и паи | GTS | РТС: СГК
TQOB | МБ ФР: Т+ А1-Облигации | GAZ | РТС: Акции Газпрома
TQOS | МБ ФР: Т+ А2-Облигации | QUADRO | РТС-СГК(Торги в валюте)
TQNO | МБ ФР: Т+ Б-Облигации | RTS10 | РТС: Рынок «Десяти»
PSEQ | МБ ФР: РПС: А1-Акции и паи | RTSIDX | Индексы РТС
PSES | МБ ФР: РПС: А2-Акции и паи | RTSIND | РТС(Индексы)
PSNL | МБ ФР: РПС: Б-Акции и паи | SES2 | ГЦБ: Крупные лоты
PSOB | МБ ФР: РПС: А1-Облигации | SPBFUT | Фьючерсы FORTS
PSNO | МБ ФР: РПС: Б-Облигации | SPBOPT | Опционы FORTS
PSAU | МБ ФР: РПС: Первичное размещение (облигации) | SPBSPT | Спот Санкт-Петербург
AUCT | МБ ФР: Аукцион НГЦБ(Акции) | SPBGKO | МКО
MAIN | ГКОМБ ГЦБ | SPBCEX | ГГКО на Петербургской валютной бирже
MAIC | ГЦБ: период закрытия | SPCGKO | Тестовая система на СПВБ
BOBR | МБ ГЦБ: Облигации ЦБ | EQBREMU | Акции 1-го уровня (Эмулятор)
FUOP | Фьючерсы ММВБ | USDRUB | Курс доллара на FORTS

    Список возможных идентификаторов параметров:

    № | Параметр | Тип | Описание
1 | STATUS | STRING | Статус
2 | LOTSIZE | NUMERIC | Размер лота
3 | BID | NUMERIC | Лучшая цена спроса
4 | BIDDEPTH | NUMERIC | Спрос по лучшей цене
5 | BIDDEPTHT | NUMERIC | Суммарный спрос
6 | NUMBIDS | NUMERIC | Количество заявок на покупку
7 | OFFER | NUMERIC | Лучшая цена предложения
8 | OFFERDEPTH | NUMERIC | Предложение по лучшей цене
9 | OFFERDEPTHT | NUMERIC | Суммарное предложение
10 | NUMOFFERS | NUMERIC | Количество заявок на продажу
11 | OPEN | NUMERIC | Цена открытия
12 | HIGH | NUMERIC | Максимальная цена сделки
13 | LOW | NUMERIC | Минимальная цена сделки
14 | LAST | NUMERIC | Цена последней сделки
15 | CHANGE | NUMERIC | Разница цены последней к предыдущей сессии
16 | QTY | NUMERIC | Количество инструментов в последней сделке
17 | TIME | STRING | Время последней сделки
18 | VOLTODAY | NUMERIC | Количество инструментов в обезличенных сделках
19 | VALTODAY | NUMERIC | Оборот в деньгах
20 | TRADINGSTATUS | STRING | Состояние сессии
21 | VALUE | NUMERIC | Оборот в деньгах последней сделки
22 | WAPRICE | NUMERIC | Средневзвешенная цена
23 | HIGHBID | NUMERIC | Лучшая цена спроса сегодня
24 | LOWOFFER | NUMERIC | Лучшая цена предложения сегодня
25 | NUMTRADES | NUMERIC | Количество сделок за сегодня
26 | PREVPRICE | NUMERIC | Цена закрытия
27 | PREVWAPRICE | NUMERIC | Предыдущая оценка
28 | CLOSEPRICE | NUMERIC | Цена периода закрытия
29 | LASTCHANGE | NUMERIC | % изменения от закрытия
30 | DIVIDENDDATE | NUMERIC | Дата закрытия реестра
31 | PRIMARYDIST | STRING | Размещение
32 | ACCRUEDINT | NUMERIC | Накопленный купонный доход
33 | YIELD | NUMERIC | Доходность последней сделки
34 | COUPONVALUE | NUMERIC | Размер купона
35 | YIELDATPREVWAPRI | NUMERIC | Доходность по предыдущей оценке
36 | YIELDATWAPRICE | NUMERIC | Доходность по оценке
37 | PRICEMINUSPREVWAPRICE | NUMERIC | Разница цены последней к предыдущей оценке
38 | CLOSEYIELD | NUMERIC | Доходность закрытия
39 | CURRENTVALUE | NUMERIC | Текущее значение индексов Московской Биржи
40 | LASTVALUE | NUMERIC | Значение индексов Московской Биржи на закрытие предыдущего дня
41 | LASTTOPREVSTLPRC | NUMERIC | Разница цены последней к предыдущей сессии
42 | PREVSETTLEPRICE | NUMERIC | Предыдущая расчетная цена
43 | PRICEMVTLIMIT | NUMERIC | Лимит изменения цены
44 | PRICEMVTLIMITT1 | NUMERIC | Лимит изменения цены T1
45 | MAXOUTVOLUME | NUMERIC | Лимит объема активных заявок (в контрактах)
46 | PRICEMAX | NUMERIC | Максимально возможная цена
47 | PRICEMIN | NUMERIC | Минимально возможная цена
48 | NEGVALTODAY | NUMERIC | Оборот внесистемных в деньгах
49 | NEGNUMTRADES | NUMERIC | Количество внесистемных сделок за сегодня
50 | NUMCONTRACTS | NUMERIC | Количество открытых позиций
51 | CLOSETIME | STRING | Время закрытия предыдущих торгов (для индексов РТС)
52 | OPENVAL | NUMERIC | Значение индекса РТС на момент открытия торгов
53 | CHNGOPEN | NUMERIC | Изменение текущего индекса РТС по сравнению со значением открытия
54 | CHNGCLOSE | NUMERIC | Изменение текущего индекса РТС по сравнению со значением закрытия
55 | BUYDEPO | NUMERIC | Гарантийное обеспечение продавца
56 | SELLDEPO | NUMERIC | Гарантийное обеспечение покупателя
57 | CHANGETIME | STRING | Время последнего изменения
58 | SELLPROFIT | NUMERIC | Доходность продажи
59 | BUYPROFIT | NUMERIC | Доходность покупки
60 | TRADECHANGE | NUMERIC | Разница цены последней к предыдущей сделки (Срочный рынок МБ, ФБ СПБ, СПВБ)
61 | FACEVALUE | NUMERIC | Номинал (для инструментов СПВБ)
62 | MARKETPRICE | NUMERIC | Рыночная цена вчера
63 | MARKETPRICETODAY | NUMERIC | Рыночная цена
64 | NEXTCOUPON | NUMERIC | Дата выплаты купона
65 | BUYBACKPRICE | NUMERIC | Цена оферты
66 | BUYBACKDATE | NUMERIC | Дата оферты
67 | ISSUESIZE | NUMERIC | Объем обращения
68 | PREVDATE | NUMERIC | Дата предыдущего торгового дня
69 | DURATION | NUMERIC | Дюрация
70 | LOPENPRICE | NUMERIC | Официальная цена открытия
71 | LCURRENTPRICE | NUMERIC | Официальная текущая цена
72 | LCLOSEPRICE | NUMERIC | Официальная цена закрытия
73 | QUOTEBASIS | STRING | Тип цены
74 | PREVADMITTEDQUOT | NUMERIC | Признаваемая котировка предыдущего дня
75 | LASTBID | NUMERIC | Лучшая спрос на момент завершения периода торгов
76 | LASTOFFER | NUMERIC | Лучшее предложение на момент завершения торгов
77 | PREVLEGALCLOSEPR | NUMERIC | Цена закрытия предыдущего дня
78 | COUPONPERIOD | NUMERIC | Длительность купона
79 | MARKETPRICE2 | NUMERIC | Рыночная цена 2
80 | ADMITTEDQUOTE | NUMERIC | Признаваемая котировка
81 | BGOP | NUMERIC | БГО по покрытым позициям
82 | BGONP | NUMERIC | БГО по непокрытым позициям
83 | STRIKE | NUMERIC | Цена страйк
84 | STEPPRICET | NUMERIC | Стоимость шага цены
85 | STEPPRICE | NUMERIC | Стоимость шага цены (для новых контрактов срочного рынка Московской Биржи)
86 | SETTLEPRICE | NUMERIC | Расчетная цена
87 | OPTIONTYPE | STRING | Тип опциона
88 | OPTIONBASE | STRING | Базовый актив
89 | VOLATILITY | NUMERIC | Волатильность опциона
90 | THEORPRICE | NUMERIC | Теоретическая цена
91 | PERCENTRATE | NUMERIC | Агрегированная ставка
92 | ISPERCENT | STRING | Тип цены фьючерса
93 | CLSTATE | STRING | Статус клиринга
94 | CLPRICE | NUMERIC | Котировка последнего клиринга
95 | STARTTIME | STRING | Начало основной сессии
96 | ENDTIME | STRING | Окончание основной сессии
97 | EVNSTARTTIME | STRING | Начало вечерней сессии
98 | EVNENDTIME | STRING | Окончание вечерней сессии
99 | MONSTARTTIME | STRING | Начало утренней сессии
100 | MONENDTIME | STRING | Окончание утренней сессии
101 | CURSTEPPRICE | STRING | Валюта шага цены
102 | REALVMPRICE | NUMERIC | Текущая рыночная котировка
103 | MARG | STRING | Маржируемый
104 | EXPDATE | NUMERIC | Дата исполнения инструмента
105 | CROSSRATE | NUMERIC | Курс
106 | BASEPRICE | NUMERIC | Базовый курс
107 | HIGHVAL | NUMERIC | Максимальное значение (RTSIND)
108 | LOWVAL | NUMERIC | Минимальное значение (RTSIND)
109 | ICHANGE | NUMERIC | Изменение (RTSIND)
110 | IOPEN | NUMERIC | Значение на момент открытия (RTSIND)
111 | PCHANGE | NUMERIC | Процент изменения (RTSIND)
112 | OPENPERIODPRICE | NUMERIC | Цена предторгового периода
113 | MIN_CURR_LAST | NUMERIC | Минимальная текущая цена
114 | SETTLECODE | STRING | Код расчетов по умолчанию
115 | STEPPRICECL | DOUBLE | Стоимость шага цены для клиринга
116 | STEPPRICEPRCL | DOUBLE | Стоимость шага цены для промклиринга
117 | MIN_CURR_LAST_TI | STRING | Время изменения минимальной текущей цены
118 | PREVLOTSIZE | DOUBLE | Предыдущее значение размера лота
119 | LOTSIZECHANGEDAT | DOUBLE | Дата последнего изменения размера лота
120 | AUCTPRICE | NUMERIC | Цена послеторгового аукциона
121 | CLOSING_AUCTION_VOLUME | NUMERIC | Количество в сделках послеторгового аукциона

    Список идентификаторов дополнительных параметров, доступных для функции GET_PARAM_EX:

    № | Параметр | Тип | Описание
1 | LONGNAME | STRING | Полное название инструмента
2 | SHORTNAME | STRING | Краткое название инструмента
3 | CODE | STRING | Код инструмента
4 | CLASSNAME | STRING | Название класса
5 | CLASS_CODE | STRING | Код класса
6 | TRADE_DATE_CODE | DOUBLE | Дата торгов
7 | MAT_DATE | DOUBLE | Дата погашения
8 | DAYS_TO_MAT_DATE | DOUBLE | Число дней до погашения
9 | SEC_FACE_VALUE | DOUBLE | Номинал инструмента
10 | SEC_FACE_UNIT | STRING | Валюта номинала
11 | SEC_SCALE | DOUBLE | Точность цены
12 | SEC_PRICE_STEP | DOUBLE | Минимальный шаг цены
13 | SECTYPE | STRING | Тип инструмента

    См. также Функции для получения значений Таблицы текущих значений параметров


Функции для получения значений Окна котировок

GET_QUOTES_II_LEVEL_DATA

Функция предназначена для получения значений котировок инструментов. С помощью этой функции можно получить данные из Таблицы котировок для заданных кодов класса и инструмента.

MAP GET_QUOTES_II_LEVEL_DATA (STRING ClassCode, STRING SecCode)

Возвращаемый «MAP» имеет следующую структуру:

№ | Параметр | Тип | Описание
1 | BID_COUNT | DOUBLE | Количество котировок покупки
2 | OFFER_COUNT | DOUBLE | Количество котировок продажи
3 | BID | COLLECTION | Котировки спроса (покупки)
4 | OFFER | COLLECTION | Котировки предложений (продажи)

Коллекции «BID» и «OFFER» имеют следующую структуру:

№ | Параметр | Тип | Описание
1 | PRICE | DOUBLE | Цена покупки / продажи
2 | QUANTITY | DOUBLE | Количество в лотах


Функции для получения значений таблицы «Позиции по инструментам»

Функции предназначены для получения значений таблицы для заданного кода клиента, кода фирмы, кода инструмента и счета депо.

DEPO_OPEN_BALANCE

Возвращает значение «Входящего остатка по инструментам».

DEPO_OPEN_BALANCE (STRING client_code, STRING firmid, STRING seccode, STRING account)

DEPO_OPEN_LIMIT

Возвращает значение «Входящего лимита по инструментам».

DEPO_OPEN_LIMIT (STRING client_code, STRING firmid, STRING seccode, STRING account)

DEPO_CURRENT_BALANCE

Возвращает значение «Текущего остатка по инструментам».

DEPO_CURRENT_BALANCE (STRING client_code, STRING firmid, STRING seccode, STRING account)

DEPO_CURRENT_ LIMIT

Возвращает значение «Текущего лимита по инструментам».

DEPO_CURRENT_LIMIT (STRING client_code, STRING firmid, STRING seccode, STRING account)

DEPO_LIMIT_AVAILABLE

Возвращает значение доступного количества инструментов.

DEPO_LIMIT_AVAILABLE (STRING client_code, STRING firmid, STRING seccode, STRING account)

DEPO_LIMIT_LOCKED

Возвращает значение «Заблокированного количества инструментов».

DEPO_LIMIT_LOCKED (STRING client_code, STRING firmid, STRING seccode, STRING account)

DEPO_LIMIT_LOCKED_BUY

Возвращает значение «Заблокированного на покупку количества лотов».

DEPO_LIMIT_LOCKED_BUY (STRING client_code, STRING firmid, STRING seccode, STRING account)

DEPO_LIMIT_LOCKED_BUY_VALUE

Возвращает значение «Стоимости инструментов, заблокированных на покупку».

DEPO_LIMIT_LOCKED_BUY_VALUE (STRING client_code, STRING firmid, STRING seccode, STRING account)

Параметры:

№ | Параметр | Тип | Описание
1 | CLIENT_CODE | STRING | Код клиента
2 | FIRMID | STRING | Код фирмы
3 | SECCODE | STRING | Код инструмента
4 | ACCOUNT * | STRING | Счет депо

(*) Параметр «ACCOUNT» должен указываться с соблюдением регистра символов (верхнего/нижнего).

Пример:

‘
ClDepoOB = DEPO_OPEN_BALANCE ("1075", "NC0080000000", "HYDR", "L01-00000F00")
ClDepoOL = DEPO_OPEN_LIMIT ("1075","NC0080000000", "HYDR", "L01-00000F00")
ClDepoСB = DEPO_CURRENT_BALANCE ("1075", "NC0080000000", "HYDR", "L01-00000F00")
ClDepoCL = DEPO_CURRENT_LIMIT ("1075", "NC0080000000", "HYDR", "L01-00000F00")
ClDepoAV = DEPO_LIMIT_AVAILABLE ("1075", "NC0080000000", "HYDR","L01-00000F00")
ClDepoLCK = DEPO_LIMIT_LOCKED ("1075", "NC0080000000", "HYDR", "L01-00000F00")
ClDepoLCKBuy = DEPO_LIMIT_LOCKED_BUY ("1075", "NC0080000000", "HYDR","L01-00000F00")
ClDepoLCKBuyValue = DEPO_LIMIT_LOCKED_BUY_VALUE ("1075", "NC0080000000", "HYDR","L01-00000F00")
‘

В примере показано присвоение переменным значений таблицы «Позиции по инструментам» для клиента с кодом «1075» по обыкновенным акциям «РусГидро»:

  • переменной «ClDepoOB» присваивается значение входящего остатка;
  • переменной «ClDepoOL» присваивается значение входящего лимита;
  • переменной «ClDepoCB» присваивается значение текущего остатка;
  • переменной «ClDepoCL» присваивается значение текущего лимита;
  • переменной «ClDepoAV» присваивается значение доступного количества инструментов;
  • переменной «ClDepoLCK» присваивается значение заблокированного количества инструментов;
  • переменной «ClDepoLCKBuy» присваивается значение заблокированного на покупку количества лотов;
  • переменной «ClDepoLCKBuyValue» присваивается значение стоимости инструментов, заблокированных на покупку.


Функции для получения значений таблицы «Позиции по деньгам»

Функции предназначены для получения значений таблицы для заданного кода клиента, кода фирмы, кода позиции и кода валюты.

MONEY_OPEN_BALANCE

Возвращает значение «Входящего остатка по денежным средствам».

MONEY_OPEN_BALANCE (STRING client_code, STRING firmid, STRING tag, STRING curr_code)

MONEY_OPEN_LIMIT

Возвращает значение «Входящего лимита по денежным средствам».

MONEY_OPEN_LIMIT (STRING client_code, STRING firmid, STRING tag, STRING curr_code)

MONEY_CURRENT_BALANCE

Возвращает значение «Текущего остатка по денежным средствам».

MONEY_CURRENT_BALANCE (STRING client_code, STRING firmid, STRING tag, STRING curr_code)

MONEY_CURRENT_LIMIT

Возвращает значение «Текущего лимита по денежным средствам».

MONEY_CURRENT_LIMIT (STRING client_code, STRING firmid, STRING tag, STRING curr_code)

MONEY_LIMIT_AVAILABLE

Возвращает значение «Доступного количества денежных средств».

MONEY_LIMIT_AVAILABLE (STRING client_code, STRING firmid, STRING tag, STRING curr_code)

MONEY_LIMIT_LOCKED

Возвращает значение «Заблокированного количества денежных средств.

MONEY_LIMIT_LOCKED (STRING client_code, STRING firmid, STRING tag, STRING curr_code)

Пример:

‘
ClMoneyOB = MONEY_OPEN_BALANCE ("1075","NC0080000000", "EQTV", "SUR")
ClMoneyOL =  MONEY_OPEN_LIMIT ("1075", "NC0080000000", "EQTV", "SUR")
ClMoneyCB = MONEY_CURRENT_BALANCE ("1075", "NC0080000000", "EQTV", "SUR")
ClMoneyCL = MONEY_CURRENT_LIMIT ("1075", "NC0080000000", "EQTV", "SUR")
ClMoneyAV =    MONEY_LIMIT_AVAILABLE ("1075","NC0080000000", "EQTV", "SUR")
ClMoneyLCK = MONEY_LIMIT_LOCKED ("1075", "NC0080000000", "EQTV", "SUR")
‘

В примере показано присвоение переменным значений таблицы «Позиции по деньгам» на Фондовой Московской Бирже для клиента с кодом «1075»:

  • переменной «ClMoneyOB» присваивается значение входящего остатка по денежным средствам;
  • переменной «ClMoneyOL» присваивается значение входящего лимита по денежным средствам;
  • переменной «ClMoneyCB» присваивается значение текущего остатка по денежным средствам;
  • переменной «ClMoneyCL» присваивается значение текущего лимита по денежным средствам;
  • переменной «ClMoneyAV» присваивается значение доступного количества денежных средств;
  • переменной «ClMoneyLCK» присваивается значение заблокированного количества денежных средств.


Функции расчета маржинальных позиций

Функции предназначены для получения значений маржинальных позиций для заданного кода клиента, кода фирмы, кода класса, счета депо и кода параметра цены, по которой идет расчет стоимости (например «OPEN» – цена открытия, «LAST» – цена последней сделки и т.п.).

SHORT_VALUE

Возвращает значение «Стоимости всех коротких позиций».

SHORT_VALUE (STRING client_code, STRING firmid, STRING seccode, STRING class_code, STRING account, STRING price_param_code)

LONG_VALUE

Возвращает значение «Стоимости всех длинных позиций».

LONG_VALUE (STRING client_code, STRING firmid, STRING seccode, STRING class_code, STRING account, STRING price_param_code)

Параметры:

№ | Параметр | Тип | Описание
1 | CLIENT_CODE | STRING | Код клиента
2 | FIRMID | STRING | Код фирмы
3 | SECCODE | STRING | Код инструмента
4 | CLASS_CODE | STRING | Код класса
5 | ACCOUNT * | STRING | Счет депо
6 | PRICE_PARAM_CODE | STRING | Код параметра цены

(*) Параметр «ACCOUNT» должен указываться с соблюдением регистра символов (верхнего/нижнего).

Пример:

‘
ClShortsValue = SHORT_VALUE ("1075", "NC0080000000", "HYDR", "TQBR", "L01-00000F00", "LAST")
ClLongsValue = LONG_VALUE ("1075", "NC0080000000", "HYDR", "TQBR", "L01-00000F00", "OPEN")
‘

Переменной «ClShortsValue» присваивается значение стоимости всех коротких позиций для клиента с кодом «1075» по инструменту «РусГидро» из класса «А1-Акции» по счету «L01-00000F00», исходя из цены последней сделки.

Переменной ClLongsValue присваивается значение стоимости всех длинных позиций для клиента с кодом «1075» по инструменту «РусГидро» из класса «А1-Акции» по счету "L01-00000F00", исходя из цены открытия.


Функции получения значений таблиц «Клиентский портфель» и «Купить/Продать»

  • GET_CLIENT_MARGINAL_PORTFOLIO_INFO
  • GET_CLIENT_MARGINAL_PORTFOLIO_INFO_EX
  • GET_CLIENT_MARGINAL_BUY_SELL_INFO
  • GET_CLIENT_MARGINAL_BUY_SELL_INFO_EX

    • Функции предназначены для получения значений указанных таблиц. Значения этих таблиц вычисляются на рабочем месте клиента QUIK с периодичностью, установленной в настройках (пункт меню Система/Настройки/Основные настройки..., раздел «Торговля» / «Клиентский портфель», флажок «Обновлять через каждые .. секунд»).

    GET_CLIENT_MARGINAL_PORTFOLIO_INFO

    Функция возвращает ассоциативный массив (MAP) с параметрами таблицы Клиентский портфель, соответствующих идентификатору участника торгов «firmid» и коду клиента «client_code».

    MAP GET_CLIENT_MARGINAL_PORTFOLIO_INFO (STRING firmid, STRING client_code)

    Параметры:

    № Параметр Тип Описание Заголовок поля в таблице
    1 IS_LEVERAGE STRING (12)

    Признак использования схемы кредитования с контролем текущей стоимости активов. Возможные значения:

    • «МЛ» – используется схема ведения позиции «по плечу», «плечо» рассчитано по значению Входящего лимита;
    • «МП» – используется схема ведения позиции «по плечу», «плечо» указано явным образом;
    • «МОП» – используется схема ведения позиции «лимит на открытую позицию»;
    • «МД» – используется схема ведения позиции «по дисконтам»;
    • <пусто> - используется схема ведения позиции «по лимитам»
             Тип клиента
    2 | IN_ASSETS | DOUBLE | Оценка собственных средств клиента до начала торгов | Вход. активы
    3 | LEVERAGE | DOUBLE | Плечо. Если не было задано явно, то отношение Входящего лимита к Входящим активам | Плечо
    4 | OPEN_LIMIT | DOUBLE | Оценка максимальной величины заемных средств до начала торгов | Вход. лимит
    5 | VAL_SHORT | DOUBLE | Оценка стоимости коротких позиций. Значение всегда отрицательное | Шорты
    6 | VAL_LONG | DOUBLE | Оценка стоимости длинных позиций | Лонги
    7 | VAL_LONG_MARGIN | DOUBLE | Оценка стоимости длинных позиций по маржинальным инструментам, принимаемым в обеспечение | Лонги МО
    8 | VAL_LONG_ASSET | DOUBLE | Оценка стоимости длинных позиций по немаржинальным инструментам, принимаемым в обеспечение | Лонги О
    9 | ASSETS | DOUBLE | Оценка собственных средств клиента по текущим позициям и ценам | Стоимость портфеля
    10 | CUR_LEVERAGE | DOUBLE | Текущее плечо | Тек.плечо
    11 | MARGIN | DOUBLE | Уровень маржи, в процентах | Ур. маржи
    12 | LIM_ALL | DOUBLE | Текущая оценка максимальной величины заемных средств | Тек. лимит
    13 | AV_LIM_ALL | DOUBLE | Оценка величины заемных средств, доступных для дальнейшего открытия позиций | ДостТекЛимит
    14 | LOCKED_BUY | DOUBLE | Оценка стоимости активов в заявках на покупку | Блок. покупка
    15 | LOCKED_BUY_MARGIN | DOUBLE | Оценка стоимости активов в заявках на покупку маржинальных инструментов, принимаемых в обеспечение | Блок. пок. маржин.
    16 | LOCKED_BUY_ASSET | DOUBLE | Оценка стоимости активов в заявках на покупку немаржинальных инструментов, принимаемых в обеспечение | Блок.пок. обесп.
    17 | LOCKED_SELL | DOUBLE | Оценка стоимости активов в заявках на продажу маржинальных инструментов | Блок. продажа
    18 | LOCKED_VALUE_COEF | DOUBLE | Оценка стоимости активов в заявках на покупку немаржинальных инструментов | Блок. пок. немарж.
    19 | IN_ALL_ASSETS | DOUBLE | Оценка стоимости всех позиций клиента в ценах закрытия предыдущей торговой сессии, включая позиции по немаржинальным инструментам | ВходСредства
    20 | ALL_ASSETS | DOUBLE | Текущая оценка стоимости всех позиций клиента | ТекСредства
    21 | PROFIT_LOSS | DOUBLE | Абсолютная величина изменения стоимости всех позиций клиента | Прибыль/убытки
    22 | RATE_CHANGE | DOUBLE | Относительная величина изменения стоимости всех позиций клиента | ПроцИзмен
    23 | LIM_BUY | DOUBLE | Оценка денежных средств, доступных для покупки маржинальных инструментов | На покупку
    24 | LIM_SELL | DOUBLE | Оценка стоимости маржинальных инструментов, доступных для продажи | На продажу
    25 | LIM_NON_MARGIN | DOUBLE | Оценка денежных средств, доступных для покупки немаржинальных инструментов | НаПокупНеМаржин
    26 | LIM_BUY_ASSET | DOUBLE | Оценка денежных средств, доступных для покупки инструментов, принимаемых в обеспечение | НаПокупОбесп
    27 | VAL_SHORT_NET | DOUBLE | Оценка стоимости коротких позиций. При расчете не используется коэффициент дисконтирования * | Шорты (нетто)
    28 | VAL_ LONG_NET | DOUBLE | Оценка стоимости длинных позиций. При расчете не используется коэффициент дисконтирования * | Лонги (нетто)
    29 | TOTAL_MONEY_BAL | DOUBLE | Сумма остатков по денежным средствам по всем позициям, без учета средств, заблокированных под исполнение обязательств, выраженная в выбранной валюте расчета | Сумма ден. остатков
    30 | TOTAL_LOCKED_MONEY | DOUBLE | Cумма заблокированных средств со всех денежных позиций клиента, пересчитанная в валюту расчетов через кросс-курсы на сервере | Суммарно заблок.
    31 | HAIRCUTS | DOUBLE | Сумма дисконтов стоимости длинных (только по инструментам обеспечения) и коротких позиций по инструментам, дисконтов корреляции между инструментами, а также дисконтов на задолженности по валютам, не покрытые обеспечением по инструментам в этих же валютах | Сумма дисконтов
    32 | ASSETS_WITHOUT_HC | DOUBLE | Суммарная величина денежных остатков, стоимости длинных позиций по инструментам обеспечения и стоимости коротких позиций, без учета дисконтирующих коэффициентов, без учета неттинга стоимости инструментов в рамках объединенной позиции по инструментам и без учета корреляции между инструментами | ТекАктБезДиск
    33 | STATUS_COEF | DOUBLE | Отношение суммы дисконтов к текущим активам без учета дисконтов | Статус счета
    34 | VARMARGIN | DOUBLE | Текущая вариационная маржа по позициям клиента, по всем инструментам | Вариац. маржа
    35 | GO_FOR_POSITIONS | DOUBLE | Размер денежных средств, уплаченных под все открытые позиции на срочном рынке | ГО поз.
    36 | GO_FOR_ORDERS | DOUBLE | Оценка стоимости активов в заявках на срочном рынке | ГО заяв.
    37 | RATE_FUTURES | DOUBLE | Отношение ликвидационной стоимости портфеля к ГО по срочному рынку | Активы/ГО
    38 IS_QUAL_CLIENT STRING Признак «квалифицированного» клиента, которому разрешено кредитование заемными средствами с плечом 1:3. Возможные значения:
    • «ПовышУрРиска» – квалифицированный;
    • <пусто> - нет
             ПовышУрРиска
    39 | IS_FUTURES | STRING | Счет клиента на срочном рынке Московской Биржи, в случае наличия объединенной позиции, иначе поле остается пустым | Сроч. счет
    40 | CURR_TAG | STRING | Актуальные текущие параметры расчета для данной строки в формате «<Валюта>-<Идентификатор торговой сессии>». Пример: «SUR-EQTV» | Парам. расч.

    (*) Подробнее о коэффициентах дисконтирования см. п. 7 Руководства по администрированию «Настройки Библиотеки расчета лимитов».

    Пример:

    ‘
    GET_CLIENT_MARGINAL_PORTFOLIO_INFO ("NC0080000000", "1")
    ‘

    GET_CLIENT_MARGINAL_PORTFOLIO_INFO_EX

    Функция возвращает ассоциативный массив (MAP) с параметрами таблицы Клиентский портфель, соответствующих идентификатору участника торгов «firmid», коду клиента «client_code» и сроку расчетов «limit_kind».

    MAP GET_CLIENT_MARGINAL_PORTFOLIO_INFO_EX (STRING firmid, STRING client_code, DOUBLE limit_kind)

    Возможные значения параметра «limit_kind»:

    • «0» – срок расчетов «Т0»;
    • «1» – срок расчетов «Т1»;
    • «2» – срок расчетов «Т2»;
    • «365» – срок расчетов «Тx».

    Дополнительно возвращаются следующие параметры:

    № | Параметр | Тип | Описание |
1 | INIT_MARGIN | DOUBLE | Значение начальной маржи. Заполняется для клиентов типа «МД» | Нач.маржа
2 | MIN_MARGIN | DOUBLE | Значение минимальной маржи. Заполняется для клиентов типа «МД» | Мин.маржа
3 | CORRECTED_MARGIN | DOUBLE | Значение скорректированной маржи. Заполняется для клиентов типа «МД» | Скор.маржа
4 | CLIENT_TYPE | DOUBLE | Тип клиента | Тип клиента
5 | PORTFOLIO_VALUE | DOUBLE | Стоимость портфеля. Для клиентов типа «МД» возвращается значение для строк с максимальным сроком расчетов limit_kind | Стоимость портфеля
6 | RCV1 | DOUBLE | Норматив покрытия риска 1. Рассчитывается как разница параметров «Стоимость портфеля» и «Начальная маржа». Для клиентов типа «МД» и «МД+» | НПР1
7 | RCV2 | DOUBLE | Норматив покрытия риска 2. Рассчитывается как разница параметров «Стоимость портфеля» и «Минимальная маржа». Для клиентов типа «МД» и «МД+» | НПР2

    Пример:

    ‘
    GET_CLIENT_MARGINAL_PORTFOLIO_INFO_EX ("NC0080000000", "1", "0")
    ‘

    GET_CLIENT_MARGINAL_BUY_SELL_INFO

    Функция возвращает ассоциативный массив (MAP) с параметрами таблицы Купить/Продать, означающими возможность купить либо продать указанный инструмент «sec_code» класса «class_code», указанным клиентом «client_code» фирмы «firmid», по указанной цене «price». Если цена равна «0», то используются лучшие значения спроса/предложения.

    MAP GET_CLIENT_MARGINAL_BUY_SELL_INFO (STRING firmid, STRING client_code, STRING class_code, STRING sec_code, DOUBLE price)

    Параметры:

    № Параметр Тип Описание
    1 IS_MARGIN_SEC DOUBLE Признак маржинальности инструмента. Возможные значения:
    • «1» – маржинальная;
    • «0» – не маржинальная.

    Не заполняется для клиентов типа «МД»
    2 IS_ASSET_SEC DOUBLE Принадлежность инструмента к списку инструментов, принимаемых в обеспечение. Возможные значения:
    • «1» – принимается в обеспечение;
    • «0» – не принимается в обеспечение.

    Не заполняется для клиентов типа «МД»
    3 | BALANCE | DOUBLE | Текущая позиция по инструменту, в лотах
    4 | CAN_BUY | DOUBLE | Оценка количества лотов, доступных на покупку по указанной цене *
    5 | CAN_SELL | DOUBLE | Оценка количества лотов, доступных на продажу по указанной цене *
    6 | POSITION_VALUATION | DOUBLE | Денежная оценка позиции по инструменту по ценам спроса/предложения
    7 | VALUE | DOUBLE | Оценка стоимости позиции по цене последней сделки
    8 | OPEN_VALUE | DOUBLE | Оценка стоимости позиции клиента, рассчитанная по цене закрытия предыдущей торговой сессии
    9 | LIM_LONG | DOUBLE | Предельный размер позиции по данному инструменту, принимаемый в обеспечение длинных позиций
    10 | LONG_COEF | DOUBLE | Коэффициент дисконтирования, применяемый для длинных позиций по данному инструменту
    11 | LIM_SHORT | DOUBLE | Предельный размер короткой позиции по данному инструменту
    12 | SHORT_COEF | DOUBLE | Коэффициент дисконтирования, применяемый для коротких позиций по данному инструменту
    13 | VALUE_COEF | DOUBLE | Оценка стоимости позиции по цене последней сделки, с учетом дисконтирующих коэффициентов
    14 | OPEN_VALUE_COEF | DOUBLE | Оценка стоимости позиции клиента, рассчитанная по цене закрытия предыдущей торговой сессии с учетом дисконтирующих коэффициентов
    15 | SHARE | DOUBLE | Процентное отношение стоимости позиции по данному инструменту к стоимости всех активов клиента, рассчитанное по текущим ценам
    16 | SHORT_WA_PRICE | DOUBLE | Средневзвешенная стоимость коротких позиций по инструментам
    17 | LONG_WA_PRICE | DOUBLE | Средневзвешенная стоимость длинных позиций по инструментам
    18 | PROFIT_LOSS | DOUBLE | Разница между средневзвешенной ценой приобретения инструментов и их рыночной оценки
    19 | SPREAD_HC | DOUBLE | Коэффициент корреляции между инструментами
    20 | CAN_BUY_OWN | DOUBLE | Максимально возможное количество инструментов в заявке на покупку этого инструмента на этом классе на собственные средства клиента, исходя из лучшей цены предложения
    21 | CAN_SELL_OWN | DOUBLE | Максимально возможное количество инструментов в заявке на продажу этого инструмента на этом классе из собственных активов клиента, исходя из лучшей цены спроса
    22 IS_REST_SHORT_SEC DOUBLE Признак того, является ли инструмент разрешенным для продажи на заемные средства. Возможные значения:
    • «1» – разрешена;
    • «0» – не разрешена.

    Не заполняется для клиентов типа «МД»

    (*) В зависимости от настроек сервера QUIK, величина может выражаться в лотах, либо в штуках. Уточните единицу измерения у обслуживающего брокера.

    Пример:

    ‘
    GET_CLIENT_MARGINAL_BUY_SELL_INFO ("NC0080000000", "1", "TQBR", "HYDR",0)
    ‘

    GET_CLIENT_MARGINAL_BUY_SELL_INFO_EX

    Функция возвращает ассоциативный массив (MAP) с параметрами таблицы Купить/Продать, означающими возможность купить либо продать указанный инструмент «sec_code» класса «class_code», указанным клиентом «client_code» фирмы «firmid», по указанной цене «price». Если цена равна «0», то используются лучшие значения спроса/предложения.

    MAP GET_CLIENT_MARGINAL_BUY_SELL_INFO (STRING firmid, STRING client_code, STRING class_code, STRING sec_code, DOUBLE price)

    Дополнительно возвращаются следующие параметры:

    № Параметр Тип Описание
    1 LIMIT_KIND DOUBLE Срок расчётов. Возможные значения:
    • «0» – «Т0»;
    • «1» – «Т1»;
    • «2» – «Т2»
    2 D_LONG DOUBLE Эффективный начальный дисконт для длинной позиции. Заполняется для клиентов типа «МД»
    Заполняется для клиентов типа «МД»
    3 D_MIN_LONG DOUBLE Эффективный минимальный дисконт для длинной позиции. Заполняется для клиентов типа «МД»
    Заполняется для клиентов типа «МД»
    4 | D_SHORT | DOUBLE | Эффективный начальный дисконт для короткой позиции. Заполняется для клиентов типа «МД»
    5 | D_MIN_SHORT | DOUBLE | Эффективный минимальный дисконт для короткой позиции. Заполняется для клиентов типа «МД»
    6 | CLIENT_TYPE | DOUBLE | Тип клиента
    7 IS_LONG_ALLOWED DOUBLE Признак того, является ли инструмент разрешенным для покупки на заемные средства. Возможные значения:
    • «1» – разрешена;
    • «0» – не разрешена.

    Заполняется для клиентов типа «МД»
    8 IS_SHORT_ALLOWED DOUBLE Признак того, является ли инструмент разрешенным для продажи на заемные средства. Возможные значения:
    • «1» – разрешена;
    • «0» – не разрешена.

    Заполняется для клиентов типа «МД»

    Пример:

    ‘
    GET_CLIENT_MARGINAL_BUY_SELL_INFO_EX ("NC0080000000", "1", "TQBR", "HYDR",0)
    ‘


Функции для работы с файлами

  • CLEAR_FILE
  • WRITE
  • WRITELN
  • GET_FILE_LEN
  • READ_LINE

    • Функции предназначены для работы с текстовыми файлами и могут использоваться, например, для ведения журнала (log-файла) действий программы. Названия файлов могут содержать пути к ним, например «C:/QUIK/log/new.log».

    CLEAR_FILE

    Очищает указанный файл.

    MAP CLEAR_FILE (STRING target_file)

    Функция возвращает ассоциативный массив (MAP), содержащий параметры:

    № Параметр Тип Описание
    1 RESULT DOUBLE Результат выполнения операции. Возможные значения:
    • «1» – выполнено успешно;
    • «0» – произошла ошибка
    2 DESCRIPTION STRING Диагностика операционной системы в случае ошибки

    WRITE

    Записывает в конец файла «target_file» строку «string_to_write».

    MAP WRITE (STRING target_file, STRING string_to_write)

    Функция возвращает ассоциативный массив (MAP), содержащий параметры:

    № Параметр Тип Описание
    1 RESULT DOUBLE Результат выполнения операции. Возможные значения:
    • «1» – выполнено успешно;
    • «0» – произошла ошибка
    2 DESCRIPTION STRING Диагностика операционной системы в случае ошибки

    WRITELN

    Записывает в конец файла «target_file» строку «string_to_write» с последующим переводом строки.

    MAP WRITELN (STRING target_file, STRING string_to_write)

    Функция возвращает ассоциативный массив (MAP), содержащий параметры:

    № Параметр Тип Описание
    1 RESULT DOUBLE Результат выполнения операции. Возможные значения:
    • «1» – выполнено успешно;
    • «0» – произошла ошибка
    2 DESCRIPTION STRING Диагностика операционной системы в случае ошибки

    Пример:

    ‘
    CLEAR_FILE ("new.log")
    WRITE ("new.log","Hello, ")
    WRITELN ("new.log","world")
    ‘

    GET_FILE_LEN

    Возвращает количество строк в файле «target_file». Если такого файла не существует, возвращает «-1».

    DOUBLE GET_FILE_LEN (STRING target_file)

    READ_LINE

    Функция считывает из файла «target_file» и возвращает строку под номером «line». Длина строки не должна превышать 1000 символов, строки большей длины при считывании будут обрезаны.

    STRING READ_LINE (STRING target_file, DOUBLE line, DOUBLE error)

    «error» - возвращаемый результат выполнения операции. Если значение равно «0», то чтение прошло успешно; «1» - произошла ошибка, «2» - достигнут конец файла.

    Пример:

    ‘
    WRITELN ("new.log","Hello, world")
    msg = READ_LINE ("new.log", GET_FILE_LEN("new.log"), error)
    MESSAGE (msg,1)
    ‘


Функции для работы со строками

LEN

Возвращает длину строковой переменной «value».

DOUBLE LEN (STRING value)

TRIM

Обрезает пробелы в начале и в конце строки.

STRING TRIM (STRING value)

Функция возвращает строку без пустых символов в начале и в конце строки.

SUBSTR

Возвращает подстроку из строки «value», начиная с символа с номером «start» и длиной «len».

STRING SUBSTR (STRING value, DOUBLE start, DOUBLE len)

FIND

Ищет вхождение подстроки в заданную строку.

DOUBLE FIND (STRING value, DOUBLE start, STRING sub)

Функция возвращает позицию первого вхождения подстроки «sub» в строке «value», начиная с позиции «start». Если подстрока не найдена, функция возвращает результат «-1».

Пример:

‘
stroka="anymessage"
stroka2=SUBSTR(stroka, FIND(stroka, 1, "message"), LEN("message"))
MESSAGE (stroka2,2)
‘


Функции для работы с графиками

  • GET_CANDLE
  • GET_CANDLE_EX

    • GET_CANDLE

    Функция для обращения к данным «свечек» на графике, а также к значениям индикаторов технического анализа.

    MAP GET_CANDLE (STRING class_code, STRING sec_code, STRING parameter_name, STRING interval, STRING graph_type, DOUBLE Date, DOUBLE Time)

    Функция возвращает ассоциативный массив (MAP), содержащий информацию о ценах в момент времени «Date»«Time», для графика, построенного по инструменту с кодом «sec_code» из класса с кодом «class_code» с временным интервалом «interval». Если «class_code» равен «», то функция ищет «sec_code» по всем классам до первого нахождения.

    Тип графика указывается следующим кодом:

    Тип графика | Код | Тип графика | Код | Тип графика | Код
PRICE | 1 | PARABOLIC SAR | 10 | CUM AD | 21
VOLUME | 2 | SROC | 11 | CHAIKIN OSCILLATOR | 22
MOVING AVERAGE | 3 | MOM | 12 | CUM WAD | 23
PRICE OSCILLATOR | 4 | ROC | 13 | ELDER FI | 24
MACD | 5 | MFI | 16 | ELDER RAY | 25
STANDARD DEV | 6 | WILLIAMS %R | 17 | VERTICAL HORIZONTAL FILTER | 26
BOLLINGER LINES | 7 | ENVELOPS | 18 | CHAIKIN VOLATILITY | 27
STOCHASTIC | 8 | VOLUME OSCILLATOR | 19 |  |
RSI | 9 | BALANCE VOLUME | 20 |  |

    Значение временного интервала «interval» можно задавать следующими числовыми величинами:

    Величина интервала | Значение | Величина интервала | Значение | Величина интервала | Значение
Месячный | month | 1 минута | 1 | 15 минут | 15
 | -3 |  | 2 | 20 минут | 20
Недельный | week | 3 минуты | 3 | 30 минут | 30
 | -2 | 4 минуты | 4 | 60 минут | 60
Дневной | day | 5 минут | 5 | 2 часа | 120
 | -1 | 6 минут | 6 | 4 часа | 240
Тиковый | 0 | 10 минут | 10 |  |

    Значение «parameter_name» должно соответствовать одному из значений имени параметра из Таблицы текущих значений параметров. Их перечень см. Функции для получения значений Таблицы текущих торгов. Если «parameter_name» указан как «», то поиск осуществляется по данным Таблицы обезличенных сделок.

    Значение даты «Date» нужно указывать в формате «ГГГГММДД». Например, «20050527» означает 27 мая 2005 г. Значение времени «Time» нужно указывать в формате «ЧЧММСС». Например, «163500» означает 16 ч. 35 мин.
    Функция возвращает ассоциативный массив (MAP), содержащий параметры:

    № | Параметр | Тип | Описание
1 | OPEN | DOUBLE | Цена открытия (первой сделки) в данном интервале времени
2 | CLOSE | DOUBLE | Цена закрытия (последней сделки) в интервале
3 | HIGH | DOUBLE | Наибольшая цена сделки в интервале
4 | LOW | DOUBLE | Наименьшая цена сделки в интервале
5 | VOLUME | DOUBLE | Суммарный объем сделок в интервале

    Пример:

    ‘
    msg = GET_CANDLE("TQBR", "HYDR", "", "5", "PRICE", 20101130, 103500)

    MESSAGE(msg, 2)
    ‘

    GET_CANDLE_EX

    В некоторых случаях, например, когда индикатор технического анализа состоит из нескольких линий, применение функции GET CANDLE невозможно. Для доступа к таким графикам средствами языка QPILE используется функция GET CANDLE EX.

    MAP GET_CANDLE_EX (STRING Tag, DOUBLE Date, DOUBLE Time)

    Функция возвращает ассоциативный массив (MAP) с данными для графика со строковым идентификатором Tag в момент времени «Date» и «Time». Таким образом, для того чтобы обратиться к данным на графике, необходимо его предварительно построить и присвоить ему уникальный строковый идентификатор Tag. Идентификатор Tag задается в диалоге «Редактирование настроек графика» на вкладке «Дополнительно».

    При вызове функции значение даты «Date» нужно указывать в формате «ГГГГММДД». Например, «20050527» означает 27 мая 2005 г. Значение времени «Time» нужно указывать в формате «ЧЧММСС». Например, «163500» означает 16 ч. 35 мин. Функция округляет параметр «Time» до ближайшего меньшего значения времени, соответствующего интервалу графика. Например, если интервал графика — «5 минут», а значение параметра «Time» — «163700», то функция округлит значения параметр «Time» до «163500», а если интервал графика – «60 минут», то «163700» округлиться до «160000».

    Возвращаемый функцией ассоциативный массив содержит следующие поля:

    № | Параметр | Тип | Описание
1 | COUNT | DOUBLE | Количество линий, образующих индикатор
2 | TIME | DOUBLE | Точное время свечки
3 | LINES | DOUBLE | Коллекция линий, в которой каждый элемент коллекции содержит ассоциативный массив (MAP)

    Каждый элемент коллекции линий содержит ассоциативный массив (MAP) со следующими параметрами:

    № | Параметр | Тип | Описание
1 | NAME | STRING | Название линии (из легенды)
2 | OPEN | DOUBLE | Цена открытия в интервале времени
3 | CLOSE | DOUBLE | Цена закрытия в интервале времени
4 | HIGH | DOUBLE | Наибольшее значение цены в интервале времени
5 | LOW | DOUBLE | Наименьшее значение цены в интервале времени
6 | VOLUME | DOUBLE | Суммарный объем сделок в интервале

    Пример:

    slice = Get_Candle_Ex ("all", 20070511, 170000)

    LineCount = Get_Value (slice,"COUNT")
    time = Get_Value (slice,"TIME")

    lines = Get_Value (slice,"LINES")
    FOR lineID FROM 0 TO LineCount-1

    line = Get_Collection_Item (lines, lineID)
    open = Get_Value (line,"OPEN")

    line_name = Get_Value (line,"NAME")

    volume = Get_Value (line,"VOLUME")

    END FOR


Функции для работы с заявками

Функции предназначены для создания заявок и отправки их в торговую систему.

SEND_TRANSACTION

Отправляет заявку с параметрами, указанными в массиве «trans_params» и ожидает ответа торговой системы в течение «wait_timeout_for_replay» (в секундах, не менее 5). Элементы массива «trans_params» заполняются по правилам создания строки для импорта транзакций из файла.

MAP SEND_TRANSACTION (DOUBLE wait_timeout_for_replay, MAP trans_params)

Транзакции, выполняющие групповое снятие заявок, не поддерживаются:

  • «KILL_ALL_ORDERS» – снять все заявки из торговой системы;
  • «KILL_ALL_STOP_ORDERS» – снять все стоп-заявки;
  • «KILL_ALL_NEG_DEALS» – снять все заявки на внебиржевые сделки и заявки на сделки РЕПО.

Функция возвращает ассоциативный массив (MAP), содержащий результат обработки заявки:

№ Параметр Тип Описание
1 RESULT DOUBLE Результат выполнения операции. Возможные значения:
  • «1» – выполнено успешно;
  • «0» – произошла ошибка
2 | RESULT_EX | STRING | Расширенная диагностика выполнения операции. Может принимать значения, соответствующие полю «STATUS» в «.tro»-файле при импорте транзакций.
3 | ORDER_NUMBER | DOUBLE | Регистрационный номер заявки в торговой системе
4 | DESCRIPTION | STRING | Текстовый комментарий с ответом сервера QUIK или торговой системы

Пример:

‘

new_global("trans_params", "")

new_global("trans_result", "")

trans_params = CREATE_MAP  ()

trans_params = set_value (trans_params, "TRANS_ID", "333")

trans_params = set_value (trans_params, "ACTION","NEW_ORDER")

trans_params = set_value (trans_params, "CLASSCODE", "TQBR")

trans_params = set_value (trans_params, "SECCODE", "HYDR")

trans_params = set_value (trans_params, "ACCOUNT", "L01-00000F00")

trans_params = set_value (trans_params, "OPERATION", "B")

trans_params = set_value (trans_params, "PRICE","7.561")

trans_params = set_value (trans_params, "QUANTITY", "1")

trans_params = set_value (trans_params, "CLIENT_CODE", "")

trans_params = set_value (trans_params, "TYPE", "L")

trans_result =SEND_TRANSACTION (30, trans_params)

WRITELN ("qpile_trans.log", get_value (curr_datetime, "DATETIME") & ": " & "Result: " & get_value (trans_result,
"RESULT") & ", Result_ex: " & get_value (trans_result, "RESULT_EX") & ", OrderNum: " & get_value (trans_result,
"ORDER_NUMBER") & ", Description: " & get_value (trans_result, "DESCRIPTION"))
‘


Функции для работы с метками

  • ADD_LABEL
  • DELETE_LABEL
  • DELETE_ALL_LABELS
  • GET_LABEL_PARAMS
  • SET_LABEL_PARAMS

    • Функции предназначены для построения меток и установки их на график.

    ADD_LABEL

    Добавляет метку с заданными параметрами.

    DOUBLE ADD_LABEL (STRING tag, MAP label params)

    В окно, где отображен график с идентификатором «tag» добавляется метка. В случае успешного добавления функция возвращает идентификатор метки или (-1), если добавить метку не удалось.

    Формат массива MAP содержит следующие параметры метки:

    № Параметр Тип Описание
    1 | TEXT | STRING | Подпись метки (если подпись не требуется, то пустая строка)
    2 | IMAGE_PATH | STRING | Путь к картинке, которая будет отображаться в качестве метки (пустая строка, если картинка не требуется)
    3 | ALIGNMENT | STRING | Расположение картинки относительно текста (возможно 4 варианта: LEFT, RIGHT, TOP, BOTTOM)
    4 | YVALUE | DOUBLE | Значение параметра на оси Y, к которому будет привязана метка
    5 | DATE | DOUBLE | Дата в формате ГГГГММДД, к которой привязана метка
    6 | TIME | DOUBLE | Время в формате ЧЧММСС, к которому будет привязана метка
    7 | R | DOUBLE | Красная компонента цвета в формате RGB. Число в интервале [0;255]
    8 | G | DOUBLE | Зеленая компонента цвета в формате RGB. Число в интервале [0;255]
    9 | B | DOUBLE | Синяя компонента цвета в формате RGB. Число в интервале [0;255]
    10 | TRANSPARENCY | DOUBLE | Прозрачность метки в процентах. Значение должно быть в промежутке [0; 100]
    11 TRANSPARENT_BACKGROUND DOUBLE Прозрачность метки. Возможные значения:
    • «0» - прозрачность отключена;
    • «1» - прозрачность включена
    12 | FONT_FACE_NAME | STRING | Название шрифта (например "Arial")
    13 | FONT_HEIGHT | DOUBLE | Размер шрифта
    14 | HINT | STRING | Текст всплывающей подсказки

    Пример:

    '

    label_params=create_map()

    label_params=set_value(label_params,"TEXT", "Текст метки")

    label_params=set_value(label_params,"IMAGE_PATH", "image.bmp")

    label_params=set_value(label_params,"ALIGNMENT", "LEFT")

    label_params=set_value(label_params,"YVALUE", 2000)

    label_params=set_value(label_params,"DATE", 20080616)

    label_params=set_value(label_params,"TIME", 220000)

    label_params=set_value(label_params,"R", 0)

    label_params=set_value(label_params,"G", 0)

    label_params=set_value(label_params,"B", 200)

    label_params=set_value(label_params,"TRANSPARENCY", 10)

    label_params=set_value(label_params,"FONT_FACE_NAME", "Tahoma")

    label_params=set_value(label_params,"FONT_HEIGHT", 12)

    label_params=set_value(label_params,"HINT", "Подсказка")

    id=ADD_LABEL("ALL", label_params)

    '

    Результат представляется следующим образом: на графике с идентификатором «ALL» будет добавлена метка с параметрами, указанными в массиве label_params.

    DELETE_LABEL

    Удаляет метку с заданными параметрами.

    DOUBLE DELETE_LABEL(STRING tag, DOUBLE id)

    Удаляет метку с графика с текстовым идентификатором «tag» по заданному идентификатору id. В случае успешного удаления возвращает 1, в случае неудачи 0.

    Пример:

    '

    err=DELETE_LABEL("ALL", id)

    '

    Результат действия функции будет удаление метки на графике с идентификатором "ALL"

    DELETE_ALL_LABELS

    Команда удаляет все метки на диаграмме с указанным графиком.

    DOUBLE DELETE_ALL_LABELS(STRING tag)

    Удаляет все нанесенные метки с диаграммы, содержащей график с идентификатором tag. Если на этой диаграмме отображаются графики с разными идентификаторами, то этой командой будут удалены метки со всех графиков, а не только с указанного графика.

    Пример:

    '

    err=DELETE_ALL_LABELS("ALL")

    '

    Результатом действия функции будет удаление всех меток на графике.

    GET_LABEL_PARAMS

    Команда позволяет получить параметры меток.

    MAP GET_LABEL_PARAMS(STRING tag, DOUBLE id)

    Возвращает параметры метки с указанным идентификатором; если метка с указанным идентификатором не существует - возвращается пустой MAP.

    • «tag» – идентификатор любого индикатора на графике, в котором расположена метка;
    • «id» – индекс или порядковый номер метки. Начинается с единицы.

    Пример:

    '

    new_params=GET_LABEL_PARAMS("ALL", id)

    '

    Разультатом действия является получение данных метки. Если такой метки не существует, то возвратившиеся значения будут пустыми.

    SET_LABEL_PARAMS

    Функция задает параметры для метки с указанным идентификатором.

    DOUBLE SET_LABEL_PARAMS(STRING tag, DOUBLE id, MAP new label params)

    Она позволяет задать новые параметры для метки. В случае успешного обновления параметров функция возвращает 1, в случае неудачи 0.

    Пример:

    '

    err=SET_LABEL_PARAMS("ALL", id, label_params)

    '

    Результатом действия функции будет измение существующих параметров на заданные функцией.


Сервисные функции

  • GET_TRADE_DATE
  • GET_DATETIME
  • APPLY_SCALE
  • IS_CONNECTED
  • GET_INFO_PARAM
  • BREAKPOINT

    • GET_TRADE_DATE

    Возвращает дату текущей торговой сессии.

    MAP GET_TRADE_DATE ()

    Функция возвращает ассоциативный массив (MAP), содержащий параметры:

    № | Параметр | Тип | Описание
1 | DATE | STRING | Торговая дата в виде строки «ДД.MM.ГГГГ»
2 | YEAR | DOUBLE | Год
3 | MONTH | DOUBLE | Месяц
4 | DAY | DOUBLE | День

    Пример:

    ‘
    writeln(log_file_name, get_value(GET_TRADE_DATE(), "Date"))
    ’

    Записывает в файл строку вида:

    02.06.2004

    GET_DATETIME

    Возвращает текущие дату и время.

    MAP GET_DATETIME ()

    Функция возвращает ассоциативный массив (MAP), содержащий параметры:

    № | Параметр | Тип | Описание
1 | DATETIME | STRING | Торговая дата в виде строки «ДД.MM.ГГГГ ЧЧ:MM:СС.ссс», где «ссс» – миллисекунды
2 | YEAR | DOUBLE | Год
3 | MONTH | DOUBLE | Месяц
4 | DAY | DOUBLE | День
5 | DAYOFWEEK | DOUBLE | Порядковый номер дня недели (воскресенье – 0, понедельник – 1, вторник – 2, среда – 3, четверг – 4, пятница – 5, суббота – 6)
6 | HOUR | DOUBLE | Час
7 | MIN | DOUBLE | Минута
8 | SEC | DOUBLE | Секунда
9 | MILLISEC | DOUBLE | Миллисекунда

    Пример:

    ‘
    writeln(log_file_name, get_value(GET_DATETIME(), "Datetime"))
    ’

    Записывает в файл строку вида:

     02.06.2004 16:57:34.460

    APPLY_SCALE

    Возвращает строку с числом, полученным округлением числа «without_scale» до разрядности «scale».

    STRING APPLY_SCALE (DOUBLE without_scale, DOUBLE scale)

    IS_CONNECTED

    Функция предназначена для определения состояния подключения клиентского места к серверу. Возвращает 1, если клиентское место подключено и 0, если не подключено.

    IS_CONNECTED ()

    GET_INFO_PARAM

    Данная функция возвращает значения параметров информационного окна (пункт меню Система / О программе / Информационное окно...).

    STRING GET_INFO_PARAM (STRING param_name)

    Параметр «param_name» может принимать значения, представленные в таблице.

    Значение параметра | Описание
VERSION | Версия программы
TRADEDATE | Дата торгов
SERVERTIME | Время сервера
LASTRECORDTIME | Время последней записи
NUMRECORDS | Число записей
LASTRECORD | Последняя запись
LATERECORD | Отставшая запись
CONNECTION | Соединение
IPADDRESS | IP-адрес сервера
IPPORT | Порт сервера
IPCOMMENT | Описание соединения
SERVER | Описание сервера
SESSIONID | Идентификатор сессии
USER | Пользователь
USERID | ID пользователя
ORG | Организация
MEMORY | Занято памяти
LOCALTIME | Текущее время
CONNECTIONTIME | Время на связи
MESSAGESSENT | Передано сообщений
ALLSENT | Передано всего байт
BYTESSENT | Передано полезных байт
BYTESPERSECSENT | Передано за секунду
MESSAGESRECV | Принято сообщений
BYTESRECV | Принято полезных байт
ALLRECV | Принято всего байт
BYTESPERSECRECV | Принято за секунду
AVGSENT | Средняя скорость передачи
AVGRECV | Средняя скорость приема
LASTPINGTIME | Время последней проверки связи
LASTPINGDURATION | Задержка данных при обмене с сервером
AVGPINGDURATION | Средняя задержка данных
MAXPINGTIME | Время максимальной задержки
MAXPINGDURATION | Максимальная задержка данных

    BREAKPOINT

    Функция предназначена для прерывания режима расчета и вывода окна «Отладка», в котором пользователь сможет наблюдать за дальнейшей работой программы.

    BREAKPOINT ()

    Команда не содержит никаких параметров и результатом ее действия является остановка выполнения программы, выделение красным маркером следующего за ним оператора и вызов окна «Отладка», в котором пользователь сможет отслеживать выполнение кода скрипта. При необходимости, команда может содержаться в коде произвольное количество раз.


Отладка программ QPILE

Окно «Отладка» предназначено для пошагового контроля за исполнением кода скриптов. Оно позволяет отслеживать выполнение кода программ, написанных на языке QPILE.

Оно может быть вызвано следующим образом:

  • из таблицы QPILE, выбрав команду контекстного меню Начать расчет в режиме отладки;
  • из кода программы функцией breakpoint().

Окно содержит два больших поля:

  • «Код программы» – выводит код языка QPILE;
  • «Значения переменных» – выводятся переменные и их значения в виде двух столбцов.

При вызове окна с помощью оператора breakpoint() следующая за ним строка программы будет отмечена красным цветом.

Окно «Отладка» содержит следующие кнопки:

  • «Следующий шаг» – выволняет один оператор в коде;
  • «Продолжить выполнение» – продолжает выполнение программы, пока не будет нажата кнопка «Остановить расчет», найден еще один оператор breakpoint() или не будет достигнут конец программы;
  • «Остановить расчет» – останавливает расчет на последнем выполненном операторе.

Доступные функции

  • «F5» – продолжить выполнение программы;
  • «Shift»+«F5» – прекратить отладку программы и закрыть данное окно;
  • «F10» – перейти к следующей строке.

См. также Сервисные функции


Приложение

  • Синтаксис команд языка QPILE
  • Рекомендации к составлению программ на QPILE


Синтаксис команд языка QPILE

Program:

              Statement_List

Statement_List:

               Statement "\n"

               Statement_List "\n" Statement

Statement:

                NAME=Expression

                IFOperator

                FOROperator

                FUNCDescr

                CONTINUE         //пропускает выполнение операторов до конца текущего Statement_List

                BREAK              //начинает выполнение оператора следующего за текущим Statement_List

                RETURN            //выход из текущего управляющего блока – из тела функции или из всей программы

IFOperator:

"IF " Condition "\n"

                 Statement_List

"ELSE" "\n"

                 Statement_List

"END IF"

Condition

                  Condition "OR" Condition

                  Condition "AND" Condition

                  "("Condition") "

                   PrimaryCondition

PrimaryCondition

                   Expression "==" Expression

                   Expression "=" Expression //c той же семантикой, что и "=="

                   Expression ">=" Expression

                   Expression "<=" Expression

                   Expression >"Expression

                   Expression "<"Expression

                   Expression "!=" Expression

                   Expression "<>" Expression //c той же семантикой, что и "!="

FOROperator:

                   "FOR  " NAME " IN  " ArgList   "\n"

                                Statement_List

                    "END FOR"

                     "FOR " NAME " FROM " Expression " TO " Expression "\n"

                                 Statement_List

                     "END FOR"

ArgList

NAME   // в этом случае переменная с именем NAME должна содержать значение вида ArgList1

                     ArgList1

ArgList1:

                     Expression

ArgList "," Expression

FUNCDescr

                      "FUNC " NAME "(" FargList ")" "\n"

                                    Statement_List

                      "END FUNC"

FArgList

NAME

FArgList "," NAME

Expression:

                        Expression "+" Term

                        Expression "–" Term

                        Expression "&" Term      //конкатенация строк

                        Term

Term:

                        Term "/" Primary

                        Term "*"Primary

                        Primary

Primary:

                        NUMBER

                        STRINGNAME        //значение переменной с именем NAME

                        "-" Primary

"(" Expression ")"

FunctionCall

FunctionCall

FNAME "(" ArgList1")"

NUMBER:

                        Digits

                        Digits "."DigitsSTRING:       //определяется стандартно

NAME:                                     //определяется стандартно

Ключевые слова = {IF, ELSE, FOR, IN, TO, FROM, AND, OR, RESULT, FUNC, END FUNC, END FOR, END IF, CONTINUE, BREAK, RETURN}


Рекомендации к составлению программ на QPILE

  1. Функции для работы со структурными переменными, такие как «SET_VALUE», «INSERT_COLLECTION_ITEM», «REMOVE_COLLECTION_ITEM» возвращают измененное значение коллекции или массива. Поскольку все параметры передаются в функцию по значению, то использование данных функций в качестве процедур приводит к потере сделанных в них изменений.

    Например:

    clientscol=INSERT_COLLECTION_ITEM(clientscol,0,initmap)

    ‘правильно
    INSERT_COLLECTION_ITEM(clientscol,0,initmap)
    ‘неправильно, в этом случае после вызова функции clientscol будет содержать то же значение, что и до ее вызова
  2. Возвращаемые функциями значения могут оказаться строковыми, хотя и представлять вещественное число. В этих случаях нужно использовать сложение с «0» для преобразования результата к численному значению. Например, для корректной инициализации переменной в операторе присваивания вида «v=GET_VALUE()» стоит написать «v=0+GET_VALUE()». В последнем случае гарантированно достигается вещественное значение переменной.

    Аналогичным образом, для приведения вещественного значения к строковому может использоваться операция склейки с пустой строкой «v=""&GET_VALUE()».

  3. Произвольные пользовательские типы могут быть сформированы путем комбинации коллекций и ассоциативных массивов. Например, если нужен список структур типа:
    c=strruct{
    openbal:double
    closebal:double
    clientcode:string}
    то его можно представить как коллекцию ассоциативных массивов в каждом из которых будет три ключа – «OPENBAL», «CLOSEBAL», «CLIENTCODE». Код для инициализации такой структуры:
    initmap=CREATE_MAP()
    initmap=SET_VALUE(initmap,"OPENBAL",0)
    initmap=SET_VALUE(initmap,"CLOSEBAL",0)
    initmap=SET_VALUE(initmap,"CLIENTCODE","")
    clientscol=CREATE_COLLECTION()
    FOR  i FROM 0 TO 10
                   clientscol=INSERT_COLLECTION_ITEM(clientscol,0,initmap)
    END FOR
    После чего, для доступа к полю «OPENBAL» 5-го клиента надо написать:
    openbal = GET_VALUE(GET_COLLECTION_ITEM(clientscol,5),"OPENBAL")

    Если вместо коллекции таких записей использовать массив с ключом представляющим из себя код клиента, то можно будет обращаться к значениям структуры клиента без указания его индекса в массиве, а зная только клиентский код:

    clientsmap=CREATE_MAP()
    FOR i FROM 0 TO 10
               clientsmap=SET_VALUE(clientsmap,"Q" & i, initmap)
    END FOR

    и последующее обращение к значению поля «OPENBAL» для клиента с кодом «Q5»:

    openbal = GET_VALUE(GET_VALUE(clientsmap,"Q5"),"OPENBAL")
  4. «MODIFY_ITEM» не выполняет действий, если указанной строки в таблице «OWN» еще нет. Поэтому надо предварительно проверять ее наличие.

    При построении пользовательской таблицы на каждой итерации изменяющей в себе строку полезным будет код:

    new_global("first_time_flag",0)

    if first_time_flag==0

               add_item(1,SAMPLE)

               first_time_flag=1

    else
               modify_item(1, SAMPLE)

    end if

    При первом запуске создается строка номер 1 со значениями полей из переменной «SAMPLE» насчитанной ранее, а на последующих итерациях строка номер 1 модифицируется.


Раздел 9. Дополнительные возможности

  • Неторговые поручения
  • Таблица поручений
  • Заполнение поручений
  • Импорт поручений из файла (подача поручений)
  • Импорт поручений из файла (отмена поручений)
  • Отчеты
  • Получение файлов от брокера и их подписание
  • Инвестиционные идеи
  • Таблица инвестиционных идей
  • Описание инвестиционной идеи
  • Ввод заявки
  • Вкладка инвестиционных идей

Раздел описывает возможности системы QUIK по проведению неторговых операций (по приему и обработке поручений на ввод/вывод и перевод средств клиента), запросу отчетов по проведенным операциям на сервере брокера, а также работы с инвестиционными идеями.


Неторговые поручения

  • Введение
  • Принцип работы
  • Виды поручений
  • Настройка

    • Введение

    Неторговые поручения представляют собой поручения брокеру на перемещение средств клиента между счетами – ввод средств в торговую систему, вывод обратно на счет клиента, перевод между разными счетами либо торговыми системами.

    Применение неторговых поручений является дополнительной возможностью системы QUIK, которая появляется при наличии на сервере специального Модуля неторговых поручений.

    Для использования неторговых поручений на Рабочем месте клиента необходимо, чтобы:

    • данному пользователю был открыт доступ к неторговым поручениям на сервере QUIK;
    • в папке с программами QUIK находился файл INSTRCLIENT.DLL;
    • в список принимаемых классов был включен класс «Неторговые поручения».

    При соблюдении этих условий в меню программы появится пункт «Неторговые поручения».

    Для возможности подтверждения неторговых поручений и принятых файлов (отчетов) одноразовыми паролями необходимо в программе QUIK Administrator (вкладка «Общие права», поле «для SMS» на форме редактирования пользователя) указать номер телефона (один или несколько) для получения одноразовых паролей.

    Принцип работы

    1. Работа с неторговыми поручениями напоминает работу с заявками. Для того чтобы видеть список отправленных поручений и их текущее состояние, нужно создать «Таблицу поручений», используя пункт меню программы Расширения / Неторговые поручения / Таблица поручений. В этой таблице отображаются поручения всех типов и состояние их обработки специалистами брокера. Двойным нажатием левой кнопки мыши на строке можно открыть поручение и посмотреть его параметры.
    2. Новые поручения создаются выбором соответствующего вида поручения из пункта меню Расширения / Неторговые поручения / [вид поручения]. На экране появится форма с полями для заполнения. Для минимизации возможных ошибок при заполнении, реквизиты клиента выбираются из справочника, заполняемого на сервере брокера.
    3. Заполненное поручение отправляется на сервер брокерской системы QUIK, где последовательно проходит проверку и подтверждение сотрудниками брокера. После того, как все необходимые подтверждения получены, происходит исполнение поручения – изменяются позиции по указанному инструменту (или денежным средствам).
    4. При подтверждении поручения сотрудниками брокера могут быть начислены дополнительные платежи за исполнение поручения, указываемые в стандартных полях:
      • «Налог» - сумма налогов и сборов, взимаемых при исполнении поручения, указывается сотрудником брокера;
      • «Комиссия депозитария» - сумма платежа, удерживаемая в пользу депозитария. Если с клиента взимается задолженность по депозитарным сборам, то она указывается брокером в этом поле;
      • «Комиссия за выдачу наличных» - сумма платежа, удерживаемая при расчетах через кассу.
    5. Поручение может быть отклонено одним из специалистов брокера. В этом случае оно получает статус «Снято», который отображается в Таблице поручений. Чтобы увидеть причину отклонения, указанную данным специалистом, нужно выбрать поручение в Таблице и открыть его двойным нажатием левой кнопки мыши. В поле «Комментарий отмены» будет указано основание для отклонения.
    6. Отправленное поручение, имеющее статус «Активно», пользователь может отменить. Для этого нужно сформировать запрос на отмену поручения, выбрав из контекстного меню на поручении пункт «Запрос на отмену поручения» и ввести текст-пояснение в открывшемся окне. Этот запрос так же проходит подтверждение сотрудниками брокера.
    7. Поручение может требовать подтверждения одноразовым паролем. Отправка SMS-сообщений с одноразовым паролем производится на номера для SMS, заданные в программе QUIK Administrator.

    Виды поручений

    Поддерживаются следующие виды поручений, доступные через пункт меню Расширения / Неторговые поручения / [вид поручения]:

    1. «Вывод ДС» - поручение на вывод денежных средств с брокерского счета на расчетный счет клиента в банке, либо на получение их в наличной форме.
    2. «Вывод ЦБ» - поручение на вывод ценных бумаг из депозитария торговой системы (НРД, ДКК) в реестр эмитента либо на другой счет внутри данного депозитария.
    3. «Ввод ДС» - поручение на перевод денежных средств, зачисленных клиентом на брокерский счет, в торговую систему биржи.
    4. «Ввод ЦБ» - поручение на перевод ценных бумаг в депозитарий торговой системы (НРД, ДКК) из реестра или другого счета в этом депозитарии.
    5. «Перевод ДС» - поручение на перевод денежных средств между счетами и торговыми системами.
    6. «Перевод ЦБ» - поручение на перевод ценных бумаг между счетами.
    7. «Конвертация валют» - поручение на конвертацию одной валюты, хранящейся на счете клиента, в другую.
    8. «Свободная форма» - поручение любого вида, представленное в виде текстового описания.
    9. «Конвертация ЦБ» - поручения на конвертацию одной ценной бумаги, хранящейся на счете клиента, в другую.
    10. «Размещение ЦБ» - поручение на участие в размещении ценных бумаг.

    Настройка

    меню Расширения / Неторговые поручения / Настройки

    • «Неполное исполнение поручений» - разрешить исполнение поручений на неполную сумму, если остатка средств на счете клиента недостаточно для покрытия расходов по сделке.
    • «Запрос при подписи поручения» - запрашивать подтверждение операции при подписании поручения.
    • «Запрос при снятии поручения» - запрашивать подтверждение операции при снятии поручения.
    • «Модальные формы поручений» – включить режим модальных форм поручений, при котором невозможно открыть новую форму подачи или подписи поручения, пока не закрыта предыдущая форма.


Таблица поручений

меню Расширения / Неторговые поручения / Таблица поручений
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр списка отправленных неторговых поручений и их состояния. Формирование новых неторговых поручений. Просмотр причин отклонения поручений. Запрос на отмену отправленных поручений.

    Формат таблицы

    Каждая строка в таблице соответствует отдельному поручению. Поручения расположены в хронологическом порядке. Столбцы таблицы имеют следующие значения:

    Параметр | Назначение
    Номер | Регистрационный номер поручения на сервере QUIK
    ***Клиент | Код клиента у брокера
    Вид | Вид поручения. Например, «Вывод ДС безналично» - вывод денежных средств на счет в банке
    Сумма | Сумма, указанная в поручении (для поручений по денежным средствам), либо количество ценных бумаг (для поручений по бумагам)
    Состояние | Состояние обработки поручения
    Дата рег. | Дата регистрации поручения на сервере QUIK
    Время рег. | Время регистрации поручения на сервере QUIK
    Дата испол. | Дата исполнения поручения на сервере QUIK
    Время исполн. | Время исполнения поручения на сервере QUIK
    Класс | Класс инструментов (для ценных бумаг) либо код расчетов (для денежных средств)
    Площадка | Наименование инструмента
    ***Клиент получ. | Код клиента – получателя (для переводов)
    Сумма платежа/налога | Сумма взимаемых платежей и налогов за выполнение поручения, вводится сотрудниками брокера
    *Риск менеджер | Признак подтверждения поручения риск-менеджером брокера
    *Бухгалтер | Признак подтверждения поручения сотрудником бухгалтерии
    *Клиент менеджер | Признак подтверждения поручения менеджером клиентского отдела
    *Бэк-офицер | Признак подтверждения поручения сотрудником бэк-офиса
    *Депозитарий | Признак подтверждения поручения сотрудником депозитария
    Код класса | Идентификатор класса в торговой системе
    Код инструмента | Идентификатор инструмента в торговой системе
    UID | Идентификационный номер пользователя в системе
    Брокерский номер | Идентификационный номер Брокера
    Тип клиента

    Тип клиента. Возможные значения:

    • «Физ. лицо» - физическое лицо;
    • «Юр. лицо» - юридическое лицо
    ФИО клиента | Наименование клиента, отправившего поручение
    Договор обслуживания | Реквизиты договора обслуживания клиента
    Валюта | Код валюты, по которой подано поручение (для поручений по денежным средствам и «Размещение ЦБ».) Для поручений «Перевод ДС» и «Конвертация валют» — код валюты, используемой при списании
    Сумма зачисления | Сумма денежных средств, подлежащая зачислению на счет
    Валюта зачисления | Код валюты зачисления, параметр поручений типа «Перевод ДС», «Конвертация валют»
    Курс конвертации | Кросс-курс конвертации, указанный в поручении типа «Конвертация валют»
    Срок действия

    Период времени, в течение которого поручение должно быть исполнено. Может принимать одно из значений:

    • «До отмены» - срок исполнения не ограничен;
    • «По» - поручение должно быть исполнено до указанной даты включительно. Если поручение не удалось выполнить в срок, ему присваивается статус «Истек срок действия»
    Комментарий | Комментарий к поручению
    Код шаблона | Код используемого шаблона поручения свободного вида. Для поручений других видов значение параметра не заполняется
    Срочность

    Приоритет осуществления операции. По умолчанию может принимать одно из значений:

    • «Нормальная»;
    • «Низкая»;
    • «Высокая».

    Дополнительные значения задаются Брокером

    Шаблон

    Наименование шаблона для поручений свободного вида. Для поручений других видов значение параметра не заполняется

    *Мидл-офис | Признак подтверждения поручения Мидл-офисом брокера
    **Депо счет (списание)

    Счет ДЕПО (списание) клиента в депозитарии

    **Поставщик: параметры депо счета

    Строка вида: «Распорядитель», «Владелец», «Депозитарий», «Номер депозитарного договора», «Дата заключения договора (в формате «ГГГГММДД»)»

    **Поставщик: раздел депо счета

    Раздел счета ДЕПО поставщика. Может принимать одно из значений:

    • «основной»;
    • «торговый»
    **Депо счет (зачисление)

    Счет ДЕПО (зачисление) клиента в депозитарии

    **Получатель: параметры депо счета

    Строка вида: «Распорядитель», «Владелец», «Депозитарий», «Номер депозитарного договора», «Дата заключения договора (в формате «ГГГГММДД»)»

    **Получатель: раздел счета депо

    Раздел счета ДЕПО получателя. Может принимать одно из значений:

    • «основной»;
    • «торговый»
    **Основание поручения

    Наименование документа, являющегося основанием для проведения операций (например, договор купли-продажи, депозитарный договор) и его реквизиты

    Банковские реквизиты

    Банковские реквизиты одной строкой. Поле заполняется для поручений по денежным средствам

    Торговый счёт

    Торговый счёт списания. Поле заполняется для поручений по ЦБ

    Торговый счёт (зачисление)

    Торговый счёт зачисления. Поле заполняется для поручений типа Перевод ЦБ, Конвертация ЦБ

    Код инструмента размещения | Код размещаемого инструмента
    Ожидает подтверждения | Признак ожидания подтверждения одноразовым паролем
    Менеджер счёта | Менеджер договора обслуживания
    Входящий номер | Номер поручения, который указывается пользователем при подаче поручения
    Площадка зачисления | Наименование инструмента зачисления. Заполняется для поручений типа Перевод ДС и Конвертация валют
    Зарегистрировано | Имя пользователя, подавшего поручение. Если поручение подано с помощью хранимой процедуры, то значение пустое
    Раздел | Наименование раздела шаблона, на основании которого создано данное поручение

    * - в случае подтверждения, в этом поле появится знак «+». Не все типы поручений требуют подтверждения всеми сотрудниками

    ** - поля заполняются только для поручений типа «Перевод ЦБ»

    *** - если в Рабочем месте QUIK включена настройка «Заменять коды клиентов на ФИО», то вместо кода клиента отображаются фамилия, имя, отчество клиента

    В зависимости от состояния обработки поручения, строки таблицы выделяются разным цветом текста:

    • «Активно» - красным;
    • «Исполнено» - синим;
    • «Снято» - черным;
    • «Запрос на отмену» - зеленым.

    Для подписания нескольких поручений одновременно выберите поручения, зажав клавишу «Ctrl» для выделения по одному поручению, или клавишу «Shift» для выделения нескольких поручений, следующих друг за другом (снять выделение с выбранных поручений можно такими же способами). Далее в контекстном меню таблицы выберите пункт «Подписать выбранные поручения».

    Доступные функции

    Данные из таблицы доступны для копирования, вывода через DDE сервер, экспорта через ODBC.

    Функции, доступные для данной таблицы, могут быть вызваны из контекстного меню нажатием правой кнопки мыши на таблице.

    • «Новое поручение» (или «F2») – открыть окно ввода нового поручения.
    • «Просмотр поручения» (или двойное нажатие левой кнопки мыши) – открыть окно просмотра зарегистрированного поручения.
    • «Отмена поручения» (или «Ctrl»+«D») – отклонить выбранное поручение, действие доступно сотрудникам брокера. Причину отмены поручения можно выбрать из списка стандартных причин и при необходимости изменить текст причины отмены. Для отмены нескольких поручений одновременно выберите поручения, зажав клавишу «Ctrl» для выделения по одному поручению, или клавишу «Shift» для выделения нескольких поручений, следующих друг за другом (снять выделение с выбранных поручений можно такими же способами).
    • «Подписать все поручения» – открыть диалог настройки группового подписания поручений. Доступно сотрудникам брокера.
      При групповом подписании поручений типа «Вывод ДС», «Перевод ДС», связанных с коррекцией денежной позицией на срочном рынке Московской Биржи и при включенном режиме коррекции этих позиций на бирже (в файле instrtw.ini параметр ChangeMoneyOnFORTS равен «1») в случае недостаточности средств на срочном рынке, в окне сообщений отображается предупреждение вида: «Неторговое поручение N не может быть подписано в связи с нехваткой средств».
    • «Отзыв последней записи» – отправить запрос на отзыв подписи у выбранного поручения, имеющего статус «Активно».
    • «Отзыв всех подписей» – отправить запрос на отзыв всех подписей у выбранного поручения, имеющего статус «Активно». Если у брокера установлен запрос одноразового пароля при подписании, то данный пункт неактивен.
    • «История исполнения поручения» – запросить историю исполнения по выбранному поручению. Доступно сотрудникам брокера.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Настройка таблицы.


Настройка таблицы

Значение полей диалога настройки таблицы:

  1. «Имя таблицы» – заголовок таблицы, поле позволяет изменить его значение, присвоенное по умолчанию.
  2. «Набор параметров» - настройка столбцов, отображаемых в таблице.
  3. «Фильтр клиентов» - ограничение списка поручений в таблице набором выбранных кодов клиента. Для пользователей, имеющих права на работу с несколькими кодами клиентов, этот фильтр позволяет распределить неторговые поручения разных клиентов по разным таблицам. Для включения фильтра нужно установить признак «Включить» и нажатием кнопки «…» настроить список выбранных кодов клиентов.
  4. «Фильтр типа клиента» - ограничение списка поручений в таблице выбранным типом клиента (физическое лицо / юридическое лицо). Для включения фильтра нужно установить признак «Включить» и в поле со списком указать нужный тип.
  5. «Фильтр брокерского номера» - ограничение списка поручений в таблице по указанному брокерскому номеру. Для включения фильтра нужно установить признак «Включить» и в поле со списком указать идентификационный номер брокера в системе. Параметр «Брокерский номер», с которым будет сравниваться введенная строка, доступен в доступных параметрах таблицы поручений. При установленном флажке «По подстроке» поиск производится по подстроке, при снятом флажке - по полному соответствию.
  6. «Фильтр даты регистрации» - позволяет включить в таблицу только поручения, зарегистрированные в указанную дату, либо за указанный период времени (флажки «За указанную дату», «За указанный период»). При установленном флажке «Только за сегодняшний день» из таблицы исключаются поручения, зарегистрированные в предыдущие дни.
    При создании новой таблицы поручений настройка «Только за сегодня» по умолчанию отключена.
  7. «Фильтр инструментов» – ограничение списка поручений в таблице по выбранному набору инструментов. Для включения фильтра нужно установить признак «Включить» и нажатием кнопки «…» настроить список кодов инструментов для отображения в таблице.
  8. «Фильтр состояния» - позволяет убрать из таблицы поручения с заданным статусом. Для исключения таких поручений нужно снять флажок с соответствующего названия статуса («Активно», «Исполнено», «Отменено» или «Запрос на отмену»).
  9. «Фильтр вида поручения» - предназначен для настройки таблицы на отображение только заданных видов поручений. Для исключения каких-либо типов поручений, нужно убрать флажок с соответствующего вида поручения.
  10. «Фильтр статуса» - выбор поручений для отображения в таблице по наличию подписи:
    • «Все» - фильтр не установлен, отображаются все записи;
    • «Подписанные» - отображаются только поручения, имеющие подписи указанных ниже категорий сотрудников, либо подпись которых отсутствует, но не требуется для подтверждения данного типа поручения;
    • «Неподписанные» - отображаются только поручения, которые требуют, но не имеют подписи указанных ниже категорий сотрудников;
    • «Риск-менеджер», «Бухгалтер», «Клиент. менеджер», «Бэк-офицер», «Депозитарий», «Мидл-офис» - выбор категорий сотрудников, выполняется включением флажков на соот-ветствующем наименовании.

См. также Таблица поручений.


Заполнение поручений

меню Расширения / Неторговые поручения / [вид поручения]
  • Поручение на ввод денежных средств
  • Поручение на вывод денежных средств
  • Поручение на перевод денежных средств
  • Поручение на ввод ценных бумаг
  • Поручение на вывод ценных бумаг
  • Поручение на перевод ценных бумаг
  • Поручение на конвертацию валют
  • Поручение свободного вида
  • Поручение на конвертацию ЦБ
  • Выбор документа-основания
  • Подтверждение одноразовым паролем
  • Ввод получателя ДС
  • Ввод получателя ЦБ


Поручение на ввод денежных средств

меню Расширения / Неторговые поручения / Ввод ДС

Поручение предназначено для перевода денежных средств, зачисленных клиентом на брокерский счет, в торговую систему биржи.

Назначение полей поручения:

  1. «Тип поручения».
  2. «Номер поручения» – регистрационный номер поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Номер». Поле доступно только при открытии поданного поручения в режиме просмотра.
  3. «Дата регистрации» – дата регистрации поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Дата рег.». Поле доступно только при открытии поданного поручения в режиме просмотра.
  4. «Время регистрации» – время регистрации поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Время рег.». Поле доступно только при открытии поданного поручения в режиме просмотра.
  5. «Входящий номер» – входящий номер поручения, заполняется пользователем. Поле может содержать произвольные символы. Максимальная длина поля: 32 символа. Поле доступно только при вводе поручения.
  6. «Валюта» – сокращенное название валюты.
  7. «Площадка» - код расчетов, соответствующий позиции по денежным средствам, на которых зачисляются средства, например, «EQTV» соответствует Фондовой бирже ММВБ.

    Если брокером используется Единая денежная позиция, то в качестве площадки указывается всегда один код расчетов, как правило, это «EQTV».
  8. «Срочность» - приоритет осуществления операции. Возможные значения:
    • «Нормальная»;
    • «Низкая»;
    • «Высокая».
  9. «Срок действия» - период времени, в течение которого поручение должно быть исполнено. Возможные значения:
    • «До отмены» - срок исполнения не ограничен;
    • «По» - поручение должно быть исполнено до указанной даты включительно. Если поручение не удалось выполнить в срок, ему присваивается статус «Истек срок действия».

    Если в настройках Модуля неторговых поручений установлен максимальный срок действия поручения, то значение «До отмены» не отображается, а в значении «По» должна быть выбрана дата, не превышающая установленный максимальный срок.
  10. «Сумма» – сумма средств для зачисления.
  11. «Согласие на частичное исполнение» – признак возможности частичного исполнения поручения. При выводе фиксированной суммы средств в максимально доступном размере, остатка средств может не хватить для покрытия расходов на исполнение поручения, и оно может быть отвергнуто брокером. В таком случае рекомендуется использовать этот признак.
  12. «Списание комиссии» – площадка списания комиссии.
  13. Поля «Налог», «Комиссия депозитария», «Комиссия за выд.нал.» заполняются (при необходимости) сотрудниками брокера при подтверждении поручения, в них указываются дополнительные платежи, связанные с исполнением поручения.
  14. «Код клиента» - код клиента в системе QUIK, на чей счет зачисляются денежные средства. В поле ниже справочно указывается фамилия и имя клиента. Если в Рабочем месте QUIK включена настройка «Заменять коды клиентов на ФИО», вместо кода клиента отображаются фамилия, имя, отчество клиента.
  15. «Договор обслуживания» – номер договора на брокерское обслуживание, заключенный с клиентом. В поле ниже справочно отображается дата договора. Если у брокера включен режим подстановки договора, то поле заполняется автоматически, даже если оно недоступно для редактирования (если у клиента несколько договоров обслуживания, то подставляется договор с более поздней датой).
  16. «Лицевой счет» - лицевой счет клиента.
  17. «Субсчет» - субсчет лицевого счета клиента.
  18. «Банк получателя» - счет брокера для зачисления по наименованию банка. Реквизиты счета отображаются в поле снизу. Параметр поручений типа «Безналично».
  19. «Номер платежного поручения» – номер платежного поручения, которым зачислены средства клиента на брокерский счет.
  20. «Номер приходного ордера» – номер приходного ордера, которым зачислены средства клиента на брокерский счет.
  21. «Торговая система» – биржевая торговая система для зачисления средств на торги.
  22. «Комментарий» – комментарий к поручению. Максимальная длина поля: 1000 символов.
  23. «Комментарий брокера» – поле доступно для просмотра и изменения только сотрудникам брокера.


Поручение на вывод денежных средств

меню Расширения / Неторговые поручения / Вывод ДС

Поручение предназначено для вывода денежных средств с брокерского счета на расчетный счет клиента в банке, либо на получение их в наличной форме.

Назначение полей поручения:

  1. «Тип поручения».
  2. «Сведения о поручении» - информационное поле, в котором содержится дополнительная информация о поручении. Задается брокером.
  3. «Номер поручения» – регистрационный номер поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Номер». Поле доступно только при открытии поданного поручения в режиме просмотра.
  4. «Дата регистрации» – дата регистрации поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Дата рег.». Поле доступно только при открытии поданного поручения в режиме просмотра.
  5. «Время регистрации» – время регистрации поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Время рег.». Поле доступно только при открытии поданного поручения в режиме просмотра.
  6. «Входящий номер» – входящий номер поручения, заполняется пользователем. Поле может содержать произвольные символы. Максимальная длина поля: 32 символа. Поле доступно только при вводе поручения.
  7. «Валюта» - код валюты расчетов.
  8. «Площадка» - код расчетов, соответствующий позиции по денежным средствам, с которого выводятся деньги, например, «EQTV» соответствует Фондовой бирже ММВБ.

    Если брокером используется Единая денежная позиция, то в качестве площадки указывается всегда один код расчетов. Как правило, это «EQTV».
  9. «Срочность» - приоритет осуществления операции. Возможные значения:
    • «Нормальная»;
    • «Низкая»;
    • «Высокая».
  10. «Срок действия» - период времени, в течение которого поручение должно быть исполнено. Возможные значения:
    • «До отмены» - срок исполнения не ограничен;
    • «По» - поручение должно быть исполнено до указанной даты включительно. Если поручение не удалось выполнить в срок, ему присваивается статус «Истек срок действия».

    Если в настройках Модуля неторговых поручений установлен максимальный срок действия поручения, то значение «До отмены» не отображается, а в значении «По» должна быть выбрана дата, не превышающая установленный максимальный срок.
  11. «Сумма» - cумма снимаемых со счета средств. Для снятия всех средств нужно выбрать подвид поручения «безналично (остаток)» либо «налично (остаток)».
  12. «Сумма с налогом» – информационное поле, в котором отображается сумма значений полей «Сумма» и «Налог».

    Если значения полей «Сумма» и «Налог» заданы в разных валютах, то при суммировании сумма налога конвертируется в валюту поручения с использованием кросс-курса.
  13. «Согласие на частичное исполнение» - признак возможности частичного исполнения поручения. Рекомендуется использовать при выводе денежных средств в большом размере, когда затруднительно рассчитать необходимый остаток средств для покрытия расходов на исполнение данного поручения.
  14. «Списание комиссии» - площадка списания комиссии.
  15. Поля «Налог», «Комиссия депозитария», «Комиссия за выд.нал.» заполняются при необходимости сотрудниками брокера при подтверждении поручения, в них указываются дополнительные платежи, связанные с исполнением поручения.
  16. «Код клиента» - код клиента в системе QUIK, со счета которого снимаются средства. В поле ниже справочно отображаются фамилия и имя клиента. Если в Рабочем месте QUIK включена настройка «Заменять коды клиентов на ФИО», то вместо кода клиента отображаются фамилия, имя, отчество клиента.
  17. «Договор обслуживания» - номер договора на брокерское обслуживание, заключенный с клиентом. В поле ниже справочно отображается дата договора. Если у брокера включен режим подстановки договора, то поле заполняется автоматически, даже если оно недоступно для редактирования (если у клиента несколько договоров обслуживания, то подставляется договор с более поздней датой).
  18. «Лицевой счёт» – лицевой счёт клиента.
  19. «Субсчёт» – субсчёт лицевого счета клиента.
  20. «Физический счёт» – физический счёт клиента. По умолчанию установлен физический счёт, привязанный к выбранной валюте.
  21. «Резидент» - включенный флажок указывает, что выбранный клиент является резидентом. Наличие флажка в поручении зависит от настроек брокера.
  22. «Получатель» - выбор получателя из справочника. В поле ниже справочно выводится информация о получателе. Если получатель в справочнике отсутствует, то для ввода его реквизитов используется кнопка «Ввести вручную» (см. Ввод получателя ДС).
  23. «Торговая система» – биржевая торговая система для зачисления средств на торги.
  24. Поле «Основание платежа» содержит наименование документа, являющегося основанием для проведения операций (например, договор купли-продажи, депозитарный договор) и его реквизиты. Максимальная длина поля: 200 символов.
  25. «Комментарий» - комментарий к поручению. Максимальная длина поля: 1000 символов.
  26. «Комментарий брокера» - поле доступно для просмотра и изменения только сотрудникам брокера.


Поручение на перевод денежных средств

меню Расширения / Неторговые поручения /Перевод ДС

Поручение предназначено для перевода денежных средств между счетами и торговыми системами.

Назначение полей поручения:

  1. «Тип поручения».
  2. «Сведения о поручении» – информационное поле, в котором содержится дополнительная информация о поручении. Задается Брокером.
  3. «Номер поручения» – регистрационный номер поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Номер». Поле доступно только при открытии поданного поручения в режиме просмотра.
  4. «Дата регистрации» – дата регистрации поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Дата рег.». Поле доступно только при открытии поданного поручения в режиме просмотра.
  5. «Время регистрации» – время регистрации поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Время рег.». Поле доступно только при открытии поданного поручения в режиме просмотра.
  6. «Входящий номер» – входящий номер поручения, заполняется пользователем. Поле может содержать произвольные символы. Максимальная длина поля: 32 символа. Поле доступно только при вводе поручения.
  7. «Валюта» - код валюты.

    Если поле «Валюта» доступно для редактирования, то при подаче поручения выполняется проверка на наличие у клиента позиции по указанной валюте. Если позиция по валюте отсутствует, то поручение не подается.
  8. «Площадка списания» - код расчетов, соответствующий позиции по денежным средствам, с которого берутся средства. Если поле «Валюта» доступно для редактирования и заполнено, то в данном списке содержатся коды расчетов, соответствующие выбранной валюте.
  9. «Площадка зачисления» - код расчетов, соответствующий позиции по денежным средствам, на который зачисляются средства. Если поле «Валюта» доступно для редактирования и заполнено, то в данном списке содержатся коды расчетов, соответствующие выбранной валюте.
  10. «Срочность» - приоритет осуществления операции. По умолчанию может принимать одно из значений: «Нормальная», «Низкая», «Высокая». Дополнительные значения задаются Брокером.
  11. «Срок действия» - период времени, в течение которого поручение должно быть исполнено. Может принимать одно из значений:
    • «До отмены» - срок исполнения не ограничен;
    • «По» - поручение должно быть исполнено до указанной даты включительно. Если поручение не удалось выполнить в срок, ему присваивается статус «Истек срок действия».

    Если в настройках Модуля неторговых поручений установлен максимальный срок действия поручения, то значение «До отмены» не отображается, а в значении «По» должна быть выбрана дата, не превышающая установленный максимальный срок.
  12. «Сумма» - сумма перевода.
  13. «Сумма с налогом» – информационное поле, в котором отображается сумма значений полей «Сумма» и «Налог».

    Если значения полей «Сумма» и «Налог» заданы в разных валютах, то при суммировании сумма налога конвертируется в валюту поручения с использованием кросс-курса.
  14. «Согласие на частичное исполнение» - признак возможности частичного исполнения поручения. При переводе фиксированной суммы средств в максимально доступном размере, остатка средств может не хватить для покрытия расходов на исполнение поручения, и оно может быть отвергнуто брокером. В таком случае рекомендуется использовать этот признак.
  15. «Списание комиссии» - площадка списания комиссии.
  16. Поля «Налог», «Комиссия депозитария», «Комиссия за выд.нал.» заполняются (при необходимости) сотрудниками брокера при подтверждении поручения, в них указываются дополнительные платежи, связанные с исполнением поручения.
  17. «Код клиента (списан.)» - код клиента-отправителя средств. В поле ниже справочно отображаются фамилия и имя клиента. Если в Рабочем месте QUIK включена настройка «Заменять коды клиентов на ФИО», то вместо кода клиента отображаются фамилия, имя, отчество клиента. Если поле «Площадка списания» заполнено, то в списке содержатся только коды клиентов, соответствующие выбранной площадке.
  18. «Лицевой счет (списание)» - лицевой счет клиента-отправителя.
  19. «Субсчет (списание)» - субсчет лицевого счета клиента-отправителя.
  20. «Договор обслуживания (списан.)» – договор брокерского обслуживания с клиентом-отправителем. В поле ниже справочно показывается дата заключения договора. Если у брокера включен режим подстановки договора, то поле заполняется автоматически, даже если оно недоступно для редактирования (если у клиента несколько договоров обслуживания, то подставляется договор с более поздней датой).
  21. «Код клиента (зачисл.)» - код клиента-отправителя средств. В поле ниже справочно отображаются фамилия и имя клиента. Если в Рабочем месте QUIK включена настройка «Заменять коды клиентов на ФИО», то вместо кода клиента отображаются фамилия, имя, отчество клиента. Если поле «Площадка зачисления» заполнено, то в списке содержатся только коды клиентов, соответствующие выбранной площадке.
  22. «Субсчет (зачислен.)» - субсчет клиента-получателя средств.
  23. «Договор обслуживания (зачисл.)» – договор брокерского обслуживания с клиентом-получателем. В поле ниже справочно показывается дата заключения договора. Если у брокера включен режим подстановки договора, то поле заполняется автоматически, даже если оно недоступно для редактирования (если у клиента несколько договоров обслуживания, то подставляется договор с более поздней датой).
  24. «Комментарий» – комментарий к поручению. Максимальная длина поля: 1000 символов.
  25. «Комментарий брокера» – поле доступно для просмотра и изменения только сотрудникам брокера.


Поручение на ввод ценных бумаг

меню Расширения / Неторговые поручения / Ввод ЦБ

Поручение предназначено для перевода ценных бумаг в депозитарий торговой системы (НРД, ДКК) из реестра или другого счета в этом депозитарии.

Назначение полей поручения:

  1. «Тип поручения». Возможные варианты:
    • «Получение ЦБ внутри ДКК»;
    • «Получение ЦБ внутри НРД»;
    • «Получение ЦБ в ДКК из реестра»;
    • «Получение ЦБ в НРД из реестра».
  2. «Входящий номер» – входящий номер поручения, заполняется пользователем. Поле может содержать произвольные символы. Максимальная длина поля: 32 символа. Поле доступно только при вводе поручения.
  3. «Номер поручения» – регистрационный номер поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Номер». Поле доступно только при открытии поданного поручения в режиме просмотра.
  4. «Дата регистрации» – дата регистрации поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Дата рег.». Поле доступно только при открытии поданного поручения в режиме просмотра.
  5. «Время регистрации» – время регистрации поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Время рег.». Поле доступно только при открытии поданного поручения в режиме просмотра.
  6. «Срочность» - приоритет осуществления операции. По умолчанию может принимать одно из значений: «Нормальная», «Низкая», «Высокая». Дополнительные значения задаются Брокером.
  7. «Площадка» - площадка для зачисления бумаг. Если поле серое (недоступно), то площадка выбирается автоматически.
  8. «Код клиента» - код клиента-получателя ценных бумаг. В поле ниже справочно выводится фамилия и имя клиента. Если в Рабочем месте QUIK включена настройка «Заменять коды клиентов на ФИО», то вместо кода клиента отображаются фамилия, имя, отчество клиента.

    При смене кода клиента значения полей «Торговый счет», «Класс», «Инструмент» не сбрасываются, если данные значения допустимы для выбранного кода клиента.
  9. «Договор обслуживания» – номер договора обслуживания. Если у брокера включен режим подстановки договора, то поле заполняется автоматически, даже если оно недоступно для редактирования (если у клиента несколько договоров обслуживания, то подставляется договор с более поздней датой).
  10. «Депозитарный договор» – номер депозитарного договора.
  11. «Место хранения» - место хранения бумаг.
  12. «Торговый счет» - торговый счет брокера для зачисления бумаг клиента на торги. Поле заполняется автоматически при указании значения в поле «Инструмент».
  13. «Класс» - класс бумаг в торговой системе, к которому относятся зачисляемые бумаги.

    Если в настройках Модуля неторговых поручений включен режим выбора инструмента из полного списка, то поле недоступно для редактирования и заполняется автоматически при выборе инструмента.

  14. «Инструмент» - выбор наименования бумаги с помощью контекстного поиска (поиск значения из списка по первым буквам, вводимым с клавиатуры). При нажатии на кнопку «…» открывается диалог по выбору инструмента. Кнопка доступна, если для выбранного торгового счёта доступен хотя бы один класс инструментов.

    Если поле «Класс» отсутствует на форме или недоступно для редактирования, то в поле «Инструмент» отображается полный список инструментов в формате: <Инструмент [Класс]> с сортировкой по инструменту.

    Если в настройках Модуля неторговых поручений включен режим выбора инструмента из полного списка, то для выбора доступна только кнопка «…», при нажатии на которую открывается диалог со списком всех инструментов всех классов, доступных для данного типа поручения.
  15. «Название» - полное наименование бумаги.
  16. «ISIN» - код по классификации ISIN, присвоенный ценной бумаге.
  17. «Номер гос. рег.» - номер, под которым зарегистрирована ценная бумага.
  18. «Тип инструмента» – наименование типа ценной бумаги.
  19. «Количество» - количество ценных бумаг в штуках. Максимальная длина поля: 13 символов. В скобках справочно отображается информация по размеру лота для инструмента.
  20. «Депо счет получателя» - счет ДЕПО клиента в депозитарии. В поле ниже справочно выводится информация о получателе. Если получатель отсутствует в справочнике, то для ввода его реквизитов используется кнопка «Ввести вручную» (см. Ввод получателя ЦБ).
    • «Раздел» - выбирается раздел счета ДЕПО.
  21. «Учетный счет» – счет клиента для учета движения денежных средств.
  22. Поля «Налог», «Комиссия депозитария», «Комиссия за выд. нал.» заполняются при необходимости сотрудниками брокера при подтверждении поручения, в них указываются дополнительные платежи, связанные с исполнением поручения.
  23. «Валюта сделки».
  24. «Сумма сделки» - стоимость ценных бумаг, выраженная в валюте сделки.
  25. «Дата сделки» - указывается брокером при подтверждении поручения, параметр поручения на перевод бумаг внутри ДКК,
  26. «Дата расчетов» - указывается брокером при подтверждении поручения, параметр поручения на перевод бумаг внутри ДКК.
  27. «Телефон» - контактный телефон поставщика.
  28. «Юрисдикция» - страна регистрации поставщика, наименование страны либо ее код.
  29. «Отв. исполнитель» - ответственный исполнитель за исполнение поручения со стороны реестра.
  30. «Идентификатор» - идентификатор (код) поставщика в НРД.
  31. «Счет депо пост.» - счет ДЕПО поставщика ценных бумаг в депозитарии.
  32. «Раздел счета пос.» - раздел счета поставщика в НРД.
  33. «Поставщик» - наименование поставщика ценных бумаг.
  34. «Документ контрагента» – документ, удостоверяющий личность контрагента. Если в справочнике документов-оснований есть хотя бы один документ типа «Удостоверяющие документы», то документ контрагента можно выбрать из данного справочника, нажав кнопку «…» справа от поля.
  35. «Основание поручения» - наименование документа, являющегося основанием для проведения операций (например, договор купли-продажи, депозитарный договор) и его реквизиты. При нажатии на кнопку «…» открывается справочник по выбору документа-основания. Для выбора доступны документы типа «Прочие».
  36. «Оплата с/на счет» – тип банковского счета, с которого будут производиться оплата поставки ценных бумаг. Правила использования этого поля определяются Брокером.
  37. «Примечание» – текстовый комментарий к поручению.
  38. «Основание получения ЦБ» – наименование документа, являющегося основанием для получения ценных бумаг, и его реквизиты. При нажатии на кнопку «…» открывается справочник по выбору документа-основания. Для выбора доступны документы типа «Прочие».
  39. «Основание для перевода» – указывается брокером (депозитарный договор поставщика с ДКК, контрагента с номинальным держателем и т.п.). Поле доступно для заполнения на этапе подписи депозитарием. При нажатии на кнопку «…» открывается справочник по выбору документа-основания. Для выбора доступны документы типа «Прочие».
  40. «Срок действия» - период времени, в течение которого поручение должно быть исполнено. Может принимать одно из значений:
    • «До отмены» - срок исполнения не ограничен;
    • «По» - поручение должно быть исполнено до указанной даты включительно. Если поручение не удалось выполнить в срок, ему присваивается статус «Истек срок действия».

    Если в настройках Модуля неторговых поручений установлен максимальный срок действия поручения, то значение «До отмены» не отображается, а в значении «По» должна быть выбрана дата, не превышающая установленный максимальный срок.
  41. Поле «Комментарий отмены» предусмотрено на случай отмены исполнения поручения, при котором в нем будет записана его причина, указанная брокером. В случае отмены поручения по инициативе клиента, в поле «Запрос на отмену» будет записана причина отмены, указанная пользователем.
  42. «Комментарий» - комментарий к поручению. Максимальная длина поля: 1000 символов.
  43. «Комментарий брокера» - поле доступно для просмотра и изменения только сотрудникам брокера.

    На форме подачи поручения на ввод ценных бумаг предусмотрен дополнительный переключатель, который используются Брокером на свое усмотрение для ввода произвольной информации.


Поручение на вывод ценных бумаг

меню Расширения / Неторговые поручения / Вывод ЦБ

Поручение предназначено для вывода ценных бумаг из депозитария торговой системы (НРД, ДКК) в реестр эмитента либо на другой счет внутри данного депозитария.

Назначение полей поручения:

  1. «Тип поручения». Возможные значения:
    • «Поставка ЦБ внутри ДКК»;
    • «Поставка ЦБ внутри НРД»;
    • «Поставка ЦБ из ДКК в реестр»;
    • «Поставка ЦБ из НРД в реестр».
  2. «Входящий номер» – входящий номер поручения, заполняется пользователем. Поле может содержать произвольные символы. Максимальная длина поля: 32 символа. Поле доступно только при вводе поручения.
  3. «Номер поручения» – регистрационный номер поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Номер». Поле доступно только при открытии поданного поручения в режиме просмотра.
  4. «Дата регистрации» – дата регистрации поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Дата рег.». Поле доступно только при открытии поданного поручения в режиме просмотра.
  5. «Время регистрации» – время регистрации поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Время рег.». Поле доступно только при открытии поданного поручения в режиме просмотра.
  6. «Срочность» - приоритет осуществления операции. По умолчанию может принимать одно из значений: «Нормальная», «Низкая», «Высокая». Дополнительные значения задаются Брокером.
  7. «Площадка» - площадка для вывода бумаг, если поле серое (недоступно), то площадка выбирается автоматически.
  8. «Код клиента» - код клиента-поставщика ценных бумаг. В поле ниже справочно указывается фамилия и имя клиента. Если в Рабочем месте QUIK включена настройка «Заменять коды клиентов на ФИО», то вместо кода клиента отображаются фамилия, имя, отчество клиента.

    При смене кода клиента значения полей «Торговый счет», «Класс», «Инструмент» не сбрасываются, если данные значения допустимы для выбранного кода клиента.
  9. «Договор обслуживания» – номер договора обслуживания. В поле ниже справочно выводится дата заключения договора. Если у брокера включен режим подстановки договора, то поле заполняется автоматически, даже если оно недоступно для редактирования (если у клиента несколько договоров обслуживания, то подставляется договор с более поздней датой).
  10. «Депозитарный договор» – номер депозитарного договора. В поле ниже справочно выводится дата заключения договора.
  11. «Депо счет поставщика» - счет ДЕПО клиента в депозитарии. В поле ниже справочно выводится информация о получателе.
    • «Раздел» - выбирается раздел счета ДЕПО.
  12. «Получатель» - наименование получателя ценных бумаг. В поле ниже справочно выводится информация о получателе. Если получатель в справочнике отсутствует, то для ввода его реквизитов используется кнопка «Ввести вручную» (см. Ввод получателя ЦБ).
  13. «Учетный счет» – счет клиента для учета движения денежных средств.
  14. Поля «Налог», «Комиссия депозитария», «Комиссия за выд.нал.» заполняются при необходимости сотрудниками брокера при подтверждении поручения, в них указываются дополнительные платежи, связанные с исполнением поручения.
  15. «Валюта сделки».
  16. «Сумма сделки» – стоимость ценных бумаг, выраженная в валюте сделки.
  17. «Дата сделки» – указывается брокером при подтверждении поручения, параметр поручения на перевод бумаг внутри ДКК.
  18. «Дата расчетов» – указывается брокером при подтверждении поручения, параметр поручения на перевод бумаг внутри ДКК.
  19. «Телефон» – контактный телефон получателя.
  20. «Юрисдикция» – страна регистрации получателя, наименование страны либо ее код.
  21. * «Отв. исполнитель» – ответственный исполнитель за исполнение поручения со стороны реестра.
  22. «Место хранения» – место хранения бумаг.
  23. «Торговый счет» – торговый счет брокера для вывода бумаг клиента с торгов.
  24. «Класс» – класс бумаг в торговой системе, к которому относятся данные бумаги.
  25. «Инструмент» – выбор наименования бумаги, с помощью контекстного поиска (поиск значения из списка по первым буквам, вводимым с клавиатуры). При нажатии на кнопку «…» открывается диалог по выбору инструмента. Кнопка доступна, если для выбранного торгового счёта доступен хотя бы один класс инструментов.
    Если поле «Класс» отсутствует на форме или недоступно для редактирования, то в поле «Инструмент» отображается полный список инструментов в формате: <Инструмент [Класс]> с сортировкой по инструменту.
  26. «Название инструмента» – полное наименование бумаги.
  27. «ISIN» – код, присвоенный ценной бумаге.
  28. «Номер гос. рег.» – номер, под которым зарегистрирована ценная бумага.
  29. «Тип инструмента» – наименование типа ценной бумаги.
  30. «Количество» – количество ценных бумаг в штуках. Максимальная длина поля: 13 символов. В скобках справочно отображается информация по размеру лота для инструмента.
  31. Поле «Основание поручения» содержит наименование документа, являющегося основанием для проведения операций (например, договор купли-продажи, депозитарный договор) и его реквизиты. При нажатии на кнопку «…» открывается справочник по выбору документа-основания. Для выбора доступны документы типа «Прочие».
  32. «Оплата с/на счет» – тип банковского счета, с которого будут производиться оплата поставки ценных бумаг. Правила использования этого поля определяются Брокером.
  33. «Примечание» – текстовый комментарий к поручению.
  34. «Основание поставки ЦБ» – наименование документа, являющегося основанием для проведения операций (например, договор купли-продажи, депозитарный договор) и его реквизиты. При нажатии на кнопку «…» открывается справочник по выбору документа-основания. Для выбора доступны документы типа «Прочие».
  35. «Основание для перевода» – указывается брокером (депозитарный договор получателя с ДКК, контрагента с номинальным держателем и т.п.). Поле доступно для заполнения на этапе подписи депозитарием. При нажатии на кнопку «…» открывается справочник по выбору документа-основания. Для выбора доступны документы типа «Прочие».
  36. «Срок действия» - период времени, в течение которого поручение должно быть исполнено. Может принимать одно из значений:
    • «До отмены» - срок исполнения не ограничен;
    • «По» - поручение должно быть исполнено до указанной даты включительно. Если поручение не удалось выполнить в срок, ему присваивается статус «Истек срок действия».

    Если в настройках Модуля неторговых поручений установлен максимальный срок действия поручения, то значение «До отмены» не отображается, а в значении «По» должна быть выбрана дата, не превышающая установленный максимальный срок.
  37. Поле «Комментарий отмены» предусмотрено на случай отмены исполнения поручения, при котором в нем будет записана его причина, указанная брокером. В случае отмены поручения по инициативе клиента, в поле «Запрос на отмену» будет записана причина отмены, указанная пользователем.
  38. «Комментарий» - комментарий к поручению. Максимальная длина поля: 1000 символов.
  39. «Комментарий брокера» - поле доступно для просмотра и изменения только сотрудникам брокера.
    (*) Параметры поручений на перевод бумаг из ДКК или НРД в реестр. Для перевода внутри депозитариев эти поля не используются.
    На форме подачи поручения на вывод ценных бумаг предусмотрен дополнительный переключатель, который используется Брокером на свое усмотрение для ввода произвольной информации.


Поручение на перевод ценных бумаг

меню Расширения / Неторговые поручения / Перевод ЦБ

Поручение предназначено для перевода ценных бумаг между счетами в пределах одного торгового счета.

При подаче поручения на Перевод ЦБ можно использовать только связанные инструменты, настраиваемые Брокером.

Назначение полей поручения:

  1. «Входящий номер» – входящий номер поручения, заполняется пользователем. Поле может содержать произвольные символы. Максимальная длина поля: 32 символа. Поле доступно только при вводе поручения.
  2. «Номер поручения» – регистрационный номер поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Номер». Поле доступно только при открытии поданного поручения в режиме просмотра.
  3. «Дата регистрации» – дата регистрации поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Дата рег.». Поле доступно только при открытии поданного поручения в режиме просмотра.
  4. «Время регистрации» – время регистрации поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Время рег.». Поле доступно только при открытии поданного поручения в режиме просмотра.
  5. «Срочность» - приоритет осуществления операции. По умолчанию может принимать одно из значений: «Нормальная», «Низкая», «Высокая». Дополнительные значения задаются Брокером из справочника «Срочности».
  6. «Код клиента (списан.)» - код клиента-поставщика ценных бумаг. В поле ниже справочно показывается фамилия и имя клиента. Если в Рабочем месте QUIK включена настройка «Заменять коды клиентов на ФИО», то вместо кода клиента отображаются фамилия, имя, отчество клиента.

    При смене кода клиента значения полей «Торговый счет», «Класс», «Инструмент» не сбрасываются, если данные значения допустимы для выбранного кода клиента.
  7. «Договор обслуживания» – номер договора обслуживания. В поле ниже справочно выводится дата заключения договора. Если у брокера включен режим подстановки договора, то поле заполняется автоматически, даже если оно недоступно для редактирования (если у клиента несколько договоров обслуживания, то подставляется договор с более поздней датой).
  8. «Депозитарный договор» – номер депозитарного договора. В поле ниже справочно выводится дата заключения договора.
  9. «Депо счет (списание)» – счет ДЕПО клиента в депозитарии. В поле ниже справочно выводится информация о получателе.
    • «Раздел счета» – выбирается раздел счета ДЕПО.
  10. «Учетный счет» – счет клиента для учета движения денежных средств.
  11. «Место хранения» – место хранения списания.
  12. «Торговый счет списания» – код торгового счета брокера, на котором учтены бумаги.
  13. «Фирма списания» – информационное поле, в котором отображается описание фирмы, с которой списываются бумаги. Задается брокером.
  14. «Класс» – класс инструментов в торговой системе биржи, к которому относятся списываемые бумаги.
  15. «Инструмент» – выбор наименования бумаги с помощью контекстного поиска. При нажатии на кнопку «…» открывается диалог по выбору инструмента. Кнопка доступна, если для выбранного торгового счёта доступен хотя бы один класс инструментов.
    Если поле «Класс» отсутствует на форме или недоступно для редактирования, то в поле «Инструмент» отображается полный список инструментов в формате: <Инструмент [Класс]> с сортировкой по инструменту.
  16. «Название» – полное наименование бумаги.
  17. «ISIN» – код, присвоенный ценной бумаге.
  18. «Номер гос.рег» – номер, под которым зарегистрирована ценная бумага.
  19. «Тип инструмента» – наименование типа ценной бумаги.
  20. «Количество» – количество бумаг, в штуках. Максимальная длина поля: 13 символов. В скобках справочно отображается информация по размеру лота для инструмента, выбранного для списания.
  21. «Код клиента» – код клиента – получателя ценных бумаг. В поле ниже справочно показывается фамилия и имя клиента. Если в Рабочем месте QUIK включена настройка «Заменять коды клиентов на ФИО», то вместо кода клиента отображаются фамилия, имя, отчество клиента.
  22. «Депо счет (зачисление)» – счет ДЕПО клиента в депозитарии. В поле ниже справочно выводится информация о получателе.
    • «Раздел счета» – выбирается раздел счета ДЕПО.
  23. «Фирма зачисл.» – информационное поле, в котором отображается описание фирмы, на которую зачисляются бумаги. Задается брокером.
  24. «Место хранения зачисл.» – место хранения зачисления.
  25. «Торговый счет зачисления» – код торгового счета брокера, на который требуется перевести бумаги.
  26. «Класс зачисл.» – класс инструментов в торговой системе биржи, к которому относятся зачисляемые бумаги.
  27. «Код при зачислении» – выбор кода инструмента при зачислении с помощью контекстного поиска. При нажатии на кнопку «…» открывается диалог по выбору инструмента. Кнопка доступна, если для выбранного торгового счёта доступен хотя бы один класс инструментов. Если поле «Код при зачислении» отсутствует на форме, то в качестве кода при зачислении используется код инструмента для списания.
  28. Поля «Налог», «Комиссия депозитария», «Комиссия за выд. нал.» заполняются при необходимости сотрудниками брокера при подтверждении поручения, в них указываются дополнительные платежи, связанные с исполнением поручения.
  29. «Дата сделки» – указывается брокером при подтверждении поручения, параметр поручения на перевод бумаг внутри ДКК.
  30. «Дата расчетов» – указывается брокером при подтверждении поручения, параметр поручения на перевод бумаг внутри ДКК.
  31. «Основание поручения» – наименование документа, являющегося основанием для проведения операций (например, договор купли-продажи, депозитарный договор) и его реквизиты. При нажатии на кнопку «…» открывается справочник по выбору документа-основания. Для выбора доступны документы типа «Прочие».
  32. «Срок действия» - период времени, в течение которого поручение должно быть исполнено. Может принимать одно из значений:
    • «До отмены» - срок исполнения не ограничен;
    • «По» - поручение должно быть исполнено до указанной даты включительно. Если поручение не удалось выполнить в срок, ему присваивается статус «Истек срок действия».

    Если в настройках Модуля неторговых поручений установлен максимальный срок действия поручения, то значение «До отмены» не отображается, а в значении «По» должна быть выбрана дата, не превышающая установленный максимальный срок.
  33. Поле «Комментарий отмены» предусмотрено на случай отмены исполнения поручения, при котором в нем будет записана его причина, указанная брокером. В случае отмены поручения по инициативе клиента, в поле «Запрос на отмену» будет записана причина отмены, указанная пользователем.
  34. «Комментарий» – комментарий к поручению. Максимальная длина поля: 1000 символов.
  35. «Комментарий брокера» – поле доступно для просмотра и изменения только сотрудникам брокера.


Поручение на конвертацию валют

меню Расширения / Неторговые поручения / Конвертация валют

Поручение предназначено для конвертации одной валюты, хранящейся на счете клиента, в другую.

Назначение полей поручения:

  1. «Входящий номер» – входящий номер поручения, заполняется пользователем. Поле может содержать произвольные символы. Максимальная длина поля: 32 символа. Поле доступно только при вводе поручения.
  2. «Номер поручения» – регистрационный номер поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Номер». Поле доступно только при открытии поданного поручения в режиме просмотра.
  3. «Дата регистрации» – дата регистрации поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Дата рег.». Поле доступно только при открытии поданного поручения в режиме просмотра.
  4. «Время регистрации» – время регистрации поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Время рег.». Поле доступно только при открытии поданного поручения в режиме просмотра.
  5. «Срочность» - приоритет осуществления операции. По умолчанию может принимать одно из значений: «Нормальная», «Низкая», «Высокая». Дополнительные значения задаются Брокером.
  6. «Код клиента» - код клиента-отправителя средств. В поле ниже справочно показывается фамилия и имя клиента. Если в Рабочем месте QUIK включена настройка «Заменять коды клиентов на ФИО», то вместо кода клиента отображаются фамилия, имя, отчество клиента.
  7. «Код клиента (зачисл.)» - код клиента-получателя средств. В поле ниже справочно показывается фамилия и имя клиента. Если в Рабочем месте QUIK включена настройка «Заменять коды клиентов на ФИО», то вместо кода клиента отображаются фамилия, имя, отчество клиента.
  8. «Договор обслуживания» - договор брокерского обслуживания с клиентом-отправителем. В поле ниже справочно показывается дата заключения договора. Если у брокера включен режим подстановки договора, то поле заполняется автоматически, даже если оно недоступно для редактирования (если у клиента несколько договоров обслуживания, то подставляется договор с более поздней датой).
  9. «Конвертация из» - валюта, из которой производится конвертация.
  10. «Конвертация в» - валюта, получаемая после конвертации.
  11. «Конвертируемая сумма» - сумма денежных средств для выполнения операции.
  12. «Получаемая сумма» - сумма денежных средств к получению.
  13. «Согласие на частичное исполнение» – признак возможности частичного исполнения поручения.
  14. Поля «Налог», «Комиссия депозитария», «Комиссия за выд.нал.» заполняются при необходимости сотрудниками брокера в момент подтверждения поручения, в них указываются дополнительные платежи, связанные с исполнением поручения.
  15. «Указывается исходная сумма» – если опция включена, то:
    • В поле «Конвертируемая сумма» вводится сумма для конвертации;
    • В поле «Получаемая сумма» (в режиме «только для чтения») отображается сумма, которая получится после конвертации.
  16. «Указывается получаемаясумма» – если опция включена, то:
    • В поле «Конвертируемая сумма» (в режиме «только для чтения») отображается сумма, вычисленная до конвертации;
    • В поле «Получаемая сумма» вводится сумма, получаемая после конвертации.
  17. «Задать курс конвертации вручную» – признак ручного ввода курса конвертации, указываемого в поле «Курс конвертации».
  18. «Курс конвертации» - значение курса конвертации валют. Рядом с полем отображается направление конвертации в виде соотношения выбранных кодов валют.

    Максимальное количество знаков в значении курса конвертации – 12 (считаются все знаки до и после запятой).

  19. Кнопка «Наоборот» позволяет изменить заданный курс на обратный (например, при выбранной валюте USD/RUR изменится на RUR/USD), заданное значение в поле «Курс конвертации» тоже заменяется на обратное к введенному. Повторное нажатие кнопки снова изменит направление курса конвертации.
  20. «Срок действия» - период времени, в течение которого поручение должно быть исполнено. Может принимать одно из значений:
    • «До отмены» - срок исполнения не ограничен;
    • «По» - поручение должно быть исполнено до указанной даты включительно. Если поручение не удалось выполнить в срок, ему присваивается статус «Истек срок действия».

    Если в настройках Модуля неторговых поручений установлен максимальный срок действия поручения, то значение «До отмены» не отображается, а в значении «По» должна быть выбрана дата, не превышающая установленный максимальный срок.
  21. Поле «Комментарий отмены» предусмотрено на случай отмены исполнения поручения, при котором в нем будет записана его причина, указанная брокером. В случае отмены поручения по инициативе клиента, в поле «Запрос на отмену» будет записана причина отмены, указанная пользователем.
  22. «Комментарий» - комментарий к поручению. Максимальная длина поля: 1000 символов.
  23. «Комментарий брокера» - поле доступно для просмотра и изменения только сотрудникам брокера.


Поручение свободного вида

меню Расширения / Неторговые поручения / Свободная форма

Поручение предназначено для подачи поручения произвольного содержания, представленного в виде текстового сообщения.

Назначение полей поручения:

  1. «Тип поручения».
  2. «Срочность» - приоритет осуществления операции. По умолчанию может принимать одно из значений: «Нормальная», «Низкая», «Высокая». Дополнительные значения задаются Брокером.
  3. «Код клиента» - код клиента-отправителя средств. В нижнем поле справочно указывается фамилия и имя клиента.
  4. «Договор обслуживания» – договор брокерского обслуживания с клиентом-отправителем, в нижнем поле справочно указывается дата заключения договора. Если у брокера включен режим подстановки договора, то поле заполняется автоматически, даже если оно недоступно для редактирования (если у клиента несколько договоров обслуживания, то подставляется договор с более поздней датой).
  5. «Раздел» – раздел шаблона текста для поручений свободного вида. Список разделов загружается с сервера QUIK, добавление шаблонов пользователем не предусмотрено.
  6. «Шаблон» – шаблон текста для поручений свободного вида. Список шаблонов загружается с сервера QUIK, добавление шаблонов пользователем не предусмотрено. Шаблоны в списке фильтруются по выбранному разделу. По желанию брокера шаблон может иметь запрет на редактирование.
  7. «Текст поручения» - поле с текстом поручения. Обычно указывается тип поручения и необходимые данные для выполнения поручения.
  8. «Срок действия» - период времени, в течение которого поручение должно быть исполнено. Может принимать одно из значений:
    • «До отмены» - срок исполнения не ограничен;
    • «По» - поручение должно быть исполнено до указанной даты включительно. Если поручение не удалось выполнить в срок, ему присваивается статус «Истек срок действия».

    Если в настройках Модуля неторговых поручений установлен максимальный срок действия поручения, то значение «До отмены» не отображается, а в значении «По» должна быть выбрана дата, не превышающая установленный максимальный срок.
  9. «Комментарий» - текстовый комментарий к поручению. Максимальная длина поля: 1000 символов.
  10. Поле «Комментарий отмены» предусмотрено на случай отмены исполнения поручения, при котором в нем будет записана его причина, указанная брокером. В случае отмены поручения по инициативе клиента, в поле «Запрос на отмену» будет записана причина отмены, указанная пользователем.
  11. «Комментарий брокера» - поле доступно для просмотра и изменения только сотрудникам брокера.

На форме подачb поручения свободного вида предусмотрены дополнительные поля и переключатели, которые используются Брокером на свое усмотрение для ввода произвольной информации (например: телефон, адрес электронной почты и т.п.).

Поручение вводится нажатием на кнопку «Подать».


Поручение на конвертацию ЦБ

меню Расширения / Неторговые поручения / Конвертация ЦБ

Поручение предназначено для конвертации одной ценной бумаги, хранящейся на счете клиента, в другую.

При подаче поручения на Перевод ЦБ можно использовать только связанные инструменты, настраиваемые Брокером.

Назначение полей поручения:

  1. «Входящий номер» – входящий номер поручения, заполняется пользователем. Поле может содержать произвольные символы. Максимальная длина поля: 32 символа. Поле доступно только при вводе поручения.
  2. «Номер поручения» – регистрационный номер поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Номер». Поле доступно только при открытии поданного поручения в режиме просмотра.
  3. «Дата регистрации» – дата регистрации поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Дата рег.». Поле доступно только при открытии поданного поручения в режиме просмотра.
  4. «Время регистрации» – время регистрации поручения на сервере QUIK. Значение отображается в таблице «Неторговые поручения» в столбце «Время рег.». Поле доступно только при открытии поданного поручения в режиме просмотра.
  5. «Срочность» - приоритет осуществления операции. По умолчанию может принимать одно из значений: «Нормальная», «Низкая», «Высокая». Дополнительные значения задаются Брокером.
  6. «Код клиента» - код клиента-отправителя средств. В поле ниже справочно показывается фамилия и имя клиента. Если в Рабочем месте QUIK включена настройка «Заменять коды клиентов на ФИО», то вместо кода клиента отображаются фамилия, имя, отчество клиента.

    При смене кода клиента значения полей «Торговый счет», «Класс», «Инструмент» не сбрасываются, если данные значения допустимы для выбранного кода клиента.
  7. «Договор обслуживания» – номер договора обслуживания. Если у брокера включен режим подстановки договора, то поле заполняется автоматически, даже если оно недоступно для редактирования (если у клиента несколько договоров обслуживания, то подставляется договор с более поздней датой).
  8. «Депозитарный договор» – номер депозитарного договора.
  9. «Депо счёт» - счет ДЕПО клиента в депозитарии. В поле ниже справочно выводится информация о получателе.
    • «Раздел» - выбирается раздел счета ДЕПО. Возможные значения: «Основной» и «Торговый».
  10. «Учетный счет» – счет клиента для учета движения денежных средств.
  11. «Валюта сделки».
  12. Поля «Налог», «Комиссия депозитария», «Комиссия за выд. нал.» заполняются (при необходимости) сотрудниками брокера при подтверждении поручения, в них указываются дополнительные платежи, связанные с исполнением поручения.
  13. «Конвертировать из»/ «Конвертировать в» служит для выбора следующих параметров конвертации:
    • «Место хранения» / «Место хранения зачисл.» – место хранения списания / зачисления;
    • «Торговый счет» - торговый счет брокера для списания/зачисления бумаг клиента на торги;
    • «Класс» / «Класс зачисления» - класс инструментов в торговой системе биржи, к которому относятся бумаги.

      Если в настройках Модуля неторговых поручений включен режим выбора инструмента из полного списка, то поле недоступно для редактирования и заполняется автоматически при выборе инструмента;

    • «Инструмент» / «Инструмент зачисления» - выбор наименования бумаги с помощью контекстного поиска. При нажатии на кнопку «…» открывается диалог по выбору инструмента. Кнопка доступна, если для выбранного торгового счёта доступен хотя бы один класс инструментов.

      Если поле «Класс» отсутствует на форме или недоступно для редактирования, то в поле «Инструмент» отображается полный список инструментов в формате: <Инструмент [Класс]> с сортировкой по инструменту.

      Если в настройках Модуля неторговых поручений включен режим выбора инструмента из полного списка, то для выбора доступна только кнопка «…», при нажатии на которую открывается диалог со списком всех инструментов всех классов, доступных для данного типа поручения. Если инструмент зачисления выбран, то при выборе инструмента списания проверяется возможность конвертации, и если конвертация выбранных инструментов невозможна, то поле «Инструмент зачисления» очищается. При выборе инструмента списания список для поля «Инструмент зачисления» фильтруется;

    • «Название инструмента» – полное наименование бумаги;
    • «ISIN» / «ISIN зачисления» - код по классификации ISIN, присвоенный ценной бумаге;
    • «Номер гос. рег.» - государственный регистрационный номер выпуска ценных бумаг, присвоенный данному активу;
    • «Тип» – наименование типа ценной бумаги;
    • «Количество» / «Количество зачисления» - количество ценных бумаг в штуках. Максимальная длина поля: 13 символов. В скобках справочно отображается информация по размеру лота для инструмента.

      Если инструменты списания и зачисления выбраны, то при редактировании значения в поле «Количество» автоматически пересчитывается значение в поле «Количество зачисления» (и наоборот) с учётом коэффициента конвертации;

    • «Коэффициент конвертации» – коэффициент конвертации инструментами списания в инструмент зачисления. Значение отображается с точностью до 2 знаков после десятичного разделителя. Поле недоступно для редактирования.
  14. Поле «Основание поручения» содержит наименование документа, являющегося основанием для проведения операций (например, договор купли-продажи, депозитарный договор) и его реквизиты. При нажатии на кнопку «…» открывается справочник по выбору документа-основания.
  15. «Примечание» – текстовый комментарий к поручению.
  16. «Срок действия» - период времени, в течение которого поручение должно быть исполнено. Может принимать одно из значений:
    • «До отмены» - срок исполнения не ограничен;
    • «По» - поручение должно быть исполнено до указанной даты включительно. Если поручение не удалось выполнить в срок, ему присваивается статус «Истек срок действия».

    Если в настройках Модуля неторговых поручений установлен максимальный срок действия поручения, то значение «До отмены» не отображается, а в значении «По» должна быть выбрана дата, не превышающая установленный максимальный срок.
  17. Поле «Комментарий отмены» предусмотрено на случай отмены исполнения поручения, при котором в нем будет записана его причина, указанная брокером. В случае отмены поручения по инициативе клиента, в поле «Запрос на отмену» будет записана причина отмены, указанная пользователем.
  18. «Комментарий» - комментарий к поручению. Максимальная длина поля: 1000 символов.
  19. «Комментарий брокера» - поле доступно для просмотра и изменения только сотрудникам брокера.


Поручения на размещение ЦБ

меню Расширения / Неторговые поручения / Размещение ЦБ

Поручение предназначено для подачи заявки на участие в аукционе по размещению ценных бумаг.

Назначение полей поручения:

  1. «Срочность» - приоритет осуществления операции. По умолчанию может принимать одно из значений: «Нормальная», «Низкая», «Высокая». Дополнительные значения задаются Брокером.
  2. «Код клиента» – код клиента-отправителя средств. В поле ниже справочно указывается фамилия и имя клиента. Если в Рабочем месте QUIK включена настройка «Заменять коды клиентов на ФИО», то вместо кода клиента отображаются фамилия, имя, отчество клиента.
  3. «Лицевой счет» – лицевой счет клиента.
  4. «Субсчет» – субсчет лицевого счета клиента.
  5. «Договор обслуживания» – номер договора на брокерское обслуживание, заключенный с клиентом. В поле ниже справочно показывается дата договора. Если у брокера включен режим подстановки договора, то поле заполняется автоматически, даже если оно недоступно для редактирования (если у клиента несколько договоров обслуживания, то подставляется договор с более поздней датой).
  6. «Инструмент» – наименование бумаги.
  7. «Дополнительные параметры подписки» – текстовое поле для ввода клиентом дополнительных параметров размещения не предусмотренных стандартной формой.
  8. «Срок действия» - период времени, в течение которого поручение должно быть исполнено. Может принимать одно из значений:
    • «До отмены» - срок исполнения не ограничен;
    • «По» - поручение должно быть исполнено до указанной даты включительно. Если поручение не удалось выполнить в срок, ему присваивается статус «Истек срок действия».

    Если в настройках Модуля неторговых поручений установлен максимальный срок действия поручения, то значение «До отмены» не отображается, а в значении «По» должна быть выбрана дата, не превышающая установленный максимальный срок.
  9. «Сумма» – объем денежных средств, резервируемых клиентом под исполнение поручения.
  10. «Площадка» – код расчетов, соответствующий позиции по денежным средствам, на который зачисляются средства, например, «EQTV» соответствует Фондовой бирже ММВБ.
  11. «Валюта сделки».
  12. «Согласие на частичное исполнение» – признак возможности частичного исполнения поручения.
  13. Поля «Налог», «Комиссия депозитария», «Комиссия за выд. нал.» заполняются при необходимости сотрудниками брокера при подтверждении поручения, в них указываются дополнительные платежи, связанные с исполнением поручения.
  14. «ISIN» – код, присвоенный ценной бумаге.
  15. «Эмитент» - организация, выпустившая ценные бумаги.
  16. «Номинал» - номинал размещаемого инструмента.
  17. «Валюта» - валюта размещаемого инструмента.
  18. «Правила» – текстовое поле для опубликования правила размещения ЦБ.
  19. «Количество» – количество ценных бумаг в поручении. Максимальная длина поля: 13 символов.
  20. «Цена» - цена за единицу инструмента.
  21. «Дата размещения» - предполагаемая дата размещения ЦБ.
  22. «Согласие с условиями размещения» – подтверждение клиентом принятия условий размещения ЦБ.
  23. «Торговая система» – биржевая торговая система для зачисления средств на торги.
  24. «Комментарий» - комментарий к поручению. Максимальная длина поля: 1000 символов.
  25. «Комментарий брокера» - поле доступно для просмотра и изменения только сотрудникам брокера.


Выбор документа-основания

Справочник «Документы-основания» содержит в себе список документов и предназначен для заполнения полей «Основания» в поручениях. Имеется возможность добавления новых и изменения существующих документов.

Справочник представлен в виде таблицы. Каждая строка в таблице соответствует отдельному документу. Столбцы таблицы имеют следующие значения:
Параметр | Назначение
Тип документа | Наименование документа основания
Номер | Номер документа
Дата | Дата документа
Реквизиты | Реквизиты документа

Типы используемых документов и доступность полей «Номер», «Дата», «Реквизиты» настраиваются в бэк-офисе Модуля неторговых поручений.

Значение кнопок диалога:

  1. Кнопка «Добавить» – открывает диалог добавления нового документа.
  2. Кнопка «Изменить» – изменение существующего документа.
  3. Кнопка «Удалить» – удаление выбранного документа из списка.
  4. Кнопка «Очистить» – удаление всех документов из списка.
  5. Кнопки [image], [image] – перемещение выбранного документа по списку вверх или вниз на одну позицию.

Для добавления выбранного документа в поле «Основание» нажмите кнопку «Сохранить».


Подтверждение одноразовым паролем

Для поручений, подаваемых пользователем через Рабочее место QUIK, доступна функция подтверждения одноразовым паролем.

Если подпись, на которой настроено подтверждение одноразовым паролем, является первой подписью, то уведомление о необходимости подтверждения неторгового поручения одноразовым паролем выводится на экран при подаче поручения. Иначе – после выставления всех предыдущих подписей.

При нажатии кнопки «Подтвердить» пользователю отправляется уведомление, содержащее одноразовый пароль. Способ получения пароля (email, SMS, push) зависит от настроек Модуля рассылки уведомлений.

Для получения нового одноразового пароля нажмите кнопку «Получить новый». Количество попыток получения и количество попыток ввода одноразового пароля настраиваются администратором Модуля неторговых поручений. После исчерпания максимального количества попыток ввода одноразового пароля неторговое поручение автоматически снимается.

Допускается ввод любого из полученных одноразовых паролей (как самого первого, так и запрошенных повторно).


Ввод получателя ДС

Окно «Ввод получателя ДС» предназначено для ввода информации о получателе денежных средств вручную, если он отсутствует в справочнике.

Назначение полей формы ввода получателя при наличных расчетах:

  1. «ФИО получателя» – фамилия, имя, отчество физического лица-получателя денежных средств.
  2. «Паспортные данные» – паспортные данные физического лица-получателя денежных средств.

Назначение полей формы ввода получателя при безналичных расчетах:

  1. «SWIFT-реквизиты» - признак выбора банковских реквизитов из справочника кодов SWIFT. При установке флажка в поле изменяются наименования полей в соответствии с настройками в БО модуля.
  2. «Наименование счета».
  3. «Наименование получателя» - фамилия, имя, отчество для физического лица или название организации для юридического.
  4. «ИНН получателя» - идентификационный номер налогоплательщика получателя.
  5. «БИК / SWIFT-код» - номер БИК или SWIFT, может быть заполнен из справочника нажатием на кнопку «…», в котором можно выбрать из списка соответствующую запись. Нижестоящие поля с реквизитами банка («БИК/SWIFT», «Наименование банка», «Адрес банка», «Корреспондентский счет», «Наименование учреждения Банка России» заполнятся автоматически.
  6. «Учреждение ЦБ РФ» - платежные реквизиты банка получателя.
  7. «Расчетный счет» - номер расчетного счета получателя.
  8. «Лицевой счет» - номер лицевого счета получателя.
  9. «Наличие банка корреспондента». При включении флажка становятся доступными для редактирования следующие поля:

    • «БИК корреспондента»;
    • «Наименование банка-корреспондента»;
    • «Адрес банка-корреспондента»;
  10. «Назначение платежа».
    В полях «Расчетный счет» и «Корреспондентский счет» допустимо вводить не более 20 цифр. При включенном режиме «SWIFT-реквизиты» в эти поля можно вводить до 32 символов (с пробелами).


Ввод получателя ЦБ

Окно «Ввод получателя ЦБ» предназначено для ввода информации о получателе ценных бумаг вручную, если он отсутствует в справочнике получателей.

Назначение полей формы ввода получателя ЦБ:

  1. «Получатель» – ФИО получателя ценных бумаг.
  2. «Депо счет получателя» – счет ДЕПО получателя в депозитарии.
  3. «Раздел счета депо» – раздел счета ДЕПО получателя.
  4. «Тип счета получателя» – тип счета получателя. Возможные значения:
    • «Собственник»;
    • «Номинальный держатель»;
    • «Доверительный управляющий»;
    • «Залогодержатель».
  5. «Идентификатор» – код получателя в НРД.
  6. «Документ получателя» – наименование документа, подтверждающего личность получателя бумаг. Если в справочнике документов-оснований есть хотя бы один документ типа «Удостоверяющие документы», то документ получателя можно выбрать из данного справочника, нажав кнопку «…» справа от поля.
  7. «Номер документа» – номер документа, подтверждающего личность получателя бумаг.
  8. «Кем выдан» – наименование организации, выдавшей документ.
  9. «Место хранения» – место хранения депо-реквизитов.


Импорт поручений из файла (подача поручений)

  • Формат tri-файла с параметрами транзакций
  • Примеры строк в файле транзакций
    •

    Рабочее место QUIK позволяет подавать неторговые поручения с помощью импорта через файл. При импорте поручений считывается строка с транзакцией на постановку нового неторгового поручения из .tri-файла, заданная в фиксированном формате. Каждая строка обрабатывается независимо. Если строка разобрана успешно, то Рабочее место QUIK отправляет на сервер транзакцию. Поданное поручение обрабатывается точно так же, как и поручение, поданное через форму ввода. Если транзакцию обработать не удалось, то сообщение об ошибке будет выведено в окне сообщений.

    При отправке транзакций все поля передаются как указаны в файле. Исключение составляют поля, которые содержат ссылку на запись в справочнике. В этом случае производится поиск записи по ключевому полю. Если запись будет найдена, то используется именно она. Если запись в справочнике обнаружить не удалось, то поле заполняется исходя из введенных вручную сведений.

    Описание процедуры импорта через файл в фиксированном формате см. в Импорт транзакций.
    Не рекомендуется размещать tri-файлы в сети.


Формат tri-файла с параметрами транзакций

Файл представляет собой последовательность строк, каждая из которых содержит информацию по отдельной транзакции. Параметры транзакции описываются в виде «НАЗВАНИЕ_ПАРАМЕТРА= значение_параметра» и разделяются символом «;».

Во всех текстовых полях не могут использоваться символы «;», «|», перевод строки «ENTER». Они являются служебными и используются только в строгом соответствии с описанием.

Параметры и принимаемые ими значения:

Параметр | Значение
ACTION Тип поручения. Обязательный параметр. Возможные значения:
  • «NEW_INSTR_TYPE_<тип>» – тип поручения. Возможные значения:
    • «NEW_INSTR_TYPE_0» - Ввод ДС безналично;
    • «NEW_INSTR_TYPE_1» - Ввод ДС налично;
    • «NEW_INSTR_TYPE_2» - Вывод ДС налично (остаток);
    • «NEW_INSTR_TYPE_3» - Перевод ДС;
    • «NEW_INSTR_TYPE_4» - Перевод ЦБ;
    • «NEW_INSTR_TYPE_5» - Вывод ДС безналично;
    • «NEW_INSTR_TYPE_6» - Вывод ДС налично;
    • «NEW_INSTR_TYPE_7» - Вывод ДС безналично (остаток);
    • «NEW_INSTR_TYPE_8» - Получение ЦБ в ДКК из реестра;
    • «NEW_INSTR_TYPE_9» - Поставка ЦБ из ДКК в реестр;
    • «NEW_INSTR_TYPE_10» - Получение ЦБ внутри НРД;
    • «NEW_INSTR_TYPE_11» - Поставка ЦБ внутри НРД;
    • «NEW_INSTR_TYPE_12» - Получение ЦБ внутри ДКК;
    • «NEW_INSTR_TYPE_13» - Поставка ЦБ внутри ДКК;
    • «NEW_INSTR_TYPE_14» - Получение ЦБ внутри НРД из реестра;
    • «NEW_INSTR_TYPE_15» - Поставка ЦБ из НРД в реестр;
    • «NEW_INSTR_TYPE_16» - Конвертация валют;
    • «NEW_INSTR_TYPE_17» - Свободная форма;
    • «NEW_INSTR_TYPE_18» - Конвертация ЦБ;
    • «NEW_INSTR_TYPE_19» - Размещение ЦБ.
  • «NEW_INSTR_TYPEID_<идентификатор типа>» – идентификатор типа поручения
TRANS_ID | Номер подаваемой транзакции. Номер должен быть уникальным для транзакций всех типов, а не только подаваемых на постановку неторговых поручений. Обязательный параметр
CLASSCODE | Код класса неторговых поручений. Обязательный параметр
INSTR_RATE Срочность поручения. Обязательный параметр. Возможные значения:
  • «1» - низкая;
  • «2» - нормальная;
  • «3» - высокая.

Дополнительные значения задаются Брокером

CLIENT_CODE | Код клиента. Обязательный параметр. Строка длиной до 12 символов
AGREE_SERV

Параметр договора обслуживания (списание). Строка длиной не более 128 символов с данными договора обслуживания. Данные для разных полей разделяются символом «|», который должен стоять также после последнего символа строки. Порядок полей: «Номер договора», «Дата договора». Параметр «Дата договора» в формате <ГГГГММДД>.

Используется в поручениях типа: 1, 2, 3, 5, 6, 7, 16, 19

AGREE_SERV2

Параметр договора обслуживания (зачисление). Строка длиной не более 128 символов с данными договора обслуживания. Данные для разных полей разделяются символом «|», который должен стоять также после последнего символа строки. Порядок полей: «Номер договора», «Дата договора». Параметр «Дата договора» в формате <ГГГГММДД>.

Используется в поручениях типа: 1, 2, 3, 5, 6, 7, 16, 19

AGREE_DEPO | Параметр депозитарного договора. Строка с данными депозитарного договора длиной не более 128 символов. Данные для разных полей разделены символом «|», который должен стоять также после последнего символа строки. Порядок полей: «Номер договора», «Дата договора». Параметр «Дата договора» записывается как <ГГГГММДД>
VOLUME

Сумма. Обязательный параметр. Указывается с двумя знаками после десятичного разделителя.

Используется в поручениях типа: 1, 2, 3, 5, 6, 7, 16, 19. Для поручений типа: 2 и 7 равен «0»

QUANTITY

Количество. Обязательный параметр.

Используется в поручениях типа: 4, 8, 9, 10, 11, 12, 13, 14, 15, 18

PAY_NUMBER

Номер платежного получения. Строка длиной до 32 символов.

Используется в поручениях типа: 0

SECCODE В разный типах поручений параметр имеет следующие значения:
  • поручения по денежным средствам - код инструмента, описывающий валюту. Для поручений «Конвертация валют» и «Перевод ДС» указывается инструмент списания;
  • поручения по ЦБ - код инструмента, описывающий валюту, в которой будет списываться комиссия;
  • поручение "Размещение ЦБ» - код инструмента, описывающий валюту, в который будет списываться комиссия и блокироваться средства под подписку.
Обязательный параметр. Используется в поручениях типа: 1, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 18, 19
SECCODE_CP

Инструмент поручения при зачислении. Указывается инструмент (валюта) зачисления.

Используется в поручениях типа: 3, 16

REAL_SECCODE

Инструмент зачисления. Может быть указан только инструмент, присутствующий на сервере QUIK. Доступен только для поручений по ценным бумагам.

Используется в поручениях типа: 4, 8, 9, 10, 11, 12, 13, 14, 15, 18

REAL_CLASS

Инструмент зачисления. Может быть указан только инструмент, присутствующий на сервере QUIK. Доступен только для поручений по ценным бумагам.

Используется в поручениях типа: 4, 8, 9, 10, 11, 12, 13, 14, 15, 18

REAL_FIRM

Код фирмы. Может быть указан только код фирмы участника.

Используется в поручениях типа: 4, 8, 9, 10, 11, 12, 13, 14, 15, 18

CLIENT_CODE_CP

Код клиента-получателя. Указывается только для поручений на перевод ДС и ЦБ. Содержит текстовую строку до 12 символов.

Используется в поручениях типа: 3, 4

BENEFACTOR

Получатель безналичных денежных средств. Строка, в которой содержимое нескольких полей разделено знаком «|», включая последнее значение. Порядок полей: «Наименование получателя», «Фамилия», «Имя», «Отчество», «ИНН», «БИК (или swift-код)», «Расчетный счет», «Наименование банка», «Корр. Счет», «Лицевой счет», «Имеется банк посредник («Y» – есть, «N» – нет)», «БИК банка посредника (swift-коде)», «Название банка посредника», «Адрес банка посредника», «Назначение платежа для банка посредника», «Региональное учреждение ЦБ РФ», «Адрес банка». Пустое значение поля указывается в соответствии с порядком полей через разделитель «|».

Поля для банка-посредника заполняются только для swift-формата.

Используется в поручениях типа: 5, 7, 9, 11, 13, 15

BENEFACTOR_CASH

Получатель наличных денежных средств. Строка, в которой содержимое нескольких полей разделено знаком «|», включая последнее значение. Порядок полей: «Наименование получателя», «Фамилия», «Имя», «Отчество», «Паспортные данные получателя».

Используется в поручениях типа: 2, 6

CAN_SPLIT Согласие на частичное исполнение. Возможные значения:
  • «0» - клиент не согласен на частичное исполнение;
  • «1» - клиент согласен на частичное исполнение.

Используется в поручениях типа: 2, 5, 6, 7

LEFTOVER Признак вывода остатка. Возможные значения:
  • «Y» - параметр поручений «Вывод ДС налично (остаток)» и «Вывод ДС безналично (остаток)»;
  • «N» (по умолчанию) - параметр для всех прочих типов поручений.
Используется в поручениях типа: 2, 7
TS

Торговая система. Строка длиной до 32 символов.

Используется в поручениях типа: 1, 2, 3, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 19

PAY_ASSIGN

Основание платежа. Строка длиной до 200 символов.

Используется в поручениях типа: 5, 7

CLIENT_ACCOUNT

Лицевой счет клиента. Строка длиной до 128 символов.

Используется в поручениях типа: 1, 2, 3, 5, 6, 7, 19

CLIENT_SUB_ACC

Лицевой субсчет. Строка длиной до 32 символов.

Используется в поручениях типа: 1, 2, 3, 5, 6, 7, 19

CLIENT_CP_SUB_ACC

Лицевой субсчет клиента-получателя. Строка длиной до 32 символов.

Используется в поручениях типа: 3

ACCOUNT

Торговый счет. Строка длиной до 12 символов. Для поручения «Перевод ЦБ" параметр будет обозначать торговый счет списания.

Используется в поручениях типа: 4, 8, 9, 10, 11, 12, 13, 14, 15, 18

ACCOUNT_CP

Торговый счет зачисления. Строка длиной до 12 символов.

Используется в поручениях типа: 4, 18

PLACE

Место хранения. Строка длиной до 20 символов.

Используется в поручениях типа: 4, 8, 9, 10, 11, 12, 13, 14, 15, 18

DEPO_ACCOUNT

Поставщик ЦБ. Строка, в которой содержимое нескольких полей разделено знаком «|», включая последнее значение. Порядок полей: «Номер счёта»,«Распорядитель», «Владелец», «Депозитарий», «Номер депозитарного договора», «Дата заключения договора» (в формате <ГГГГММДД>).

Используется в поручениях типа: 4, 8, 9, 10, 11, 12, 13, 14, 15, 18

DEPO_ACC_TYPE

Раздел счета депо поставщика. Строка длиной до 15 символов.

Используется в поручениях типа: 4, 8, 9, 10, 11, 12, 13, 14, 15

DEPO_ACCOUNT_CP

Получатель ЦБ. Содержит данные по получателю ЦБ. Строка, в которой содержимое нескольких полей разделено знаком «|», включая последнее значение. Порядок полей: «Номер счёта», «Распорядитель», «Владелец», «Депозитарий», «Номер депозитарного договора», «Дата заключения договора (в формате ГГГГММДД)».

Используется в поручениях типа: 4

DEPO_ACC_TYPE_CP

Раздел счета депо получателя. Строка длиной до 15 символов.

Используется в поручениях типа: 4

PUT_REASON

Основание поставки ЦБ. Строка длиной до 250 символов.

Используется в поручениях типа: 8, 9, 10, 11, 12, 13, 14, 15

INSTR_REASON

Основание поручения. Строка длиной до 100 символов.

Используется в поручениях типа: 8, 9, 10, 11, 12, 13, 14, 15

SEC_DEAL_CURR

Валюта сделки.

Используется в поручениях типа: 8, 9, 10, 11, 12, 13, 14, 15

SEC_DEAL_SUMM

Сумма сделки.

Используется в поручениях типа: 8, 9, 10, 11, 12, 13, 14, 15

PAYER_ACCOUNT

Оплата производится с/на счет. Строка длиной до 100 символов.

Используется в поручениях типа: 8, 9, 10, 11, 12, 13, 14, 15

СP

Контрагент: получатель или поставщик. Строка длиной до 250 символов.

Используется в поручениях типа: 8, 9, 10, 11, 12, 13, 14, 15

COUNTRY

Юрисдикция. Строка длиной до 15 символов.

Используется в поручениях типа: 8, 9, 10, 11, 12, 13, 14, 15

DEPO_CP

Номер счета ДЕПО контрагента: получателя или поставщика. Строка длиной до 100 символов.

Используется в поручениях типа: 8, 10, 11, 12, 13, 14

SEC_DEAL_DATE

Дата сделки в формате <ГГГГММДД>.

Используется в поручениях типа: 13

SEC_PAY_DATE

Дата расчетов в формате <ГГГГММДД>.

Используется в поручениях типа: 13

PHONE

Контактный телефон. Строка длиной до 30 символов.

Используется в поручениях типа: 8, 9, 10, 11, 12, 13, 14, 15

SEC_COMMENT

Примечание. Строка длиной до 250 символов.

Используется в поручениях типа: 8, 9, 10, 11, 12, 13, 14, 15

SEC_DEPO_ID

Идентификатор в депозитарии. Строка длиной до 100 символов.

Используется в поручениях типа: 8, 10, 11, 12, 14

SUBDEPO_CP

Раздел счета ДЕПО контрагента. Строка длиной до 100 символов.

Используется в поручениях типа: 8, 10, 11, 12, 14

DOCUMENT

Наименование документа, удостоверяющего личность контрагента. Строка длиной до 100 символов.

Используется в поручениях типа: 8, 9, 10, 12, 14, 15

DOC_NUMBER

Номер документа, удостоверяющего личность. Строка длиной до 15 символов.

Используется в поручениях типа: 8, 9, 10, 12, 14, 15

DOC_DATE

Дата выдачи документа, удостоверяющего личность, в формате<ГГГГММДД>

Используется в поручениях типа: 8, 9, 10, 12, 14, 15

DOC_ISSUER

Кем был выдан данный документ. Строка длиной до 250 символов.

Используется в поручениях типа: 8, 9, 10, 12, 14, 15

SEC_CP_TYPE

Тип счета контрагента. Строка длиной до 100 символов.

Используется в поручениях типа: 8, 9, 10, 12, 14, 15

RESPONSIBLE

Ответственный исполнитель. Строка длиной до 100 символов.

Используется в поручениях типа: 8, 9, 14, 15

CLASSCODE_OUT

Код класса при зачислении. Код класса для зачисления ценных бумаг в поручении «Перевод ЦБ» или код класса полученных ценных бумаг в поручении «Конвертация ЦБ».

Используется в поручениях типа: 4, 18

SECCODE_OUT

Код инструмента при зачислении. Код инструмента для зачисления ценных бумаг в поручении «Перевод ЦБ» или код инструмента полученных ценных бумаг в поручении «Конвертация ЦБ».

Используется в поручениях типа: 2, 4, 18

FIRM_OUT

Код фирмы. Код фирмы должен соответствовать классу, указанному в поле «CLASSCODE_OUT». Используется для определения соответствия кода фирмы инструменту после конвертации ЦБ.

Используется в поручениях типа: 18

QUANTITY_OUT

Количество после конвертации ЦБ.

Используется в поручениях типа: 18

DOC_COMMENT

Комментарий к поручению. Строка длиной до 1000 символов.

Используется в поручениях типа: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18

FIRM_ACC_NAME

Наименование получателя. Должно присутствовать в справочнике банковских счетов брокера.

Используется в поручениях типа: 0

CROSS_RATE

Курс конвертации.

Используется в поручениях типа: 16

COMMON_TEXT

Текст поручения общего вида. Строка длиной до 1020 символов. Не должно содержать символа перевода строки («ENTER») и «;».

Используется в поручениях типа: 17

DISTR_SECCODE

Код инструмента подписки.

Используется в поручениях типа: 19

DISTR_DATE

Дата размещения в формате <ГГГГММДД>.

Используется в поручениях типа: 19

WANTED_QTY

Обязательный параметр. Количество бумаг для подписки.

Используется в поручениях типа: 19

WANTED_PRICE

Обязательный параметр. Цена бумаг для подписки.

Используется в поручениях типа: 19

DISTR_INFO

Дополнительные параметры подписки. Строка длиной до 250 символов.

Используется в поручениях типа: 19

EXPIREDAY

Срок действия поручения в формате <ГГГГММДД> либо «0» - если срок указан «До отмены».

Используется в поручениях типа: 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19

SEC_LOTSIZE

Размер лота для инструмента, по которому подается поручение на перевод ЦБ. Параметр задается, если лотность инструментов списания и зачисления различается. Используется в поручениях типа 4

SEC_IN_LOTSIZE

Размер лота для инструмента зачисления, по которому подается поручение на перевод ЦБ. Параметр задается, если лотность инструментов списания и зачисления различается. Используется для поручений типа 4

VOLUME_TRANS

Сумма зачисления после конвертации. Параметр задается, если не задан курс конвертации. Используется в поручениях типа: 16

SWIFT_MODE Режим банковских реквизитов. Возможные значения:
  • «0» – реквизиты в формате банка;
  • «1» – реквизиты банка в SWIFT-формате.
Используется в поручениях типа: 5, 7, 9, 11, 13, 15 (при условии, что задан параметр «BENEFACTOR»)
MAN_CRATE_MODE Режим задания кросс-курса. Возможные значения:
  • «0» – прямой кросс-курс;
  • «1» – обратный кросс-курс.
Используется в поручениях типа: 16
PLACE_TRANS | Место хранения зачисления. Строка длиной 20 символов. Используется в поручениях типа: 4, 18
DEPO_CLIENT_ACCOUNT Учетный счет.
Используется в поручениях типа: 4, 8, 9, 10, 11, 12, 13, 14, 15, 18
INTERNAL_NUMBER Входящий номер поручения.
Используется в поручениях типа: 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 18
DEPO_PLACE | Место хранения (депо). Используется в поручениях типа: 8, 9, 10, 11, 12, 13, 14, 15


Примеры строк в файле транзакций

Файл с транзакциями представляет собой ряд строк, обрабатываемых последовательно. Каждая строка соответствует новому поручению.

Поручение «Ввод ДС безналично»:

ACTION=NEW_INSTR_TYPE_0; TRANS_ID=434; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;

AGREE_SERV=Дог.000|20070307|; VOLUME=100.51; PAY_NUMBER= №100; SECCODE= RURSUR389;
TS= МБФР; CLIENT_ACCOUNT=Торговый счет 276; CLIENT_SUB_ACC=subacc276_Q7;
DOC_COMMENT=Ставка согласно тарифному плану; FIRM_ACC_NAME=СибирьГазОргСинтез-Инвест;

EXPIREDAY=20100228;INTERNAL_NUMBER=444;

Поручение «Ввод ДС налично»:

ACTION=NEW_INSTR_TYPE_1; TRANS_ID=435; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;
AGREE_SERV=Дог.000|20070307|; VOLUME=100.51; SECCODE=RURSUR389; TS= МБФР;
CLIENT_ACCOUNT=Торговый счет 276; CLIENT_SUB_ACC=subacc276_Q7;

DOC_COMMENT=Ставкасогласнотарифному плану; EXPIREDAY=20100228; INTERNAL_NUMBER=351/2;

Поручение «Вывод ДС налично (остаток)»:

ACTION=NEW_INSTR_TYPE_2; TRANS_ID=436; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;

AGREE_SERV=Дог.000|20070307|; VOLUME=0;

BENEFACTOR_CASH=Петров|Петр|Петрович|50 00 №12345675 выдан УВД г.Бобруйска 23.03.2001|;

CAN_SPLIT=1; LEFTOVER=Y; TS= МБФР; CLIENT_ACCOUNT=Торговый счет 276;

CLIENT_SUB_ACC=subacc276_Q7; SECCODE_OUT=RURSUR389;

DOC_COMMENT=Ставкасогласнотарифному плану;EXPIREDAY= 20100228; INTERNAL_NUMBER=51A;

Поручение «Перевод ДС»:

ACTION=NEW_INSTR_TYPE_3; TRANS_ID=437; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;
AGREE_SERV=Дог.000|20070307|; VOLUME=100.51; SECCODE=RURSUR389; SECCODE_CP=RURSUR389;

CLIENT_CODE_CP=Q8; CLIENT_ACCOUNT=Торговый счет 276;
CLIENT_SUB_ACC=subacc276_Q7; CLIENT_CP_SUB_ACC=12345;

DOC_COMMENT=Ставкасогласнотарифному плану;
EXPIREDAY= 0; INTERNAL_NUMBER=89-4;

Поручение «Перевод ЦБ»:

ACTION=NEW_INSTR_TYPE_4; TRANS_ID=438; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;
QUANTITY=10; SECCODE=RURSUR389; REAL_SECCODE=EESR; REAL_CLASS=BQUOTE;
REAL_FIRM=NC0038900000; CLIENT_CODE_CP=Q8; ACCOUNT=L01-00000F00;

ACCOUNT_CP=L01-00000F00; DEPO_ACCOUNT=L01-00000F00|Брокеров И.И.|Ушкин У.У.|НРД|Дог.105|20070307|;

DEPO_ACC_TYPE=111; DEPO_ACCOUNT_CP=L01-00000F00|Брокеров И.И.|Ушкин У.У.|НРД|Дог.105|20070307|;

DEPO_ACC_TYPE_CP=111; CLASSCODE_OUT=BQUOTE; SECCODE_OUT=EESR;
DOC_COMMENT=Ставка согласнотарифному плану;EXPIREDAY=0; INTERNAL_NUMBER=404;

Поручение «Вывод ДС безналично»:

ACTION=NEW_INSTR_TYPE_5; TRANS_ID=439; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;
AGREE_SERV=Дог.000|20070307|; VOLUME=100.51; SECCODE=RURSUR389;
BENEFACTOR=Тупик|Клиентов|Сергей|Сергеевич|540100000001|045004001|40801810000000000001|Брокер-Банк|31001810000000000001|005|;

CAN_SPLIT=1; TS= МБФР; PAY_ASSIGN=п/п 50; CLIENT_ACCOUNT=Торговый счет 276;
CLIENT_SUB_ACC=subacc276_Q7;
DOC_COMMENT=Ставка согласно тарифному плану;

EXPIREDAY=0; INTERNAL_NUMBER=32;

Поручение «Вывод ДС налично»:

ACTION=NEW_INSTR_TYPE_6; TRANS_ID=440; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;
AGREE_SERV=Дог.000|20070307|; VOLUME=100.51; SECCODE=RURSUR389;
BENEFACTOR_CASH=ПЕТРОВ|ПЕТР|ПЕТРОВИЧ|50 23.03.2001|; г.Бобруйска УВД выдан №12345675 00

CAN_SPLIT=1; TS= МБФР; CLIENT_ACCOUNT=Торговый счет 276; CLIENT_SUB_ACC=subacc276_Q7;
DOC_COMMENT=Ставка согласно тарифному плану; EXPIREDAY=0; INTERNAL_NUMBER=211;

Поручение «Вывод ДС безналично (остаток)»:

ACTION=NEW_INSTR_TYPE_7; TRANS_ID=441; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;
AGREE_SERV=Дог.000|20070307|; VOLUME=0; SECCODE=RURSUR389;

BENEFACTOR=Тупик|Клиентов|Сергей|Сергеевич|540100000001|045004001|40801810000000000001|Брокер-Банк|31001810000000000001|005|;

CAN_SPLIT=1; LEFTOVER=Y; TS= МБФР; PAY_ASSIGN=п/п 50; CLIENT_ACCOUNT=Торговый счет 276;

CLIENT_SUB_ACC=subacc276_Q7; DOC_COMMENT=Ставкасогласнотарифному плану;EXPIREDAY=0; INTERNAL_NUMBER=32D1;

Поручение «Получение ЦБ в ДКК из реестра»:

ACTION=NEW_INSTR_TYPE_8; TRANS_ID=442; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;
QUANTITY=100; SECCODE=RURSUR389; REAL_SECCODE=EESR; REAL_CLASS=BQUOTE;
REAL_FIRM=NC0038900000; TS= МБФР; ACCOUNT=L01-00000F00; PLACE=ДКК;

DEPO_ACCOUNT=L01-00000F00|Брокеров И.И.|Ушкин У.У.|НРД|Дог.105|20070307|;

DEPO_ACC_TYPE=строка001; PUT_REASON=Основной договор; INSTR_REASON=Сделка; SEC_DEAL_CURR=Рубли;

SEC_DEAL_SUMM=100.51; PAYER_ACCOUNT=110110110110; CP=cp221; COUNTRY=RF; PHONE=8(383)2223322;

SEC_COMMENT=По заявлению клиента; SEC_DEPO_ID=i27d31; RESPONSIBLE=Ivanov.A.G.;
DOC_COMMENT= Ставка согласно тарифному плану;EXPIREDAY=0; INTERNAL_NUMBER=12/31;

Поручение «Поставка ЦБ из ДКК в реестр»:

ACTION=NEW_INSTR_TYPE_9; TRANS_ID=443; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;
QUANTITY=100; SECCODE=RURSUR389; REAL_SECCODE=EESR; REAL_CLASS=BQUOTE; REAL_FIRM=NC0038900000;

TS= МБФР; ACCOUNT=L01-00000F00; PLACE=ДКК; DEPO_ACCOUNT=L01-00000F00|Брокеров И.И.|Ушкин У.У.|НРД|Дог.105|20070307|;

DEPO_ACC_TYPE=Основной; PUT_REASON=Основной договор; INSTR_REASON=Сделка; SEC_DEAL_CURR=Доллары;

SEC_DEAL_SUMM=100.51; PAYER_ACCOUNT=110110110110; CP=cp221; COUNTRY=RF;

PHONE=8(383)2223322; SEC_COMMENT=По заявлению клиента; DOCUMENT=Паспорт; DOC_NUMBER=5000 1233232;

DOC_DATE=20000101; DOC_ISSUER=УВД Центрального района; SEC_CP_TYPE=Залогодержатель;

RESPONSIBLE=Ivanov.A.G.; DOC_COMMENT=Ставка согласно тарифному плану;EXPIREDAY=0;

INTERNAL_NUMBER=35/1; DEPO_PLACE=НРД;

Поручение «Получение ЦБ внутри НРД»:

ACTION=NEW_INSTR_TYPE_10; TRANS_ID=444; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;

QUANTITY=100; SECCODE=RURSUR389; REAL_SECCODE=EESR; REAL_CLASS=BQUOTE;

REAL_FIRM=NC0038900000; TS= МБФР; ACCOUNT=L01-00000F00; PLACE=НРД;

DEPO_ACCOUNT=L01-00000F00|Брокеров И.И.|Ушкин У.У.|НРД|Дог.105|20070307|; DEPO_ACC_TYPE=Основной;

PUT_REASON=Основной договор; INSTR_REASON= Сделка; SEC_DEAL_CURR=Доллары;

SEC_DEAL_SUMM=100.51; PAYER_ACCOUNT=110110110110; CP=cp221; COUNTRY=RF; DEPO_CP=cp777;
PHONE=8(383)2223322; SEC_COMMENT=По заявлению клиента; SEC_DEPO_ID=i27d31; SUBDEPO_CP=cp222;
DOC_COMMENT= Ставка согласно тарифному плану;EXPIREDAY=0; INTERNAL_NUMBER=203;

Поручение «Поставка ЦБ внутри НРД»:

ACTION=NEW_INSTR_TYPE_11; TRANS_ID=445; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;

QUANTITY=100; SECCODE=RURSUR389; REAL_SECCODE=EESR; REAL_CLASS=BQUOTE; REAL_FIRM=NC0038900000;

TS= МБФР; ACCOUNT=L01-00000F00; PLACE=НРД; DEPO_ACCOUNT=L01-00000F00|Брокеров И.И.|Ушкин У.У.|НРД|Дог.105|20070307|;

DEPO_ACC_TYPE=Основной; PUT_REASON=Основной договор ; INSTR_REASON=Сделка; SEC_DEAL_CURR=Доллары; SEC_DEAL_SUMM=100.51;
PAYER_ACCOUNT=110110110110; CP=cp221; COUNTRY=RF; DEPO_CP=cp777; PHONE=8(383)2223322;
SEC_COMMENT=По заявлению клиента; SEC_DEPO_ID=i27d31; SUBDEPO_CP=cp222;
DOC_COMMENT=Ставка согласно тарифному плану;EXPIREDAY=0; INTERNAL_NUMBER=100/01;
DEPO_PLACE=НРД;

Поручение «Получение ЦБ внутри ДКК»:

ACTION=NEW_INSTR_TYPE_12; TRANS_ID=446; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;
QUANTITY=100; SECCODE=RURSUR389; REAL_SECCODE=EESR; REAL_CLASS=BQUOTE; REAL_FIRM=NC0038900000;
TS=МБФР; ACCOUNT=L01-00000F00; PLACE=ДКК; DEPO_ACCOUNT=L01-00000F00|Брокеров И.И.|Ушкин У.У.|НДЦ|Дог.105|20070307|;
DEPO_ACC_TYPE=Основной; PUT_REASON=Основной договор ; INSTR_REASON=Сделка;
SEC_DEAL_CURR=Доллары; SEC_DEAL_SUMM=100.51; PAYER_ACCOUNT=110110110110;
CP=cp221; COUNTRY=RF; DEPO_CP=cp777; PHONE=8(383)2223322;
SEC_COMMENT=По заявлению клиента 8; DOC_COMMENT=Ставка согласно тарифному плану;EXPIREDAY=0; INTERNAL_NUMBER=55-01;

Поручение «Поставка ЦБ внутри ДКК»:

ACTION=NEW_INSTR_TYPE_13; TRANS_ID=447; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;
QUANTITY=100; SECCODE=RURSUR389; REAL_SECCODE=EESR; REAL_CLASS=BQUOTE; REAL_FIRM=NC0038900000;
TS=МБФР; ACCOUNT=L01-00000F00; PLACE=ДКК; DEPO_ACCOUNT=L01-00000F00|Брокеров И.И.|Ушкин У.У.|НРД|Дог.105|20070307|;
DEPO_ACC_TYPE=Основной; PUT_REASON=Основной договор ; INSTR_REASON=Сделка; SEC_DEAL_CURR=Доллары;
SEC_DEAL_SUMM=100.51; PAYER_ACCOUNT=110110110110; CP=cp221; COUNTRY=RF; DEPO_CP=123;
SEC_DEAL_DATE=20090401; SEC_PAY_DATE=20090401; PHONE=8(383)2223322;
SEC_COMMENT=По заявлению клиента; DOC_COMMENT=Ставка согласно тарифному плану;EXPIREDAY=0;

INTERNAL_NUMBER=016-01; DEPO_PLACE=ДКК;

Поручение «Получение ЦБ в НРД из реестра»:

ACTION=NEW_INSTR_TYPE_14; TRANS_ID=448; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;
QUANTITY=100; SECCODE=RURSUR389; REAL_SECCODE=EESR; REAL_CLASS=BQUOTE;
REAL_FIRM=NC0038900000; TS= МБФР; ACCOUNT=L01-00000F00; PLACE=НРД; DEPO_ACCOUNT=L01-00000F00|Брокеров И.И.|Ушкин У.У.|НРД|Дог.105|20070307|;
DEPO_ACC_TYPE=Основной; PUT_REASON=Основной договор; INSTR_REASON=Сделка;
SEC_DEAL_CURR=Доллары; SEC_DEAL_SUMM=100.51; PAYER_ACCOUNT=110110110110;
CP=cp221; COUNTRY=RF; PHONE=8(383)2223322; SEC_COMMENT=По заявлению клиента;
SEC_DEPO_ID=i27d31; RESPONSIBLE=Ivanov.A.G.; DOC_COMMENT=Ставка согласнотарифному плану;EXPIREDAY=0; INTERNAL_NUMBER=103/1;

Поручение «Поставка ЦБ из НРД в реестр»:

ACTION=NEW_INSTR_TYPE_15; TRANS_ID=449; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;
QUANTITY=100; SECCODE=RURSUR389; REAL_SECCODE=EESR; REAL_CLASS=BQUOTE; REAL_FIRM=NC0038900000;
TS= МБФР; ACCOUNT=L01-00000F00; PLACE=НРД; DEPO_ACCOUNT=L01-00000F00|Брокеров И.И.|Ушкин У.У.|НРД|Дог.105|20070307|;
DEPO_ACC_TYPE=Основной; PUT_REASON=Основной договор; INSTR_REASON=Сделка; SEC_DEAL_CURR=Доллары;
SEC_DEAL_SUMM=100.51; PAYER_ACCOUNT=110110110110; CP=cp221; COUNTRY=RF; PHONE=8(383)2223322;
SEC_COMMENT=По заявлению клиента; DOCUMENT=Паспорт; DOC_NUMBER=5000 1233232; DOC_DATE=20000101;
DOC_ISSUER=УВД Центрального района; SEC_CP_TYPE=Залогодержатель; RESPONSIBLE=Ivanov.A.G.;
DOC_COMMENT=Ставка согласно тарифному плану;EXPIREDAY=0; INTERNAL_NUMBER=12332/001; SSI_ACCOUNT_ID=А0001;

DEPO_PLACE=НРД;

Поручение «Конвертация валют»:

ACTION=NEW_INSTR_TYPE_16; TRANS_ID=450; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;
AGREE_SERV=Дог.000|20070307|; VOLUME=100.51; SECCODE=RURSUR389; SECCODE_CP=RUREUR389;
DOC_COMMENT=  Ставка согласнотарифномуплану;EXPIREDAY=20100228;INTERNAL_NUMBER=44K;

Поручение «Свободная форма»:

ACTION=NEW_INSTR_TYPE_17; TRANS_ID=451; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;
DOC_COMMENT=Ставка согласно тарифному плану; COMMON_TEXT=Это текст поручения свободного типа.;EXPIREDAY=20100228;

Поручение «Конвертация ЦБ»:

ACTION=NEW_INSTR_TYPE_18; TRANS_ID=452; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;
QUANTITY=10; SECCODE=RURSUR389; REAL_SECCODE=EESR; REAL_CLASS=BQUOTE; REAL_FIRM=NC0038900000;
ACCOUNT=L01-00000F00; ACCOUNT_CP=L01-00000F00; DEPO_ACCOUNT=L01-00000F00|Брокеров И.И.|Ушкин У.У.|НРД|Дог.105|20070307|;
CLASSCODE_OUT=BQUOTE; SECCODE_OUT=LKOH; FIRM_OUT=NC0038900000; QUANTITY_OUT=15;
DOC_COMMENT=Ставка согласно тарифному плану;EXPIREDAY=0; INTERNAL_NUMBER=123;

Поручение «Размещение ЦБ»:

ACTION=NEW_INSTR_TYPE_19; TRANS_ID=453; CLASSCODE=INSTR; INSTR_RATE=1; CLIENT_CODE=Q7;
AGREE_SERV=Дог.000|20070307|; VOLUME=100.51; SECCODE=RURSUR389; TS= МБФР; CLIENT_ACCOUNT=Торговый счет 276;
CLIENT_SUB_ACC=subacc276_Q7; DISTR_SECCODE=IRGZ; DISTR_DATE=20090101; WANTED_QTY=100;
WANTED_PRICE=100; DISTR_INFO=Минимальная цена не может быть меньше 100;EXPIREDAY=20100228;


Импорт поручений из файла (отмена поручений)

  • Пример строки в файле транзакций
    •

    Рабочее место QUIK позволяет отменять неторговые поручения с помощью импорта через файл. При импорте поручений считывается строка с транзакцией на отмену неторгового поручения из .tri-файла, заданная в универсальном формате. Каждая строка обрабатывается независимо. Если строка разобрана успешно, то Рабочее место QUIK отправляет на сервер транзакцию. Отмененное поручение обрабатывается точно так же, как и поручение, отмененное через форму ввода. Если транзакцию обработать не удалось, то сообщение об ошибке будет выведено в окне сообщений.

    При отправке транзакций все поля передаются как указаны в файле. Исключение составляют поля, которые содержат ссылку на запись в справочнике. В этом случае производится поиск записи по ключевому полю. Если запись будет найдена, то используется именно она. Если запись в справочнике обнаружить не удалось, то поле заполняется исходя из введенных вручную сведений.

    Описание процедуры импорта через файл в универсальном формате см. в Импорт транзакций.


Пример строки в файле транзакций

Отмена поручения с номером 1000:

CLASSCODE=INSTR; ACTION=Запрос на отмену поручения; Код клиента=E2; Номер поручения=1000; Запрос на отмену=Комментарий;


Отчеты

Отчеты - это представление итогов операций клиента за определенный период в форме, предусмотренной брокером.

Данный раздел описывает стандартные формы отчетов, поставляемый разработчиком системы QUIK. Вид и содержание отчетов у конкретного брокера могут отличаться от приведенных примеров.

Сервис запроса отчетов брокера с Рабочего места QUIK является дополнительной возможностью системы QUIK. Данная возможность появляется на сервере после установки Модуля формирования отчетов.

Для использования отчетов на Рабочем месте клиента, необходимо, чтобы:

  • данному пользователю был открыт доступ к отчетам на сервере QUIK;
  • в папке с программами QUIK находился файл REPORTS.DLL;
  • в списке принимаемых классов должен быть включен класс Отчеты.

При соблюдении перечисленных условий в меню программы появится пункт «Отчеты».

Принцип работы

  1. Для получения отчета выберите в меню программы пункт «Расширения / Отчеты» и в нем выберите требуемый тип отчета.

  2. В открывшемся окне выберите:
    • «Код клиента».
    • «Начало периода» и «Конец периода» – даты начала и конца периода формирования отчета. Для отчета по портфелю клиента указывается одна дата.
    • «Фильтрация по сложности инструмента» – настройка фильтра отображения сделок в отчете по типу сложности инструмента:
      • «Отключена» – в отчете отображаются все сделки;
      • «Все с присвоенной сложностью фин. инструмента» – в отчете отображаются только те сделки, инструменты которых имеют тип сложности;
      • «По указанному типу сложного фин. инструмента» – в отчете отображаются только те сделки, инструменты которых имеют заданный в поле «Сложность финансового инструмента» тип.
    • «Сложность финансового инструмента» – тип сложности финансового инструмента (например: «0», «4», «800» и т.д.).

    3. Затем нажмите кнопку «Выполнить». Запрос будет передан на сервер.

  3. При получении отчета на экране откроется окно для его просмотра. В окне сообщений так же появится уведомление о времени получения отчета. Каждый полученный отчет открывается в новом окне.
  4. Полученный отчет можно скопировать в буфер обмена, отправить на печать, сохранить в виде файла формата HTML, а так же сохранить в виде HTML-файла с расширением .xls. Эти действия выполняются из контекстного меню окна просмотра отчета.
  5. Если в полученном отчете показаны пустые таблицы или «Нет данных», это означает, что за указанный период операций произведено не было.

См. также:

  • Отчет по портфелю клиента
  • Отчет по всем сделкам клиента
  • Отчет по всем стоп-заявкам клиента
  • Отчет по всем сделкам всех клиентов
  • Отчет по всем заявкам клиента
  • Отчет по отправленным файлам
  • Отчет по неторговым поручениям клиента
  • Отчет по одному неторговому поручению
  • Отчет по адресным заявкам клиента
  • Отчет по позициям на срочном рынке ФОРТС
  • Отправка клиентам произвольных файлов


Отчет по портфелю клиента

меню Отчеты / Отчёт по портфелю клиента

Отчет отражает состояние средств клиента на указанный день.

Отчет состоит из трех таблиц. В первой таблице приведено количество инструментов, во второй таблице – информация о денежных средствах, а в третьей таблице совокупная оценка инструментов на начало дня и на конец дня. Валюта, в которой указываются итоговые значения, задается в БО Модуля.

Отчет содержит следующие параметры:

  • «Остаток входящий» - состояние счета на начало торгового дня;
  • «Остаток исходящий» - состояние счета на конец торгового дня;
  • «Оценка входящая» - стоимость инструментов на начало торгового дня;
  • «Оценка исходящая» - стоимость инструментов по итогам всех сделок на конец торгового дня.

Пример отчета:

См. также Отчеты.


Отчет по всем сделкам клиента

меню Расширения / Отчеты / Отчет по всем сделкам клиента

В отчете отражаются все сделки, заключенные клиентом за указанный период времени. Также отчет содержит дополнительные параметры:

Некоторые параметры отображаются в отчете при определенных настройках Модуля формирования отчетов в файле Trades.ini, см. примечание к соответствующим настройкам.

  • «Рынок» – наименование рынка, если он задан для класса инструментов.
    Параметр «Рынок» отображается, если ShowMarket=1 в секции [DialogParams].
  • «Валюта» – валюта котирования инструмента.
  • *«Комиссия брокера» - величина комиссионного вознаграждения брокера.
  • *«Валюта» – валюта сделки.
    (*) Параметры «Комиссия брокера» и «Валюта» отображаются, если ShowFaceUnit=1 в секции [DialogParams] и заполнена секция [ShowBrokerComis].
  • «Суммарная комиссия ТС» – величина комиссионного вознаграждения торговой системы.
    Параметр «Суммарная комиссия ТС» отображается, если ShowTSComis=1 и TotalComisTS=1 в секции [DialogParams].
  • ** «Комиссия за ИТС» - комиссионное вознаграждение Московской Биржи по договорам о предоставлении интегрированного технологического сервиса (ИТС).
  • ** «Комиссию за организацию торговли» - комиссионное вознаграждение, которое взимается в пользу организатора торговли.
  • ** «Клиринговая комиссия» - процент клиринговой комиссии по умолчанию, взимаемой биржей при расчетах по сделкам для всех классов инструментов (режимов торгов), за исключением тех, для которых он задан явно в секции «Настройки комиссионного вознаграждения по режимам торгов».
    (**) Параметры «Комиссия за ИТС», «Комиссия за организацию торговли», «Клиринговая комиссия» отображаются, если ShowTSComis=1 и TotalComisTS=0 в секции [DialogParams].
  • «Валюта» – валюта расчетов сделки.
    Параметр «Валюта» отображается, если ShowTSComis=1 и ShowFaceUnit=1 в секции [DialogParams].
  • «Дата расчетов» - дата проведения расчетов по сделке.
  • «Уровень маржи» - уровень маржи, рассчитанный на момент заключения сделки.
  • ***«Стоимость портфеля» – значение стоимости портфеля.
  • ***«Мин. маржа» – минимальная маржа. Если величина больше, чем 1025, то отображается значение «INF»
  • *** «Нач. маржа» – начальная маржа.
  • ***«Скор. Маржа» – скорректированная маржа.
    (***) Параметры «Стоимость портфеля», «Мин. маржа», «Нач. маржа», «Скор. Маржа» отображаются, если ShowDiscountParams=1 в секции [DialogParams].
  • «УДС» – уровень достаточности средств.
    Параметр «УДС» отображается, если ShowFundsLevel=1 в секции [DialogParams].
  • «ID пользователя» – UID пользователя, подавшего заявку.
  • «Сложность финансового инструмента» – тип сложного финансового продукта. Столбец отображается, если в настройках отчета в фильтре «Фильтрация по сложности инструмента» выбрано значение «Все с присвоенной сложностью фин. инструмента» или «По указанному типу сложного фин. инструмента».

Пример отчета:

См. также Отчеты.


Отчет по всем стоп-заявкам клиента

Отчет отображает все стоп-заявки, поданные клиентом в указанный период.

Пример отчета:

Руководство пользователя QUIK © ARQA Technologies / www.arqatech.com/ru/products/quik/


Отчет по всем сделкам всех клиентов

меню Расширения / Отчеты / Отчет по всем сделкам всех клиентов

В отчете отражаются все сделки клиентов одной группы за указанный промежуток времени.

Пример отчета:

Руководство пользователя QUIK © ARQA Technologies / www.arqatech.com/ru/products/quik/


Отчет по всем заявкам клиента

меню Расширения / Отчеты / Отчёт по всем заявкам клиента

Отчет отражает состояние клиентских заявок за указанный период и суммарную оценку денежных средств, которые потребовались для их регистрации или исполнения.

Пример отчета:

Руководство пользователя QUIK © ARQA Technologies / www.arqatech.com/ru/products/quik/


Отчет по отправленным файлам

меню Расширения / Отчеты / Отчет по отправленным файлам

Отчет отражает информацию о том, какие файлы были отправлены клиенту, а также о файлах, полученных / подписанных клиентом.

Пример отчета:

Руководство пользователя QUIK © ARQA Technologies / www.arqatech.com/ru/products/quik/


Отчет по неторговым поручениям клиента

меню Расширения / Отчеты / Отчет по неторговым поручениям клиента

Отчет содержит перечень всех принятых неторговых поручений клиента по вводу, выводу или переводу средств между счетами за указанный период.

Отчет может содержать не только поручения по коду клиента отправителя, но и по коду клиента получателя, если при его формировании включена опция «Учет получателей».

В первой таблице приведен список поручений на операции с денежными средствами, во второй таблице – с ценными бумагами, третья таблица содержит список поручений свободного вида.

Пример отчета:

См. также Отчеты.


Отчет по одному неторговому поручению

меню Расширения / Отчеты / Отчет по одному неторговому поручению

Отчет формируется по указанному номеру неторгового поручения и содержит перечень пара-метров неторгового поручения, заданных в шаблоне. Права на формирование «Отчёта по одному неторговому поручению» имеют пользователи с правами Клиента и Менеджера. При этом пользователям с правами Клиента, помимо номера неторгового поручения, необходимо указать код клиента.

Пример отчета:

См. также Отчеты.


Отчет по адресным заявкам клиента

меню Расширения / Отчеты / Отчёт по адресным заявкам клиента

Отчет отражает состояние адресных заявок клиента за указанный период и суммарную оценку денежных средств, которые потребовались для их регистрации или исполнения.

Пример отчета:

См. также Отчеты.


Отчет по позициям на срочном рынке Московской Биржи

меню Расширения / Отчеты / Отчет по позициям на срочном рынке ФОРТС

Отчет отражает позиции и ограничения клиента на срочном рынке Московской Биржи на указанную дату.

Пример отчета:

Отчет состоит из следующих таблиц:

  • позиции по счетам на конец дня;
  • ограничения по клиентским счетам (все сессии);
  • таблицы «Единая денежная позиция».

Параметры таблиц отчета аналогичны параметрам Таблицы позиций по клиентским счетам, Таблицы ограничений по клиентским счетам, таблицы «Позиции по деньгам».

См. также Отчеты.


Получение файлов от брокера и их подтверждение

  • Назначение
  • Принятые файлы
  • Просмотр файлов
  • Подтверждение файлов
  • Получение файлов

    • Назначение

    Брокер имеет возможность передать клиенту какие-либо файлы, например, подготовленные им отчеты. Файлы могут содержать электронную цифровую подпись (ЭЦП) отправителя. Достоверность ЭЦП проверяется автоматически при приеме файлов. В зависимости от настроек Модуля формирования отчетов у брокера, клиент может подтвердить файл с помощью ЭЦП, если это предписано регламентом брокерского обслуживания, подтвердить файл без подписи (в случае отсутствия настроенного криптопровайдера) или подтвердить одноразовым паролем. Факты получения и подтверждения файлов клиентом регистрируются сервером QUIK.

    Принятые файлы

    меню Расширения / Отчеты / Принятые файлы...

    Прием файлов производится автоматически при соединении программы QUIK с сервером. Получение файлов сопровождается появлением в программе QUIK формы, показанной на рисунке. Если брокер отправил клиенту одновременно файлы, подписанные электронной цифровой подписью и не подписанные, то все принятые файлы разделятся на две части и отобразятся в разных окнах. При необходимости, окно с перечнем принятых файлов можно открыть вручную через пункт меню Расширения / Отчеты / Принятые файлы....

    В окне «Принятые файлы» содержится следующая информация:

    1. «Принято файлов» – количество полученных файлов.
    2. «Папка» – путь к стандартному каталогу для ведения архива полученных файлов. Файлы с электронной цифровой подписью сохраняются в папку ReportsSigned, файлы без подписи – в папку Reports в том каталоге, где установлено Рабочее место QUIK.
    3. «Открыть папку…» – открытие окна с каталогом, в который сохраняются принятые файлы, полученные от отправителя.
    4. В таблице с полученными файлами каждая строка соответствует отдельному принятому файлу. В столбцах отображаются следующие параметры:

      Параметр | Назначение
      Файл | Имя файла
      Подпись отправителя
      • «Да» - файл подписан отправителем;
      • «Нет» - файл не подписан (в этом случае последующие поля не заполняются)
      Статус подписи отправителя
      • «Да» - подпись верна;
      • «Нет» - подпись не верна (в этом случае последующие поля не заполняются)
      Владелец сертификата | Наименование владельца сертификата
      УЦ сертификата | Наименование учетного центра, которым был выдан сертификат
      Серийный номер сертификата | Номер выданного сертификата
      Ошибка | Сообщение об ошибке
      Подтвержден | «Да» – файл подтвержден пользователем, иначе не заполняется

    5. «Выбрать всё» – выделить все принятые файлы в таблице. Доступно при наличии в таблице файлов, которые требуют подтверждения и для которых применим способ подтверждения с помощью «ЭЦП» или «Без подписи».
      Принятые файлы, для которых применим способ подтверждения с помощью одноразового пароля, выбираются только по одному.
    6. «Снять выделение» – снять выделение с выбранных файлов.
    7. Кнопка «Открыть файл» – просмотр полученного файла. Доступно при выборе только одного файла.
    8. Кнопка «Сохранить как…» – сохранить файл в выбранный каталог. Доступно при выборе только одного файла, и если выбранный файл получен в текущем сеансе работы.

    При нажатии на кнопку [image] открывается окно редактирования таблицы принятых файлов, в котором настраивается отображение необходимых столбцов.

    Просмотр файлов

    Полученные файлы можно открыть для просмотра, нажав кнопку «Открыть файл» в нижней части окна. Файл открывается во внешней программе (например, MS Excel), которая должна быть предварительно установлена на компьютере пользователя.

    Файлы сохраняются в стандартный каталог, который служит только для ведения архива полученных файлов, поэтому при открытии файла открывается его копия во временном каталоге, а сам файл остаётся без изменений в стандартном каталоге. При необходимости файл сохраняется пользователем в другой каталог, нажатием на кнопку «Сохранить как…».

    Подтверждение файлов

    При приеме клиентом файлов выбирается доступный способ подтверждения, соответствующий полученному файлу. В зависимости от настроек Модуля формирования отчетов можно выбрать следующие способы подтверждения файлов в поле со списком «Подтвердить получение»:

    • «ЭЦП» – подтвердить выбранный файл с помощью электронной цифровой подписи (ЭЦП).
    • «Без подписи» – подтвердить выбранный файл.
    • «Пароль» – подтвердить выбранный файл одноразовым паролем. Для запроса одноразового пароля у Модуля формирования отчетов нажмите кнопку «Получить пароль по SMS». Полученный пароль вводится в поле слева. Поле становится активным только после получения пароля и появляется надпись «Введите пароль». Количество попыток получения и количество попыток ввода одноразового пароля настраиваются администратором Модуля формирования отчетов. После исчерпания максимального количества попыток ввода одноразового пароля возможность подтверждения файла через одноразовые пароли блокируется. Допускается ввод любого из полученных одноразовых паролей (как самого первого, так и запрошенных повторно для данного файла).

    Для подтверждения выбранного файла нажмите кнопку «Подтвердить».

    При выборе уже подтверждённого файла поле со списком «Подтвердить получение» недоступно.

    Формирование ЭЦП выполняется внешней программой, которая должна быть установлена на компьютере пользователя. За консультациями по получению и установке данной программы обратитесь к своему брокеру.

    Сформированная ЭЦП регистрируется на сервере брокера. Результат выполнения операции отображается в столбце «Подтвержден» окна «Принятые файлы» и в «Окне сообщений».

    Файлы, принятые пользователем, могут быть отозваны брокером, при условии, что они не подтверждены клиентом. Для отзыва неподписанных файлов клиенту нужно связаться со своим брокером. После выполнения этой процедуры файл удаляется из списка принятых файлов.

    Для подтверждения файла (любым способом) необходимо наличие соединения с сервером.

    Получение файлов

    меню Расширения / Отчеты / Получение файлов...

    Если в Модуле формирования отчетов включена настройка «Оповещать о новых файлах», то прием файлов производится как в момент соединения программы QUIK с сервером, так и позже, по мере поступления новых файлов. Получение новых файлов в текущем сеансе работы обозначается системным уведомлением и в меню Отчеты появляется новый пункт Получение файлов.

    В таблице с полученными файлами каждая строка соответствует отдельному принятому файлу. В столбцах отображаются следующие параметры:

    Параметр | Назначение
Имя файла | Имя файла
Размер | Размер файла

    Нажав кнопку «Принять файлы», открывается окно «Принятые файлы», в котором отображаются все вновь принятые файлы из списка. После принятия новых файлов пункт меню Получение файлов пропадает из меню Отчеты.


Отправка отчета при аварийном завершении работы

При аварийном завершении работы Рабочего места QUIK доступно формирование отчета для выявления проблемы, вызвавшей завершение работы.

В момент завершения работы на экране отображается сообщение с возможностью выбора действия:

  1. При нажатии на кнопку «Сформировать отчет» формируется zip-архив, содержащий дамп процесса. Если программа была запущена с ключом -full-dump, то будет получен полный дамп процесса, иначе – мини-дамп. После создания архива открывается окно проводника, где указан путь до подкаталога \dmp в текущем рабочем каталоге программы. Скопируйте путь до архива и отправьте его вместе с zip-архивом на адрес Службы технической поддержки QUIK: quiksupport@arqatech.com.

  2. При нажатии на ссылку «quiksupport@arqatech.com» также формируется zip-архив. Если размер сформированного архива не превышает 5 МБ, то откроется бланк письма, в котором автоматически добавлен архив во вложении. Если почтовый клиент не настроен или письмо не открывается, то отображается сообщение об ошибке:

    Если размер полученного архива превышает 5 МБ, отображается соответствующее сообщение:

    При нажатии на кнопку «ОК» открывается бланк письма без вложения. Укажите в письме ссылку на внешнее местоположение архива. Если почтовый клиент не настроен или не открывается письмо, то отображается сообщение об ошибке (см. выше).

  3. При нажатии на кнопку «Перезапустить QUIK» перезапуск производится с ключом -clear без формирования отчета.

    Если аварийное завершение программы возникло при загрузке WND-файла, то файл автоматически включается в архив с отчетом и при нажатии на кнопку «Перезапустить QUIK» открывается окно с выбором действий:

    После нажатия на кнопку «ОК» программа будет перезапущена в соответствии с выбранным действием.

    Если в директории WNDSAV нет файла *.WND и в рабочем каталоге нет файла с именем файла настроек и с расширением SAV.WND, то первый пункт скрывается и по умолчанию выбирается «Пропустить загрузку текущего файла оконной конфигурации»:


Инвестиционные идеи

  • Таблица инвестиционных идей
  • Описание инвестиционной идеи
  • Ввод заявки
  • Вкладка инвестиционных идей

    • Дополнительный функционал Инвестиционных идей позволяют брокеру транслировать клиентам аналитическую информацию, а клиентам в полуавтоматическом режиме совершать операции, опираясь на полученные рекомендации.

    Возможности:

    • Брокер или инвестиционная компания, желающая продать подписку на инвестиционные рекомендации своим клиентам, или для повышения их лояльности, может использовать сервис инвестиционных идей для регулярной публикации идей в Рабочем месте QUIK с заданными параметрами инвестирования.
    • Трейдер, планирующий совершать долгосрочные или среднесрочные инвестиции, подключив подписку на инвестиционные идеи у брокера, может просматривать рекомендации с подробной аналитической и статистической информацией в Рабочем месте QUIK и подавать заявки, формирующиеся на основе заданных брокером рекомендаций.


Таблица инвестиционных идей

меню Расширения / Инвестиционные идеи / Таблица идей или кнопка
Если все идеи в таблице прочитаны, то кнопка меняет вид на [image].
  • Назначение
  • Формат таблицы
  • Доступные функции

    • Назначение

    Просмотр доступных (активных и закрытых) инвестиционных идей. Записи таблицы используются для быстрого просмотра и сортировки идей по параметрам.

    Формат таблицы

    Количество отображаемых идей регулируется администратором или пользователем с помощью стандартных табличных фильтров.

    По умолчанию идеи в таблице отсортированы по времени последнего изменения идеи.

    В столбцах таблицы отображаются следующие параметры:

    Параметр | Назначение
    *Идея | Наименование инвестиционной идеи
    *Статус Состояние исполнения идеи:
    • «Активна» – действующая идея с незавершенным сроком инвестирования. Активные идеи с назначенной ценой выхода предлагают совершить обратную операцию по продаже/покупке активов (выход из идеи);
    • «Закрыта» – идея с прошедшим сроком инвестирования (статус устанавливается на следующий день после дня окончания инвестирования);
    • «Закрыта аналитиком» – идея закрыта аналитиком брокера
    *Инструмент | Код инструмента инвестиционной идеи. Для идей типа «Аналитический обзор» может быть задано несколько кодов через запятую
    *Опубликована | Дата публикации идеи
    *Обновлена | Дата внесения изменений в параметры идеи
    *Направление Направление операции. Возможные значения:
    • «Продавать»;
    • «Покупать».
    Для идеи типа «Аналитический обзор» поле не заполняется
    *Тип Тип идеи. Возможные значения:
    • «Торговая идея»;
    • «Аналитический обзор»
    *Аналитик | Наименование компании
    *Срок | Период инвестирования (в неделях/месяцах/годах). Если срок не указан, то автоматически отображается «1 год»
    *Рекомендуемая доля в портфеле,% | Рекомендуемый брокером объем сделки, в процентах. Задается брокером
    *Доходность прогнозируемая, % | Предполагаемая доходность идеи, в процентах. Задается брокером
    Последняя сделка | Цена последней совершенной сделки по инструменту в денежном выражении (для облигаций в процентах). Для идей типа «Аналитический обзор» не рассчитывается
    Измен. к закр. | Разница между ценой последней сделки и ценой закрытия, в денежном выражении (для облигаций в процентах). Для идей типа «Аналитический обзор» не рассчитывается
    Текущая доходность, % | Текущая доходность, приведенная к периоду инвестирования (то есть проценты за период от публикации идеи и до конца срока инвестирования). Рассчитывается как отношение разницы между текущей ценой последней сделки и ценой входа (если она не задана, то ценой на момент публикации) к цене входа (цене на момент публикации). Для идей типа «Аналитический обзор» не рассчитывается
    Рекомендуемая цена открытия | Рекомендуемая цена входа в идею. Если не указана, то значение параметра «Цена при публикации». Задается брокером
    Цена выхода | Рекомендуемая цена выхода из идеи. Рассчитывается брокером на основе указанной доходности и цены открытия, либо текущей цены на дату публикации (параметр «Цена при закрытии»)
    Стоп-лосс по цене, в % | Рекомендация закрыть с убытком, если цена >=, или <=. Параметр отображается для информации
    Идентификатор | Идентификатор инвестиционной идеи

    * — поля отображаются в таблице по умолчанию. Весь набор доступных полей можно добавить в диалоге настройки таблицы

    Доступные функции

    К таблице может быть применен Режим связанных окон, в котором таблица инвестиционных идей выступает в качестве основной таблицы, и с ней могут быть связаны окна с описанием идей и следующие таблицы:

    • Таблица заявок;
    • Таблица сделок;
    • Таблица обезличенных сделок;
    • Таблица стоп-заявок;
    • Таблица котировок;
    • Графики.

    Из контекстного меню таблицы доступны следующие функции:

    • «Описание идеи» (или двойное нажатие левой кнопки мыши на строке таблицы) – открыть окно с описанием идеи. Можно открыть несколько окон с описанием идей. Открытые идеи помечаются в таблице как прочитанные.
    • «Отметить все как прочитанные» – отметить все инвестиционные идеи в таблице как прочитанные.

    Дополнительно:

    • Описание стандартных функций контекстного меню для таблиц.
    • Полный список управляющих клавиш для всех типов таблиц.

    См. также Настройка таблицы.


Настройка таблицы

Значение полей диалога настройки таблицы:

  1. «Имя таблицы» – изменение названия таблицы, присвоенного по умолчанию.
  2. «Набор параметров» – выбор отображаемых параметров и настройка их очередности.

Редактирование таблицы завершается нажатием на кнопку «ОК».

См. также Таблица инвестиционных идей.


Описание инвестиционной идеи

Открытие окна описания инвестиционной идеи осуществляется из таблицы «Инвестиционные идеи» выбором пункта контекстного меню «Описание идеи».

В верхней части окна отображается история изменения идеи (изменение параметров, закрытие идеи по достижении цели или закрытие идеи аналитиком) с указанием даты изменения.

Набор отображаемых параметров в окне идеи:

  • Неизменяемые параметры, заданные брокером.
  • Динамическая информация, формируемая системой QUIK (описание параметров приведено в «Формат таблицы»).

Дополнительно в окне отображаются следующие параметры:

  • Логотип – логотип компании / инструмента. Если логотип не загружен, то отображается название актива.
  • «Доходность, %» – фактическая доходность инвестиционной идеи в процентах. Отображается только для закрытых идей.
  • «Код клиента» – выбор кода клиента. Поле не отображается для идей типа «Аналитический обзор». Если код клиента выбран, то ниже поля информационно отображается расчет доли в портфеле по выбранному коду клиента в валюте и в процентах. Расчет доли в портфеле не отображается, если данный параметр не задан брокером в описании идеи.
  • Кнопки действия – действия, выполняемые с идеей. Кнопки не отображаются для идей типа «Аналитический обзор». В зависимости от типа и статуса идеи отображается разный набор кнопок:
    • «Покупать» или «Продавать» — открыть форму ввода заявки по выбранному инструменту с заданным направлением. Для закрытых идей кнопка недоступна;
    • «Выйти из идеи» — открыть окно ввода заявки по инструменту с обратным направлением сделки, на весь текущий объем активов по инструменту и выбранному коду клиента. Активность кнопки не зависит от статуса идеи. Если идея на покупку, а у клиента нет положительной позиции по соответствующему инструменту, то кнопка «Выйти из идеи» становится недоступной. Аналогично для идей на продажу в случае отсутствия отрицательной позиции;
    • «Новая идея» — переход на идею, связанную с текущей идеей. Кнопка отображается, если связанная идея существует.
  • Описание идеи – текстовое описание идеи.
  • «Полный обзор» – ссылка для просмотра или скачивания полной версии описания идеи в PDF-формате или ссылка на страницу сайта.
Для открытия таблицы «Текущие торги» с инструментом идеи необходимо дважды нажать левой кнопкой мыши на логотип или код инструмента. Функционал недоступен для идей типа «Аналитический обзор».

См. также Таблица инвестиционных идей.


Ввод заявки

Форма ввода заявки вызывается из окна описания инвестиционной идеи нажатием на кнопку «Покупать» / «Продавать» в зависимости от направления операции.

Ниже перечислены параметры, которые заполняются автоматически в зависимости от заданных параметров идеи:

  1. «Инструмент» – инструмент выбранной идеи.
  2. «Покупка» / «Продажа» – направление операции.
  3. «Цена» – цена заявки за одну единицу инструмента. Цена берется из рекомендуемой цены открытия идеи, а если она не указана, то из цены встречного предложения.
  4. «Кол-во» – количество инструментов, выраженное в лотах. Рассчитывается из объема сделки и цены. Количество инструментов в одном лоте указано в скобках.
  5. «Код клиента» – идентификатор клиента, заданный в основных настройках клиентского места или выбранный в окне описания идеи.
  6. «Объем и комиссия» – объем сделки, если брокером указана рекомендуемая доля в портфеле в параметрах идеи. Рассчитывается по выбранному в заявке коду клиента, исходя из доступных на счету средств в соответствии с направлением заявки. Сумма брокерской комиссии рассчитывается автоматически в соответствии с установленным алгоритмом и выводится в поле справа.

Более подробное описание формы ввода заявки приведено в Разделе 5 «Торговые операции клиента».

См. также Описание инвестиционной идеи.


Вкладка инвестиционных идей

меню Расширения / Инвестиционные идеи / Создать вкладку
Пункт меню «Создать вкладку» недоступен, если в таблице «Инвестиционные идеи» нет записей или содержатся только идеи типа «Аналитический обзор».
  • Назначение
  • Формат вкладки

    • Назначение

    Вкладка предназначена для просмотра доступных окон и таблиц, которые можно использовать для работы с инвестиционной идеей.

    Формат вкладки

    На вкладке в произвольном порядке размещаются следующие окна и таблицы:

    • Таблица «Инвестиционные идеи» с первой по списку выбранной идеей;
    • Окно описания выбранной инвестиционной идеи;
    • Таблица «Позиции по инструменту»;
    • Таблица котировок по инструменту из выбранной идеи;
    • График цены и объема с интервалом в 5 минут;
    • Таблица заявок, отфильтрованная по инструменту;
    • Таблица сделок, отфильтрованная по инструменту.

    Пользователь может связать нужные ему окна с таблицей инвестиционных идей и просматривать все данные по выбранной инвестиционной идее в рамках одной вкладки. При необходимости данный набор окон может быть изменен. Можно добавить в набор таблицы стоп-заявок, состояния счета или информации по инструменту или несколько окон графиков с различными интервалами.

    См. также Таблица инвестиционных идей.


Раздел 10. Форматы сохранения таблиц в текстовый файл

  • Таблица текущих торгов
  • Таблица истории значений параметров
  • Таблица обезличенных сделок
  • Новости
  • Окно сообщений Трейдера
  • Таблица заявок
  • Таблица стоп-заявок
  • Таблица сделок
  • Таблица позиций участника по деньгам
  • Таблица заявок на внебиржевые сделки
  • Таблица безадресных заявок на внебиржевые сделки
  • Таблица сделок для исполнения
  • Таблица заявок-отчетов на сделки РПС
  • Таблица участников торгов


Таблица текущих торгов

Вывод в текстовый файл осуществляется выбором в таблице пункта контекстного меню «Сохранить в файл». В текстовый файл данные записываются строками в том порядке, в котором они указаны в таблице.

Файл представляет последовательность строк, каждая из которых содержит данные по отдельному финансовому инструменту, разделенные через запятую без пробелов. При этом последовательность параметров в строке соответствует последовательности параметров, отображаемых в текущей таблице.

Значения параметров указаны в Приложении .

В текстовом файле сохраняется набор параметров, отображаемых в текущей таблице.

Пример строк файла для торгуемых инструментов:

Код класса,% изменения от закрытия,Bloomberg ID,CFI,CUSIP,ISIN,Базис РЕПО,Допуск к дополнительной сессии,Доступность в утренней сессии
+МосЭнерго [МБ ФР: РПС: А1-Акции и паи],PSEQ,0,00,,,,RU0008958863,,Да,Да


Таблица истории значений параметров

Файл представляет последовательность строк, каждая из которых содержит данные по отдельному финансовому инструменту по состоянию на указанный момент времени, разделенные через запятую без пробелов. При этом последовательность параметров в строке соответствует последовательности параметров, отображаемых в текущей таблице.

Значения параметров указаны в Приложении.

В текстовом файле сохраняется набор параметров, отображаемых в текущей таблице.

Пример строки файла:

 Время,Инструмент,Статус,Состояние сессии,Цена открытия,Дата расчетов,ISIN,RIC,
4:56:11,ЛУКОЙЛ,торгуется,открыта,0.0,15.09.2022,RU0009024277,,
Объем файла может быть очень большим.


Таблица изменений параметров

Формат аналогичен формату сохранения в текстовый файл Таблицы истории значений параметров.


Таблица обезличенных сделок

Вывод в файл осуществляется через пункт меню Действия или из контекстного меню таблицы.

Файл представляет последовательность строк, каждая из которых содержит данные по отдельной сделке, разделенные через запятую без пробелов. Последовательность параметров и их значения приведены в таблице:

№ | Параметр | Примечание | № | Параметр | Примечание
1 | Номер |  | 9 | Объем |
2 | Время | Формат определяется настройками операционной системы | 10 | Доходность |
3 | Инструмент |  | 11 | Сумма РЕПО |
4 | Класс | Пусто, если выбран только один класс | 12 | Срок РЕПО |
5 | Код инструмента |  | 13 | Объем выкупа РЕПО |
6 | Цена |  | 14 | Ставка РЕПО (%) |
7 | НКД |  | 15 | Код расчетов |
8 | Количество |  | 16 | Операция | «B» - купля, «S» - продажа

Пример строки файла:

218640697,10:47:52,ИркЭнерго,А1-Акции ММВБ,IRGZ,16.400,0.00,500,820000.00,,,0,,0.000,T0,B
218646023,10:58:50,РусГидро,РЕПО:Акции ММВБ,HYDR,1.6880,0.00,10000,1688000.00,,1688000.00,7,600.00,0.000,R07,S


Новости

Файл представляет собой последовательность блоков строк, разделенных пустой строкой.

Образец сообщения:

DD.MM.YY HH:MM:SS (Агентство)
<Заголовок>
<Текст новости>

Значение полей сообщения:

Поле | Значение
DD.MM.YY | дата, где «DD» - день, «MM» – месяц, «YY» – год
Агентство | название агентства
<Заголовок> | заголовок сообщения
<Текст новости> | текст новости

В файле сохраняются только тексты новостей, просмотренные пользователем. Остальные новости сохраняются в виде заголовков.


Окно сообщений Трейдера

Сообщения сохраняются в файл стандартными блоками строк (см. образец сообщения), разделенными пустой строкой.

Образец сообщения:

Сообщение NNNN ===============
Отправлено ДД.MM.ГГ в ЧЧ:MM:СС
Отправитель: Организация1, Пользователь1
Получено ДД.MM.ГГ в ЧЧ:MM:СС
Получатель: Организация1, Пользователь2
Текст сообщения: <сообщение>
Статус: <статус>
===============

Значение полей сообщения:

Поле | Значение
NNNN | Идентификатор сообщения
ДД.MM.ГГ | Дата, где «ДД» – день, «MM» – месяц, «ГГ» – год
ЧЧ:MM:СС | Время, где «ЧЧ» – час, «MM» – минуты, «СС» – секунды
Организация1 | Наименование организации отправителя
Пользователь1 | Имя отправителя
Организация2 | Наименование организации получателя
Пользователь2 | Имя получателя
<сообщение> | Текст сообщения
<статус> | Состояние сообщения, указанное в таблице


Таблица заявок

Функция сохранения в файл вызывается из контекстного меню или пункта меню программы Действия и доступна в двух вариантах:

  • «Сохранить в файл заявки из таблицы» – записать в файл только те заявки, которые отображены в таблице.
  • «Сохранить в файл все заявки» – записать в файл все имеющиеся заявки, без учета настроек таблицы.

Файл представляет собой последовательность строк, каждая из которых содержит параметры отдельной заявки, разделенные запятыми без пробелов. Формат файла аналогичен файлам, сохраняемым на Рабочем месте Московской Биржи.

Номер | Параметр | Примечание
1 | Номер
2 | Время | Формат определяется настройками операционной системы
3 | Инструмент сокр.
4 | Класс
5 | Код инструмента
6 | Операция | «B» - купля, «S» - продажа
7 | Счет
8 Тип заявки
  • 1-й символ (тип заявки): «M» - рыночная, «L» - лимитированная;
  • 2-й символ (условие разбиения): «O» - все сделки по одной цене, «S» - по разным ценам;
  • 3-й символ (условие исполнения): «W» - снять остаток, «N» - немедленно или отклонить, <пробел>-поставить в очередь;
  • 4-й символ (значение в поле «Цена»): «P» - Цена, «Y» - Доходность, «W» - Средневзвешенная цена
9 | Состояние | «O» - активная, «M» - удовлетворенная, «W» - удаленная, «U» - ожидающая подтверждения, «A» - измененная
10 | Цена
11 | НКД
12 | Количество
13 | Скрытое количество
14 | Остаток
15 | Объем
16 | Доходность
17 | Трейдер
18 | Дилер
19 | Срок | Дата в формате <ГГГГММДД>
20 | Комментарий | Примечание в формате <клиент (5)>/<поручение (14)>
21 | Код расчетов
22 | Код клиента
23 | Снята (время) | Формат определяется настройками операционной системы
24 | < пусто >

Пример строк файла:

 59348,15:34:02,РусГидро,TQBR,HYDR,S,NL0080000043,LSP,M,1.700,0.00,137,,,232900.00,0.00,NC00800000000,
NC00800000000,,2608/,,2608,,

4142841,11:22:06,ES0018000O6,Опционы FORTS,ES18000O6,B,SPBFUT00050,LONP,M,529,0.00,1,,,529.00,0.00,,SPBFUT000000,,,,SPBFUT00050,,


Таблица стоп-заявок

Функция сохранения в файл вызывается из контекстного меню или пункта меню программы Действия и доступна в двух вариантах:

  • «Сохранить в файл стоп-заявки из таблицы» – записать в файл только те стоп-заявки, которые отображены в таблице.
  • «Сохранить в файл все стоп-заявки» – записать в файл все имеющиеся стоп-заявки, без учета настроек таблицы.

Файл представляет собой последовательность строк, каждая из которых содержит параметры отдельной заявки, разделенные запятыми без пробелов.

№ Параметр Примечание
1 | Номер
2 | Время | Формат определяется настройками операционной системы
3 | Дата | Дата в формате «ДД.MM.ГГ», где «ДД» - день, «MM» - месяц, «ГГ» - год
4 Тип стоп заявки

Возможные значения:

  • «S» – стоп-лимит;
  • «O» – с условием по другому инструменту;
  • «L» – со связанной заявкой;
  • «T» – тейк-профит;
  • «SI» – стоп-лимит, выставляемый по исполнению активной заявки;
  • «TI» – тейк-профит, выставляемый по исполнению активной заявки;
  • «ST» – тейк-профит и стоп-лимит;
  • «STI» – тейк-профит и стоп-лимит, выставляемый по исполнению активной заявки
5 | Инструмент сокр.
6 | Класс
7 | Код инструмента
8 | Инструмент стоп-цены
9 | Класс стоп-цены
10 | Код инструмента стоп-цены
11 | Операция | «B» - купля, «S» - продажа
12 | Счет
13 Частичное исполнение учитывается

«F» если «Да», иначе пусто

14 | Брать исполненный объем в качестве количества выставляемой стоп-заявки | «P» если «Да», иначе пусто
15 | При частичном исполнении связанной заявки снять стоп-заявку | «K» если «Да», иначе пусто
16 | Состояние | «O» – активная, «M» – удовлетворенная, «W» – удаленная
17 | Цена
18 | Направление стоп-цены | «>=» или «<=»
19 | Цена условия
20 | Количество
21 | Код клиента
22 | Дилер
23 | Срок | «GTC» - до отмены, «TODAY» - сегодня, или срок в формате «ДД.ММ.ГГ»
24 | Комментарий | Примечание в формате <клиент (5)>/<поручение (14)>
25 | Номер заявки
26 | Связ. заявка
27 | Цена связ. заявки
28 | Сделка условия
29 | Отступ
30 | Защитный спред
31 | Время снятия стоп-заявки | Формат определяется настройками операционной системы
32 | Направление стоп-лимит цены | «>=» или «<=»
33 | Стоп-лимит цена
34 | Тейк-профит по рыночной | «TM» - рыночная заявка, «TL» - лимитированная
35 | Стоп-лимит по рыночной | «LM» - рыночная заявка, «LL» - лимитированная
36 | Время действия
37 | Активна с | Формат определяется настройками операционной системы
38 | Активна по | Формат определяется настройками операционной системы

Пример строки файла:

 101909,12:57:23,16.12.2009,ST,Татнфт3ап,А1-Акции,RU14TATN3014,Татнфт3ап,А1-Акции,RU14TATN3014,B,L01-00000F00,,,,O,88.00,<=,85.00,1,110,NC0038900000,TODAY,110//prim,,,,,5.00,0.00,,>=,90.00,TM,LM,AIT,10:30:00,18:00:00


Таблица сделок

Функция сохранения в файл вызывается из контекстного меню или пункта меню программы Действия и доступна в двух вариантах:

  • «Сохранить в файл сделки из таблицы» – записать в файл только те сделки, которые отображены в таблице.
  • «Сохранить в файл все сделки» – записать в файл все имеющиеся сделки, без учета настроек таблицы.

Файл представляет последовательность строк, каждая из которых содержит параметры по отдельной сделке. В качестве разделителя параметров в строке по умолчанию используется символ «,» (запятая). Символ разделителя можно изменить в настройках программы, выбрав пункт меню Система/Настройки/Основные настройки..., раздел «Программа» / «Экспорт данных» подраздел «Экспорт в текстовые файлы», параметр «Использовать в качестве разделителя значений символ».

№ Параметр Примечание № Параметр Примечание
1 | Номер | 22 | Комиссия ТС
2 | Заявка | 23 | Ставка РЕПО (%)
3 | Время | Формат определяется настройками операционной системы | 24 | НКД на дату выкупа
4 Операция
  • «B» – купля;
  • «S» – продажа
 25 Сумма РЕПО
5 | Комментарий | примечание в формате <клиент (5)>/ <поручение (14)> | 26 | Объем выкупа РЕПО
6 | Трейдер | 27 | Срок РЕПО (%)
7 | Партнер | 28 | Начальный дисконт(%)
8 | Счет | 29 | Нижний дисконт(%)
9 | Код класса | 30 | Верхний дисконт(%)
10 Код инструмента 31 Блокировка обеспечения
  • «Y» – да;
  • «N» – нет
11 | Цена | 32 | Клиринговая комиссия
12 | Кол-во | 33 | ФБ комиссия
13 | Объем | 34 | ТЦ комиссия
14 | Дата расчетов | Дата в формате <ДД.ММ.ГГГГ> | 35 | Код клиента
15 | НКД | 36 | Идентификатор счета
16 | Доходность | 37 | Исходный номер
17 Период
  • «O» – открытие;
  • «C» – закрытие;
  • «N» – нормальный
 38 Айсберг-заявка
  • «Y» – да;
  • «» – нет
18 | Цена выкупа | 39 | Валюта расчетов
19 | Код расчетов | 40 | Организация партнера
20 Тип сделки
  • «T» – обычная;
  • «Р» – первичное размещение;
  • «N» – адресная;
  • «F» – перевод денег/инструментов;
  • «R» – адресная РЕПО;
  • «G» – витринная РЕПО с ЦК;
  • «H» – РЕПО 1 часть;
  • «h» – РЕПО 2 часть;
  • «N» – РПС с ЦК
 41 Дата торгов Дата в формате <ДД.ММ.ГГГГ>
21 | Дилер

Примеры строк файла:

10780,40570,05:00:08,S,//842,NC0038900000,NC0038900000,L01-00000F00,BPSEQ,LKOH,1800.00,2,3600.00, 13.11.2013,,,N,0.00,B05,T,,,0.00,0.00,,3600.00,,5,,,,N,0.00,0.00,0.00,,,,,N,SUR,,,13.11.2013,
10780,40571,05:00:08,B,Q10//842,NC0038900000,NC0038900000,L01-00000F00,BPSEQ,LKOH,1800.00,2,3600.00, 13.11.2013,,,N,0.00,B05,T,,,0.00,0.00,,3600.00,,5,,,,N,0.00,0.00,0.00,Q10,,,,N,SUR,,,13.11.2013,
10781,40779,05:23:37,S,//911,NC0038900000,NC0038900000,L01-00000F00,BPSEQ,LKOH,50.00,1,50.00,13.11.2013,,, N,0.00,T0,T,,,0.00,0.00,,50.00,,0,,,,N,0.00,0.00,0.00,,,,,N,EUR,,,13.11.2013,


Позиции участника по деньгам

Функция сохранения в файл вызывается из контекстного меню или пункта меню Действия и доступна в двух вариантах:

  • «Сохранить в файл денежные позиции из таблицы» – записать в файл только те позиции, которые отображены в таблице.
  • «Сохранить в файл все денежные позиции» – записать в файл все имеющиеся позиции без учета настроек таблицы.

Файл представляет собой последовательность строк, каждая из которых содержит параметры отдельной позиции, разделенные запятыми без пробелов.

№ | Параметр | Примечание | № | Параметр | Примечание
1 | Код позиции |  | 6 | Плановый |
2 | Валюта |  | 7 | На покупку (в заявках) |
3 | Описание |  | 8 | На продажу (в заявках) |
4 | Входящий |  | 9 | Нетто |
5 | Текущий |  |  |  |


Таблица заявок на внебиржевые сделки

Функция сохранения в файл вызывается из контекстного меню или пункта меню Действия и доступна в двух вариантах:

  • «Сохранить в файл заявки на внебиржевые сделки из таблицы» – записать в файл только те заявки, которые отображены в таблице.
  • «Сохранить в файл все заявки на внебиржевые сделки» – записать в файл все имеющиеся заявки, без учета настроек таблицы.

Файл представляет собой последовательность строк, каждая из которых содержит параметры отдельной заявки, разделенные запятыми без пробелов.

№ Параметр Примечание № Параметр Примечание
1 | Номер | 17 | Партнер
2 | Время | Формат определяется настройками операционной системы | 18 | Трейдер
3 | Инструмент | 19 | Дилер
4 | Класс | 20 | Ставка РЕПО
5 | Код инструмента | 21 | Цена выкупа
6 Операция
  • «B» - покупка;
  • «S» – продажа
 22 Ставка возмещения
7 | Счет | 23
8 Состояние
  • «O» - активна;
  • «W» - снята;
  • «M» - исполнена
 24 Код клиента
9 | Цена | 25 | Снята(время) | Формат определяется настройками операционной системы
10 | НКД | 26 | Остаток
11 | Количество | 27 | Сумма РЕПО
12 | Объем | 28 | Срок РЕПО
13 | Доходность | 29 | Объем выкупа РЕПО
14 | Ссылка | 30 | Начальный дисконт(%)
15 | Примечание | Примечание в формате <клиент (5)>/<поручение (14)> | 31 | Нижний дисконт(%)
16 | Код расчетов | 32 | Верхний дисконт(%)
33 Блокировка обеспечения
  • «Y» – да;
  • «N» – нет

Пример строки файла:

473941922,15:23:05,ЛУКОЙЛ,РЕПО-М: Акции,LKOH,S,S01-00000F00,O,3000.0000,,10,30000.00,,
6,,Rb,NC0080100000, NU0080100009,NC0080100000,,3000.0000,,,,,10,30000.00,,30000.00,,,,N


Таблица безадресных заявок на внебиржевые сделки

Функция сохранения в файл вызывается из контекстного меню или пункта меню Действия и доступна в двух вариантах:

  • «Сохранить в файл безадресные заявки на внебиржевые сделки из таблицы» – записать в файл только те заявки, которые отображены в таблице.
  • «Сохранить в файл все безадресные заявки на внебиржевые сделки» – записать в файл все имеющиеся заявки, без учета настроек таблицы.

Файл представляет собой последовательность строк, каждая из которых содержит параметры отдельной заявки, разделенные запятыми без пробелов.

№ Параметр Примечание № Параметр Примечание
1 Номер 7 Состояние
  • «O» - активна;
  • «W» - снята;
  • «M» - исполнена
2 Время Формат определяется настройками операционной системы
 8 Цена
3 | Инструмент | 9 | Количество
4 | Класс | 10 | Код расчётов
5 | Код инструмента | 11 | Дилер
6 Операция
  • «B» - покупка;
  • «S» – продажа

Пример строки файла:

15879,11:09:35,РАО ЕЭС,РПС:А1-Акции,RU0008926621,B,O,5.000,10000,T0,NC0038900000


Сделки для исполнения

Функция сохранения в файл вызывается из контекстного меню или пункта меню Действия и доступна в двух вариантах:

  • «Сохранить в файл сделки для исполнения РПС из таблицы» – записать в файл только те сделки, которые отображены в таблице.
  • «Сохранить в файл все сделки для исполнения РПС» – записать в файл все имеющиеся сделки, без учета настроек таблицы.

Файл представляет собой последовательность строк, каждая из которых содержит параметры отдельной заявки, разделенные запятыми без пробелов.

№ Параметр Примечание № Параметр Примечание
1 | Номер | 23 | НКД
2 | Дата торгов | В формате «ДД.ММ.ГГ» | 24 | Дилер
3 | Дата исполнения | В формате «ДД.ММ.ГГ» | 25 | Код клиента
4 | Инструмент | 26 | Время исполнения | Формат определяется настройками операционной системы
5 | Класс | 27 | Сумма РЕПО
6 | Код инструмента | 28 | Срок РЕПО
7 Операция

Для сделок:

  • «B» - покупка;
  • «S» - продажа.

Для взносов:
  • «B» - зачисление;
  • «S» - списание

 29 Сумма возврата РЕПО
8 | Счет | 30 | Объем выкупа РЕПО
9 Состояние

  • «M» - исполненная;
  • «U» - ожидает подтверждения, т.е. ввода отчета;
  • «P» – ожидает ввода встречного отчета;
  • «G» - ожидает внесения компенсационного взноса

 31 Дисконт(%)
10 | Цена | 32 | Нижний дисконт(%)
11 | Количество | 33 | Верхний дисконт (%)
12 Объем 34 Тип сделки
  • «T» - обычная;
  • «N» - адресная РПС;
  • «R» - 1-ая часть РЕПО;
  • «r» - 2-ая часть РЕПО;
  • «D» - компенсационный взнос
13 Код расчетов 35 Исполнить
  • «Y» - исполнить сегодня;
  • «N» - нет
14 | Партнер | 36 | Остаток
15 | Счет партнера | 37 | Сумма обязательства
16 Отчет 38 Исполнить завтра
  • «Y» - исполнить завтра;
  • «N» - нет
17 | Отчет партнера | 39 | Номер заявки
18 Номер сделки 1ой части РЕПО 40 Тип клиринга
  • « » - не установлен;
  • «M» - многосторонний;
  • «S» - простой
19 Цена 1ой части РЕПО 41 Состояние расчетов
  • «U» - не рассчитана;
  • «P» - в расчетах;
  • «S» - не рассчитана
20 | Ставка РЕПО(%) | 42 | Комиссия
21 | Цена выкупа | 43 | Комиссия за отчет
22 | Комментарий | Примечание в формате <клиент (5)>/<поручение (14)> | 44 | Время расчетов | Формат определяется настройками операционной системы

Пример строки файла:

251739276,25.09.2009,25.09.2009,ЛУКОЙЛ,РЕПО-М: Акции,LKOH,B,L01-00000F00,U,2080.0000,10,20800.00,S0, NC0038900000,S01-00000F00,,,251739276,2080.0000,10.0000,2080.5699,Q7//,,NC0038900000,Q7,,20800.00,10, 20805.70,20805.70,16.8000,,,R,Y,10,20800.00,N,0, ,U,0.00,0.00,
251764622,29.09.2009,29.09.2009,АгорРосIPO,РПС: А2-Акции,RU000A0JPHE0,B,L01-00000F00,U,1300.00,1,1300.00, B0,NC0038900000,L01-00000F00,,,,,,,E3/,,NC0038900000,E3,,,,,,,,,N,,1,,,0, ,,0.00,0.00,


Таблица заявок-отчетов на сделки РПС

Функция сохранения в файл вызывается из контекстного меню или пункта меню Действия и доступна в двух вариантах:

  • «Сохранить в файл отчеты на сделки для исполнения РПС из таблицы» – записать в файл только те отчеты, которые отображены в таблице.
  • «Сохранить в файл все отчеты на сделки для исполнения РПС» – записать в файл все имеющиеся отчеты, без учета настроек таблицы.

Файл представляет собой последовательность строк, каждая из которых содержит параметры отдельной заявки, разделенные запятыми без пробелов.

№ Параметр Примечание № Параметр Примечание
1 Номер 9 Состояние
  • «O» – ждет исполнения;
  • «W» - снят;
  • «M» – исполнен
2 | Дата | В формате «ДД.ММ.ГГ» | 10 | Объем
3 | Время | Формат определяется настройками операционной системы | 11 | Количество
4 | Инструмент | 12 | Трейдер
5 | Класс | 13 | Партнер
6 | Код инструмента | 14 | Дилер
7 | Счет | 15 | <пусто>
8 | Счет партнера | 16 | Снят (время) | Формат определяется настройками операционной системы

Пример строки файла:

200260234,21.02.2006,10:23:55,Ростел-ао,,RTKM,L01-00000F00,S01-00000F00,M,-6156840.00,100000,
MU0080000100,Дилер1,Дилер2,,


Таблица участников торгов

Функция сохранения в файл вызывается из контекстного меню или пункта меню Действия и доступна в двух вариантах:

  • «Сохранить в файл информацию об участниках торгов из таблицы» – записать в файл только те строки, которые отображены в таблице.
  • «Сохранить в файл всю информацию об участниках торгов» – записать в файл все имеющиеся строки, без учета настроек таблицы.

Файл представляет собой последовательность строк, каждая из которых содержит данные по отдельному участнику, разделенные запятыми без пробелов.

№ | Параметр | Примечание | № | Параметр | Примечание
1 | Идентификатор участника | 12 символов | 4 | Статус |
2 | Название участника |  | 5 | Запрет необеспеченных торгов |
3 | Биржа |

Пример строки файла:

MC0042600000,Открытие,MICX,Активная


Глоссарий

А Б В Г Д Е З И К Л М Н О П Р С Т У Ф Ш Э Я D I O Q

А

Актив – совокупность имущественных прав: материальных ценностей, денежных средств, долговых требований и др., принадлежащих физическому или юридическому лицу и имеющих коммерческую ценность. Примеры активов: рубли РФ, акции обыкновенные НК ЛУКойл и др.

Б

Базовый актив – ценные бумаги, товары, фондовые индексы или фьючерсы, стоимость которых является базой для расчета при исполнении срочного договора.

В

Вариационная маржа – денежное выражение изменения обязательств участника биржевых торгов, учитывающее изменение котировки срочного контракта.

Волатильность – мера изменчивости цены определенного финансового инструмента за выбранный промежуток времени.

Г

Гарантийное обеспечение – сумма денежных средств, требуемая для обеспечения открытых позиций на срочном рынке.

Д

Двухфакторная авторизация – аутентификация пользователя на сервере QUIK предполагающая два этапа:

  1. Ввод логина и пароля к серверу QUIK.
  2. Ввод дополнительной кодовой фразы, переданной пользователю по заранее условленному способу связи от брокера.

Длинная позиция, лонг – покупка актива в расчете на увеличение его стоимости («игра на повышение»).

Доска опционов – это таблица, отображающая в удобной форме спрос и предложение по разным опционным контрактам на один и тот же базовый актив. Подробнее см. п. Таблица «Доска опционов».

Е

Единая денежная позиция на спот- и срочном рынках – учёт на одной денежной позиции клиента как операций с инструментами спот-рынка, так и операций с инструментами срочного рынка.

З

Заявка – согласие купить/продать инструменты на указанных в поручениях условиях. Заявки на торги по условиям своего выполнения могут быть адресными и безадресными.

  • Адресная заявка выражает намерение заключить сделку с определенным партнёром.
  • Безадресная заявка выражает согласие заключить сделку, адресованное всем участникам торгов.

Подробнее см. п. Операции в Режиме переговорных сделок.

Заявка «по исполнению» представляет собой условную заявку, условием активации (начала проверки стоп-цены сервером QUIK) которой является исполнение определенной активной заявки, называемой «заявкой-условием». Подробнее см. п. Заявка с условием «по исполнению».

И

Инструмент – предмет сделок купли/продажи, заключаемых в период торгов в определенной торговой секции биржи, который определяется совокупностью стандартных условий, предусмотренных регламентом биржи. Пример инструмента: акции обыкновенные НК ЛУКойл (А1-Акции ММВБ).

К

Карман транзакций – таблица, позволяющая формировать список отложенных заявок и отправлять эти заявки в торговую систему выборочно или одновременно. Таблица «Карман транзакций» представляет собой хранилище сформированных, но не отправленных на сервер заявок пользователя. Подробнее см. п. Таблица «Карман транзакций».

Класс инструментов – совокупность инструментов, отвечающих одинаковым требованиям к обращению. Классы содержат однородные инструменты (например, облигации) и позволяют совершать с ними сделки на определенных условиях (например, сделки РЕПО). Пример класса инструментов: А1-Облигации ММВБ, РЕПО: РТС.

Клиентский портфель – таблица, которая предназначена для отображения информации по денежной стоимости средств клиента, доступным заемным средствам и показателям маржинального кредитования. Подробнее см. п. Таблица «Клиентский портфель».

Код инструмента – биржевой идентификатор в виде цифро-символьного кода, присвоенный инструменту. Примеры кодов инструментов на ММВБ: «LKOH» для обыкновенных акций НК ЛУКойл, «RU14TATN3006» для 3-го выпуска обыкновенных акций ОАО «Татнефть».

Короткая позиция, шорт – продажа актива с целью последующего выкупа по более низкой цене («продажа без покрытия»).

Л

Линия тренда – индикатор графического анализа, используемый для наблюдения за направленностью изменения цен.

Листинг – процедура оценки надежности ценных бумаг и допуска их к торгам на бирже.

Лонг – см. Длинная позиция.

Лот – стандартная единица размера сделки, выраженная в количестве инструмента. Например, 1 лот = 100 инструментам означает, что в торговой системе совершаются сделки с количеством инструментов кратным 100.

М

Маклерская заявка – специальный вид транзакций, используемый в случае, когда один сервер QUIK используется несколькими участниками торгов для подключения к торговым системам бирж. Маклерская заявка позволяет указать код участника торгов непосредственно при вводе поручений из числа брокеров, использующих данный сервер QUIK. Подробнее см. п. Маклерская заявка.

Маржа – денежная сумма, подлежащая внесению в обеспечение исполнения сделки по каждой открытой позиции, имеющейся у участника рынка.

Маржинальное кредитование – кредитование денежными средствами или инструментами под залог текущей стоимости активов клиента (инструментов и/или денежных средств). Подробнее см. п. Маржинальная торговля.

Маржируемый опцион – опцион, расчеты по которому осуществляется аналогично фьючерсу. При купле/продаже маржируемого опциона списание величины премии со счета покупателя на счет продавца не производится, вместо этого биржа осуществляет резервирование на счете покупателя величины гарантийного обеспечения (ГО). Перечисление премии осуществляется в ходе ежедневного перечисления вариационной маржи по заключённым за день сделкам и имеющимся открытым позициям. Расчет вариационной маржи производится аналогично расчету вариационной маржи по фьючерсам, на основе цен заключенных сделок и расчетных цен опционов.

Н

Неторговое поручение представляет собой поручение брокеру на перемещение средств клиента между счетами – ввод средств в торговую систему, вывод обратно на счет клиента, перевод между разными счетами либо торговыми системами. Подробнее см. п. Неторговые поручения.

О

Объединенная позиция – см. Единая денежная позиция на спот- и срочном рынках.

Опцион – контракт, предоставляющий право на покупку или продажу определённого количества базового актива по определённой цене на установленное время. Опционы бывают следующих видов:

  • CALL-опцион – дает право на приобретение определённого количества базового актива по установленной цене в течение определённого отрезка времени.
  • PUT-опцион – контракт на продажу определённого количества базового актива по определённой цене на определённый срок.

Отложенная заявка – заявка с желаемыми условиями, не отправленная на биржу.

Отчет – представление итогов операций клиента за определенный период в форме, предусмотренной брокером. Подробнее см. п. Отчеты.

П

Плечо – соотношение собственных и заемных средств клиента при маржинальной торговле.

Позиция – количество денежных средств (или инструментов), доступных для совершения торговых операций на фондовом рынке.

«Портфель» – особый тип таблиц, структура которых описана на встроенном языке программирования QPILE и может содержать параметры, рассчитываемые по математическим формулам на основе данных из других таблиц системы QUIK. Подробнее см. п. Таблица «Портфель».

Р

Режим переговорных сделок (РПС ) – режим сделок без предварительного депонирования средств с отложенной датой исполнения, предусматривающий возможность заключения адресных и безадресных сделок. Подробнее см. п. Операции в Режиме переговорных сделок.

РЕПО – см. Сделка РЕПО.

С

Сделка РЕПО или сделка с обратным выкупом – сделка с ценными бумагами, состоящая из двух частей:

  1. По первой части сделки РЕПО в дату ее заключения продавец ценных бумаг обязан поставить ценные бумаги, а покупатель обязан заплатить денежные средства.
  2. В дату исполнения второй части сделки РЕПО покупатель ценных бумаг по первой части сделки РЕПО обязан поставить ценные бумаги, а продавец по первой части сделки РЕПО обязан заплатить денежные средства в соответствии с условиями заключенной сделки РЕПО.

Подробнее см. п. Торговые операции РЕПО.

Спот-актив – актив, торгующийся на бирже в режиме «поставка против платежа».

Спрэд – разница между лучшей ценой покупки и лучшей ценой продажи актива.

Срочный рынок – рынок, на котором заключаются сделки поставки активов по истечении определенного срока на заранее оговоренных условиях. Для этого используются специфические инструменты (инструменты срочного рынка) – стандартизованные контракты (фьючерсные, опционные и др.)

Стоп-заявка – поручение, исполняемое брокером в зависимости от достижения рыночной ценой инструмента определенного уровня. В такой заявке указывается два значения цены:

  • стоп-цена – условие вида «цена последней сделки не более (не менее) заданной величины». При наступлении условия заявка будет активирована, т.е. отправлена на биржу в виде обычной лимитированной заявки.
  • цена, указываемая в заявке при отправке на биржу.

Подробнее см. п. Условные (стоп-) заявки.

Страйк – цена исполнения опциона. Зафиксированная в опционном контракте цена, по которой может быть куплен или продан базовый актив в случае исполнения опциона.

Субадминистрирование – возможность обслуживания клиентов брокера, являющегося клиентом другого брокера (субброкером). Подробнее см. п. Субадминистрирование.

Субброкер – профессиональный участник рынка ценных бумаг, оказывающий брокерское обслуживание клиентов на основе услуг другого брокера, предоставляющего ему технологический доступ к торгам, депозитарное и другое обслуживание.

Счет депо – объединенная общим признаком совокупность записей в регистрах депозитария, предназначенная для учета инструментов.

Т

Тикер – то же, что и код инструмента.

Торговая сессия – период времени, в течение которого осуществляется объявление и обработка заявок, а также совершение сделок с ценными бумагами и финансовыми инструментами.

Торговая система биржи – совокупность программно-технических средств, обеспечивающих проведение торгов на бирже.

Торговый счет – раздел учета в биржевой торговой системе, в котором отображаются средства участника торгов, зарезервированные для совершения сделок на бирже.

Транзакция – поручение клиента брокеру на совершение какой-либо операции. Примеры транзакций: ввод новой заявки, снятие заявки.

У

Уровень маржи – соотношение величины собственных средств и суммы стоимости всех активов клиента, исчисляемое в процентах.

Условная заявка – заранее подготовленная лимитированная заявка, передаваемая в торговую систему биржи при наступлении заданного условия. Подробнее см. п. Условные (стоп-) заявки.

Ф

Фьючерс – обязательство по истечении определенного срока купить либо продать определенный базовый актив по обусловленной цене.

Ш

Шаг цены – минимально возможная разница между ценами, указанными в заявках на покупку/продажу.

Шорт – см. Короткая позиция.

Э

Экспирация – исполнение опциона. В результате экспирации, между подписчиком и держателем опциона фиксируется сделка с базовым активом на оговоренных опционом условиях, а сам опцион считается исполненным.

Я

Язык QPILE (QUIK Programmable Interface and Logic Environment) – представляет собой список команд, интерпретируемых Рабочим местом QUIK. Подробнее см. Алгоритмический язык QPILE.

D

DDE (Dynamic Data Exchange) – механизм передачи обновленной информации между приложениями в операционных системах Microsoft Windows.

I

ISIN-код инструмента (ISIN – International Securities Identification Number) – международный идентификационный код инструмента.

O

ODBC (Open DataBase Connectivity) – стандарт обмена информацией между различными источниками данных, разработанный компанией Microsoft.

Q

QPILE – см. Язык QPILE.


Заказ обезличенных сделок

меню Система / Заказ данных / Поток обезличенных сделок…

Настройка списков инструментов для получения информации по обезличенным сделкам:

  1. «Классы инструментов» – выберите классы инструментов, по которым необходимо осуществлять заказ обезличенных сделок.
  2. Кнопки ниже списка классов предназначены для изменения настроек по всем классам:
    • «Очистить» - отключить все классы,
    • «Выделить все» - выбрать все классы из списка,
    • «Снять фильтры» - удалить все настройки фильтров по классам.
  3. «Текущий класс» – полное наименование выбранного класса, количество доступных и выбранных инструментов в данном классе:
    • «Инструментов доступно» – количество инструментов, доступных для данного класса;
    • «Инструментов выбрано» – количество инструментов, выбранных в «Фильтре инструментов»;

    Внутри каждого класса настраивается:

    • «Фильтр инструментов» – если флажок установлен, то прием данных осуществляется только по выбранным инструментам. Если флажок снят, то прием данных осуществляется по всем инструментам, доступным для данного класса. Классы, по которым установлен фильтр инструментов, выделяются серым цветом.
  4. «Общая информация» – информация по всем доступным классам:
    • «Классов доступно» – количество доступных классов;
    • «Классов выбрано» – количество выбранных классов;
    • «Инструментов доступно» – общее количество доступных инструментов;
    • «Инструментов выбрано» – общее количество выбранных инструментов.
  5. «Получать информацию по обезличенным сделкам с текущего момента» - настройка рассылки обезличенных сделок пользователю. Если флажок установлен, то информация о сделках поступает с сервера QUIK с момента установления связи с сервером. Если флажок снят (по умолчанию), то сделки дозаказываются с учетом последней сделки, имеющейся в Рабочем месте QUIK.
  6. «Получить заново данные по обезличенным сделкам» - при нажатии кнопки удаляется вся доступная информация об обезличенных сделках (очищаются все таблицы и файловое хранилище), и сделки перезаказываются с учетом настройки «Получать информацию по всем обезличенным сделкам с текущего момента».
  7. Сохраните настройки, нажав кнопку «Да».
Комментарии:
  1. Список инструментов, выбранных по умолчанию в диалоге создания Таблицы обезличенных сделок, совпадает со списком инструментов, отмеченных пользователем в диалоге настройки заказа обезличенных сделок. При добавлении в Таблицу обезличенных сделок инструментов, по которым не заказаны обезличенные сделки (т.е. инструменты не были выбраны в диалоге настроек заказа обезличенных сделок), данные инструменты автоматически добавляются в список инструментов для заказа обезличенных сделок.
  2. Если при создании тиковых графиков по Таблице обезличенных сделок или при настройке экспорта тиков в системы тех. анализа на основании Таблицы обезличенных сделок пользователь выбирает инструмент, по которому не заказаны обезличенные сделки, то данный инструмент автоматически добавляется в список инструментов для заказа обезличенных сделок.
  3. При использовании настройки «Получить заново данные по обезличенным сделкам» не предусмотрена автоматическая очистка данных для экспорта обезличенных сделок с использованием ODBC и DDE. Очистка данных производится пользователем вручную. Перезапуск расчета QPILE-портфеля также осуществляется пользователем вручную.

См. также Структура данных.


Адресные заявки

Окно ввода новой адресной заявки может быть вызвано одним из следующих способов:

  1. Общим способом выполнения транзакций - нажатием кнопки [image] на панели инструментов, выбором соответствующего класса (например «РПС Акции 1-го уровня») и операции «Ввод адресной заявки». Эта же операция может быть выполнена горячей клавишей «Ctrl»+«T».
  2. В Таблице заявок на внебиржевые сделки (в таблице должна присутствовать хотя бы одна заявка):
    • Нажатием кнопки [image] на панели инструментов;
    • Выбором пункта контекстного меню «Новая заявка на внебиржевую сделку» или пункта меню программы Действия/Новая заявка на внебиржевую сделку;
    • Двойным щелчком левой кнопки мыши на строке с заявкой;
    • Нажатием клавиши «F2».
  3. В таблице «РПС котировки» по выбранному инструменту:
    • Нажатием кнопки [image] на панели инструментов;
    • Выбором пункта контекстного меню «Новая заявка» или пункта меню программы Действия/Новая заявка;
    • Двойным щелчком левой кнопки мыши на строке с котировкой;
    • Нажатием клавиши «F2».

См. также:

  • Операции в Режиме переговорных сделок ММВБ
  • Ввод адресной заявки (полная форма ввода)
  • Ввод адресной заявки (упрощенная форма ввода)
  • Настройки программы, относящиеся к адресным заявкам
  • Отмена адресной заявки


Ввод адресной заявки (упрощенная форма ввода)

  1. «Инструмент» – выберите название инструмента из списка инструментов данного класса.
  2. «Торговый счет» – выберите из списка номер торгового счета, в отношении которого делается поручение.
  3. «Операция» – направление операции: «Покупка» или «Продажа».
  4. «Цена» - цена заявки, за единицу финансового инструмента.
  5. «Количество» - количество инструментов, выраженное в лотах.
  6. «Клиент» - идентификатор клиента в системе QUIK.
  7. «Поручение» – текстовый комментарий к заявке.
  8. «Расчеты» – укажите вручную либо выберите из списка код расчетов по сделке (значения: «T0», от «B0» до «B30», «Z0»; для валютного рынка: «T0», «T1», «F1W», «F2W», «F1M», «F2M», «F3M», «F6M», «F1D-F180D»). Если поле не заполнено, принимается значение по умолчанию: «T0».
  9. «Партнер» – выберите из списка либо укажите вручную краткое наименование контрагента по сделке.
  10. «Возмещение» – денежные средства, перечисляемые одним из контрагентов по сделке другому, в случае просрочки исполнения своих обязательств по сделке. Задается в процентах от суммы сделки. Обязательный параметр операций РЕПО.

Звездочкой ( *) отмечены обязательные поля.
Поля «Количество», «Код клиента», «Ссылка», «Поручение» могут быть заполнены автоматически. Подробнее см. Настройка автозаполнения полей ввода заявки.

Нажатием кнопки «Ввести» заявка отправляется в торговую систему. Нажатие кнопки «Отмена» закрывает окно без отправления заявки.

Заявка, принятая торговой системой, отображается в Таблице заявок на внебиржевые сделки.

См. также:

  • Операции в Режиме переговорных сделок ММВБ
  • Адресные заявки
  • Настройки программы, относящиеся к адресным заявкам


Настройки программы, относящиеся к адресным заявкам

Настройки устанавливаются через пункт меню программы Система/Настройки/Основные настройки..., раздел «Торговля» / «Заявки» / «Внебиржевые заявки»:

  • «Подставлять текущую цену в заявку РЕПО» – если флажок установлен, то в поле «Цена» автоматически подставляется цена последней сделки на этот инструмент с соответствующего обычного класса.
  • «Проверять цены на min-max для РПС, РЕПО» - проверять соответствие цены заявки РЕПО или РПС диапазонам допустимых значений «Мин.цена» и «Макс.цена» из Таблицы текущих торгов, установленных на основном классе инструментов. Например, для класса «РПС А1-Акции» основным классом является класс «А1-Акции». Если при этом какая-либо из цен диапазона нулевая, то ограничение с данной стороны не проверяется.
Функция «Автозаполнение» позволяет при формировании новой адресной заявки задавать соответствия между параметрами «Код клиента/Поручение» и «Класс/Инструмент / Операция». В результате, при выборе в форме ввода адресной заявки определенного инструмента и операции, в полях «Код клиента» и «Поручение» подставляются определенные значения.

См. также:

  • Операции в Режиме переговорных сделок ММВБ
  • Адресные заявки
  • Ввод адресной заявки (полная форма ввода)
  • Ввод адресной заявки (упрощенная форма ввода)


Отмена адресной заявки

Неисполненные отправленные адресные заявки со статусом «Активна» доступны для снятия. Полученные адресные заявки недоступны для отмены.

Снятие адресной заявки может быть осуществлено одним из следующих способов:

  1. В Таблице заявок на внебиржевые сделки (снимаемая заявка должна быть выбрана):
    • Выбором пункта контекстного меню «Снять заявку на внебиржевую сделку»;
    • Двойным щелчком правой кнопки мыши на строке с заявкой;
    • Нажатием кнопки [image] на панели инструментов;
    • Нажатием клавиш «Ctrl»+«D».
  2. Общим способом выполнения транзакций - нажатием кнопки [image] на панели инструментов, выбором соответствующего класса (например «РПС: А1-Акции») и операции «Отмена адресных заявок». Эта же операция может быть выполнена горячей клавишей «Ctrl»+«T». В открывшемся окне укажите номер снимаемой заявки и код пользователя (необязательно).

См. также Адресные заявки.


Безадресные заявки

Окно ввода новой безадресной заявки может быть вызвано одним из следующих способов:

  1. В Таблице безадресных заявок на внебиржевые сделки (в таблице должна присутствовать хотя бы одна заявка):
    • Выбором пункта контекстного меню «Новая безадресная внебиржевая заявка» или пункта меню программы Действия/Новая безадресная внебиржевая заявка;
    • Двойным щелчком левой кнопки мыши на строке с заявкой;
    • Нажатием кнопки [image] на панели инструментов;
    • Нажатием клавиши «F2».
  2. Общим способом выполнения транзакций - нажатием кнопки [image] на панели инструментов, выбором соответствующего класса (например «РПС Акции 1-го уровня») и операции «Ввод безадресной заявки». Эта же операция может быть выполнена горячей клавишей «Ctrl»+«T».

См. также:

  • Операции в Режиме переговорных сделок ММВБ
  • Ввод безадресной заявки
  • Отмена безадресной заявки


Ввод безадресной заявки

  1. «К/П» – направление операции: «Купля» либо «Продажа».
  2. «Инструмент» - выберите название инструмента из списка ценных бумаг данного класса.
  3. «Цена» - цена заявки, за единицу финансового инструмента.
  4. «Лоты» - количество инструментов, выраженное в лотах.
  5. «Код расчетов» - укажите вручную либо выберите из списка код расчетов по сделке (значения: «T0», от «B0» до «B31»).
  6. «Снять активные заявки» – если флажок установлен, то ранее введенная безадресная заявка по этому инструменту отменяется, а вводимая заявка будет единственной.

Нажатием кнопки «Выполнить» заявка отправляется в торговую систему. Нажатие кнопки «Отмена» закрывает окно без отправления заявки.

Заявка, принятая торговой системой отображается в Таблице безадресных заявок на внебиржевые сделки и таблице «РПС котировки». Параметры лучших заявок по каждому инструменту отображаются в Таблице текущих торгов.

См. также:

  • Операции в Режиме переговорных сделок ММВБ
  • Безадресные заявки


Отмена безадресной заявки

Неисполненные заявки со статусом «Активна» доступны для снятия.

Снятие безадресной заявки может быть осуществлено одним из следующих способов:

  1. В Таблице безадресных заявок на внебиржевые сделки (снимаемая заявка должна быть выбрана):
    • Выбором пункта контекстного меню «Снять безадресную заявку на внебиржевую сделку» или пункта меню программы Действия/Снять безадресную внебиржевую заявку;
    • Двойным щелчком правой кнопкой мыши на строке с заявкой;
    • Нажатием кнопки на панели инструментов;
    • Нажатием клавиш «Ctrl»+«D» на снимаемой заявке.
  2. Общим способом выполнения транзакций - нажатием кнопки на панели инструментов, выбором соответствующего класса (например «РПС Акции 1-го уровня») и операции «Отмена безадресной заявки». Эта же операция может быть выполнена горячей клавишей «Ctrl»+«T».

В открывшемся окне укажите следующие параметры:

Звездочкой (*) отмечены обязательные поля.

  1. «Заявка»* - номер заявки для снятия.
  2. «К/П» – направление операции: «Купля» или «Продажа».
  3. «Инструмент»* – выберите название инструмента из списка ценных бумаг данного класса.
  4. «Код расчетов» - укажите вручную либо выберите из списка код расчетов по сделке (значения: «T0», от «B0» до «B31»).
  5. «Трейдер» – идентификатор трейдера, подавшего заявку.
  6. «Фирма» – идентификатор фирмы-участника торгов, от имени которой подана заявка.

См. также:

  • Безадресные заявки
  • Ввод безадресной заявки


Ввод расчетной заявки-отчета на исполнение сделок РПС

Окно ввода новой расчетной заявки-отчета может быть вызвано одним из следующих способов:

  1. В Таблице сделок для исполнения (в таблице должна присутствовать хотя бы одна заявка):
    Выбором пункта контекстного меню «Подтвердить отчетом»;
    • Двойным щелчком левой кнопки мыши на строке с заявкой;
    • Нажатием кнопки [image] на панели инструментов;
    • Нажатием клавиши «F2».
  2. Общим способом выполнения транзакций - нажатием кнопки [image] на панели инструментов, выбором соответствующего класса (например «РПС: А1-Акции») и операции «Ввод расчетной заявки-отчета (макс. 4 сделки)». Эта же операция может быть выполнена горячей клавишей «Ctrl»+«T».

Фильтры:

  1. «Класс» - выбор класса бумаг из списка.
  2. «Инструмент» - выбор инструмента в данном классе.
  3. «Клиент» – код клиента.
  4. «Партнер» - код участника торгов, являющегося контрагентом по сделке.
  5. «Счет депо» - код счета депо.
  6. «Счет депо партнера» - код счета депо партнера.
  7. «№ отчета партнера» – номер отчета партнера по сделке.
  8. «Только сделки с исполнением сегодня» - фильтр по сделкам с наступившим сроком исполнения.

Настройки фильтров формы ввода расчетной заявки-отчета сохраняются в файл конфигурации (*.wnd).

Если в таблице «Сделки для исполнения» выделена строка со сделкой и из контекстного меню таблицы открыта форма «Ввод расчетной заявки-отчета», то поля формы: «Класс», «Инструмент», «Клиент», «Партнер», «Счет депо», «Счет депо партнера», «№ отчета партнера» заполняются значениями, указанными в этой сделке.

Для подтверждения сделок выберите их, отметив «галочкой» в первой колонке. Нажатие кнопки «Выделить все» позволяет отметить все заявки в списке. Нажатием кнопки «Снять выделение» снимаются отметки со всех заявок.

Справочные поля:

  1. «Количество сделок» отображает количество сделок, включенных в отчет.
  2. «Нетто количество» – сальдо изменения позиции по бумагам в результате исполнения выбранных сделок.
  3. «Нетто сумма» – сальдо изменения позиции по деньгам в результате исполнения выбранных сделок.

    Если количество выбранных в таблице сделок превышает максимальное количество сделок, доступное для подтверждения в одной транзакции (4 сделки), то значения в полях «Нетто количество» и «Нетто сумма» очищаются, и в левой нижней части формы выводится предупреждение «Нетто-параметры не могут быть посчитаны».

  4. «Подтверждать срочным отчетом» – признак исполнения в режиме расчетов по правилам простого клиринга.

Нажатием кнопки «Отправить» заявка-отчет отсылается в торговую систему. Нажатие кнопки «Выход» закрывает окно без отправления заявки.

Заявка-отчет, принятая торговой системой отображается в Таблице заявок-отчетов на сделки РПС. Соответствующая ей сделка в Таблице сделок для исполнения изменит статус с «Ждет исполнения» на «Включен в отчет». После того, как партнер по сделке подтвердит ее со своей стороны, статус изменится на «Исполнен» и сделка будет завершена.

См. также:

  • Операции в Режиме переговорных сделок ММВБ
  • Расчетные заявки-отчеты об исполнении сделок РПС
  • Отмена заявки-отчета на исполнение сделок РПС


Отмена заявки-отчета на исполнение сделок РПС

Неисполненные отправленные заявки-отчеты со статусом «Активна» доступны для снятия. Полученные заявки-отчеты для отмены недоступны.

Снятие заявки-отчета может быть произведено одним из следующих способов:

  1. В Таблице заявок-отчетов на сделки РПС (снимаемая заявка должна быть выбрана):
    • Выбором пункта контекстного меню «Снять отчет»;
    • Двойным щелчком правой кнопки мыши на строке с заявкой;
    • Нажатием кнопки [image] на панели инструментов;
    • Нажатием клавиш «Ctrl»+«D» на снимаемой заявке.
  2. Общим способом выполнения транзакций - нажатием кнопки [image] на панели инструментов, выбором соответствующего класса (например «РПС Акции 1-го уровня») и операции «Отмена безадресной заявки». Эта же операция может быть выполнена горячей клавишей «Ctrl»+«T».

В открывшемся окне укажите следующие параметры:

Звездочкой (*) отмечены обязательные поля.
  1. «Отчет»* – Номер отменяемой заявки-отчета.
  2. «Трейдер» – идентификатор трейдера, подавшего заявку.
  3. «Фирма» - идентификатор фирмы-участника торгов, от имени которой подана заявка.
  4. «Инструмент»* – выберите название инструмента из списка ценных бумаг данного класса.

См. также:

  • Операции в Режиме переговорных сделок ММВБ
  • Расчетные заявки-отчеты об исполнении сделок РПС
  • Ввод заявки-отчета на исполнение сделок РПС


Расчетные заявки-отчеты об исполнении сделок РПС

Операция предназначена для ввода в Торговую систему отчетов об исполнении ранее заключенных сделок, содержащихся в таблице «Сделки для исполнения». Сделки, доступные для ввода отчёта, образуют список переговорных сделок, ещё не занятых в расчётах. В отчет включаются сделки из таблицы «Сделки для исполнения», отфильтрованные по наименованию инструмента, режиму, торговому счёту, партнёру и торговому счёту партнёра. В отчёт могут входить от одной до четырех сделок из этого списка.

См. также:

  • Ввод расчетной заявки-отчета на исполнение сделок РПС
  • Отмена заявки-отчета на исполнение сделок РПС
  • Операции в Режиме переговорных сделок ММВБ


Заявки исполнения без подтверждения

Заявка исполнения без подтверждения используется для исполнения сделок одного дилера или между дилерами, когда не происходит уменьшение позиции партнера по деньгам и бумагам. Для исполнения сделки требуется ввод одной заявки исполнения. Сделка совершается в момент подачи этой заявки. При постановке заявок исполнения осуществляется контроль позиций по деньгам и бумагам. Заявка исполнения направляется в адрес только конкретного партнера. В заявке исполнения отражаются нетто-сумма и нетто-количество сделок, включенных в заявку.

Ввод заявки исполнения без подтверждения

Окно ввода новой заявки исполнения без подтверждения может быть вызвано общим способом выполнения транзакций - нажатием кнопки [image] на панели инструментов, выбором соответствующего класса (например «РПС: А1-Акции») и операции «Ввод отчета на исполнение без подтверждения». Эта же операция может быть выполнена горячей клавишей «Ctrl»+«T».

Заполнение полей окна ввода заявки при вводе заявки исполнения без подтверждения общим способом выполнения операций:

Звездочкой (*) отмечены обязательные поля.
  1. «Кол-во сделок»* – Количество заключенных сделок, подтверждаемых в отчете. Значения от 1 до 4.
  2. «Сделка 1»* .. «Сделка 4» – идентификационные номера подтверждаемых сделок.
  3. «Направленность сделки 1»* .. «Направленность сделки 4» – направление операции для соответствующей сделки: Купля или Продажа.

Нажатием кнопки «Выполнить» заявка отправляется в торговую систему. Нажатие кнопки «Отмена» закрывает окно без отправления заявки.

См. также Операции в Режиме переговорных сделок ММВБ